Truy cập, xác định và quản lý các tùy chọn dự án
Altium Essentials: Schematic Electrical Rules Validation
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Các tab General, Error Reporting và Options của hộp thoại Project Options
Tóm tắt
Mỗi dự án hiện có hoặc mới tạo đều có một tập hợp các thiết lập tùy chọn riêng. Các thiết lập này được lưu trong tệp dự án (ví dụ: *.PrjPcb) và sẽ khác nhau tùy theo loại dự án. Các thiết lập tùy chọn được cấu hình trong hộp thoại Project Options.
Truy cập
Có thể truy cập hộp thoại Project Options bằng một trong các cách sau:
- Nhấp chuột phải vào mục dự án trong bảng Projects, sau đó nhấp vào Project Options trên menu ngữ cảnh.
-
Nhấp vào biểu tượng
trong bảng Projects khi dự án mong muốn đang được chọn trong bảng.
- Từ bất kỳ trình biên tập nào, chọn Project » Project Options từ các menu chính.
Các tab của hộp thoại
Chung

Tab General của hộp thoại Project Options
Tab General của hộp thoại Project Options cho phép bạn kiểm soát khả năng truy cập trực tuyến và đồng bộ hóa của một dự án Workspace.
Tùy chọn/Điều khiển
Khi truy cập cho một dự án trong lúc đã ngắt kết nối khỏi Workspace của dự án đó, tùy chọn khả dụng duy nhất là nút Turn Off Synchronization.
Khi truy cập cho một dự án không thuộc Workspace, tab General của hộp thoại Project Options sẽ chỉ hiển thị nút Make Project Available Online. Nhấp vào nút này để mở hộp thoại Đưa lên trực tuyến; sau khi hoàn tất các bước cần thiết, dự án của bạn sẽ được thêm vào Workspace. Khi hoàn tất, tất cả các tùy chọn trong tab hộp thoại sẽ khả dụng.
Chung
- Description - sử dụng trường này để cung cấp mô tả tùy chọn cho dự án. Mô tả này sẽ được hiển thị trong trường mô tả khi duyệt dự án trong giao diện trình duyệt Workspace.
Khả năng truy cập trực tuyến và đồng bộ hóa
-
Version Control - trạng thái đánh dấu của ô này phản ánh chế độ truy cập trực tuyến hiện tại. Bật tùy chọn này để lưu dự án dưới sự quản lý của VCS trong kho lưu trữ thiết kế Git Versioned Storage của Workspace, hoặc tắt tùy chọn để chỉ đồng bộ hóa đơn giản. Việc bật kiểm soát phiên bản đầy đủ cho phép nhiều người dùng cùng làm việc trên dự án, nghĩa là dự án sẽ được chia sẻ với tất cả những người cộng tác khác đang kết nối với Workspace của bạn.
-
Migrate to Altium 365 Versioned Storage - bật tùy chọn này để chuyển một dự án đang sử dụng hệ thống VCS bên ngoài sang VCS gốc của Altium 365 Workspace. Dự án thiết kế sau khi chuyển đổi vẫn giữ lại lịch sử các lần commit VCS trước đó và có thể tận dụng các tính năng hỗ trợ VCS gốc của Workspace, chẳng hạn như dòng thời gian lịch sử dựa trên sự kiện. Tùy chọn này chỉ khả dụng cho một dự án được nhân bản.
-
Server Folder - thư mục Workspace chứa dự án.
-
Enable Conflict Prevention Notifications - bật tùy chọn này để quản lý quyền truy cập chỉnh sửa tệp bằng cách nhận cảnh báo khi một thành viên trong nhóm đang chỉnh sửa cùng tài liệu của một dự án Workspace, nhằm tránh nguy cơ xung đột dữ liệu.
-
Turn Off Synchronization - nhấp vào nút này để tắt đồng bộ hóa, đảm bảo bản sao dự án cục bộ không còn được liên kết với bản trên Workspace. Dự án trên Workspace sẽ không bị thay đổi.
Yêu cầu
-
Link Requirements – nếu Khối của Requirements Portal chưa được liên kết với dự án thiết kế, nhấp vào nút này để mở hộp thoại Link Requirements , nơi bạn có thể chọn khối cần liên kết với dự án.
-
Linked Requirements – nếu Khối của Requirements Portal đã được liên kết với dự án thiết kế, mục này sẽ hiển thị khối được liên kết Nhấp vào liên kết để thay đổi ánh xạ Dự án–Khối hiện tại. Nhấp vào nút Unlink để xóa liên kết.
Tham khảo trang Yêu cầu trong thiết kế để tìm hiểu thêm.
Báo cáo lỗi

Tab Error Reporting của hộp thoại Project Options (đối với dự án PCB)
Tab Error Reporting của hộp thoại Project Options cho phép bạn xác định mức báo cáo cho từng vi phạm có thể xảy ra về điện và cách thể hiện bản vẽ trên các tài liệu sơ đồ nguyên lý nguồn khi kiểm tra tính hợp lệ của dự án. Khi dự án được kiểm tra tính hợp lệ, các thiết lập vi phạm này sẽ được sử dụng kết hợp với các thiết lập trên tab Ma trận kết nối để kiểm tra các vi phạm kết nối trong tài liệu nguồn.
Tùy chọn/Điều khiển
Danh sách vi phạm
Danh sách này trình bày tất cả các vi phạm có thể xảy ra về điện và cách thể hiện bản vẽ trên các tài liệu nguồn của dự án. Các vi phạm được phân thành những nhóm sau:
PCB Design:
Multi-board Design:
Harness Design:
Mỗi loại vi phạm cụ thể được trình bày với các trường sau:
- Violation Type Description - mô tả ngắn gọn về loại vi phạm.
-
Report Mode - sử dụng trường này để chỉ định mức độ nghiêm trọng khi vi phạm quy tắc kiểm tra. Sử dụng danh sách thả xuống để chọn một trong các mức báo cáo sau:
-
Menu chuột phải
Các lệnh sau khả dụng trên menu chuột phải:
- All Off - đặt Report Mode cho tất cả các loại vi phạm thành No Report.
- All Warning - đặt Report Mode cho tất cả các loại vi phạm thành Warning.
- All Error - đặt Report Mode cho tất cả các loại vi phạm thành Error.
- All Fatal - đặt Report Mode cho tất cả các loại vi phạm thành Fatal Error.
- Selected Off - đặt Report Mode cho tất cả các loại vi phạm đã chọn thành No Report.
- Selected To Warning - đặt Report Mode cho tất cả các loại vi phạm đã chọn thành Warning.
- Selected To Error - đặt Report Mode cho tất cả các loại vi phạm đã chọn thành Error.
- Selected To Fatal - đặt Report Mode cho tất cả các loại vi phạm đã chọn thành Fatal Error.
- Default - khôi phục Report Mode cho tất cả các loại vi phạm về cài đặt mặc định.
- Report Suppressed Violations in Messages Panel - bật tùy chọn này để hiển thị các vi phạm trong bảng Messages ngay cả khi chúng đã bị ẩn thông qua tab này.
Tùy chọn bổ sung
- Set To Installation Defaults - nhấp để đưa các tùy chọn của tab về giá trị mặc định khi cài đặt.
Ma trận kết nối

Tab Connection Matrix của hộp thoại Project Options
Tab Connection Matrix của hộp thoại Project Options cung cấp một ma trận cho phép thiết lập các quy tắc kết nối giữa chân linh kiện và các đối tượng định danh net, chẳng hạn như cổng và đầu nối trang sơ đồ. Ma trận này xác định các điều kiện logic hoặc điện cần được báo cáo dưới dạng cảnh báo hoặc lỗi. Ví dụ, một chân đầu ra nối với một chân đầu ra khác thường được xem là điều kiện lỗi, nhưng hai chân thụ động nối với nhau thì không. Khi dự án được kiểm tra tính hợp lệ, các cài đặt vi phạm này sẽ được sử dụng (kết hợp với các cài đặt đã xác định trên tab Báo cáo lỗi) để kiểm tra vi phạm trong các tài liệu nguồn.
Tùy chọn/Điều khiển
Ma trận kết nối
Ma trận trình bày tất cả các phép kiểm tra kết nối dây có thể có giữa các tổ hợp chân linh kiện, cổng và đầu nối trang sơ đồ, đồng thời kiểm tra các đối tượng chưa được kết nối. Ma trận được đọc theo hàng ngang/cột dọc và màu của ô tại giao điểm hàng-cột cho biết cách Trình biên dịch sẽ phản hồi khi kiểm tra điều kiện cụ thể đó.
Để thay đổi chế độ báo cáo cho một phép kiểm tra vi phạm trong ma trận, hãy nhấp vào ô màu tại giao điểm hàng và cột của hai đối tượng. Mỗi lần nhấp, chế độ sẽ chuyển sang mức báo cáo tiếp theo. Các mức sau được hỗ trợ:
- No Report
- Warning
- Error
- Fatal Error
Menu chuột phải
Các lệnh sau có trong menu ngữ cảnh khi nhấp chuột phải:
- All Off - đặt tất cả các ô trong ma trận thành No Report.
- All Warning - đặt tất cả các ô trong ma trận thành Warning.
- All Error - đặt tất cả các ô trong ma trận thành Error.
- All Fatal - đặt tất cả các ô trong ma trận thành Fatal Error.
- Default - đưa tất cả các ô về giá trị mặc định.
Tùy chọn bổ sung
- Set To Installation Defaults - nhấp để đưa các tùy chọn của tab về giá trị mặc định khi cài đặt.
Tạo lớp

Tab Class Generation của hộp thoại Project Options
Tab Class Generation của hộp thoại Project Options cho phép bạn cấu hình và kiểm soát việc tạo lớp. Lớp là một tập hợp logic các đối tượng thiết kế thuộc cùng một loại cụ thể. Ví dụ, một nhóm linh kiện có liên quan có thể được gom vào một Lớp linh kiện riêng, sau đó dùng làm cơ sở để tạo quy tắc dành riêng cho nhóm đó. Tab này cung cấp các điều khiển để xác định những lớp nào được tạo tự động và những lớp do người dùng định nghĩa nào được tạo khi đồng bộ hóa các tài liệu sơ đồ nguyên lý nguồn với tài liệu thiết kế PCB.
Tùy chọn/Điều khiển
Các lớp được tạo tự động
-
Generate Net Classes for Buses - chọn tùy chọn này để tự động tạo một lớp net cho mỗi bus trong thiết kế. Các thành viên của lớp sẽ là từng net cấu thành bus đó (bus được dùng để tạo lớp).
-
Generate Net Classes for Components - chọn tùy chọn này để tự động tạo một lớp net cho mỗi linh kiện trong thiết kế. Các thành viên của lớp sẽ là các net nối với các chân của linh kiện đó (linh kiện được dùng để tạo lớp).
-
Generate Separate Net Classes for Bus Sections - chọn tùy chọn này để tự động tạo một lớp net riêng cho mỗi đoạn bus. Một đoạn bus được tạo bằng cách chỉ định một bus thực chất là một phần của bus lớn hơn, ví dụ,
D[15..8], từ busD[15..0]. -
Generate Net Classes for Named Signal Harnesses - bật tùy chọn này để tự động tạo một lớp net cho mỗi bó tín hiệu có tên trong thiết kế. Các thành viên của lớp sẽ là các net tương ứng với những tín hiệu được tập hợp trong bó tín hiệu có tên đó (bó tín hiệu được dùng để tạo lớp).
-
Sheet-Level Class Generation Grid - vùng này cho phép bạn kiểm soát việc tự động tạo các lớp linh kiện và/hoặc lớp net ở cấp từng trang sơ đồ nguyên lý. Tất cả các trang sơ đồ nguyên lý nguồn của dự án đều được liệt kê với các thông tin sau cho mỗi trang:
- Sheet Name - tên của tài liệu sơ đồ nguyên lý.
- Full Path - đường dẫn tuyệt đối đến thư mục chứa tài liệu.
-
Component Classes - chọn tùy chọn này để tạo một lớp linh kiện cho trang sơ đồ.
- Generate Rooms - chọn tùy chọn này để tạo một vùng bố trí (room) cho lớp linh kiện.
-
Net Classes Scope - sử dụng trường này để xác định có tạo lớp net cho trang sơ đồ hay không và phạm vi tạo nếu có. Danh sách thả xuống của trường cung cấp các lựa chọn sau:
- None - không tạo lớp net cho trang sơ đồ này.
- Local Nets Only - tạo lớp net cho trang sơ đồ này nhưng chỉ chứa các net thành viên nằm cục bộ trong trang.
- All Nets - tạo lớp net cho trang sơ đồ này, trong đó chứa tất cả các net thành viên liên quan đến trang (cả net cục bộ và net kết nối sang nơi khác).
-
Structure Classes Generate Structure - chọn tùy chọn này để tạo một lớp cấu trúc cho trang sơ đồ.
Lớp cấu trúc là một loại lớp đặc biệt có thể chứa bất kỳ loại lớp nào (lớp net, lớp linh kiện, v.v.) làm thành viên. Bằng cách tự động tạo một lớp cấu trúc từ mỗi trang sơ đồ nguyên lý trong dự án – có chứa linh kiện và/hoặc net – khi chuyển thiết kế sang PCB, cấu trúc của dự án có thể được thể hiện trung thực ở phía PCB. Các lớp cấu trúc không chỉ cho phép tái hiện cấu trúc tài liệu sơ đồ nguyên lý trong môi trường PCB để hỗ trợ điều hướng nâng cao, mà còn có thể được sử dụng trong các truy vấn logic, chẳng hạn khi xác định phạm vi áp dụng quy tắc thiết kế hoặc khi lọc.
Các lớp do người dùng định nghĩa
- Generate Component Classes - chọn tùy chọn này để tạo các lớp linh kiện do người dùng định nghĩa khi chuyển thiết kế sang PCB. Các lớp linh kiện được định nghĩa thủ công trên sơ đồ nguyên lý bằng cách thêm tham số ClassName vào các linh kiện cần áp dụng và đặt giá trị của tham số thành tên lớp mong muốn.
- Generate Rooms for Component Class - chọn tùy chọn này để tạo các vùng bố trí dựa trên các lớp linh kiện do người dùng định nghĩa. Các linh kiện này cần có tham số linh kiện mang tên 'ClassName'.
- Generate Net Classes - chọn tùy chọn này để tạo các lớp net do người dùng định nghĩa khi chuyển thiết kế sang PCB. Các lớp net được định nghĩa thủ công trên sơ đồ nguyên lý bằng cách sử dụng chỉ thị Net Class. Để đưa một net vào một lớp net, hãy gắn chỉ thị Net Class vào dây hoặc bus tương ứng (hoặc một vùng blanket) và đặt giá trị của tham số ClassName của chỉ thị thành tên lớp mong muốn.
► Tìm hiểu cách tạo lớp net do người dùng định nghĩa
► Tìm hiểu cách tạo lớp linh kiện do người dùng định nghĩa
Tùy chọn bổ sung
- Set To Installation Defaults - nhấp để đặt các tùy chọn của tab về giá trị mặc định khi cài đặt.
Lưu ý
-
Để tạo các lớp (tự động và/hoặc do người dùng định nghĩa) khi chuyển thiết kế sang PCB, bạn phải đảm bảo rằng các thiết lập so sánh tương ứng đã được đặt thành Find Differences trên tab So sánh của hộp thoại Project Options, như sau:
- Lớp net - đặt kiểu so sánh Extra Net Classes (trong danh mục Differences Associated with Nets) thành Find Differences.
- Lớp linh kiện - đặt kiểu so sánh Extra Component Classes (trong danh mục Differences Associated with Components) thành Find Differences.
-
Ngoài ra, trên tab Tạo ECO của hộp thoại Project Options , bạn phải đảm bảo rằng các thiết lập ECO tương ứng đã được đặt thành Generate Change Orders.
- Lớp net - đặt kiểu thay đổi Add Net Classes (trong danh mục Modifications Associated with Nets) thành Generate Change Orders.
- Lớp linh kiện - đặt kiểu thay đổi Add Component Classes (trong danh mục Modifications Associated with Components) thành Generate Change Orders.
So sánh

Tab Comparator của hộp thoại Project Options
Tab Comparator của hộp thoại Project Options cho phép bạn xác định những loại khác biệt cần tìm và những loại cần bỏ qua khi so sánh các tài liệu. Đối với mỗi phép so sánh có thể thực hiện, bạn có thể chọn tìm hoặc bỏ qua các khác biệt bằng danh sách thả xuống tương ứng trong cột Mode. Bạn có thể thiết lập để tìm các khác biệt về linh kiện, net, tham số và đối tượng vật lý theo yêu cầu.
Tùy chọn/Điều khiển
Hộp thoại này được chia thành hai vùng chính:
- Vùng phía trên, có tiêu đề Comparison Type Description/Mode, liệt kê mô tả và chế độ so sánh của từng kiểu so sánh có sẵn.
- Vùng phía dưới, có tiêu đề Object Matching Criteria, được dùng để xác định tiêu chí đối sánh cho Net, Net Class, Component Class, Differential Pair và Structure Class.
Mô tả/Chế độ của kiểu so sánh
- Comparison Type Description - vùng này liệt kê mô tả của từng kiểu so sánh có sẵn trong dự án. Sử dụng thanh cuộn ở ngoài cùng bên phải để cuộn đến Differences Associated with Components, Differences Associated with Nets, Differences Associated with Parameters, Differences Associated with Physical và Differences Associated with Structure Classes nhằm xem/thay đổi các chế độ so sánh trong từng nhóm.
-
Mode - nhấp vào một mục để thay đổi chế độ so sánh bằng danh sách thả xuống:
-
Find Differences- chọn tùy chọn này để tìm các khác biệt thuộc kiểu so sánh đó. -
Ignore Differences- chọn tùy chọn này để bỏ qua mọi khác biệt thuộc kiểu so sánh đó (sẽ không thực hiện so sánh đối với kiểu so sánh đó).
-
Tiêu chí đối sánh đối tượng
- Object Type - danh sách các loại đối tượng như Net, Net Class, Component Class, Differential Pair và Structure Class.
- Min Match % - nhập tỷ lệ phần trăm khớp tối thiểu mong muốn hoặc nhấp vào phía bên phải của cột rồi sử dụng các phím mũi tên lên và xuống để tăng hoặc giảm giá trị.
- Min Matched Members - nhập số lượng thành viên khớp tối thiểu mong muốn hoặc nhấp vào phía bên phải của cột rồi sử dụng các phím mũi tên lên và xuống để tăng hoặc giảm giá trị.
- Use Name Matching - nhấp vào mục hoặc sử dụng danh sách thả xuống để chọn After member matching hoặc Never.
- Show Manual Matching Dialog - nhấp vào mục hoặc dùng danh sách thả xuống để chọn For unmatched objects hoặc Never.
Tùy chọn bổ sung
- Ignore Rules Defined in PCB Only - chọn tùy chọn này để bỏ qua các quy tắc chỉ được định nghĩa trong PCB của dự án thiết kế. Ví dụ, khi thực hiện lệnh thay đổi kỹ thuật, các thay đổi có thể được áp dụng từ sơ đồ nguyên lý sang PCB; nếu tùy chọn này được bật, các quy tắc chỉ có trong PCB sẽ bị bỏ qua. Nếu không có quy tắc tương ứng trong các trang sơ đồ nguyên lý của cùng dự án, bộ so sánh sẽ không tìm cách thêm quy tắc mới.
- Set To Installation Defaults - nhấp để đặt các tùy chọn của tab về giá trị mặc định khi cài đặt.
Tạo ECO

Tab ECO Generation của hộp thoại Project Options
Tab ECO Generation của hộp thoại Project Options cho phép bạn cấu hình những loại sửa đổi có thể được đưa vào khi tạo Lệnh thay đổi kỹ thuật (ECO) dựa trên những khác biệt do Bộ so sánh phát hiện.
Tùy chọn/Điều khiển
Danh sách loại sửa đổi
Danh sách này trình bày tất cả các sửa đổi có thể thực hiện thông qua Lệnh thay đổi kỹ thuật khi đồng bộ hóa các tài liệu sơ đồ nguyên lý nguồn với tài liệu thiết kế PCB. Các mục trong danh sách bao gồm các nhóm loại sửa đổi liên quan đến Components, Nets, Parameters, Structure Classes, v.v.
Mỗi loại sửa đổi cụ thể bao gồm các trường sau:
- Modification Type Description – mô tả ngắn gọn về loại sửa đổi (hành động mà Bộ đồng bộ hóa sẽ thực hiện).
-
Mode – dùng trường này để kiểm soát việc có đưa loại sửa đổi vào ECO được tạo hay không. Dùng danh sách thả xuống để chọn một trong các tùy chọn sau:
- Generate Change Orders - đưa loại sửa đổi vào ECO được tạo.
- Ignore Differences - loại trừ loại sửa đổi khỏi ECO được tạo.
Menu chuột phải
Lệnh sau có trong menu ngữ cảnh khi nhấp chuột phải:
- Report – dùng lệnh này để tạo báo cáo về các chế độ sửa đổi hiện được cấu hình. Hộp thoại Report Preview sẽ xuất hiện với báo cáo đã được tải sẵn. Dùng hộp thoại này để xem xét báo cáo bằng các điều khiển trang/thu phóng trước khi xuất báo cáo ra tệp hoặc in.
Tùy chọn bổ sung
- Push Component Designator Changes to Annotation File (if any) – chọn để đưa các thay đổi ký hiệu định danh linh kiện vào tệp đánh số linh kiện.
- Set To Installation Defaults – nhấp để đặt các tùy chọn của tab về giá trị mặc định khi cài đặt.
Tùy chọn

Tab Options của hộp thoại Project Options
Tab Options của hộp thoại Project Options cho phép bạn chỉ định đường dẫn đầu ra và các tùy chọn liên quan cho các đầu ra được tạo cho dự án. Bạn cũng có thể chỉ định các tùy chọn tạo netlist và phạm vi định danh net.
Tùy chọn/Điều khiển
-
Output Path – đường dẫn đầu ra mặc định để tạo các tệp đầu ra từ dự án thiết kế hiện tại (
*.PrjPcb). - ECO Log Path – đường dẫn đầu ra mặc định cho các tệp nhật ký ECO.
-
Schematic Template Location – dùng trường này để chỉ định thư mục chứa các tệp mẫu sơ đồ nguyên lý (
*.SchDot,*.SchDoc) cho dự án.
Tùy chọn đầu ra
- Open outputs after compile – bật để mở các tệp được tạo sau khi biên dịch dự án thiết kế. Đối với dự án gói thư viện tích hợp, bật tùy chọn này để cài đặt thư viện tích hợp sau khi biên dịch dự án gói.
-
Timestamp folder – bật để tạo thư mục có dấu thời gian cho đầu ra được tạo, chẳng hạn như báo cáo BOM (Reports » Bill of Materials). Tên thư mục có định dạng
<FolderName> Date Time, trong đó<FolderName>được chỉ định trong trường Output Path, cònDatevàTimecó cùng định dạng với thiết lập hệ thống của bạn. - Archive project document – bật để lưu trữ tài liệu dự án. Ví dụ, khi tạo đầu ra sản xuất từ thiết kế PCB (File » Fabrication Outputs và File » Assembly Outputs), thư mục đầu ra đích sẽ chứa một bản sao của tài liệu PCB liên quan.
- Use separate folder for each output type – bật để tạo các thư mục riêng cho từng loại đầu ra được tạo cho dự án thiết kế. Cấu trúc thư mục này cũng sẽ được hiển thị trong bảng Projects.
Tùy chọn netlist
- Allow Ports to Name Nets – bật để đặt tên net bằng thuộc tính Name của cổng đã nối dây thay vì dùng tên net mặc định do hệ thống tạo.
- Allow Sheet Entries to Name Nets – bật để đặt tên net bằng tên điểm kết nối trang thay vì dùng tên net mặc định do hệ thống tạo.
- Allow Single Pin Nets – bật để cho phép tồn tại các net chỉ chứa một chân.
-
Append Sheet Numbers to Local Net – bật để nối thêm giá trị tham số Sheet Number của tài liệu sơ đồ nguyên lý (tham số cấp tài liệu) vào tên các net cục bộ trên trang đó. Net cục bộ là net không đi ra ngoài trang. Tùy chọn này không áp dụng cho net đi ra ngoài trang (và do đó không phải là net cục bộ).
- Higher Level Names Take Priority – bật để dùng các nhãn net trên các trang cấp cao hơn trong cấu trúc phân cấp để đặt tên cho các net trên các trang cấp thấp hơn.
-
Power Port Names Take Priority – phần mềm có khả năng cục bộ hóa một net nguồn toàn cục bằng cách nối dây từ cổng nguồn đến một cổng thông thường. Thao tác này buộc tất cả các chân trên trang đó được nối với cổng nguồn ấy phải thuộc một net riêng. Bật tùy chọn này sẽ buộc việc đặt tên net phải dùng tên của net được gán cho cổng nguồn.
Phạm vi định danh net
Thiết kế nhiều trang được xác định ở cấp độ điện (hoặc kết nối) bằng các định danh net. Các định danh net (nhãn net, cổng, điểm vào trang, cổng nguồn và chân ẩn) tạo ra các kết nối logic giữa những điểm thuộc cùng một net. Các kết nối này có thể nằm trong một trang hoặc trải rộng trên nhiều trang. Kết nối vật lý tồn tại khi một đối tượng được nối trực tiếp với một đối tượng điện khác bằng dây dẫn. Kết nối logic được tạo ra khi hai định danh net cùng loại (ví dụ: hai nhãn net) có cùng thuộc tính Net .
Khi tạo mô hình kết nối của thiết kế, bạn phải xác định cách các định danh net kết nối với nhau – thao tác này được gọi là thiết lập Net Identifier Scope. Về cơ bản, có hai cách kết nối các trang trong thiết kế nhiều trang: theo chiều ngang, trực tiếp từ trang này sang trang khác, rồi sang trang tiếp theo, v.v.; hoặc theo chiều dọc, từ trang con đến ký hiệu trang đại diện cho nó trên trang cha. Với kết nối ngang, các kết nối được thiết lập từ cổng đến cổng (cũng có thể từ nhãn net đến nhãn net). Với kết nối dọc, các kết nối được thiết lập từ điểm vào trang đến cổng.
Sử dụng danh sách thả xuống để chọn một trong các phạm vi sau:
-
Automatic (Based on project contents) – chế độ này tự động chọn chế độ định danh net dựa trên các tiêu chí sau: nếu có điểm vào trang trên trang cấp cao nhất thì sử dụng Hierarchical; nếu không có điểm vào trang nhưng có cổng thì sử dụng Flat; nếu không có cả điểm vào trang lẫn cổng thì sử dụng Global.
- Flat (Only ports global) – các cổng kết nối toàn cục trên tất cả các trang trong toàn bộ thiết kế. Với tùy chọn này, nhãn net chỉ có phạm vi cục bộ trên từng trang, tức là chúng không kết nối giữa các trang. Tất cả các cổng cùng tên sẽ được kết nối trên mọi trang. Tùy chọn này có thể được sử dụng cho thiết kế nhiều trang dạng phẳng. Không nên sử dụng cho thiết kế lớn vì có thể khó lần theo một net qua các trang.
- Hierarchical (Sheet entry <-> port connections, power ports global) – kết nối theo chiều dọc giữa một cổng và điểm vào trang tương ứng. Tùy chọn này chỉ tạo kết nối giữa các trang thông qua các điểm vào trên ký hiệu trang và các cổng tương ứng trên trang con. Các cổng trên trang được dùng để đưa net hoặc bus lên các điểm vào trên ký hiệu trang tương ứng ở trang cha. Cổng không có điểm vào trang tương ứng sẽ không được kết nối, ngay cả khi có cổng cùng tên trên một trang khác. Nhãn net chỉ có phạm vi cục bộ trên từng trang, tức là chúng không kết nối giữa các trang. Tuy nhiên, các cổng nguồn có phạm vi toàn cục – tất cả các cổng nguồn cùng tên đều được kết nối trong toàn bộ thiết kế. Tùy chọn này có thể được sử dụng để tạo thiết kế với độ sâu hoặc cấu trúc phân cấp bất kỳ, đồng thời cho phép lần theo một net xuyên suốt thiết kế trên bản in sơ đồ nguyên lý.
- Strict Hierarchical (Sheet entry <-> port connections, power ports local) – chế độ kết nối này hoạt động giống chế độ Hierarchical , nhưng các cổng nguồn chỉ có phạm vi cục bộ trên từng trang, tức là chúng không kết nối với các cổng nguồn cùng tên trên những trang khác.
- Global (Netlabels and ports global) – các cổng và nhãn net kết nối trên tất cả các trang trong toàn bộ thiết kế. Với tùy chọn này, mọi net có cùng nhãn net sẽ được kết nối với nhau trên tất cả các trang. Đồng thời, tất cả các cổng cùng tên cũng sẽ được kết nối trên mọi trang. Nếu một net kết nối với cổng cũng có nhãn net, tên của net sẽ là tên nhãn net đó. Tùy chọn này cũng có thể được sử dụng cho thiết kế nhiều trang dạng phẳng; tuy nhiên, việc lần theo kết nối từ trang này sang trang khác sẽ khó khăn vì không phải lúc nào cũng dễ tìm tên net bằng mắt trên sơ đồ nguyên lý.
Cho phép hoán đổi chân bằng các phương pháp sau
Trong trình biên tập PCB, việc hoán đổi chân, cặp vi sai và phần linh kiện được thực hiện bằng cách hoán đổi các net trên pad linh kiện cùng phần đồng tương ứng. Khi các thay đổi được hợp nhất vào sơ đồ nguyên lý, có hai cách xử lý việc hoán đổi chân:
-
Adding / Removing Net-Labels – bật để cho phép hoán đổi các chân trên ký hiệu linh kiện. Chỉ có thể thực hiện hoán đổi trên sơ đồ nguyên lý bằng cách hoán đổi nhãn net nếu kết nối được thiết lập thông qua các nhãn net, tức là các chân không được nối trực tiếp với nhau bằng dây dẫn.
-
Changing Schematic Pins – bật để cho phép hoán đổi các nhãn net trên dây dẫn nối với chân linh kiện. Hoán đổi chân sẽ là tùy chọn duy nhất khả dụng khi các net đã được nối trực tiếp với linh kiện bằng dây dẫn. Phương pháp này có thể được sử dụng cho các linh kiện đơn giản (như mảng điện trở), hoặc khi không có lựa chọn nào khác do cấu trúc của thiết kế sơ đồ nguyên lý.
Chung
- Automatic Sheet Numbering – bật tùy chọn này để tự động đánh số các trang sơ đồ nguyên lý trong dự án này. Tùy chọn này cho phép kiểm soát số hiệu trang và lưu chúng dưới dạng tham số trong các tài liệu sơ đồ nguyên lý tương ứng.
-
Automatic Cross References – bật tùy chọn này để tự động thêm thông tin tham chiếu chéo cho cổng, đầu nối ngoài trang và điểm vào trang vào tất cả các tài liệu sơ đồ nguyên lý nguồn trong dự án đang hoạt động. Tính năng này giúp lần theo kết nối net trong thiết kế không phân cấp.
- New Indexing of Sheet Symbols – bật để sử dụng bất kỳ chữ số hoặc số nào làm chỉ số đầu hoặc cuối của một ký hiệu trang lặp, bao gồm cả 0. Không cho phép số âm. Chỉ số cuối phải luôn lớn hơn chỉ số đầu.
Tham chiếu chéo
-
Sheet Style – chọn một trong các kiểu trang sau đây để tham chiếu chéo các cổng trên một trang sơ đồ nguyên lý hoặc các trang sơ đồ nguyên lý trong dự án.
-
None– không thêm thông tin kiểu trang vào chuỗi tham chiếu chéo của tất cả các cổng. -
Name– thêm tên các trang mà cổng liên kết đến vào chuỗi tham chiếu chéo. -
Number– thêm số trang của các trang mà cổng liên kết đến vào chuỗi tham chiếu chéo.
-
-
Location Style – chọn một trong các kiểu vị trí sau đây để tham chiếu chéo các cổng trên một trang sơ đồ nguyên lý hoặc các trang sơ đồ nguyên lý trong dự án.
-
None– không thêm thông tin vị trí vào chuỗi tham chiếu chéo của tất cả các cổng. -
Zone– thêm số vùng tham chiếu (các vùng được xác định trên đường viền trang) vào chuỗi tham chiếu chéo của tất cả các cổng liên kết với đối tượng cha, chẳng hạn như vị trí của ký hiệu trang. -
Location X,Y– hiển thị vị trí của các cổng trong dấu ngoặc trong chuỗi tham chiếu chéo của tất cả các cổng liên kết với đối tượng cha, chẳng hạn như vị trí của ký hiệu trang.
-
- Follow Cross References settings in Preferences – khi bật tùy chọn này, giá trị của các tùy chọn Sheet Style và Location Style sẽ được kế thừa từ các tùy chọn trong vùng Port Cross References của trang Sơ đồ nguyên lý – Chung thuộc hộp thoại Preferences.
-
Display Cross References for:
-
Ports – sử dụng danh sách thả xuống để chọn chế độ hiển thị tham chiếu chéo cho các cổng.
-
Disabled– không thêm tham chiếu chéo vào các cổng. -
Only Related Sheet Entry– hiển thị tham chiếu chéo đến điểm kết nối trang tương ứng trên trang sơ đồ nguyên lý cha. -
Only Related Ports– hiển thị tham chiếu chéo đến các cổng tương ứng. -
Sheet Entry & Ports– hiển thị tham chiếu chéo đến cả điểm kết nối trang và các cổng.
-
- Off-sheet Connectors – bật tùy chọn này để hiển thị tham chiếu chéo cho các đối tượng đầu nối ngoài trang.
- Sheet Entries – bật tùy chọn này để hiển thị tham chiếu chéo cho các đối tượng điểm kết nối trang.
-
Ports – sử dụng danh sách thả xuống để chọn chế độ hiển thị tham chiếu chéo cho các cổng.
Cặp vi sai
-
Custom Diff Pair Suffix Grid – liệt kê các hậu tố cặp vi sai mặc định (
_P/_N) và tất cả các hậu tố cặp vi sai tùy chỉnh đã được xác định, bao gồm:- Positive Suffix – hậu tố cho net dương của một cặp vi sai.
- Negative Suffix – hậu tố cho net âm của một cặp vi sai.
- Add – nhấp để thêm một cặp hậu tố mới vào danh sách.
- Remove – nhấp để xóa các cặp hậu tố đã chọn khỏi danh sách.
Tạo xNets
- Sources/Destinations – xác định danh sách các tiền tố, phân tách bằng dấu phẩy, cho ký hiệu định danh của các linh kiện có thể được dùng làm linh kiện nguồn hoặc đích trong xNets.
- Discretes – xác định danh sách các tiền tố, phân tách bằng dấu phẩy, cho ký hiệu định danh của các linh kiện có thể được dùng làm linh kiện nối tiếp trong xNets.
Đa kênh

Tab Multi-Channel của hộp thoại Project Options
Tab Multi-Channel của hộp thoại Project Options cho phép bạn xác định quy tắc đặt tên vùng bố trí và định dạng ký hiệu định danh linh kiện để sử dụng với các thiết kế đa kênh. Thiết kế đa kênh cho phép tham chiếu nhiều lần đến cùng một trang con trong dự án. Có thể thực hiện điều này bằng cách đặt nhiều ký hiệu trang tham chiếu đến cùng một trang con, hoặc thêm từ khóa Repeat vào ký hiệu định danh của một ký hiệu trang để tạo nhiều thể hiện của trang đó.
Altium Designer cung cấp khả năng thiết kế đa kênh thực sự, nghĩa là bạn có thể tham chiếu lặp lại từng trang trong một dự án. Mọi thay đổi cần thiết đều có thể được áp dụng tại một nơi, sau đó việc biên dịch lại dự án sẽ truyền những thay đổi đó đến từng thể hiện. Altium Designer không chỉ hỗ trợ nhiều kênh mà còn cho phép lồng các kênh vào nhau.
Việc ánh xạ từ một linh kiện logic duy nhất trên sơ đồ nguyên lý sang nhiều thể hiện vật lý trên PCB được kiểm soát bởi quy tắc đặt ký hiệu định danh đa kênh được xác định trên tab này.
Tùy chọn/Điều khiển
Đặt tên vùng bố trí
-
Room Naming Style - sử dụng trường này để chỉ định kiểu đặt tên cho các vùng bố trí. Khi bạn chọn một kiểu trong danh sách, hình ảnh bên dưới sẽ được cập nhật để phản ánh quy ước đặt tên sẽ xuất hiện trong thiết kế. Khi thiết kế được biên dịch, một vùng bố trí sẽ được tạo cho mỗi trang trong thiết kế, bao gồm từng nhóm kênh và từng kênh cấp thấp hơn. Có năm kiểu khả dụng — hai kiểu phẳng và ba kiểu phân cấp (các kiểu có bao gồm đường dẫn):
- Flat Numeric With Names
- Flat Alpha With Names
- Numeric Name Path
- Alpha Name Path
- Mixed Name Path
-
Level Separator for Paths - sử dụng trường này để chỉ định ký tự/ký hiệu cần dùng để phân tách thông tin đường dẫn khi sử dụng các kiểu đặt tên phân cấp (các kiểu có bao gồm đường dẫn). Theo mặc định, ký tự gạch dưới (_) sẽ được sử dụng.
- Preview - khi bạn thay đổi Room Naming Style và/hoặc Designator Format, hình ảnh trong vùng này sẽ tự động cập nhật để phản ánh quy ước đặt tên sẽ xuất hiện trong thiết kế. Hình ảnh minh họa một thiết kế có các kênh lồng nhau theo cấu trúc 2 x 2. Các vùng gạch chéo lớn hơn biểu thị hai kênh cấp trên (hoặc nhóm kênh), còn các vùng tô bóng bên trong biểu thị các kênh cấp thấp hơn (mỗi kênh hiển thị hai linh kiện mẫu).
Đặt tên linh kiện
-
Designator Format - sử dụng trường này để chỉ định định dạng dùng khi gán ký hiệu định danh cho các linh kiện trong thiết kế. Danh sách thả xuống của trường cung cấp tám định dạng được xác định sẵn sau đây: năm định dạng phẳng và ba định dạng có thể dùng trong ngữ cảnh phân cấp (có chứa tên kênh):
- $Component_$RoomName
- $RoomName_$Component
- $Component$ChannelAlpha
- $Component_$ChannelPrefix$ChannelAlpha
- $Component_$ChannelIndex
- $Component_$ChannelPrefix$ChannelIndex
- $ComponentPrefix_$ChannelIndex_$ComponentIndex
- $ComponentPrefix_$RoomName_$ComponentIndex
Xác định định dạng ký hiệu định danh riêng
Bạn cũng có thể xác định định dạng ký hiệu định danh linh kiện riêng bằng cách nhập trực tiếp vào trường Designator Format. Có thể sử dụng các từ khóa sau khi tạo chuỗi định dạng:
- $RoomName - đây là tên của kênh liên quan, được xác định theo kiểu đã chọn trong trường Room Naming Style .
- $Component- đây là ký hiệu định danh logic của linh kiện.
- $ComponentPrefix - đây là tiền tố ký hiệu định danh logic của linh kiện (ví dụ: U đối với U1).
- $ComponentIndex - đây là chỉ số ký hiệu định danh logic của linh kiện (ví dụ: 1 đối với U1).
- $ChannelPrefix - đây là ký hiệu định danh logic của ký hiệu trang sơ đồ.
- $ChannelIndex - đây là chỉ số kênh.
- $ChannelAlpha - đây là chỉ số kênh được biểu diễn dưới dạng một ký tự.
Lưu ý
- Việc đánh chỉ số kênh bằng chữ cái chỉ thực sự hữu ích nếu thiết kế có tổng cộng ít hơn 26 kênh hoặc nếu bạn sử dụng định dạng ký hiệu định danh có tính phân cấp.
- Đối với thiết kế đa kênh, các tab được hiển thị dọc theo cạnh dưới của trang sơ đồ nguyên lý trong cửa sổ thiết kế, mỗi tab tương ứng với một kênh (hoặc một nhóm kênh). Tên tab là tên ký hiệu trang sơ đồ cộng với số kênh, ví dụ: BANKA. Đây là các chế độ xem đã biên dịch (chế độ xem vật lý) của thiết kế, còn thiết kế logic vẫn giữ nguyên như trước trên tab Editor.
Bản in mặc định

Tab Default Prints của hộp thoại Project Options
Tab Default Prints của hộp thoại Project Options cho phép bạn thiết lập các đầu ra in mặc định cho những trình biên tập khác nhau của Altium Designer. Các thiết lập mặc định được chỉ định này sẽ được sử dụng khi chạy các lệnh in sau từ menu chính của các trình biên tập:
- File » Print
- File » Print Preview » Print
Bạn cũng có thể truy cập tab Default Prints của hộp thoại Project Options từ trình biên tập sơ đồ nguyên lý và trình biên tập PCB bằng cách chọn lệnh File » Default Prints từ menu chính.
Tùy chọn/Điều khiển
Khu vực chính của tab hiển thị danh sách tất cả các đầu ra dạng bản in được hỗ trợ có thể tạo từ trình biên tập sơ đồ nguyên lý và PCB. Các loại đầu ra được chia thành các nhóm sau:
-
Assembly Outputs -
Documentation Outputs -
Fabrication Outputs -
Other Outputs -
Report Outputs -
Validation Outputs
Với mỗi mục, thông tin sau được hiển thị:
- Output Description – nội dung được xuất khi sử dụng loại đầu ra in này.
- Supports – trình biên tập hỗ trợ loại đầu ra in này.
-
Default Print – cho biết loại đầu ra in này có được dùng làm loại bản in mặc định (bật) hay không (tắt).
Tùy chọn bổ sung
-
Configure – nhấp vào nút này để truy cập hộp thoại liên quan nhằm cấu hình đầu ra in đang được chọn. Các hộp thoại bao gồm:
- Hộp thoại In – để cấu hình Bản vẽ lắp ráp, Bản vẽ tổng hợp, Bản in PCB, Bản in PCBLIB, Bản in sơ đồ nguyên lý, Bản vẽ khoan tổng hợp, Bản vẽ/Hướng dẫn khoan, Bản in artwork cuối cùng, Bản in lớp nguồn, và Bản in mặt nạ hàn/kem hàn.
- Hộp thoại Cài đặt in PCB 3D – để cấu hình Bản in PCB 3D.
- Hộp thoại Video PCB 3D – để cấu hình đầu ra Video PCB 3D.
- Hộp thoại PDF3D – để cấu hình đầu ra PDF3D và PDF3D MBA.
- Hộp thoại Thuộc tính in văn bản nâng cao – để cấu hình Bản in báo cáo và Bản in văn bản. Xác định các tùy chọn cho đầu ra in (ví dụ: đầu trang và đánh số trang/dòng). Bạn cũng có thể chỉ định sử dụng một phông chữ cụ thể.
- Wave Print Properties Form hộp thoại – để cấu hình Bản in SimView.
- Hộp thoại Thiết lập báo cáo cấu trúc lớp – để cấu hình đầu ra Báo cáo cấu trúc lớp bo mạch.
- Hộp thoại Trình quản lý báo cáo – để cấu hình báo cáo Danh mục vật tư và So sánh BOM.
- Hộp thoại Cấu hình xuất nhận xét – để cấu hình báo cáo Xuất nhận xét.
- Hộp thoại Thiết lập khác biệt – để cấu hình Báo cáo khác biệt.
- Hộp thoại Thiết lập kiểm tra quy tắc điện – để cấu hình báo cáo xác thực Kiểm tra quy tắc điện.
- Page Setup – nhấp để truy cập hộp thoại thiết lập trang cho đầu ra in đang được chọn. Trong hộp thoại này, bạn có thể cấu hình bản in với máy in đã chọn về giấy, tỷ lệ và cài đặt màu. Bạn cũng có thể truy cập hộp thoại cấu hình liên quan, hộp thoại thiết lập máy in, xem trước bản in và cuối cùng in đầu ra bằng máy in đã chọn.
Đường dẫn tìm kiếm

Tab Search Paths của hộp thoại Project Options
Tab Search Paths của hộp thoại Project Options cho phép bạn chỉ định các đường dẫn tìm kiếm tệp thư viện và mô hình cho dự án.
Tùy chọn/Điều khiển
Danh sách đường dẫn tìm kiếm theo thứ tự
Bảng này hiển thị danh sách đường dẫn tìm kiếm tệp thư viện và mô hình theo thứ tự (ví dụ: thư viện footprint PCB, mô hình mô phỏng và tính toàn vẹn tín hiệu). Với mỗi đường dẫn, bạn có thể chỉ định bộ lọc và cài đặt tìm kiếm đệ quy.
- Path - vị trí của đường dẫn tìm kiếm.
- Filter - bộ lọc tìm kiếm. Theo mặc định, bộ lọc tìm kiếm tất cả các tệp.
- Recursive - chọn để tìm kiếm trong tất cả các thư mục con của thư mục đường dẫn tìm kiếm. Nhấp đúp vào một đường dẫn tìm kiếm để chỉnh sửa đường dẫn đó.
Các loại tệp sau được hỗ trợ: thư viện footprint (*.PcbLib), tệp mô hình mô phỏng (*.mdl), tệp mạch con mô phỏng (*.ckt), tệp mô hình IBIS (*.ibs).
- Delete - dùng để xóa đường dẫn tìm kiếm đã chọn.
- Properties - dùng để truy cập hộp thoại Edit Search Path nhằm chỉnh sửa các thuộc tính của đường dẫn tìm kiếm đã chọn.
- Move Up - dùng để di chuyển đường dẫn tìm kiếm đã chọn lên một dòng.
- Move Down - dùng để di chuyển đường dẫn tìm kiếm đã chọn xuống một dòng.
Các tệp tìm thấy trên tất cả đường dẫn tìm kiếm
Bảng này hiển thị các tệp thư viện và mô hình được tìm thấy từ danh sách Ordered List of Search Paths. Sử dụng nút Refresh List để xem danh sách đã cập nhật.
Tham số

Tab Parameters của hộp thoại Project Options
Tab Parameters của hộp thoại Project Options cho phép bạn quản lý các tham số được xác định cho dự án, thường được gọi là project-level parameters. Các tham số được xác định ở cấp dự án có thể được sử dụng trên tất cả các trang sơ đồ nguyên lý và tài liệu PCB trong dự án thông qua các chuỗi đặc biệt: =<ProjectParameterName> trên sơ đồ nguyên lý (ví dụ: =Project) và .<ProjectParameterName> trên PCB (ví dụ: .Project). Tham số có thể được dùng để cung cấp thông tin thiết kế bổ sung. Ví dụ, các tham số cấp dự án có thể được dùng trên toàn dự án làm nguồn dữ liệu tham số cho các chuỗi đặc biệt được thêm vào trang sơ đồ nguyên lý và/hoặc tài liệu PCB – trong đó tài liệu PCB không hỗ trợ các tham số cục bộ.
Các tham số dự án phía Workspace được lưu trong Workspace cùng với dự án và chỉ có thể chỉnh sửa từ giao diện trình duyệt của Workspace (tìm hiểu thêm về Editing a Project trong Altium 356 Workspace hoặc On-Prem Enterprise Workspace). Ngược lại, các tham số dự án phía thiết kế được lưu trong tệp dự án (*.PrjPcb) và có thể chỉnh sửa trong Altium Designer. Các tham số dự án phía Workspace xuất hiện trong tab Parameter của hộp thoại Project Options với biểu tượng màu xanh lam , còn các tham số dự án phía thiết kế xuất hiện với biểu tượng màu cam
Tùy chọn/Điều khiển
-
Parameters Grid – vùng chính liệt kê tất cả các tham số hiện được xác định cho dự án, bao gồm:
- Name – tên tham số.
- Value – giá trị tham số.
-
Add – nhấp để mở hộp thoại Parameter Properties, nơi bạn có thể thêm tham số. Sử dụng các trường Name và Value tương ứng để đặt tên có ý nghĩa, phản ánh mục đích của tham số và nhập giá trị cho tham số đó. Cả hai trường đều cho phép tối đa 255 ký tự.
- Remove – nhấp để xóa các tham số đã chọn khỏi danh sách tham số. Tùy chọn này không khả dụng đối với các tham số dự án phía Workspace vì chúng chỉ có thể được xóa hoặc chỉnh sửa trong Workspace.
- Edit – nhấp để mở hộp thoại Parameter Properties, nơi bạn có thể sửa đổi nội dung của tham số hiện được chọn. Tùy chọn này không khả dụng đối với các tham số dự án phía Workspace vì chúng chỉ có thể được xóa hoặc chỉnh sửa trong Workspace.
- Refresh – nhấp để hoàn tác các thay đổi gần nhất đối với tham số dự án phía thiết kế. Đối với các tham số dự án phía Workspace, nhấp để đảm bảo bạn có phiên bản mới nhất của tham số. Những thay đổi đối với các tham số dự án phía Workspace được thực hiện trong Workspace sẽ không được phản ánh trong hộp thoại này cho đến khi sử dụng tùy chọn này.
Menu chuột phải
Các lệnh sau có sẵn trên menu chuột phải:
-
Edit – dùng để sửa đổi tham số hiện được chọn trong hộp thoại Parameter Properties. Lệnh này không khả dụng đối với các tham số dự án phía Workspace vì chúng chỉ có thể được xóa hoặc chỉnh sửa trong Workspace.
-
Add – dùng để thêm tham số phía thiết kế mới vào danh sách trong hộp thoại Parameter Properties.
-
Remove – dùng để xóa (các) tham số đã chọn khỏi danh sách. Lệnh này không khả dụng đối với các tham số dự án phía Workspace vì chúng chỉ có thể được xóa hoặc chỉnh sửa trong Workspace.
-
Copy – dùng để sao chép (các) tham số đã chọn vào bộ nhớ tạm của Windows.
-
Paste – dùng để dán (các) tham số từ bộ nhớ tạm của Windows vào danh sách tham số. Lệnh này không khả dụng đối với các tham số dự án phía Workspace vì chúng chỉ có thể được xóa hoặc chỉnh sửa trong Workspace.
Trang sơ đồ thiết bị

Tab Device Sheets của hộp thoại Project Options
Tab Device Sheets của hộp thoại Project Options cho phép bạn chỉ định các thư mục chứa trang sơ đồ thiết bị và thứ tự của chúng.
Tùy chọn/Điều khiển
- Main region - liệt kê các Device Sheet Folders đường dẫn của dự án hiện tại. Chọn Include Sub-folders để bao gồm các thư mục con của những thư mục cha được liệt kê.
- Move Up - dùng để di chuyển thư mục trang sơ đồ thiết bị đã chọn lên một bậc mỗi lần.
- Move Down - dùng để di chuyển thư mục trang sơ đồ thiết bị đã chọn xuống một bậc mỗi lần.
- Add - dùng để mở hộp thoại tìm kiếm thư mục mới cần thêm.
- Remove - dùng để loại bỏ thư mục trang sơ đồ thiết bị đã chọn.
OutputJobs được quản lý

Tab Managed OutputJobs của hộp thoại Project Options
Tab Managed OutputJobs của hộp thoại Project Options cho phép bạn cấu hình danh sách các mẫu tác vụ đầu ra có sẵn trong Workspace đang kết nối để sử dụng với dự án.
Tùy chọn/Điều khiển
- Outputjob List - liệt kê tất cả các tác vụ đầu ra trong Workspace theo Item Revision, Revision State, Description và Name.
- Add - nhấp để mở hộp thoại Select configuration item (Output Jobs) nhằm chọn (các) tác vụ đầu ra mong muốn.
- Remove - nhấp để loại bỏ (các) tác vụ đầu ra đã chọn.
Tùy chọn thư viện

Tab Library Options của hộp thoại Project Options
Tab Library Options của hộp thoại Project Options cho phép bạn chọn định dạng cho dự án thư viện tích hợp.
Tùy chọn/Điều khiển
-
Integrated Library Format
- Original - chọn để sử dụng định dạng thư viện tích hợp ban đầu. Định dạng này được dùng để tương thích với phần mềm Protel DXP (DXP 2002), trước khi Altium Designer ra đời.
-
Altium Designer- chọn để sử dụng Altium Designer làm định dạng thư viện tích hợp (được sử dụng trong tất cả các phiên bản phần mềm kể từ Altium Designer 2004 đầu tiên).
).
