Altium NEXUS Documentation

Cross-Probing and Selecting

Modified by Tiffany Cullen on Jun 6, 2019

Altium provides various powerful cross-probing and cross-selecting capabilities enabling fast, efficient navigation between schematic and PCB design domains. The Cross-Probing and Cross Selecting features are powerful search tools to help locate objects in other editors by selecting the object in the current editor.

Cross-probing is used to point to a chosen object on the current document then "jump to" its corresponding counterpart in the target document. Between the PCB and schematic editors, full cross-probing support is provided for documents, components, buses, nets, and pins/pads(s). Literally, with a single click, you can select a supported object in either domain and see it highlighted in both. 

Cross selecting enables you to select an object(s) on the source document and by enabling the cross select command, the same object(s) will be selected on the target document. 

Compilation and the Unified Data Model

When a project is compiled, a Unified Data Model (UDM) is created in the computer’s memory. The UDM models every aspect of the design, including the components, the connectivity, the component footprints, the relationships between the PCB project and a connected FPGA project, etc. It is this Unified Data Model that enables cross-probing functionality between different design domains. Many of the cross-probing features use auto-compilation, ensuring the very latest model of the data is being used. Compilation also can be performed manually at any time by clicking Project » Compile PCB Project.

Document Setup

Many of the features of Cross-Probing and Cross Selecting either require, or are more easily utilized, viewing both the schematic and PCB documents at the same time. You can view both documents at the same time by performing one of the following:

  • Right-click on the document tab then select Split Vertical or Split Horizontal depending on your viewing preference.
To close the split screen view, right-click on the document tab then select Merge All.
  • If you are using more than one screen, you can drag the document tab onto another monitor. 

Cross-Probing

The cross-probing feature is accessed from either the schematic or PCB editor using the Tools » Cross Probe command or by clicking the  button from an editor's Standard toolbar. 

The cross-probed objects on the target document will be displayed in accordance with the Dimming option defined on the System - Navigation page of the Preferences dialog. Dimming will not be applied to the originating document.
In order to perform cross-probing, ensure that the source schematic and PCB documents for the project are open as tabbed documents in the main design window. 

There are two cross-probing modes, Continuous Mode and Jump-To Mode, which are both described in the following sections.

Continuous Cross-Probing Mode

The Continuous Mode allows you to stay in the source document while cross-probing to different objects on the target document. For this mode, ensure that the schematic and PCB documents are open side-by-side in the main design window.

After launching the cross-probe command by clicking Tools » Cross Probe, the cursor will change to a cross-hair and you will be prompted to choose the object that you wish to navigate. Position the cursor over the required object within the workspace and click or press Enter. The corresponding object will be highlighted on the target document.

Cross-probing from the source (e.g., schematic) with corresponding object highlighted on the PCB.

You can continue to cross-probe additional objects or right-click or press Esc to exit.

When using Continuous Mode, if you have not opened the schematic and PCB documents side-by-side, you will have to make the PCB document active to view the results of the cross-probe.
When using Continuous Mode repeatedly, the last object you choose is the one displayed/highlighted. Cross-probe filtering is not cumulative.

Jump To Cross-Probing Mode

The Jump To Mode allows you to cross-probe to a single object and make the target document the active document. 

After launching the cross-probe command by clicking Tools » Cross Probe, the cursor will change to a cross-hair and you will be prompted to choose the object that you wish to navigate. Position the cursor over the required object within the workspace then Ctrl+click or press Ctrl+Enter. The corresponding object will be highlighted on the target document which will be made the active document.

Cross-Probing from Additional Locations in the Software

Cross-Probing also can be accomplished in various additional places in the software. These additional locations enable you to use the cross-probe function even as you are building your design without the need to use the Tools » Cross Probe command.

Probing Within the Engineering Change Order Dialog

You can cross probe from the Engineering Change Order dialog by right-clicking to access cross probe commands to locate the Reference component in the schematic or the target component in the PCB as shown in the image below:

Probing Within the Differences Between Dialog

The Differences between dialog can be used to cross-probe to a selected component on the schematic or PCB. Use the Project » Show Differences command to open the Differences between dialog. Double-click on an entry to cross probe to that component on the schematic or PCB.  

Note that the Choose Documents To Compare dialog will open if the documents have not previously been chosen. Click OK in the Choose Documents To Compare dialog to open the Differences between dialog. 

Cross-Probing From the Variant Management Dialog

You can use the Variant Management dialog to cross probe to a chosen component on the schematic or the PCB. Double-click on the component in the Variant Management dialog or right-click then select Cross Probe from the menu.

Probing Within the Differences Panel

To cross probe to the schematic or PCB from the Differences panel (click the Explore Differences button in the Differences between dialog to access this panel), double-click on an entry in the panel.

Probing Within the BomDoc

Cross-Probing also can be done within the BomDoc. In the BomDoc, right-click, choose Cross Probe then select to which item you wish to navigate from the sub-menu.

Cross Selecting

This feature facilitates dynamic, bi-directional component cross-selection. It is used to select corresponding objects between PCB and schematic documents. In other words, when you select an object on the PCB document, the same object on the source schematic document is also selected, and vice-versa.

This feature is accessed by:

  • Clicking Tools » Cross Select Mode from the main menus. This command toggles the feature on and off and the status of the command is displayed in the Tools menu. Cross Select Mode is enabled when a blue box appears around the Cross Select Mode icon in the Tools menu as shown in the image below.


Cross Select Mode in the Tools menu shown disabled (left) and enabled (right).

  • Checking or un-checking the Cross Selection option in the System - Navigation page of the Preferences dialog.
  • Clicking Shift+Ctrl+X.

To use the Cross Select Mode, the command must be enabled in both editors. 

With Cross Select Mode enabled, click to select one or more objects within the workspace. Those same objects will become selected on the corresponding document.

The target document will not be made the active document and it is therefore highly recommended to have both source and target documents open side-by-side.
Cross Select Mode behavior is controlled using the Cross Select Mode controls on the System - Navigation page of the Preferences dialog.
If a document is closed and then reopened, the project must be re-compiled before the Cross Select Mode feature will work correctly for objects on that document.

Selecting PCB Components from the Schematic

It is possible to cross-select between selected parts on one or more schematic source documents and the corresponding component footprints on the PCB document for the active project. As an example, this can be useful when selecting a set of parts on the source documents to create a new component class quickly on the PCB document.

To use this feature:

  • Ensure the target PCB document is open.
  • Select the required part(s) on the source schematic document(s).
  • Choose the Tools » Select PCB Components command.
This feature can also be accessed by clicking Part Actions » Select PCB Components from the right-click menu when the cursor is over the selected part (or one part in a selection of parts). If cross-selecting a single part using this method, the part need not be selected.

After launching the command, all schematic source documents will be automatically compiled and the PCB document for the project will then be made the active document. All corresponding component footprints for the selection will become selected and zoomed (but not masked) in the workspace.

Since the target PCB will become the active document, it is highly recommended to have the source schematic(s) and PCB document open side-by-side.

To create the new component class once the part or set of parts has been selected on the PCB using the Select PCB Components command:

  1. Click Design » Classes to open the Object Class Explorer dialog.
  2. Right-click Component Classes then select Add Class by right-clicking in the left column. Enter the desired name of the new class.
  3. Click the button between the Non-Members and Members region of the dialog to add the desired and selected part(s) to the right-hand column.
  4. Click Cancel to close the Object Class Explorer dialog and return to the workspace.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。