Altium NEXUS Documentation

SaveObject

Created: July 27, 2015 | Updated: December 11, 2020

Parent page: WorkspaceManager Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: ObjectKind=Document|SaveMode=Standard

Summary

This command is used to save the currently active document.

Access

This command can be accessed from the active document's editor by:

  • Choosing the File » Save command, from the main menus.
  • Clicking the  button on the editor's main toolbar.
  • Using the Ctrl+S keyboard shortcut.

Use

After launching the command, the active document will be saved.

Tips

  1. A modified document is flagged by an asterisk suffix next to its entry in the Projects panel. A modified document also has an asterisk next to its name in its open document tab (or on the associated pop-up menu if documents are grouped). In addition, modified documents are distinguished in the Projects panel through use of the  icon. To see this icon, click the drop-down part of the  button on the Projects panel, and enable the Show open/modified status option (part of the General cluster of options). This option can also be enabled from the System - Projects Panel page of the Preferences dialog.
  2. For schematic documents, if the current file format is not Binary Version 5.0, the File Format dialog will appear, from where you can choose the format in which to save. It is recommended to choose the option to save in SCH Binary Version 5.0. If you have used features that were not available in previous versions of Altium NEXUS, saving in an earlier format may result in loss of data.
  3. For PCB documents, if the current file format is not Binary Version 6.0, the File Format dialog will appear, from where you can choose the format in which to save. It is recommended to choose the option to save in PCB Binary Version 6.0. If you have used features that were not available in previous versions of Altium NEXUS, saving in an earlier format may result in loss of data.
  4. The active document can also be saved (if in a modified state) by using the corresponding command from its document tab - right-click on the tab to access a context menu of commands. Note that this command will not be available if multiple documents of the same type are open and currently grouped.


Applied Parameters: ObjectKind=Document|SaveMode=SaveAs

Summary

This command is used to save a copy of the currently active document with a new name and/or different format (where available), to a specified location on the hard disk.

Access

This command is accessed from the active document's editor by choosing the File » Save As command, from the main menus.

Use

After launching the command, the standard Windows Save As dialog appears. Use this dialog to browse to a particular destination in which to save the file, give the file a new name (if required) and also to select the format in which to store the file (where available).

The newly saved file will be opened in place of the original file as the active document.

Tips

  1. The parent project must be saved in order to point to the copy of the document the next time the project is opened, otherwise the project will include the original document still.


Applied Parameters: ObjectKind=Document|SaveMode=SaveCopyAs

Summary

This command is used to save a copy of the currently active document with a new name and/or different format (where available), to a specified location on the hard disk.

Access

This command is accessed from the active document's editor by choosing the File » Save Copy As command, from the main menus.

Use

After launching the command, the standard Windows Save A Copy Of dialog appears. Use this dialog to browse to a particular destination in which to save the file, give the file a new name (if required) and also to select the format in which to store the file (where available).

The newly saved file will not be opened in place of the original file.


Applied Parameters: ObjectKind=FocusedDocument|SaveMode=Standard

Summary

This command is used to save the currently focused document in the Projects panel.

Access

This command can be accessed from the Projects panel by:

  • Right-clicking on the entry for the required document and choosing the Save command, from the context menu.
  • Clicking to focus the required document, then clicking the Project button and choosing the Save command from the context menu.
The command will only be available provided the focused document is actually open, or open and hidden.

Use

First, ensure that the document you wish to save is actually open as one of the available tabbed documents in the main design window - it does not need to be made the active document.

After launching the command, the focused document will be saved.

Tips

  1. A modified document is flagged by an asterisk suffix next to its entry in the Projects panel. A modified document also has an asterisk next to its name in its open document tab (or on the associated pop-up menu if documents are grouped). In addition, modified documents are distinguished in the Projects panel through use of the  icon. To see this icon, click the drop-down part of the  button on the Projects panel, and enable the Show open/modified status option (part of the General cluster of options). This option can also be enabled from the System - Projects Panel page of the Preferences dialog.
  2. For schematic documents, if the current file format is not Binary Version 5.0, the File Format dialog will appear, from where you can choose the format in which to save. It is recommended to choose the option to save in SCH Binary Version 5.0. If you have used features that were not available in previous versions of Altium NEXUS, saving in an earlier format may result in loss of data.
  3. For PCB documents, if the current file format is not Binary Version 6.0, the File Format dialog will appear, from where you can choose the format in which to save. It is recommended to choose the option to save in PCB Binary Version 6.0. If you have used features that were not available in previous versions of Altium NEXUS, saving in an earlier format may result in loss of data.
  4. A non-active document can also be saved (if in a modified state) by using the corresponding command from its document tab - right-click on the tab to access a context menu of commands. Note that this command will not be available if multiple documents of the same type are open and currently grouped.


Applied Parameters: ObjectKind=FocusedDocument|SaveMode=SaveAs

Summary

This command is used to save a copy of the currently open document with a new name and/or different format (where available), to a specified location on the hard disk.

Access

This command can be accessed from the Projects panel by:

  • Right-clicking on the entry for the required document and choosing the Save As command, from the context menu.
  • Clicking to focus the required document, then clicking the Project button and choosing the Save As command from the context menu.
The command will only be available provided the focused document is actually open, or open and hidden.

Use

First, ensure that the document you wish to save is actually open as one of the available tabbed documents in the main design window - it does not need to be made the active document.

After launching the command, the standard Windows Save As dialog appears. Use this dialog to browse to a particular destination in which to save the file, give the file a new name (if required) and also to select the format in which to store the file (where available).

The newly saved file will be opened in place of the original file.

Tips

  1. The parent project must be saved in order to point to the copy of the document the next time the project is opened, otherwise the project will include the original document still.


Applied Parameters: ObjectKind=FocusedCategory|SaveMode=Standard

Summary

This command is used to save all documents that are currently open within the focused category (sub-folder) in the Projects panel.

Access

This command can be accessed from the Projects panel by:

  • Right-clicking on the entry for the required category (sub-folder) and choosing the Save All command, from the context menu.
  • Clicking to focus the required category (sub-folder), then clicking the Project button and choosing the Save All command from the context menu.
The command will only be available provided the focused category contains at least one document that is actually open, or open and hidden.

Use

First, ensure that the sub-folder whose documents you wish to save is focused in the Projects panel. Focus is given simply by clicking once on the folder's entry.

After launching the command, all documents residing within the focused sub-folder or descendant folders thereof, and that are currently open and/or open and hidden, will be saved.

Tips

  1. A modified document is flagged by an asterisk suffix next to its entry in the Projects panel. A modified document also has an asterisk next to its name in its open document tab (or on the associated pop-up menu if documents are grouped). In addition, modified documents are distinguished in the Projects panel through use of the  icon. To see this icon, click the drop-down part of the  button on the Projects panel, and enable the Show open/modified status option (part of the General cluster of options). This option can also be enabled from the System - Projects Panel page of the Preferences dialog.
  2. The affected documents are saved, irrespective of whether they have been modified or not.


Applied Parameters: ObjectKind=Project|SaveMode=SaveAs

Summary

This command is used to save a copy of the currently active project, with a new name (if required), and to a specified location on the hard disk.

Access

With a document for the required project open as the active document, this command is accessed from that document's editor by choosing the File » Save Project As command, from the main menus.

Use

First, ensure that one of the target project's associated design documents is open as the active document in the main design window.

After launching the command, the standard Windows Save As dialog appears. Use this dialog to browse to a particular destination in which to save the project file, and give the file a new name (if required).

The newly saved project will be opened in place of the original project as the active project.

Tips

  1. Only the project document is saved. The constituent design documents are not saved by this command.
  2. The project document can be placed anywhere on the hard disk - the paths to the constituent design files will be updated accordingly.


Applied Parameters: ObjectKind=FocusedProject|SaveMode=Standard

Summary

This command is used to save the currently focused project in the Projects panel.

Access

This command can be accessed from the Projects panel by:

  • Right-clicking on the entry for the required project and choosing the Save Project command, from the context menu.
  • Clicking to focus the required project, then clicking the Project button and choosing the Save Project command from the context menu.

Use

First, ensure that the project you wish to save is focused in the Projects panel.

After launching the command, the project will be saved.

Tips

  1. A modified project is flagged by an asterisk suffix next to its entry in the Projects panel. In addition, modified projects are distinguished in the Projects panel through use of the icon. To see this icon, click the drop-down part of the  button on the Projects panel, and enable the Show open/modified status option (part of the General cluster of options). This option can also be enabled from the System - Projects Panel page of the Preferences dialog.
  2. Only the project document is saved. The constituent design documents are not saved by this command.


Applied Parameters: ObjectKind=FocusedProject|SaveMode=SaveAs

Summary

This command is used to save a copy of the currently focused project in the Projects panel, with a new name (if required), and to a specified location on the hard disk.

Access

This command can be accessed from the Projects panel by:

  • Right-clicking on the entry for the required project and choosing the Save Project As command, from the context menu.
  • Clicking to focus the required project, then clicking the Project button and choosing the Save Project As command from the context menu.

Use

First, ensure that the required project is focused in the Projects panel.

After launching the command, the standard Windows Save As dialog appears. Use this dialog to browse to a particular destination in which to save the project file, and give the file a new name (if required).

The newly saved project will be opened in place of the original project.

Tips

  1. Only the project document is saved. The constituent design documents are not saved by this command.
  2. The project document can be placed anywhere on the hard disk - the paths to the constituent design files will be updated accordingly.


Applied Parameters: ObjectKind=Workspace

Summary

This command is used to save the current Design Workspace (*.DsnWrk).

Access

This command can be accessed by:

  • Clicking the Workspace button in the Projects panel, then choosing the Save Design Workspace command, from the context menu.
  • Choosing the Project » Design Workspace » Save Design Workspace command, from the main menus.

Use

After launching the command, the active Design Workspace will be saved.

Tips

  1. A modified design workspace is flagged by an asterisk suffix next to its entry in the Projects panel.
  2. The currently open Design Workspace is identified in the top field of the Projects panel.
  3. Only the Design Workspace document is saved (*.DsnWrk). The constituent projects and their design documents are not saved by this command.
  4. A default Design Workspace (Workspace1.DsnWrk) is assigned to the Projects panel when:
    1. No specific Design Workspace has been opened.
    2. The creation of a new Design Workspace is specified.
    3. When all open projects and documents - part of a specific Design Workspace or not - are closed.

This default Design Workspace is initially unsaved and so use of this command will behave like the Save Design Workspace As command. Its name is used as the default entry in the Save As dialog, when you proceed to save the Design Workspace.


Applied Parameters: ObjectKind=Workspace|SaveMode=SaveAs

Summary

This command is used to save a copy of the currently active Design Workspace in the Projects panel, with a new name (if required), and to a specified location on the hard disk.

Access

This command can be accessed by:

  • Clicking the Workspace button in the Projects panel, then choosing the Save Design Workspace As command, from the context menu.
  • Choosing the Project » Design Workspace » Save Design Workspace As command, from the main menus.

Use

After launching the command, the standard Windows Save As dialog appears. Use this dialog to browse to a particular destination in which to save the Design Workspace file, and give the file a new name (if required).

The newly saved Design Workspace will be opened in place of the original Design Workspace.

Tips

  1. Only the Design Workspace document is saved (*.DsnWrk). The constituent projects and their design documents are not saved by this command.
  2. The Design Workspace document can be placed anywhere on the hard disk - the paths to the constituent project files will be updated accordingly.


Applied Parameters: ObjectKind=All|ModifiedOnly=True

Summary

This command is used to save all open projects and documents that have been modified. If an existing Design Workspace is open, this will be saved too, if its project membership has changed.

Access

This command can be accessed by:

  • Choosing the File » Save All command, from an editor's main menus.
  • Choosing the Project » Design Workspace » Save All command, from an editor's main menus.
  • Clicking the Workspace button in the Projects panel, then choosing the Save All command, from the context menu.

Use

After launching the command, all open projects and documents that are detected as having been modified, will be saved.

If the open projects are part of an existing (previously saved) Design Workspace, and project membership has changed (projects added or removed since last save), then the Design Workspace document (*.DsnWrk) will also be saved.

Tips

  1. A modified entity (document, project, design workspace) is flagged by an asterisk suffix next to its entry in the Projects panel. A modified document also has an asterisk next to its name in its open document tab (or on the associated pop-up menu if documents are grouped). In addition, modified documents and projects are distinguished in the Projects panel through use of the  and  icons respectively. To see these icons, click the drop-down part of the  button on the Projects panel, and enable the Show open/modified status option (part of the General cluster of options). This option can also be enabled from the System - Projects Panel page of the Preferences dialog.
  2. Saving is carried out in the order: Documents in project ---> Project documents ---> Design Workspace document.
  3. For schematic documents, if the current file format is not Binary Version 5.0, the File Format dialog will appear, from where you can choose the format in which to save. It is recommended to choose the option to save in SCH Binary Version 5.0. If you have used features that were not available in previous versions of Altium NEXUS, saving in an earlier format may result in loss of data.
  4. For PCB documents, if the current file format is not Binary Version 6.0, the File Format dialog will appear, from where you can choose the format in which to save. It is recommended to choose the option to save in PCB Binary Version 6.0. If you have used features that were not available in previous versions of Altium NEXUS, saving in an earlier format may result in loss of data.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。