Altium NEXUS Documentation

SetupPreferences

Modified by Jason Howie on Apr 11, 2017

Parent page: WorkspaceManager Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: NoGrouping=True

Summary

This command is used to turn off grouping in the Projects panel.

Access

This command can be accessed by:

  • Clicking the Workspace button in the Projects panel, then choosing the Project Panel » Grouping » No Grouping command, from the context menu.
  • Choosing the Project » Design Workspace » Project Panel » Grouping » No Grouping command, from the main menus.

Use

After launching the command, document grouping will be turned off in the Projects panel. Within each project that is open, all documents will be listed on the same, single level, beneath the parent project entry (structure will still be reflected for source documents of hierarchical designs). The documents will appear in the order defined by the sorting option chosen for the panel.

Tips

  1. Grouping controls for the panel can also be accessed from the System - Projects Panel page of the Preferences dialog.
  2. Grouping controls can also be accessed by clicking the drop-down part of the  button on the Projects panel, and switching to the Grouping cluster of options.


Applied Parameters: GroupByClass=Toggle

Summary

This command is used to group documents by class in the Projects panel.

Access

This command can be accessed by:

  • Clicking the Workspace button in the Projects panel, then choosing the Project Panel » Grouping » By Class command, from the context menu.
  • Choosing the Project » Design Workspace » Project Panel » Grouping » By Class command, from the main menus.

Use

After launching the command, documents in the Projects panel will be grouped by class. Within each project, source design documents will appear directly underneath the project, with all other documents grouped together into document classes, such as:

  • Settings - this class would feature setting-based documents, such as Ouput Job Configuration files, Harness Definition files, and the board Annotation file.
  • Libraries - this class would feature all libraries added to the project (SchLib, PcbLib, etc).
  • Generated - this class would feature output generated from the source documents (e.g. fabrication outputs, assembly outputs, netlists, reports, and so on).
  • Documentation - this class would feature any documentation-based documents (e.g. text documents added to the project).

The class groupings will appear in the order defined by the sorting option chosen for the panel.

Tips

  1. Grouping controls for the panel can also be accessed from the System - Projects Panel page of the Preferences dialog.
  2. Grouping controls can also be accessed by clicking the drop-down part of the  button on the Projects panel, and switching to the Grouping cluster of options.


Applied Parameters: GroupByType=Toggle

Summary

This command is used to group documents by type in the Projects panel.

Access

This command can be accessed by:

  • Clicking the Workspace button in the Projects panel, then choosing the Project Panel » Grouping » By Type command, from the context menu.
  • Choosing the Project » Design Workspace » Project Panel » Grouping » By Type command, from the main menus.

Use

After launching the command, documents in the Projects panel will be grouped by type. Within each project, documents will first be grouped together into classes, such as:

  • Source Documents - this class would feature all source design documents for the project (e.g. schematic sheets and PCBs).
  • Settings - this class would feature setting-based documents, such as Ouput Job Configuration files, Harness Definition files, and the board Annotation file.
  • Libraries - this class would feature all libraries added to the project (SchLib, PcbLib, etc).
  • Generated - output generated from the source documents (e.g. fabrication outputs, assembly outputs, netlists, reports, and so on).

The constituent documents will then be further grouped according to their type, for example:

  • Settings - sub-folders including Annotation Documents, Harness Definition Files, Ouput Job Files, and so on.
  • Libraries - sub-folders including Schematic Library Documents, PCB Library Documents, Pad Via Library Documents, and so on.

The sub-folder groupings will appear in the order defined by the sorting option chosen for the panel.

Tips

  1. Grouping controls for the panel can also be accessed from the System - Projects Panel page of the Preferences dialog.
  2. Grouping controls can also be accessed by clicking the drop-down part of the  button on the Projects panel, and switching to the Grouping cluster of options.


Applied Parameters: SortByOrder=True

Summary

This command is used to sort projects and their documents, by project order, in the Projects panel.

Access

This command can be accessed by:

  • Clicking the Workspace button in the Projects panel, then choosing the Project Panel » Sort By » Project order command, from the context menu.
  • Choosing the Project » Design Workspace » Project Panel » Sort By » Project order command, from the main menus.

Use

After launching the command, all currently open projects and their documents will be sorted by project order in the Projects panel. Project order is determined in accordance with the positional numbering assigned to each document.

Tips

  1. Sorting will initially be carried out in ascending order. Launch the command again to sort in descending order. The level of sorting is as follows:
    1. Sort all documents in sub-folders such that positional numbering is kept sequential.
    2. Sort all sub-folders such that positional numbering is kept sequential.
  2. Sorting controls for the panel can also be accessed from the System - Projects Panel page of the Preferences dialog.
  3. Sorting controls can also be accessed by clicking the drop-down part of the  button on the Projects panel, and switching to the Sorting cluster of options.


Applied Parameters: SortByName=True

Summary

This command is used to sort projects and their documents, alphabetically, in the Projects panel.

Access

This command can be accessed by:

  • Clicking the Workspace button in the Projects panel, then choosing the Project Panel » Sort By » Alphabetically command, from the context menu.
  • Choosing the Project » Design Workspace » Project Panel » Sort By » Alphabetically command, from the main menus.

Use

After launching the command, all currently open projects and their documents will be sorted alphabetically in the Projects panel.

Tips

  1. Sorting will initially be carried out in ascending order. Launch the command again to sort alphabetically in descending order. The level of sorting is as follows:
    1. Sort all open projects alphabetically.
    2. Sort all sub-folders within a project alphabetically.
    3. Sort all documents within a sub-folder alphabetically.
  2. Sorting controls for the panel can also be accessed from the System - Projects Panel page of the Preferences dialog.
  3. Sorting controls can also be accessed by clicking the drop-down part of the  button on the Projects panel, and switching to the Sorting cluster of options.


Applied Parameters: SortByStatus=True

Summary

This command is used to sort projects and their documents, by document open/modified status, in the Projects panel.

Access

This command can be accessed by:

  • Clicking the Workspace button in the Projects panel, then choosing the Project Panel » Sort By » Status command, from the context menu.
  • Choosing the Project » Design Workspace » Project Panel » Sort By » Status command, from the main menus.

Use

After launching the command, all currently open projects and their documents will be sorted according to document open/modified status, in the Projects panel.

Tips

  1. Sorting will initially be carried out in ascending order. Launch the command again to sort in descending order. The level of sorting is as follows:
    1. Sort all open projects such that status precedence is satisfied.
    2. Sort all sub-folders within a project such that status precedence is satisfied.
    3. Sort all documents within a sub-folder such that status precedence is satisfied.
  2. The status precedence (highest to lowest) for ordering purposes is as follows:
    1. Modified (Project document only)
    2. Open/Modified
    3. Open
    4. Hidden
  3. When more than one project, sub-folder, or document within a sub-folder have the same status, alphabetical ordering will be applied.
  4. Sorting controls for the panel can also be accessed from the System - Projects Panel page of the Preferences dialog.
  5. Sorting controls can also be accessed by clicking the drop-down part of the  button on the Projects panel, and switching to the Sorting cluster of options.


Applied Parameters: SortByVCSStatus=True

Summary

This command is used to sort projects and their documents, by document VCS status, in the Projects panel.

Access

This command can be accessed by:

  • Clicking the Workspace button in the Projects panel, then choosing the Project Panel » Sort By » VCS Status command, from the context menu.
  • Choosing the Project » Design Workspace » Project Panel » Sort By » VCS Status command, from the main menus.

Use

After launching the command, all currently open projects and their documents will be sorted according to document VCS status, in the Projects panel.

Tips

  1. Sorting will initially be carried out in ascending order. Launch the command again to sort in descending order. The level of sorting is as follows:
    1. Sort all sub-folders within a project such that VCS status precedence is satisfied.
    2. Sort all documents within a sub-folder such that VCS status precedence is satisfied.
  2. The VCS status precedence (highest to lowest) for ordering purposes is as follows:
    1. Conflict
    2. Locked by me
    3. Locked by someone else
    4. Modified
    5. Modified and locked by me
    6. No modification
    7. Out of date
    8. Not in version control
    9. Scheduled for addition
    10. Scheduled for deletion
  3. When more than one sub-folder, or document within a sub-folder have the same VCS status, alphabetical ordering will be applied.
  4. Sorting controls for the panel can also be accessed from the System - Projects Panel page of the Preferences dialog.
  5. Sorting controls can also be accessed by clicking the drop-down part of the  button on the Projects panel, and switching to the Sorting cluster of options.


Applied Parameters: ShowPosition=Toggle

Summary

This command is used to toggle the display of document position information, in the Projects panel.

Access

This command can be accessed by:

  • Clicking the Workspace button in the Projects panel, then choosing the Project Panel » Show » Position command, from the context menu.
  • Choosing the Project » Design Workspace » Project Panel » Show » Position command, from the main menus.

Use

After launching the command, position information for each document within an open project in the Projects panel will be shown or hidden, depending on whether the option to display position was previously disabled or enabled.

Tips

  1. Each document in a project is given a position number, starting from 1, assigned as it is added to the project. As you drag and drop documents within a project (or between projects) the positional information will update accordingly.
  2. Positional information can also be toggled from the System - Projects Panel page of the Preferences dialog, using the Show document position in project option.
  3. Positional information can also be toggled by clicking the drop-down part of the  button on the Projects panel, switching to the General cluster of options, and using the Show document position in project option.


Applied Parameters: ShowStatus=Toggle

Summary

This command is used to toggle the display of document open/modified status, in the Projects panel.

Access

This command can be accessed by:

  • Clicking the Workspace button in the Projects panel, then choosing the Project Panel » Show » Status command, from the context menu.
  • Choosing the Project » Design Workspace » Project Panel » Show » Status command, from the main menus.

Use

After launching the command, open/modified status information for each document in the Projects panel will be shown or hidden, depending on whether the option to display status was previously disabled or enabled.

Tips

  1. There are four document status indicators used in the Projects panel:
    1.  - the document is currently open as a tabbed-document in the main design window.
    2.  - the document is currently hidden.
    3.  - the document is both currently open and has been modified (yet to be saved).
    4.  - this icon is used in two instances. First, it appears next to the main project document, to show that the project has been modified (yet to be saved). It also appears for a document that is both currently hidden, and has been modified (yet to be saved).
  2. A closed document is represented by no icon.
  3. All schematic source documents for a PCB's parent project are required to be open for compilation and comparison (the latter requires the PCB to be open too). These documents are opened and automatically hidden in order to prevent clutter in the tabbed area of the main design window. When a document is hidden, it is still open from the point of view of processes such as compilation/synchronization/annotation, It is just not displayed as a tabbed-document in the main design window. When a project is opened, and the first schematic sheet is opened, the PCB document will always be opened and hidden.
  4. A modified entity (document, project, design workspace) is flagged by an asterisk suffix next to its entry in the Projects panel. A modified document also has an asterisk next to its name in its open document tab (or on the associated pop-up menu if documents are grouped).
  5. Hovering the mouse over an icon will display textual confirmation of the document's status.
  6. Status information can also be toggled from the System - Projects Panel page of the Preferences dialog, using the Show open / modified status option.
  7. Status information can also be toggled by clicking the drop-down part of the  button on the Projects panel, switching to the General cluster of options, and using the Show open / modified status option.


Applied Parameters: ShowVCSStatus=Toggle

Summary

This command is used to toggle the display of document VCS status, in the Projects panel.

Access

This command can be accessed by:

  • Clicking the Workspace button in the Projects panel, then choosing the Project Panel » Show » VCS Status command, from the context menu.
  • Choosing the Project » Design Workspace » Project Panel » Show » VCS Status command, from the main menus.

Use

After launching the command, VCS status information for each document in the Projects panel will be shown or hidden, depending on whether the option to display VCS status was previously disabled or enabled.

Tips

  1. The following document VCS status indicators are used in the Projects panel:
    1.  - No modification.
    2.  - Modified.
    3.  - Out of date.
    4.  - Conflict.
    5.  - Locked by me.
    6.  - Locked by someone else.
    7.  - Modified and locked by me.
    8.  - Scheduled for addition.
    9.  - Scheduled for deletion.
  2. A document that is not in Version Control is represented by no icon.
  3. Hovering the mouse over an icon will display textual confirmation of the document's VCS status.
  4. VCS status information can also be toggled from the System - Projects Panel page of the Preferences dialog, using the Show VCS status option.
  5. VCS status information can also be toggled by clicking the drop-down part of the  button on the Projects panel, switching to the General cluster of options, and using the Show VCS status option.


Applied Parameters: ObjectKind=OutputPreferences

Summary

This command is used to configure the properties of the currently selected output container, or print job, in the active Output Job Configuration file.

Access

With the required output container/print job selected, this command can be accessed from the OutputJob Editor by:

  • Choosing the Tools » Container Setup command, from the main menus.
  • Using the Ctrl+Shift+O keyboard shortcut.

Use

First, ensure that the output container/print job that you wish to configure is selected, in the Output Containers region, or Hard Copy region of the main job configuration window, respectively.

After launching the command, the applicable settings dialog will appear. Use the dialog to manage and configure the properties of the selected output container/print job, which will be applied when generating output from its linked output generators.

Tips

  1. The associated settings dialog can also be accessed by clicking on the Change link, at the top-right of the container/print job's entry in the Output Containers/Hard Copy region.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。