Altium Designer Documentation

Defining the Board Shape

Modified by Susan Riege on Feb 12, 2018
The Board Shape defines the boundary, or extents, of the board in the PCB Editor. The Board Shape is PCB object that is also referred to as the Board Outline and is essentially a closed polygon. When you create a new PCB document, it is the black area with the visible grid showing inside (assuming the grid is coarse enough to see at the current zoom level).


The default 6" by 4" board

The Board Shape is used by Altium Designer when:

  • Splitting a board into multiple board regions.
  • Placing bending lines on a flex board region.
  • Defining the extents of the power planes for plane edge pull back.
  • Splitting power planes.
  • Calculating the board edge when outputting design data to other tools

When a new board file is created, the default Board Shape is sized 6000 x 4000mil. The shape can be resized, or redefined, in a variety of ways. Note that PCB documents created using the PCB templates have the Board Shape already correctly sized. Regardless of the final make up of the board (single rigid area or multiple rigid-flex sections), the overall outer shape is referred to as the Board Shape.

Creating and Modifying the Board Shape

The Board Shape can be redefined:

  • Manually - by redefining the shape or moving the existing board vertices (corners). Switch to Board Planning Mode (View » Board Planning Mode) then use the Redefine, Edit or Move Board Shape commands in the Design menu.
  • From selected objects - typically done from an outline on a mechanical layer. Use this option if an outline has been imported from an MCAD tool as a DWG/DXF file. Switch to 2D Layout Mode (View » 2D Layout Mode), select the primitives on the mechanical layer (Edit » Select » All on Layer), then use the Design » Board Shape » Define from selected objects command.
  • From a 3D body - use this option if the blank board has been imported as a STEP model from an MCAD tool into a 3D Body Object (Place » 3D Body). Switch to 3D Layout Mode (View » 3D Layout Mode) then use the command in the Design » Board Shape sub-menu to select the Board Shape.

Importing an Outline to Use for the Board Shape


Ensure that the scale, default line width, and layer mappings are configured when importing DXF/DWG data.

You can set the Board Shape to match the shape defined by a set of objects on one of the PCB Editor's mechanical layers. Using this feature in combination with the ability to import DWG or DXF data from a mechanical CAD package provides a method of transferring the Board Shape requirements from the mechanical CAD domain into Altium Designer.

To import a DXF/DWG file into a newly created PCB:

  1. Select File » New » PCB.
  2. The new blank PCB will open. The black region represents the current Board Shape. Before importing a new shape, set the following as required to suit the requirements of your design and the shape being imported:
    • The Units - set in the Other section of the Properties panel in Board mode.

  • The Grid - set in the Grid Manager section of the Properties panel in Board mode.

  • The Origin - click Edit » Origin » Set from the main menus then click to define the location of the origin. It helps to set this to suit the location of the origin in the incoming outline.
  1. Now, import the board's shape as a .DXF or .DWG file. Please note that the shape to be imported must be a closed shape and internal cutouts are not automatically created (but can be defined later from imported objects).
  2. Select File » Import » DXF/DWG to open the Import File dialog, ensure the File Type on the bottom right of the dialog is AutoCAD Files (*.DXF,*DWG) then browse to find the required file. 
  3. When the Open button is clicked the Import from AutoCAD dialog will open.
  4. Set the Scale, Default Line Width and Layer Mappings as required then click OK.
  5. Each DXF/DWG object will be mapped to an object and will be displayed in the workspace. 

There is now a closed boundary defined on a mechanical layer, which can be use to define the board shape.

Defining the Board Shape From Selected Objects

As mentioned, once an enclosed boundary of line and/or arc objects has been defined, these objects can be used to create the board shape.

To define a board shape from these objects:

  1. Set the View mode to 2D Layout Mode (View menu).
  2. Select the objects (the Edit » Select » All on Layer command is ideal for this).
  3. Run the Design » Board Shape » Define from selected objects command - the board shape will be redefined to the selected objects and the display updated.

The software will attempt to find the shape based on the centerline of the selected objects. If the coordinates for the end of one track/arc segment do not exactly match the coordinates of the next track/arc segment then the boundary identification algorithm will fail and a message will be displayed showing the failure location. It will offer to use a tracing algorithm instead. Note that the tracing algorithm follows the outer edge of the track/arc objects so the board shape will be slightly different than the one created from the centerlines. Only choose this option if your design can accept the impact of this difference.

Defining the Board Shape from a 3D Body

This feature redefines the board shape based on a surface (face) of an imported 3D STEP model. It can be used to quickly create a complex board shape and helps integration between electronic and mechanical design areas. This is a two-stage process: first the STEP model is imported, then the required shape is selected from the STEP model. 

To do this:

  1. Switch to View » 3D Layout Mode.
  2. To import the STEP model (.step or .stp) place a 3D body (Place » 3D Body), then in the 3D Body mode of the Properties panel, select Generic in the 3D Model Type region. Select Embed Model or Link to Models in the Source region to import the required STEP model. Note that this STEP model can be deleted once the board shape has been redefined.
  3. Select Design » Board Shape » Define from 3D body.
  4. The Status bar will prompt you to Pick a 3D body. Click the imported 3D body to select it.
  5. The cursor will change to a crosshair and the Status bar will prompt you to Choose Face. As you hover the cursor over each face, it will be outlined. Click to select the correct face.
  6. The Board Outline Creation Successful dialog will appear, displaying options on how you want the imported 3D model positioned in relation to the newly-defined board shape. These can be ignored if you are planning on deleting the STEP model, otherwise configure the options as required.

Note that if you keep the STEP model embedded in or linked to the PCB file you will be notified whenever the STEP file changes. You will also be prompted to update the shape - a handy feature if the shape is still under development and updates are expected.


Defining the board shape from an imported STEP model.

Only surfaces aligned with the X-Y plane can be used to create the board shape. If you select a model surface that requires alignment in the X-Y plane, you will be asked in a Confirmation dialog to align the surface before you can continue. This dialog also allows you to place the model using the selected face in relation to either the top or bottom surface of the board. This means that the vertical position of the model can also be set at the same time. After alignment you will need to select Design » Board Shape » Define from 3D Body again. After the board shape has been redefined, you will be given the option to hide the 3D body.

Modifying or Redefining the Board Shape

In Board Planning Mode you can modify the board shape by moving the vertices or completely redraw (redefine) it. Refer to the Board Shape object to learn more.

Redefining the Board Shape Using Jump Location

To accurately define the shape based on a set of dimensions, you can use the Jump Location shortcut keys instead of the mouse. To do this:

  1. Set the origin to define the location of the bottom left of the PCB (Edit » Origin » Set).
  2. Select Design » Redefine Board Shape and release the mouse.
  3. Press the J key to open the Jump submenu. 

Press the O key to jump to the origin you just defined. Press Enter to define the first corner of the new board shape.

  1. Press J, L to open the Jump to Location dialog.

The X-Location field will be active; type in the X location of the next corner of the board (do not touch the mouse).

  1. Press the Tab key to move to the Y-Location field in the Jump to Location dialog then type in the appropriate Y value.
  2. Press Enter to accept the values and close the dialog. The cursor will be at the correct location. Do not touch the mouse; press the Enter key again to define this corner.
  3. Press J, L again to open the Jump to Location dialog. Type in the next X coordinate, press Tab, type in the Y coordinate, press Enter to accept the values then press ENTER to define this corner.
  4. Repeat this process until all corners are defined, finishing back at the 0, 0 origin. Again, do not touch the mouse; press Enter.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
Request Free Trial

Complete this form to request a free 15 day trial of Altium Designer: