Altium Designer Documentation

Getting Familiar with the Altium Design Environment

Created: December 25, 2023 | Updated: January 17, 2024
Applies to Altium Designer version: 24

Altium Designer brings a complete electronic product development environment, catering for all aspects of the electronic development process, including front-end design and capture, mixed-signal circuit simulation, physical PCB design, etc.

This page discusses basic working techniques with Altium Designer so you can quickly start your next product design.

Main UI Elements

Altium Designer uses UI elements common to other Windows applications and CAD tools. The main of those are shown below and described afterward.

Javascript

Design space – the main region of the application window where the active document is shown. In the design space, you can explore the document's content (e.g., a schematic document, as shown in the above image) and work with it.

Panels – provide access to different features and functionalities related to the active project or document. Panels can be accessed from the menu of the Panels button at the bottom right of the design space.

Main menus – provide you with access to commands for working with the current document type. The set of available menus and commands depends on the type of the currently active document.

Active Bar – always shown at the top of the design space of the current document, the Active Bar provides handy access to the most commonly used commands, such as commands for placing and selecting objects.

Quick Access Bar – provides you with access to high-level operations, such as saving documents and undoing/redoing actions.

Learn more about these and other elements of the Altium Designer environment: Elements of the Environment.

Signing in to Your Altium Account

In order to access Altium on-demand services, such as On-Demand licensing and connection to an Altium 365 Workspace, you must be signed in to your Altium account from Altium Designer. When you are not signed in to your Altium account, the Current User control at the top-right of the design space is presented as . To sign in, click the control and select the Sign In entry on the associated menu. Use the subsequent Sign In dialog that appears to enter your Altium account credentials, then click the Sign in button. The control will change to your Altium profile picture (e.g., ).

Learn more about available signing in options: Signing in to Your Altium Account.

Connecting to Your Altium 365 Workspace

When signed in to your Altium account, you can connect to an available Altium 365 Workspace to access its features and data. To do so, click on the Active Workspace Control at the top-right of the design space (when you are not connected to a Workspace, the control is presented as ). In the subsequent menu, click the entry for the Altium 365 Workspace you wish to connect to. The control will change to reflect the name of the connected Workspace (e.g., ).

Learn more about available connection options: Accessing Your Workspace.

Setting Up the Environment

The Preferences dialog is a central location in which you can set up global system settings across different functional areas of Altium Designer. To access the Preferences dialog, click the  icon at the top-right of the design space.

Click a page entry on the left-hand side of the dialog to show its options on the right-hand side of the dialog. For convenience, pages are clustered into categories for function areas (System, Data Management, Schematic, etc.).

Learn more about Altium Designer preferences: Accessing, Defining & Managing System Preferences.

Working with Design Projects and Documents

The starting point for every design created in Altium Designer is a project. An Altium Designer project is a set of design documents whose output defines a specific implementation. As well as storing links to each document in the project, the project file also stores project-specific options, such as error check settings.

Altium Designer supports the PCB, Multi-board and Harness types of design projects. Below is a brief description of each.

In a Printed Circuit Board (PCB) project, the electronic circuit is captured as a schematic, which is built up from libraries of component symbols that are placed and wired together.

The design is then transferred to the PCB editor where each component is instantiated as a footprint (pattern) and the circuit wiring becomes point-to-point connection lines. A shape for the final PCB is defined, along with the physical layers the board will include. Design rules specify the layout requirements, such as routing widths and clearance. The components are positioned within the board shape, and the connection lines are then replaced by routing.

When the design is complete, standard format output files are generated which can be used to fabricate the blank board, configure an assembly machine, and so on.

In a Multi-board project, the logical design is captured using a schematic document that connects together sub-project modules, which in turn represent existing PCB projects. The Multi-board schematic data is then transferred to a Multi-board assembly document where the physical board assemblies, as defined by the sub-projects, are positioned together and within an added enclosure.

A Multi-board project (*.PrjMbd) effectively defines the electrical and physical connectivity between existing PCB design projects through the application of a logical schematic document (*.MbsDoc) and synchronized assembly document (*.MbaDoc).

Note that Multi-board design functionality is not supported with the Altium Designer Standard Subscription.

The Harness Design functionality allows engineers of various types (involved in the Product Design process) to work in Altium Designer. It brings comprehensive harness design support into the same environment as PCB and system design, removing the previous heavy reliance on third-party software.

The Harness Design functionality allows you to create a full wiring harness design, from the individual pin-to-pin connections right through to manufacturing documentation. A harness design can be created as a standalone project, or as part of a Multi-board project. In the latter case, the logical connections between PCBs in the Multi-board project are used to define the connectivity within the harness.

Note that Harness Design functionality is not supported with the Altium Designer Standard Subscription.
Learn more about Harness Design.

The most of project management operations (creating, opening, etc.) are performed using the File main menu and the Projects panel.

Javascript

To create a new design project, select the File » New » Project command from the main menus. In the Create Project dialog that opens, select the location where you want to create the project, the type of the project, and other options such as project name, storage folder, etc. After clicking the Create button, the entry of the new project will appear in the Projects panel.

All project-related data is stored in documents, which are also referred to as files. To add a new document to a project, right-click the project's entry in the Projects panel and select a required document type in the Add New to Project menu.

Note that a newly created document is initially unsaved. Use the right-click menu of the document's entry in the Projects panel to save it. Similarly, use right-click menu of the project's entry in the Projects panel to save it when the project is changed (e.g., when its structure is changed by adding a new document).

To open an existing project, use the File » Open Project command from the main menus and the subsequent Open Project dialog. The structure of the opened project will appear in the Projects panel.

Double-click a document entry in the panel to open this document in the design space.

The icons next to the project and document entries in the Projects panel provide a visual summary of their open/modified and version control status.

When working with a document of a "graphical" type (e.g., a schematic sheet or PCB document), you can zoom and pan the document to focus on a specific document area. The basic shortcuts that can be used to do this are:

  • Ctrl+Mouse Wheel or Middle-Click, Hold&Drag to zoom in and out
  • Right-Click, Hold&Drag or Mouse Wheel or Shift+Mouse Wheel to slide the document around

The video below demonstrates use of these shortcuts.

To learn more about working with projects and documents, refer to the following pages:

Working with Design Objects

Creation of a document, be it a schematic sheet, PCB, or drawing, is essentially placing objects in the required arrangement and setting their properties. The main placement and editing techniques common for most Altium Designer editors are listed below.

  1. To place an object, select the corresponding placement command from the main menus or the Active Bar. For example, to place a wire in a schematic sheet, select the Place » Wire command from the main menus or click the  icon in the Active Bar.
  2. After selecting a placement command, you will enter the placement mode indicated by a crosshair under the cursor. Position the cursor in the design space, then left-click to place the object. For complex objects, such as wires or polygons, you must continue the position-and-click procedure to place all vertices of the object.
  3. When in placement mode, press Tab to open to edit the object's properties in the Properties panel that opens, before placing the object. Once you have finished setting the properties, click the  button in the design space to return to placement mode. 
  4. To end placement mode, right-click.
  5. To edit the properties of a placed object, select it by clicking on it in the design space. Its properties will be shown in the Properties panel. If the panel is not open, double-click the object to select it and open the panel.

The video below demonstrates the object placement process and editing its properties.

Getting Help

Altium Designer provides various ways for you to locate additional information and help. 

  • Press F1 over any object, editor, panel, menu entry, or button to open the documentation for that item.
  • Press Shift+F1 while running a command for a list of shortcuts you can use in that command.
  • Use the navigation tree on the left side of the documentation to read about a particular subject ( show image).

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: