Altium Designer Documentation

Multi-board Design Improvements

Modified by Susan Riege on Dec 15, 2018

New 3D Graphics Engine Supports Mates

Underlying this release of Altium Designer is a powerful new 3D engine. This engine prepares the way for substantial improvements in many areas of the software, including multi-board design.

One of the benefits the new 3D engine brings is the ability to introduce more MCAD-like design capabilities in the Multi-board Assembly editor. The first feature to be introduced is Mates. Objects are no longer related by aligning and positioning them, now they are mated.

In mechanical CAD software, the concept of relating two objects in space is a fundamental part of the design process - a process known as mating those two objects. When two objects have been mated they can be manipulated as a single object. These mated objects can then be mated to another object, and through this process a set of discrete objects are formed into an assembly - the very essence of mechanical design.

Opening a Multi-board Assembly Created in a Previous Version of Altium Designer

Multi-board assemblies created in a previous version of Altium Designer must be imported, due to file format changes required to support the new 3D engine and the improved feature set.

When an old-format MbaDoc is opened the Legacy document import dialog will appear:

Select the Design » Import command in the Multi-board Assembly editor to generate ECOs that will re-load the child modules. This process may take some time, as the improved Multi-board Assembly editor now loads the entire PCB file data.

Because of the file format changes required to support the improved feature set and the new 3D engine, a multi-board assembly saved in this release of Altium Designer can not be opened in older versions of Altium Designer - if this is attempted it will open as an empty document.

Multi-board Assembly Editor UI Changes

In line with the schematic and PCB editors, the Multi-board Assembly editor now includes an Active Bar.

Mode controls are located on the Active Bar, including Mating mode, Measurement mode, and Section Plane features.

Click to enter Mating mode. The cursor will highlight potential mate sites on each surface, as the cursor is moved over the surface. Two mating sites on different objects must be nominated, these will be bought together after the second one is chosen. Press Esc to exit Mating mode.
Click to enter Measurement mode. Click one object and then click a second object, the distance between their closest edges/surfaces will be displayed. Further measurements can be made as you will remain in Measurement mode. Press Ctrl+M to remain in Measurement mode but clear existing measurements, press Esc to exit Measurement mode and clear the display of all measurements. Press Q to toggle the measurement units.
Click to enter Section View mode. The board will be sectioned along the Section Plane, with all objects in front of the plane being hidden. Click the button a second time to exit Section View.
Click to display the Section Plane. Use the Section Plane Gizmo to re-orient the plane, hover the cursor to change the color of one of the Gizmo's control lines from orange to yellow, then click, hold and drag on that control to re-orient the Section Plane. Click the button a second time to hide the Section Plane.

Working with Mates

Mate: a connection formed between 2 separate objects. The connection is at a user-selected point on a surface on each object, once mated the objects will re-orient so their surface planes and their perpendicular axes are aligned.

  • Target - the first site nominated as a Mate site.
  • Source - the second site nominated, this object will move to mate with the Target.
  • Mating axis - the perpendicular axis passing through the center of the Mate.
  • Mates are defined by entering Mating mode, and then interactively defining the Target and Source mating sites.
  • A mate can be modified by selecting it in the Mates section of the Multiboard Assembly panel, and then editing its properties in the Mates mode of the Properties panel.

Select the Mate of interest in the panel, edit its setting in the Properties panel. In the workspace, the white circle indicates the Mating location, the purple line indicates the mating axis.

Most of the editing actions, such as rotating or modifying the distance, can be performed using hotkeys - these are detailed in the Mates mode of the Properties panel.

Defining a Mate

To define a Mate:

  1. Click the  button on the Active Bar to switch to Mating mode (Tools » Mating, Shift+Ctrl+A shortcut). The mating process requires 1 click to define each mate site but  further clicks can be used when needed, as described in the green highlight box below.
  2. While in mating mode, hover the cursor over an object to be mated. As the cursor is positioned over a surface on the object, that surface will change color (to gray), and display potential mate sites (glyphs).
    • On a planar surface select from 9 glyphs, located at the center, corners and mid points of the bounding rectangle.
    • On a cylindrical surface select from 2 glyphs, located along the axis, at each end of the cylinder.
  3. Each glyph is a potential mate site, the glyph that is currently closest to the cursor is highlighted by a larger green dot. Click the cursor anywhere over the surface to accept the highlighted glyph as the first mate site. This is the Target for the Mate. Once selected, the Target is marked by a purple dot.
  4. As the cursor is moved off the surface it will go green, indicating that the Target lies on that surface.
  5. Repeat this process on the second object to define the second mate site (the Source). The Source is highlighted using a brown dot.
  6. As soon as the Source is defined, the Source object will move so that the Source site and the Target site are mated (located together), with their surface planes and perpendicular axes aligned. The Mate location is indicated by a circular arc which remains visible through other objects (when the Mate is selected), and the perpendicular axis of the mate location is displayed using a dashed purple line.
  7. When objects are mated they are locked together, and move as a single object.
  8. To modify an existing Mate, select it in the Multiboard Assembly panel, then edit its values in the Properties panel. 

Tips:

  • The Status bar indicates when you are in mating mode.
  • If it is difficult to select a glyph, for example selecting the center of a hole in an object (demonstrated in the video below), or the wrong glyph was selected, you can change the Target glyph before moving on to define the Source glyph.
  • As the cursor continues to be moved over the plane containing the Target, each glyph highlights in green when it becomes closest to the cursor. The current Target remains highlighted in purple. If a different glyph is required, position the cursor to highlight it in green, then left-mouse click to nominate it.
  • If it is not possible to define a Mate on a mounting screw, hide the screw (right-click on the object in the Multiboard Assembly panel) and use the screw hole instead.
  • The second mate site must be located on a different object from the first mate site. If a second surface is selected on the same object as the first mate site, the action is interpreted as choosing a new first mate site.
  • Mated objects can be mated to a third object.
  • The workspace view can be changed while you are defining a Mate:

    • Ctrl+Right click and drag to zoom in/out
    • Shift+Right click and drag to pivot the workspace view around the click location.
  • Press Esc to abort the mating process and drop out of Mating mode.

Simple demonstration of defining a Mate between a nut and a screw.The Status bar indicates when when you are in mate definition mode, or mate editing mode.

Modifying a Mate

To modify a Mate, select it in the Multiboard Assembly panel and then use the Properties panel to adjust its settings. Note that the Status bar indicates when the mate is in editing mode.

To modify a Mate, first select it in the Mates section of the Multiboard Assembly panel, then edit it in the Properties panel.

  • A new Mate defaults to Auto.
  • There are 3 modes the Mate can be configured as:
    • Auto - the Mate is locked in all directions, dragging either object will move both. Using the edit fields in the panel, the Source can be Offset in the X & Y directions across the Target mating plane, and the Distance can also be adjusted along the mating axis.
    • Plane-to-Plane - the Mate is locked along the mating axis, but can be interactively dragged across the X/Y plane. Use the edit field to adjust the Distance , moving the Source along the mating axis.
    • Axis-to-Axis - the Mate is locked in the X/Y plane, but can be interactively dragged along the mating axis. Using the edit fields in the panel, the Source can be Offset in the X & Y directions of the mating plane, the Target remains stationary.
  • The hotkeys (detailed in the Help section of the panel) provide an efficient way of adjusting a locked mate. A hotkey can be held, it is not necessary to press the key repeatedly.
  • Once the objects have been correctly positioned, set the mode to Auto to ensure that their location relationship is not inadvertently changed by dragging an object in the workspace.
  • To remove a Mate, right-click on it in the Multiboard Assembly panel and select Remove Mate from the context menu, or select it in the panel and press the Delete key on the keyboard.

Viewing and Defining a Section Plane

The Section Plane Gizmo is used to move the plane, the highlighted Gizmo line shows which direction the plane will move when you click and drag.

  • There are two aspects to working with a Section View, first locate and orient the Section Plane, then enable the Section View mode.
  • Click the button to toggle the Section Plane visibility on and off (View » Toggle Section Plane Visibility, shortcut Shift+Ctrl+E).
  • Use the Section Plane Gizmo to move or re-orient the Section Plane by clicking and dragging on the required Gizmo line or arc, as shown in the image above. The plane can be moved when the Section View mode is on, if required.
  • Click the  button to switch the Section View mode on, when it is on all objects in front of the plane are hidden. Click again to switch Section View mode off (View » Toggle Section View, shortcut Shift+Ctrl+V).

Enhanced Collision Testing

Utilizing the new 3D engine, collision testing times have been substantially reduced. Collisions are flagged whenever two objects have surfaces that touch or intersect. Mated surfaces are not considered to be colliding.

  • To check for collisions select Tools » Check Collisions (Ctrl+K shortcut), all collisions will be detailed in the Messages panel.
  • If required, collision violation markers can be cleared by selecting the Tools » Clear Violations command.

Support for Rigid-Flex

The Multi-board assembly editor now supports rigid-flex PCBs. The multi-board assembly editor displays the PCB in the final folded state, as defined in the PCB editor.

Export to MCAD

To export the entire assembly in either STEP 3D or Parasolid format, select File » Export » STEP 3D or File » Export » Parasolid from the menus.

The STEP file of the Multi-board assembly opened in the Rhinoceros MCAD editor.

Additional New Commands

  • Toggle Project Type - use this command to switch the Assembly editor display from Perspective to Orthographic view (View menu, P shortcut).
  • Lock / Unlock Selected Part - use this command to lock the selected part (or mated parts) at its current location in the Assembly editor workspace (right-click menu).
    • Parts that are locked are marked with a padlock icon in the Multiboard Assembly panel.
    • A locked individual part does not display a Gizmo (mated parts never show a Gizmo).
    • A locked part cannot be mated if it is selected as the Source (the object that moves).
  • Toggle Units - toggles the units displayed in a measurement between imperial and metric (Q shortcut).

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.