Altium Designer Documentation

Zoom

Modified by Susan Riege on Jul 21, 2018

Parent page: PCB Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: Action = All

Summary

This command is used to display all design objects on the current document.

Access

This command can be accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Fit Document command (from the PCB Editor or PCB Library Editor) or the View » Fit All Objects command (from the PCB Library Editor) from the main menus.
  • Clicking the  button on the PCB Standard toolbar (PCB Editor), or PCB Lib Standard toolbar (PCB Library Editor).
  • Using the Ctrl+PgDn keyboard shortcut.
  • Pressing the V key in the workspace to access the View pop-up menu then choosing the Fit Document command (from the PCB Editor and PCB Library Editor), or Fit All Objects command (from the PCB Library Editor).
  • Pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the All command.
In the PCB Library Editor, the command can also be accessed by right-clicking in the workspace then choosing either the View » Fit Document command or the View » Fit All Objects command from the context menu.

Use

After launching the command, the view in the main design window will change to present all design objects in the workspace.


Applied Parameters: Action = Document

Summary

This command is used to display all electrical design objects on the current document.

Access

This command is accessed from the PCB Editor by:

  • Choosing the View » Fit Board command from the main menus.
  • Pressing the V key in the workspace to access the View pop-up menu, then choosing the Fit Board command.

Use

After launching the command, the view of the main design window will change to display all electrical design objects.


Applied Parameters: Action = Board

Summary

This command is used to display all objects that are part of the 2D footprint aspect of the active library component (PCB Library document), or all electrical objects on the current board (PCB document).

Access

This command is accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Fit Document command from the main menus.
  • Pressing the V key in the workspace to access the View pop-up menu, then choosing the Fit Document command.
  • Pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the Board command.

Use

After launching the command, the view of the main design window will change to display:

  • PCB Editor - all electrical design objects.
  • PCB Library Editor - all design objects that consitute the 2D footprint aspect of the component.

Tips

  1. In the PCB Library Editor, the view will not extend to include any defined 3D Body objects, that are placed beyond the extents of the objects used to define the 2D footprint.


Applied Parameters: Action = Area

Summary

This command is used to zoom into a user-defined area of the current document.

Access

This command can be accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Area command from the main menus.
  • Clicking the  button on the PCB Standard toolbar (PCB Editor) or PCB Lib Standard toolbar (PCB Library Editor).
  • Pressing the V key in the workspace to access the View pop-up menu, then choosing the Area command.
In the PCB Library Editor, the command can also be accessed by right-clicking in the workspace then choosing the View » Area command from the context menu.

Use

After launching the command, the cursor will change to a cross-hair and you will be prompted to select the first corner of the zoom window. Position the cursor then click or press Enter to anchor this corner. You will then be prompted to select the second corner. Move the cursor to size the zoom area then click or press Enter to anchor this second corner. The display will change with the specified area centered in the main design window.


Applied Parameters: Action = Window

Summary

This command is used to zoom into a user-defined area of the current document.

Access

This command can be accessed from the PCB Editor and PCB Library Editor by pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the Window command.

Use

After launching the command, the cursor will change to a cross-hair and you will be prompted to select the first corner of the zoom window. Position the cursor then click or press Enter to anchor this corner. You will then be prompted to select the second corner. Move the cursor to size the zoom area then click or press Enter to anchor this second corner. The display will change with the specified area centered in the main design window.


Applied Parameters: Action = Point

Summary

This command is used to redefine the display area about a specified point in the current document.

Access

This command is accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Around Point command from the main menus.
  • Pressing the V key in the workspace to access the View pop-up menu then choosing the Around Point command.
  • Pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the Point command.
In the PCB Library Editor, the command can also be accessed by right-clicking in the workspace then choosing the View » Around Point command from the context menu.

Use

After launching the command, the cursor will change to a cross-hair and you will be prompted to select the center point of a zoom window. Position the cursor then click or press Enter to anchor this center point. You will then be prompted to select the corner of the zoom window. Move the cursor to size the zoom area then click or press Enter to anchor the corner. The display will change with the specified area centered in the main design window around the specified center point.


Applied Parameters: Action= Selected

Summary

This command is used to change the view in the main design window so that all selected objects are visible.

Access

This command is accessed from the PCB Editor, and PCB Library Editor by:

  • Choosing the View » Selected Objects command from the main menus.
  • Pressing the V key in the workspace to access the View pop-up menu then choosing the Selected Objects command.
  • Pressing the Z key in the PCB Editor workspace to access the Zoom pop-up menu then choosing the Selected command.
  • Clicking the  button on the PCB Standard toolbar (PCB Editor).
  • Right-clicking in the PCB Library Editor workspace then choosing the View » Selected Objects command from the context menu.

Use

First, ensure that all objects that you want to zoom in upon are selected.

After launching the command, the view in the main design window will change to fit all selected objects. Depending on the number of objects selected and their respective locations, the selection will be zoomed and centered in the window.


Applied Parameters: Action= Filtered

Summary

This command is used to change the view of the main design window to fit all objects that come under the scope of the currently applied filter.

Access

This command is accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Filtered Objects command from the main menus.
  • Pressing the V key in the workspace to access the View pop-up menu then choosing the Filtered Objects command.
  • Pressing the Z key in the PCB Editor workspace to access the Zoom pop-up menu then choosing the Filtered command.
  • Clicking the  button on the PCB Standard toolbar or Filter toolbar (PCB Editor).
  • Right-clicking in the PCB Library Editor workspace then choosing the View » Filtered Objects command from the context menu.

Use

After launching the command, the view of the main design window will change to fit all design objects that come under the scope of the applied filter query.

Tips

  1. Adjust the level of masking applied to all objects not falling under the scope of the filter by using the Masked Objects slider bar located in the Mask and Dim Settings section on the View Options tab of the View Configuration panel.
  2. Filtering can be quickly cleared by using the Shift+C keyboard shortcut.


Applied Parameters: Action = In

Summary

This command is used to bring the design closer to you, relative to the cursor position, in the current document.

Access

This command is accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Zoom In command from the main menus.
  • Using the PgUp keyboard shortcut.
  • Pressing the V key in the workspace to access the View pop-up menu then choosing the Zoom In command.
  • Pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the In command.
  • Right-clicking in the PCB Library Editor workspace and choosing the View » Zoom In command from the context menu.
The command can also be accessed in the PCB Library Editor by clicking the  button on the PCB Lib Standard toolbar.

Use

Launch the command to zoom in on a particular section of the design. Use the command repeatedly to zoom in to a greater extent.

Tips

  1. As this command is relative to the cursor position, it is a good idea to position the cursor in the desired location prior to launching the command. To use the command effectively, use the shortcut or use the accelerator keyboard sequence: V, I (or Z, I).
  2. This command can be used through its respective keyboard shortcut even while another process is running (for example, while in placement mode).
  3. You can use the mouse to zoom in to a region of the document by one of the following methods (where applicable and depending on how the buttons of your mouse might be assigned):
    1. Hold the Ctrl key and roll the mouse wheel upward. Use of the Ctrl key is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
    2. Hold both the Ctrl key and the right-mouse button, then move the mouse forward.
    3. Hold the right (first) and left (second) mouse buttons, then move the mouse forward.
    4. Click and hold the mouse wheel, then move the mouse forward.


Applied Parameters: Action = MicroIn

Summary

This command is used to bring the design closer to you, relative to the cursor position, in the current document.

Access

This command is accessed from the PCB Editor and PCB Library Editor by using the Shift+PgUp keyboard shortcut.

Use

Launch the command to zoom in on a particular section of the design. Use the command repeatedly to zoom in to a greater extent, and in progressively smaller steps.

Tips

  1. As this command is relative to the cursor position, it is a good idea to position the cursor in the desired location prior to launching the command.
  2. This command can be used even while another process is running (for example, while in placement mode).
  3. You can use the mouse to zoom in to a region of the document by one of the following methods (where applicable and depending on how the buttons of your mouse might be assigned):
    1. Hold the Ctrl key and roll the mouse wheel upward. Use of the Ctrl key is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
    2. Hold both the Ctrl key and the right-mouse button, then move the mouse forward.
    3. Hold the right (first) and left (second) mouse buttons, then move the mouse forward.
    4. Click and hold the mouse wheel, then move the mouse forward.


Applied Parameters: ZoomLevel = 4.0

Summary

This command is used to set the magnification of the current document to 400%.

Access

This command is accessed from the PCB Editor and PCB Library Editor by using the Ctrl+PgUp keyboard shortcut.

Use

After launching the command, the view of the current document will be set to a magnification of 400%, centered around the current cursor location.

Tips

  1. As this command is relative to the cursor position, it is a good idea to position the cursor in the desired location prior to launching the command.
  2. This command can be used even while another process is running (for example, while in placement mode).
  3. You can use the mouse to zoom in to a region of the document by one of the following methods (where applicable and depending on how the buttons of your mouse might be assigned):
    1. Hold the Ctrl key and roll the mouse wheel upward. Use of the Ctrl key is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
    2. Hold both the Ctrl key and the right-mouse button, then move the mouse forward.
    3. Hold the right (first) and left (second) mouse buttons, then move the mouse forward.
    4. Click and hold the mouse wheel, then move the mouse forward.


Applied Parameters: Action = Out

Summary

This command is used to move the design away from you, relative to the cursor position, in the current document.

Access

This command is accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Zoom Out command from the main menus.
  • Using the PgDn keyboard shortcut.
  • Pressing the V key in the workspace to access the View pop-up menu then choosing the Zoom Out command.
  • Pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the Out command.
  • Right-clicking in the PCB Library Editor workspace then choosing the View » Zoom Out command from the context menu.
The command can also be accessed in the PCB Library Editor by clicking the  button on the PCB Lib Standard toolbar.

Use

Launch the command to zoom out from a particular section of the design. Use the command repeatedly to zoom out to a greater extent.

Tips

  1. As this command is relative to the cursor position, it is a good idea to position the cursor in the desired location prior to launching the command. To use the command effectively, use the shortcut or use the accelerator keyboard sequence: V, O (or Z, O).
  2. This command can be used, through its respective keyboard shortcut, even while another process is running (for example, while in placement mode).
  3. You can use the mouse to zoom out from a region of the document by one of the following methods (where applicable and depending on how the buttons of your mouse might be assigned):
    1. Hold the Ctrl key and roll the mouse wheel downward. Use of the Ctrl key is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
    2. Hold both the Ctrl key and the right-mouse button then move the mouse backward.
    3. Hold the right (first) and left (second) mouse buttons then move the mouse backward.
    4. Click and hold the mouse wheel then move the mouse backward.


Applied Parameters: Action = MicroOut

Summary

This command is used to move the design away from you, relative to the cursor position, in the current document.

Access

This command is accessed from the PCB Editor and PCB Library Editor by using the Shift+PgDn keyboard shortcut.

Use

Launch the command to zoom out from a particular section of the design. Use the command repeatedly to zoom out to a greater extent, and in progressively larger steps.

Tips

  1. As this command is relative to the cursor position, it is a good idea to position the cursor in the desired location prior to launching the command.
  2. This command can be used even while another process is running (for example, while in placement mode).
  3. You can use the mouse to zoom out from a region of the document by one of the following methods (where applicable and depending on how the buttons of your mouse might be assigned):
    1. Hold the Ctrl key and roll the mouse wheel downward. Use of the Ctrl key is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
    2. Hold both the Ctrl key and the right-mouse button then move the mouse backward.
    3. Hold the right (first) and left (second) mouse buttons then move the mouse backward.
    4. Click and hold the mouse wheel then move the mouse backward.


Applied Parameters: None

Summary

This command is used to change the magnification of the display of the current document by a specified value.

Access

This command is accessed from the PCB Editor and PCB Library Editor by pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the Select command.

Use

After launching the command, the Zoom Value (0.001x..4x) dialog will appear. Enter the required zoom level (magnification) required then click OK. The view of the main design window will update in accordance with the chosen magnification.

Tips

  1. Values greater than 1 are entered in order to zoom in to a greater extent (increase magnification). Values less than 1 are used to zoom out to a greater extent (decrease magnification).
  2. You can use the mouse to zoom in to or zoom out from a region of the document by one of the following methods (where applicable and depending on how the buttons of your mouse might be assigned):
    1. Hold the Ctrl key and roll the mouse wheel upward or downward. Use of the Ctrl key is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
    2. Hold both the Ctrl key and the right-mouse button then move the mouse forward or backward.
    3. Hold the right (first) and left (second) mouse buttons then move the mouse forward or backward.
    4. Click and hold the mouse wheel then move the mouse forward or backward.


Applied Parameters: Action = RedrawCurrent

Summary

This command is used to redraw the current layer of the current document to remove any undesirable drawing update effects.

Access

This command is accessed from the PCB Editor and PCB Library Editor by:

  • Using the Alt+End keyboard shortcut.
  • Pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the Current command.

Use

After launching the command, the main design window is refreshed and the content of the current layer is redrawn.

Tips

  1. This command does not affect the current view setting of the main design window.


Applied Parameters: Action = Last

Summary

This command is used to return the display to the previous view of the screen in the current document.

Access

This command is accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » Zoom Last command from the main menus.
  • Pressing the V key in the workspace to access the View pop-up menu then choosing the Zoom Last command.
  • Pressing the Z key in the workspace to access the Zoom pop-up menu then choosing the Last command.
In the PCB Library Editor, the command can also be accessed by right-clicking in the workspace then choosing the View » Zoom Last command from the context menu.

Use

After launching the command, the main design window will show the previous view of the current document. Use the command repeatedly to toggle back and forth between current and previous views.


Applied Parameters: Action = Pan

Summary

This command is used to redraw the view in the main design window, placing the location marked by the cursor - prior to launching the command - at the center of the window.

Access

This command is accessed from the PCB Editor and PCB Library Editor by using the Home keyboard shortcut.

Use

After launching the command, the location in the workspace directly underneath the cursor prior to the launch will be centered in the main design window.

Tips

  1. The zoom-level remains unchanged when using this command. If the present zoom-level does not allow for the centering of the location, the document will be horizontally scrolled so that the location is horizontally centered in the main design window.
  2. Hold the right mouse button down to display the slider (panning) hand cursor then drag to move your view of the workspace.


Applied Parameters: Action = Redraw

Summary

This command is used to refresh the screen, in effect performing a redraw of the current document, to remove any undesirable drawing update effects.

Access

This command is accessed from the PCB Editor and PCB Library Editor by using the End keyboard shortcut.

Use

After launching the command, the main design window is refreshed and the content of the window is redrawn.

Tips

  1. This command does not affect the current view setting for the workspace.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.