Single Component Editing

Now reading version 19.0. For the latest, read: Single Component Editing for version 24
 

Parent page: Managed Components

A managed component is defined/edited using the Component Editor, which can operate in two modes - Single Component Editing and Batch Component Editing. The former provides a streamlined interface when defining/editing a single component. This is the default mode when creating a new Component Item, or editing a single revision of an existing Component Item. The latter provides the interface for defining/editing multiple components, but can be used to define/edit a single component, should you wish.

This document looks at working with the Component Editor in its Single Component Editing mode.

The Component Editor in this mode is accessed when creating/editing a component through the Components panel, or Explorer panel. It is also directly accessed by using the File » New » Component command, from the main menus.
For more information on working with the Component Editor in its Batch Component Editing mode, see Component Editor - Batch Component Editing Mode.

Facilitating the Functionality

This Single Component Editing functionality is delivered through a purpose-made extension for the Component Editor - the Single Component Editor extension.

The Single Component Editor extension.The Single Component Editor extension.

This feature is only made available, provided the Single Component Editor extension is installed as part of your Altium Designer installation. This extension is installed by default when installing the software, but in case of inadvertent uninstall, can be found back on the Purchased tab of the Extensions & Updates page (click on the current user control (e.g. ) at the top-right of the workspace and choose Extensions and Updates from the menu).

Interface Overview

In its Single Component Editing mode, the Component Editor interface is essentially divided into four main regions, illustrated in the following image and summarized thereafter.

The Component Editor, when operating in its Single Component Editing mode, can be divided into four key regions.The Component Editor, when operating in its Single Component Editing mode, can be divided into four key regions.

  1. Component - where you define key properties of the component, including its Name, Description, unique Id, resident Folder, Type, and reference to any Component Template as required.
  2. Models - where you add links to released domain models, for use by the component.
  3. Parameters - where you craft a set of parametric data that will be applied to the component. This can include parameters from a referenced Component Template, as well as additional user-defined parameters. Links to website URLs can also be added here, as well as datasheets.
  4. Part Choices - where you can search for, and add Part Choices for the component; the real world manufacturer parts that you want to be used for the design component when the board is manufactured and assembled.

Component

This region provides controls for defining the following component attributes:

  • Name - reflects the humanly-readable name given to the component. This system parameter is available and indexed when searching within the server and will provide a good means to locate specific components beyond having to remember their Item ID!

As you start typing the name, a pop-up listing of available manufacturer parts - from the managed content server's Local Part Catalog - will appear. You can select an entry to quickly define your component, either fully (all information), with parameters only (parameters and part choices), or just use the name. This creation from manufacturer part search facility is also available by pressing the  button at the far right side of the field. For more information, see Creating the Component from a Manufacturer Part Search.

The field will populate with any default value for the Name system parameter that has been defined in a referenced Component Template.
  • Description - reflects the description added to the component. This system parameter is available and indexed when searching within the server.
The field will populate with any default value for the Description system parameter that has been defined in a referenced Component Template. Also, if the component is being created from a manufacturer part search, and the Use all data option is chosen, the Description field will be populated with the description from that chosen part.

In addition, and by clicking the Advanced Settings control, you get access to the following:

  • Id - this field is used to determine the ID used for the released Component Item in the server. For a new component created through the File » New » Component command or the Components panel, this field is populated in accordance with the component template defined for the component type chosen in the Create new component dialog. Where a template does not exist, or where the <Undefined> entry is chosen in the dialog, a default naming scheme is used; CMP-{00000}. For a new component created through the Explorer panel, this field is populated in accordance with the default naming scheme specified for that component's parent folder. If the parent folder has a component template attached, then defined Component Naming will be brought in from that template. The software will automatically assign the next available unique ID, based on that scheme, having scanned the entire server and identifiers of existing Items.

Alternatively, you can override the auto-assigned ID for the component by entering the ID required directly in the Id field. You always have full control and final say over how the Items are identified.

This field will be read-only if the component has already been released.
  • Folder - use this field to release the component to a specific folder in the target server. For a new component created through the File » New » Component command or the Components panel, this field is populated in accordance with the component template defined for the component type chosen in the Create new component dialog. Where a template does not exist, or where the <Undefined> entry is chosen in the dialog, this field is blank. For a new component created through the Explorer panel, this field is populated with that component's parent folder. You have full control over where in the target server a component will be stored. To manually specify a target folder, click the  button to access the Choose Folder dialog. Browse to, and choose an existing folder, or create a new one on-the-fly.
Taking the time to carefully determine the folder path for your component ensures it is released into the correct destination folder from the outset. However, Items can be easily moved to any folder in the server structure, post release, if need be.
This field will be read-only if the component has already been released.
  • Template - this field provides the ability to reference a defined Component Template. Click on the field to access a listing of all Component Template Items currently available in the active managed content server (to which you are signed in). Click on an entry to create a link to the indicated (latest) revision of that Component Template Item. Template information will be brought into the Component Editor (Name, Description, Id naming format, Folder, Type, Models, and Parameters). For more information, see Referencing a Component Template.
  • Type - this field supports the ability to define the type of component and is a key attribute used to facilitate targeted searching of managed components. When browsing your own managed components using the Components panel, the Categories grouping for managed components is derived from the component type defined for each component. Click on the field to access a listing of currently defined component types from which to choose. The types are defined at the preferences level. Click the  button at the right of the field to access the Data Management - Component Types page of the Preferences dialog, from where you can craft this listing to better suit your needs - either by adding new types and sub-types, or editing and removing existing types.
It is also possible to change the component type for one or more components after release to a completely different type, on-the-fly. In the Components panel or Explorer panel, select the component(s) that you want to change, then right click and choose the Operations » Change Component Type command from the context menu. The Component Type dialog will appear from which you can select the new component type.
The field will populate with any default value for the ComponentType parameter that has been defined in a referenced Component Template, or with the component type selected through the Create New Component dialog, which appears when you attempt to create a new managed component.

Models

This region of the editor is used to add links to released domain models, for use by the component.

At the most basic level, a component used in board design requires representation in the schematic and PCB editing domains. It therefore needs schematic symbol and PCB footprint models.

The Models region, providing the controls to define the models required to represent the component in the Schematic, PCB and Simulation domains.The Models region, providing the controls to define the models required to represent the component in the Schematic, PCB and Simulation domains.

Use the following collapsible sections to learn more about working with models.

Parameters

This region of the editor is used to add parametric data to the component. Three types of parameter can be manually added here:

  •  Parameter - a standard, user-defined parameter.
  •  Link - a URL link to the page of a web site, for example a manufacturer's website, or an online datasheet.
  •  Datasheet - providing a link to a datasheet (in any format) that is (has been) uploaded to the server and referenced by the component.

The Parameters region, providing the controls for adding parametric data to the component.The Parameters region, providing the controls for adding parametric data to the component.

Any number of these parameter types may be added as required. To do so, click the drop-down part of the  button at the bottom of the region, then choose the relevant entry from the menu. A new parameter will be added to the list as follows:

  • Parameter - will be added below the currently selected entry in the list. The name will be in the default format Parameter n, click on the Name field to change this as required. Click on the Value field and type the value as required.
  • Link - will be added at the bottom of the list. Click on the Name field and enter the required name. This will be presented on the right-click References sub-menu, when accessed for a placed instance of the component on a schematic sheet. Type (or paste) the URL for the target page into the Value field. This will become a hyperlink, with which to access the target.
  • Datasheet - a standard Windows Open dialog will appear, with which to browse to, and select, the required datasheet. Multiple datasheets can be added simultaneously through this dialog. Each datasheet will be added at the bottom of the list. The Name will initially be that of the file itself, and is presented in the Explorer panel, and also in the References sub-menu for a component, after it is placed on a schematic sheet. Change this to a more suitable caption as required. The Value will be the file, in terms of its name, format, and size on disk. This will be a hyperlink, with which to quickly access the datasheet.
Clicking the  button directly (not accessing its drop-down menu) will add a standard Parameter. To remove a parameter, select it in the list (multiple parameters can be selected for removal) and click the  button.
The Parameters region can also be populated with parametric data from a part found by conducting a Manufacturer Part Search. For more details, see Creating the Component from a Part Search.

Attaching Datasheets through Drag and Drop

In addition to the manual attachment through the Open dialog mentioned in the previous section, you can also attach one or more datasheets to the component in the following ways:

  • By dragging and dropping from Windows File Explorer to anywhere within the Parameters region.

Example demonstrating attachment of datasheets from a local drive, and then editing the local caption for the main datasheet. Example demonstrating attachment of datasheets from a local drive, and then editing the local caption for the main datasheet.

  • By dragging and dropping a datasheet link from a web page in an external web browser, to anywhere within the Parameters region.

Example demonstrating attachment of a datasheet from a web page. Example demonstrating attachment of a datasheet from a web page.

Template Parameters

In addition, if the component references a Component Template, then any parameters defined in that template will be brought in, and added to the Parameters region.

Example parameters from a referenced Component Template Item.Example parameters from a referenced Component Template Item.

Things to note:

  • A standard template parameter (not marked as Read-only or Required) is distinguished in the Parameters region by use of the  icon.
  • A template parameter marked as Read-only is distinguished in the Parameters region by use of the  icon.
  • A template parameter marked as Required is distinguished in the Parameters region by use of the  icon.
  • An existing user-defined parameter that has the same name as a parameter in the linked Component Template Item, will be replaced with the template version. Any existing value for that parameter will be kept (and not overwritten with the value in the template).
  • The value fields for template-based parameters that have been marked as read-only, will be non-editable. For all other template-based parameters, that have not been marked as read-only, you are free to change the values as required.
  • If a template-based parameter has been marked as Required, but has not been given a value in the template, its value field will contain the  icon, alerting you to the fact that a value is required for this parameter. You will not be able to release a component until values are defined for all required parameters.
Template Parameters cannot be removed.

Support for Unit-aware Component Parameter Data Types

The Component Editor supports unit-aware component parameter data types that are defined within a referenced Component Template. You can enter a parameter's value directly into the applicable field using a range of formats - such as 2.2k, 2k2, 4M, 2.5GHz - with the managed content server engineered with the requisite smarts to recognize the numerical value behind those entries.

This feature of a component template facilitates targeted searching through the server's Search facility - a facility that not only allows you to search by component type, but allows you to search smarter, with range searches. Using the power of unit-aware component parameters, you can quickly define a search, for example, to find all capacitors with a capacitance between 47uF and 220uF.

Unit-aware parameters are also used for smart filtering when searching through your own managed components using the Components panel.
Unit-aware data types for component parameters can only be defined through a component template.

Component parameters from a referenced component template that have unit-aware data types.Component parameters from a referenced component template that have unit-aware data types.

When entering a value for a component parameter that uses a unit-aware data type, the following are things to consider:

  • You can enter the value in a range of different formats: 
    • Numerical value only (e.g. 10). Note that if the data type has a unit, this will be applied automatically. Those types with units, have the unit in brackets after their name.
    • Numerical value in scientific notation (e.g. 1e10, 1E6).
    • Numerical value and units (e.g. 10F).
    • Numerical value with prefix (e.g. 10k). The appropriate unit will automatically be added (where applicable).
    • Numerical value with prefix and units (e.g. 10kF).
    • Numerical value with prefix in typical engineering format (e.g. for a resistance: 2k2, 2K2, 10r2, 10R2). The value will automatically be normalized accordingly (e.g. 2K2 will become 2.2k).
  • You can enter prefix and/or units with or without a space after the numerical value (e.g., 10uF, or 10 uF). The space will be automatically stripped.
Note that engineering abbreviations are case insensitive, so entering 2k2 is the same as entering 2K2, and entering 100R is the same as entering 100r. The only exception is M (Mega) and m (milli).

Item Level Parameters

Altium Designer (in conjunction with Altium 365 Workspace or self-managed Altium Concord Pro) supports the concept of Item level parameters. These are parameters that are added to the parent Component Item, and available to all its released revisions, without having to re-release the Item into a new revision to pick up those parameters. As such, they are often referred to as Dynamic Parameters. This feature allows for component updates without having to create new component revisions, which in turn would affect related designs in which those components are used. An example might be a cost parameter change - applied dynamically on-the-fly as it were.

This functionality is available when instigated through a connected enterprise system instance (or through use of the CSV uploader when connected to self-managed Concord Pro). When defining parametric attributes through the relevant configuration file, you can determine whether a parameter should be pushed to the item, or the revision, with the latter being the default. For more information, see Component Synchronization with Enterprise Systems. (Altium 365 Workspace), or Component Synchronization with Enterprise Systems (self-managed Concord Pro).

Item-level, or dynamic parameters can be viewed when editing a Component Item revision. Note that they are only visible when using the Component Editor in its Single Component Editing mode.

Example Item level parameter that has been added to a Component Item, and available to its revisions.Example Item level parameter that has been added to a Component Item, and available to its revisions.

Note that such parameters have a different icon -  - to distinguish them in the Parameters region of the Editor. Hovering over the icon will display the text Dynamic.

Item Level Parameters

Altium NEXUS (in conjunction with the Altium NEXUS Server) supports the concept of Item level parameters. These are parameters that are added to the parent Component Item, and available to all its released revisions, without having to re-release the Item into a new revision to pick up those parameters. As such, they are often referred to as Dynamic Parameters. This feature allows for component updates without having to create new component revisions, which in turn would affect related designs in which those components are used. An example might be a cost parameter change - applied dynamically on-the-fly as it were.

This functionality is available when instigated through a connected enterprise system instance, or through use of the CSV uploader. When defining parametric attributes through the relevant configuration file, you can determine whether a parameter should be pushed to the item, or the revision, with the latter being the default. For more information, see PLM Integration.

Item-level, or dynamic parameters can be viewed when editing a Component Item revision. Note that they are only visible when using the Component Editor in its Single Component Editing mode.

Example Item level parameter that has been added to a Component Item, and available to its revisions.Example Item level parameter that has been added to a Component Item, and available to its revisions.

Note that such parameters have a different icon -  - to distinguish them in the Parameters region of the Editor. Hovering over the icon will display the text Dynamic.

Part Choices

This region of the editor is used to specify one or more Part Choices for the component - the 'allowed' manufacturer parts that can be used to implement the component on the assembled board. The actual supply chain intelligence - comprising Manufacturer (and part number), Supplier (and part number), Description, Pricing and Availability - is sourced from the managed content server's local Part Catalog and the relevant Part Source.

Each managed content server has its own dedicated Part Catalog. This is a managed local part catalog database, dedicated to the management and tracking of manufacturer parts and their associated supplier parts. The local Part Catalog stores items representative of actual Manufacturer Parts, along with one or more items representative of Supplier Parts - the incarnations of those Manufacturer Parts, as sold by the Suppliers/Vendors. Each Supplier Part is a reference to an item in a parts database - either the aggregate parts database of the Altium Parts Provider (the default Part Source which itself interfaces to, and gathers the parts from, enabled Suppliers), or a linked local parts database (a Part Source configured as a Custom Database Parts Provider). Enable required Suppliers and determine Location/Currency ranges for the Altium Parts Provider within the Part Providers area of the server's browser interface. While you remain signed into your managed content server from Altium Designer, the Altium Parts Options region - on the Data Management - Parts Providers page of the Preferences dialog - becomes read-only and adopts those settings defined for the server. For more information on managing the Altium Parts Provider part source for your server installation, see Part Source Configuration. (Altium 365 Workspace), or Part Source Configuration (self-managed Concord Pro).
Each managed content server has its own dedicated Part Catalog. This is a managed local part catalog database, dedicated to the management and tracking of manufacturer parts and their associated supplier parts. The local Part Catalog stores items representative of actual Manufacturer Parts, along with one or more items representative of Supplier Parts - the incarnations of those Manufacturer Parts, as sold by the Suppliers/Vendors. Each Supplier Part is a reference to an item in a parts database - either the aggregate parts database of the Altium Parts Provider (the default Part Source which itself interfaces to, and gathers the parts from, enabled Suppliers), or a linked local parts database (a Part Source configured as a Custom Database Parts Provider). Enable required Suppliers and determine Location/Currency ranges for the Altium Parts Provider within the Part Providers area of the server's browser interface. While you remain signed into your managed content server from Altium Designer, the Altium Parts Options region - on the Data Management - Parts Providers page of the Preferences dialog - becomes read-only and adopts those settings defined for the server. For more information on managing the Altium Parts Provider part source for your Altium NEXUS Server, see Supply Chain Management.

Example Part Choices list for a component being defined, containing a single manufacturer part.Example Part Choices list for a component being defined, containing a single manufacturer part.

A manufacturer part can be added to the Part Choices list for the component in two ways:

To manually add a part choice, click the  button at the bottom of the region. The Add Part Choices dialog will appear - search for the required manufacturer part, select a part, then click the OK button. Click the SPNs entry for a manufacturer part - Supplier Part Numbers - to see the available suppliers of that part, and assess whether you are making the right part choice, based on availability, pricing, etc.

If the component already has defined data, or if there are already part choices in the list, the Use component data dialog will appear. Use this to decide how you want to use the result, should you wish to replace any or all existing data or, to just have the part added as a part choice, click Skip.
Search results in the dialog are by Manufacturer Part, with the associated SPN entries reflective of the enabled vendors supplying that part. When you select a part, it is the manufacturer part that is added to the Part Choices list. And by using the manufacturer part, and not a specific vendor/supplier, you get a single Part Choice that will bring with it all solutions based on the suppliers vending that part (and who are available for use through your managed content server).

Making a manual part choice - use the Add Part Choices dialog to search for the required manufacturer part, select its entry and click OK.Making a manual part choice - use the Add Part Choices dialog to search for the required manufacturer part, select its entry and click OK.

To remove a part choice, select it in the list, then click the  button.

Creating the Component from a Manufacturer Part Search

Providing a boost to creation of a managed component, Altium Designer supports the ability to search for a real-world manufacturer part, courtesy of Manufacturer Part Search functionality, and then add that part (or a portion of its data) into the Component Editor. In this way, you can quickly define a new managed component for addition to your managed content server, without having to craft that component from scratch. There is no having to 'reinvent the wheel' as it were, since all data for that part - its name, description, parameters, datasheets, part choices and any defined models - can be brought in.

The feature itself can be accessed in a number of ways - click on a collapsible section to explore further.

As a general observation, if the component has no data yet defined, all data available for that part will be loaded when using this feature. If the component is partially defined, then you will be given the option of how to use the data from the chosen part - whether to use all its data (name, description, parameters, models and part choices), its parameters only (name, parameters and part choices, while leaving description, datasheets and models untouched), or just its name (leaving all other entities untouched).

Running a Component Rule Check

When you attempt to commit/release a component back to the server, the Component Editor runs a validation - a Component Rule Check. This feature can also be run at any time, manually, by choosing the Tools » Component Rule Check command, from the main menus (be sure to have saved your component before you do).

The command is also available from the editor's main File menu.

Just as a board project has the Compiler to detect for any violations, the Component Editor has a Component Validator. Any violations that are found will be listed in the Messages panel.

Detecting issues with a component prior to releasing/committing to the server.Detecting issues with a component prior to releasing/committing to the server.

The Component Validator tests for an array of potential issues with the component and its defined models - both hardwired tests, as well as a range of violation types that can be user-defined at the global level.

The following hardwired validation checks all carry a report mode of :

  1. Component not referencing any models.
  2. A target folder not specified for the component in the target managed content server.
  3. Component not having a unique Id.

User-definable checks are configured on the Data Management - Component Rule Checks page of the Preferences dialog.

User-definable violation checks that can be configured as part of global preferences, for use with the Component Validator.User-definable violation checks that can be configured as part of global preferences, for use with the Component Validator.

Any of the hardwired tests that fail, or user-defined checks at a level of Error or above, would prevent release of the component.

A Word About Linked Simulation Models

Related page: Managed Simulation Models

As with Symbol and Footprint Items, a component can also reference a revision of a Simulation Model Item. Adding a model link of this type is similar to adding a Symbol and Footprint, with the exception of there being no Wizard-based creation option, so refer back to the previous sections for information on that. Here, we look at including component-level simulation parameters, and also configuration of pin mapping.

Adding Component-Level Simulation Parameters

When using a simulation model for a component in a design, parameters specific to that model can be specified at two different levels:

  • Model-Level Parameter - specified as part of the simulation model definition itself (in the SimModel file), and released with that definition into a revision of the linked Simulation Model Item.
  • Component-Level Parameter - specified as part of the component definition (here in the Component Editor), and released with that definition into a revision of the linked Component Item.
Component-level parameters are used for parameters that are shared between multiple models or where the designer wants to make such a parameter visible/editable on the schematic (e.g. value, frequency etc).

Parameters are added at the component-level in the Parameters region of the Component Editor. It is important to note that the naming of parameters must be the same as those parameters defined at the model-level. To see the model-level parameters, and therefore which parameters can be added at the component-level (and their names!), click the View Parameters control, at the bottom of the Simulation model's preview window.

View the model-level parameters for a Simulation Model Item, to see which parameters can be added at the component-level - and how they are named!View the model-level parameters for a Simulation Model Item, to see which parameters can be added at the component-level - and how they are named!

Armed with the available model-level parameters, you can now proceed to add any of those same parameters at the component-level. To do so, click the  button at the bottom of the Parameters region. A new parameter entry will be added to the list. Change the name as required - remembering to match exactly the name of the corresponding model-level parameter.

Add sim-related parameters at the component-level. Notice that two parameters are already available - Area Factor and Temperature - courtesy of a referenced Component Template.Add sim-related parameters at the component-level. Notice that two parameters are already available - Area Factor and Temperature - courtesy of a referenced Component Template.

When an instance of the released component is placed in a design, a simulation parameter can have a different value at the component-level, to that for the same parameter at the model-level. When the netlist is generated, the component-level parameter will have priority.
For some of the built-in SPICE3f5 models, entering a value for a parameter at the component-level will override a related parameter defined in a linked model file (*.mdl). For a semiconductor capacitor, for example, specifying a value for the component-level Width parameter will override any value specified for the DEFW parameter in the associated model file. If a parameter is specified at the component-level for a subcircuit model, that value will override the value defined for it in the linked subcircuit file (*.ckt). If a parameter is specified at the component-level for a digital device, that value will override the value specified for that parameter in the source SimCode definition (*.scb).

Pin Mapping

Once the link to the required SIM model has been chosen, you need to ensure that the pins of the component - when represented in the schematic domain - are correctly mapped to the pins of the simulation model.

This feature is not available while in Single Component Editing mode - you will need to switch to Batch Component Editing mode (Tools » Switch to Batch Editor).

Once you have switched the Component Editor to its Batch Component Editing mode, mapping is performed in the Pin Mapping dialog, accessed by right-clicking on the component definition's SIM model entry and choosing Operations » Edit Pin Mapping from the context menu. For each schematic pin, use the available drop-down to change the associated Model Pin entry accordingly. If the device is multi-part, be sure to check the mapping for each part. Once finished, you can switch back to Single Component Editing mode (Tools » Switch to Single Component Editor), or proceed to release from within the Batch Component Editing mode.

Ensuring correct schematic pin-to-model pin mapping.Ensuring correct schematic pin-to-model pin mapping.

For a multi-part component, the ability to exclude a part from simulation is also determined through the Pin Mapping dialog.
For the built-in SPICE3f5 and supported PSpice models, the function of each of the pins in a model can be found in the general form section for that model, in the SPICE 3f5 user manual. For subcircuit models, the manufacturer will typically insert comments for each pin of the model, describing that pin's function. If no commenting is evident, then the pinout of the model will typically be that of the physical device itself. Consult the datasheet for the device in this case. For Digital SimCode models, the mapping of the component pins to the INPUTS and OUTPUTS declared in the SimCode file will depend on the input and output node list entries in the netlist template.

Full Support for Digital SimCode Models

When using a managed component that references a Simulation Model Item featuring a SimCode definition (in a *.scb file), that scb file (released with the SimModel file to the server) is used for subsequently run simulations. In the generated simulation netlist (*.nsx file), the model reference will contain the full path to the scb file, cached locally from the server. For example:

.MODEL 74LS90 xsimcode(file="C:\ProgramData\Altium\Altium Designer {A586F887-1E00-4F36-9EC8-61C78B91FA73}\VaultsFileCache\0072B38F-E431-40BB-B462-FD262DB9CDAB\Released\LS.SCB" func=ls90)

.MODEL 74LS90 xsimcode(file="C:\ProgramData\Altium\Altium NEXUS {A586F887-1E00-4F36-9EC8-61C78B91FA73}\VaultsFileCache\0072B38F-E431-40BB-B462-FD262DB9CDAB\Released\LS.SCB" func=ls90)

An .scb file typically contains multiple scb models. When the simulation model definition is released, the .scb file - released and stored with the SimModel file in the server - is stripped back to include only the single scb model referenced by the simulation model definition, and not the full listing of models.

 

Note

The features available depend on your level of Altium Designer Software Subscription.

Content