Altium Designer Documentation

The Altium Designer Environment

Modified by Susan Riege on May 5, 2020

Altium Designer provides a unified electronic product development environment, catering for all aspects of the electronic development process, including:

  • Front-end design and capture
  • Physical PCB design
  • Mixed-signal circuit simulation
  • Signal integrity analysis
  • PCB manufacturing

Altium Designer includes all the editors and software engines needed to perform all aspects of the electronic product development process. All document editing and processing is performed within the Altium Designer environment. Altium Designer also interfaces seamlessly to supporting tools, such as route software or third-party simulation software. Underlying Altium Designer is the X2 Integration Platform, which brings together Altium Designer's various editors and software engines and provides a consistent user interface across all the tools and editors. The exact set of features and functionality that is available will depend on the specific license that has been purchased. The Altium Designer environment is fully customizable, which allows you to set up the workspace to suit the way you work. A consistent selection and editing paradigm across different editors allows you to easily and smoothly switch between various design tasks within the Altium Designer environment.

Getting Help

Altium Designer provides various ways for you to locate additional information and help. 

  • Press F1 over any object, editor, panel, menu entry, or button to open the documentation for that item.
  • Press Shift+F1 while running a command for a list of shortcuts you can use in that command.
  • Use the navigation tree on the left side of the documentation to read about a particular subject.

Resource-level documentation (preferences, objects, panels, commands, dialogs, etc.,) can be found under the Preferences & References heading in the navigation tree.

Elements of the Environment

Altium Designer is unique in its ability to support all aspects of electronic design, from capture to generation of PCB manufacturing output. It does this in a single software application, through the support of the underlying X2 integration platform. The platform supports all of the standard user-interface elements, such as menus and toolbars (also called resources), with each editor plugging in its own specific set of resources and commands. See the below section for descriptions, access, etc., to Altium Designer's environment elements.


The Elements

The following sections describe some of the main elements of the Altium Designer design space highlighted in the image above.

Open Versus Active Documents

In Altium Designer, you are allowed to have as many documents open as you wish, however, only one document can be the 'active' document. The active document is open in the design space allowing you to make any required updates. All open documents appear as a tab near the top of the design space. The tab of the currently active document displays with a medium gray background; documents that are open and not currently active display with a charcoal gray/black background.

Right-click on any document tab to access a drop-down of commands to close the document on which you right-clicked, close all documents of the same editor (e.g., all PcbDoc, all SchLib, or all PcbLib documents) as the one on which you right-clicked, close all open documents, split, tile or merge documents.

Refer to Configuring and Customizing Altium Designer for more information.

Preferences 

Preferences dialogs are a central location in which you can set up global system settings across different functional areas of the software. These preferences apply across projects and relevant documents. The various dialogs are accessed by clicking  at the top right of the design space. Use  on the left side of the dialog to open the selections for the required area then choose the desired title to open that specific preference page.

Licenses

Altium Designer provides various license types and each is designed to suit your individual needs. The licensing system enables you to get up-and-running with Altium Designer software in a timely and efficient manner. To access the License Management page, click  next to your sign-in credentials at the top right of the design space then select Licenses from the drop-down menu.

For full licensing information refer to System Installation, Licensing & Management

Extensions & Updates

Extensions

Extensions are add-ons to the software that provide extended features and functionality. You have the ability to install, update or remove additional functionality, which includes a new importer or exporter, a tool for schematic symbol generation, and support for mechanical CAD collaboration.

To access the Extensions & Updates page, click  next to your sign-in credentials at the top right of the design space then select Extensions and Updates from the drop-down menu.

Refer to Extending Altium Designer for detailed information.

Updates

Updating Altium Designer gives you the most recent release of the core platform software and any extensions you have installed.

To access Updates, click  next to your sign-in credentials at the top right of the design space then select Extensions and Updates from the drop-down menu. On the Extensions & Updates page, select the Updates tab as shown in the image below.

The (n) displays the total number of updates that are available. If there is no (n), there are no updates.

The Updates page displays any core platform updates that are available and a listing of System Extensions and Software Extensions for which there is an update available.

Refer to Extending Altium Designer for detailed information.

Panels

Panels are essential elements of the Altium Designer environment. Whether specific to a particular document editor, or used on a more global, system-wide level, they present information and controls that aid productivity and allow you to design more efficiently. For example, the PCB panel can be used to browse by Components or Nets. When Altium Designer is first started, the Projects panel will already be open and pinned/docked on the left side of the design space. To open other panels, click the Panels button on the bottom left of the design space then select the desired panel. Each editor has panels specific to that editor.

Panels are used to work across the environment, for example, the Projects panel is used to open any document in the project, as well as display the project hierarchy. Document-specific panels can only be displayed when that document type is the active document.

Left image: PCB panels; right image: Schematic panels

For detailed information about accessing panels, panel display modes (i.e. pinned/docked, pop-up, floating), moving and closing panels, and more, refer to Working with Panels in Altium Designer

Active Bar

The Active Bar gives you quick access to frequently used functions that are also found in the main menus. You can hover over an icon to view a pop-up of the icon's description. To use the icon displayed, click on it. For placement icons, the object will appear on the cursor, allowing you to drag the object to the required location. When a white triangle is displayed at the bottom right of an icon, there is a group of other icons available. Click and hold the cursor over that icon to display a list of additional icons available then select the desired command/icon. The most recently used icon is displayed for that group.

Top image: PCB Active Bar; Bottom image: schematic Active Bar

If desired, the Active Bar can be disabled. To disable the Active Bar, on the Advanced Settings dialog (accessed by clicking the Advanced button on the System - General page of the Preferences dialog), uncheck the Value field of the UI.UseActiveBar Preference Name. As stated in the Advanced Settings dialog, Altium Designer will need to be restarted for the new setting to take effect.

The main menus allow access to commands and functions for the active document. The menus appear across the top left of each editor and each editor has its own set of menus.

Main menus for PCB (top image) and SCH (bottom image)

To use commands, click the title (e.g., Design) then select the desired command from the drop-down menu.

Some commands have sub-menus, which are indicated by a . When you hover the cursor over such a command, the sub-menu opens.

Quick Access Bar

The Quick Access Bar is located at the top left of the design space and is used to quickly perform frequently used functions. 

  •  - use to exit and close Altium Designer.
  •  - use to save the currently active document.
  •  - use to save all documents in which changes have been made.
  •  - use to access the Open Project dialog in which you can choose the project to open.
  •  - use to undo the last action. The icon is available only if an action has occurred.
  •  - use to redo the last action. The icon is available only if an undo action has been performed.

Status Bar 

The Status Bar displays summary information, such as the coordinate position of the cursor, command prompts, and layer. You can toggle the display of the Status Bar by choosing View » Status Bar from the main menus.

Heads Up Display

The Heads Up Display gives you real-time feedback about objects currently under the cursor in the PCB workspace. To show the Heads Up Display, select View » Board Insight » Toggle Heads Up Display from the main menus or use the Shift+H shortcut keys to toggle the display.

You can customize the information in the Heads Up Display information, as well as the background color, font and font color on the PCB Editor - Board Insight Modes page of the Preferences dialog.

Projects and Documents

All project-related data is stored in documents, which are also referred to as files. Documents, projects and project groups can be opened using the relevant commands available from the main File menu. Alternatively, you can drag-and-drop a document, project file, or project group file directly into Altium Designer to open it. As well as storing links to each document in the project, the project file also stores project-specific options, such as error check settings, compiler settings, and so on.

When you open a document, it becomes the active document in Altium Designer's main design window. Multiple documents can be opened simultaneously. Each open document has its own tab at the top of the design window. Documents can occupy the entire workspace, or the workspace can be shared between multiple open documents via the Split commands in the Window menu. Documents can then be dragged from one split region to another.

Refer to Configuring and Customizing Altium Designer for detailed information regarding multiple documents, monitors, and the Split and Tile commands.

Additional References

Configuring and Customizing Altium Designer

Altium Designer Tutorial

Project Management in Altium Designer

Project Navigation

Shortcut Keys

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.