Tutorial - Output Documentation and Project Release in Altium NEXUS

Created: July 12, 2022 | Updated: July 12, 2022

Parent page: Tutorial - A Complete Design Walkthrough with Altium NEXUS

Main page: Preparing Your Design for Manufacture

Now that you've completed the design and layout of the PCB, you're ready to produce the output documentation needed to get the board reviewed, fabricated, and assembled.

Tutorial board exported as a 3D PDF, open in Adobe Acrobat
Output types include PDF 3D, with full zoom, pan and rotate, and the ability to control the display of nets, components, and the silkscreen, in Adobe Acrobat Reader®.

Available Output Types

Because a variety of technologies and methods exist in PCB manufacture, the software has the ability to produce numerous output types for different purposes:

Assembly Outputs

  • Assembly Drawings – component positions and orientations for each side of the board.
  • Pick and Place Files – used by robotic component placement machinery to place components onto the board.
  • Test Point Report – as ASCII file, available in 3 formats, that details the location of each pad/via that has been nominated as a testpoint.

Documentation Outputs

  • PCB Prints – configure any number or printouts (pages), with any arrangement of layers and display of primitives. Use this to create printed outputs, such as assembly drawings.
  • PCB 3D Prints – views of the board from a three-dimensional view perspective.
  • PCB 3D Video – output a simple video of the board based on a sequence of 3D key-frames defined in the PCB editor's PCB 3D Movie Editor panel.
  • PDF 3D – generate a 3D PDF view of the board with full support to zoom, pan, and rotate in Adobe Acrobat®. The PDF includes a model tree, giving control over the display of nets, components, and the silkscreen.
  • Schematic Prints – schematic drawings used in the design.

Fabrication Outputs

  • Composite Drill Drawings – drill positions and sizes (using symbols) for the board in one drawing.
  • Drill Drawing/Guides – drill positions and sizes (using symbols) for the board in separate drawings.
  • Final Artwork Prints – combines various fabrication outputs together as a single printable output.
  • Gerber Files – creates manufacturing information in Gerber format.
  • Gerber X2 Files – a new standard that encapsulates a high-level of design information with backward compatibility to the original Gerber format.
  • IPC-2581 File – a new standard that encapsulates a high-level of design information within a single file.
  • NC Drill Files – creates manufacturing information for use by numerically controlled drilling machines.
  • ODB++ – creates manufacturing information in ODB++ database format.
  • Power-Plane Prints – creates internal and split plane drawings.
  • Solder/Paste Mask Prints – creates solder mask and paste mask drawings.
  • Test Point Report – creates test point output for the design in a variety of formats.

Netlist Outputs

  • Netlists describe the logical connectivity between components in the design and are useful for transferring the design to other electronics design applications. A large variety of netlist formats are supported.

Report Outputs

  • Bill of Materials – creates a list of parts and quantities (BOM) in various formats required to manufacture the board.
  • Component Cross Reference Report – creates a list of components based on the schematic drawing in the design.
  • Report Project Hierarchy – creates a list of source documents used in the project.
  • Report Single Pin Nets – creates a report listing any nets that only have one connection.

Individual Outputs or an Output Job File

Main page: Streamlining Generation of Manufacturing Data with Output Jobs

The PCB editor has three separate mechanisms for configuring and generating output:

  1. Individually – the settings for each output type are stored in the Project file. You selectively generate that output when required using the commands in the Fabrication Outputs, Assembly Outputs and Export sub-menus (accessed from the File menu), and the Reports menu.
  2. Using an Output Job file – the settings for each output type are stored in an Output Job file, which is a dedicated output settings document that supports all possible output types. These outputs can then be generated manually or as a project release.
  3. In the design release process – output documentation that is set in all Output Job files of the project can be generated as a part of the integrated project release process, with the ability to validate the design.

Example of an OutputJob file
An Output Job file allows you to configure each output type, configure their output naming, format, and output location. Output Job files can also be copied from one project to another.

Although the individual outputs configured using the File and Reports menus use the same setup dialogs as an Output Job, the settings are independent and must be configured again if you switch from one approach to the other.

The OutputJob file, or OutJob, maps each output (in the list on the left) to an output container (in the column on the right). The output setting defines what you want to output (double-click to configure); the container defines where the output is to be written to (double-click the icon, or click the Change link). Any number of outputs can be added in the OutJob, and outputs can be mapped to individual or shared output containers.

  1. In the Projects panel, right-click on the project name and select Add New to Project » Output Job File. A new OutJob will be opened and added to the project.
  2. Save the OutJob and name it Fabrication. It will automatically be saved in the same folder as the project file.
  3. To add a new Gerber output, click the OutputJob, click this text to add a new Fabrication Output link in the Fabrication Outputs section of the OutJob and select Gerber Files » [PCB Document] as shown in the image below. If you select the [PCB Document] option, the project PCB is automatically chosen. Choosing this also means the OutJob can easily be copied between projects, as this setting will not have to be updated. If there are multiple PCBs in the project, you will need to select the specific board.
  4. The Gerber output has been added; you will configure it shortly.

    OutputJob, showing the menu when you click to add a new Fabrication Output


Configuring the Gerber Files

Dialog page: Gerber Setup

  • Gerber continues to be the most common form of data transfer between board design and board fabrication, with Gerber X2 and ODB++ becoming more and more popular.
  • Each Gerber file corresponds to one layer of the physical board: the component overlay, top signal layer, bottom signal layer, top solder mask layer, and so on. It is advisable to consult with your board fabricator to confirm their requirements before supplying the output files required to fabricate your design.
  • If the board has holes, an NC Drill file must also be generated, using the same units, resolution, and position on film settings.
  • Gerber files are configured in the Gerber Setup dialog, accessed via the PCB Editor's File » Fabrication Outputs » Gerber Files command, or by adding a Gerber output into the Fabrication Outputs section of an Output Job then double-clicking on it.

    Composite image showing 3 of the 5 tabs in the Gerber Setup dialog
    Configure the Gerber outputs in the Gerber Setup dialog.

  1. In the OutJob, double-click on the Gerber Files output added in the previous set of steps. The Gerber Setup dialog will open, as shown in the image above.
  2. Since the board has been designed in Metric, set the Units to Millimeters on the General tab of the dialog.
  3. The smallest unit used on the board is 0.25mm for the routing and clearance, but because most of the components have their reference point at their geometric center (and were placed on a 1mm grid), some of their pads will actually be on a 0.01 grid. Set the Format to 4:3 on the General tab. This ensures that the resolution of the output data is more than adequate to cover these grid locations. Note: the NC drill file must always be configured to use the same Units and Format.
  4. Switch to the Layers tab then click the Plot Layers button and select Used On. Note that mechanical layers may be enabled; these are not normally Gerbered on their own. Instead, they are often included if they hold detail that is required on other layers, for example, an alignment location marker that is required on every Gerber file. In this case, the Mechanical Layer options on the right side of the dialog are used to include that detail with another layer. Disable any mechanical layers that were enabled in the Layers to Plot section of the dialog.
  5. Click on the Advanced tab of the dialog. Confirm that the Position on Film option is set to Reference to relative origin. Note: the NC drill file must always be configured to use the same Units, Format, and Position on Film settings as the Gerber files otherwise the drill locations will not match the pad locations!
  6. Click OK to accept the other default settings and close the Gerber Setup dialog.
  7. Same way, add the NC Drill output to the OutJob file – click the OutputJob, click this text to add a new Fabrication Output link in the Fabrication Outputs section of the OutJob and select NC Drill Files » [PCB Document].
  8. Double-click on the added NC Drill Files output to access the NC Drill Setup dialog. Set the Units to Millimeters and the Format to 4:3. Make sure that the Coordinate Position option is set to Reference to relative origin, and click OK to accept the other default settings and close the dialog.

    NC Drill Setup dialog, configured to generate proper NC Drill files
    The NC Drill Setup dialog configured to generate proper NC Drill files for the tutorial.

  9. Now that the Gerber and NC Drill settings are configured, the next step is to configure their naming and output location. This is done by mapping them to an Output Container on the right side of the OutJob. For discrete files with their own file format, use a Folder Structure container. Select Folder Structure in the list of Output Containers then click the radio buttons for the Gerber and NC Drill Files in the Enabled column of the Outputs section to map these outputs to the selected container, as shown below.

    OutputJob configured to generate Gerbers and NC Drill as discrete files
    The OutJob configured to generate Gerber and NC Drill outputs as discrete files.

  10. The last step is to configure the container. To do this, click the Change link in the container to open the Folder Structure settings dialog. Across the top are a set of controls that are used to configure if the outputs are Release Managed or Manually Managed; make sure that they are set to Release Managed. Explore the other options. The lower part of the dialog will display how the names and folder structure change as you select different options.
  11. Click OK to close the dialog.

Configuring Validation Report Generation

The software includes a number of validation checks, which can be included as an output, during output generation. Each produces an HTML report file. During the project release process, these checks will be performed prior generation of other outputs, and if any validation checks are not passed successfully, the release will fail.

  1. To add a new Validation output, click the OutputJob, click this text to add a new Validation Output link in the Validation Outputs section of the OutJob and select Design Rules Check » [PCB Document].
  2. Map the added report to the Folder Structure Output Container – select the Folder Structure container in the list on the right side of the OutJob, then click the radio button for the Design Rules Check output in the Enabled column of the Outputs section.
  3. Save locally and close the OutputJob file.

Configuring the Bill of Materials

Main page: BOM Management with ActiveBOM

Ultimately, every part used in the design must have detailed supply chain information. Rather than requiring that this information be added to each design component, or added as a post-process in an Excel spreadsheet, you can add it at any point through the design cycle in an ActiveBOM (*.BomDoc).

ActiveBOM is the component management editor included in Altium NEXUS, which is used to:

  • Configure the component information so that it is BOM-ready, including adding additional non-PCB component BOM items, such as the bare board, glue, mounting hardware, and so on.
  • Add additional columns, such as a line number column, to suit the requirements of the assembly house.
  • Map each design component to a real-world manufacturer part.
  • Verify the supply chain availability and price for each part, for a defined number of manufactured units.
  • Calculate the cost to build for the defined number of manufactured units.

ActiveBOM, configured for the tutorial project
ActiveBOM is used to map each design component to a real-world part.

This ability to inject supply chain details directly into the BOM changes the role of the BOM document in the PCB project. No longer a simple output file, ActiveBOM raises the component management process to sit alongside the schematic capture and PCB design processes, where ActiveBOM's BomDoc becomes the source of all Bill Of Materials data for the PCB project for all BOM-type outputs. ActiveBOM is the recommended approach to BOM management.
ActiveBOM queries the supply chain in real-time, using the Part Providers enabled in the settings of your connected Workspace. Because data is updated in real-time, the availability of the parts used in this tutorial will change over time. The list of available suppliers also changes over time. For these reasons, the results you get may be different from the results shown and described in this tutorial.

To include a BomDoc in the tutorial:

  1. Select File » New » ActiveBOM Document from the main menus. Note that a PCB project can only include one BomDoc.
  2. The BomDoc will be created, and the components used in the tutorial listed as BOM Items. The BomDoc is configured in the Properties panel, where the production quantity and currency, supply chain, and visible BOM Item parameters are defined, along with other settings. Take some time to familiarize yourself with the features available in the Properties panel's two tabs. Note that the panel includes a search field at the top, which is handy for quickly locating a control or a parameter.
  3. Explore the Columns tab of the panel. Note that the available data to be included in the BOM can be sourced from various locations, controlled by the Sources buttons.
  4. The components are detailed in the main grid area of the BomDoc. By default, there is a column titled Line #. Click the Set Line Numbers button (ActiveBOM, Set Line Numbers button) to populate this column (you may need to refresh the BomDoc with the Refresh button at the top-right of the document to show the Line # values in the grid).
  5. Because the components were acquired from the Manufacturer Part Search panel, each part already includes supply chain information. When you click on a part in the BOM Items grid, its supply chain information is displayed in the lower region of the BomDoc as shown in the image above. Each row displayed in this lower region of the BomDoc is referred to as a Solution, with the manufacturer part + part number (referred to as an MPN) shown on the left, and available suppliers + supplier part numbers (referred to as SPNs) are shown in each tile on the right.
  6. Note that the BOM Items grid includes a BOM Status column on the right. Hover the mouse cursor over a status icon for information about any issues detected.
  7. The Status icons should indicate that all of the Items include the error No MPN ranked. This means that the designer (you) has not yet checked through the selected parts (MPNs) and indicated that they are happy with each of them. An MPN is accepted by assigning it a rank (as shown in the image above). Do this for each of the items that show no other error type. It is possible that the transistor may have other errors; this will be resolved shortly.
  8. The Status of four of the five BOM Items should change to green (ActiveBOM Status Indicator, ready to order) indicating that these Items are clear (ready to order).
  9. The status of each Item is checked against the current configuration of BOM Checks configured in the Properties panel. The BOM Checks list in the panel details all BOM checks that are currently being violated. The available BOM checks and their current settings are configured in the Bom Checks dialog (accessed with the ActiveBOM Gear button, click to open the BOM Checks dialog icon below the BOM Checks list).
  10. Select the transistor Item; it may be flagged as Obsolete. For an Item that does not have an MPN assigned, or has an MPN but that part has no suppliers, you can also create a Manufacturer Link.

    The Manufacturer Link feature allows you to connect a Workspace part, or a non-Workspace part with supply chain issues, to your preferred manufacturer part. Using this feature, you can bring the full power of the Altium Parts Provider to all of your design components directly in the BomDoc, complete with real-time supplier, price, and availability information. The Manufacturer Link is stored in the BomDoc.
  11. To add a Manufacturer Link, select the transistor in the grid, click the Add Solution button and select Create/Edit Manufacturer Links from the drop-down menu.
  12. The Edit Manufacturer Links dialog will open. Click the Add button to add a new Manufacturer Link; the Add Part Choices dialog will open. This dialog is used to search for a suitable manufacturer part. As well as identifying a suitable part, you can also check the suppliers, price, and availability.

    The Search field in the Add Part Choices dialog is automatically populated with data from the component you selected in the BomDoc. The field that supplies the search data is determined by the Suggested Keywords setting in the Data Management – Part Providers page of the Preferences dialog. The default is to search using the Comment field; this can be changed if required.
  13. If the search only returns the same part you already have used, try broadening the search, for example, search for BC547C.
  14. Keep an eye on the vertical colored bar at the edge of the Manufacturer Part column. This indicates the Lifecycle state of that part. Ideally, you will select a part with a green Lifecycle state (Volume Production). Note that you do not need the part to have models since you already have a symbol on the schematic and a footprint on the PCB.
  15. Choose a part that has a Lifecycle state of Volume Production (hover the cursor over the vertical colored bar to view the lifecycle state) and stock available, then click OK to accept this part.

    Added part choices and rankings in the BomDoc are automatically saved back for the component in the Workspace.
  16. You will return to the Edit Manufacturer Links dialog. Click OK to close the dialog and return to the BomDoc.
  17. The Solutions region of the BomDoc will show two solutions: the original part used in the design, and the Solution you just added. The Solutions are listed in the order they will be used in the BOM. Use the Ranking feature to promote the part you selected to be the primary Solution by hovering over the stars then clicking the desired rank (as shown below).
  18. All parts now include supply chain details. Save the BomDoc and the project locally.

ActiveBOM, adding a Manufacturing Link to create another Solution
Create a Manufacturer Link to select a part directly in the BomDoc when the schematic part does not include suitable supply chain details.


Preparing the Output BOM

Dialog page: Report Manager

The actual output BOM file that is generated is done using the Report Manager. The Report Manager is a highly configurable report generation engine that can generate output in a variety of formats including text, CSV, PDF, HTML, and Excel. Excel-format BOMs can also have a template applied using one of the pre-defined templates or one of your own. An Excel-format BOM can also be generated without Microsoft Excel being installed; select the MS Excel File option in the File Format drop-down.

  • The Report Manager generates BOM output from the Bill of Materials For Project dialog, accessed via:
    • The schematic or PCB editor's Reports » Bill of Materials, or
    • By adding a BomDoc to the project and running the BomDoc's Reports » Bill of Materials command, or
    • By adding a Bill of Materials into the Report Outputs section of an Output Job.
  • The default behavior is for the Report Manager to present the component detail in the same way it has been configured in the BomDoc if the project includes a BomDoc. Columns can be added and removed using the Columns tab in the Properties region of the dialog.
  • If the project does not include a BomDoc, the Columns tab includes an additional region, used to define how like-components are identified for clustering. Clustering is achieved by dragging and dropping component attributes to the Drag a column to group region of the dialog.
  • The main grid region of the dialog is the content that is written into the BOM. In this region, you can click and drag to reorder the columns, click on a column heading to sort by that column, Ctrl+Click to sub-sort by that column, and define value-based filters for a column using the small drop-down in each column header.
  • By default, the BOM generator sources information from the schematic documents. A variety of Sources are available. Use the buttons in the Columns tab in the Properties region of the dialog to enable other sources. For example, if you enable the PCB Parameters you can include detail such as component location and side of board if required.

    Bill of Materials Report Manager dialog
    The Report Manager takes the configuration from the BomDoc if the project includes a BomDoc.

Mapping Design Data into the Generated BOM

Design data can be passed from Altium NEXUS into an Excel-format Bill Of Materials by referencing an Excel template that includes special statements.

When creating the Bill of Materials template in Excel, a combination of Fields and Columns can be used to specify the desired layout. Several example templates are included with the software in the \Templates folder of the installation user files. Refer to the Mapping Design Data into the BOM section of the BOM Configuration in the Report Manager page for details of the available fields. Note that fields need to be defined above or below the Column region of the template.

  1. Add a new OutJob file to the project and save it as Assembly in the same folder as the project file.
  2. To add a new BOM output, click the OutputJob, click this text to add a new Report Output link in the Report Outputs section of the OutJob and select Bill of Materials » [ActiveBOM Document].
  3. Double-click on the added Bill of Materials output to open the Report Manager dialog.
  4. In the Export Options of the Properties pane on the right side of the dialog, set Generic XLS (*.xls, *.xlsx, *.xlsm) for the File Format and BOM Template Single Supplier for the Template.

    Unlike the MS-Excel (*.xls, *.xlsx *.xlsm) file format, Generic XLS (*.xls, *.xlsx, *.xlsm) uses a built-in XLS-format file generator, so that this format can be generated without having Microsoft Excel installed.

    Bill of Materials Report Manager dialog, Export Options
    The Report Manager takes the configuration from the BomDoc if the project includes a BomDoc.

  5. Click OK to save changes and close the dialog.
  6. In the OutJob file, map the added BOM report to the PDF Output Container – select the PDF container in the list on the right side of the OutJob, then click the radio button for the Bill of Materials output in the Enabled column of the Outputs section.
  7. Configure the PDF container – click the Change link in the container to open the PDF settings dialog. Click the Assembly.PDF entry, select the Separate file for each output using output name, and click Done. The output BOM will be assigned the name set to the output in the OutJob file (Bill of Materials.pdf), that can be seen in the Preview region of the dialog.

    PDF setting dialog, configuring output naming
    Configure the BOM output naming in the PDF setting dialog.

  8. Click OK to close the dialog.
  9. Add the Pick & Place output to the OutJob file – click the OutputJob, click this text to add a new Assembly Output link in the Assembly Outputs section of the OutJob and select Generates pick and place files » [PCB Document].
  10. Double-click on the added Generates pick and place files output to access the Pick and Place Setup dialog. Set the Units to Metric in the Output Setting region on the bottom left part of the dialog and click OK to accept the other default settings and close the dialog.
  11. Map the added Pick & Place output to the Folder Structure Output Container – select the Folder Structure container in the list on the right side of the OutJob, then click the radio button for the Generates pick and place files output in the Enabled column of the Outputs section.
  12. Save the project to the Workspace.

Project Release

Main page: Board Design Release

With output documentation configured in OutJob files, the project is ready to be released to the connected Workspace. The board design release process is automated, enabling you to release your board design projects without the risks associated with manual release procedures. When a particular project is released, a snapshot of the design source is taken and archived along with any generated output – which represents a tangible product that is made from that design project and sold by the company.

The release process itself is performed using Altium NEXUS's Project Releaser, the user interface to which is provided courtesy of a dedicated view – the Release view. The release process is a staged flow, with the entries on the left-hand side of the view showing you at-a-glance, which stage you are currently at.

Project Releaser, Configure Server Release stage
The Release view – the user interface to the Project Releaser.

  1. Access the Release view – right-click the project file in the Project panel and select the Project Releaser command from the context menu.
  2. The Release view will open as a separate document tab. On the first stage – 1. Configure Server Release (shown on the image above) – you specify the type(s) of data that you wish to generate. Click on Details controls at the far right of each data set header to access details of what exactly is going to be generated by a data set.
  3. Click the Options button at the bottom-left of the view to access the Project Release Options dialog. On the dialog's Release Options tab, make sure that the Managed - <WorkspaceName> is selected as the Release Target; Fabrication is assigned to Fabrication Data set, and Assembly is assigned to the Assembly Data set. Click OK to close the dialog and get back to the Release view.

    Project Release Options dialog, configured for online release
    Configure options for the online release in the Project Release Options dialog.

  4. Make sure that both fabrication and assembly Data Items are included in the release – Include Fabrication Data and Include Assembly Data for No Variant options are enabled (source data are always included in the project release) – then click the button to proceed.
  5. The Item Creation dialog will open, with the list of target release items to be created in the Workspace. Select the Create items option to confirm creation of the items.
  6. If there are changes in the open documents that have not been saved locally, the Project Modified dialog will open. In this case, select the Save and Commit changes option to save the changes locally and proceed with saving the changes to the Workspace.

    If there are changes to the project and/or its files that have not been saved to the Workspace yet, the Pending Commits dialog will open, alerting about this fact. Select the Commit option to proceed with saving the changes to the Workspace.
  7. In the Commit to Version Control dialog that opens, make sure that modified project's source files, and those that are not in version control, are enabled, enter a meaningful Comment (e.g., The project is ready to be released), and click the Commit And Push button.
  8. The next stage of the release process – 2. Validate Project – is run automatically when one or more Validation-type reports are detected in assigned OutJob file(s). As the Fabrication OutJob file includes generation of the Desing Rules Check report, this validation output generator is run.

    If any validation checks are not passed successfully, the release will fail. For the project release in this tutorial, this will mean that the PCB document includes at least one DRC violation. In this case, stop the release process with the Cancel button at the bottom-right of the view, open the PCB document, resolve the DRC violations, then start the release process again.
  9. If validation is successful, the next stage of the release process – 3. Generate Data – is run automatically. This is where all other outputs – defined in the OutJob file(s) assigned to the included Data Items – are run, to generate the data to be released into the relevant target items in the Workspace.
  10. With all validation checks passed, and output data generated, the next stage of the release process – 4. Review Data – allows you to review the generated data. Click a View link to open the associated data file, or file set, either within the relevant editor within Altium NEXUS (e.g. the CAM editor) or within the relevant external application (e.g. a PDF viewing tool). If the generated data all looks good, proceed with the release by clicking the Release button at the bottom-right of the view.

    Project Releaser, Review Data stage
    Review of the generated data, ready to be released to the Workspace.

  11. The Confirm Release dialog will open, summarizing the configurations of the project that will be released to the Workspace. Enter a Release Note (e.g., Initial Release), and click OK.
  12. After confirming the release in the previous stage, the next stage – 5. Upload Data – is automatically entered. It simply presents the progress of data upload into the revisions of the relevant data Items in the Workspace.
  13. The final stage of the process – 6. Execution Report – provides a summary of the release. Close the Release view using the Close button at the bottom-right of the view.
You started with a blank schematic sheet and worked through to a finished PCB with output files released to the Workspace, which is the entire design process in Altium NEXUS. Next, we will explore some features related to project management and collaboration.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: