Altium NEXUS Documentation

NC Drill Setup

Modified by Susan Riege on Mar 8, 2018


The NC Drill Setup dialog

Summary

This dialog is used to configure NC Drill file output options.

Access

The NC Drill Setup dialog is accessed in one of the following ways:

  • Using an NC Drill output generator in an OutputJob Configuration file (*.OutJob). The output is generated when the configured output generator is run.
  • In an active PCB document, click File » Fabrication Outputs » NC Drill Files. The output will be generated immediately upon clicking OK in the dialog.
The settings defined in the NC Drill Setup dialog when generating output directly from the PCB are distinct and separate to those defined for the same output type in an OutputJob Configuration file. In the case of the former, the settings are stored in the project file, whereas for the latter, they are stored in the OutputJob Configuration file.

Options/Controls

Options

  • NC Drill Format - use this region to specify the units and format to be used in the NC Drill output files. 
  • Units
    • Inches - enable this option to use imperial units where all work is done in mils (1/1000 inch).
    • Millimeters - enable this option to use metric units where all work is done in millimeters.
  • Format
    • 2:3 - provides a resolution of 1 mil  (1/1000 inch).
    • 2:4 - provides a resolution of 0.1 mil. 
    • 2:5 - provides a resolution of 0.01 mil. 
If you are using one of the higher resolutions, check that the PCB manufacturer supports that format. The 2:4 and 2:5 formats only need to be chosen if there are holes on a grid finer than 1 mil.
  • Leading/Trailing Zeroes - zero suppression is a technique that reduces the size of the generated data files by removing all zeroes from the start (leading) or end (trailing) of numbers.
    • Keep leading and trailing zeroes - if this option is enabled, all leading and trailing zeroes will appear in the generated NC Drill file.
    • Suppress leading zeroes - if this option is enabled, no leading zeroes will appear in the generated NC Drill file.
    • Suppress trailing zeroes - if this option is enabled, no trailing zeroes will appear in the generated NC Drill file.
  • Coordinate Positions 
    • Reference to absolute origin - use the absolute origin as the reference point.
    • Reference to relative origin - use the relative origin as the reference point.
  • Other​ 
    • Optimize change location commands - check this option to optimize any change location commands.
    • Generate separate NC Drill files for plated & non-plated holes - check this option to create separate drill files for plated and unplated holes.
    • Use drilled slot command (G85) - check this option to use multiple drilled holes to create slots.
    • Generate Board Edge Rout Paths - check this option to create a separate NC Rout file to define the board shape, including board cutouts.
      • Rout Tool Dia - specify the tool size used to rout the board outline. This option is only available when Generate Board Edge Rout Paths is enabled.
    • Generate EIA Binary Drill File (.DRL) - use this option to generate a .DRL file. DRL is a binary format drill file. For a multi-layer PCB that incorporates blind and/or buried vias, a separate drill file for each layer pair is created with a unique file extension.
The NC Drill files should be created with the same format as the Gerber files. For example, if the Gerber files have been configured to use the 2:4 format, then the corresponding NC Drill files should use the same format. If Gerber files have been generated with the coordinate position on the film set to use either the absolute or relative origin, the NC Drill files should ideally be generated using the same origin reference.

Tips

Generated NC Drill Files

Filename Description
FileName.DRL Binary format drill file. For a multi-layer PCB that incorporates blind and/or buried vias, a separate drill file for each layer pair is created with a unique file extension.
FileName.DRR Drill report - detailing the tool assignments, hole sizes, hole count and tool travel.
FileName.TXT ASCII format drill file. For a multi-layer PCB that incorporates blind and/or buried vias, a separate drill file for each layer pair is created with a unique file extension.
FileName-Plated.TXT ASCII format drill file. Specifically for plated holes in a PCB design. A separate file will be created for each hole type - slotted, square or round.
FileName-NonPlated.TXT ASCII format drill file. Specifically for non-plated holes in a PCB design. A separate file will be created for each hole type - slotted, square or round.
FileName-BoardEdgeRout.TXT ASCII format rout file. Specifically for board outline including board cutouts.
FileName.LDP ASCII format drill pair report. Used by the CAM Editor to detect blind and buried vias.

Once generated, the output will be added to the project and appear in the Projects panel under the Generated folder in an appropriately-named sub-folder. If you have used a separate folder for each output type, then corresponding (separate) Generated folders will be added to the Projects panel (e.g., Generated (NC Drill Output)).

Location of Generated Files

The output path for generated files depends on how the output was generated:

  • From an OutputJob file - the generated files are stored in a folder within the project folder. The naming and folder structure is defined in the Output Container that the NC Drill File output is targeting.
  • Directly from the PCB - the output path is specified in the Project Options - Options dialog. By default, the output path is set to a sub-folder under the folder that contains the Project file and has the name Project Outputs for <ProjectName>. The output path can be changed as required. If the option to use a separate folder for each output type has been enabled in the Options tab, the NC Drill files will be written to a further sub-folder named NC Drill Output.

Automatically Opening the Generated Output

When generating NC Drill outputs, you can specify that the output be opened automatically in a new CAM document. The way in which this is accomplished depends on how you are generating the output:

  • From an OutputJob file - enable the NC Drill Output auto-load option in the Output Job Options dialog (Tools » Output Job Options from the OutputJob Editor).
  • Directly from the PCB - ensure that the Open outputs after compile option is enabled on the Options tab of the Project Options dialog (Project » Project Options).

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.