Altium NEXUS Documentation

ODB Setup

Modified by Susan Riege on May 18, 2019

The ODB++ Setup dialog
The ODB++ Setup dialog

Summary

This dialog provides controls to completely configure ODB++ file output options. ODB++ is a CAD-to-CAM data exchange format used in the design and manufacture of printed circuit boards. The format was originally developed by Valor Computerized Systems, Ltd., as an open database that could provide a more information-rich data exchange between PCB design software and Valor CAD-CAM software used by PCB fabricators.

Access

The ODB++ Setup dialog is accessed in one of the following ways:

  • Using an ODB output generator in an OutputJob Configuration file (*.OutJob). The output is generated when the configured output generator is run.
  • In an active PCB document, click File » Fabrication Outputs » ODB++ Files. The output will be generated immediately upon clicking OK in the dialog.
The settings defined in the ODB++ Setup dialog when generating output directly from the PCB are distinct and separate to those defined for the same output type in an OutputJob Configuration file. In the case of the former, the settings are stored in the project file, whereas for the latter, they are stored in the OutputJob Configuration file.

Options/Controls

Layers to Plot

Check the box next to each specific layer(s) you wish to plot as part of the generated output.

Mechanical Layer(s) to Add to All Plots

Check the box next to each mechanical layer(s) you want added to all plots.

Miscellaneous Options

  • ​Include unconnected mid-layer pads - check to allow unconnected pads in the mid-layer on ODB++ plots.
  • Generate DRC Rules export file (.RUL) - check to generate a .RUL file that contains all design rules defined for the source document from which the ODB++ data is being generated.
  • Export only the objects inside the board outline - check to specify the source that is to be used to create the ODB++ profile layer. The profile layer contains the enclosing boundary of the board. By default, this field is set to Board Outline (also referred to as the board shape, it is a closed polygonal shape that defines the boundary, or extents, of the PCB). Created with each new PCB, this is perhaps the best source for creation of the Profile layer. If your design has no associated board shape, you can choose which source PCB layer has been used to define the closed polygon representing the boundary of the board (e.g., the KeepOut layer or a specific Mechanical layer). This option is only available when the source document contains an embedded board array object and it provides control over the extent of objects exported. Note that if an object (e.g., text) is outside of, but touching the board outline and this option is enabled, that object will still be exported.
  • Merge Net-Tie Nets - when enabled, if a design contains nets connected by Net-Tie components, these nets will report as distinguished single nets in the netlist.
  • Select the PCB layer / Board Outline that will be used to create the ODB++ 'profile' layer - use the drop down to select the desired layer/board outline:

Plot Layers

Use the drop-down, or right-click in the Layers to Plot section, to easily select a group of layers to plot:

  • All On - click to check all boxes in the Plot column (ODB++ data will be created for all checked layers).
  • All Off - click to clear all checked boxes in the Plot column (no ODB++ data will be created). 
  • Used On - click to check all boxes in the Plot column of the layers that are used in the project.

Additional Options

Right-clicking in the Layers Plot section or Mechanical Layer(s) to Add to All Plots section will display:

  • Add Layer Class - click to add a layer class.
  • Edit Layer Class - click to edit the layer class name.

Tips

Generating from an Embedded Board Array

When generating an ODB++ output from a PCB design that contains an embedded board array, the following statements apply:

  • The design is analyzed automatically for layer stackup violations.
  • Embedded boards that are flipped will display their layer stacks as flipped.
  • Mid-signal layers and internal planes that are different can still appear on the same mid-layer panel.
  • Mid-signal layers and internal planes can be flipped against each other.

When generating ODB++ output from the PCB design, all objects on all layers enabled for plotting will be exported. If you only want to export design objects residing within the board outline, ensure that all additional layers containing objects outside of this boundary are disabled for plotting.

Location of Generated Files

The output path for generated files depends on how the output was generated:

  • From an OutputJob file - the generated files are stored in a folder within the project folder. The naming and folder structure is defined in the Output Container that the ODB++ output is targeting.
  • Directly from the PCB - the output path is specified in the Project Options - Options dialog. By default, the output path is set to a sub-folder under the folder that contains the Project file and has the name Project Outputs for <ProjectName>. The output path can be changed as required. If the option to use a separate folder for each output type has been enabled in the Options tab, then the ODB++ files will be written to a further sub-folder named ODB++ Output.

Automatically Opening the Generated Output

When generating ODB++ output, you can specify that the output be opened automatically in a new CAM document. The way in which this is accomplished depends on how you are generating the output:

  • From an OutputJob file - enable the ODB++ Output auto-load option in the Output Job Options dialog (Tools » Output Job Options from the OutputJob Editor).
  • Directly from the PCB - ensure that the Open outputs after compile option is enabled on the Options tab of the Project Options dialog (Project » Project Options).
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.