Altium Designer Documentation

Создание связности

Последнее изменение: Pavel Demidov; 26.06.2019

Содержание

Полное содержание

Главная страница: Подробнее о схемах

Именно компоненты и их соединение между собой определяют уникальное электронное устройство. В схеме вы создаете логическое представление устройства, соединяя между собой выводы компонентов, чтобы сконструировать печатную плату, где вы размещаете физические компоненты и создаете ту же самую связность с помощью трасс.

Физическая и логическая связность

На схеме вы можете задать связь с помощью провода (объекта Wire), проложенного от одного компонента к другому – это называется физической связностью.

Вы также можете соединить один вывод с другим, разместив короткий отрезок объекта Wire и метку цепи (Net Label) на каждом из этих выводов. При компиляции проекта система определит эти две части цепи и соединит их между собой для формирования единой цепи. Такая связность называется логической.

Физическая связность позволяет отследить каждый провод при чтении схемы, но большое количество связей может привести к загромождению схемы. С другой стороны, метки цепей Net Label сокращают количество проводов, но в этом случае необходимо просматривать схему, чтобы найти все возможные соединения. Как разработчик, вы можете свободно выбирать, какая модель связности лучше подходит в вашем проекте, или использовать оба этих способа.

Размещайте провода, чтобы создать физическую связность, либо используйте метки цепей, чтобы создать логическую связность.

Помимо создания логической связности в пределах листа схемы, существуют также объекты для создания логической связности между листами схемы. Способ связности будет зависеть от структуры схемы – является ли она плоской или иерархической. Подробнее об этом ниже.


Существует ряд идентификаторов цепей, которые можно использовать для создания связи между листами.

Объекты, используемые для создания связности

Редактор схем включает в себя следующие объекты, используемые для создания связности. Вместе эти объекты называются идентификаторами цепей.

Идентификатор цепи Назначение
Bus
(Шина)
Используется для объединения набора цепей, например Data[0..7]. Цепи должны именоваться последовательно, с помощью определенной схемы именования (например, Data0, Data1,... Data7), и это именование определяет название шины, например Data[0..7].
Bus Entry
(Вход в шину)
Используется для разделения двух различных цепей по разные стороны от линии Bus, без создания короткого замыкания между этими цепями. В прочих ситуациях использовать не обязательно.
OffSheet Connector
(Межлистовой соединитель)
Используется для соединения цепи на разных листах схемы (не в пределах одного листа). Поддерживает только горизонтальную связность (плоские проекты). Межлистовые соединители имеют ограниченную функциональность по сравнению с объектами Port.
Net Label
(Метка цепи)
Используется для создания связности с другими метками цепей с тем же именем на одном листе. Цепь автоматически именуется по имени метки цепи. Метки цепей могут быть размещены на выводах компонентов, проводах и шинах. Обратите внимание, что метки цепей не создают связи между листами, пока в настройках проекта параметру Net Identifier Scope не задано значение Global.
Pin
(Вывод)
Выводы размещаются в редакторе схемных символов для представления физического контакта компонента. Электрически активным является только один конец вывода, который называется электрической точкой вывода.
Port
(Порт)
Используется для соединения на разных листах схемы. Связность может быть вертикальной в иерархическом проекте или горизонтальной в плоском проекте (о вертикальной и горизонтальной связности сказано ниже). Имена портов используются для именования цепей, если в диалоговом окне Options for Project включен параметр Allow Ports to Name Nets. В этом случае, порты также создают связи в пределах листа схемы.
Power Port
(Порт питания)
Создает связность со всеми другими портами питания с тем же именем во всем проекте, независимо от структуры проекта. Цепь автоматически именуется по порту питания. При необходимости цепь может быть локализована определенным листом схемы.
Sheet Entry
(Вход в лист)
Разместите в символе листа Sheet Symbol, чтобы создать связность с портом с тем же именем на дочернем по отношению к символу листа схеме. Входы в лист используются в качестве имен цепей, если в диалоговом окне Options for Project включен параметр Allow Sheet Entries to Name Nets.
Signal Harness
(Сигнальный жгут)
Используется для группирования любого сочетания цепей, шин и жгутов более низкого уровня.
Wire
(Провод)
Электрический примитив-полилиния, который используется для формирования электрических соединений между точками на схеме. Является аналогом физического провода.

Идентификаторы цепей различных типов с одинаковыми именами не связываются друг с другом автоматически, это зависит от настроек именования цепей. Об этих настройках сказано ниже.

Как структура проекта влияет на связность

Связанная страница: Многолистовые и многоканальные проекты

Если схема не помещается на один лист, ее можно разбить на множество листов. Существуют две отдельных модели организации и создания связности в многолистовых схемам: плоский проект, который можно представить как одну большую схему, разрезанную на ряд более малых листов, и иерархический проект, где листы связаны в структуру типа родитель-потомок.

Создание многолистовых проектов осуществляется путем размещения объектов Sheet Symbol на родительском листе, который представляет связанный дочерний лист, как показано на изображении ниже.


Объекты Sheet Symbol представляют связанные листы более низкого уровня. В плоских проектах у этой структуры может быть только один уровень глубины, в иерархических проектах ограничения на количество уровней нет.

Что определяет, является ли проект плоским или иерархическим? Это параметр Net Identifier Scope, который определяет, как вы хотите создать связь между листами. Его настройка осуществляется на вкладке Options диалогового окна Options for Project.

Проект может содержать только один лист верхнего уровня. Ссылки на остальные исходные документы должны быть заданы символами листов. Символ листа не может ссылаться на лист, на котором он находится, либо ссылать на лист более верхнего уровня, поскольку это создаст неразрешимую петлю в структуре проекта.

Плоский проект

Связанная страница: Многолистовые и многоканальные проекты

Проект называется плоским, если связность создается непосредственно от одного листа к другому, а не через объекты Sheet Symbol на родительском листе. В плоском проекте символы листов лишь представляют дочерние листы (и ссылаются на них). Все листы проекта отображаются в панели Projects на одном уровне, поскольку иерархии нет. На обоих изображениях ниже показан плоский проект.

Создавать плоские проекты проще. Плоский проект может включать в себя лист верхнего уровня с объектами Sheet Symbol для каждого дочернего листа, но это не обязательно, поскольку этот лист верхнего уровня не используется для создания связи между листами. Для небольших проектов, который содержат только два или три листа схемы, лист верхнего уровня может не иметь смысла. Если количество листов велико, лист верхнего уровня может помочь читающему схему понять работу устройства по расположению логических блоков (объектов Sheet Symbol) на листе.

 
Один и тот же проект без листа верхнего уровня (слева) и с листом верхнего уровня (справа). Оба являются примерами плоского проекта.

В плоском проекте, соединения между листами может быть создано с помощью объектов Port, Offsheet Connector, Power Port и Net Label, как показано на изображении с увеличительным стеклом выше. Рекомендуемым подходом является использование объектов Net Label в пределах листа и объектов Port для задания связи между листами. Порты предлагают больше функций, чем межлистовые соединители, в том числе возможность добавлять перекрестные ссылки Port Cross Reference, которые добавляют каждому порту ИмяЛиста[Координаты], ссылаясь на соответствующий порт на другом листе, как показано на изображении ниже.

Ограничения на количество листов в плоском проекте нет.


Возле каждого порта можно добавить перекрестную ссылку Port Cross Reference, которая показывает целевой лист и координаты соответствующего порта.

Поведение плоского проекта, где связность осуществляется непосредственно от одного листа до другого, определяется заданным параметру Net Identifier Scope значением Automatic, Flat или Global. Обратите внимание, что если вы решили использовать сочетание объектов Port и Net Label для создания связи между листами, вы не можете использовать опцию Automatic – в этом случае, необходимо вручную задать параметру Net Identifier Scope значение Global.

Иерархический проект

Главная страница: Многолистовые и многоканальные проекты

Проект называется иерархическим, если связность между листами осуществляется от объекта Sheet Symbol до дочернего листа, на который этот объект ссылается. На уровне цепей, связность создается между объектом Sheet Entry в этом символе листа Sheet Symbol и портом Port с тем же именем, что и у входа в лист, на дочернем листе. Такой тип связности также называется вертикальной, поскольку связь между листами создается только между родительским листом и его дочерними листами.


В иерархическом проекте связность на уровне цепей создается от объекта Sheet Entry на верхнем листе до соответствующего объекта Port на дочернем листе.

У иерархических проектов есть два главных преимущества.

  1. Первое заключается в возможности показать читающему схему функциональность устройства, поскольку листы схем систематизированы и представлены логическими блоками (объектами Sheet Symbol). Лист верхнего уровня представляет проект в качестве набора функциональных блоков высокого уровня, традиционное расположение слева направо, от входа к выходу которых отображает функционирование всей схемы. Если необходимо, эти блоки могут быть далее разбиты на более малые блоки, что позволяет создавать схемы нижнего уровня, на которых расположены компоненты, и формировать относительно простую структуру, с небольшим количеством компонентов. Поскольку каждый лист относительно прост, можно оставлять малый размер листов, что является большим преимуществом для печати схем.
  2. Другим основным преимуществом является то, что в иерархическом проекте отследить сигнал, как правило, проще, поскольку читающему схему нужно только сопоставить объект Sheet Entry на родительском листе и объект Port на дочернем листе, и отследить сигнал по линии связи на каждом листе.

Для формирования иерархического проекта необходимы дополнительные действия – в символах листов нужно создать входы в лист, и на листе верхнего уровня иерархии необходимо создать линии связи для определения сигналов между объектами Sheet Symbol. Система включает в себя средство, которое позволяет поддерживать синхронизацию объектов Sheet Entry с объектами Port на дочерних листах (Design » Synchronize Sheet Entries and Ports для всех объектов Sheet Symbol, либо Sheet Symbol Actions » Synchronize Sheet Entries and Ports из контекстного меню для отдельного объекта Sheet Symbol). Также есть средства, которые помогают разбить большой проект малые блоки (Edit » Refactor » Move Selected Sub-circuit to Different Sheet). Чтобы узнать больше об этих средствах, обратитесь к странице Реструктуризация проекта.

Ограничений на количество уровней и количество листов в иерархическом проекте нет.

Проект является иерархическим, когда связь между листами осуществляется только между объектами Sheet Entry на родительском листе и соответствующими объектами Port на дочернем листе. Это поведение иерархического проекта определяется заданным параметру Net Identifier Scope значением Automatic, Hierarchical или Strict Hierarchical.

Многоканальные проекты

Главная страница: Многолистовые и многоканальные проекты

Электронные устройства зачастую включают в себя повторяющиеся участки схемы. Это может быть стерео-усилитель или 64-канальный микшерский пульт. Подобные проекты полностью поддерживаются в Altium Designer в так называемых многоканальных проектах. В многоканальном проекте вы создаете повторяющуюся схему один раз, и далее указываете системе повторить ее путем размещения множества объектов Sheet Symbol, которые все ссылаются на один дочерний лист схемы, либо настройкой одного объекта Sheet Symbol на повторение дочернего листа необходимое количество раз. При компиляции проекта, схема дублируется в памяти, копируя все компоненты и связи необходимое число раз, в соответствии с заданной пользователем схемой именования.

 
Слева показаны четыре объекта Sheet Symbol, каждый из которых ссылается на один лист схемы (PortIO.SchDoc). Справа показана схема InputChannel.SchDoc, продублированная восемь раз с помощью ключевого слова Repeat.

Логическое представление проекта не разбивается на отдельные схемы, а всегда остается многоканальным. При его передаче в редактор плат, физические компоненты и цепи дублируются необходимое количество раз, и вам доступны все возможности перекрестного перехода и перекрестного выделения при работе между схемой и платой. В редакторе плат также есть средство для дублирования размещения компонентов и трассировки из одного канала в другой, с возможностью простого перемещения и поворота целого канала. Чтобы узнать больше о многоканальных проектах, обратитесь к странице Многоканальные проекты.

Многоканальный проект должен быть иерархическим, поскольку система использует эту структурную модель для создания в оперативной памяти каналов при компиляции проекта.

Для многоканального проекта задайте параметру Net Identifier Scope значение Automatic, Hierarchical или Strict Hierarchical.

Дублирование компонентов и цепей решается системой на основе схемы именования, выбранной на вкладке Multi-channel диалогового окна Options for Project.

Определение области действия идентификаторов цепей

Страница диалогового окна: Options for Project

При компиляции проекта система использует текущие настройки параметра Net Identifier Scope для определения того, как должна быть создана связность между листами схем. Настройка параметра Net Identifier Scope осуществляется на вкладке Options диалогового окна Options for Project (Project » Project Options).


Выберите режим Net Identifier Scope в соответствии со структурой вашего проекта

Поведение опций Global, Flat и Hierarchical показано на изображениях ниже.


Простые примеры, показывающие создание связности для трех главных режимов (слева на право): Global, Flat, Hierarchical.

Помимо упомянутых выше трех опций (Global, Flat, Hierarchical), также существует опция Automatic. Как правило, лучше оставить эту настройку в состоянии Automatic – Altium Designer выберет наиболее подходящий режим на основе структуры листов и наличия/отсутствия объектов Port и Sheet Entry.

Когда выбрано Automatic, система автоматически выбирает, какой из трех основных режимов идентификаторов цепей использовать, на основе следующих критериев:

  • Если на листе верхнего уровня есть входы в лист, будет использоваться Hierarchical.
  • Если нет входов в лист, но есть порты, то будет использоваться Flat.
  • Если нет ни входов в лист, ни портов, будет использоваться Global.

Режим Strict Hierarchical локализует все порты питания на каждом листе. В этом режиме необходимо связать все цепи питания (и земли) на каждом из дочерних листов с помощью объектов Ports и Sheet Entry. Вы можете сделать это для отдельных листов, не используя режим Strict Hierarchical, а разместив объекты Sheet Entry + Port для цепей питания, которые вы хотите локализовать.

Как именуются цепи

Каждый раз, размещая провод между выводами компонентов, вы создаете связность. Каждой цепи в проекте задается имя. Если вы не разместили идентификатор цепи, который может использоваться для именования цепи, то система присвоит этой цепи имя на основе одного из выводов в этой цепи, например NetR7_1, как показано на изображении ниже. Если на каком-либо этапе позиционное обозначение компонента будет изменено, то при компиляции проекта это заданное системой имя цепи также будет изменено, и эти изменения необходимо передать из схемы в плату, чтобы синхронизировать данные проекта.


Цепям без идентификатора цепи присваивается заданное системой имя, на основе одного из выводов в этой цепи.

Объекты Net Label всегда именуют цепи, к которым они присоединяются. Точкой присоединения по умолчанию является нижний левый угол объекта Net Label, обозначенный небольшим перекрестием при перемещении объекта.

Другие идентификаторы будут именовать цепи, если в области Netlist Options вкладки Options диалогового окна Options for Project включены соответствующие параметры.

Идентификаторы цепей различных типов не соединяются друг с другом автоматически. Например, порт с именем Reset не будет соединен с меткой цепи с именем Reset, даже если в диалоговом окне Options for Project включен параметр Allow Ports to Name Nets. Связь между этими объектами необходимо задать проводом.

Множество идентификаторов в одной цепи

Вы не можете размещать множество объектов Net Label с различными именами на одной цепи в пределах одного листа схемы. Подобные ситуации будут помечаться ошибкой при компиляции проекта. Тем не менее, вы можете размещать множество идентификаторов на одной цепи в различных листах схем, где эта цепь присутствует.

Это позволяет разработчику следующее:

  • Изменять имя цепи на различных уровнях иерархии для лучшего отражения назначения цепи на разных листах.
  • Повторно использовать дочерние листы схем без необходимости переименовывать цепи на них.

Настройки по умолчания предполагают, что использовать множество идентификаторов цепей не допустимо. При обнаружении такой ситуации в процессе компиляции появится предупреждение. Если в проекте необходимо использовать множество имен для одной цепи, выполните одно из следующих действий:

  • Измените настройки проверки ошибки Nets with Multiple Names на вкладке Error Reporting диалогового окна Options for Project
  • Подавите отдельные предупреждения путем размещения объекта Specific No ERC Marker на каждом из них. Обратите внимание, что объект Specific No ERC Marker можно разместить, щелкнув ПКМ по предупреждению в списке в панели Messages или щелкнув ПКМ по цветной волнистой линии, обозначающей нарушение на листе схемы. Вид и цвет объекта можно изменить в панели Properties, когда объект No ERC Marker выделен.

Настройки для управления именованием цепей

Страница диалогового окна: Options for Project

В конечном итоге, у цепи на плате может быть только одно имя (у одной цепи платы не может быть два имени), и у каждое имя цепи может использоваться в плате только один раз (на плате не следует использовать две различных цепи с одним именем). Система автоматически обрабатывает цепи со множеством имен, чтобы при компиляции проекта у цепи было только одно имя, но это может быть не то имя, которое вы ожидаете. Для управления тем, какое имя будет выбрано, существует ряд параметров в области Netlist Options на вкладке Options диалогового окна Options for Project. Обратитесь к странице диалогового окна Options for Project для получения более подробной информации об этих параметрах.

Хорошим подходом является включение параметров Allow Ports to Name Nets и Higher Level Names Take Priority. В сочетании с разумным использованием меток для значимых цепей на каждом листе, это позволяет обеспечить именование всех важных цепей, в том числе тех, которые используются на множестве листов, и обеспечить использование имен, присвоенных на схемах более высокого уровня, на схемах более низкого уровня.

Если включены параметры именования множества цепей, используется следующий порядок приоритетов именования цепей:

  • Если параметр Power Port Names Take Priority выключен, используется следующий порядок: Net Label, Power Port, Port, Pin.
  • Если параметр Power Port Names Take Priority включен, используется следующий порядок: Power Port, Net Label, Port, Pin.

Две отдельные цепи с одним именем

Другая проблема именования цепей может возникнуть при использовании одного имени цепи на разных листах схем для обозначения различных цепей. Эта проблема будет обнаружена в ходе компиляции проекта проверкой Duplicate Nets. Вы не можете передать проект в плату при наличии этого нарушения, поскольку при передаче проекта эти две отдельных цепи будут объединены в одну цепь на плате.

Эту ситуацию можно решить включением параметра Append Sheet Numbers to Local Net на вкладке Options диалогового окна Options for Project. Если этот параметр включен, именам всех локальных цепей будет добавлен параметр SheetNumber, как показано на изображении ниже.

 
Поскольку метка цепи Input была использована на множестве листов, был включен параметр Append Sheet Numbers to Local Net для предотвращения появления ошибки Duplicate Nets.
Результат можно увидеть, щелкнув по вкладке скомпилированного листа (изображение справа). Обратите внимание, что имени цепи было добавлено _2.

Параметр Append Sheet Numbers to Local Net будет работать, только если листам схем были назначены уникальные параметры SheetNumber. Параметр SheetNumber присваивается на вкладке Parameters панели Properties в режиме Document Options, для каждого схемного листа. Вместо присвоения уникальных номеров каждому схемному листу вручную вы можете использовать команду Tools » Annotation » Number Schematic Sheets, которая откроет диалоговое окно Sheet Numbering for Project. Его можно использовать для присвоения уникальных параметров SheetNumbers (числовое значение для каждого листа) и DocumentNumbers (обычно используется для нумерации документов согласно выбранной предприятием схеме) всем листам.

Намеренное соединение двух цепей

Бывают случаи, когда необходимо специально соединить две цепи в проекте. Это не простая проблема именования, когда проект требует замкнуть две цепи. Примером может быть ситуация, когда необходимо соединить аналоговую землю и цифровую землю нужным образом.

Это можно сделать, соединив две цепи с помощью компонента Net Tie. Компонент Net Tie является не более чем управляемым замыканием. На схеме у компонента Net Tie присутствуют два (или больше) вывода, которые подсоединяются к цепям, которые необходимо замкнуть. Обратите внимание, что выводы не связываются друг с другом на схеме, но они соединяются вместе внутри посадочного места.


Компонент Net Tie, используемый для трассировки одного тактового сигнала к двум тактовым выводам ПЛИС. На печатной плате контактные площадки (показаны штриховкой) посадочного места компонента Net Tie замкнуты трассой (показана контуром).

На стороне печатной платы, посадочное место содержит столько же контактных площадок, сколько выводов присутствует в схемном компоненте, с проводником между ними. Система автоматически игнорирует короткие замыкания, созданные внутри компонента Net Tie на плате, поэтому ошибка не будет создаваться.

В этом случае, у каждой цепи будет собственное имя, как на схеме, так и на плате.

  • При создании символа и посадочного места компонента Net Tie задайте параметру Component Type значение Net Tie или Net Tie in BOM.
  • При трассировке компонента Net Tie на плате можно использовать любые режимы для трассировки от контактной площадки компонента Net Tie. Для трассировки к контактной площадке компонента Net Tie переключитесь в режим Stop at First Obstacle или Ignore Obstacle.
    Показать изображение

Цепи питания

Настройки по умолчанию предполагают, что цепи питания являются глобальными, т.е. они будут доступны на любом схемном листе. Чтобы получить доступ к цепи питания, просто разместите объект Power Port с нужным именем цепи, затем задайте связи между компонентами и этими портами питания.


Именно имя цепи определяет, к какой цепи будет подключен порт питания, а не стиль символа. На изображении выделены три порта питания, и они все подключены к цепи питания GND.

Локализация цепи питания – Глобально

Как упоминалось ранее, в иерархическом проекте цепи питания можно локализовать в каждом листе схемы путем выбора опции Strict Hierarchical у параметра Net Identifier Scope. Этот подход локализует все цепи питания на каждом листе, поэтому эти цепи необходимо связать между собой тем же образом, что и сигнальные цепи. Если этого не сделать, то при компиляции проекта появится ошибка Duplicate Net Name для каждой цепи питания, которая присутствует на каждом листе схемы. Также необходимо задать настройки Connection Matrix, чтобы объекты Port могли быть подключены к объектам Power Port.


Если параметру Net Identifier Scope задано значение Strict Hierarchy, то цепи питания необходимо связать вручную на каждом листе, где они используются.

Локализация цепи питания – Индивидуально

Определенную цепь питания можно локализовать на определенном листе, подключив Power Port к объекту Port на этом листе схемы.


Здесь присутствует цепь питания 3V3, которая была локализована только этим листом, поэтому ее связи необходимо задать на родительском листе вручную. Цепи GND и 5V остаются глобальными цепями питания.

Цепи питания и скрытые выводы питания

Более ранние версии систем Altium для проектирования включали в себя функции и параметры, которые поддерживали использование скрытых выводов схемных компонентов. Эта функция была полезной, когда в проекте была одна цепь питания и одна цепь земли, что позволяло автоматически подсоединить все выводы питания всех компонентов к соответствующим цепям, скрыв эти выводы питания. Это было наиболее распространено для многосекционных компонентов, поскольку избавляло разработчиков от необходимости отображения выводов питания этих компонентов на схеме.

Современные электронные устройства, как правило, содержат множество цепей питания и земли. И эти цепи не просто трассируются к соответствующим контактам питания – доставка питания теперь является критически важным аспектом успешного конструирования платы.

Поскольку природа проектирования цепей доставки питания изменилась, необходимость скрывать выводы компонентов и автоматически соединять их отпала – до такой степени, что большинство разработчиков выступают против этой практики. Поэтому Altium Designer больше не поддерживает скрытие выводов и предварительное назначение им имени цепи. Старые проекты будут корректно формировать списки цепей при открытии в более новых версиях Altium Designer.

Группирование множества цепей

Общей сложностью больших проектов является поддержка управляемости цепей, не только с точки зрения разработчика, который создает связность, но и с точки зрения читающего схему, которому необходимо интерпретировать и понять ее. Это особенно важно для многолистовых схем, поскольку здесь и разработчик, и читающий схему могут легко запутаться.

Здесь может помочь группирование цепей в линии Bus или Signal Harness.

Работа с линиями Bus

Линии Bus (Шина) используются для группирования набора последовательных цепей, например шины адреса или шины данных. Ключевым требованием является именование этих цепей: все цепи должны содержать общее основное имя, после которого идет цифровой идентификатор, как показано на изображении ниже. Например, цепи Control1, Control2 и Control3 могут быть объединены в шину Control[1..3]. Шины не могут использоваться для группирования не связанных между собой цепей, например, Enable, Read и Status. Для этого используются линии Signal Harness, о которых сказано ниже.

Чтобы создать корректную шину, она должна включать в себя следующие элементы (как показано на изображении ниже):

  • Объект Net Label на каждой отдельной цепи
  • Объект Net Label на линии Bus
  • Объект Port с тем же именем, что у линии Bus, если шина уходит на другие листы

 
Для создания корректной шины должны присутствовать все элементы, показанные на изображении выше. Объекты Bus Entry необходимо использовать, только если вы хотите разместить различные элементы шины по разные стороны от линии Bus.

Шины не передаются в плату. Вместо этого, для каждой шины на схеме, либо, если необходимо, для каждой секции шины, может быть создан класс цепей. Создание секции шины осуществляется путем определения шины, которая, по сути, является частью большей шины, например D[15..8], из шины D[15..0]. Если включен соответствующий параметр, то плата будет включать в себя класс цепей для всей шины, а также для каждой созданной секции. Включение этих параметров осуществляется на вкладке Class Generation диалогового окна Options for Project.

Работа с линиями Signal Harness

Линии Signal Harness (Сигнальный жгут) достаточно гибки в настройке, поскольку их можно использовать для группирования любого количества цепей, шин и жгутов более низкого уровня. Как следует из имени, они аналогичны проводным жгутам, в которых может быть сгруппировано любое сочетание проводов для трассировки в электронном или электротехническом изделии. Создание жгутов и управление ними сложнее, но в результате они значительно упрощают представление схемы и повышают ее читаемость.


Жгуты используются для группирования любого сочетания цепей, шин и жгутов более низкого уровня.

Элементы, которые в совокупности составляют жгут, включают в себя:

  • Объект Harness Connector – представляйте Harness Connector в виде воронки, которая собирает все подключаемые сигналы через объекты Harness Entry. Ключевым свойством объекта Harness Connector является Harness Type, которое определяет жгут и используется для объединения различных элементов, составляющих сигнальный жгут, в том числе подключаемые объекты Port / Sheet Entry.
  • Объекты Harness Entry – каждый сигнал (цепь, шина или сигнальный жгут), который нужно добавить в этот сигнальный жгут, входит в Harness Connector через объект Harness Entry. Объект Harness Entry включает в себя свойство Harness Type, которое используется только для вложенных сигнальных жгутов и указывает, что к этому Harness Entry подключен сигнальный жгут более низкого уровня.
  • Линия Signal Harness – подобная шине линия, которая размещается для переноса сигнального жгута на листе.
  • Свойство Harness Type – Harness Type является набором объектов Harness Entry. Каждый найденный Harness Type определяется в файле Harness Definition File, как описано ниже. Harness Type и связанные с ним объекты Harness Entry, по сути, являются именами контейнеров, которые переносят цепи, а не именами самих цепей. Чтобы проверить значение Harness Type, наведите курсор мыши на объект, например, Port, Sheet Entry или Harness Connector (проект должен быть скомпилирован).
  • Файл Harness Definition File – система управляет сигнальными жгутами, записывая объекты Harness Entry, которые находятся в каждом сигнальном жгуте (Harness Type), в ASCII-файл Harness Definition File. На изображении ниже показан синтаксис файла Harness Definition File – для каждого Harness Type в этом файле существует строка, которая описывает объекты Harness Entry внутри этого жгута. Файл Harness Definition File создается (и управляется) автоматически для каждого листа схемы, в котором присутствуют Harness Connector – вы можете найти эти файлы в папке \Settings в дереве проекта, как показано на изображении ниже. Если в проект вносятся изменения, которые влияют на сигнальные жгуты, файлы Harness Definition автоматические обновляются при компиляции проекта. Если файл Harness Definition File отсутствует в папке проекта, он автоматически создается повторно при открытии листа схемы (если необходимо, его можно удалить, и он будет создан повторно автоматически).
  • Объекты Port + Sheet Entry – подобно цепи или шине, сигнальный жгут можно передать на другие листы через порт и затем связать с листом более верхнего уровня через соответствующий вход в лист. Обратите внимание, что система автоматически изменяет цвет объектов Port и Sheet Entry, чтобы показать, что они переносят сигнальный жгут – для этого должен быть включен параметр Sheet Entries and Ports use Harness Color на странице Schematic - Graphical Editing диалогового окна Preferences. Обратите внимание, что объекты Port и Sheet Entry включают в себя свойство Harness Type, значение которого задается автоматически при подключении порта к линии Signal Harness, когда вы размещаете порт. Для порта на листе схемы, в которой определен жгут (присутствует Harness Connector), свойство Harness Type определяется автоматически, и его нельзя изменить. Для объекта Port или Sheet Entry, размещенного на листе схемы более высокого уровня, это свойство будет пустым и доступным для редактирования; как правило, в его ручной настройке нет необходимости. Назначенное свойство Harness Type можно проверить в любой момент, наведя курсор мыши на объект Port/Sheet Entry.


Определения жгутов хранятся в файлах Harness Definition. На изображении выше показаны два определенных сигнальных жгута: 1WB_Write_Read и JTAG.

Как упоминалось ранее, помимо цепей и шин, вы можете подсоединить к сигнальному жгуту другой сигнальный жгут и создать так называемые вложенные сигнальные жгуты. Этот случай определяется в объекте Harness Entry, свойству Harness Type которого присваивается значение входящего сигнального жгута.


Помимо цепей и шин, сигнальный жгут может переносить другие сигнальные жгуты.

На изображении выше, сигнальный жгут Stereo был использован дважды. Это корректно, поскольку ни сигнальный жгут, ни входы в жгут не используются для определения цепей, которые переносит жгут. Вы можете использовать сигнальный жгут повторно где угодно в проекте. Примените для этого команду Place » Harness » Predefined Harness Connector. Будет открыто диалоговое окно, которое включает в себя опции по размещению линии Signal Harness и объекта Port, если это необходимо.


Существующие сигнальные жгуты могут быть использованы повторно где угодно в проекте, в том числе на одном листе схемы для переноса различных цепей.

Элементы, которые составляют сигнальный жгут, используются компилятором проекта для определения цепей, которые входят в этот сигнальный жгут, и определения отдельных логических соединений, которые располагаются на множестве листов схем. Элементы сигнального жгута не используются для именования цепей – для этого используются стандартные способы именования цепей, о которых уже было сказано ранее.

Это поведение можно переопределить при необходимости. Цепям в сигнальном жгуте может быть задано имя на уровне жгута путем размещения объекта Net Label на линии Signal Harness. В этом случае, изначальный объект Net Label больше не будет использоваться, вместо этого цепь будет именоваться по объекту Net Label, размещенному на линии Signal Harness, и объекту Harness Entry, в следующем виде:

  • Заданное системой имя цепи = ИмяЦепиНаЛинииSignalHarness.ИмяHarnessEntry


Сигнальным жгутам JTAG заданы имена на уровне жгута, определенные наличием объектов Net Label HARD и SOFT. Заданные системой имена цепей показаны на изображении ниже.
У сигнального жгута 1WD_Write_Read нет заданного на уровне жгута имени, поэтому его цепи сохраняют имена объектов Net Label.

На изображении выше, на линии Signal Harness каждого экземпляра жгута JTAG размещены объекты Net Label с именами HARD и SOFT. Поскольку было добавлено имя цепи на уровне жгута, то метки цепей внутри этих жгутов используются только для создания логических соединений в пределах этого листа. При компиляции проекта цепям присваиваются имена, использующие обозначенный выше синтаксис, как видно на изображении ниже.


Обратите внимание на именование цепей JTAG, составленных из объекта Net Label жгута и объектов Harness Entry.

Для именованных сигнальных жгутов также могут быть созданы классы цепей платы. Для этого включите соответствующий параметр на вкладке Class Generation диалогового окна Options for Project. Классы цепей создаются только для сигнальных жгутов, проименованных объектом Net Label.

У именования цепей в сигнальном жгуте путем размещения объекта Net Label на линии Signal Harness (как описано в предыдущем разделе) есть преимущество, которое заключается в том, что оно также позволяет работать с сигнальными жгутами без необходимости добавлять объект Harness Connector и объекты Harness Entry на лист схемы. Некоторые разработчики предпочитают использовать такой подход, поскольку это делает схему более простой и наглядной, как показано на изображении ниже, где сигнальный жгут JTAG не использует объект Harness Connector.

Обратите внимание, что для такого способа необходим по крайней мере один объект Harness Connector этого типа (Harness Type) где-либо в проекте, либо определение жгута должно быть заблокировано (LOCKED) в файле Harness Definition. Это ключевой слово не позволяет системе удалить определение жгута при ручном или автоматическом обновлении файлов Harness Definition. Синтаксис блокирования определения жгута показан на изображении ниже.


Как и сигнальные жгуты, которые используют объекты Harness Connector, сигнальный жгут без Harness Connector должен быть определен в одном из файлов Harness Definition для схемы, в котором такой жгут используется.
Это определение должно включать в себя ключевое слово LOCKED, чтобы система не удаляла и не изменяла это определение.

Компиляция проекта

Связанная страница: Компиляция и верификация проекта

На этой странице множество раз упоминалась компиляция проекта. Что же такое компиляция, и зачем необходимо компилировать проект?

Редактор схем является интеллектуальным средством черчения, а не просто инструментом для определения связей. Когда вы соединяете два вывода с помощью провода, вы, по сути, фиксируете свой инженерный замысел, а не создаете цепь. Цепь не будет создана до момента компиляции проекта. Существует ряд преимуществ такого подхода, самым большим из которых является то, что скомпилированная модель проекта находится вне отдельных редакторов. Скомпилированная модель называется унифицированной моделью данных (Unified Data Model – UDM). Эта модель включает в себя подробное описание каждого компонента в проекте и его связь с другими компонентами.

При компиляции проекта система:

  • Строит список цепей для каждого листа схемы
  • Создает связность между листами, на основе выбранной области действия идентификаторов цепей
  • Строит унифицированную модель данных, отображая подробную информацию о компонентах и связях в панели Navigator
  • Анализирует проект на ошибки

Унифицированная модель данных

В основе системы лежит унифицированная модель данных (Unified Data Model – UDM). При компиляции проекта происходит создание единой связанной модели, которая занимает центральное место в процессе проектирования. Данные этой модели затем можно открывать и изменять с помощью различных редакторов и служб системы. Вместо того, чтобы хранить данные каждого аспекта проектирования по отдельности, модель UDM структурирована для хранения всей информации о проекте, в том числе о компонентах и связи между ними.


Унифицированная модель данных делает данные о проекте доступными для всех редакторов, что позволяет использовать такие расширенные возможности проектирования, как многоканальное проектирование.

Итак, как же взаимодействовать с унифицированной моделью данных, чтобы, например, отследить цепь в проекте? Это осуществляется через панель Navigator.

Изучение связности

Справочная страница: Панель Navigator

Если проект большой и разбит на множество листов, может быть сложно отследить цепь и проверить связность проекта, просто взглянув на схему. Чтобы упростить этот процесс, используется панель Navigator. Панель отображает весь скомпилированный проект, поэтому она будет пустой, пока вы не скомпилируете проект (Project » Compile PCB Project).

Основной подход к использованию панели приведен ниже:

  • Задайте поведение просмотра, нажав кнопку  в верхней части панели – будет открыто диалоговое окно Preferences, где вы сможете задать предпочитаемый метод подсветки (настройки области Highlight Methods). Либо щелкните ПКМ по интересующему объекту в панели и используйте команды контекстного меню для настройки поведения навигации, как показано на изображении ниже.
  • Задайте область просмотра в области Documents for панели. Для просмотра всего проекта выберите Flattened Hierarchy.
  • Щелкните мышью по компоненту в области Instance панели, чтобы перейти к этому компоненту.
  • Щелкните мышью по цепи или шине в области Net/Bus, чтобы перейти к этой цепи или шине.
  • Зажмите клавишу Alt при щелчке мышью, чтобы перейти к объекту как на схеме, так и на плате.


Щелкните по компоненту или цепи в панели Navigator, чтобы найти этот компонент или цепь и отследить связность в проекте. Щелкните ПКМ, чтобы увидеть опции отображения.
Наведите курсор мыши на изображение, чтобы увидеть навигацию к компоненту одновременно на схеме и на плате (зажмите клавишу Alt при щелчке мышью в панели Navigator, чтобы включить объект на плате).

Навигация к компонентам на плате

Помимо проведения поиска компонентов на схеме и на плате (при зажатой клавише Alt) из панели Navigator, вы также можете переходить к выводам/компонентам/цепям/шинам/жгутам на плате непосредственно из схемы.

Например, при щелчке мышью по компоненту на схеме, вы также можете найти этот компонент на плате.

Для этого необходимо сделать следующее:

  • Включите параметр Selecting в области Highlight Methods, а также задайте предпочтительные настройки в области Cross Select Mode на странице System - Navigation диалогового окна Preferences.
  • Включите перекрестное выделение (Tools » Cross Select Mode) в редакторе схем или редакторе плат.


Эти настройки определяют поведение навигации и перекрестного выделения.

Теперь при выделении выводов/компонентов/цепей/шин/жгутов на схеме эти объекты будут также выделены на плате, как показано на изображении ниже.


При выделении компонентов и цепей на схеме, эти объекты будут также выделены на плате. Перекрестное выделение также работает из платы в схему.

Перекрестный переход и перекрестное выделение

Помимо возможности выделения объектов из одного редактора в другом (перекрестное выделение), система также поддерживает перекрестный переход. У перекрестного перехода есть два режима: непрерывный (оставляет исходный редактор активным) и переходной (переход в целевой редактор). Вы также можете осуществлять перекрестный переход из различных панелей и диалоговых окон, например, из панели Messages и диалогового окна Engineering Change Order. Чтобы узнать больше, обратитесь к странице Перекрестный переход и выделение.

Связность в проектном пространстве платы

В редакторе плат, связность между узлами в цепи представляется набором линий соединения между точками.

В пределах отдельной цепи, эти линии соединяют все узлы этой цепи. Порядок соединения называется топологией цепи, о которой сказано ниже.


Узлы в цепи соединены линиями соединения.

Линии соединения отображаются как сплошные тонкие линии. Линии соединения помогают при размещении компонентов для определения положения и поворота компонентов, которые соединены между собой. Чтобы сделать отображение более ясным, при перемещении компонента все линии соединения скрываются, кроме линий, подсоединенных к этому компоненту.


Используйте линии соединения при размещении и повороте компонентов.

Кроме того, что линии соединения являются полезной подсказкой при размещении компонентов, их также можно использовать при интерактивной и автоматической трассировке. Поскольку связность отслеживается и обновляется в процессе вашей работы, вы можете провести трассу до любой точки цепи, чтобы завершить соединение, а не только до той контактной площадки, на которой заканчивается линия соединения.

Топология цепи

Порядок, в котором узлы цепи соединены друг с другом, называется топологией цепи. Топология цепи управляется применяемым правилом проектирования Routing Topology, в котором по умолчанию задана топология Shortest (Наикратчайшая). Это значит, что узлы цепи соединяются между собой в таком порядке, в результате которого общая длина линий соединений цепи оказывается наименьшей. Эта общая длина отслеживается при перемещении компонента, и порядок линий соединений будет изменяться динамически для поддержания их наименьшей общей длины. Это можно видеть на анимации выше, где линии, соединенные с нижним компонентом, изменяют точки подключения при перемещении компонента. Это происходит каждый раз, когда контактная площадка перемещается ближе к другой контактной площадке в цепи.

Применение предопределенной топологии

Справочная страница: Правило проектирования Routing Topology

Чтобы цепь (или класс цепей) использовал другую топологию, могут быть созданы дополнительные правила проектирования Routing Topology. На изображениях ниже слева показана топология правила по умолчанию, справа показана топология Starburst (Звезда), примененная к той же цепи. В топологии Starburst линии соединения исходят из контактной площадки, у которых в качестве электрического типа Electrical Type задано Source (типом по умолчанию всех контактных площадок является Load).


При топологии по умолчанию линии соединения образуют наименьшую общую длину. При топологии Starburst все линии соединения исходят из контактной площадки с типом Source.

Применение пользовательской топологии

Справочная страница: From-To Editor

В отдельной цепи, соединение между двумя узлами называется From-To (От-До). Чтобы управлять путем линий соединения на уровне отдельных пар контактных площадок, вы можете создавать пути From-To внутри цепи вручную, по сути, определяя пользовательскую топологию цепи.

Соедиения From-To определяются в режиме From-To Editor панели PCB. Процесс определения From-To следующий: выделите в панели два узла цепи (Nodes on Net) и нажмите кнопку Add From To. Чтобы отличать соединения From-To в рабочей области, они отображаются пунктирными, а не сплошными линиями.


Между двумя контактными площадками было определено соединение From-To. Обратите внимание, что линия From-To отображаются пунктирной, а не сплошной линией.

Когда панель PCB находится в режиме From-To Editor, все линии соединения, которые не являются From-To, скрываются.

Для получения более подробной информации об определении соединений From-To обратитесь к странице From-To Editor.

Управление отображением линий соединения

Справочные страницы: Панель View Configuration, Объект Connection

  • Включите/отключите отображение всех линий соединения путем переключения параметра Default Connection Lines в области System Colors на вкладке Layers and Colors панели View Configuration.
  • Включите/отключите отображение линий соединения выборочно с помощью команд подменю View » Connections (нажмите клавишу N, чтобы открыть это меню). У всех доступных команд есть быстрые клавиши, которые позволяют быстро выполнить такие задачи, как скрытие всех линий соединения (N, H, A) и последующее отображение линий соединения определенной цепи (N, S, N).
  • В режиме одного слоя (Shift+S) отобразите линии, которые соединяют контактные площадки только на этом слое. Используйте для этого параметр All Connections in Single Layer Mode в панели View Configuration (раздел Additional Options на вкладке View Options).
  • Для линии соединения, которая начинается и заканчивается на различных слоях, отобразите ее с помощью сочетания цветов начального и конечного слоя. Используйте для этого параметр Use Layer Colors For Connection Drawing в панели View Configuration (раздел Additional Options на вкладке View Options).
  • Назначьте цвет линиям соединения в цепи или в наборе цепей, чтобы легко распознавать их. Об этом сказано ниже.
  • Примените маскирование или затенение ко всем цепям, кроме нужных. Откройте панель PCB в режиме Nets, затем выберите Dim (затенить прочие объекты, но разрешить редактирование затененных объектов) или Mask (маскировать прочие объекты и разрешить редактирование только немаскированных объектов) в выпадающем списке, затем щелкните мышью по цепи (или классу цепей). Все объекты будут затенены, за исключением тех, которые принадлежат выбранной цепи (цепям), что упрощает отображение и работу с объектами в этой цепи.
  • При перемещении компонента вы можете временно отключить оптимизацию и отображение линий соединения нажатием клавиши N.

Настройка цвета цепей

Чтобы сделать схему более читаемой и упростить работу с цепями и трассами в редакторе плат, можно использовать цвет для связей на схеме и для цепей и трасс на плате.

Применить выделение цветом к цепи или шине в редакторе схем можно с помощью команд в подменю View » Set Net Colors, как показано на изображении ниже. Эти цвета в любой момент можно передать в редактор плат с помощью команды Update PCB.

В редакторе плат, цвет и видимость по умолчанию для линий соединения определяется настройками Connection Lines в разделе System Colors панели View Configuration. Обратите внимание, что этот цвет по умолчанию применяется при создании цепей (при первой передаче проектных данных со схемы); цвет существующих линий соединения не изменяется при изменении этой настройки.

В редакторе плат, цвета, примененные к цепям, отображаются в панели PCB в режиме Nets на фоне флажка рядом с именем цепи, как показано в правом нижнем углу изображения ниже.

Этот цвет всегда применяется к неразведенным цепям (к линиям соединения). Чтобы применить этот цвет к разведенным цепям, включите флажок рядом с именем цепи в панели PCB и задайте настройки отображения на странице Board Insight Color Overrides диалогового окна Preferences. В примере на изображении ниже для основного шаблона переопределения цвета задан параметр Solid, в качестве поведения при отдалении задано значение Override Color Dominates.

Цвета цепей, примененные в редакторе схем, передаются в плату с помощью команды Update PCB. Настройте переопределение цветов в плате, чтобы управлять тем, как эти цвета будут отображаться в плате.

Нажмите F5 для переключения состояния функции Net Color Override в редакторе схем и в редакторе плат. Может понадобиться выполнить обновление экрана (End).

Изменение цвета цепей на плате

Не всегда возможно применить цвет к связям на схеме и передать его в плату. В этом случае, цвет можно применить к линиям соединения и к трассировке в редакторе плат. Чтобы изменить цвет цепи после передачи проекта, дважды щелкните мышью по имени цепи в режиме Nets в панели PCB. Цвет отдельной цепи можно изменить в диалоговом окне Edit Net.

Чтобы изменить цвет множества цепей, используйте режим Nets панели PCB:

  • Используйте стандартные способы выделения множества объектов (Shift+ЛКМ или Ctrl+ЛКМ) для выделения множества классов цепей или отдельных цепей.
  • Щелкните ПКМ по одному из выделенных объектов и выберите команду Change Net Color из контекстного меню, чтобы назначить выбранным цепям новый цвет.
  • Щелкните ПКМ еще раз и выберите команду Display Override » Selected On, чтобы включить переопределение цвета для выбранных цепей.


Улучшите отображение цепей путем изменения цвета линий соединения и включения переопределения цвета.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Отлично! Знаете ли Вы, что мы предлагаем для студентов специальные скидки на лицензии? Для получения более подробной информации нажмите здесь.

А пока что Вы можете запросить пробную лицензию, заполнив форму ниже.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.