Ansys CoDesigner

Debido a la complejidad de los productos electrónicos modernos que incorporan circuitos de alta velocidad y RF, se requiere una comunicación intensiva entre los ingenieros de PCB y de simulación durante el proceso de diseño de PCB, y esta comunicación debe ser lo más clara y sencilla posible para ambas partes. No basta con exportar un diseño modificado por el ingeniero de PCB u optimizado por el ingeniero de simulación y pasarlo a la otra parte; también debe comunicarse qué se ha cambiado, lo que normalmente se hace por correo electrónico o verbalmente. Este enfoque es imperfecto debido a la necesidad de hacer seguimiento de todas las solicitudes y comparar los datos manualmente para decidir cambios en el diseño o iniciar un nuevo análisis. Estos y otros desafíos relacionados pueden superarse mediante Ansys CoDesigner, una interfaz para transferir diseños de placas de circuito impreso entre los ámbitos de diseño de PCB y simulación.

Esta función está disponible cuando están instaladas la extensión Ansys CoDesigner (para Altium Designer) y la extensión Altium Link (para Ansys Electronics Desktop).

Software compatible

Actualmente son compatibles la siguiente plataforma de simulación y sus versiones:

Ansys Electronics Desktop (AEDT) – versión 2023 R1, 2023 R2, 2024 R1, 2024 R2, 2025 R1, 2025 R2, 2026 R1

Instalación y configuración

Para acceder a Ansys CoDesigner en Altium Designer, debe estar instalada la extensión de software Ansys CoDesigner. Esta extensión puede instalarse o eliminarse manualmente.

Para obtener más información sobre la gestión de extensiones, consulte la página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Para acceder a Ansys CoDesigner en Ansys Electronics Desktop, debe instalarse la extensión Altium Link. El proceso es el siguiente:

  1. Descargue y descomprima el archivo de la extensión Altium Link. Puede obtenerse contactando con ansyscollaboration@altium.com (indique la versión de AEDT utilizada).

  2. Asegúrese de que la aplicación AEDT esté cerrada.

  3. En la carpeta descomprimida, localice el archivo install_altiumlink.bat, haga clic con el botón derecho sobre él y seleccione Run as administrator.

  4. Abra AEDT y seleccione el comando Tools » Layout Links en los menús principales.

  5. En la pestaña Config del cuadro de diálogo Layout Links que se abre, haga clic en el botón Add Link, vaya a la carpeta \AnsysEM\<version>\Win64 de los archivos del programa AEDT y abra el archivo altiumlink.dll.

  6. En la pestaña Layout Links del cuadro de diálogo Layout Links, asegúrese de que el vínculo Altium aparezca en la lista y cierre el cuadro de diálogo.

Cómo funciona

Una vez que la funcionalidad de Ansys CoDesigner se ha añadido al software de diseño de PCB y simulación, puede transferir cambios de diseño en ambos sentidos. Los cambios de diseño se transfieren a través de un Altium 365 Workspace, que actúa como puente entre los dos ámbitos. La ventaja de transferir cambios de diseño a través de un Workspace es que el proceso de actualización se vuelve stateless. Esto significa que cada parte puede seguir trabajando de manera independiente; no hay necesidad de preocuparse por el punto del proceso de diseño/simulación en el que se encuentra el otro equipo.

Ansys CoDesigner facilita el intercambio bidireccional push/pull de cambios de diseño entre los dos ámbitos. Desde Altium Designer, se detectan los cambios en el apilado de capas y materiales, componentes y primitivas, y pueden aplicarse en AEDT. Desde AEDT, los cambios propuestos en el apilado de capas y materiales pueden enviarse a través del archivo EDB y detectarse/aplicarse en Altium Designer. Los ingenieros de ECAD y simulación pueden comunicarse mediante el sistema de comentarios, con cada hilo de comentarios asociado a un componente específico de un diseño. Los resultados de simulación pueden enviarse desde AEDT a Altium 365 Workspace y asociarse con una revisión del diseño, con la posibilidad de visualizarlos a través de la interfaz del navegador del Workspace y previsualizarlos dentro de Altium Designer.

La interfaz de colaboración

  • En Altium Designer, el panel Ansys CoDesigner  se utiliza para hacer Push y Pull de los cambios de diseño en ambos sentidos y mostrar mensajes.

    Se accede al panel Ansys CoDesigner  desde el editor PCB en Altium Designer haciendo clic en el botón Panels en la parte inferior derecha del espacio de diseño y seleccionando la opción Ansys CoDesigner  en el menú que aparece. Tenga en cuenta que debe estar conectado a un Workspace para acceder al panel, y el documento PCB debe formar parte de un proyecto PCB almacenado en este Workspace para poder usar la funcionalidad.

  • En AEDT, los cuadros de diálogo a los que se accede desde el cuadro de diálogo Layout Links (Tools » Layout Links) o desde la pestaña Desktop de la cinta cuando hay un proyecto abierto se utilizan para:
    • Conectarse a su Altium 365 Workspace e importar desde él un diseño de PCB.
    • Hacer Push del diseño al Workspace y hacer Pull desde él.
    • Explorar el historial de intercambio de datos entre Altium Designer y AEDT.
    • Añadir comentarios a componentes del diseño.

Enviar cambios desde Altium Designer

Para enviar el diseño desde Altium Designer, haga clic en el botón Push en el panel Ansys CoDesigner . Aparecerá una ventana de edición en la parte superior del panel. Introduzca un mensaje sobre el cambio de diseño y, a continuación, haga clic en Send. La región Latest from Altium Designer del panel Ansys CoDesigner  se actualizará con los detalles de este envío.

A continuación, el diseño puede importarse a AEDT. Para un diseño que ya se haya importado, los cambios pueden traerse a AEDT.

Tenga en cuenta que, al utilizar la funcionalidad Ansys CoDesign, la información sobre modelos de simulación (SPICE, IBIS, etc.) se transfiere desde los esquemáticos al PCB al aplicar la orden de cambio de ingeniería. Use el tipo de comparación Changed Simulation Model en la pestaña Comparator tab of the Project Options dialog y el tipo de modificación Change Component Simulation Model en la pestaña ECO Generation tab of the Project Options dialog para configurar, respectivamente, la detección de diferencias en los modelos de simulación entre los esquemáticos y el PCB y la creación de ECO para estas diferencias.

Obtenga más información sobre Keeping the Schematics & PCB Synchronized.

Push and Share para invitar a un ingeniero de simulación

Cuando haga clic en Push en el panel Ansys CoDesigner , también puede habilitar la opción Share debajo del campo Comment para enviar por correo electrónico una invitación al ingeniero de simulación usando el cuadro de diálogo Share with a Simulation Engineer que se abre después de hacer clic en el botón Send.

Introduzca la dirección de correo electrónico del ingeniero de simulación y una nota opcional (si es necesario), y luego haga clic en el botón Share . Puede compartir con una persona que ya sea miembro del equipo de su Workspace, con otro usuario registrado de Altium dentro o fuera de su organización, o con un usuario que no tenga una cuenta de Altium. Puede aparecer un cuadro de diálogo de notificación para alertarle de que el usuario cuyo correo electrónico ha introducido podría estar fuera de su organización; haga clic en OK para invitarlo de todos modos.

Tras una breve espera, aparecerá otro cuadro de diálogo indicando que la invitación se envió correctamente.

Como parte del proceso de invitación:

  • Un usuario que ya sea miembro del equipo de su Workspace tendrá el proyecto compartido con él con permisos de visualización, y recibirá un correo electrónico de invitación con el que podrá acceder al proyecto dentro del Workspace.
  • Un usuario que no sea miembro del equipo de su Workspace pero tenga una cuenta de Altium (independientemente de si está dentro o fuera de su organización) será añadido como miembro del equipo del Workspace, y el proyecto se compartirá con él con permisos de visualización. Recibirá un correo electrónico de invitación con el que podrá acceder al proyecto dentro del Workspace.
  • Un usuario sin cuenta de Altium recibirá un correo electrónico que lo dirigirá a un formulario intermedio para registrarse/crear una cuenta de Altium. Se añadirá como miembro del equipo del Workspace al registrarse, y el proyecto se compartirá con él con permisos de visualización.
  • La invitación solo puede realizarla un administrador del Workspace.
  • El ingeniero de simulación no podrá importar el diseño de la placa en AEDT si el proyecto no se comparte con él.
  • Debe iniciar sesión en su Workspace en el navegador y confirmar que al ingeniero de simulación invitado se le haya asignado Edit permissions en el cuadro de diálogo del proyecto Share. Aunque el ingeniero de simulación podrá hacer Pull del diseño solo con permisos de visualización, no podrá hacer Push de cambios al diseño si the project no se comparte con él con permisos de edición.
  • Tenga en cuenta que el usuario que no tenga una cuenta de Altium será tratado como si fuera su propia organización personal al registrarse. No se añadirá a su organización.

Traer cambios a Altium Designer

Cuando se envían desde AEDT nuevos cambios, el banner New changes have been detected aparece automáticamente en el panel Ansys CoDesigner . El panel mostrará el nombre del ingeniero de simulación que realizó el Push y el comentario opcional que introdujo al hacer el Push.

Cuando se hace clic en el botón Pull y si el archivo EDB se ha incluido en el Push desde AEDT, se listará cada cambio que debe realizarse en el archivo de trabajo para sincronizarlo con la instantánea de su Workspace. Cada diferencia detectada se enumera en la lista Changes del panel. Desmarque la casilla de cada cambio que no desee aplicar. Cuando esté listo, haga clic en el botón Apply para aplicar al diseño todos los cambios habilitados.

Si los resultados de simulación se han incluido en el Push desde AEDT, el control Design Summary se mostrará en el panel. Haga clic en el control para presentar los resultados de simulación en el cuadro de diálogo Design Summary.

Los resultados de simulación también pueden consultarse en la vista del proyecto en la interfaz de navegador de Altium 365, en la carpeta Ansys del área Simulation .

Importar un diseño a AEDT

Para comenzar a trabajar en un diseño de PCB en AEDT, primero debe importarse a AEDT. Para ello:

  1. En el cuadro de diálogo Layout Links (Tools » Layout Links), haga clic en la celda [Action] para el vínculo Altium en la pestaña Layout Links y seleccione Projects. Como alternativa, haga clic en el botón Projects de la pestaña Desktop de la cinta cuando haya un proyecto abierto. Se abrirá el cuadro de diálogo Altium.
  2. Inicie sesión en su cuenta de Altium. Asegúrese de que la entrada Altium Account esté seleccionada en la lista desplegable de la parte superior del cuadro de diálogo y haga clic en el botón Sign In. Se abrirá una página en su navegador predeterminado donde podrá introducir las credenciales de su cuenta de Altium o usar SSO para iniciar sesión en su cuenta de Altium: show example.

    • El método de autenticación SSO es compatible con AEDT 2024 R1.
    • Cuando esté conectado, use el botón Sign Out en la parte superior del cuadro de diálogo Altium para cerrar sesión en la cuenta de Altium conectada actualmente. 
  3. Seleccione el Workspace donde reside el proyecto requerido en la lista desplegable Workspace.
  4. Seleccione el proyecto en la lista Projects y haga clic en el botón Import.

    Tenga en cuenta que el proyecto debe haberse enviado desde Altium Designer para que esté disponible para importación.
  5. Guarde el archivo del proyecto AEDT usando el cuadro de diálogo Save As que se abre y, a continuación, cierre el cuadro de diálogo Altium.

  • Use el botón Refresh en el cuadro de diálogo Altium para actualizar el cuadro de diálogo con los datos más recientes del Workspace conectado.
  • En una etapa posterior, puede seguir trabajando en un diseño importado volviendo a abrir su copia de trabajo del proyecto AEDT (File » Open).

Enviar cambios desde AEDT

Para enviar el diseño desde AEDT:

  1. En el cuadro de diálogo Layout Links (Tools » Layout Links), haga clic en la celda [Action] para el vínculo Altium en la pestaña Layout Links y seleccione Push/Pull. Como alternativa, haga clic en el botón Push/Pull de la pestaña Desktop de la cinta cuando el proyecto esté abierto.
  2. Use el campo Comment en la parte superior del cuadro de diálogo que se abre para añadir un comentario que describa qué se incluye en el Push.
  3. Active las opciones Include EDB file (para enviar los cambios de diseño) y/o Include the Simulation Result (para enviar los resultados de simulación).
  4. Haga clic en el botón Push to Altium 365. La región Latest from Ansys del cuadro de diálogo se actualizará con los detalles de este envío.

El envío se detectará en Altium Designer y podrá traerse a Altium Designer como se describió anteriormente.

Traer cambios a AEDT

Cuando los cambios de diseño se han enviado desde Altium Designer, pueden traerse en AEDT.

  1. En el cuadro de diálogo Layout Links (Tools » Layout Links), haga clic en la celda [Action] para el vínculo Altium en la pestaña Layout Links y seleccione Push/Pull. Como alternativa, haga clic en el botón Push/Pull de la pestaña Desktop de la cinta cuando el proyecto esté abierto.
  2. Revise la región Latest From Altium del cuadro de diálogo que se abre para obtener información sobre el envío más reciente desde Altium Designer y haga clic en el botón Show Changes para abrir el cuadro de diálogo donde se describen las diferencias entre el diseño del Workspace y el diseño actual en AEDT. Use las casillas de verificación proporcionadas en las pestañas del cuadro de diálogo para seleccionar los cambios que desea aplicar al diseño en AEDT.

    Use el botón Refresh para actualizar la región Latest From Altium con los datos más recientes.
  3. Una vez revisados los cambios, haga clic en el botón Apply changes para aplicar los cambios al diseño en AEDT.

En todas las versiones compatibles de AEDT, deberá hacer clic en el botón Apply changes en cada pestaña del cuadro de diálogo EDB Diff para traer all cambios a AEDT.

Explorar el historial de intercambio

Se conserva el historial de envíos y recepciones del diseño.

Para examinar el historial en Altium Designer, haga clic en el control History a la derecha del título de la región Latest from the Ansys en el panel Ansys Codesigner . Se abrirá la lista de envíos y recepciones tanto de Altium Designer como de Ansys . Use el botón  en la parte superior del panel para volver a los cambios más recientes.

Para examinar el historial en AEDT, haga clic en la celda [Action] para el vínculo Altium en la pestaña Layout Links del cuadro de diálogo Layout Links (Tools » Layout Links) y seleccione Push/Pull o Comment o haga clic en el botón Push/Pull o Comment  en la pestaña Desktop de la cinta. Seleccione la pestaña History del cuadro de diálogo que se abre. Expanda una entrada de push/pull para ver sus detalles. Use el botón Refresh para actualizar la pestaña con los datos más recientes.

Añadir comentarios en Altium Designer y AEDT

Tanto los ingenieros eléctricos como los de simulación también pueden beneficiarse del soporte del Workspace para comentarios mediante la creación de hilos de comentarios asociados a componentes específicos.

En Altium Designer, los comentarios existentes están disponibles a través del panel Comments and Tasks.

  • Para añadir un comentario nuevo a un componente en la PCB, haga clic en el botón Comments en la parte superior del panel, coloque el cursor sobre un componente en el espacio de diseño para que quede resaltado con un borde azul y haga clic. En el cuadro de diálogo de introducción de comentarios que se abre, escriba el comentario y haga clic en Post.

  • Para responder a un comentario, seleccione la entrada del comentario en el panel Comments and Tasks, escriba la respuesta en el campo de texto proporcionado en el cuadro de diálogo de entrada del comentario y haga clic en Reply. La respuesta se añadirá al hilo de comentarios.

Consulte la página Document Commenting para obtener más información.

En AEDT, los hilos de comentarios se gestionan a través de la pestaña Comments del cuadro de diálogo Altium al que se accede haciendo clic en la celda [Action] para el vínculo Altium en la pestaña Layout Links del cuadro de diálogo Layout Links (Tools » Layout Links) y seleccionando Comment. La lista de la parte superior del cuadro de diálogo presenta los hilos de comentarios existentes para el proyecto.

Para añadir un comentario a un componente en AEDT:

  1. Seleccione un componente específico en el panel Components (View » Components) o en el espacio de diseño.
  2. En el cuadro de diálogo Layout Links (Tools » Layout Links), haga clic en la celda [Action] para el vínculo Altium en la pestaña Layout Links y seleccione Comment.
  3. Escriba el comentario en el campo Comment de la parte inferior del cuadro de diálogo que se abre.
  4. Haga clic en el botón Create Thread . Se añadirá un nuevo hilo a la lista.

Para responder a un hilo existente desde AEDT:

  1. Seleccione una entrada de comentario numerada en la lista de la pestaña Comments del cuadro de diálogo Altium.
  2. Escriba la respuesta en el campo Comment de la parte inferior del cuadro de diálogo.
  3. Haga clic en el botón Reply Thread . Se añadirá una nueva respuesta bajo la entrada del hilo de comentarios relacionado en la lista.

  • Una vez añadidos, los nuevos hilos y respuestas agregados desde AEDT estarán disponibles en el panel Comments and Tasks de Altium Designer.
  • Para actualizar la pestaña Comments del cuadro de diálogo Altium con nuevos comentarios y respuestas añadidos desde Altium Designer, haga clic en el botón Refresh.
  • Active la opción Unresolved Only en el cuadro de diálogo Altium para ocultar de la lista los hilos de comentarios que se hayan marcado como resueltos (en Altium Designer).
  • Use el menú contextual de una entrada seleccionada para un comentario y un hilo de comentarios en el cuadro de diálogo Altium para eliminar esta entrada, seleccionar el componente relacionado o acercar la vista al componente en el espacio de diseño.
AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contenido