電子システム設計
電子設計の初期段階では、概念・機能レベルで設計を定義することが重要です。この最初のステップは、システムのアーキテクチャと主要な構成要素を俯瞰的に示し、開発プロセス全体の重要な基盤となります。 適切に作成されたブロック図は、電子システムの主要な機能ユニットを明確にし、それらの相互接続を示します。個々の部品の実装に関する細かな詳細にとらわれることなく、設計の各部分がどのように連携するかを視覚的に把握できます。このように抽象化することで、システム全体の動作とモジュール間の関係に集中でき、必要な機能がすべて考慮され、システムのアーキテクチャが設計要件に適合していることを確認できます。
Electronic System Design(ESD)ドキュメントを使用すると、システムレベルのブロック図を設計し、関係者と共同作業を行うことができます。
新しいESDドキュメントの作成
新しいESDドキュメントは、Renesas 365 Workspace内のソリューションの一部として作成できます。ソリューションの詳細ページで、右上の
ボタンをクリックし、表示されるメニューからSystem Designを選択して Create ESDウィンドウを開きます。
ウィンドウは最初に簡易表示で開き、次のフィールドが表示されます。
-
Name – ESDドキュメントの名前を入力します(必須)。
-
Description – 必要に応じてESDドキュメントの説明を入力します。
その他の設定項目を表示するには、
ボタンをクリックします。Parent Folderフィールドが表示されます。このフィールドを使用して、Workspaceのフォルダー構造内でESDドキュメントを作成する場所を指定します。デフォルトでは、 Projectsフォルダーです。フィールドの右側にあるChangeリンクをクリックすると、Workspaceのフォルダー構造が表示され、ドキュメントの保存先として別のフォルダーを選択できます(
)。
新しいESDドキュメントを必要に応じて設定したら、
をクリックします。ソリューションの詳細ページに戻り、新しく作成したESDドキュメントのタイルが表示されます。
ESDドキュメントを開くには、タイル内の名前をクリックするか、
ボタンをクリックして、表示されるメニューからOpenを選択します。 または、目的のESDドキュメントのタイルを直接ダブルクリックします。
ESDドキュメントの定義
ESDドキュメントでは、特定の機能、動作、またはデバイス(信号処理やMPUなど)を functional blocksで表します。構造と視覚的な表現の観点では、機能ブロックは、図形や画像(ラベル付き)、ハードウェア/ソフトウェアオブジェクトで表される機能の主要コンポーネント、ポート、ほかのブロックを含めることができるコンテナーです。Ports は機能ブロックのインターフェース(MPUのI2Cインターフェースなど)を表すために使用でき、機能ブロック間のconnection lines(ブロック間、またはそのポート間に直接配置)は、相互接続(異なるデバイスのインターフェース間を流れる信号など)を表します。
配置と編集の共通操作
ESDドキュメントエディターでの操作の詳細については、以下の折りたたみセクションを参照してください。
ドキュメントの表示操作
メイン表示領域での表示操作は次のとおりです。
-
Right-Click, Hold&Dragでドキュメントをパンします。 -
Mouse Wheelで垂直方向にスクロールします。 -
Shift+Mouse Wheelで垂直方向にスクロールします。 -
Ctrl+Mouse Wheelで拡大/縮小します。
オブジェクトの選択
ESDドキュメントに配置したオブジェクトに対して、位置やサイズの編集、クリップボード操作(切り取り/コピー)、削除などの操作を行うには、まずそのオブジェクトを選択する必要があります。
最も基本的な方法として、設計オブジェクトにカーソルを合わせてクリックすると、そのオブジェクトを選択できます。一部の設計オブジェクトでは、選択後にサイズや形状をグラフィカルに変更できます。オブジェクトが選択されると、その周囲の各編集ポイントに編集ハンドルが表示されます。オブジェクトの形状やサイズを変更するには、編集ハンドルをクリックしてドラッグします。具体的にどのような変更が行われるかは、編集するオブジェクトによって異なります。
選択したオブジェクト以外の場所をクリックするか、Escを押すと、選択が解除されます。
クリックによる選択は累積されないことに注意してください。別のオブジェクトをクリックすると、選択中のオブジェクトの選択は解除されます。複数のオブジェクトを選択するには、 Shift キーを押しながら、選択または選択解除したいオブジェクトを順番にクリックします。つまり、 Shift+Click ショートカットは、ほかのオブジェクトの状態に影響を与えることなく、現在カーソルの下にあるオブジェクトの選択状態を切り替えます。
設計ドキュメントの特定の領域にある複数のオブジェクトを選択するには、選択矩形を使用できます。Click and Hold 選択するオブジェクトを囲む仮想の長方形の一方の角にあたる、オブジェクトから離れた位置から、この長方形の対角までドラッグします。選択長方形の内側にあるすべての表示オブジェクトと、選択長方形に接触するすべての表示オブジェクトが選択されます。
ESDドキュメント内のすべてのオブジェクトを選択するには、Ctrl+Aショートカットも使用できます。
切り取り/コピーと貼り付けの使用
同じESDドキュメント内、または異なるESDドキュメント間で、オブジェクトを切り取り/コピーして貼り付けることができます。 切り取り/コピーするオブジェクトを選択し、デザインスペース内で右クリックして、コンテキストメニューから Cut(ショートカット: Ctrl+X)/Copy(ショートカット: Ctrl+C)コマンドを選択します。 最後に切り取り/コピーした内容をドキュメントに配置するには、デザインスペース内で右クリックし、コンテキストメニューから Paste コマンドを選択します(ショートカット: Ctrl+V)。
オブジェクトの重なり順の変更
ESDドキュメントに配置されたオブジェクトは、自動的にレイヤー状に重ねられます。各オブジェクトは作成順に応じて異なるレイヤーに配置されるため、オブジェクトを重ねて配置できます。新しく作成または追加されたオブジェクトは、常に最前面のレイヤーに配置されます。
右クリックメニューのArrangeサブメニューにある以下のコマンドを使用すると、重なり合うオブジェクトの中で、対象オブジェクトの重なり順を変更できます。
-
Bring to Front(
Ctrl+Alt+])/Send to Back(Ctrl+Alt+[)– 重なり合うオブジェクトの中で、対象オブジェクトを最前面/最背面に移動します。コマンドを実行した後、移動するオブジェクトをクリックします。オブジェクトはX座標とY座標を変えずに、重なり合うすべてのオブジェクトの手前/奥に移動します。 -
Bring Forward(
Ctrl+])/Send Backward(Ctrl+[)– 重なり合うオブジェクトの中で、あるオブジェクトを別のオブジェクトの手前/奥に移動します。コマンドを実行した後、移動するオブジェクトをクリックし、次に、その手前/奥に配置する基準となるオブジェクトをクリックします。最初のオブジェクトは、X座標とY座標を変えずに、この基準オブジェクトの手前/奥に移動します。
オブジェクトの整列
デザインスペース内にオブジェクトを正確に配置し、他のオブジェクトと垂直方向や水平方向に揃えられるように、オブジェクト(またはオブジェクトのグループ)を配置またはドラッグしているときに、ドキュメント内の他のオブジェクトと位置が揃うとガイド線が表示されます。また、配置済みの周囲のオブジェクトと同じ間隔になる位置にオブジェクトを配置/ドラッグすると、矢印が表示されます。
整列コマンドを使用してオブジェクトを揃えることもできます。整列の対象にするすべてのオブジェクトを選択し、選択したオブジェクトを右クリックして、Alignメニューから必要なコマンドを選択します。
-
Align Left / Align Right / Align Top / Align Bottom コマンドを使用すると、選択したデザインオブジェクトの左端/右端/上端/下端をそれぞれ揃えることができます。 コマンドを実行すると、最も左/右/上/下にあるオブジェクトの左端/右端/上端/下端が基準となり、選択した他のすべてのオブジェクトが左/右/上/下に移動して、それぞれの端がこの基準に揃います。
-
Align Horizontal Centers / Align Vertical Centers コマンドを使用すると、選択したオブジェクトの水平方向/垂直方向の中心を揃えて、1列/1行に配置できます。 コマンドを実行すると、選択したオブジェクトが水平/垂直方向に移動し、水平方向/垂直方向の中心が揃った1列/1行になります。列の垂直中心線は、選択したオブジェクトのうち最も左にあるオブジェクトと最も右にあるオブジェクトの中間に位置します。 行の水平中心線は、最も上にあるオブジェクトと最も下にあるオブジェクトの中間に位置します。
-
Distribute Horizontally / Distribute Vertically コマンドを使用すると、選択したオブジェクトの水平方向/垂直方向の間隔を均等にできます。 コマンドを実行すると、選択したオブジェクトのうち最も左と最も右/最も上と最も下にあるオブジェクトの位置は固定されたまま、その間に他のすべてのオブジェクトが等間隔で配置されます。オブジェクトの垂直方向/水平方向の位置は変わりません。
オブジェクトのサイズの統一
配置済みのオブジェクトのサイズは、選択した状態で手動で調整できますが、あるオブジェクトの幅や高さを他の配置済みオブジェクトに適用して、サイズを揃えることもできます。サイズを揃えるオブジェクト(機能ブロック、ポート、ハードウェアコンポーネント、ソフトウェアコンポーネント、長方形、楕円、テキスト、画像)を選択し、基準となるオブジェクトを右クリックして、Match sizeコンテキストメニューから必要なコマンドを選択します。これにより、基準オブジェクトの幅(Width)、高さ(Height)、またはその両方(Both width and height)を、選択した他のオブジェクトに適用できます。
オブジェクトのグループ化
ESDドキュメントに配置されたオブジェクトは、グループ化できます。グループ化すると、グループ内のすべてのオブジェクトをすばやく選択/選択解除でき、グループ内の1つのオブジェクトを移動すると、すべてのオブジェクトを一緒に移動できます。
現在選択されているオブジェクトをグループ化するには、デザインスペース内で右クリックし、コンテキストメニューからGroup コマンドを選択します。選択したオブジェクトをメンバーとするグループが作成されます。
グループを解除するには、グループに属するオブジェクトを右クリックし、コンテキストメニューからUngroup コマンドを選択します。
オブジェクトのスタイルの変更
ESDドキュメント内で1つ以上のオブジェクトを選択すると、上部ツールバーのコントロールを使用して、そのスタイル(デザインスペース内での表示形式)を変更できます。
-
Font settings – これらのコントロールを使用して、テキストを含む選択したオブジェクト(機能ブロック、ポート、コンポーネント、テキスト)のフォント(フォントファミリー、フォントサイズ、太字/斜体/下線の属性、文字色、配置)を設定します。
-
Color – これらのコントロールを使用して、選択したオブジェクトの塗りつぶし色(該当する場合)と輪郭の色を設定します。
-
Line – これらのコントロールを使用して、選択したオブジェクトの線種と線幅を設定します。これは、線オブジェクト(接続線およびポリライン)と、その他のオブジェクトの輪郭に適用されます。
あるオブジェクトのスタイルを別のオブジェクトにすばやく適用するには、コピー元のオブジェクトを選択し、デザインスペース内で右クリックして、コンテキストメニューから Copy Style コマンドを選択します(ショートカット:Ctrl+Alt+C)。コピーしたスタイルを1つまたは複数のオブジェクトに適用するには、それらのオブジェクトを選択して右クリックし、コンテキストメニューから Paste Style コマンドを選択します(ショートカット:Ctrl+Alt+V)。
オブジェクトを右クリックし、コンテキストメニューから Set Default Style コマンドを選択することもできます。このオブジェクトのスタイルは、以降に同じ種類のオブジェクトを配置する際に適用されます。
配置済みのオブジェクトは、選択してドラッグすることで移動できます。個々のノードを選択して移動することで、オブジェクトの形状やサイズを変更することもできます。
配置済みのオブジェクトは、選択して右上の矢印アイコン(
)を使用することで回転させることもできます。アイコンをクリックしてドラッグすると、選択したオブジェクトが90度単位で回転します。
操作の取り消しとやり直し
Ctrl+Z および Ctrl+Y のショートカットを使用すると、それぞれ、ESDドキュメントを直前の操作前の状態に戻したり、取り消した変更をやり直したりできます。
オブジェクトのロック
オブジェクトの右クリックメニューにある Lock/Unlock サブメニューのコマンドを使用して、サイズと位置、または内容をロック/ロック解除します。
-
Lock / Unlock – このコマンドを使用して、オブジェクトのサイズと位置、スタイル(外観)、内容(機能ブロックのテキストなど)をロック/ロック解除します。サイズと位置をロックすると、グラフィカルに変更できなくなり、オブジェクトを削除することもできなくなります。
-
Lock size and position / Unlock size and position – このコマンドを使用して、オブジェクトのサイズと位置のみをロック/ロック解除します。
-
Lock style / Unlock style – このコマンドを使用して、オブジェクトのスタイルのみをロック/ロック解除します。
-
Lock content / Unlock content – このコマンドを使用して、オブジェクトの内容のみをロック/ロック解除します。
オブジェクトが完全にロックされている場合(サイズと位置、スタイル、内容がすべてロックされている場合)、選択するとオブジェクトの周囲に赤い点線が表示されます。オブジェクトの一部のみがロックされている場合(スタイルのみがロックされている場合など)、選択するとオブジェクトの周囲に黄色い点線が表示されます。
オブジェクトのプロパティへのアクセス
配置済みオブジェクトのプロパティにアクセスするには、デザインスペースでオブジェクトを選択し、右上の
ボタンをクリックして Properties ペインを開きます。または、配置済みオブジェクトを右クリックし、表示されるメニューから Properties コマンドを選択します。
デザインスペースでオブジェクトが選択されていない場合、Properties ペインにはESDドキュメント自体のプロパティが表示されます。
Properties ペインの Parameters 領域では、選択したオブジェクト(機能ブロック、ハードウェアコンポーネント、ソフトウェアコンポーネント、ポート、接続)のパラメーターを管理できます。オブジェクトが選択されていない場合は、ESDドキュメント自体のパラメーターを管理できます。 開いた Properties ペインで、
ボタンと
ボタンを使用して、それぞれパラメーターを追加、削除します。パラメーターの名前または値をクリックすると編集できます。
Properties ペインの Documentation & Resources 領域には、ソリューションとその要素に関連するリソース(ルネサスのドキュメント、PDF)へのリンクが、自動的に生成されたリストとして表示されます。
特殊文字列
テキスト(テキストオブジェクト、機能ブロックの名前など)は、ESDドキュメントにユーザー定義の固定テキストを表示するだけでなく、ドキュメントやオブジェクトのパラメーターのプレースホルダーとしても使用できます。ESDドキュメントで特殊文字列を使用するには、オブジェクトのテキストにパラメーター名を含めます。特殊文字列は、接頭辞 = で始まります(例:=ControlAlgorithm、=MotorType など)。
以下のルールに従って、複数の特殊文字列を通常のテキスト(固定文字列)とともに1つの文字列に連結できます。
| 要素 | 機能 | 例 |
|---|---|---|
=(等号) |
後続の文字列が、解釈する必要のある式であることを示します。 | =MotorType( ) |
+(プラス) |
文字列に必要な特殊文字列と固定文字列の要素を連結するために使用します。 | =MotorType + NumberOfMotors( ) |
' '(一重引用符) |
文字列内の任意の位置に固定文字列を含めるために使用します。 | =MotorType + ' Motor (x' + NumberOfMotors + ')'( ) |
機能ブロックの配置と設定
ESDドキュメントに新しい機能ブロックを配置するには、下部ツールバーの
ボタンをクリックします(または、ライブラリペインの Standard 領域にあるボタンを使用します)。デザインスペース内でマウスボタンを押し続けて機能ブロックの長方形の最初の角を固定し、カーソルを移動して長方形のサイズを調整してから、マウスの左ボタンを離して配置を完了します。または、デザインスペース内をクリックすると、デフォルトサイズの機能ブロックを配置できます。機能ブロックの名前を変更するには、機能ブロックをダブルクリックし、名前を入力して Enter を押すか、機能ブロックの外側をクリックします。
配置済みの機能ブロックから、新しい機能ブロックをすばやく配置することもできます。配置済みの機能ブロックにカーソルを合わせるか、ブロックを選択し、ブロックの境界にある紫色の点をクリックすると、対応する方向に元のブロックと同じサイズの新しい機能ブロックが配置されます。元のブロックと新しいブロックは、接続線で接続されます。紫色の点にカーソルを合わせて新しいブロックのプレビューが表示されているときに、Tab を押すと、両方のブロックへのポートの配置を切り替えられます。
機能ブロックにハードウェアコンポーネントを追加するには、下部のツールバーにある
ボタンをクリックします。カーソルが十字に変わり、コンポーネントのプレビューが付随して表示されます。機能ブロックの境界内をクリックして、コンポーネントを配置します。配置したコンポーネントをダブルクリックし、表示されるポップアップウィンドウの検索バーを使用してコンポーネントを検索します。検索結果の一覧からコンポーネントを選択すると、そのコンポーネントの名前が機能ブロックの図形内に表示されます。
機能ブロック内にポートを配置するには、下部のツールバーにある
ボタンをクリックします(または、Libraryペインの Standard 領域にあるボタンを使用します)。カーソルが十字に変わり、デフォルトのポートが付随して表示されます。機能ブロックの境界内をクリックして、ポートを配置します。機能ブロックの外側をクリックすることもできます。この場合、新しいデフォルトの機能ブロックが自動的に作成されます。ポート名を変更するには、ポートをダブルクリックして必要な名前を入力し、Enter を押すか、ポートの外側をクリックします。
RA Explorerの使用
Renesas RAファミリのMCUを検索する際は、RA Explorer ウィンドウを使用して必要なコンポーネントを見つけることができます。ハードウェアコンポーネントを配置した後、検索バーに RA または Renesas を入力し、ポップアップの上部にある Explorer Mode リンクを使用すると、適合するコンポーネントの一覧が表示されるウィンドウが開きます。デフォルトでは、機能ブロックに配置されたポートに基づいて一覧が絞り込まれます。現在のポート一覧は、ウィンドウの上部に表示されます。Add Port コントロールを使用して別の種類のポートを追加したり、ドロップダウンを使用して各種類のポートの必要数を変更したりできます。一覧で目的のコンポーネントをクリックすると、そのコンポーネントが選択され、ウィンドウの右側にピンマップが表示されます。目的のコンポーネントを選択した状態で
ボタンをクリックすると、ハードウェアコンポーネントオブジェクトに適用されます。
RA MCUをハードウェアコンポーネントオブジェクトに適用したら、そのオブジェクトを選択し、Properties ペインを開いてプロパティを確認できます。必要に応じて、
ボタンをクリックして RA Explorer ウィンドウを開き、別のMCUを選択できます。
Device Configurationの使用
Device Configuration機能では、ハードウェアコンポーネントのポート、パッケージ情報、周辺機能、ピン割り当てを確認および管理できます。ハードウェアコンポーネントを選択した状態で、Properties ペインの Device Configuration 領域を展開すると、現在のデバイス構成の詳細を確認できます。
Device Configuration 領域の見出しの右側にある Edit コントロールをクリックすると、Device Configuration ウィンドウが開きます。
ハードウェアコンポーネントに現在割り当てられているポートの一覧はウィンドウの上部に、現在のデバイス構成は左側に表示されます。Add Port コントロールを使用して別の種類のポートを追加したり、ドロップダウンを使用して各種類のポートの必要数を変更したりできます。デバイス構成への変更は、ウィンドウの右側に表示されます。
ウィンドウの Modified 領域で、該当する項目の右側にある x をクリックしてポートを削除することもできます。
ハードウェアコンポーネントに割り当てられているポートが、機能ブロックのポートと種類や数で一致しない場合は、コンポーネントの Properties ペインの Device Configuration 領域に通知が表示されます。また、デザインスペース内では、コンポーネントがオレンジ色の点と枠線で強調表示されます。この不一致を解消するには、Device Configuration ウィンドウの
コントロールを使用します。ソフトウェアが機能ブロックのポートに合わせてハードウェアコンポーネントにポートを割り当てます。
ハードウェアコンポーネントに割り当てられているポートに合わせて機能ブロックのポートを更新する場合は、ウィンドウの左下にある Update Functional Block with ports from Device Model オプションを有効にします。
変更後のデバイス構成がサポートされていない場合は、Device Configuration ウィンドウの上部にその旨を知らせるメッセージが表示されます(この場合、変更を適用することはできません)。ポートの構成を手動で変更するか、メッセージバナー内の Undo Last Change コントロールを使用して、ウィンドウ内で行った直近の変更を元に戻してください。
デバイス構成に必要な変更を加えたら、
ボタンをクリックして、ハードウェアコンポーネントに変更を適用します。
機能ブロックの接続
接続線の始点と終点は、機能ブロックの境界、ポートの境界、長方形の境界、画像の境界、別の接続線、またはESDドキュメント内の空きスペースに配置できます。接続線を配置するには、下部ツールバーの
ボタンをクリックします(または、Libraryペインの Standard領域にあるボタンを使用します)。接続線の始点にする位置をクリックします。カーソルを移動してクリックし、接続線の形状を定義する頂点を順に配置します。接続線は、機能ブロックを横切らないように自動的に配置されます。ドキュメントの空きスペースで接続線の配置を終了するには、右クリックします。機能ブロック、ポート、または配置済みの接続線上に頂点を配置すると、現在の接続線の配置は自動的に終了します。
配置済みの接続線を選択すると、次の編集ハンドルを使用できます。
-
A をクリックしてドラッグすると、接続線の端点の位置を変更できます。
-
B をクリックしてドラッグすると、接続線のセグメントの位置を変更できます。 端点の位置は固定されたままです。
接続線の両端(始点と終点)には、それぞれ矢印を表示するかどうかを設定できます。接続線を選択した状態で、上部ツールバーの
ボタンをクリックし、表示されるポップアップメニューから必要なスタイルを選択します。
配置済みの接続線のデジグネータを設定するには、接続線をダブルクリックし、必要なデジグネータを入力します。デジグネータを選択した状態で、右上のハンドルを使用すると回転できます(
)。
接続線のセグメントは、その編集ハンドルをドラッグするか、セグメントを右クリックして表示されるメニューからPin Segmentを選択すると固定できます。固定されたセグメントの編集ハンドルは、青色で塗りつぶされて表示されます(
)。接続線の他のセグメントを移動しても、固定されたセグメントの現在の水平位置または垂直位置は変わりません。セグメントの固定を解除するには、そのセグメントの右クリックメニューからUnpin Segmentを選択します。
ブランケットの配置
ESDドキュメントエディタでは、ESDドキュメントにブランケットオブジェクトを配置して、システム設計に関する情報をさらに記載できます。また、ハードウェアブランケットとソフトウェアブランケットは、それぞれPCBプロジェクトまたはソフトウェアプロジェクトにリンクできるため、システム設計の特定部分のコンテキストをESDドキュメント内で直接確認できます。
下部ツールバーのブランケットオブジェクトメニューを使用して、ブランケット(
)、ハードウェアブランケット(
)、またはソフトウェアブランケット(
)を配置します(または、Libraryペインの Standard領域にあるボタンを使用します)。
ハードウェアブランケットをPCBプロジェクトに、またはソフトウェアブランケットをソフトウェアプロジェクトにリンクするには、デザインスペースでブランケットを選択し、Propertiesペインの
ボタンをクリックします。 ソリューションにリンクされたハードウェア/ソフトウェアプロジェクトの一覧が表示されるSelect Project to linkウィンドウが開きます。ブランケットにリンクするプロジェクトを選択し、
ボタンをクリックします。リンクされたプロジェクトの情報がPropertiesペインに表示されます。
ボタンをクリックすると、リンクされたプロジェクトが新しいブラウザタブで開きます。
ボードサポートパッケージの生成
ソフトウェアブランケットでは、BSP(ボードサポートパッケージ)を生成できます。ソフトウェアブランケットのプロパティにある
ボタンをクリックします。
ソリューションのSDMが自動的にプッシュされ(詳細はこちら)、リンクされたソフトウェアプロジェクトに変更が適用されます。ソフトウェアプロジェクトがまだ存在しない場合は、先に新しいソフトウェアプロジェクトが作成されます。
リファレンスデザインがソリューションにインポートされており(詳細はこちら)、そのリファレンスデザインにリンクされたハードウェアブランケットが、ソフトウェアブランケットを含む機能ブロックを囲むように配置されている場合、BSPの生成時に評価キットのコンテキストが取得されます。boardNameがデバイスモデルに追加され、ソフトウェア生成時に使用されることで、対象の評価キットボードに対応した構成が生成されます。
テキストの配置
ESDドキュメントエディタでは、テキスト文字列を配置できます。必要に応じて、テキスト文字列にリンクを追加することもできます。
テキスト文字列を配置するには、下部ツールバーの
アイコンをクリックします(または、Libraryペインの Standard領域にあるボタンを使用します)。
配置済みのテキスト文字列を編集するには、ダブルクリックして必要なテキストを入力し、Enterを押すか、テキストオブジェクトの外側をクリックします。
配置済みのテキストにリンクを追加するには、まず対象のテキストオブジェクトを選択し、次に
をクリックします。上部ツールバーの ボタンをクリックします。表示されるポップアップフィールドに必要なURLを入力し、Enterを押します。
追加したリンクにアクセスするには、テキストオブジェクトにカーソルを合わせ、表示されるポップアップ内のリンクをクリックします。
リンクを編集するには、ポップアップ内の
ボタンをクリックし、必要に応じてURLを変更してEnterを押します。テキストオブジェクトからリンクを削除するには、
ボタンをクリックします。
グラフィカルオブジェクトの配置
ESDドキュメントエディターには、ESDドキュメントに基本的な自由形式の描画要素を配置するための、さまざまなグラフィック要素ツールが用意されています。
-
長方形(
)
-
楕円(
)
-
線(
)
-
画像(
)
下部ツールバーのグラフィカルオブジェクトメニューを使用して、必要なオブジェクトを配置します(または、ライブラリパネルの Standard領域にあるボタンを使用します)。
メニューから必要なコマンドを選択したら、設計スペース内でクリックしてドラッグし、グラフィック要素の位置とサイズを指定して配置します。たとえば長方形では、対角の頂点間の距離を指定します。ポリラインの場合は、クリックして最初の頂点を配置し、続けてクリックして後続の頂点を配置することで、形状を決定します。
配置したグラフィカルオブジェクトは、選択してドラッグすることで移動できます。個々のノードも選択して移動できます。
ライブラリからのオブジェクトの配置
ESDドキュメントエディターでは、Libraryパネルから利用できるライブラリにある、よく使用する要素を配置することもできます。このパネルにアクセスするには、 設計スペースの左上にある
ボタンをクリックします。
パネルには次の領域があります。
-
Software Components – この領域のボタンを使用して、あらかじめ名前が定義された ソフトウェアコンポーネントを配置します。
この領域にソフトウェアコンポーネントを追加するには、+ボタンをクリックします。開いたManage Software Componentsウィンドウで、左側のチェックボックスを使用して必要なソフトウェアコンポーネントを選択し、
ボタンをクリックします。
Libraryパネルでソフトウェアコンポーネントを非表示にするには、Manage Software Componentsウィンドウ(
)でそのチェックボックスをオフにするか、Libraryパネルでコンポーネントのボタンを右クリックし、Removeを選択します。
-
Symbols – この領域のボタンを使用して、あらかじめ用意された画像オブジェクトを配置します。
Libraryパネルで目的のオブジェクトのアイコンをクリックすると、ドキュメントに配置できます。
SDMのプッシュとプル
ソリューションのすべての側面を相互に同期させるため、ESDエディターには、ソリューションのシステムデータモデル(SDM)をプッシュおよびプルする機能が用意されています。これを行うには、ESDドキュメントの右上にある
ボタンメニューの対応するコマンドを使用します。
-
Push SDM – このコマンドを使用して、ESDドキュメントからSDMをプッシュします。ソリューションのSDMがESDドキュメントで行った変更と同期され、その変更をAltium Designerのハードウェアプロジェクト(詳細はこちら)やe2 studioのソフトウェアプロジェクトなど、ほかのドメインにプルできるようになります。
-
Pull SDM – このコマンドを使用して、SDMをESDドキュメントにプルします。ソリューションのSDMと同期するためにESDドキュメントに適用すべき変更がある場合、Engineering Change Orderウィンドウが開きます。 Enabled列のチェックボックスを使用して、ESDドキュメントに適用する変更を選択し、
ボタンをクリックします。
ESDドキュメントの管理
ボタンメニューのその他のコマンドを使用して、ドキュメントを管理できます。
-
Edit – このコマンドを使用してEdit Project ウィンドウを開きます。このウィンドウでは、ESDドキュメントのName および Description (
)を変更できます。
ボタンをクリックすると、Parent FolderフィールドとWorkspaceのParametersにアクセスできます。Parent Folderフィールドは情報表示専用で、編集できません。親フォルダーを変更するには、Moveコマンドを使用する必要があります。変更を確定するには、
ボタンをクリックします。
-
Move – このコマンドを使用してMove to ウィンドウを開きます。このウィンドウでは、ESDドキュメントをWorkspaceのフォルダー構造内の別の親フォルダーに移動できます(
)。ウィンドウで新しい親フォルダーを選択します。
ボタンをクリックすると、移動が実行されます。
-
Clone – このコマンドを使用してClone - ESDウィンドウを開きます。このウィンドウでは、ESDドキュメントの同一のコピーを作成できます(
)。ウィンドウでESDドキュメントの名前と、任意の説明を指定します。デフォルトでは、元のドキュメント名に接尾辞– Copyが付加されます。
ボタンをクリックすると、Parent Folderフィールドにアクセスできます。デフォルトでは、元のドキュメントがあるフォルダーが設定されています。フィールドの右側にあるChange リンクをクリックすると、Workspaceのフォルダー構造にアクセスでき、複製したドキュメントを保存する別のフォルダーを選択できます。
各フィールドを必要に応じて設定したら、
ボタンをクリックすると、元のドキュメントが複製されます。作成したESDドキュメントのコピーは、Renesas 365 Workspaceの対象ソリューションの詳細ページから、そのソリューションにリンクできます。詳しくはこちらをご覧ください。
-
Download – このコマンドを使用して、ESDドキュメントを
*.jsonファイルとしてダウンロードします。 -
Download as Template – このコマンドを使用して、ESDドキュメントを
*.json形式のテンプレートとしてダウンロードします。 -
Export to – メニューのコマンドを使用して、現在のESDドキュメントを
*.png、*.svg、または*.pdf形式でエクスポートします。
コメント機能
ESDドキュメントエディターでは、ESDドキュメントにコメントを追加できます。コメントは、特定の位置、オブジェクト、または領域に割り当てられる、ユーザーが追加するメモで、他のユーザーが返信できます。コメントは共有データとは独立してWorkspaceに保存されるため、共有データ自体を変更することなく、ユーザー間のコラボレーションを促進します。 コメント内では、1人以上のユーザーやグループをメンションできます。また、コメントをWorkspaceメンバーに割り当てることもできます。
コメントの投稿、返信、管理は、コンテキストに応じたコメントウィンドウを使用して、ドキュメントのデザインスペース内で直接行います。 コメントは画面右側の Comments and Tasks ペインにも表示されます。このペインは、操作用のインターフェースというよりも、コメントの全体像の把握や移動に役立つものです。
コメントを配置するには、ESDドキュメントの右上にあるツールバーの
ボタン、ドキュメントのデザインスペースの右クリックメニューにあるAdd Commentコマンド、またはComments and Tasksペインの
ボタンを使用します。
ESDドキュメントの共有
ESDドキュメントは、閲覧権限を付与してWorkspace外のユーザーと共有できます。ESDドキュメントの右上にある
ボタンをクリックして、 Share Itemウィンドウを開きます。Share Item Withフィールドを選択し、ユーザーのメールアドレスを省略せずに入力します。 そのユーザーは、自分のWorkspaceまたはパーソナルスペースを通じて、共有されたESDドキュメントにゲストレベルでアクセスできます。






)
)
)
)。

)またはその機能ブロック内に配置されたハードウェアコンポーネント(
)を選択したときに、Properties ペインから RA Explorer ウィンドウにアクセスすることもできます。RA Explorer ウィンドウで目的のコンポーネントを選択すると、機能ブロック内にハードウェアコンポーネントが自動的に配置され(まだ配置されていない場合)、選択したコンポーネントが適用されます。







)。










