Webビューアー
Altium 365 の Web Viewer インターフェースでは、標準的な Web ブラウザーから PCB プロジェクトのドキュメントに幅広くアクセスできます。単なる Web ベースのビューアーにとどまらず、高度なブラウザー技術により、プロジェクト構造の参照、設計ドキュメントの操作、設計内の要素に関する情報の抽出、コメントを付ける領域やオブジェクトのハイライト表示が可能です。
ドキュメントを表示する際、Web 形式であっても回路図や PCB の表示品質が損なわれることはありません。また、自由なパンやズームに加え、設計全体にわたるコンポーネントやネットの検索、クロスプローブ、選択、詳細確認も行えます。
独立したブラウザーベースの表示プラットフォームである Web Viewer インターフェースでは、設計編集環境でプロジェクトを開くことなく、設計ドキュメントに対話的な読み取り専用アクセスが可能です。設計を「所有」するエンジニアなど、その設計で作業している他のユーザーが Web Viewer スペース内の操作によって影響を受けることはありません。ただし、該当する場合には、関連するコメント通知が送信されます。
Web Viewer へのアクセス
Web Viewer インターフェースは、次の場合に使用されます。
-
特定のプロジェクトを管理する際に、詳細管理インターフェースから作業中(WIP)の設計プロジェクトのソースを表示する場合。
-
製造ポータルから、リリース済み設計パッケージの設計スナップショットを表示する場合。
-
共有ライブ設計の設計データを表示する場合。
-
共有データスナップショットのデータを表示する場合。
-
製造パッケージビューアーから、製造パッケージの基板製造データおよび実装データを表示する場合。
以下の折りたたみセクションでは、それぞれの場合のアクセス方法と、Web Viewer インターフェースがどのように表示されるかを詳しく説明します。
設計プロジェクトのソースの表示
この場合、Web Viewer インターフェースは、プロジェクトの詳細管理ページの Design ビューに表示されます。このページにアクセスするには、Workspace のブラウザーインターフェースの Projects ページで目的のプロジェクトを選択し、プロジェクト一覧の上にある
コントロールをクリックして、表示されるメニューから Open 項目を選択します。または、一覧内の目的のプロジェクト項目を直接ダブルクリックします。ページは新しいブラウザータブで開きます。
Workspace のブラウザーインターフェースの Projects ページから、プロジェクトの詳細管理ページにアクセスします。Web Viewer インターフェースは、このページの Design ビューに表示されます。
リリースパッケージの設計スナップショットの表示
この場合、Web Viewer インターフェースは、現在確認している管理対象プロジェクトの選択したリリースパッケージについて、製造ポータルの Design Snapshot ビューに表示されます。ポータルにアクセスするには、次の手順を実行します。
- 目的のプロジェクトの詳細管理ページ(プロジェクトをダブルクリックしてアクセス)で、Releases ビューに切り替えます。
-
リリースパッケージを開いて表示するには、そのパッケージの
ボタンをクリックして、リリースパッケージ全体を開きます。または、
ボタンをクリックし、リリースパッケージ全体(All Release)または特定のアセンブリ(バリアント)のいずれかを選択します。開いたプロジェクトリリースは、新しいManufacturing Portal ブラウザータブに表示されます。
- Manufacturing Portal 内で、Design Snapshot ビューに切り替えます。表示しているのはソース設計データの最新バージョンではなく、このリリースパッケージを作成するために設計をリリースした時点のスナップショットであることに注意してください。
Manufacturing Portal から Web Viewer インターフェースにアクセスし、設計プロジェクトの特定のリリースパッケージに含まれる設計スナップショットを確認します。
製造パッケージ内の基板製造データと実装データの表示
この場合、特定の製造パッケージを表示すると、製造パッケージビューアーのFabricationページとAssemblyページを通じてWeb Viewerインターフェースが表示されます。Manufacturing Package Viewerには、次の方法でアクセスできます。
-
パッケージの送信先の製造業者には、Altium 365を通じてそのパッケージにアクセスするための招待メールが届きます。メール内の
ボタンをクリックすると、Altium 365 Sign Inページに移動します(すでにプラットフォームまたはAltiumLiveアカウントにサインインしている場合を除きます)。サインインすると、共有パッケージが読み込まれた状態でManufacturing Package Viewerに移動します。
-
送信された製造パッケージは、Altium 365プラットフォームインターフェースのShared with Me ページから利用できます。製造パッケージは、タイル内の
アイコンで示されます。Manufacturing Package Viewerでパッケージを開くには、目的のパッケージを選択し、タイル内の
ボタンをクリックして、表示されるメニューからOpen コマンドを選択します。または、タイルを直接ダブルクリックするか、パッケージ名をクリックします。
-
特定のプロジェクトについて作成して送信した製造パッケージは、そのプロジェクトの詳細管理ページにアクセスすると、Releases ビューのSent 領域に一覧表示されます。上記を参照してください。Manufacturing Package Viewerでパッケージを開くには、目的のパッケージを選択し、タイル内の
ボタンをクリックして、表示されるメニューからOpen コマンドを選択します。
Webビューアーの機能
Web Viewerインターフェースには、設計データに詳細にアクセスできるさまざまな機能が統合されています。コメントシステムなどのその他の機能は、プロジェクトの詳細管理ページのDesignビューから使用すると、Altium Designerと直接リアルタイムで通信します。以降のセクションでは、利用可能な各種機能を紹介します。
データビュー
Web Viewerインターフェースでは、情報が個別のデータビューに分けて表示されます。表示されるビューは、表示しているデータの種類によって異なります。
- 設計ソースを表示する場合は、4つのデータビューに、ソース回路図、基板の2D表示、基板の3D表示、部品表がそれぞれ表示されます。レイヤースタックビューにもアクセスできます。
- 製造パッケージのデータを表示する場合は、3つのデータビューが表示されます。Fabricationページでは、GerberビューアーであるFabrication データビューを利用できます。Assembly ページには、基板のPCB および3Dデータビューが用意されています。
- Gerberデータの共有スナップショットを表示する場合は、単一のデータビュー(Gerber)が表示されます。このGerberビューは、製造パッケージを表示する際に基板製造ページのFabrication データビューに表示されるものと同じです。
SCH
このビューには、設計のソース回路図シートが表示されます。
SCH データビューには、現在選択されている回路図ソースドキュメントが表示されます。
マルチチャネル設計のサポート
Webビューアーは、マルチチャネル設計の表示に対応しています。この表示モードでは、物理チャネルごとに個別の回路図ドキュメントが表示されます。物理シート名(Altium Designerで表示した際の、その回路図ドキュメントのコンパイル済みタブ名)が論理ドキュメント名の末尾に追加され、複数のチャネルが、それぞれの論理ドキュメント名の下に物理シートとして表示されます。これは物理回路図シートのPDFドキュメントを生成した場合と似ていますが、Altium 365のWebビューアーが提供する高度なインタラクティブ操作を利用できます。
Altium Designerでのマルチチャネル設計の操作については、マルチチャネル設計の作成を参照してください。
表示操作
メイン表示領域での操作は次のとおりです。
-
マウスホイールを前後に回して、拡大/縮小します。
-
クリックしたまま(または右クリックしたまま)ドラッグして、ドキュメントをパンします。
-
クリックして選択します。
-
Rを押すと、ドキュメントの表示がリセットされます(ドキュメント全体が表示されます)。
PCB
このビューでは、PCBを2Dで表示します。
表示操作
メイン表示ウィンドウでの操作は次のとおりです。
- マウスホイールを前後に回して、拡大/縮小します。
- クリックしたまま(または右クリックしたまま)ドラッグして、ドキュメントをパンします。
- クリックして選択します。繰り返しクリックすると、同じ位置にあるオブジェクトを順に切り替えたり、所属するネットを選択したりできます。
- 単層モードでは、テンキーの+または–を押すと、レイヤーリスト内を前後に移動できます。
- Rを押すと、ドキュメントの表示がリセットされます(ドキュメント全体が表示されます)。
- 3を押すと、基板の3Dビューが開きます。
レイヤーの表示制御
PCB データビューの表示とレイヤーの表示状態は、Layers/Objects ペインのLayerモードで制御します。このペインにアクセスするには、ビューの左上にある
コントロールをクリックし、Layers表示モードを選択します。Stackup Viewコマンドをクリックすると、現在のPCBのレイヤースタックビューが開きます。
Layer/Objectsペイン – レイヤーとオブジェクトの表示を制御する中心的な場所です。
Layers/Objectsペインに一覧表示される各レイヤーには、描画順を最前面に設定するためのチェックボックスがあります。チェックを入れると、そのレイヤーは最後に描画され、他のPCBレイヤーのグラフィックスに重ねて表示されます。配置したコメントは、現在選択されている(チェックが入っている)レイヤーに関連付けられます。その後、コメントペインでそのコメントを選択すると、同じレイヤー順序が復元されます。
レイヤーの表示順を(上部の
コントロールで)リセットすると、描画順はデフォルトの状態(Topレイヤー)に戻ります。
ペインのレイヤー項目は、次のカテゴリに分類されています。
- Copper – 使用されているすべての信号レイヤーと内部プレーンレイヤー。
- Solder Mask – Top Solder、Bottom Solder。
- Paste Mask – Top Paste、Bottom Paste。
- Silkscreen – Top Overlay、Bottom Overlay。
- Mechanical – 使用されているすべてのメカニカルレイヤー。
- Other – Mutli-Layer、Drill Guide、Keep-Out Layer、Drill Drawingなど。
ペイン上部のTopとBottom view コントロールを使用すると、基板を上面から見る表示と下面から見る表示をすばやく切り替えられます。必要に応じて、各レイヤー項目のチェックボックスで最前面の描画順を変更できます。
LayersObjectsペインでレイヤーの表示状態を操作する際のポイントは次のとおりです。
-
現在表示されているレイヤーは、ペイン内で名前が通常の明るさで表示されます(例:
)。現在非表示のレイヤーは、名前が薄く表示され(例:
)、右端に
アイコンが表示されます。
-
現在表示されているレイヤーを非表示にするには、その項目をクリックするか、項目にマウスポインターを合わせて右端の
アイコンをクリックします。逆に、現在非表示のレイヤーを表示するには、その項目をクリックするか、項目にマウスポインターを合わせて右端の
アイコンをクリックします。
-
レイヤーのグループ全体(例:
Solder Mask)を非表示にするには、グループ項目にマウスポインターを合わせ、右端の
アイコンをクリックします。逆に、グループ内のすべてのレイヤーが現在非表示の場合は、グループ項目にマウスポインターを合わせ、右端の
アイコンをクリックすると表示できます。グループ内に表示中と非表示のレイヤーが混在している場合は、そのグループに
アイコンが表示されます。クリックすると表示中のレイヤーがすべて非表示になり、もう一度クリックすると(アイコンは
に変わります)、すべてのレイヤーが表示されます。
-
「単層モード」ですばやく表示するには、目的のレイヤーにマウスポインターを合わせ、
コントロールをクリックします。他のすべてのレイヤーが非表示になります。単層モードを終了するには、
コントロールをもう一度クリックします。
-
レイヤーの表示状態を、設計に最初にアクセスしたときの状態に戻すには、Layers/Objectsペインの右上にある
コントロールをクリックします。
オブジェクトの表示制御
PCBデータビューでの基板オブジェクトの表示状態は、Layers/Objectsペインで制御します。オブジェクトの表示オプションにアクセスするには、ビューの左上にある
コントロールをクリックしてから、Objects表示オプションをクリックします。
Objects表示モードのLayers/Objectsペイン。
リスト内のオブジェクトタイプ(または対応する
アイコン)を選択すると、表示/非表示が切り替わります。複数のオブジェクトタイプを選択できます。
コントロールを使用すると、オブジェクトの表示状態がデフォルト(すべてのオブジェクトを表示)にリセットされます。
特定のオブジェクトタイプだけを表示するには、その項目に対応するOnlyオプションを使用します。そのオブジェクトタイプだけが表示され、他のすべてのオブジェクトタイプは自動的に非表示になります。
コントロールを使用すると、オブジェクトの表示状態が基板のデフォルト表示にリセットされます。
複数のPCBドキュメントの表示
PCBパネル、基板レイアウトの試作版、別のPCB設計(および対応する回路図ドキュメント)など、追加のPCBドキュメントを含むプロジェクトでは、Web Viewerでこれらの「プライマリ以外」のPCBドキュメントを表示し、クロスプローブできます。
このようなPCBドキュメントを開くと、Web Viewerの関連機能は、可能な限り選択した基板レイアウトを対象とし、それ以外の場合はプライマリPCB(プロジェクト構造内で最初に見つかったPCB)をデフォルトの対象とします。配置したコメントはその基板レイアウトに関連付けられ、ネットナビゲーション、レイヤースタックアップビュー、測定、Informationペインのデータなどの機能は、開いている追加のPCBドキュメントに適用されます。
デフォルトでは、最初(順序が最上位)のPCBが表示されます。別のPCBドキュメントを選択すると、その基板設計と関連するWeb Viewerの機能にアクセスできます。
PCBの測定、配置したコメント、オブジェクト検索など、Web Viewerの各機能は追加のPCBドキュメントでも利用できます。選択した検索対象のオブジェクトやコメントが別のPCBドキュメントに属する場合、以下に示すように、該当するPCBドキュメントでコメントやオブジェクトが自動的に選択され、ハイライト表示されます。
Web Viewerの機能は各PCBドキュメントに対して利用でき、それぞれのドキュメントに関連付けられます。
追加のPCBドキュメントでも、可能な場合はメインの設計ビュー間でクロスプローブできます。
-
1つの回路図ドキュメントが、物理的なレイアウトが異なる2つのPCBなどに関連付けられている場合、その回路図からのクロスプローブは、プロジェクトのプライマリ(最初の)PCBドキュメントを対象とします。
-
上記の場合、どちらのPCBからクロスプローブしても、共通の回路図ドキュメントが開きます。
-
追加のPCBに専用の回路図ドキュメントが関連付けられている場合、クロスプローブはこの2つのドキュメント間で直接行われます。
-
BOMデータ、レイヤースタックアップ、シミュレーションのアップロードは、プロジェクト設計全体に関連付けられます。
測定
PCB データビューで基板を2D表示しているときは、測定を行えます。測定するには、
ボタンをクリックします。Measurementsペインが開き、カーソルが十字に変わって、測定モードに入ります。次の3つの測定モードに対応しています。
- Free – スナップによるガイドなしで、データビュー内の任意の2点間を自由に測定します。
- Point to Point – データビュー内の任意の2点間を測定します。オブジェクト上にカーソルを移動すると、スナップによるガイドが働きます。カーソルは次のように変化します。
-
– パッドまたはビアの中心。
-
– プリミティブオブジェクトの頂点。
-
– トラックセグメントの中点。
-
– ビュー内の任意の点。
- Object to Object – データビュー内で選択した2つのオブジェクト間を測定します。対応するオブジェクトはパッド、ビア、トラック、フィル、リージョンで、カーソルを合わせると選択候補としてハイライト表示されます。
測定は次の手順で行います。
- FreeまたはPoint to Pointモードでは、測定を開始する位置(点1)にカーソルを合わせてクリックします。その点に小さな白い十字が表示されます。Object to Objectモードでは、最初のオブジェクト(オブジェクト1)を選び、選択状態にします。
- FreeまたはPoint to Pointモードでは、目的の終点(点2)にカーソルを移動して、もう一度クリックします。カーソルを移動すると、補助として測定線が表示され、現在のXY距離(点1から線の終点まで)が示されます。Object to Objectモードでは、2つ目のオブジェクト(オブジェクト2)を選び、選択状態にします。
- Measurements ペインには、測定したXY距離、X(水平)距離、Y(垂直)距離が表示されます。Object to Objectモードでは、選択した2つのオブジェクト間の最短距離がXY距離となります。
-
続けて他の点やオブジェクト間の距離を測定するか、
ボタンをもう一度クリック(またはEsc)して測定モードを終了します。
3D
このビューではPCBを3Dで表示します。
表示操作
メイン表示ウィンドウの操作方法は次のとおりです。
-
マウスホイールを前後に回すと、拡大/縮小します。
-
クリックしたままドラッグすると、基板が回転します。
-
右クリックしたままドラッグすると、ドキュメントをパンします。
-
クリックすると選択します。
-
Rを押すと、ドキュメントの表示をリセットします(ドキュメント全体を表示します)。
-
2を押すと、2D基板ビュー(PCBタブ)が開きます。
Draftsman
このビューには、設計内で利用可能なDraftsmanドキュメントが表示されます。左側のナビゲーションツリーでDraftsmanドキュメント(*.PCBDwf)を選択して開き、表示することもできます。他の設計ビューと同様に、Draftsmanビューはドキュメントへのコメント追加に対応しています。
Draftsmanデータビューには、現在選択されているDraftsmanソースドキュメントのすべてのページが表示されます。
閲覧操作
メイン表示領域での閲覧操作は次のとおりです。
- マウスホイールを前後に回すと、拡大/縮小できます。
- マウスの左ボタン(または右ボタン)を押したままドラッグすると、ドキュメントをパンできます。
- Rを押すと、ドキュメントの表示がリセットされます(ドキュメント全体が表示されます)。
BOM
このビューには、設計の部品表が表示されます。部品表はソース回路図ドキュメントからその場で生成されます。プロジェクトにActiveBOMドキュメント(*.BomDoc)が含まれている場合は、そのドキュメントから生成されます。このビューは対話的な操作と設定変更に対応し、Altiumのサプライチェーンリソースから取得した最新の部品データを取り込みます。
BOMには、基板1枚の組み立てに必要なすべての部品が反映されます。また、現在のデータの妥当性も能動的にチェックされ、その結果がステータスアイコンで示されます。たとえば、
は問題なし/OK、
は部品値の重複、
は生産終了部品または在庫不足を示します。価格情報はAltiumの部品プロバイダーサービスから取得されます。このサービスでは、部品およびサプライヤーのデータへのWebリンクも提供されます。
このビューを操作する際のポイントは次のとおりです。
-
部品のメーカー型番の項目をクリックすると、対応する実際のメーカー部品へのWebリンクにアクセスできます。
-
部品のサプライヤー型番の項目をクリックすると、サプライヤーの部品情報への直接リンクにアクセスできます。
-
デジグネーターをクリックすると、他のデータビューで該当する部品をクロスプローブできます。
-
列ヘッダーを切り替えることで、その列を基準に項目を昇順(
)または降順(
)で並べ替えられます。
-
ヘッダー間の境界をドラッグすると、列幅を変更できます。
-
列設定メニュー(
)を使用して、ビューに表示する列を指定します。選択肢は、BOM内の部品に含まれるすべてのパラメーターから生成されます。
-
BOMデータビューの行項目に追加されたコメントは、行の先頭にアイコンで示されます。このアイコンを選択すると、コメントウィンドウに関連するコメントが開きます。BOMのコメントはAltium Designerでは利用できないことに注意してください。
-
一覧の上にあるSearch フィールド(
)を使用すると、目的の部品をすばやく検索できます。
-
プロジェクトのリリースビューまたは履歴ビューから、BOMデータを比較できます。詳細については、BOM比較を参照してください。
プロジェクトにActiveBOMドキュメントが含まれている場合、BOMビューには、カスタム列、列の別名、定義済みの検証チェック、行番号など、そのドキュメントの設定が適用されます。
ActiveBOMドキュメントの作成と設定の詳細については、ActiveBOMによるBOM管理を参照してください。
プロジェクトに含まれるActiveBOMドキュメントの設定は、WebのBOMビューに適用されます。
SiliconExpertによる拡張データ
会社でSiliconExpertアカウントを保有し、Altium 365のSiliconExpert Integration機能が有効になっている場合、SiliconExpertから取得した部品のパラメトリックデータを、WorkspaceのBOMドキュメントビュー、部品のPart Choiceの選択、およびBOM Portalで利用できます。SiliconExpertの高度なメーカー部品リスク評価データは、必要に応じてBOMドキュメントに取り込まれ、部品の生産終了の可能性、規格への適合性、調達リスクなどを評価するパラメーターとして表示されます。
SiliconExpertのパラメトリックBOMデータは、対応する
アイコンで示される専用のパラメーター列に含まれます。このアイコンは、列設定ドロップダウンメニューにも目印として表示されます。
すべてのSiliconExpertデータを有効にしたWorkspaceのBOMビュー。デフォルトで有効になっているのは、Lifecycle、YTEOL、RoHSの各パラメーターのみです。
この拡張された調達データを最大限に活用するには、要件に基づいて各パラメーター値の重要性を評価します。詳細については、SiliconExpertから取得できるパラメーターを参照してください。SiliconExpert連携はAltium Designerでも利用できます。Altium DesignerでのSiliconExpertからの部品データの取得を参照してください。
Z2Dataによる拡張データ
上記と同様に、会社でAltium 365のZ2Data Integrationが有効になっており、WorkspaceのAdminページでアクティブ化されている場合(Z2Dataアプリケーションの設定を参照)、Z2Dataの拡張された部品およびサプライチェーンのパラメトリックデータをWorkspaceで利用できます。
アイコンで示されるZ2Dataパラメーターは、Column Settingsドロップダウンメニュー(
)で有効にして、設計のBOMに含めることができます。有効にした(チェックを入れた)パラメーターはBOMビューに列として追加され、BOMの各行に対応するZ2Dataパラメーターが表示されます。表示例を参照してください。
マルチボード設計ビュー
このビューには、マルチボードプロジェクトのドキュメント用に設定された回路図ビューと3Dビューが表示されます。上位レベルのマルチボード回路図(MBS)およびアセンブリ(MBA)ドキュメントは、マルチボードの「子」プロジェクト間の電気的および物理的な接続情報を表すデータを提供します。これらの子プロジェクトは、全体として1つのマルチボードプロジェクトを構成するサブプロジェクトです。
マルチボード設計データビューは、Workspaceのメインのプロジェクトビューからマルチボードプロジェクトを開くと表示されます。回路図(MBS)、基板アセンブリ(MBA)、および統合されたBOMビューを切り替えるタブがあり、相互接続された子プロジェクトからなるマルチボードの視点で設計を表示します。ナビゲーションツリーでChild Projectsオプションを選択すると、マルチボードプロジェクトの構成(サブ)プロジェクトを表示してアクセスできます。
MBS情報ペイン
MBS回路図でモジュール、接続、またはエントリポイントをクリックすると、右側のInformationペインにその詳細が表示されます。ネットレベルまでのすべての接続データが含まれます。
アイコンをクリックしてComments and Tasksペインを開き、モジュール、エントリポイント、接続、または空白領域にコメントを配置できます。詳細については、以下のコメントセクションを参照してください。
MBAオブジェクトペイン
MBAビューのObjectsペイン(
)にアクセスすると、マルチボードアセンブリビューに表示する基板モジュールと3Dデータオブジェクトを指定できます。各オブジェクトの項目に対応する
アイコンで表示と非表示を切り替え、ペイン上部の
アイコンですべてのオブジェクトを表示した状態にビューをリセットできます。
ハーネス設計ビュー
このビューには、ハーネス設計プロジェクトのドキュメントの基本的な配線ビューとレイアウトビューが表示されます。専用のHarness Wiring Diagram(*.WirDoc)ドキュメントとHarness Layout Drawing(*.LdrDoc)ドキュメントには、コネクタ間のワイヤ/ケーブル、およびそのハーネスの物理的な構造を表すデータが含まれます。ハーネスプロジェクトには、追加情報を記載したDraftsmanドキュメントや、必要なハーネス部品の詳細を記載したActiveBOMドキュメントを含めることもできます。なお、ハーネスプロジェクトはマルチボードプロジェクトと統合して、既存のハーネスタイプの接続を表現できます。
ハーネス設計の作成について詳しくは、Altium Designerでのハーネス設計を参照してください。
ハーネス設計プロジェクトは、Workspaceのプロジェクトページから開きます。このビューには、含まれるドキュメントの種類(配線、レイアウト、Draftsman、BOM)ごとに選択可能なタブがあります。メインの配線/レイアウトビューで選択したオブジェクトの詳細は、右側のInformationペインに表示されます。以下の折りたたみセクションを参照してください。
製造ビュー
このビューには、以下の場所にあるGerberデータと製造データの両方を確認するためのGerber Viewerが表示されます。
-
共有されたGerberデータのスナップショット内。
-
リリース済みのWorkspaceプロジェクト内(ファイルセクションの
FAB»Gerber領域)。
表示操作
メイン表示ウィンドウの操作方法は次のとおりです。
-
マウスホイールを前後に回すと、拡大/縮小できます。
-
クリックしたまま(または右クリックしたまま)ドラッグすると、ドキュメントをパンできます。
-
テンキーの+または–を押すと、単一レイヤーモードでレイヤーリストを順方向または逆方向に切り替えられます。
-
Rを押すと、ドキュメントの表示がリセットされます(ドキュメント全体を表示)。
レイヤーの表示制御
Gerber/Fabrication データビューの表示とレイヤーの表示/非表示は、Layers ペインから制御します。ビュー左上の
コントロールをクリックすると、このペインにアクセスできます。
Gerberレイヤーは、次のカテゴリに分類されます。
- Copper – 使用されているすべての信号レイヤーと内部プレーンレイヤー。
- Solder Mask – Top Solder、Bottom Solder。
- Silkscreen – Top Overlay、Bottom Overlay。
- Paste – Top Paste、Bottom Paste。
- Other Layers – Top Pad Master、Bottom Pad Master、NC Drill(*.txt形式)、およびMechanical xxを含みます。
ペイン上部の Top View および Bottom View コントロールを使用すると、それぞれ上面または下面のガーバーデータの表示にすばやく切り替えることができます。いずれの場合も、内層銅箔層、メカニカル層、NCドリル層は無効になります。
Layers/Objects ペインでのレイヤーの表示設定については、次の点に留意してください。
-
現在表示されているレイヤーは、ペイン内で名前が通常の明るさで表示されます(例:
)。現在非表示のレイヤーは、名前が薄く表示され(例:
)、右端に
アイコンが表示されます。
-
現在表示されているレイヤーを非表示にするには、その項目をクリックするか、項目にカーソルを合わせて右端の
アイコンをクリックします。逆に、現在非表示のレイヤーを表示するには、その項目をクリックするか、項目にカーソルを合わせて右端の
アイコンをクリックします。
-
レイヤーのグループ全体(例:
Solder Mask)を非表示にするには、グループの項目にカーソルを合わせて右端の
アイコンをクリックします。逆に、グループ内のすべてのレイヤーが現在非表示の場合は、グループの項目にカーソルを合わせて右端の
アイコンをクリックすると表示できます。グループ内に表示と非表示のレイヤーが混在する場合は、グループに
アイコンが表示されます。クリックすると残りのレイヤーがすべて非表示になり、もう一度クリックすると(この時点では
と表示)、すべてのレイヤーが表示されます。
-
「シングルレイヤーモード」ですばやく表示するには、目的のレイヤーにカーソルを合わせ、
コントロールをクリックします。他のレイヤーはすべて非表示になります。「シングルレイヤーモード」を終了するには、
コントロールをもう一度クリックします。
-
レイヤーの表示設定をガーバーデータに最初にアクセスしたときの状態に戻すには、 Layers/Objects ペインの右上にある
コントロールをクリックします。
測定
Gerber/Fabrication データビューでガーバーデータを表示しているときは、測定を行うことができます。測定するには、
ボタンをクリックします。Measurements ペインが開き、カーソルが十字に変わり、測定モードになります。測定は次の手順で行います。
-
測定を開始したい位置(ポイント1)にカーソルを合わせてクリックします。そのポイントに小さな白い十字マークが付きます。
-
目的の終点(ポイント2)にカーソルを移動し、もう一度クリックします。カーソルを移動すると、補助となる測定線が表示され、現在のXY距離(ポイント1から線の終点まで)が示されます。
- Measurements ペインには、測定されたXY距離、X(水平)距離、Y(垂直)距離が表示されます。
-
続けて他のポイント間の距離を測定するか、
ボタンをもう一度クリック(または Esc)して測定モードを終了します。
ガーバー比較の実行
共有されたガーバーファイルパッケージを表示しているときは、現在のデータと別のガーバーデータパッケージのデータを比較できます。一般的な比較例としては、連続するプロジェクトリリースから生成された共有ガーバーデータ間の比較や、主要な設計段階の反復間の比較があります。
比較処理を開始するには、ビューの
メニューから Compare Geber オプションを選択し、続いて表示される Compare Gerber ウィンドウで比較対象のガーバーデータセットを選択します。ウィンドウにガーバーパッケージをドロップするか、適切なファイルを参照して選択し、アップロードしてください。比較処理が完了すると、ガーバー比較ビューが開き、2つのガーバーデータセット間のグラフィックとネットの変更点を詳しく確認できます。
詳細については、関連する ガーバー設計データの比較 または スタンドアロンのガーバー比較ビューアーを参照してください。
レイヤースタックビュー
現在の設計の PCBレイヤースタック(基板の物理的な積層構造)をグラフィカルに表現したものを、Web Viewerのさまざまな場所から表示できます。レイヤースタックアップビューには、基板の内部構造と、レイヤーの種類、材料、寸法などの関連データが表示されます。
Altium Designerでの基板レイヤースタックの操作については、レイヤースタックの定義を参照してください。
レイヤースタックビューでは、Draftsmanレイヤースタックドキュメントを作成してリリースしたり、リリース済みの ガーバー出力ファイルから情報を抽出したりすることなく、関係者が重要な製造情報をビューアーですぐに確認できます。このビューには、プロジェクト設計ビュー、設計リリーススナップショット、送信済みの製造パッケージなど、設計ソースファイルが表示される場所からアクセスできます。
レイヤースタックビューを開くには、プロジェクト設計ビューアーの 基板情報ペインから Stackup View コマンドを選択するか、PCBの表示中に レイヤーメニューから選択します。プロジェクトリリースの 設計スナップショットを表示しているときも、同じ方法でレイヤースタックビューにアクセスできます。
Web Viewerの他のビューと同様に、レイヤースタックビューにもコメントを配置できます。レイヤースタックの任意の要素のグラフィカルオブジェクトを選択し、コンテキストコメントウィンドウでユーザーへのメンションや割り当てを含むコメントを入力できます。なお、レイヤースタックへのコメントでは、フリーハンド描画と領域選択は利用できません。
コメントの配置の詳細については、後述の「コメント」セクションを参照してください。
その他のドキュメント
ソースのAltium Designerプロジェクトに保存されているその他の種類のドキュメントファイルは、WorkspaceのDesignビュー内のOther Documentsの場所にまとめて表示されます。これらの「非CAD」ファイル(通常は設計仕様書、参考資料、ステータスログなど)は、主要な設計ファイルとともにバージョン管理されます。選択したファイルは、対応する
アイコン、またはメインビュー領域からダウンロードできます。ただし、PDFファイルは例外で、WorkspaceのPDFビューアーで自動的に開かれます。
DRCおよびERCレポート
Web Viewerには、現在のプロジェクトのデザインルールチェック(DRC)と電気ルールチェック(ERC)のレポートが含まれます。これらは、プロジェクトドキュメントに保存されたAltium Designerの設定に従って、ソース設計データから生成されます。これにより、Altium Designerで設計を開かなくても、ルールに関するエラーや違反を簡単に確認できます。
これらのレポートは、ProjectナビゲーションペインのDesignセクション内で展開可能なリストとして表示されます。レポートは、Altium Designerでプロジェクトが更新され、サーバーに再保存された場合など、必要に応じて動的に生成されます。なお、DRCまたはERCレポートは、関連するエラーが検出された場合にのみ含まれます。
デザインルールチェックと電気ルールチェックは、該当する場合、確認用としてサーバーで生成されます。
DRCまたはERCレポートを展開すると、含まれるカテゴリが表示されます。各カテゴリを開くと、検出された個々の違反やエラー、警告などのサブリストが表示されます。Altium Designerで適用除外とされたDRC違反は、そのエントリに付いた
アイコンで示されます。
個々のエントリを選択すると、関連ドキュメントが開き、該当箇所にズーム/パンします。右側のReport情報ペインには、ルール情報、クラス、種類、および影響を受ける具体的なオブジェクトなど、選択したエントリの詳細が表示されます。
共通のインターフェース要素
以下のコントロール(すべて右上のコントロール群に配置)は、各種データビューに共通しています。
-
– このコントロールを使用すると、右側のペインがComments and Tasksモードに切り替わります。このモードでは、コメントの追加と管理、およびタスクとしてユーザーへの割り当てができます。詳細については、後述の「コメント」セクションを参照してください。
-
– このコントロールを使用すると、部品やネットを検索できるSearch 機能にアクセスできます。この機能は、SCH、PCB 、3D データビューで利用できます(独自の検索機能を備えたBOM データビュー、およびGerber/Fabrication データビューでは利用できません)。検索機能の使い方の詳細については、「検索」を参照してください。
-
– このコントロールを使用すると、Infoペインにアクセスできます。
このペインは、オブジェクトが選択されていない場合、さらに2つのサブビューに分かれます。
-
Controls – SCH、PCB、3D 、Gerber/Fabrication データビューを閲覧する際に利用できるコントロールの一覧を表示します(一部のコントロールは特定のビューでのみ利用できます)。
-
Board Info – プロジェクト設計の概要情報として、Board Size(基板のX寸法とY寸法)、Layers(信号層とプレーン層の合計、およびそれぞれの層数)、Components(すべての種類の部品を含む総数、および基板の表面と裏面に配置された部品の内訳)、Nets(総数)を表示します。このサブビューは、Gerber/Fabrication データビューのペインにはありません。
-
– このコントロールを使用してデータをダウンロードします。現在表示しているデータの種類に応じてダウンロードされる内容、またはダウンロードできる内容の詳細については、「ダウンロード」を参照してください。
-
– このコントロールを使用して全画面モードに切り替えます。
-
– 全画面モードでは、このコントロールを使用して全画面モードを終了します(またはEscを押します)。
バリアントのサポート
設計ソースを表示する際、プロジェクトにバリアントが定義されていれば、各種データビューで設計を表示しながらバリアントを切り替えることができます。左側のナビゲーションペインには、利用可能なバリアントの一覧が表示されます。デフォルトでは[No Variations]に設定され、ベース設計が表示されます。
プロジェクトに定義されている利用可能なバリアントへのアクセス。
プロジェクトに定義されているすべてのバリアントの一覧から、バリアントを選択します。現在のデータビューが更新され、未実装部品に対して有効になっている表示オプションも含め、そのバリアントが反映されます(SCH およびPCB データビュー)。3DおよびBOM データビューでは、部品の実装/未実装に応じて、その部品が表示または一覧に記載されるかどうかが決まります。
選択
設計ソースを表示しているときは、SCH、PCB、3Dの各データビューから、次のように設計内のオブジェクトを選択できます。
- SCH データビューから(コンポーネントおよびネットの選択)– コンポーネントまたはワイヤーにカーソルを合わせ、クリックして選択します。ハイライトとマスクが適用され、そのコンポーネントまたはネットだけが完全に表示されます。選択したコンポーネント/ネットの情報は、右側のペインに表示されます。
-
PCB データビューから(コンポーネント、パッド、ビア、トラックセグメント、およびネットの選択)– 対応する種類のオブジェクトにカーソルを合わせ、クリックして選択します。マスクが適用され、そのオブジェクトだけが完全に表示されます。選択したオブジェクトの情報は、右側のペインに表示されます。
オブジェクトを繰り返しクリックすると、カーソルの下にあるネットとオブジェクトが順番に選択されます。ダブルクリックすると、そのオブジェクトに関連するネットをすぐに選択できます。
- 3D データビューから(コンポーネント、パッド、ビアの選択)– コンポーネント、パッド、またはビアにカーソルを合わせ、クリックして選択します。マスクが適用され、そのオブジェクトだけが完全に表示されます。選択したオブジェクトの情報は、右側のペインに表示されます。
ネットの選択
ProjectsペインのNetsセクションを展開すると、プロジェクトの設計内にあるネットの一覧を表示できます。リスト内の項目を選択すると、回路図、PCB、および3Dビューでそのネットの位置が特定されてハイライト表示され、右側の情報ペインに詳細が表示されます。この情報には、ネットが存在するレイヤーの一覧と、そのネットを含む回路図ドキュメントの選択可能な一覧が含まれます。
選択したネットを対応するすべてのビューで確認するには、上部のタブ、または右側のネット情報ペインにあるビュータブのオプションから、SCH、PCB、または3Dを選択します。
クロスプロービング
設計ソースを表示しているときに、アクティブなデータビューで対応するオブジェクトを選択すると、他の1つ以上のデータビューでも、該当する場合はそのオブジェクトが選択されます。これにより、同じ選択対象にすばやくクロスプローブできます。メインの表示ウィンドウでオブジェクトが選択されているときに表示される、右側のペインのコントロールからもクロスプロービングを行えます。
クロスプロービング用のコントロール(コンポーネントを選択した場合)。
以下の折りたたみセクションでは、対応するクロスプロービングの例をいくつか紹介します。
SCHデータビューからのネットのクロスプローブ
SCH データビュー内の回路図ドキュメントで目的のネットを選択し、いずれかのコントロール(PCB、3D)をクリックして、対象のデータビューでそのネットをクロスプローブします。Informationペインの上部でも選択できます。ビュー内では、可能な場合はネットが選択されて拡大表示され、選択したネットだけが完全に表示されるようにマスクが適用されます。
PCBデータビューからのパッド/ビア/トラックのクロスプローブ
PCB データビュー内の基板で目的のパッド、ビア、またはトラックセグメントを選択し、3D コントロールをクリックして、3Dデータビューでそのパッド/ビア/トラックセグメントをクロスプローブします。ビュー内では、可能な場合はオブジェクトが選択されて拡大表示され、選択したオブジェクトだけが完全に表示されるようにマスクが適用されます。
ブラウザーのタブ間でのクロスプローブ
ブラウザーのタブ間やウィンドウ間でも、動的なクロスプローブがサポートされています。同じ設計を2つ開いた状態(それぞれ別のブラウザータブに表示されます)で、ビューアーのInfoペインにあるCross Select Across Tabsオプションを有効にします(オブジェクトを選択すると利用できます)。これにより、2つのブラウザービュー間でクロスプローブがリアルタイムに連動します。
検索
Related information: 検索クエリリファレンスおよび高度な設計検索。
設計ソースを表示している場合、Web Viewerインターフェースでは、高度なクエリベースの検索機能を利用できます。単純な設計検索から、クエリ用語やフィルタリングロジックを使用した非常に詳細な検索まで対応しています。検索機能には、ビューアー上部のSearchフィールドを選択するか、Ctrl+Kコマンドを使用してアクセスできます。Recentには、コンテキストに応じた再利用可能な検索式が一覧表示されます。
Web Viewerの検索機能は、コンテキストを認識するユーザーインターフェースを備えており、利用可能な設計データと現在のクエリキーワードに基づいて候補を表示します。
検索フィールドを選択すると、ドロップダウンに選択可能なクエリキーワード(Terms)の一覧が表示され、入力に応じて現在の設計に含まれるデータに基づく候補が動的に表示されます。特定の部品やネットを探すような単純な検索では、検索語を直接入力できます。
検索語では大文字と小文字は区別されず、キーワードの一部にワイルドカードを使用することもできます。たとえば、VCC*は「VCC」で始まるすべてのネット項目を検索します。
用意されている高度な検索用語を使用すると、特定の条件に基づいて柔軟に検索できます。入力時には、コンテキストに応じた候補が検索ドロップダウンリストに表示され、入力を支援します。コマンドには、標準のfield:value構文を使用します。設計アイテムは、オブジェクトまたは種類(例:Object:Port
、Type:IC
)、プロパティ(例:Value:1k
、Package:0402
)、特定のパラメーター(例:Tolerance:5%
、Manufacturer:Micron
)、接続関係(ConnectsTo:R12
、ConnectsTo:U8.OUT、またはConnectsTo:U8.4
)に基づいて検索し、ハイライト表示できます。
クエリ用語をさらに柔軟に活用できるようにするのが、組み合わせ論理と値の範囲の機能です。たとえば、フィルタリングロジック(例:Type:Resistor AND Package:0402
、ConnectsTo:u8 NOT net:GND
)、範囲条件(例:Value:[1k to 2k]
)、電源ネットの除外(ConnectsTo.NoPower:U8
)や信号経路の接続ではなく物理的なネット経路の接続(ConnectsToDirect:U1.17
)などの接続ロジックがあります。
ダウンロード
Web Viewerでは、どのデータビューからでもデータをダウンロードできます。ダウンロードするには、右上のコントロール群にある
コントロールをクリックします。実行される処理は、現在表示している内容によって異なります。
-
Design Project Source or Shared Live Design – Downloadペインにアクセスします。
作業中(WIP)の設計プロジェクト(基本設計)のスナップショットを含むZipアーカイブをダウンロードできます。また、該当するOutput Jobファイルが存在する場合は、その設定情報を直接使用して、以下の派生出力を生成およびダウンロードすることもできます。
-
GerberファイルとNCドリルファイルを含むZipアーカイブ(基本設計に対してのみ生成)。
-
Draftsmanで作成されたドキュメント全体のPDF、または組立図のみのPDF。前者にはプロジェクト内にDraftsmanドキュメントが必要です(基本設計に対してのみ生成され、バリアントには対応しません)。後者はアクティブなバリアントに対して生成されます。
-
回路図ドキュメントのPDF(アクティブなバリアントに対して生成)。
-
基板アセンブリの3D STEPファイル(
*.step)(アクティブなバリアントに対して生成)。 -
CSV形式のBOM(アクティブなバリアントに対して生成)。
ペイン内の項目にカーソルを合わせ、対応する
コントロールをクリックしてダウンロードします。必要に応じてデータが先に生成され、その後ダウンロードされます。事前に生成が必要な出力については、そのまま待つことも、Download ペインを閉じることもできます。データの準備ができるとメールが送信され、そのメールからダウンロードにアクセスできます。
ペインのReleases 領域は、設計プロジェクトのソースを表示している場合にのみ表示されます(共有ライブ設計では表示されません)。プロジェクトから生成されたすべてのリリースパッケージが一覧表示されます。項目をクリックすると、別のブラウザータブで開いて内容を確認できます。
- Shared Data Snapshot – スナップショットの作成元となったソースドキュメントを含む、単一のZipアーカイブをダウンロードします。
- Fabrication & Assembly Data in a Manufacturing Package – パッケージに含まれる各データセットのフォルダーを含む、単一のZipアーカイブをダウンロードします。
コメント
Web Viewerインターフェースは、設計ドキュメントへのコメント追加に対応しています。コメントは、対応するデータビュー上の特定の点、オブジェクト、または領域(該当する場合)に割り当てられる、ユーザーが追加する注記であり、他のユーザーが返信できます。コメントは、共有データとは独立してWorkspaceに保存されるため、共有データ自体を変更することなく、ユーザー間のコラボレーションを促進します。コメントの投稿、返信、管理は、メイン表示領域のコンテキストコメントウィンドウから直接行います。コメントは、右側に表示されるComments and Tasks ペインにも表示されます。このペインは、操作用インターフェースというよりも、概要の確認やナビゲーションのためのツールとして機能します。
管理対象プロジェクトの子回路図シートに重ねて表示されたコメントの例。 Comments and Tasksペインにはすべてのコメントが表示され、メイン表示領域でアクセスできるウィンドウでは、必要な場所でコンテキストに応じたコメントのやり取りができます。
コメントを使用できる場所
コメント機能は、次の場所で使用できます。
- 特定のプロジェクトにアクセスした際の、詳細管理ページのDesign ビュー。SCH、PCB/3D、Draftsman、BOMの各データビューにコメントを追加できます。ここで追加したコメントは、共有ライブ設計のDesign ビューおよびAltium Designerに自動的に表示され、その逆も同様です。BOMのコメントは、Altium DesignerのActiveBOMドキュメントとは共有されません。
- 現在確認中の管理対象プロジェクトで選択したリリースパッケージに対する、製造ポータルのDesign Snapshotビュー。SCH、PCB/3D、Draftsman、BOMの各データビューにコメントを追加できます。ここで追加したコメントは、プロジェクトの詳細管理ページのDesign ビュー、共有ライブ設計のDesign ビュー、およびAltium Designerに自動的に表示されます。BOMのコメントは、Altium DesignerのActiveBOMドキュメントとは共有されません。
- 共有ライブ設計を表示している際の、統合ビューアー内の回路図ドキュメント(SCH データビュー)、PCB(PCB および3Dデータビュー)、Draftsman、または部品表(BOMデータビュー)。ここで追加したコメントは、プロジェクトの詳細管理ページのDesign ビューおよびAltium Designerに自動的に表示され、その逆も同様です。BOMのコメントは、Altium DesignerのActiveBOMドキュメントとは共有されません。
- 共有設計スナップショットを表示している際の、統合ビューアー内の回路図ドキュメント(SCH データビュー)およびPCB(PCB および3Dデータビュー)。ビューアー内で追加したコメントは、Altium Designerとは共有されません。設計スナップショットを共有され、その設計の確認にビューアーを使用している関係者にのみ表示されます。
- 開いているマルチボードプロジェクトで、最上位の回路図(MBS)ドキュメントを表示している際のDesignビュー。
- 開いているハーネスプロジェクトで、Wiring、Layout、Draftsman、BOMの各ドキュメントを表示している際のDesignビュー。
- Managed BOMドキュメントを表示している際のBOM Portal。コメントとタスクペインからBOMの行項目にコメントを追加し、必要に応じてタスクとしてユーザーに割り当てることができます。
- 共有ガーバーデータスナップショットを表示している際の、ガーバービューアー(Gerber データビュー)。ビューアー内で追加したコメントは、Altium Designerとは共有されません。データスナップショットを共有され、そのガーバーデータの確認にビューアーを使用している関係者にのみ表示されます。
- 特定の製造パッケージ(設計プロジェクトの特定のリリースから作成されたもの)を表示している際の、製造パッケージビューアーのFabrication(Fabrication データビュー)およびAssembly(PCB および3Dデータビュー)ページ。ビューアー内で追加したコメントは、Altium Designerとは共有されません。製造パッケージを共有され、そのパッケージの確認にビューアーを使用している関係者にのみ表示されます。
- レイヤースタックアップビュー。このビューには、開いているプロジェクトのDesignビュー、プロジェクトリリースのDesign Snapshotビュー、および送信済みの製造業者向けパッケージのFabricationビューからアクセスできます。Webビューアー内で追加したコメントは、製造パッケージを共有され、そのパッケージの確認にビューアーを使用している関係者に表示されます。コメントは、Altium Designerのレイヤースタックマネージャーとは共有されません。
コメントの配置
コメント配置モードには、次の3つの方法のいずれかで入ることができます。
-
ブラウザータブの上部バナー領域にある
ボタンをクリックします。
- Alt+Cキーボードショートカットを使用します。
-
Comments and Tasksペインの上部にある
ボタンをクリックします。
いずれの場合も、カーソルが十字形に変わり、コメント配置モードになります。次の手順で操作します。
-
必要に応じて、対応する次の3種類のコメントのいずれかを配置します。
-
Comment on a point – 任意の位置をクリックして、その位置にコメントを添付(「ピン留め」)します。BOMドキュメントにコメントを付ける場合は、明細行を選択します。
-
Comment on object – オブジェクトをクリックして、そのオブジェクトにコメントを添付(「ピン留め」)します。SCHデータビューでサポートされるオブジェクトは、コンポーネント、ピン、ワイヤ、バス、ポートです。PCBデータビューでは、コンポーネント、パッド、ビア、トラックセグメントがサポートされます。3Dデータビューでは、コンポーネント、パッド、ビアがサポートされます。SCH およびPCB データビューでは、ビュー内でカーソルを移動すると、コメントを添付できるオブジェクトがハイライト表示されます。このタイプのコメントは、Draftsmanビュー、およびGerberデータを表示している場合のGerber とFabricationデータビューではサポートされません。
-
Comment on area – クリックしてドラッグし、コメントを添付(「ピン留め」)する領域を指定します。このタイプのコメントは、3D データビューではサポートされません。
-
-
いずれの場合もコメントウィンドウが表示され、選択した位置、オブジェクト、または領域に関連付けてコメントを入力できます。表示されたフィールドにコメントを入力します。コメント内では、1人以上のユーザーや1つ以上のグループにメンションできます。コメントフィールドに@文字を入力すると、Workspaceのメンバー一覧にすばやくアクセスできます。コメントをメンバーにassignedすることもできます。これらの追加機能の詳細については、「コンテキストコメントウィンドウの操作」セクションを参照してください。
-
コメントを入力し、メンションを追加して、必要に応じて担当者を割り当てたら、下部の
ボタンをクリックします。コメントが投稿され、コンテキストコメントウィンドウとComments and Tasksペインの両方に表示されます。メインの設計表示領域には、コメントに固有の番号が付いたマーカーが表示されます。
次の連続画像は、回路図ドキュメントのコンポーネント(SCH データビュー内)にコメントを追加し、チームメンバーへのメンションを追加して、そのメンバーにタスクを割り当てる例を示しています(詳細は後述)。
2Dモードで表示中にPCBに配置したコメントは、その時点のレイヤービュー(コメント配置時のレイヤーの表示設定およびアクティブレイヤー設定)に関連付けられます。その後、Comments and TasksペインまたはPCBビュー内のマーカーからコメントを選択すると、そのコメントのレイヤービュー設定が復元されます。
コンテキストコメントウィンドウの操作
コメントおよびインターフェースのコンテキストコメントウィンドウの操作に関するポイントは、次のとおりです。
- コメントウィンドウには、Comments and Tasksペインとは独立してアクセスできます。コメントマーカーをクリックして開きます。
-
コメントウィンドウの左上にある
ボタンを使用すると、それぞれ前のコメント、次のコメントへ順番に切り替えられます。切り替えはコメントマーカーの番号順に行われ、前後のコメントに関連付けられた設計上の位置、オブジェクト、または領域がズームされて中央に表示されるとともに、そのコメントがコメントウィンドウに表示されます。
-
最初のコメントが投稿された後は、コメントウィンドウを開くと返信を入力できる状態になります。表示されたフィールドにテキストを入力し、
ボタンをクリックして投稿します。返信せずに終了するには、
ボタンをクリックします。
-
コメント内でユーザーまたはグループにメンションできます。@文字を入力すると、Workspaceチームの全メンバーを一覧表示するポップアップが開きます。また、「@」に続けて1文字以上入力すると、グループやユーザー(ユーザーの場合は名前またはメールアドレス)を検索できます。一致するグループ、チームメンバー、およびチーム外のユーザー(組織内のユーザー)が一覧表示され、その中から選択できます。項目をクリックして追加するか、Up/Down Arrowキーを使用して選択し、Enter を押して追加できます。
@<theirfullemail>と入力することで、Workspaceチーム外(かつ組織外)のユーザーにメンションすることもできます。そのユーザーが表示中の対象への共有アクセス権をすでに持っている場合は、メンションされたことを知らせる通知メールが送信されます。そのユーザーにアクセス権がない場合は、Shareウィンドウが表示され、アクセス権を設定して対象を共有するか、アクセス権を付与しないかを選択できます。そのユーザーには、共有状況に関するメールが送信されます。
続いて表示される情報ウィンドウでは、そのユーザーをWorkspaceのメンバーとして招待するリクエストを送信するオプションを選択できます。その後、次のRequest Invitationウィンドウでメモや他の申請者を追加し、Workspace管理者による処理を依頼するリクエストを送信します。詳細については、招待リクエストの処理を参照してください。関係するすべてのユーザー(あなた、プロジェクトの共有相手、Workspace管理者)に、共有権限(
)またはWorkspaceへのアクセスの変更に関する通知メールが届きます。
-
メンションしたユーザー(Workspaceのチームメンバーのみ)にタスクを割り当てることができます。必要に応じてAssign a Task toオプションを有効にしてください。デフォルトでは最初にメンションしたユーザーに割り当てられ、メンションがない場合は自分自身(
Me)に割り当てられます。または、ドロップダウンメニューから別のWorkspaceメンバーを選択し、タスクを割り当てることもできます。割り当てられたユーザーは、Comments and Tasksペインのエントリに、関連するタスク参照とともにユーザープロファイルの画像または文字で表示されます。タスクの割り当ては、コメントの編集中に変更または解除できます。
コメントにタスクが関連付けられている場合、コメントウィンドウの上部には次の項目が表示されます。
-
コメントのタスクを割り当てられたメンバーを示すアイコン(画像または文字)。アイコンを選択すると、ドロップダウンリストから別のWorkspaceメンバーにタスクを再割り当てできます。
-
プロジェクトIDまたは名前の末尾にタスク番号を付けた、英数字のタスク参照。この参照をクリックすると、Workspaceにあるそのプロジェクトのタスクページで、該当するタスクのエントリにクロスプローブできます。
-
タスクの優先度アイコン(矢印または炎)。デフォルトは
Mediumで、WorkspaceのTasksページにあるタスクのエントリから変更できます。 -
タスクの現在の進行状況(
To Do、In Progress、Resolved)。これは対応するドロップダウンメニューから変更できます。
-
ウィンドウの
メニューにあるConvert to Taskオプションを使用して、既存のコメントにタスクを追加できます。新しいタスクは最初に自分自身に割り当てられますが、担当者のアバター(左上)から開くドロップダウンリストで別のWorkspaceメンバーを選択すると、担当者を変更できます。なお、ドキュメントビュー内のマーカーは、単純なコメント参照番号からタスクIDに変わります。
-
新しいコメントを追加するとき、または既存のコメントを編集するときに、設計ビューにフリーハンドの描画を追加し、そのコメントに関連付けたり添付したりできます。これを行うには、コメントウィンドウの上にある
ボタンをクリックします。フリーハンド描画モードに切り替わり、コメントウィンドウが一時的にフローティングコントロールバーに置き換わります。
ボタンをクリックすれば、いつでも「コメント」モードに戻れます。フリーハンド描画モードでは、カーソルを配置してからクリックしてドラッグし、必要な描画を作成します。コントロールバーのボタンで線の色や太さを変更できます(PCBの2Dビューで特に便利です)。描き間違えた場合は、
をクリックするだけで描画を削除し、最初からやり直せます。コントロールバーの右端にあるボタンで、コメントを投稿(Post)またはキャンセル(X)できます。
-
コメントウィンドウには、Windowsのクリップボードから画像ファイルやキャプチャしたスクリーンショットを貼り付けることもできます。スクリーンショット(またはコピーした画像ファイル)は、テキストのメモやユーザーへのメンションの前後に、コメントフィールドへ貼り付けられます。画像はコメントウィンドウの本文に表示されます。画像をクリックすると、フルサイズで表示できます。投稿したコメントのComment and Tasksペイン内のエントリには、関連するIncludes Imagesの注記が表示されます。
-
新しいコメントを投稿すると、元のビューのスクリーンショットが撮影され、そのコメントに添付されます。コメントウィンドウ内のOriginal Snapshotコントロールをクリックすると、このスクリーンショットにアクセスできます。スナップショットには、コメント作成時にビューに表示されていた内容がそのまま記録されます。ズームレベルやアクティブなレイヤー(PCB)も同じで、コメントを投稿する前にフリーハンドの描画を作成していた場合は、その描画も含まれます。
-
コメントの編集または削除は、コメントウィンドウからのみ行うことができ、それぞれEdit コマンドとDelete コマンドを使用します。これらのコマンドは、
コントロールに対応するメニューから利用できます。なお、これらのコマンドは自分が投稿したコメントに対してのみ使用できます。他のユーザーが投稿したコメントを編集または削除することはできません。既存のコメントを編集する場合は、変更を加えてから
ボタンをクリックして確定します。変更を適用せずに終了するには、
ボタンをクリックします。
-
コントロールに対応するメニューには、Copy Linkコマンドもあります。このコマンドを使用すると、コメントスレッドの作成者は、そのスレッドを表示するためのリンクを取得して共有できます。提供されたリンクを開いたユーザーにプロジェクトへのアクセス権がない場合(そのユーザーにまだプロジェクトが共有されていない場合)、アクセスをリクエストできます。詳細については、直接リンクによる共有を参照してください。
- コメントウィンドウを開いたとき(対応するマーカーをクリックするか、Comments and Tasksペインで選択したとき)は、スレッドの最初と最新のコメントのみが表示されます。スレッド内のすべてのコメントを表示するには、これらのエントリの間にあるコントロールをクリックします。スクロールバーを使用して、すべてのコメントを閲覧できます。
-
共有された設計プロジェクトを閲覧しているユーザーは誰でも、コメントウィンドウ上部の
コントロールを切り替えることで、コメントを解決済みにしたり、再びアクティブにしたりできます。コメントにタスクが割り当てられている場合は、ステータスのドロップダウンメニューから現在のステータスを「解決済み」(または別のステータス)に変更できます。解決済みのコメントは、デフォルトではComments and Tasksペインに表示されませんが、ピンの表示/非表示オプションで表示できます。詳細については、次のセクションを参照してください。
- 設計プロジェクトの特定のリリースをレビュー中に(製造ポータルのDesign Snapshotビューで)ユーザーがコメントを投稿した場合、そのコメントには、該当リリースへのリンクとしてリリース情報が含まれます。
- 以前にコミットされたプロジェクト(Historyビューでコミットイベントとして表示)にVCSタグが付いている場合、そのコメントにはタグ名も表示されます。このタグ名は、そのコミット時点のスナップショットへのリンクとして機能します。
- コメント投稿にURLリンクを追加できます。URLをコピーしてコメント欄に貼り付けるだけで、自動的に検出され、クリックしてアクセスできる通常のリンクとして表示されます。
Commentsペインの操作
以下は、コメントとインターフェースのComments and Tasksペインの操作に関する注意事項です。
- Comments and Tasksペインは、コメントの投稿、編集、返信を行う操作用インターフェースではなく、プロジェクト全体のコメントを一覧表示し、移動するためのツールです。投稿、編集、返信の操作は、コンテキストコメントウィンドウでのみ行えます。
- メイン表示領域でコメントマーカーをクリックしても、Comments and Tasksペインは開きません。この操作では、コンテキストコメントウィンドウのみが開きます。
-
ペインの左上にあるコントロールを使用して、メイン表示ウィンドウ内のコメントマーカーピンを表示(
)または非表示(
)にできます。画像にカーソルを合わせると、例を確認できます。
-
Comments and Tasksペインの上部には、スレッドのフィルター設定にアクセスするためのコントロールがあり、ペインに表示する内容を指定できます。フィルターは基本的に2つのレベルで設定できます。第1レベル(プライマリレベル)では、どのユーザーのコメントを表示するかを制御できます。
ペインのフィルターオプションで、コメントの表示を次のように絞り込めます。
- Tasks only – ユーザータスクとして割り当てられたコメントのみ。これらは、Tasksページのフローでも利用できます。
- ASSIGNED TO – 下の一覧で選択したユーザーに割り当てられたコメントのみ。ユーザーのチェックボックスを選択すると、そのユーザーにタスクが割り当てられているコメントのみがペイン(および表示中のドキュメント)に表示されます。現在サインインしているユーザーは、コメントのタスクが割り当てられているかどうかにかかわらず、一覧の先頭に表示されます。
プライマリフィルターと組み合わせて適用される第2レベルのフィルターには、2つのオプションがあります。解決済みのコメントまたはタスクをすべて非表示にする(Unresolved onlyを有効化)、およびプロジェクト全体ではなく、現在表示しているアクティブドキュメントのコメントのみを表示する(Current documentのみを有効化)ことができます。
- 上記のオプションウィンドウの下部にあるNotification Settings項目をクリックすると、プロジェクト内のどのコメントについてメール通知を受け取るかを設定するウィンドウが開きます。すべてのコメントスレッドの通知を受け取る、通知を受け取らない、または自分が関与しているスレッド(自分が開始したスレッド、返信したスレッド、または自分がメンションされたスレッド)の通知のみを受け取る、のいずれかを選択できます。
-
ペイン内のコメントスレッドの並び順にも、2つのレベルがあります。まず、コメントは所属するドキュメントごとに並べられ、その順序は左側のペインにあるソースドキュメントのナビゲーション構造と同じです。次に、各ドキュメント内では、コメントが作成日時の降順に並べられます。
-
ペイン内のコメントスレッドの項目をクリックすると、メイン表示ウィンドウでそのコメントにフォーカスが移り、コンテキストコメントウィンドウが開きます。Comments and Tasksペイン内のコメント項目も青色で強調表示されます。Comments and Tasksペインには同じコメントマーカー番号が表示されるため、どのコメントを表示しているかを簡単に確認できます。現在表示しているドキュメント以外のコメントをクリックすると、そのコメントがあるドキュメントがアクティブになります。
- ペイン内の各コメント項目には、以下の例のように、そのコメントに関する主要な情報の概要が表示されます。
コメントに関するその他の注意事項
-
コメントがオブジェクトに関連付けられていて、そのオブジェクトが設計から削除された場合、コメントは領域コメントに変換され、同じ座標に残ります。このような場合、コメントに保存された元の設計のスクリーンショットが非常に役立ちます。
-
設計ドキュメントがプロジェクトから削除されると、そのドキュメントに関連付けられたコメントは非表示になります。
-
設計内でオブジェクトを移動すると、それに関連付けられたコメントも移動します。
-
以前のバージョンのAltium Designerでフリーハンドコメントを使用していた設計では、それらは領域コメントに変換され、各コメントにフリーハンドの描画が添付されます。
-
Altium Designer 20.xでは、フリーハンドの描画に使用された線の色と幅の設定は無視されます。代わりに、描画は赤色の線のみで表示され、線幅には、以前のバージョンのソフトウェアでコメントに使用されていた標準の変更不可の幅が使用されます。
-
解決済みのコメントは削除できません。未解決に戻してから削除する必要があります。
Jiraタスクの操作
Related page: Jiraタスクの操作
WorkspaceでJira連携が有効になっており、AdminページでJiraアプリケーションが設定されている場合、配置したコメントに、Atlassian Jira
コメントと同じ方法で配置したJira課題は、Comments and Tasksペインに表示されます。また、Jiraスペース内の課題へのリンクが用意され、タスクの優先度やステータスの設定を直接操作できます。
配置されたJiraタスクのインスタンスは、Jiraスペース内の対応する課題と同期されます。Jira課題とWorkspaceタスク間の双方向のデータ同期により、Altium 365と連携してJiraスペースから設計プロジェクトを管理できます。例を表示。
Jira連携の設定の詳細については、Jiraアプリケーションの情報を参照してください。
Requirements Portalの操作
Related page: 要件の操作
Altium 365 Web Viewerは、設計ドキュメントレベルでシステム要件を管理・検証するためのRequirements Portalとの連携にも対応しています。
Workspaceでこの機能が有効になっている場合、Requirements Portalのインターフェースで定義された正式な要件仕様(例を表示)をWorkspaceの設計ドキュメントに配置したり、担当者を割り当て可能なWorkspaceタスクとして作成したりできます。要件インスタンスはWorkspaceとRequirements Portalの間で常に同期されるため、プロジェクトのすべての関係者が、設計の要件仕様への適合状況を確認、管理、検証できます。
要件インスタンスは、Requirementsペインからドキュメントに配置するか、対応可能なWorkspaceタスクとして作成します。
Requirements Portalから提供される要件には、WorkspaceのRequirementsペインからアクセスし、コメントの配置と同じ方法で設計ドキュメントに配置します。選択した要件に対する設計の適合状況は、要件ウィンドウまたはRequirementsペイン内の該当タイルにある検証メニューのオプションから設定できます。
要件は設計ビュー内で検証済み(またはそれ以外の状態)に設定できます。検証ステータスは、Requirements Portalの要件エントリと同期されます。
新しいデータへの更新
Web Viewerインターフェースを使用して最新のソースプロジェクトのドキュメントを確認している場合(特定のプロジェクトを管理する際に詳細管理ページのDesign ビューから確認する場合や、共有されたライブ設計を表示する場合)、Altium DesignerからプロジェクトがWorkspaceにコミットされるたびに、データが自動的に更新されます。コミット後まもなく、インターフェース内に通知が表示されます。新しいデータの生成が完了したら、Refresh Pageコントロールをクリックして、ビューを最新のデータセットに更新します。










































































)のNet Name項目をクリックします。PCBデータビューでネットを選択するには、SCH データビューでネットを選択してからPCB データビューに切り替えるか、






























































