Altium Designer Documentation

Simulation Interface Updates

Modified by Rob Evans on Dec 18, 2020

Following on from the recent introduction of an advanced new SPICE Simulation engine for Altium Designer, which delivered improved speed, solution convergence, accuracy and reliability, the latest round of Simulation updates focuses on user interface improvements to the software's mixed-signal SPICE Simulation workflow.

The Simulation interface updates include a new intuitive Simulation Dashboard panel, a revised Sim Model dialog and general interface updates. The new Simulation workflow (based on the Simulation Dashboard) is offered as an alternative to the existing approach based on the Analyses Setup dialog. Also included is a comprehensive range of ready-to-use Simulation Generic components.

This simplified process of configuring, verifying and running a simulation is performed directly in the new Simulation Dashboard, as outlined below.

► See Mixed-signal Circuit Simulation for more detailed information.

Revised SIM Model dialog

The Sim Model dialog has been significantly revised to simplify the process of working with and adding component Simulation Models. Now refocused towards the immediate tasks that are undertaken during a circuit simulation workflow, the updated dialog interface rationalizes the model addition process to a fewer number of more logical steps. Access the dialog by adding a simulation model to a component (the Simulation option on the menu), or by editing a component's existing simulation model ().

Use the button in the Sim Model dialog to access a suitable simulation model from the available local library entries, or from your server-based model entries. Once the model is loaded, review and if necessary edit the schematic-model Pin Mapping, and add model Parameter values as needed.

Models for passive RLC components can be added by a simple automated process in the Simulation Dashboard during the Verification process.

Alternatively, you can apply a generic rather than a specific simulation model sourced from the supplied Simulation Generic Components library. Added as a File-based Library, this generic simulation model library holds a broad range of common simulation models and functions.

Note that the generic simulation parts can be placed directly on to the schematic from their library entries in the Components panel, but will need to be replaced by physical (rather than virtual) components as the design progresses.

Stimulation Source Interface

The stimulation sources used in a design are now considered as special virtual simulation tools rather than custom components. The sources are managed in a dedicated Properties panel mode rather than via a component simulation model, which directly offers access to the stimulation source's parameters and includes a representative waveform preview.

A Stimulation Source configuration can be assigned a Stimulus Name and further names added to the instance as needed (). You can then switch between the Stimulation Source configurations from the Stimulus Name drop-down menu.

Stimulation Sources can be added directly from the Active Bar, Mixed Sim toolbar or on-demand from the Simulation Dashboard panel – see below.

Simulation Dashboard Panel

A major component of the Altium Designer Simulation user interface updates is the introduction of the Simulation Dashboard panel. The panel offers a greatly simplified approach to checking, configuring, running and reviewing simulations when compared to the previous approach based on the Analyses Setup dialog. Open the new panel by choosing the Simulation Dashboard option from the button (bottom right) or by selecting the View » Panels » Simulation Dashboard command from the main menus.

The Simulation Dashboard panel is arranged as a sequence of interactive simulation process steps, where each section provides status feedback and/or configuration options. The panel can be set to apply to the nets and objects for all schematics in the design project (Project) or to the currently open schematic only (Document).

Following is an overview of each step section in the Simulation Dashboard panel:

1. Verification

Click the initial button to invoke a series of automated processes and checks, which include the generation of the circuit's SPICE Netlist (*.nsx), a number of simulation-related electrical rule checks, and simulation model validity checks. The model check will detect components with missing simulation models, and models with parsing or pin mapping errors. Use the context link associated with an error to correct the issue.

The system will automatically offer to add simulation models to passive components where needed. The simulation models for these components – resistors, inductors and capacitors – are inherently known by the simulation engine and are represented in the Sim Model dialog as a series of parameters. These auto-assigned simulation models are sufficient for most analysis requirements, and also provide the quickest and easiest approach to adding models to a circuit's passive components – click the associated Assign link to invoke the process.

  

Note that subsequent changes to the simulation circuit design will trigger a verification request.

2. Preparation

Manage Simulation Sources and Probes that are included in the current schematic. Sources and Probes can be enabled/disabled (checkboxes), removed (X), or created (+ Add). Note that Sources and Probes are configured through the Properties panel, and also may be added from the Active Bar.

3. Analysis Setup & Run

Configure and run the common simulation analyses, and optionally set up and apply parameter sweeps and Monte Carlo tolerance variations. Configuration options for the analyses include x-axis range settings (frequency/time), output plot setups based on output expressions, and additional processes such as Fourier and Noise analyses. Output plot expressions can be enabled/disabled, removed, or added.

Click the links in the panel to invoke the associated type of simulation analysis run.

Once an Operating Point analysis has been run to establish the electrical steady state of the circuit, the computed Voltage, Power or Current readings at relevant nodes can be shown as labels by selecting the Display on schematic button options in the Simulation Dashboard panel.

Advanced simulation plots that incorporate parameter sweep options are configured under the General tab in the Advanced Analysis Settings dialog, which is opened from the link in the panel's Analysis Setup & Run section. Select and configure a parameter variation that will apply to the current analyses. Select the dialog's Advanced tab to configure the simulation engine's advanced settings and options.

4. Results

Display and manage the results of the most recent simulation runs, listed as the available analysis types. The Load Profile option will restore the analysis settings from that run.

You also can toggle the lock icon () associated with a simulation result entry to preserve the results of that run, where a subsequent analysis run of that type will be renamed with an incremented number suffix.

Third Party Designs and Libraries

Altium Designer's Mixed-signal SPICE simulation now supports a range of analog SPICE model formats and designs including PSpice® and LTSpice®.

General PSpice model libraries, typically with a .lib extension, are accepted as file-based libraries loaded through the Data Management - File-based Libraries page of the Preferences dialog. A basic component symbol is automatically generated for each of these model entries, allowing them to be placed directly into a schematic design.

LTSpice Importer

Simulation designs saved from LTSpice® are able to be imported into Altium Designer with the LTSpice Import Wizard, which is made available by installing the LTSpice Importer software extension.

Invoke the wizard with the File » Import Wizard menu command, select LTSpice Design Files as the file type option, and then complete the subsequent wizard steps. Component symbol files referenced by the LTSpice design file (*.asc) are automatically added as library files, and in turn, the simulation models referenced within the component library files are also added to the import.

The import process results in an Altium Designer PCB project that also includes a Schematic Library containing the design's components and a set of generated simulation models in the general *.mdl format. LTSpice Voltage Sources are imported as an equivalent Altium Designer Simulation Stimulus type.

Library and Model files

  • The successful import of an LTSpice design relies on the availability of the design's component library data files, such as the supporting component symbol files (*.asy) and simulation model files (*.sub or *.lib, etc). All the required files should exist in the same source folder as the LTSpice design file (*.asc) that is being imported.
  • Contrary to the above, if the LTSpice application has been installed on the PC that hosts Altium Designer, then the library files will automatically be detected in the LTSpice installation and added to the import process.
  • Note that the Import Wizard also supports importing LTSpice component library files (*.asy) only, without the need for a corresponding design file (*.asc).

OrCAD Simulation Design Import

OrCAD™ designs and their associated PSpice® Simulation libraries are able to be imported into Altium Designer via the OrCAD Import Wizard, which is made available by enabling the OrCAD design importer in the Configure Platform page of the Extension and Updates view.

Invoke the wizard with the File » Import Wizard menu command, select OrCAD Designs and Libraries Files as the type option, and then complete the subsequent wizard steps. The process will import OrCAD design files (*.DSN), libraries (*.OLB) and PSpice simulation files (*.LIB) as required, and create corresponding Altium Designer project files, library files, and also PSpice model files in the sub-circuit format (*.ckt).

The import process will add the imported PSpice simulation model data to design components where required, and interpret stimulation source generators in the Altium Designer format. The result is a simulation-ready project design in Altium Designer.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。