Altium NEXUS Documentation

FAQ

Modified by Shinichi Kawaguchi on Nov 19, 2019

ソフトウェア ソリューションの特定領域を稼働させるために役立つ有効な方法の1つとして、よくある質問のリストを調べることができます。よくある質問は、通常、「この機能はどこにありますか」などの一般的な質問から「設計をxyz形式でエクスポートする方法を教えてください」といった、より具体的な質問まで多岐に渡ります。

Altiumは場合によって、予想される質問を先取りして記載したり、ユーザーの認識が必要なソフトウェアの重要な特徴を強調したりします。また、Altium Design Forumsを参照して、Altium NEXUSを毎日仕事で使用している人々が提供してくれる、あらゆるソフトウェア側面に関する莫大な知識を利用することも多くあります。

まずは、さまざまなFAQを含むリストにざっと目を通してみましょう。リストは探しやすいようにカテゴリ別にまとめられています。進捗を妨げていた問題を解消し、生産性の高い作業に戻るために必要な回答が見つかるかもしれません。

Altiumを使用した設計に関するこのFAQリストは全てを網羅するものではなく、今後も引き続き掲載情報を増やしていく予定です。その間、Altiumを使用した設計の可能性を最大限に引き出すためのお役に立てれば幸いです。

FAQは以下のカテゴリ別に分けられており、必要に応じてさらにサブカテゴリに分類されています。


Altium NEXUSの環境

全般

フローティングモードで移動しているときにパネルがドッキングしないようにするには、<Ctrl> キーを押したままにします。


プロジェクト

全般

はい。Altium NEXUSのインストールには、いくつかのサンプルプロジェクトが含まれています。サンプルプロジェクトは、Examplesフォルダー(デフォルトインストールでは、\Users\Public\Documents\Altium\AD<VersionNumber>\Examples)にあります。

管理されたプロジェクト

管理されたプロジェクトを使用する主な利点には、以下のようなものがあります。

  • 保管の簡略化保管場所の指定が不要バックアップなどの基本サービスの自動化
  • 共同作業機能の基盤
  • デフォルトでのバージョンコントロール
  • 専用コメントシステムを使用可能
  • 通知およびステータス。ローカルでの変更を含むドキュメントステータスが設計チーム全体に表示されます。
  • 複雑な設定を行わないで、PCB設計の並行作業が可能。

管理されたプロジェクトの利点は、デフォルトでバージョンコントロールによって管理されることと、共有ドライブ、サーバー、契約などを気にすることなく共同作業できることです。

最初にプロジェクトを表示できるのは、作成者と、管理されたコンテンツサーバー(コンテンツの保管場所)の管理者のみです。このプロジェクトに別のユーザーがアクセスできるようにするには、アクセス許可を設定してプロジェクトを共有します。

設計バリアント

設計のバリアントを確認するには、デザインをコンパイルした後で、回路図のコンパイル済みタブに切り替えますプロジェクトに対して1つでもバリアントが定義されていれば、[Projects] パネルでそのプロジェクトエントリーの下に [Variants] フォルダーが表示されます。このフォルダーには、ベースデザイン([No Variations])に加えて、定義した全てのバリアントが含まれます。リストから任意のバリアントを選んで現在のバリアントにするには、目的のバリアントをダブルクリックするか、右クリックしてコンテキストメニューで [Set as current] コマンドを選択します。この方法で [No Variations] を使用すると、ベースデザインに切り替えることができます。

コンパイル済みタブに切り替えるたびに使用可能なメニューが変わり、物理設計の表示時に実行できるコマンドが反映されます。回路図シートの下部にある論理設計タブ([Editor])をクリックすると、標準の編集メニューに戻ります。

PCB上での代替部品の処理方法は以下の2種類があります。

  • フットプリントが同じ場合  - 選択した代替部品のフットプリント名がベース部品と同じであれば、このフットプリントのインスタンスのみがPCBに転送されます。1つのコンポーネントに複数のフットプリントを割り当てることができるので、[Variant Management] ダイアログで各バリアントに対して正しいフットプリントを選択していることを確認する必要があります。
  • フットプリントが変わる場合 - 選択した代替部品のフットプリント名がベース部品とは異なる場合、両方のフットプリントがPCBに転送されます。設計者は、2つのフットプリントをPCB上でどのように配置するかを決める必要があります。実装されるのはどちらか一方だけなので、両方のフットプリントに同じデジグネータが割り当てられます。

代替部品の選択後、選択した代替コンポーネントと元のベースデザインのコンポーネントのピンに互換性があるかどうかをチェックします。ピン互換であるには、代替コンポーネントと元のコンポーネントの間でピン数が一致し、ピンの位置と電気的タイプも完全に一致する必要があります。ただし、シンボルで使用されるグラフィカルプリミティブが2つのコンポーネント間で一致する必要はありません。

代替コンポーネントのピンに互換性がないことが検出されると、[Confirm] ダイアログが表示され、置換を続行するには [OK] をクリックする必要があります。ピン互換でない代替コンポーネントを使用しても続行できますが、配線に影響が及ぶ可能性があるので注意してください。また、後でデザインをコンパイルするときに違反が発生するおそれがあります。

バージョンコントロール

Altium NEXUSのインターフェースでは、以下のVCSアプリケーションを使用できます。

  • Altium NEXUSに組み込まれたSubversion(SVN)バージョンコントロールシステム。
  • 管理されたコンテンツサーバーのビルトインSubversion(SVN)システム。一元化バージョンコントロール方式で、サーバーベースのデザインリポジトリと外部のデザインリポジトリの両方にアクセスする場合に使用します。

コンポーネントとライブラリ

全般

それぞれのモードに、同じ一連のピンが含まれる必要があります。そうでない場合、プロジェクトのコンパイル時に警告が生成されます。この条件があるのは、ピンからパッドへのマッピングは、1つのフットプリントに対して1セットしか定義できないためです。必要に応じて、特定のモードでピンを非表示にできます。また、全てのモードでピン位置が一致する必要はありません。

管理コンポーネント

同じであり、同じではありません。これは全て、管理コンポーネント(コンポーネントアイテム)に部品選択が関連付けられているかどうかによって決まります。ソースコンポーネント定義が最初にリリースされたときに生成されるコンポーネントアイテム(管理コンポーネントと呼ばれる)は、そのコンポーネントのエンジニアリングビューまたは設計ビューを表します。これは要するにコンテナで、設計領域でこのコンポーネントをモデル化するために使用される情報が全て格納されています。パラメーター情報に加えて、必要なドメインモデル(回路図シンボル、PCB 2D/3Dコンポーネント、シミュレーション)へのリンクが全て含まれます。これを使用して基板設計を行う設計者にとっては大きな意味がありますが、設計領域以外では意味がありません。設計領域とサプライチェーン領域を統合する、実際の「統合コンポーネント」となるには、物理的に製造された実際の部品がコンポーネントアイテムにマッピングされている必要があります。それには、このコンポーネントに部品選択を指定する必要があります。

そして、この単純な管理コンポーネントを本当の統合コンポーネントへと変えるのが、従来型の電子設計領域を、残りの組織からも認識されるもっと大きい「製品領域」へとマッピングするインテリジェントな機能です。

配置済みの各コンポーネントには、サーバーのソースコンポーネントアイテムへのリンクが割り当てられています。この情報は、[Properties] パネルで選択したコンポーネントのプロパティを表示すると確認できます。この最も低い個別コンポーネントレベルで、配置済みのインスタンスを、同じコンポーネントアイテムの新しいレビジョンに更新(または全く別のコンポーネントアイテムに変更)するには、[Design Item ID] 欄の右側にある...ボタンをクリックします。[Choose Item] ダイアログが開き、現在リンクされているソースサーバーのアイテム(およびそのレビジョン)が表示されます。新しいレビジョンを選択するか、別のコンポーネントアイテムを使用する場合はこれを参照します。

1か所からバッチ方式で複数の変更を反映する場合は、[Item Manager][Tools] » [Item Manager])を使用します。Item Managerは、1つの回路図シート(フリードキュメント)、または基板設計プロジェクト内の回路図一式に含まれる全ての管理コンポーネントとシートシンボルを表示します。これらの管理されたエンティティのうち、どのエンティティをどのように更新するかを、ユーザーがコントロールできます。エントリーを1つ選び、リンクされたアイテムの新しいレビジョンを選択します。リンクされたアイテムが同じであれば、一連のエントリーを選択して1回の操作で次のレビジョンを選択することができます。提示された全ての変更がマネージャに反映されます。

必要な変更を全て設定したら、設計変更指示(ECO)を生成して実行するだけで変更が反映されます。

データベース ライブラリ

はい。複数のExcelスプレッドシートファイル(*.xls)を使用してターゲットデータベースが作成されている場合、ODBCドライバーの制約により、接続できるシート数は64までになります。

コンポーネントのバックエンドデータベースとしてMicrosoft Accessを使用する場合、使用するAltium NEXUSソフトウェアのバージョンが32ビットであるか64ビットであるかによって重要な違いが1つあります。

  • 64ビットのAltium Designソフトウェア(Altium NEXUS 18.0以上)の場合 - MS Access DbLibsを使用するには、64ビットのMicrosoft Accessデータベースエンジンが必要です。
  • 32ビットのAltium Designソフトウェア(Altium NEXUS 17.1以下)の場合 - MS Access DbLibsを使用するには、32ビットのMicrosoft Accessデータベースエンジンが必要です。

Accessを含むMicrosoft Officeは、通常、適切なバージョンがインストールされますが、多くのユーザーが、32ビットと64ビットの両方のバージョンのAltium NEXUSソフトウェアを同じコンピューターで実行すると考えられます。ここで問題になるのは、32ビットと64ビットの両方のOfficeアプリケーションおよびドライバーを同じコンピューターで実行することを、Microsoftが正式にはサポートしていない点です。考えられる3つの解決策については、Using Database Libraries with 32-bit and 64-bit Altium Design Software on the same Computerを参照してください。

サプライヤーデータへの関連付け

サプライヤーデータへのライブリンク機能を使用するために、Altiumアカウントにサインインする必要はありません。サプライヤーデータの検索は、Webサービス経由で直接実行されます。ただし、価格情報を別の通貨で表示するとき、通貨換算の為替レートが毎日更新されますが、これはアカウントにサインインしている場合に限られます。

この状態は、ユーザーが組織に管理されたコンテンツサーバーにサインインしている場合に発生します。組織で使用するサプライヤーは、管理されたコンテンツサーバーによって一元的に規定されるので、サーバー接続中は、[Preferences] ダイアログ[Data Management - Suppliers] ページに表示されるサプライヤーリストが無効化されます。これは、集中管理、定義されたリストの読み取り専用コピーです。このリストは、ブラウザーベースのサーバーインターフェースの [Suppliers] ページで定義します。

パッド/ビアテンプレートとライブラリ


回路図

マルチシートとマルチチャンネルデザイン

フラットデザインは、大規模な回路図シートを切って多数の小さいシートに分割したようなものだと考えることができます。フラットデザインでは全てのシートが同じレベル上にあります。フラットデザインでは、任意のシートから別の任意のシートに対して接続を直接作成することができ、このような接続は水平接続と呼ばれています。

一方、階層デザインには、シート間の親子関係を作成するためのシートシンボルが含まれます。これらのシートシンボル内のシートエントリーを介して接続が作成され、シート上のポートから別のシート上のポートに直接接続することはできません。

シート間の接続を作成する方法を定義するには、ネット識別範囲を使用します。ネット識別範囲は、[Options for Project] ダイアログの [Options] タブで設定します。

あるシートから別のシートに直接、接続されている場合、そのデザインはフラットであり、この接続動作を定義するには、[Net Identifier Scope][Automatic][Flat][Global] のいずれかを設定します。ただし、ポートとネットラベルを組み合わせてシート間の接続を作成する場合、[Automatic] オプションは使用できません。この場合は [Net Identifier Scope] に手動で [Global] を設定する必要があります。

シート間の接続が、親シートのシートエントリーと対応する子シートのポートの間にのみ作成されている場合、その設計は階層型であり、この接続動作を定義するには、[Net Identifier Scope][Automatic][Hierarchical][Strict Hierarchical] のいずれかを設定します。

いいえ。マルチチャンネルデザインは階層型でなければなりません。これは、デザインのコンパイル時に、ソフトウェアがこの構造モデルを使用してメモリ内にチャンネルインスタンスを作成するからです。

マルチチャンネルデザインの場合、[Net Identifier Scope][Automatic][Hierarchical][Strict Hierarchical] のいずれかを設定します。

コンポーネントとネットに重複がある場合、[Options for Project] ダイアログの [Multi-Channel] タブで選択された命名ルールに従い、ソフトウェアによって重複が解消されます。

アノテート

アノテートは、デフォルトで、コンポーネントのデジグネータの位置に基づいて設定されます。アノテートが予想どおりに設定されない場合、デジグネータの配置が正しいことを確認してください。または、コンポーネントの位置の基準として、部品(正確には部品の中央)を使用する方法もあります。

デジグネータまたは部品を使用する場合、[Annotate] ダイアログでこれを指定します。


PCB設計

全般

PCBデザインにグラフィックを含める方法は2種類あります。

Windowsクリップボードから貼り付け

PCBエディタでは、通常のWindowsの<CTRL> + <V>貼り付けコマンドを使用して、Windowsクリップボードから直接メタファイルを現在のPCBレイヤーに貼り付けることができます。ただし、全ての画像エディタで、画像データがメタファイルデータとしてクリップボードにコピーされるわけではないので注意が必要です。確実にメタファイルデータとしてコピーするには、はじめにイメージをMicrosoft Wordに貼り付け、そこからコピーしたデータをAltium NEXUSに貼り付けます。

対応されているメタファイルデータには、ビットマップ、線、円弧、シンプルフィル、TrueTypeテキストが含まれるので、ロゴなどのグラフィカルシンボルを簡単に貼り付けることができます。インポートされたデータは現在のレイヤーに配置され、このレイヤーに指定された色が適用されます。貼り付けプロセス中に作成されたPCBオブジェクトは、自動的にユニオンに追加されます。貼り付け後、ユニオンの編集ハンドルを使用して、貼り付けたイメージのサイズを微調整できます。貼り付けで作成されたユニオンのサイズはいつでも変更できます。右クリックで表示されるメニューから [Resize Union] コマンドを使用してください(コマンド実行後に目的のユニオンをクリックして選択します)。

[Preferences] ダイアログ[PCB Editor - General] ページ[Paste from other applications] オプションを使用すると、[Preferred Format] として [Metafie] または [Text] を設定できます。このオプションは、グラフィックには影響を与えません。グラフィック内の個々の形状はリジョンオブジェクトに変換されます。テキスト文字列を貼り付けるとき、このオプションに [Metafile] が設定されていれば、それぞれの文字がテキスト文字列に変化され、[Text] が設定されている場合は文字列全体がAltium NEXUS文字列として貼り付けられます。


Altiumロゴがグラフィックとして貼り付けられ、グラフィック内の各文字がリジョンオブジェクトに変換されています。

グラフィックをフォントとして配置

グラフィックを絵文字(フォントに含まれる文字の1つ)として含むカスタムのTrueTypeフォントを作成し、そのフォントを使用して文字列をPCBに配置することができます。この方法は使いやすいだけだけでなく、絵文字のフォントがベクタ形式の画像から作成されるので、正確な倍率を設定できます。

PCB設計で使用される多数の標準シンボル(鉛フリー、リサイクル、静電気注意、アース、C-Tick、UL、CE、FCCなど)のフォントは、Altium NEXUSを使用した設計に関する代表的な専門家の1人であるMooretronicsのDarren Moore氏によって作成されたものです。このフォントは、こちら(2015年1月付)からダウンロードできます。また、新しいバージョンについては、Altium NEXUS forumのスレッドで最新の投稿をチェックしてください。

このフォントは、カードウェアとしてライセンス提供されています。使用条件については、ダウンロードしたzipファイルに含まれるReadme.txtを参照してください。readmeファイルには使用可能なグラフィックのリストも含まれています。グラフィックの多くで、テキストあり/なしの両方のバージョンが提供されており、大文字または小文字を使用して希望するバージョンを選択できます。以下の画像は、このフォントで使用できるグラフィックの例です。


Mooretronicsフォントに含まれる便利なグラフィックの例

基板

スプリットラインをドラッグするとき、ドラッグ先が許可された場所で、有効な分割を実行できる場合はラインが青色で表示されたままになります。終点の移動先が無効な場所である場合(ボードシェープと同じ外形上にある場合など)、スプリットラインは赤色に変わります。ラインが赤く表示されている間に配置しようとしても、スプリットラインは削除されます。

ボードを折りたためるのは、[Board Region] ダイアログのリジッド部分のいずれかで、[3D Locked] オプションが有効になっている場合に限られます。この設定が必要なのは、折りたたみプロセスで固定状態を維持する基板部分をAltium NEXUS側で認識する必要があるからです。

デザインルールとDRC

ポリゴン クリアランスルールが失敗する最も一般的な理由は、そのルールがポリゴンを構成するプリミティブをターゲットとするのではなく、ポリゴンを1つのエンティティとして対象にしているからです。ポリゴン内のプリミティブをターゲットにするには、ポリゴンに対するクリアランスルールで、キーワードとして、IsPolygonではなくInPolygonInPolyInNamedPolygonのいずれかを使用する必要があります。

Polygon Pourオブジェクトは、ポリゴンが再構築されるときに必要に応じて再生成されるリジョンオブジェクトまたはトラックオブジェクトのコンテナと見なすことができます。トラックとリジョンは、PCB製造プロセスで作成される物理的な銅箔の一部を構成します。物理的な銅箔に対応するその他のオブジェクトには、円弧、フィル、ストリング、パッド、ビアがあります。クリアランスルールの対象となるのは、いわゆる「銅箔オブジェクト」であるこれらのオブジェクトのみです。クリアランスルールのクエリーは、ターゲットがPolygon Pourオブジェクトである場合(クエリーでIsPolygonが使用されているなど)、正しく動作しません。InPolygonなどを使用して、ポリゴンを構成するリジョン、またはトラックをクエリーの対象にする必要があります。

もう1つの注意事項として、ポリゴン クリアランスルールは、一般的なクリアランスルール(AllAllの間のクリアランスルール)よりも優先順位を高くする必要があります。最も高い優先順位は1です。

Polygon Pourオブジェクトとその他全てのオブジェクトの間のクリアランスを設定します。

1番目のクエリー InPolygon
2番目のクエリー All

ネットクラスPower内のネットに関連付けられたPolygon Pourオブジェクトと、その他全てのオブジェクトの間のクリアランスを設定します。

1番目のクエリー InPolygon and InNetClass('Power')
2番目のクエリー All

Polygon Pourオブジェクトとトップレイヤー上のオブジェクトの間のクリアランスを設定します。

1番目のクエリー InPolygon
2番目のクエリー OnTopLayer

PolyPower_VCC_1という名前のPolygon PourオブジェクトとGNDネット内のビアの間のクリアランスを設定します。

1番目のクエリー InNamedPolygon('PolyPower_VCC_1')
2番目のクエリー InNet('GND') And IsVia

配線

コネクションラインを常に表示するには、[View Configurations] パネル[View Options] タブの [Additional Options] セクションで、[All Connections in Single Layer Mode] オプションを有効にします。

インタラクティブ配線中、現在配線しているネットのトラックセグメントは、格子状または空洞(空白)で表示されます。全ての格子状セグメントは、次にクリックされた時点で配置されます。空洞セグメントはルックアヘッドセグメントと呼ばれます。ルックアヘッドセグメントの目的は、コミットしなくても、次のセグメントの配置場所を事前に検討できるようにすることです。

配線中、キーボード ショートカットの<1>使用すると、ルックアヘアッドモードのオン/オフを切り替えることができます。

3D

3Dナビゲーションを使用するには、マウスの右ボタンを押したままにします。右ボタンだけを押したままにするとパンし、<Ctrl>キーを同時に押すとズームし、<Shift>キーを同時に押すと回転します。

基板は常に、現在のカーソル位置を中心にして動きます。動作コマンドを起動する前に、カーソルを適切な位置に合わせてください。

<0>(ゼロ)を押すと、基板が回転なしの水平なデフォルト状態に戻ります。<9>を押すと、水平または垂直方向に向きます(90度の回転)。

<Ctrl> + <F>キーボード ショートカットを使用すると基板が反転し、基板の反対側が表示されます。

3Dレイアウトでのナビゲーションに使用するメインツールは、回転する球体です。<Shift>キーを押したままにすると、現在のカーソル位置に回転する球体が表示されます。<Shift>キーを押したままで右クリックすると、いずれかの動作モードが開始します。動作モードの選択は、右クリックしたときに、どの動作セレクターがハイライト表示されているかによって決まります。以下のイメージでは、中央にあるドットがハイライト表示されているので、マウスを動かすと、その動きに合わせて基板が球体の回りを全方向に回転します。その他の動作モードには、水平回転、X軸回転、Y軸回転があります。モードを選択するには、右クリックする前に、目的の動作セレクターにカーソルを合わせます。


回転球体を中心に基板を回転させるには、<Shift>キーを押しながら右クリックしたままにします。

回転球体を使用する代わりに、3Dマウスを使用する方法があります。例えば 3Dconnexion製のSpace Navigatorを使用すると、3Dレイアウトモードで非常に簡単に基板を移動および回転することができます。

インポートした3Dモデルで使用できる基準点には、Altium NEXUSでオブジェクトの位置合わせに使用するために適したハンドルが提供されない場合があります。設計者が一般的に必要とする基準点は、穴の中心やピンの中心です。

押し出し、円柱、球体、リンク/埋め込みモデル(STEP、Parasolid、SOLIDWORKS)といったモデルタイプや、管理されたコンテンツサーバーから参照される3Dモデルアイテムには関係なく、どのような3D外形にもスナップポイントを追加できます。

円(穴)、またはピンの中心にスナップポイントを追加する場合、どちらも以下の手順を実行します。

  1. ピン、または穴にアクセスしやすいように、モデルの向きを合わせてズームインします。
  2. [Tools] » [3D Body Placement] » [Add Snap Points from Vertices] コマンドを選択します。
  3. ステータスバーに注意しながらカーソルを目的の3Dモデル上に合わせてクリックし、<Enter>キーを押して選択します。カーソルが3D位置カーソル(青色で6つの点を持つ形状)に変わります。
  4. 次に、スペースキーを押してコマンドを2番目のモードに切り替えます。このモードで、選択した2つの頂点の中間位置にスナップポイントを定義できます(ステータスバーに詳細を表示)。
  5. ピン、または穴のエッジにカーソルを合わせ、クリックしてこれを頂点として選択します。
  6. ピン、または穴の反対側にある2番目の頂点にカーソルを合わせ、クリックしてこれを選択します。
  7. ピン、または穴の中心に、スナップポイントが表示されます。

出力

全般

Altium NEXUSのデータをExcelのBOMにマッピングするには、BOMの生成に使用するExcelテンプレートに、Field=XXXXColumn=YYYYの項目を入力します。例えば、Column=LibRefを追加すると、全てのコンポーネントのライブラリ参照をリストにした列が追加され、Field=Titleを追加すると、Titleパラメーターに定義された値が追加されます。詳細については、Including Design Data in the Excel BOMを参照してください。

PCBドキュメント内のプリミティブが、ガーバーのエクスポート設定に指定された領域に収まらない場合、このエラーが表示されます。原因としては、基板/パネルがこの領域より大きいか、off-boardオブジェクトのせいで予想よりも範囲が大きくなっている可能性があります。

フィルムサイズを大きくする手順

  1. メインメニューから、[File] » [Fabrication Outputs] » [Gerber Files] コマンドを選択します。
  2. [Gerber Setup] ダイアログが表示されたら、[Advanced] タブを選択します。
  3. フィルムサイズとして適切なX(横方向)Y(縦方向)の値を入力したら、もう一度ガーバーファイルを生成します。
  4. XとYの値が、使用するPCBに対して既に十分大きい値である場合、PCBエディターに戻り、off-boardオブジェクトをチェックします。

off-boardオブジェクトの特定と削除

[View] » [Fit Document] コマンド(キーボードショートカット: <Ctrl> + <Page Down>)を使用します。PCBファイルで、基板のエッジの外側にオブジェクトがある場合、これらのオブジェクトが含まれるように画面サイズが変更されます。オブジェクトが遠く離れている場合、ボードが非常に小さく表示されます。これらのオブジェクトを削除するには、以下の手順を実行します。

  1. メインメニューで [Edit] » [Deselect] » [All] コマンド(キーボードショートカット: <X>、<A>)を使用し、選択を全て解除します。
  2. メインメニューで [Edit] » [Select] » [Outside Area] コマンド(キーボードショートカット: <S>、<O>)を使用し、基板の周囲をドラッグします。
  3. off boardオブジェクトが選択されたので、削除できる状態になりました。削除する前に、[PCB List] パネルを開き(<Shift> + <F12>キーを押すか、[View] » [Panels] » [PCB List] を選択)、選択したオブジェクトを確認することを推奨します。右クリックで [Remove Non-Selected] を選択し、選択されていないオブジェクトをリストから削除します。

これらのオブジェクトを削除するか、PCBの範囲内で正当な位置に戻したら、ガーバーファイルを再生成します。エラーメッセージが表示されないことを確認します。

ドリルテーブルは出力生成中に自動的に更新されますが、いつでも手動で更新できます。手動で更新するには、テーブルが選択されているときに [Properties] パネルで ボタンを押します。

Altium NEXUS 18.0では、ドリルテーブルの自動更新を [Advanced Setting] で設定できるようになっていますが、デフォルトはオフです。自動更新オプションを有効にすると、パフォーマンスが低下する場合があります。


システムのインストール、ライセンス認証と管理

全般

はい。Altium NEXUSでエラーが発生した場合に、Altium開発者にクラッシュレポートを送信する機能が提供されています。エラー/例外ダイアログが表示された場合、[Send Report] ボタンをクリックしてエラー発生時の操作内容の説明を追加してください。情報が多いほど、クラッシュの原因を再現して問題を解決できる見込みが高くなります。

注 - クラッシュが発生したのに例外ダイアログが表示されない場合、ソフトウェアがフリーズ状態になっています。強制的にクラッシュレポートを送信するには、キーボードショートカットの<Ctrl> + <Alt> + <Insert>を使用してください。ダイアログは、Altium NEXUSアプリケーションウィンドウの後ろに表示される場合があります。

インストール

インストールしたAltium NEXUSを、同じメジャーバージョン内で次のプライマリ(またはセカンダリ)ポイントリリースに更新することはできますが、特定のメジャーバージョンから次のメジャーバージョンに更新することはできません。

つまり、Altium NEXUS x.0.1をインストールしている場合、x.y.zへの更新は有効ですが、x+1.y.zに更新することはできません。

ここで

  • xは、現在のメジャーバージョンです。
  • x+1は、次のメジャーバージョンです。
  • yは、現在のメジャーバージョン内の現在のプライマリポイントリリースです。
  • zは、現在のメジャーバージョン内の現在のセカンダリポイントリリースです。

したがって、検討している次のソフトウェアバージョンに応じて、2つの選択肢があります。

  • 同じメジャーバージョン内で更新が可能な場合 - 現在のバージョンを更新するか、または新しい更新を別にインストールし、両方のバージョンを共存させた上で、要件に適したバージョンを使用することができます。
  • 次のメジャーバージョンを使用可能な場合 - 現在のバージョンを引き続き使用するか、最新機能を使用するために次のバージョンをインストールすることができます。または、両方のバージョンをインストールして、必要に応じて最適なバージョンを使用することもできます。
異なるバージョンをインストールする利点は、古いバージョンを直接、すばやく利用できる一方、独立して、古いバージョンを効率的に新しいバージョンに更新できる点です。
ソフトウェアの各バージョンには、専用のインストーラーがあります。

ソフトウェアの複数バージョンを容易にインストールする2つの重要な要素があります。

  • インストールの際、プログラムファイル共有ドキュメントのインストール場所として、異なるインストール先フォルダーを指定できます。
  • システムは、それぞれのバージョンに対してGUID(Globally Unique Identifier)を使用します。この識別子(標準的な128ビットのURNモデルを使用し、32桁の16進数で表される)は、アプリケーションデータフォルダーやレジストリの項目を一意的に識別するために使用されます。Altium NEXUSの特定のバージョンを実行する場合、システムはこの識別子を使用して、そのバージョン専用のファイルやレジストリ項目を操作します。

メインプログラムのインストールフォルダーおよび共有ドキュメントフォルダーについては、内容がわかる名前をつけることができます。ソフトウェアの複数の異なるバージョンがインストールされたマシンでは、これは非常に便利です。ただし、他のフォルダーはGUIDでのみ区別されます。このため、適切なフォルダーが適切なバージョンに使用されていることを見分けることが突然難しくなります。しかしながら便利な方法があります。[Preferences] ダイアログを使用すると、現在動作しているバージョンのソフトウェアで使用されているGUIDをすばやく識別し、その情報を使ってWindowsエクスプローラーから適切なフォルダーを選択できます。

GUIDは、(Altium NEXUSの標準のデフォルトインストールの)[Preferences] ダイアログの以下のページで識別できます。

ライセンス認証

いいえ、ライセンス認証は不要であり、これこそがオンデマンド ライセンスの特長です。ユーザーが認証プロセスについて気にする必要はありません。オンデマンド ライセンスを使用する場合、認証手順や手動追加の必要なライセンスファイルはありません。アカウントにサインインするだけで、ユーザーに指定された全ての該当ライセンスが適用されます。

スタンドアロン ライセンスで、Altiumアカウントに(Altiumポータルから)サインインする必要があるのは、以下の場合のみになります。

  • 最初にライセンス認証を行うとき
  • ライセンス認証を再実行するとき(ライセンスファイルのバックアップを作成せずにライセンスを削除した場合などに必要 )
Altiumアカウントのグループ管理者は、Webブラウザーから直接、Altium Dashboardを使用してスタンドアロンライセンスのライセンス認証を行うこともできます。この方法は、クライアントPCが何らかの理由でインターネットにアクセスできない場合、特に有効です。インターネットに接続できる管理者ユーザーがライセンスにアクセスしてライセンス認証を行い、該当する.alfファイルを組織の各クライアントユーザーに送るだけです。

はい、可能です。ご使用のライセンスタイプによって方法が異なります。オンデマンド ライセンスオンデマンド モードで使用している場合、オフィスでの使用後、帰宅前にライセンスを解放してください。その後、自宅でライセンスにアクセスして使用し、終了したら解放します。

スタンドアロン ライセンスを使用している場合、ライセンスファイルを自宅のコンピューターにコピーするだけで作業できます。ただし、当然ながら、2つのAltium NEXUSインスタンスを同時に実行することはできません。

いいえ。オンデマンド ライセンスの使用中、常にインターネットへの接続(Altiumポータルへのログイン)が必要とされるわけではありません。これは、オンデマンド ライセンスを使用する方法の1つ(オンデマンド モード)にすぎません。例えば、複数のユーザーが常にAltium NEXUSを使用しているわけではない場合、ユーザー間で同じライセンスを共有するためにこのモードを使用できます。オンデマンド ライセンスを「オフライン」(サインインしない)モードで使用する場合、ライセンスをローミングすることができます(ローミングモード)。

オンデマンド ライセンスのローミングモードは、「オフライン」での使用を可能にします。インターネット接続があるかないかに関係なく、任意の場所で作業でき、ライセンス認証は有効なままです。アカウントにサインインする必要があるのは、早めにライセンスを返却する場合や、「ローミング時間」を延長する場合だけです。

オンデマンド ライセンスをローミングできる最長時間は、実際のライセンス自体の有効期間です。これは特に、期限付きライセンスに関係があります。

オンデマンドライセンスをローミングしていてローミング期間が終了した場合、猶予期間はなく、そのライセンスは使用できなくなります。

スタンドアロンプライベートサーバーライセンスのライセンス認証は、Webブラウザーから直接、Altium Dashboardを使用して実行できます。業務用ではない(Altium NEXUSを実行していない)PCを使用して、Dashboardにアクセスします。必要なライセンスファイル(*.alf)を取得したら、ネットワークに接続されていない通常の(業務用)PCにファイルをコピーします。詳細については、License Activationを参照してください。

Altium Dashboardにアクセスして使用できるのは、Altiumアカウントのグループ管理者のみです。

アカウントにサインインすると、使用可能なスタンドアロン ライセンス[Available Licenses] 領域に表示され、使用していないことが示されます。もう一度使用するには、[Reactivate] オプションを使用してライセンスを再認証します。

または、アカウントのグループ管理者である場合、[Altium Dashboard] でライセンスを認証してファイルを取得できます。

Altiumポータルは、ユーザーのAltiumアカウントに関連付けられた機能を安全に使用する手段を提供します。オンデマンド ライセンスは、ポータルで機能を提供する例の1つです。また、SupportCenterやインストール管理へのアクセスも提供しています。これらを使用するには、Altiumアカウント(AltiumLive)の認証情報を使用した安全で一意のログインが必要です。

Altiumポータルを介したAltiumアカウント管理サーバーへの接続は全て、httpsを介した安全な接続です。

Altium NEXUSからオンデマンド サービスへの接続機能を使用するとき、Altiumによって以下の情報が収集される場合があります。

  • MACアドレス: Altiumは、PCを識別するためにコンピューターのMACアドレスを使用します。複数のコンピューターからサインインすると、それぞれのサインイン要求が個別に記録されます。
  • HDDシリアル番号: MACアドレスに加えてこの情報を使用することで、ライセンス認証を目的としたPCの識別がより確実になります。
  • Altium NEXUSのバージョン: Altiumはソフトウェアバージョンを使用して製品を区別することで、各製品に適したサービスを提供することができます。

サインイン認証情報とともに上記の情報を使用することで、アカウント管理サーバーは有効なライセンスが使用されていることを確認できます。

Altiumが、Altium NEXUS内で使用される設計またはファイルに関する情報を読み取ったり収集したりすることはありません。Altium NEXUSからAltiumポータルへの接続は全てセキュリティ保護されています。収集される情報だけでなく、ユーザーが入力した情報も、Altiumポータルへのリクエストに含まれて送信されます。Altiumポータルでデータが記録されるとき、データには記録時のタイムスタンプが含まれます。

ライセンスの使用状況をAltiumが把握することについて懸念がある場合、ローミングモードでライセンスを使用するか、スタンドアロンライセンスを使用することをお勧めします。

ユーザーは、サーバーに永続的に接続しているわけではありません。Altium NEXUSがリクエストを送信したり、返答を受信したりするとき、セキュリティ保護されたAltiumポータルを介して、アカウント管理サーバーと通信します。その後、接続は終了します。サインインや、表示する使用可能なライセンスの要求など、多数のリクエストが送信されますが、それぞれが独立しており、リクエスト後に接続は終了します。

オンデマンド ライセンスの使用中、Altium NEXUSはライセンスの更新や、使用中のライセンスがリモートから強制解放されていないかどうかを確認するために、定期的にセキュリティ保護されたAltiumポータルを介して、アカウント管理サーバーにリクエストを送信します。何らかの理由でアカウント管理サーバーに接続できない場合も、ライセンス認証は失われず、使用を継続することができます。Altium NEXUSは定期的に接続を回復しようとします。最初はユーザーへの通知は行われませんが、ユーザーによってはタイトルバーに表示されるエラーに気づくかもしれません。このメッセージは再接続すると表示されなくなります。長時間にわたって(例えば数時間以上)アカウント管理サーバーに接続できない場合、Altiumポータルへのインターネット接続を確立するように要求するメッセージダイアログが表示されます。この場合も、ライセンス認証は引き続き有効できます。

オンデマンド、またはローミングのいずれかのモードで使用しているか、Altium NEXUS内で直接使用している場合、オンデマンド ライセンスを強制的に解放することができます。例えば、休暇の際にライセンスを解放し忘れた場合、自宅のコンピューターから解放し、家でそのライセンスを使用することができます。「解放権限」の及ぶ範囲は、ライセンスに対して管理者権限があるかどうかによって異なります。

  • 管理者権限がある - 任意のユーザーが使用しているライセンスをリモートで解放できます。ライセンスは解放され、それを使用していたユーザーはライセンスを失効します。
  • 管理者権限がない - 自分が使用している(別のコンピューターの)ライセンスに限り解放できます。そのライセンスは再使用できます。
別のコンピューターでローミング中のライセンスに対してシートを強制解放する場合、Altium倫理規定に従って、ライセンスの解放後にそのコンピューターでそのローミングライセンスを使用しない、または他のユーザーに使用させないことを約束する必要があります。
Altiumアカウントの管理者は、また、Altium Dashboard内で使用中のオンデマンド ライセンスのシートを強制解放することができます。

全てのオンデマンド ライセンスには、同時に使用できるシートが一定数あります。規定された数に達するまで、ユーザーはライセンスを使用するためのシートを獲得できます。後続ユーザーが自由にライセンスを使用できるわけではありませんが、「制限を超えた」使用が可能です。システムはシートが使用可能になったかどうかを定期的にチェックし、シートが使用可能になって獲得されるまで、シート制限を超えていることをユーザーに通知し続けします。

Altium NEXUSの各バージョンが、ライセンスのシートを1つ維持します。それぞれのケースで、1つのオンデマンド ライセンスオンデマンド モードで使用されます。

オンデマンド ライセンスが期限切れになることはありません。バックグラウンドでのライセンス有効性チェックやライセンス更新で、何らかの理由によりエラーが発生した場合も、ライセンスの使用を継続して作業を保存できますが、メッセージが表示されます。表示されるメッセージは状況によって異なります。

  • インターネット接続が切断された場合、Altium NEXUSのタイトルバーにメッセージが表示され、サインインでエラーが発生したという警告が通知されます。
  • 何らかの理由でポータルのセッションがタイムアウトした場合、sign inダイアログが表示されます。
  • 上記以外で、「Altiumポータルはライセンスを更新できませんでした。Altium NEXUSはまもなく再試行を行います」というメッセージが表示される場合があります。

セッションがタイムアウトする理由はいくつかあります。1時間以上ポータルにリクエストを送信しないと、セッションはタイムアウトします。また、それまでの操作に関係なく、約12時間経過するとセッションはタイムアウトします。ユーザーがサインインしている間にポータルが再起動した場合も、セッションタイムアウトになります。

ライセンスの利用状況は、Altium NEXUSの [License Management] ビューで確認できます。[Available Licenses] 欄で、ライセンスの左側にあるプラス記号(+)をクリックすると、詳細情報が開き、このライセンスのシートを使用しているユーザーと使用モードが表示されます。

または、Altiumアカウントの管理者である場合は、[Altium Dashboard][Reports] ページにアクセスします。このページは、オンデマンド ライセンスの使用状況を監視およびレポートする広範な機能を提供しています。提供されるレポートを使用すると、組織内でライセンスがどのように使用されているかを監査することができます。これは、利用可能なライセンスシートが最善の方法で使用されていることを確認するとともに、将来的なライセンス要件を予測し、個々のユーザーの使用状況を明らかにするために役立ちます。

Altium NEXUSの拡張

Altium NEXUSでは、ソフトウェアの拡張機能の管理は [Extensions and Updates] 画面から行います。この画面を表示するには、ワークスペースの右上のコントロールをクリックし、メニューから [Extensions and Updates] コマンドを選択します。

[Extensions & Updates] 画面は、[License Management] 画面のライセンス一覧の下方にある [Extensions and Updates] コントロールをクリックして、直接、表示することもできます。

Altium Dashboard

管理者権限のあるユーザー(アカウントのGroup Administratorsグループのメンバーであるユーザー)のみがDashboardへのアクセス権を持ち、組織のアカウントを表示および変更することができます。

Group Administratorsグループのメンバーとして追加されたユーザーは、このアカウントの管理者になります。ユーザーをこのグループに追加する方法は以下の2つがあります。

  • アカウントに対して新しいライセンスが購入されると、このライセンスのNotification Contactが自動的にこのグループに追加されます。
  • 別のアカウント管理者が手動でユーザーをこのグループに追加することもできます。言い換えると、Group Administratorsグループのメンバーは、このグループにメンバーを追加するだけで、別のユーザーに管理者権限を付与できます。

企業ロゴには、アップロードしたイメージのサイズが220x220ピクセル以下で、JPGまたはPNG形式のものを使用できます。

組織のプロファイルにアクセスするには、この組織に属するユーザーのプロファイルページで、プロファイルに関連付けられたリンクをクリックします。また、AltiumLiveコミュニティ内の別の領域(通常はユーザーの名前の近く)からも組織のプロファイルページへのリンクにアクセスできます。例としては、Forumの記事やBugCrunchレポートがあります。

組織のプロファイルを非公開にして、AltiumLiveコミュニティ全体には表示しないようにするには、Dashboard[Profile] ページの [General Information] 領域で、[Public] オプションを無効化します。

新規ユーザーをアカウントに追加する場合、このユーザーの電子メールアドレスとして、既存ユーザーによって使用されていない電子メールを入力する必要があります。電子メールアドレスが重複した新規ユーザーを作成しようとすると、警告を表示したエラーダイアログが表示されます。

これには、目的のユーザーをいったん無効化してから再度有効化する必要があります。有効化によりパスワードリセットが起動され、新しい一時パスワードを含む電子メールがユーザーに送信されます。

Dashboardを使用せずに、ユーザーが自分でパスワードをリセットすることもできます。この場合、[AltiumLive Sign-In] ページ[Forgot Password] リンクをクリックします。新しい一時パスワードを含む電子メールがユーザーに送信されます。

パスワードは8文字以上の英数字でなければならず、1つの数字、1つの大文字、1つの小文字を必ず含む必要があります。スペースは使用できません。

削除操作を取り消すことはできません。間違ってユーザーを削除した場合、新規ユーザーをアカウントに追加するのと同じ方法で、もう一度ユーザーを追加する必要があります。

特定のAltiumアカウントに定義されたグループであれば、任意の数のグループに、ユーザーをメンバーとして追加できます。

いいえ。Dashboardを使用して、アカウントにライセンスを追加したり削除したりすることはできません。ライセンスの購入については、Altium営業所へのお問い合わせが必要です。

これは、ライセンスのサブスクリプションの有効期限です。この日を過ぎると、コンテンツへのアクセスおよびソフトウェアの更新の権限が終了します。

Dashboard内で割り当てる場合、特定のライセンスを表示してから、このライセンスを使用するグループを割り当てる方法と、特定のグループを表示してから、このグループに1つ以上のライセンスを割り当てる方法があります。この方法は、オンデマンド ライセンスとスタンドアロン ライセンスにのみ適用できます。

オンデマンド ライセンスとスタンドアロン ライセンスはどちらも、同じアカウント内の複数のグループによる使用を割り当てることができます。これにより、ライセンスにアクセスし、使用できるユーザーを正確にコントロールできます。マルチシートのオンデマンドライセンスの場合、1つ以上の定義済みグループにシートを割り当てることができます。これにより、ライセンスの地理範囲内で、EULAで定められた条件に従って、お客様が専用のサーバーを導入することなく、グローバルなフローティング ライセンスとして利用できます。

はい。目的のライセンスの管理ページをドリルダウンし、[Activate] ボタンをクリックしてください。

スタンドアロン ライセンスのライセンス認証では、対応するAltium NEXUSのバージョンのライセンス認証を行えますが、一度に認証できるのは1つのバージョンのみです。プライベートサーバー ライセンスのライセンス認証では、ライセンスを適用する全てのAltium NEXUSのバージョンに対して認証プロセスを繰り返す必要があります。


 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。