Altium NEXUS Documentation

Publishing to a PLM from Altium NEXUS

Created: September 23, 2019 | Updated: September 25, 2019
All Contents

Design data that has been released from Altium NEXUS to the NEXUS Server – via the Project Releaser – also needs to be available to the wider enterprise through data management processes such as PLM (Product Lifecycle Management).  The presence of up to date ECAD engineering data in a company PLM system provides the design production information necessary for managing procurement, component sources and supply chains at the enterprise level.

The combination of Altium’s NEXUS client and server offers a relatively simple way for users to propagate (or ‘publish’) released engineering files to PLM by harnessing the flexibility of NEXUS server Workflow Processes that can be accessed directly in the NEXUS design environment.

The configurable server Processes specify the user interface, process flow and error handling for the PLM publishing procedures, while the data connection to the PLM system is (currently) handled by editable XML files. Set up in the NEXUS Server, typically by an administrator, the Processes and PLM data connection files are configured to suit the company PLM instance and data management policies.

As a starting point, server PLM configuration files are available for popular systems such as PTC Windchill®, Arena® etc, and the server offers preloaded Processes for common PLM publishing tasks. The supplied sample Processes are effectively read-only templates that must be re-saved as an available named process.

► See PLM Integration in the NEXUS Server for more information on configuring PLM Process Workflows and PLM Instance connections.

The following PLM publishing Processes (when enabled in the NEXUS Sever) are available in the NEXUS design environment:

Each process, available as a re-saved name from the NEXUS client menus, initiates the matching publishing action in the NEXUS server. This pushes the appropriate release data to the specified PLM instance, and accepts return parameter data such as the identification numbers associated with items or objects created in PLM – PLM part numbers.

The below overviews of PLM Publishing processes in NEXUS interact with a Windchill PLM instance. Along with other PLM instance implementations, you can also set the server PLM integration to a Filesystem instance for testing purposes – this acts as a PLM emulator and generates items in a specified local/network folder.

Project Releaser with Publish

When enabled in the NEXUS server, the Project Releaser with Publish process adds a new final stage to the Project Releaser in the NEXUS design environment.

The additional Publish to PLM step is available to run when all stages of the project release have successfully completed, where it will push all released object data to the specified PLM instance. For an overview of this PLM publishing process, see the Publish to PLM section below.

► See Working with the Project Releaser for more information on releasing a design and where available, publishing the release data to PLM.

Project with Initialize in PLM

Where a company engineering workflow is fully integrated with PLM, it may be desirable to establish a design project’s release structure in PLM at the very beginning of the ECAD design cycle. This can be achieved in the NEXUS design environment by applying the server's Project with Initialize in PLM process to create a new Managed Project, which also creates a corresponding set of release framework entries in PLM.

In the example case shown here, the Process is named New Managed Project with PLM initialize. This was derived from the Project with Initialise in PLM template process in the NEXUS server.

To start the process, select Fie » New » Managed Project » New Managed Project with PLM initialize (or your equivalent process) from the main menu. Note that an additional New Managed Project menu option, which was derived from the server’s Project process, is available here for creating a standard Managed Project.

The New Managed Project with PLM initialize dialog (as named in this example) is defined in the matching server Process workflow and its user interface Form. Enter the new Managed Project name and type etc, and if necessary, edit the project storage paths under the dialog’s Advanced tab.

Use the following Login Credentials dialog to select the server PLM template that applies, and therefore the targeted PLM instance, along with your PLM sign in credentials. The credentials are saved with the Managed Project and will be not requested for subsequent PLM interactions with the project.

As the process proceeds, its steps and status may be monitored in the Tasklist panel (View » Panels » Tasklist). When all active tasks are completed, the final status of the process activity may be viewed by selecting the Show Closed option in the Activities listing. Select the refresh button () to update the entries.

A successful completion of the New Managed Project with PLM initialize process will have the following results:

  • A new Managed Project is created in the NEXUS sever and made available the NEXUS (client) design space.
  • The project release structure items, with associated PLM Part Numbers, are added to the PLM instance.
  • The part numbers generated by the PLM are ported back to NEXUS as PLM PartNumber parameters.

The items (generally shown as files) created within the PLM instance correspond to the NEXUS project release packages, as shown for a project release in the NEXUS Explorer panel (under the Details tab). The naming of the items, and their associated attributes, are defined by the PLM instance configuration in the NEXUS server – specifically, within the XML configuration file.

Note that the release entries in the PLM instance are normally accessed by the wider enterprise (procurement etc) and are generally not the domain of an ECAD design engineer. They are shown here in a typical format by way of example.

Within the PLM structure the included Project parent item defines the parent-child relationships in the release – here titled NEXUS Project – Managed Project 7, with an associated PLM Part number of 0000023627. The PLM project structure will be updated and added to when the NEXUS Managed Project has been developed and then released to the NEXUS server and PLM.

The PLM item part numbers generated by the PLM instance are transferred back to the NEXUS server during the PLM structure initialization process. They become available as Server Parameters in the Managed Project and can be applied as special text strings in a schematic document. Note that the names of the generated parameters and their Value number format are determined by the PLM installation itself.

Publish to PLM - User selects

The Publish to PLM (User selects) process allows you to choose specific revisions of released Managed Project data to be pushed to a PLM instance.

Where items already exist in the PLM for a given project, such as the initialized PLM structure for a project as outlined above (Project with Initialize in PLM), the items are updated and added to as required. Where released data for a Managed Project does not already exist in the PLM instance, the structure and data are added to PLM. In both cases, PLM part numbers will be assigned to any new PLM items and passed back to NEXUS as parameters.

In the example shown here, the Process is named Publish to PLM – select and was derived from the Publish to PLM (User Selects) template process in the NEXUS server.  Note that if the selected project has not been released to the NEXUS server no release packages will be available for propagation to PLM. To start the process from the design environment select Project » Project Activities » Publish to PLM – select (or your equivalent process) from the main menu.

The following Publishing to PLM – select dialog automatically selects the currently active NEXUS project for publishing to PLM, however the Project drop down menu and its type ahead filtering may be used to select any released project in the NEXUS server as an alternative.

The dialog's Request title field allows the process to be renamed for this publish to PLM task. The AUTO setting names the task as its process name – in this case, Publish to PLM - select. Click the dialog's  button to invoke the Publish to PLM process.

The following Select data to publish dialog allows you to choose a particular project revision release and then release packages from within that release.

Alternatively, select the dialog’s browse button () to open the Choose Design Review Dataset explorer dialog where specific sets of released data can be specified for publishing. Note that to see all revisions of the released data, the Show only latest option must be deselected in the dialog’s menu.

Through either of the above two methods a list of dataset revisions for publishing can be built up in the Select data to publish dialog.

Submitting that list () for publishing accesses the PLM instance, which will respond by requesting your PLM user credentials. Submit these to confirm and start the publish to PLM action.

The progress of the publishing process can be monitored in the Tasklist panel (View » Panels » Tasklist), where the named task and its status will be included in the panel’s Tasks list and as a closed activity when successfully completed. With the panel's Show closed option enabled, selecting a closed activity will open a corresponding information dialog that includes a task's related PLM publish details (Data tab) and a graphic representation of its process flow status (Diagram tab).

Under the dialog's Data tab, click the PLM Publish Completed Log file entry (*.log) to download a plain text file that reports the sequence of events in the activity workflow. 

Within the PLM instance itself (Windchill in this example) the item entries will be added to include the specified project release data. Note that the structure of the created Windchill entries and data will depend on its setup, and the configuration of the NEXUS PLM publishing template.

In this example, PLM items have been added for the specified revisions of the released Assembly and Fabrication files for Project 5, along with entries for the Managed Components used in the design. Note that component CAP01005 already existed in PLM from a previous publishing process.

Content and Structure

For all types of NEXUS to PLM data interaction, the PLM parent-child structure of the entries can be seen by selecting a file release item, or in NEXUS terms, a release package, which will show its constituent file collection.

The PLM publishing process will also include components used in the design, as shown above.

The configuration of the NEXUS server’s PLM publishing template will determine when/if component entries are created in PLM. With the template’s default configuration, component entries that already exist in PLM will be linked to, and those that are not in PLM will be created and linked to.

When a new component item has been created in PLM, its PLM part number is ported back to the matching Managed Component in the NEXUS server as a parameter. The below image shows a component’s parameters list before and after it has been published to PLM with a released design project.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: