CoDesign을 위한 SOLIDWORKS 설정
Parent page: Altium CoDesigner 설치 및 구성
Altium CoDesigner는 ECAD와 MCAD 설계 영역 간에 인쇄 회로 기판 설계를 전송하는 인터페이스입니다. MCAD 소프트웨어에 CoDesigner 애드인을 추가하면 CoDesigner를 통해 설계 변경 사항을 양방향으로 전달할 수 있습니다. 설계 변경 사항은 ECAD와 MCAD 영역 사이에서 가교 역할을 하는 Altium 워크스페이스를 통해 전달됩니다.
► 사용 중인 MCAD 소프트웨어와 CoDesigner 간의 버전 호환성을 확인하세요
SOLIDWORKS에서 CoDesigner 설치 및 구성
SOLIDWORKS®와 양방향으로 연동하려면 Altium CoDesigner for SOLIDWORKS 애드인을 설치해야 합니다.
MCAD 소프트웨어에서 CoDesigner에 액세스하려면 애드인을 설치하고 활성화하세요.
애드인을 설치하려면:
-
설치하기 전에 SOLIDWORKS를 종료합니다.
-
SOLIDWORKS 애드인(AltiumCoDesignerSolidWorks_<VersionNo>.exe)을 다운로드하여 설치합니다.
-
SOLIDWORKS를 실행하고 위에 표시된 것처럼 Add-Ins 대화 상자에서 애드인을 활성화합니다.
-
애드인을 활성화하면 일반적인 방법으로 작업 창 탭에 Altium CoDesigner 탭을 추가할 수 있습니다. 모든 협업 활동은 이 탭을 통해 수행됩니다.
CoDesigner 작업 창 탭 표시
SOLIDWORKS에서는 Customize Taskpane Tabs 대화 상자에서 작업 창 탭을 활성화하거나 비활성화할 수 있습니다.
CoDesigner는 SOLIDWORKS 작업 창 탭을 통해 액세스할 수 있습니다.
SOLIDWORKS에 Altium CoDesigner 작업 창 탭이 표시되지 않는 경우:
-
위에 표시된 것처럼 작업 창 상단의 Setup 톱니바퀴 아이콘을 클릭합니다. Customize Taskpane Tabs 대화 상자가 열립니다.
-
대화 상자에서 Altium CoDesigner 탭을 활성화합니다.
SOLIDWORKS에서 워크스페이스에 연결
SOLIDWORKS는 워크스페이스를 통해 Altium Designer와 협업하며, 처음 사용할 때는 해당 워크스페이스에 로그인해야 합니다.
로그인하지 않은 상태에서는 아래에 표시된 것처럼 Altium CoDesigner 탭에 로그인 필드가 표시됩니다. 로그인 모드는 두 가지로, 하나는 Altium 365 워크스페이스에 로그인하는 모드이고 다른 하나는 온프레미스 Enterprise Server의 워크스페이스에 로그인하는 모드입니다.
Altium 365 워크스페이스에 연결
-
Altium CoDesigner 작업 창 탭에서 Altium Account 옵션을 선택합니다.
-
Altium Live에 로그인할 때 사용하는 이메일 주소를 Email로 입력하고, Altium Live Password를 입력합니다.
-
Remember Me 옵션을 활성화하면 비밀번호를 포함한 로그인 정보가 저장되고, SOLIDWORKS를 시작할 때마다 Altium 365 워크스페이스에 자동으로 연결됩니다.
-
Sign In 버튼을 클릭하여 연결합니다.
Altium Enterprise Server 워크스페이스에 연결
온프레미스 Enterprise Server 워크스페이스에 로그인합니다.
-
Altium CoDesigner 작업 창 탭에서 Use Custom Server 옵션을 선택합니다.
-
처음 로그인할 때는 온프레미스 Enterprise Server 워크스페이스에 연결할 Server Address(URL)을 지정해야 합니다. 주소는 시스템 관리자가 제공합니다.
-
User Name 및 Password를 입력합니다. 이 정보도 시스템 관리자가 제공합니다.
-
Remember Me 옵션을 활성화하면 비밀번호를 포함한 로그인 정보가 저장되고, SOLIDWORKS를 시작할 때마다 워크스페이스에 자동으로 연결됩니다.
로그인하면 Altium CoDesigner를 통해 협업을 시작할 준비가 완료됩니다.
SOLIDWORKS 협업 설정 구성
로그인한 후에는 위에 표시된 것처럼 CoDesigner 메뉴의 Settings 메뉴 항목을 통해 여는 Altium CoDesigner Settings 대화 상자에서 CoDesigner 설정을 구성할 수 있습니다.
설정 대화 상자에서 CoDesigner 옵션을 구성합니다.
-
Common folder for storing models that are coming from ECAD - CoDesigner에서 생성한 모든 컴포넌트 모델은 소속 프로젝트에 관계없이 이 위치에 저장됩니다. 보드 파트와 보드 어셈블리는 Solidworks로 처음 가져올 때 지정한 프로젝트 폴더에 CoDesigner가 생성합니다. 위치를 지정하지 않으면 모든 컴포넌트 모델이 프로젝트 폴더에 생성되며 다른 프로젝트에서 재사용할 수 없습니다.
-
Build 3D geometry for Copper - 상단 및 하단 구리 레이어는 항상 보드 파트 표면의 데칼로 표현됩니다. 이 옵션을 활성화하면 CoDesigner가 모든 구리 레이어와 스루홀 Pad를 표현하는 돌출 피처도 생성합니다. 이 옵션을 활성화하면 대량의 데이터가 생성되어 성능에 큰 영향을 줄 수 있습니다.
-
Build Vias - 비아 배럴도 포함하려면 이 옵션을 활성화하세요. 이 옵션을 활성화하면 대량의 데이터가 생성되어 성능에 큰 영향을 줄 수 있습니다.
-
Flat Folder Structure - 이 옵션을 활성화하면 하위 파트 및 어셈블리 파일이 주 어셈블리 파일과 동일한 폴더에 저장됩니다. 옵션을 비활성화하면 모든 하위 파트 및 어셈블리 파일이
\<McadAssyName>-EDM하위 폴더에 저장됩니다. SOLIDWORKS에서 Windchill을 제품 데이터 관리 시스템으로 사용하는 경우 단일 계층 폴더 구조를 권장합니다. -
Smart Sketch Update - 이 옵션을 활성화하면 가져오기 중 MCAD CoDesigner가 ECAD에서 변경된 스케치 요소만 다시 그리며, 변경되지 않은 요소와 관련된 치수 및 제약 조건은 그대로 유지합니다. 원하지 않는 결과가 나타나면 이 옵션을 비활성화하세요. 자세한 내용은 스마트 스케치 변경 지원을 참조하세요.
-
Build Route Tool Path – Route Tool Path는 보드가 제작되는 Panel에서 보드를 밀링으로 분리하기 위해 정의된 Outline입니다. MCAD에서 이 경로가 필요하지 않으면 이 옵션을 비활성화하세요. 자세한 내용은 ECAD Route Tool Path를 참조하세요.
-
Transfer board sketch holes that are bigger than <Size><Units> to ECAD as cutouts - 보드 프로파일 스케치에 포함된 홀 중 ECAD에서 Pad로 해석할 수 있는 홀(원형, 사각형 또는 슬롯 홀 포함)은 홀 크기(또는 슬롯 너비)가 이 값 이하이면 ECAD에서 프리 Pad로 변환됩니다. 크기가 이 값보다 큰 홀은 보드 컷아웃으로 변환됩니다. 사각형이나 슬롯 형태에 해당하지 않는 비원형 홀은 크기에 관계없이 항상 보드 컷아웃으로 변환됩니다.
-
Ignore components smaller than
<Value><Units>in height - 작은 컴포넌트를 동기화 과정에서 제외할 수 있습니다. 가져오기를 수행할 때 높이가<Value><Units>미만인 컴포넌트를 제외하도록 이 옵션을 구성하세요. 컴포넌트 높이는 ECAD에서 컴포넌트(풋프린트)의 속성으로 정의되며, 풋프린트에 배치된 3D 모델의 높이를 의미하지 않습니다. 자세한 내용은 작은 컴포넌트를 무시하도록 CoDesigner 구성하기를 참조하세요. -
Participate in the product improvement program - MCAD CoDesigner 사용에 관한 기술 정보를 Altium과 자동으로 공유하려면 이 옵션을 활성화하세요. 자세한 내용은 제품 개선 프로그램을 참조하세요.
SOLIDWORKS에서 작업하기
이 섹션에서는 Altium MCAD CoDesigner로 작업할 때 중요한 SOLIDWORKS 전용 설정을 자세히 설명합니다.
SOLIDWORKS Default 템플릿
새 컴포넌트를 생성할 때마다 컴포넌트 템플릿을 선택하라는 메시지가 표시되지 않도록, 아래와 같이 파트에 대한 Default 템플릿을 구성하여 사용하는 것이 좋습니다. SOLIDWORKS에서 제공하는 템플릿이나 회사 자체 템플릿을 사용할 수 있습니다. 아래와 같이 Parts, Assemblies, Drawings의 템플릿 위치를 정의하고 Always use these default document templates을 선택하세요.
원하는 SOLIDWORKS 템플릿을 구성합니다.
SOLIDWORKS에서 PCB 구리, 마스크 및 실크스크린 표시
CoDesigner는 상단 구리, 상단 솔더 마스크 및 상단 실크스크린 이미지를 하나의 상단 데칼로 결합하고, 보드의 동일한 하단 레이어에도 이 과정을 반복합니다. 이러한 상단 및 하단 데칼은 보드를 MCAD로 가져올 때 적용됩니다.
상단 데칼은 상단 구리 레이어, 상단 솔더 마스크 레이어 및 상단 실크스크린 레이어를 결합한 것입니다.
데칼 관련 참고 사항:
-
데칼이 올바르게 표시되지 않으면 SOLIDWORKS의 렌더링 문제일 수 있습니다. 인증된 비디오 카드와 최신 비디오 드라이버 소프트웨어 업데이트에 대한 자세한 내용은 https://www.solidworks.com/support/system-requirements를 참조하세요. 이 페이지에는 인증된 카드 및 드라이버 페이지로 이동하는 링크가 포함되어 있으며, 여기에서 비디오 카드의 업데이트 패치를 다운로드할 수 있습니다.
-
이전 단계로 데칼 표시 문제가 해결되지 않으면 SOLIDWORKS System Options 대화 상자의 Performance 페이지에서 Enhanced graphics performance 옵션을 전환해 보세요. 일부 비디오 카드에서는 이 옵션을 비활성화하면 도움이 되고, 다른 비디오 카드에서는 활성화하면 도움이 됩니다.
-
CoDesigner 설정에서 Build 3D Geometry for Copper and Solder Mask 모드를 활성화하면 각 구리 레이어와 솔더 마스크 레이어가 개별 레이어로 전송되며, 하나의 데칼로 결합되지 않습니다. 이 모드에서는 실크스크린 세부 정보가 솔더 마스크 레이어에 데칼로 적용됩니다. 자세한 내용은 CoDesigner의 구리, 마스크 및 오버레이 레이어 처리 방식
SOLIDWORKS의 데칼 저장
PDM 시스템과 함께 SOLIDWORKS를 사용하는 설계자를 더 효과적으로 지원하기 위해 CoDesigner는 데칼(구리, 실크스크린 및 솔더 마스크 레이어를 나타내는 이미지 파일)을 보드 파트 파일에 직접 저장합니다. 이를 통해 MCAD 측에서 PDM 시스템을 사용할 때 PCB 관련 파일을 더 간편하게 관리할 수 있습니다.
데칼은 SOLIDWORKS prt 파일에 저장되므로 SOLIDWORKS와 PDM 시스템을 함께 사용하는 작업이 간소화됩니다.
여러 버전의 SOLIDWORKS로 작업하기
회사에서 여러 버전의 SOLIDWORKS를 사용한다면, 이전 버전의 SOLIDWORKS에서는 최신 버전에서 생성된 파일을 열 수 없다는 점을 알고 계실 것입니다. CoDesigner가 모델 저장용 공통 폴더를 사용하도록 설정되어 있다면 이로 인해 문제가 발생할 수 있습니다. 최신 버전의 SOLIDWORKS를 사용하는 엔지니어가 공유 모델을 덮어쓰면 이전 버전의 SOLIDWORKS를 사용하는 엔지니어는 해당 모델을 사용할 수 없게 될 수 있습니다.
CoDesigner는 공통 모델 폴더 경로를 Configuration(config) 파일에 저장합니다:
-
파일:
SolidworksAddin.config -
위치:
%localappdata%\Altium\Altium CoDesigner\Config\
이 파일은 SOLIDWORKS를 시작할 때 로드되고 SOLIDWORKS를 종료할 때 저장됩니다. 여러 버전의 SOLIDWORKS로 작업해야 하며 각 버전에서 서로 다른 공통 모델 폴더 위치를 사용하도록 Altium MCAD CoDesigner를 설정하려면, 실행할 각 SOLIDWORKS 버전에 대해 고유한 config 파일을 만들 수 있습니다.
이 Altium CoDesigner 설치본은 SOLIDWORKS 2023 및 SOLIDWORKS 2024에서 실행되도록 설정되어 있습니다.
설정 방법은 다음과 같습니다:
- 작업에 사용할 각 SOLIDWORKS 버전에 대해 config 파일의 복사본을 만듭니다.
-
각 config 파일 복사본의 파일 이름에 SOLIDWORKS 버전을 포함합니다. 예:
SolidworksAddin.2023.config. -
그런 다음 아래와 같이 config 파일에서
SolidWorksPartsLibraryFolderPath키의Value을(를) 편집하거나, SOLIDWORKS를 실행하고 Altium CoDesigner Settings 대화 상자에서 경로를 편집하여 각 SOLIDWORKS 버전에 필요한 고유한 모델 경로를 지정할 수 있습니다.
각 SOLIDWORKS 버전이 고유한 CoDesigner 모델 경로로 실행되도록 config 파일을 설정합니다.
CoDesign을 위한 SOLIDWORKS PDM 설정
SOLIDWORKS PDM Client
SOLIDWORKS PDM으로 작업할 때 함께 사용하면 유용한 도구는 SOLIDWORKS PDM Client입니다. 이 클라이언트는 PDM Vault(서버)에 대한 접근을 제공하여 PDM Vault의 내용을 찾아보고 탐색할 수 있게 해줍니다.
-
PDM 클라이언트는 SOLIDWORKS Installation Manager를 통해 설치됩니다.
-
Vault의 내용을 Windows 파일 탐색기에 표시하려면 Vault View도 필요합니다. PDM Client가 설치되면 Vault Viewer를 설치할 수 있습니다
PDM 설정
-
아래와 같이 SOLIDWORKS PDM 설정(SOLIDWORKS의 Tools 메뉴에서 접근 가능)에서 Prompt to check out file if opened in read-only mode 옵션을 비활성화합니다. 이렇게 하면 기존 컴포넌트를 체크아웃할 필요가 없어 다른 기계 엔지니어에게 불편을 주지 않습니다. 다만 컴포넌트 속성을 변경해야 할 때는 해당 컴포넌트를 체크아웃해야 합니다.
SOLIDWORKS Product Data Management(PDM)는 제품 개발 중 팀 관리와 협업을 지원하는 온프레미스 데이터 관리 솔루션입니다.
PDM 관리 대상으로 유지할 것을 권장하는 항목
- CoDesigner가 모델을 저장하는 공통 폴더. Altium CoDesigner Settings 대화 상자의 모델 저장용 공통 폴더 옵션에 지정된 폴더를 SOLIDWORKS PDM 관리 대상으로 설정하고, ECAD와 협업하기 전에 해당 폴더를 로컬 저장소와 동기화합니다.
-
MCAD CoDesigner 3.7 이하 버전에서는
\Orig및\Expt하위 폴더를 포함합니다. - MCAD CoDesigner 3.8 이상 버전에서 Windchill을 제품 데이터 관리 시스템으로 사용하는 경우, Altium CoDesigner Settings 대화 상자에서 Flat Folder Structure 옵션을 활성화하는 것이 좋습니다.
- PCB 프로젝트와 관련된 어셈블리 및 파트.
PDM 관리 대상으로 유지할 필요가 없는 항목
- PNG 파일은 데칼(구리, 실크스크린 및 솔더 마스크를 나타내는 이미지)을 생성하는 데 사용됩니다. 이 이미지 파일은 보드 파트가 저장된 폴더와 동일한 폴더에 저장됩니다.
다음 단계는?
이제 MCAD 소프트웨어에 CoDesigner가 설치되고 워크스페이스에 연결되었으므로, 다음 단계는 관련 워크스페이스 설정을 구성하는 것입니다.


)
)
).