Criar e gerir processos

O Altium Designer fornece um poderoso ambiente de projeto colaborativo. Parte disso é o suporte a Workflows, que orientam os projetistas de uma empresa por processos de projeto típicos do dia a dia, como:

  • Solicitação de novas peças de biblioteca do Workspace
  • Realização de revisões de projeto
  • Criação de novos projetos do Workspace.

Cada Workflow usado para implementar um determinado processo de projeto é criado como parte de uma Process Definition. Portanto, ele pode ser referido como o Workflow subjacente desse processo, ou simplesmente como uma Process Workflow.

Os processos, e seus Workflows, são criados e gerenciados por meio da interface do navegador do Workspace do Enterprise Server — por um Administrador desse Workspace.

Para as três áreas de projeto mencionadas anteriormente, workflows de processo predefinidos são incluídos com a instalação do seu servidor. Alguns deles são ativados para uso imediatamente. Use-os, modifique-os ou crie os seus próprios conforme necessário, para atender às necessidades da sua empresa. Outros são exemplos — estes não podem ser ativados e usados como estão. Portanto, cada um deles é mais como um “modelo” — edite conforme os requisitos e o nome da sua empresa, e salve como uma nova definição de processo, que você can então ativa e usa, junto com todas as outras definições.

Um poderoso Process Workflow Editor oferece a flexibilidade para você criar processos com workflows que podem ser tão simples ou tão complexos quanto necessário, e alinhados aos requisitos da sua empresa.

Acessando Processos

Todo o gerenciamento de processos é realizado na área Processes (Admin – Processes) da interface do navegador do Workspace do Enterprise Server.

Você deve estar conectado como um Administrador do seu Workspace do Enterprise Server para ver a área Processes da interface.

Acessando a área Processes da interface do navegador do Workspace do Enterprise Server — o centro de comando para trabalhar com processos e seus workflows associados.Acessando a área Processes da interface do navegador do Workspace do Enterprise Server — o centro de comando para trabalhar com processos e seus workflows associados.

A interface de Processes é apresentada nas quatro abas a seguir:

  • Browser – fornece uma listagem resumida de todos os processos (ativos ou fechados). Um “painel de processos” centralizado, por assim dizer.
  • Part Requests – fornece uma área dedicada para gerenciar os processos relacionados ao tema de solicitação de peças.
  • Project Activities – fornece uma área dedicada para gerenciar os processos relacionados ao tema de trabalho com projetos do Workspace, como revisões de projeto e publicação em um sistema PLM.
  • Project Creations – fornece uma área dedicada para gerenciar os processos relacionados ao tema de criação de novos projetos de projeto do Workspace.
As últimas três abas podem ser chamadas de Process Themes. Os Temas de Processo permitem que os vários processos sejam agrupados de forma intuitiva, por área de projeto. Eles também permitem que o software ofereça suporte à criação de novos processos, suportando apenas os elementos de workflow necessários para uma determinada área e, assim, simplificando a construção do workflow requerido. No futuro, essa abordagem fornece uma base para a Altium expandir a interface por meio da adição de novos temas, conforme necessário.

As seções a seguir examinam essas várias abas com mais detalhes.

Aba Browser

Use esta aba para navegar centralmente por todos os processos ativos ou fechados, em todos os temas de processo. Por padrão, a aba apresenta todos os processos Active (em execução). Altere para visualizar todos os processos Closed (por exemplo, concluídos, rejeitados ou encerrados) usando o campo suspenso acima da lista.

Navegue por todos os processos ativos em um local conveniente. Passe o cursor sobre a imagem para ver um exemplo de navegação por todos os processos fechados.
Navegue por todos os processos ativos em um local conveniente. Passe o cursor sobre a imagem para ver um exemplo de navegação por todos os processos fechados.

Para cada entrada, as seguintes informações são apresentadas (quando aplicável):

  • Status – o estado do processo. Pode ser um dos seguintes:
    • Active – o processo está ativo no momento, e seu workflow associado está em andamento.
    • On hold – o processo está ativo no momento, mas está aguardando entrada inicial, como atribuição de responsável, antes que seu workflow possa prosseguir.
    • Closed – o processo agora está fechado, por exemplo, foi concluído com sucesso ou rejeitado.
    • Terminated – o processo agora está fechado e foi encerrado diretamente por um Administrador do Workspace.
  • Process Name – o nome da definição do processo.
  • Title – este campo é usado para distinguir entre várias instâncias do mesmo processo. O título é o nome do processo, com um sufixo de instância (#1, #2 e assim por diante).
  • State – este é o estado atualmente alcançado no workflow associado ao processo.
  • Assignee (Somente processo ativo) – este é o usuário que agora tem uma tarefa a executar para mover o processo adiante a partir do seu estado atual no workflow.
  • Started By – o usuário que iniciou o processo.
  • Started At – a data e hora em que o processo foi iniciado.
  • Ended At (Somente processo fechado) – a data e hora em que o processo foi fechado.

Para um processo ativo, também há um controle Terminate (). Clique nele para forçar o encerramento de um processo. O processo será movido para a listagem Closed de processos.

Os processos podem ser classificados por qualquer coluna que possua o controle — clique no controle ou no nome da coluna. Também é possível realizar pesquisas usando o campo Search no topo da lista. Os dados em todos os campos, exceto Status, Started At, Ended At e Terminate, podem ser usados na pesquisa.
  • Você também pode importar de um arquivo uma definição de processo previamente exportada, diretamente da aba Browser . Para isso, clique no botão . Na caixa de diálogo Open exibida, navegue até o arquivo de Workflow necessário e abra-o (*.aaw). O tema de processo correto será detectado, e o conteúdo do arquivo será carregado no Process Workflow Editor. Para mais informações, consulte Importando/Exportando uma Definição de Processo.
  • Use o botão para exportar um relatório das atividades atualmente listadas (Process Workflows) como um arquivo *.csv detalhado delimitado por vírgulas — ver exemplo. Atividades Active ou Closed podem ser exportadas, e as entradas a serem incluídas podem ser filtradas usando o campo Search de nome do processo. No lado do projeto, o painel Explorer panel do Altium Designer inclui um botão equivalente — na aba Activites ao navegar por um projeto (usando a visualização padrão Project ) — para baixar os dados das atividades atualmente listadas relacionadas a esse projeto.

Clique em uma entrada de um processo para visualizar um diagrama do seu workflow subjacente (na aba Diagram abaixo da lista), mostrando o que precisa acontecer para que o processo seja concluído, e em que ponto do fluxo esse processo está, em termos de quem agora tem uma tarefa a realizar para fazer o processo avançar.

Clique no controle no canto inferior direito para destacar o ponto atual alcançado no workflow — a entrada do(s) usuário(s) piscará momentaneamente.

Visualizando o workflow subjacente de um processo selecionado na sua aba Diagram. Cada workflow é construído de forma diagramática, permitindo que você veja rapidamente em que ponto do workflow um processo se encontra e quem agora possui a próxima tarefa para continuar o progresso desse processo.Visualizando o workflow subjacente de um processo selecionado na sua aba Diagram. Cada workflow é construído de forma diagramática, permitindo que você veja rapidamente em que ponto do workflow um processo se encontra e quem agora possui a próxima tarefa para continuar o progresso desse processo.

As seguintes abas adicionais também estão disponíveis:

  • Data – mostra todos os dados pertinentes ao processo. Para um processo de revisão de projeto, por exemplo, isso pode incluir o projeto e seu conjunto de dados, o tipo de revisão, as pessoas envolvidas na revisão e quaisquer anexos adicionais. Para um processo de solicitação de peça, isso pode incluir fichas técnicas anexadas, dados paramétricos e quaisquer componentes preliminares.

    Entidades aplicáveis, como anexos, fichas técnicas, projeto e conjunto de dados do projeto (Item-Revision), aparecerão como hiperlinks para navegação rápida ou abertura. Você também tem a capacidade de configurar os dados paramétricos que ficam visíveis para o usuário padrão nesta aba. Ao editar o workflow de um processo, e sem nenhum elemento selecionado, os dados que podem ser apresentados na aba Data são listados no painel à direita. Clique no controle Edit para acessar seu formulário relacionado (<ProcessName> Data).
  • History – mostra um histórico das ações realizadas ao longo do workflow do processo.

    Use as abas Data e History para navegar, respectivamente, por mais detalhes do processo e pela trilha de sua atividade de workflow.Use as abas Data e History para navegar, respectivamente, por mais detalhes do processo e pela trilha de sua atividade de workflow.

Abas Part Requests/Project Activities/Project Creations

Use estas abas — que reúnem processos em temas específicos — para visualizar, criar e gerenciar workflows de processo que serão usados ao solicitar uma nova peça de biblioteca do Workspace, realizar revisões de projeto ou publicar em um sistema PLM, ou criar novos projetos de projeto, respectivamente.

Por padrão, a região superior de uma aba apresenta todas as versões Latest dos processos definidos dentro do tema. Altere para visualizar os processos definidos All (isto é, todas as versões) usando o campo suspenso acima da lista.

Exemplo de navegação pelas versões mais recentes dos processos definidos para um determinado tema (neste caso, o tema Project Activities).Exemplo de navegação pelas versões mais recentes dos processos definidos para um determinado tema (neste caso, o tema Project Activities).

Para cada entrada, as seguintes informações são apresentadas:

  • Process Name : version – o nome da definição do processo e sua versão. Para garantir que você esteja sempre visualizando/trabalhando com a versão mais recente, certifique-se de que o campo suspenso de versão acima da lista esteja definido como Latest.
  • Instances (active / all) – o número de instâncias desta versão da definição do processo que estão ativas no momento, juntamente com o número total de instâncias que foram iniciadas.
  • Created By – o usuário que criou esta versão da definição do processo.
  • Created At – a data e hora em que esta versão da definição do processo foi criada (salva e implantada).
  • Active – mostra se esta versão da definição do processo está ativa () e, portanto, pode ser usada, ou foi suspensa (), ou é uma definição de exemplo (modelo) () e, portanto, não pode ser usada. Somente definições de processo ativas aparecerão na área relevante da interface do Altium Designer, para uso pelos projetistas. Clique no ícone para alternar o estado ativo, quando aplicável.

    Somente a versão mais recente de uma definição de processo pode ser usada (tornada ativa e iniciada). Versões anteriores não podem ser usadas, mas podem ser modificadas para produzir uma versão posterior. Além disso, definições de processo de exemplo (cujo estado Active é identificado por ) não podem ser usadas imediatamente. Cada uma delas é mais como um “modelo” — edite conforme os requisitos e o nome da sua empresa, e salve como uma nova definição de processo, que você can então ativa e usa, junto com todas as outras definições.
  • Actions – clique no controle  para acessar um menu de ações da definição do processo:
    • Startcomo administrador, você pode iniciar uma nova instância desta versão da definição do processo selecionando este comando. Isso só está disponível desde que a definição do processo tenha sido ativada. Se o processo tiver sido suspenso, ou se for uma definição de exemplo (modelo), o comando ficará esmaecido e uma instância não poderá ser iniciada.
    • Edit – selecione para modificar o workflow subjacente da definição do processo. O diagrama de workflow desta versão da definição do processo será apresentado no Process Workflow Editor, como ponto de partida para o trabalho. Qualquer Administrador pode modificar qualquer definição de processo definida pelo usuário, independentemente de quem a tenha criado originalmente, e salvá-la e implantá-la como a próxima versão. Para definições de processo padrão fornecidas pela Altium, você pode criar uma nova definição de processo com base na edição de uma delas (essencialmente fazendo um fork), mas não pode modificar o padrão em si. Para mais informações sobre edição de uma definição de processo, consulte Editando uma Definição de Processo Existente.
    • Assign – selecione para abrir a janela Assign Access to This Workflow, de onde você pode definir quais usuários e/ou grupos podem acessar o workflow subjacente. Para mais informações sobre gerenciamento de acesso a um workflow, consulte Gerenciando o Acesso ao Workflow do Processo.
    • Remove – selecione para remover (excluir) esta versão da definição do processo. Observe que algumas das definições de processo padrão fornecidas pela Altium não podem ser removidas (e, portanto, não possuem esse controle). Se pelo menos uma instância da definição do processo tiver sido iniciada, independentemente de ainda estar ativa ou não, a definição não poderá ser removida (o comando não será listado no menu).
As definições de processo podem ser classificadas por qualquer coluna que possua o controle — clique no controle ou no nome da coluna. Também é possível realizar pesquisas usando o campo Search no topo da lista. Os dados nas colunas Process Name : version e Created By podem ser usados na pesquisa.

Clique em uma entrada de uma definição de processo para visualizar seu workflow diagramático na aba Diagram abaixo da lista. Se houver uma instância atualmente ativa de um processo, a visualização mostrará em que ponto esse processo está no fluxo, em termos de quem agora tem uma tarefa a realizar para movê-lo adiante.

Se várias instâncias de um processo estiverem ativas, a visualização Diagram mostrará um estado combinado. Clique no controle no canto inferior direito para destacar o ponto atual alcançado no workflow — a entrada do(s) usuário(s) piscará momentaneamente.

Visualizando o workflow subjacente de um processo selecionado na sua aba Diagram.Visualizando o workflow subjacente de um processo selecionado na sua aba Diagram.

Definições de Processo Padrão

Uma série de definições de processo é fornecida pela Altium — nos três temas de processo — como parte da instalação do Enterprise Server. Algumas delas são ativadas para uso imediatamente e podem ser usadas como estão, enquanto outras são exemplos — não podem ser ativadas e usadas diretamente. Todas podem ser usadas como ponto de partida para criar suas próprias definições de processo conforme necessário. Use as seções recolhíveis a seguir para acessar informações sobre as definições de processo fornecidas.

A instalação do Enterprise Server também inclui o processo LibSync, que sincroniza dados de componentes entre o Enterprise Server e uma instância de PLM de destino. Este é um workflow de processo “interno” e somente leitura e, portanto, não pode ser editado nem incluído na lista de processos na página Processes do Workspace (Admin » Processes). Consulte Sincronização de Componentes PLM para mais informações.

Adicionando uma Nova Definição de Processo

Related page: Definindo um Workflow de Processo

Novos processos podem ser criados usando o Process Workflow Editor dedicado. Para acessar o editor, ative a aba do tema em que deseja criar seu novo processo e, em seguida, clique no botão no canto superior direito da página.

É importante ativar primeiro o tema, para que o processo seja criado com o Type correto.

Acessando o Process Workflow Editor. Garantir que o tema de processo desejado esteja ativo antes do acesso assegurará que a nova definição de processo seja configurada para o tipo de tema correto.Acessando o Process Workflow Editor. Garantir que o tema de processo desejado esteja ativo antes do acesso assegurará que a nova definição de processo seja configurada para o tipo de tema correto.

Dê à sua nova definição de processo um nome significativo, depois construa o workflow graficamente e defina os aspectos necessários de cada elemento nesse fluxo. Para tarefas de usuário, é usado um User Form Editor para compor o formulário necessário que será apresentado ao usuário, para receber sua entrada quando ele receber uma tarefa no ponto relevante do workflow.

O poderoso Process Workflow Editor oferece a flexibilidade para você criar processos com workflows que podem ser tão simples ou tão complexos quanto necessário, e alinhados aos requisitos da sua empresa.O poderoso Process Workflow Editor oferece a flexibilidade para você criar processos com workflows que podem ser tão simples ou tão complexos quanto necessário, e alinhados aos requisitos da sua empresa.

Depois que um processo tiver sido definido conforme necessário, clique no botão para adicioná-lo à lista de processos disponíveis para aquele tema de processo. A nova definição de processo será ativada e ficará pronta para uso.

O Editor sinalizará quaisquer problemas em seu diagrama de workflow que estejam impedindo que ele seja salvo e implantado — por exemplo, um diagrama deve ter um evento Start e pelo menos um evento End definido. E uma Tarefa de Usuário deve ter pelo menos um campo de formulário e um Responsável.

Editando uma Definição de Processo Existente

Qualquer Administrador pode modificar qualquer definição de processo definida pelo usuário, independentemente de quem a tenha criado originalmente, e salvá-la e implantá-la como a próxima versão. Para isso, clique no  controle na coluna Actions da definição de processo que você deseja modificar e selecione Edit no menu exibido. O diagrama de fluxo de trabalho desta versão da definição de processo será apresentado no Process Workflow Editor, como ponto de partida para o trabalho.

Para definições de processo fornecidas pela Altium, é possível criar uma nova definição de processo com base na edição de uma delas (essencialmente, um fork), mas não é possível modificar o padrão em si.

Exemplo de edição de uma definição de processo existente – acessando o Process Workflow Editor, com o qual realizar as alterações necessárias.Exemplo de edição de uma definição de processo existente – acessando o Process Workflow Editor, com o qual realizar as alterações necessárias.

Faça as alterações necessárias no fluxo de trabalho diagramático do processo, incluindo quaisquer alterações nos formulários associados às tarefas do usuário, e então clique no botão para salvar efetivamente a definição como a próxima versão. No exemplo aqui, a definição de processo original Company Pre-release Review : 1 (versão 1) é modificada e salva para se tornar Company Pre-release Review : 2 (versão 2).

Com as modificações feitas, salve e implante como a próxima versão dessa definição de processo.Com as modificações feitas, salve e implante como a próxima versão dessa definição de processo.

Usando o campo suspenso no canto superior esquerdo e definindo a entrada como All, você pode ver todas as versões das definições de processo existentes. Na imagem abaixo, você pode ver ambas as versões da definição de processo Company Pre-release Review.

Mostrando todas as versões da definição de processo de exemplo Company Pre-release Review. Observe que somente a versão mais recente (versão 2) pode ser ativada e usada.Mostrando todas as versões da definição de processo de exemplo Company Pre-release Review. Observe que somente a versão mais recente (versão 2) pode ser ativada e usada.

Apenas a versão mais recente de uma definição de processo pode ser usada (tornada ativa e iniciada). Versões anteriores podem, no entanto, ser usadas como ponto de partida para criar uma versão posterior. Se você excluir a versão mais recente de uma definição de processo, a versão anterior seguinte se tornará efetivamente a mais recente e poderá novamente ser ativada e usada (instâncias iniciadas).

Importando/Exportando uma Definição de Processo

Definições de processo podem ser exportadas e importadas, permitindo que você as reutilize rapidamente entre instâncias do Enterprise Server – uma verdadeira economia de tempo quando o fluxo de trabalho subjacente de um processo pode ser particularmente complexo, e ter de "reinventar a roda", por assim dizer, seria uma tarefa desanimadora.

Para importar:

  1. Acesse a guia de tema (Part Requests, Project Activities, Project Creations) correspondente à definição de processo que você deseja importar.

    Se você tentar importar uma definição de processo para o tema errado, o software o alertará sobre isso e a importação será impedida.
  2. Clique no botão para criar uma nova definição de processo e acessar o Process Workflow Editor.
  3. Clique no botão . Na caixa de diálogo Open exibida, navegue até o arquivo de Workflow necessário (*.aaw) e abra-o. O conteúdo do arquivo substituirá completamente tudo o que estiver atualmente definido para a definição de processo (Nome, diagrama etc.).
Você também pode importar uma definição de processo previamente exportada de um arquivo, diretamente da guia Browser da interface. Para fazer isso, clique no botão . Na caixa de diálogo Open exibida, navegue até o arquivo de Workflow necessário (*.aaw) e abra-o. O tema de processo correto será detectado, e o conteúdo do arquivo será carregado no Process Workflow Editor.

Para exportar:

  1. Clique no controle  na coluna Actions da versão necessária da definição de processo que deseja exportar e selecione Edit no menu exibido para acessar o modo de edição.
  2. No Process Workflow Editor, clique no botão . A definição de processo será exportada como um arquivo de Workflow (<ProcessDefinitionName>.aaw) para a pasta padrão de downloads definida no seu navegador.
  3. Clique na entrada Processes na árvore de navegação à esquerda da interface do navegador do Workspace para sair do Process Workflow Editor sem fazer nenhuma alteração na definição de processo.

Gerenciando o Acesso ao Fluxo de Trabalho do Processo

Como administrador, você pode definir quais usuários e/ou grupos podem acessar um fluxo de trabalho de processo. Para fazer isso, clique no controle  na coluna Actions da definição de processo para a qual deseja configurar o acesso ao fluxo de trabalho subjacente e selecione Assign no menu exibido. A janela Assign Access to This Workflow será aberta.

Comece a digitar o nome completo ou o nome de usuário de um usuário, ou o nome de um grupo, no campo de texto para exibir uma lista de usuários/grupos correspondentes. Vários usuários/grupos podem ser adicionados. Para remover o acesso de um usuário/grupo adicionado ao fluxo de trabalho, clique no X de exclusão, à extrema direita do nome.

Com os usuários/grupos definidos conforme necessário, clique em para efetivar a atribuição do fluxo de trabalho. O fluxo de trabalho ficará então disponível somente para os usuários/grupos adicionados (e membros do grupo Administrators) quando acessado conforme descrito na seção Designer Access to Process Workflows abaixo.

Conforme indicado na janela Assign Access to This Workflow, se nenhum usuário/grupo for adicionado, o fluxo de trabalho ficará disponível para todos os usuários.

Acesso do Designer aos Fluxos de Trabalho de Processo

Related pages: Performing Design Reviews, Publishing to a PLM, Process-based Part Requests

Depois que o conjunto necessário de definições de processo para cada tema de processo disponível for criado conforme necessário para sua empresa, as definições ativadas estarão disponíveis para uso pelos assigned users assim que estiverem conectados ao Workspace do Enterprise Server. As seções a seguir mostram onde um designer pode acessar e iniciar esses processos ativos – tanto pelo Altium Designer quanto pela interface do navegador do Workspace.

Os administradores do Workspace podem, como mencionado anteriormente, iniciar uma nova instância de qualquer definição de processo ativada – diretamente da guia de tema de processo correspondente dentro da área Processes da interface do navegador do Workspace – clicando no controle  na coluna Actions e selecionando Start no menu exibido.

Solicitações de Peças

Related page: Solicitações de Peças Baseadas em Processo

Dentro do Altium Designer, definições de processo ativadas que fazem parte do tema Part Requests podem ser acessadas nos seguintes locais:

  • No painel Components. Clique com o botão direito na área principal do painel – as definições de processo ativas de solicitação de peças estão disponíveis no submenu Operations » Submit Request. Como alternativa, clique no link Submit request na seção Need more components?.

Se não houver definições de processo ativas disponíveis para o tema de processo Part Requests, o submenu Submit Request não será apresentado. Talvez seja necessário sair do Workspace e entrar novamente, ou reiniciar o Altium Designer, para atualizar.
  • No painel Manufacturer Part Search. Se o item de pesquisa atualmente selecionado tiver o ícone , o painel Information (acessado clicando em ) apresentará o botão . Clique na parte de lista suspensa do botão para acessar um menu com as definições de processo ativas de solicitação de peças. Clicar diretamente na parte principal do botão iniciará a primeira definição de processo da lista.
Solicitar uma peça pelo painel Manufacturer Part Search oferece o benefício adicional de preencher automaticamente informações importantes para você, incluindo todas as folhas de dados e informações paramétricas.

Se não houver definições de processo ativas disponíveis para o tema de processo Part Requests, o botão não será apresentado. Talvez seja necessário sair do Workspace e entrar novamente, ou reiniciar o Altium Designer, para atualizar.

Se o item de pesquisa atualmente selecionado tiver um ícone , as definições de processo ativas de solicitação de peças estarão disponíveis no menu associado ao botão (clique na parte suspensa do botão).

As definições de processo ativas de solicitação de peças também podem ser acessadas pelo menu de clique com o botão direito na área principal do painel, no submenu Submit Request.

Se não houver definições de processo ativas disponíveis para o tema de processo Part Requests, o submenu Submit Request não será apresentado. Talvez seja necessário sair do Workspace e entrar novamente, ou reiniciar o Altium Designer, para atualizar.
  • No painel Explorer, na pasta Part requests ou após realizar uma pesquisa. O botão estará disponível e, quando pressionado, apresentará as definições de processo ativas de solicitação de peças disponíveis para escolha.

Observe que, se o recurso Legacy Part Requests feature tiver sido habilitado, o botão aparecerá como . Uma entrada adicional relacionada a novas solicitações de peças usando essa funcionalidade legada também aparecerá no menu. Ela terá o sufixo (Legacy). Se não houver definições de processo ativas disponíveis para o tema de processo Part Requests, e o recurso Legacy Part Requests não estiver habilitado, o botão Submit Request não será exibido. Talvez seja necessário sair do Workspace e entrar novamente, ou reiniciar o Altium Designer, para atualizar.

Na interface do navegador do Workspace, definições de processo ativadas que fazem parte do tema Part Requests podem ser acessadas na página Part Requests, clicando no botão no canto superior direito da página.

Acessando definições ativadas de Part Requests na página Part Requests da interface do navegador do Workspace.Acessando definições ativadas de Part Requests na página Part Requests da interface do navegador do Workspace.

Se não houver definições de processo ativas disponíveis para o tema de processo Part Requests, o botão ficará indisponível. Se existir apenas uma definição de processo, o botão não aparecerá com funcionalidade de lista suspensa e iniciará esse processo imediatamente ao ser clicado.

Atividades de Projeto

Related pages: Performing Design Reviews, Publishing to a PLM, PLM Integration.

Definições de processo ativadas que fazem parte do tema Project Activities podem ser acessadas em vários locais.

Revisão de Projeto e Publicação PLM Padrão

No Altium Designer, definições de processo ativadas de revisão de projeto e publicação – que fazem parte do tema Project Activities – podem ser acessadas no submenu de contexto Project Activities, acessado clicando com o botão direito na entrada do projeto de design no painel Projects, ou no menu principal Project » Project Activities.

Se não houver definições de processo ativas de revisão de projeto e publicação PLM padrão disponíveis para o tema de processo Project Activities, os menus não ficarão visíveis.

Na interface do navegador do Workspace, definições de processo ativadas de revisão de projeto e publicação – que fazem parte do tema Project Activities – podem ser acessadas na página Projects da interface. Selecione o projeto necessário e clique no botão .

Acessando definições ativadas de Project Activities (revisão de projeto e publicação PLM padrão) para um projeto do Workspace, na área Projects da interface do navegador do Workspace.Acessando definições ativadas de Project Activities (revisão de projeto e publicação PLM padrão) para um projeto do Workspace, na área Projects da interface do navegador do Workspace.

Se não houver definições de processo ativas de revisão de projeto e publicação PLM padrão disponíveis para o tema de processo Project Activities, o botão não será exibido.

Publicação em PLM por meio do Project Releaser

No Altium Designer, o processo de publicação em uma instância de PLM como parte do Project Releaser pode ser acessado no submenu Project » Project Releaser do projeto ativo, ou clicando com o botão direito na entrada do projeto de design no painel Projects e escolhendo o processo na entrada do menu de contexto Project Releaser.

Criações de Projeto

No Altium Designer, definições de processo ativadas que fazem parte do tema Project Creations podem ser acessadas em três locais:

  • No submenu principal File » New » Project in <WorkspaceName>.

  • No submenu de contexto Convert to Managed Project, acessado clicando com o botão direito na entrada de um projeto local no painel Projects.

  • No submenu de contexto Clone, acessado clicando com o botão direito na entrada de um projeto na caixa de diálogo Open Project dialog quando a localização do Workspace estiver selecionada.

Observe que, quando pelo menos uma definição de processo para o tema de processo Project Creations está ativa, a capacidade de criar um novo projeto de Workspace por meio da caixa de diálogo Create Project dialog (File » New » Project) é desabilitada – o Workspace conectado não fica disponível como local de destino. Regular projetos (locais) e do tipo VCS podem ser criados normalmente por meio dessa caixa de diálogo.

Se não houver definições de processo ativas disponíveis para o tema de processo Project Creations – que é o caso padrão para uma instalação nova do Enterprise Server – os menus de processo não ficarão visíveis, e você poderá criar um projeto de Workspace por meio da caixa de diálogo Create Project normalmente.

Observe também que, nessa configuração padrão, o comando Convert to Managed Project muda para Make Project Available on Server.

Na interface do navegador do Workspace, definições de processo ativadas que fazem parte do tema Project Creations podem ser acessadas nos seguintes locais:

  • Na página principal Projects da interface, clicando no botão .

Acessando definições ativadas de Project Creations na área principal Projects da interface do navegador do Workspace.Acessando definições ativadas de Project Creations na área principal Projects da interface do navegador do Workspace.

  • Na página Projects da interface, quando se deseja clonar um projeto específico. Selecione o projeto necessário e clique no botão para acessar os processos no menu.

Acessando definições ativadas de Project Creations ao querer clonar um projeto do Workspace, na área Projects da interface do navegador do Workspace.Acessando definições ativadas de Project Creations ao querer clonar um projeto do Workspace, na área Projects da interface do navegador do Workspace.

  • Se não houver definições de processo ativas disponíveis para o tema de processo Project Creations – que é o caso padrão para uma instalação nova do Enterprise Server – o menu oferecerá a funcionalidade básica de clonagem de projeto (Clone). Isso não está relacionado à funcionalidade de fluxo de trabalho do processo.
  • Para usar o Constraint Manager no gerenciamento das restrições de projeto do seu projeto PCB do Workspace baseado em processo, certifique-se de atribuir um template de projeto apropriado ao criar esse projeto. Esse deve ser um template salvo a partir de um projeto PCB que foi criado com a opção Constraint Management habilitada na caixa de diálogo Create Project dialog.
AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Conteúdo