Altium Designer Documentation

Средства преобразования библиотек на основе баз данных_AD

Последнее изменение: Pavel Demidov; 08.07.2021

Главная страница: Работа с библиотеками на основе баз данных

Программное обеспечение Altium для проектирования предлагает возможность размещения компонентов непосредственно из базы данных предприятия с помощью создания и использования библиотеки на основе базы данных. Тип используемой библиотеки на основе базы данных зависит от того, каким образом вы хотите управлять исходными библиотеками символов и моделей. Если эти библиотеки хранятся на жестком диске или в каком-либо сетевом расположении, вы можете использовать библиотеку типа Database Library (DbLib). С другой стороны, если вы хотите размещать библиотеки под управлением системы контроля версий – с помощью репозитория Subversion – вам могут понадобиться библиотеки типа SVN Database Library (SVNDbLib).

Независимо от типа используемой библиотеки на основе базы данных, в основе их лежит один и тот же принцип – возможность размещения компонентов непосредственно из подключенной внешней базы данных. Чтобы сделать эту возможность максимально доступной, предоставляются средства, которые позволяют быстро преобразовать существующие библиотеки в структуру библиотеки на основе базы данных. С помощью этих средств вы можете преобразовать:

  • Интегрированную библиотеку в библиотеку на основе базы данных (DbLib или SVNDbLib).
  • Библиотеку на основе базы данных (DbLib или SVNDbLib) в интегрированную библиотеку.
  • Исходные библиотеки схемных символов / посадочных мест в библиотеку на основе базы данных в системе контроля версий.
  • Библиотеку на основе базы данных в библиотеку на основе базы данных в системе контроля версий.
  • Систему OrCAD Component Information System (CIS) в библиотеку на основе базы данных (DbLib).

Следующие разделы этого документа содержат более подробную информацию по выполнению этих преобразований в системе.

Создание библиотеки на основе базы данных из интегрированной библиотеки

Интегрированные библиотеки безопасны по своей сути. Кроме того, они идеально подходят для использования в проектах, которые передаются за пределы предприятия, благодаря своей переносимости. Если проект хранится только внутри предприятия и/или вы хотите, чтобы компоненты Altium были тесно связаны с базой данных предприятия, то библиотеки на основе баз данных будут лучшим выбором. Система предоставляет возможность быстрого преобразования интегрированных библиотек в структуру Database Library (DbLib) или SVN Database Library (SVNDbLib). В процесс преобразования может быть включено множество интегрированных библиотек, при этом каждая из них будет добавлена в виде отдельной таблицы в целевую базу данных.

Преобразование в DbLib

Создание стандартной библиотеки на основе базы данных (DbLib) из интегрированной библиотеки (IntLib) осуществляется с помощью мастера Integrated Library to Database Library Translator. Мастер, по сути, декомпилирует указанные интегрированные библиотеки для создания отдельных таблиц в целевой базе данных, с заполнением информацией о параметрах и моделях, извлеченной из каждого компонента в этих библиотеках. Указанный файл библиотеки на основе базы данных затем используется для подключения к этой базе данных.

Мастер также можно использовать для импорта/добавления дополнительных компонентов в существующую базу данных, подключенной с помощью файла DbLib.
Преобразование поддерживает только использование баз данных типа Access.

Преобразование одной или множества исходных интегрированных библиотек в структуру базы данных – простой благодаря мастеру Integrated Library to Database Library Translator процесс.

Процесс включает в себя следующие этапы:

  1. Создайте новый или откройте существующий файл библиотеки на основе базы данных (*.DbLib). Обычно при преобразовании одной или множества интегрированных библиотек в существующую базы данных Access используется существующий файл DbLib, который подключен к этой базе данных.
  2. Когда файл Database Library (*.DbLib) открыт в качестве активного документа, выберите команду Tools » Import from Integrated Libraries главного меню, чтобы открыть мастер Integrated Library to Database Library Translator Wizard.
  3. Используйте начальную страницу мастера, чтобы указать целевую базу данных – новую или существующую базу данных Access. При создании новой базы данных щелкните по символу папки справа от поля Database Location, чтобы открыть стандартное диалоговое окно открытия Open . Используйте это диалоговое окно, чтобы определить, где и под каким именем будет создана новая база данных. Выбранное название/путь будут введены в поле Database Location.
Если мастер был открыть из существующего файла DbLib, параметр Existing Access Database будет выбран по умолчанию, а поле Database Location будет предварительно заполнено базой данных, к которой подключен этот файл DbLib.
  1. Используйте следующую страницу мастера, чтобы указать целевой файл библиотеки на основе базы данных. Укажите путь и имя нового файла DbLib, который будет создан, либо найдите и откройте существующий файл. По умолчанию это поле предварительно заполнено активным файлом DbLib.
Если вы используете существующий файл DbLib и изменяете целевую базу данных, то после завершения работы мастера файл DbLib будет подключен к новой целевой базе данных.
  1. Используйте следующую страницу мастера, чтобы указать интегрированные библиотеки, которые вы хотите преобразовать. Используйте кнопку Add, чтобы открыть диалоговое окно Select Source Integrated Libraries, из которого вы можете найти и выбрать нужные библиотеки. Входящие в них библиотеки схемных символов и моделей (если они существуют) будут извлечены и сохранены в расположения, указанные в поле Destination Folder.
По умолчанию поле Destination Folder будет указывать на подпапку Libraries, вложенную в папку, в которой находится файл DbLib (указанный на предыдущей странице мастера).
  1. После выбора исходных интегрированных библиотек нажмите Next, чтобы начать процесс преобразования. Будет отображен индикатор выполнения, а также информация о преобразуемой в данный момент библиотеке. По завершении преобразования нажмите Finish на последней странице мастера, чтобы сделать указанный файл DbLib активным в рабочем окне (если он еще не является таковым).
Для каждой интегрированной библиотеки, включенной в процесс преобразования, будет создана отдельная таблица в базе данных, названная в соответствии с интегрированной библиотекой. Для существующей базы данных, если таблица с тем же именем, что и у интегрированной библиотеки, уже существует, информация из этой библиотеки будет добавлена в существующую таблицу.

Полученный в результате процесса преобразования файл DbLib.

Когда процесс преобразования завершен, вы можете перейти в исходные библиотеки схемных символов и удалить всю информацию о параметрах и моделях из символов. Затем проведите необходимую тонкую настройку отображения полей в документе DbLib для ссылок на подходящие столбцы базы данных. Для получения более подробной информации обратитесь к разделу Отображение полей базы данных в проектные параметры страницы Работа с библиотеками на основе баз данных.

Мастер извлечет только информацию о моделях посадочных мест с точки зрения ссылки модели и пути к заданным моделям. Информацию о ссылках на имитационные модели будет необходимо ввести во внешнюю базу данных вручную.
Убедитесь, что компоненты схемных библиотек в IntLib не включают в себя параметр Part Number. Информация о номере компонента, введенная в базу данных для определения отдельных записей компонентов, берется из поля Design Item ID компонентов схемы, которое находится в разделе Properties вкладки General панели Properties при просмотре свойств активного компонента. Ввод в качестве параметра приведет к ошибке преобразования из-за дублирующегося значения.

Преобразование в SVNDbLib

Создание библиотеки на основе базы данных в системе контроля версий (SVNDbLib) из интегрированной библиотеки (IntLib) осуществляется с помощью мастера SVN Database Library Conversion. Мастер, по сути, декомпилирует указанные интегрированные библиотеки для создания отдельных таблиц в целевой базе данных, с заполнением информацией о параметрах и моделях, извлеченной из каждого компонента в этих библиотеках. Затем создается указанный файл библиотеки на основе базы данных в системе контроля версий, который используется для подключения к этой базе данных. Составные библиотеки схемных символов и посадочных мест разделяются и фиксируются в указанных директориях заданного репозитория SVN в системе контроля версий, на который ссылается файл SVNDbLib.

Преобразование поддерживает только использование баз данных типа Access.

Преобразование одной или множества исходных интегрированных библиотек в структуру библиотеки на основе базы данных в системе контроля версий – простой благодаря мастеру SVN Database Library Conversion процесс.

Процесс включает в себя следующие этапы:

  1. Откройте мастер SVN Database Library Conversion. Главные методы следующие:
  • Выберите команду Tools » SVN Database Library Maker из главного меню редактора библиотек схемных символов, редактора библиотек посадочных мест или редактора библиотек на основе баз данных.
  • В панели Projects, щелкните ПКМ по библиотеке проекта (SchLib, PcbLib или IntLib) и выберите команду SVN Database Library Maker из контекстного меню.
  1. Используйте страницу Libraries to Convert, чтобы указать интегрированные библиотеки, которые вы хотите преобразовать. Список может изначально содержать в себе одну или множество библиотек (активная библиотека или все библиотеки проекта, которые были добавлены в этот проект – зависит от того, какой метод открытия мастера вы использовали). Удалите их из списка перед тем, как выбирать интегрированные библиотеки, которые вы хотите преобразовать. Используйте кнопку Add, чтобы открыть диалоговое окно Library Files, из которого вы можете найти и выбрать нужные интегрированные библиотеки.
  2. Используйте страницу Options, чтобы определить параметры преобразования, в том числе как будут разделены исходные библиотеки, в каких директориях какого репозитория они должны быть сохранены и выходную директорию для файла SVNDbLib. Для библиотеки схемных символов доступно два параметра, которые позволяют удалить информацию о параметрах и/или моделях из каждого компонента и оставить только "оболочку" символа.
Репозиторий SVN и его структура папок должны быть определены заранее. Вы просто указываете его и папки внутри его структуры, в которые будут сохранены файлы разделенных библиотек. Репозиторий и папки не создаются на лету.
  1. После выбора исходных интегрированных библиотек и настройки необходимых параметров преобразования нажмите Next, чтобы начать процесс преобразования. Будет отображен индикатор выполнения, а также информация о преобразуемой в данный момент библиотеке. Процесс преобразования включает в себя:
    1. Извлечение исходных библиотек из предоставленных интегрированных библиотек.
    2. Разделение библиотек схемных символов и посадочных мест на файлы библиотек с отдельными символами/посадочными местами.
    3. Фиксация разделенных библиотек символов и посадочных мест в репозитории в указанных базовых директориях.
    4. Мастер извлечет только информацию о моделях посадочных мест. Подключенные имитационные модели поддерживаются библиотеками на основе баз данных в системе контроля версий (SVNDbLib), но хранение файлов имитационных моделей в репозитории Subversion не поддерживается. Если такие ссылки присутствуют, они будут добавлены как параметры.
    5. Создание отдельной таблицы базы данных в формируемой базе данных Access (которая будет названа также, как указанное для файла SVNDbLib имя) для каждой преобразуемой интегрированной библиотеки, с заполнением информации о параметрах и моделях, извлеченной из каждого компонента в этих библиотеках. Название каждой таблицы соответствует названию интегрированной библиотеки с суффиксом _IntLib (например, Capacitor - Ceramic_IntLib).
    6. Создание указанного файла SVNDbLib, подключение к базе данных и репозиторию.
  2. По завершении преобразования нажмите Finish, чтобы закрыть мастер и сделать файл SVNDbLib активным документом.

Полученный в результате процесса преобразования файл SVNDbLib.

Убедитесь, что компоненты схемных библиотек в IntLib не включают в себя параметр Part Number. Информация о номере компонента, введенная в базу данных для определения отдельных записей компонентов, берется из поля Design Item ID компонентов, которое находится в разделе Properties вкладки General панели Properties при просмотре свойств активного компонента. Ввод в качестве параметра приведет к ошибке преобразования из-за дублирующегося значения.

Создание интегрированной библиотеки из библиотеки на основе базы данных

Библиотеки на основе баз данных идеально подходят в тех случаях, когда вы хотите, чтобы компоненты Altium Design были тесно связаны с базой данных предприятия. Если необходимо передать проект за пределы предприятия либо если вы хотите, чтобы проектировщики работали с безопасными интегрированными библиотеками, этого можно добиться. Система предоставляет возможность скомпилировать интегрированную библиотеку непосредственно из библиотеки на основе базы данных – либо из стандартной библиотеки на основе базы данных (DbLib), либо из библиотеки на основе базы данных в системе контроля версий (SVNDbLib). Таким образом, библиотекари могут продолжать использовать библиотеки на основе баз данных, а проектировщики – использовать периодически повторно формируемые интегрированные библиотеки, работая как бы автономно.

Преобразование осуществляется с помощью мастера Offline Integrated Library Maker. Процесс осуществляется для каждой каждой таблицы базы данных, с полным контролем над тем, какие таблицы в базе данных следует учитывать. Для каждой включенной таблицы будет создана отдельная интегрированная библиотека.

Преобразование библиотек на основе баз данных (DbLibs или SVNDbLibs) в "автономные" интегрированные библиотеки с помощью мастера Offline Integrataed Library Maker.

Процесс включает в себя следующие шаги:

  1. Когда файл Database Library (*.DbLib) или SVN Database Library (*.SVNDbLib), который вы хотите преобразовать, открыт в качестве активного документа, выберите команду Tools » Offline Integrated Library Maker из главного меню, чтобы открыть мастер Offline Integrated Library Maker.
  2. На странице Library to Convert укажите файл DbLib или SVNDbLib, который следует обработать. По умолчанию в качестве библиотеки для преобразования будет указана активная библиотека, из которой был запущен мастер. При необходимости вы можете свободно найти и выбрать другую библиотеку на основе базы данных.
  3. На странице Options укажите, какие таблицы в подключенной базе данных следует включить в процесс преобразования. По умолчанию будут включены все таблицы базы данных. Чтобы исключить какую-либо таблицу, убедитесь, что соответствующий параметр Convert отключен. На этой странице мастера вы также можете указать выходную директорию, в которую будут сохранены сформированные интегрированные библиотеки. Введите путь к этой директории напрямую или нажмите иконку  справа от поля, чтобы открыть диалоговое окно Browse for Folder, из которого вы можете перейти к нужной директории и выбрать ее. Сформированный выходной файл (интегрированная библиотека) для каждой включенной таблицы базы данных будет сохранен в собственную подпапку внутри указанной выходной папки, с тем же названием, что и у таблицу.
  4. После выбора библиотеки на основе базы данных и настройки соответствующих параметров преобразования необходимым образом нажмите Next, чтобы начать процесс преобразования. Будет отображен индикатор выполнения, а также информация о преобразуемой в данный момент библиотеке. Помните, что процесс преобразования осуществляется для каждой таблицы базы данных, которую вы указали для преобразования. Процесс, по сути, включает в себя следующее:
    1. В панели Projects создается и открывается пакет интегрированной библиотеки (*.LibPkg). Название пакета соответствует имени таблицы. Например, для таблицы под названием Capacitor - Ceramic будет создан пакет с названием Capacitor - Ceramic.LibPkg.
    2. Будет создан и добавлен в пакет LibPkg документ схемной библиотеки. Опять же, эта библиотека будет названа в соответствии с именем таблицы (например, Capacitor - Ceramic.SchLib).
    3. Каждая запись в таблице затем рассматривается как компонент Altium, который нужно создать. Для этого из соответствующей исходной библиотеки извлекается схемный символ, который добавляется в качестве компонента в новую библиотеку. Затем этому компоненту добавляется информация о параметрах и ссылках на модели, определенная в записи.
    4. Модели посадочных мест, на которые приведена ссылка, извлекаются и добавляются в документ библиотеки посадочных мест. Опять же, название этого документа соответствует названию таблицы (например, Capacitor - Ceramic.PcbLib). Документ библиотеки посадочных мест затем добавляется в пакет LibPkg.
    5. Если исходной библиотекой является DbLib и в записи базы данных определены ссылки на имитационные модели, соответствующие файлы имитационных моделей также добавляются в LibPkg. Расположение этих моделей остается неизменным. Полный путь к модели указывается в ссылке на соответствующую модель.
    6. Затем происходит компиляция LibPkg, результатом которой является интегрированная библиотека (например, Capacitor - Ceramic.IntLib), после чего эта библиотека добавляется в список установленных библиотек системы.
Установленные в данный момент библиотеки можно увидеть на вкладке Installed диалогового окна Available Libraries, которое можно быстро открыть нажатием кнопки Libraries в верхней части панели Libraries.

Результат процесса преобразования – проекты пакетов библиотек с составными документами библиотек символов и посадочных мест, а также скомпилированные библиотеки IntLib, которые добавляются в список установленных библиотек и, соответственно, становятся доступными всем проектам плат.

Создание SVNDbLib из исходных библиотек (SchLib/PcbLib)

Вы можете использовать исходные библиотеки схемных символов и посадочных мест, добавленные в проект, вместо того, чтобы компилировать их в интегрированную библиотеку. Возможно, вы часто редактируете компоненты в этих компонентах и поэтому не хотите каждый раз декомпилировать и повторно компилировать соответствующую библиотеку IntLib. Библиотеки на основе баз данных в системе контроля версий (SVNDbLib) предлагают что-то похожее – возможность быстрого доступа к исходным библиотекам для их изменения в сочетании с безопасным хранением этих библиотек в репозитории в системе контроля версий.

В системе доступно простое и быстрое преобразование существующих исходных библиотек схемных символов и посадочных мест в структуру библиотеки на основе базы данных в системе контроля версий. Преобразование осуществляется с помощью мастера SVN Database Library Conversion, во многом аналогично преобразованию интегрированной библиотеки. В преобразование может быть включено множество библиотек каждого типа, и каждая библиотека схемных символов будет добавлена в отдельную таблицу целевой базы данных.

Преобразование поддерживает только использование баз данных типа Access.

Преобразование одной или множества исходных библиотек схемных символов и посадочных мест в структуру библиотеки на основе базы данных в системе контроля версий – простой благодаря мастеру SVN Database Library Conversion процесс.

Процесс включает в себя следующие этапы:

  1. Откройте мастер SVN Database Library Conversion. Поскольку мастер предварительно заполняется данными библиотек в зависимости от того, откуда вы его открыли, вы можете сэкономить время, открыв мастер из нужного места:
  • Из редактора библиотек схемных символов – когда открыта библиотека схемных символов, доступ к мастеру осуществляется с помощью команды Tools » SVN Database Library Maker. Тем не менее, может понадобиться включить в процесс преобразования подключенные модели посадочных мест, для чего необходимо найти и добавить соответствующую библиотеку (или библиотеки) посадочных мест.
  • Из редактора библиотек посадочных мест – когда открыта библиотека посадочных мест, доступ к мастеру осуществляется с помощью команды Tools » SVN Database Library Maker. Но, как правило, вы не преобразуете только библиотеки посадочных мест, поэтому необходимо найти и добавить соответствующие библиотеки схемных символов.
  • Из панели Projects – это, пожалуй, самый простой метод, где необходимо, чтобы исходные библиотеки схемных символов и посадочных мест были добавлены в проект. Зачастую это происходит именно так, если интегрированные библиотеки не используются. Щелкните ПКМ по файлу библиотеки и выберите команду SVN Database Library Maker из контекстного меню. Мастер автоматически добавит все библиотеки проекта.
  1. Используйте страницу Libraries to Convert, чтобы указать исходные библиотеки схемных символов и посадочных мест, которые хотите преобразовать. Список будет изначально заполнен одной или множеством библиотек (активной библиотекой или всеми библиотеками, которые были добавлены в проект – в зависимости от того, как был открыт мастер). Измените список, если необходимо. Используйте кнопку Add, чтобы открыть диалоговое окно Library Files, из которого вы можете найти и выбрать необходимые исходные библиотеки схемных символов и посадочных мест.
  2. На странице Options , чтобы определить параметры преобразования, в том числе как будут разделены исходные библиотеки, в каких директориях какого репозитория они должны быть сохранены и выходную директорию для файла SVNDbLib. Для библиотеки схемных символов доступно два параметра, которые позволяют удалить информацию о параметрах и/или моделях из каждого компонента и оставить только "оболочку" символа.
Репозиторий SVN и его структура папок должны быть определены заранее. Вы просто указываете его и папки внутри его структуры, в которые будут сохранены файлы разделенных библиотек. Репозиторий и папки не создаются на лету.
  1. После выбора исходных библиотек схемных символов и посадочных мест и настройки необходимых параметров преобразования нажмите Next , чтобы начать процесс преобразования. Будет отображен индикатор выполнения, а также информация о преобразуемой в данный момент библиотеке. Процесс преобразования включает в себя:
    1. Разделение библиотек схемных символов и посадочных мест на файлы библиотек с отдельными символами/посадочными местами.
    2. Фиксация разделенных библиотек символов и посадочных мест в репозитории в указанных базовых директориях.
    3. Мастер извлечет только информацию о моделях посадочных мест. Подключенные имитационные модели поддерживаются библиотеками на основе баз данных в системе контроля версий (SVNDbLib), но хранение файлов имитационных моделей в репозитории Subversion не поддерживается. Если такие ссылки присутствуют, они будут добавлены как параметры.
    4. Создание отдельной таблицы базы данных в формируемой базе данных Access (которая будет названа также, как указанное для файла SVNDbLib имя) для каждой преобразуемой интегрированной библиотеки, с заполнением информации о параметрах и моделях, извлеченной из каждого компонента в этих библиотеках. Название каждой таблицы соответствует названию схемной библиотеки с суффиксом _SchLib (например, Capacitor - Ceramic_SchLib).
    5. Создание указанного файла SVNDbLib, подключение к базе данных и репозиторию.
  2. По завершении преобразования нажмите Finish, чтобы закрыть мастер и сделать файл SVNDbLib активным документом.

Полученный в результате процесса преобразования файл SVNDbLib.

Убедитесь, что компоненты схемных библиотек не включают в себя параметр Part Number. Информация о номере компонента, введенная в базу данных для определения отдельных записей компонентов, берется из поля Design Item ID компонентов, которое находится в разделе Properties вкладки General панели Properties при просмотре свойств активного компонента. Ввод в качестве параметра приведет к ошибке преобразования из-за дублирующегося значения. По завершении процесса преобразования, все схемные компоненты, у которых есть этот параметр, не будут созданы в базе данных и, следовательно, они не появятся в списке компонентов базы данных на вкладке Table Browser документа SVNDbLib.

Преобразование DbLib в SVNDbLib

Возможно, вы уже используете библиотеки на основе баз данных, преобразованных из интегрированных библиотек с структуру DbLib или созданных с нуля. Но затем вы можете захотеть перенести исходные библиотеки символов и посадочных мест в безопасный репозиторий в системе контроля версий. Система предлагает средства для эффективного перехода от стандартных библиотек на основе баз данных (DbLib) к библиотекам на основе баз данных в системе контроля версий (SVNDbLib).

Преобразование осуществляется с помощью мастера SVN Database Library Conversion, во многом аналогично преобразованию интегрированной библиотеки.

Преобразование существующих стандартных библиотек на основе баз данных (DbLib) в библиотеки на основе баз данных в системе контроля версий (SVNDbLib) – простой благодаря мастеру SVN Database Library Conversion процесс.

Процесс включает в себя следующие этапы:

  1. Откройте существующий файл DbLib, который необходимо преобразовать, затем выберите команду Tools » SVN Database Library Maker. Появится мастер SVN Database Library Conversion.
  2. На странице Libraries to Convert укажите исходную библиотеку на основе базы данных, которую необходимо преобразовать. Параметр Database Libraries будет уже включен, а в соответствующем поле будет указан путь к активной библиотеке. Если вы хотите преобразовать другую библиотеку DbLib, нажмите кнопку  и используйте диалоговое окно, чтобы выбрать нужную библиотеку Database Library File.
  3. После нажатия кнопки Next, выбранный файл DbLib будет проанализирован и появится диалоговое окно, уведомляющее о том, что база данных может быть изменена. Нажмите Yes, чтобы продолжить.
  4. На странице Options мастера определите параметры преобразования, в том числе как будут разделены исходные библиотеки, в каких директориях какого репозитория они должны быть сохранены и выходную директорию для файла SVNDbLib. Для библиотеки схемных символов доступно два параметра, которые позволяют удалить информацию о параметрах и/или моделях из каждого компонента и оставить только "оболочку" символа.
Репозиторий SVN и его структура папок должны быть определены заранее. Вы просто указываете его и папки внутри его структуры, в которые будут сохранены файлы разделенных библиотек. Репозиторий и папки не создаются на лету.
Поскольку внешняя база данных, подключенная к изначальному файлу DbLib, уже существует, она не будет создана. База данных останется в своем текущем расположении. В зависимости от того, хотите ли вы, чтобы сформированный файл SVNDbLib и база данных были в одном и том же расположении, у вас есть два варианта. В первом случае вы задаете в качестве выходного пути для SVNDbLib тот же самый, в котором в данный момент находится база данных. Второй вариант – сформировать SVNDbLib в другой директории и затем перенести в нее базу данных. В этом случае необходимо изменить свойства подключения в файле SVNDbLib, чтобы он указывал на новое расположение, и произвести повторное подключение.
  1. После выбора исходного файла DbLib и настройки необходимых параметров преобразования нажмите Next , чтобы начать процесс преобразования. Будет отображен индикатор выполнения, а также информация о преобразуемой в данный момент библиотеке. Процесс преобразования включает в себя:
    1. Разделение библиотек схемных символов и посадочных мест на файлы библиотек с отдельными символами/посадочными местами.
    2. Фиксация разделенных библиотек символов и посадочных мест в репозитории в указанных базовых директориях.
    3. Создание указанного файла SVNDbLib, подключение к базе данных и репозиторию.
  2. По завершении преобразования нажмите Finish, чтобы закрыть мастер и сделать файл SVNDbLib активным документом.

Полученный в результате процесса преобразования файл SVNDbLib.

Немного об отображении полей

В сформированном файле SVNDbLib заданные на вкладке Field Mappings отображения между полями базы данных и проектными параметрами остаются теми же самыми, что и в изначальном файле DbLib.

Отображения полей в изначальном файле DbLib и сформированном SVNDbLib идентичны.

Тем не менее, следует отметить два важных момента:

  • Заданные отображения путей для символов и моделей посадочных мест игнорируются. SVNDbLib использует только отображенные поля ссылок [Library Ref] и [Footprint Ref] для поиска нужного символа и посадочного места в библиотеках, зафиксированных в репозитории. Информация о путях, определенная в базе данных, игнорируется, поскольку они указывают на библиотеки, расположенные на жестком диске или другом локальном/сетевом ресурсе.
Если вы все же хотите включать информацию о путях в базу данных, измените информацию, чтобы пути указывали на библиотеки в репозитории. Следует помнить, что если информация о путях к библиотекам отсутствует в базе данных, то это делает ее более надежной. Расположение репозитория и/или его внутренняя структура папок могут быть изменены, и базу данных не нужно будет изменять.
  • Определенные отображения имитационных моделей также останутся заданными в файле SVNDbLib. Тем не менее, хранение файлов имитационных моделей в репозитории Subversion не поддерживается. Хотя ссылки на модели и будут добавлены в экземпляр компонента при его размещении, сами модели не будут найдены.

Прямая поддержка OrCAD® CIS

Среда полностью поддерживает подключение и использование существующих систем OrCAD Component Information System (CIS). Структура CIS, по сути, преобразуется в структуру стандартной библиотеки на основе базы данных (DbLib) Altium Designer.

Из OrCAD в Altium Designer – необходимы преобразования

Чтобы обеспечить возможность прямого размещения из внешней базы данных (*.mdb, *.xls), необходимы следующие преобразования файлов:

  • Файл OrCAD CIS Configuration (*.dbc), который управляет ссылкой на внешнюю базу данных и включает в себя информацию об отображении полей в проектные параметры, должен быть преобразован в файл библиотеки на основе базы данных (*.DbLib) Altium Designer.
На данный момент Altium Designer поддерживает только файлы OrCAD CIS .dbc в бинарном формате.
  • Соответствующие файлы библиотек OrCAD должны быть преобразованы в файлы библиотек Altium Designer:
    • Библиотека OrCAD Capture (*.olb) ---> Библиотека схемных символов (*.SchLib).
    • Файл библиотеки OrCAD Max (*.llb) ---> Библиотека посадочных мест (*.PcbLib).

Автоматическое создание библиотеки на основе базы данных

Самый простой и эффективный способ создания файла DbLib и исходных библиотек Altium Designer – это использование мастера Import Wizard (File » Import Wizard). На второй странице мастера убедитесь, что в качестве типа импортируемых файлов выбран пункт OrCAD CIS Configuration Files and Libraries.

Используйте Import Wizard для быстрого преобразования файла CIS Configuration и соответствующих библиотек OrCAD в файлы DbLib и исходных библиотек (SchLib и PcbLib) Altium Designer.

На следующих страницах мастера необходимо указать:

  • Расположение внешней базы данных.
  • Расположение файла CIS Configuration (*.dbc) – помните, что он должен быть в бинарном формате, а не XML.
  • Где и под каким именем должен быть создан целевой файл DbLib.
  • Библиотеки символов и/или посадочных мест OrCAD, на которые ссылается внешняя база данных.
При указании исходных библиотек OrCAD вы также определяете, где будут сохранены итоговые библиотеки Altium Designer. По умолчанию эти библиотеки будут сохранены в подпапке \Libraries, расположенной в той же директории, что и целевой файл DbLib.

Следуйте инструкциям мастера, чтобы определить базу данных, файл CIS Configuration, исходные библиотеки OrCAD и целевой файл DbLib.

После определения исходных и целевых файлов и директорий необходимым образом нажмите Next, чтобы начать процесс импорта. По завершении импорта нажмите Finish , чтобы закрыть мастер и сделать файл DbLib активным документом.

Итоговый файл DbLib после завершения процесса импорта.

Что следует иметь в виду:

  • Путь поиска библиотек автоматически добавляется в файл DbLib, на вкладку Symbol & Model Search Paths диалогового окна Database Library Options, который указывает на папку, содержащую преобразованные файлы библиотек.
  • Информация об отображении параметров, в том числе заданный ключ поиска, берется непосредственно из файла OrCAD CIS Configuration.
  • Автоматически задаются два отображения моделей. Примеры имен полей базы данных и назначенных проектных параметров:
    • Footprint Name ---> [Orcad Footprint]
    • Symbol Name ---> [Orcad Library]

Эти элементы определяют ссылку на исходный схемный символ для определенной записи компонента во внешней базе данных и соответствующую модель посадочного места, связанную с этим компонентом.

Создание библиотеки на основе базы данных вручную

Создание файла DbLib с помощью Import Wizard является самым быстрым, но не единственным способом. Конечно, вы можете создать файл DbLib вручную. Для этого:

  1. Создайте новый файл DbLib, подключите его ко внешней базе данных, определите настройки отображения и обновления параметров необходимым образом.
  2. После этого необходимо импортировать библиотеки OrCAD. Это можно сделать с помощью Import Wizard для преобразования файлов библиотек OrCAD (*.olb, *.llb) в библиотеки Altium Designer (*.SchLib, *.PcbLib).
    1. При выборе типа импортируемых файлов укажите пункт OrCAD Designs and Libraries Files.
    2. Пропустите страницу Importing OrCAD Designs и перейдите к странице Importing OrCAD Libraries. Добавьте все исходные библиотеки OrCAD, на которые ссылается база данных.
    3. Пропустите следующие страницы, которые относятся к импорту файлов проекта.
    4. На странице Output Library Options мастера оставьте параметр Output Libraries as PCB Project включенным.
    5. На странице Output Libraries мастера укажите выходную директорию для сформированных файлов библиотек.

Импорт исходных библиотек OrCAD, содержащих символы и посадочные места, на которые ссылается база данных.

  1. По завершении импорта в указанной директории будет создана папка Imported OrCAD Libraries.PrjPcb. Вы можете переместить сформированные библиотеки Altium Designer в другое расположение, если необходимо. Например, вы можете переместить библиотеки в папку под названием Libraries, созданную внутри директории с файлом DbLib.
  2. Когда у вас есть библиотеки символов и посадочных мест, необходимо вернуться к файлу DbLib и настроить пути поиска библиотек (на вкладке Symbol & Model Search Paths диалогового окна Database Library Options), чтобы указать папку, в которой эти библиотеки сохранены.

 

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Concord Pro

Заполните форму ниже, чтобы получить бесплатную пробную версию Altium Concord Pro