Altium Designer Documentation

Определение регионов платы и линий сгиба_AD

Термин "регион платы" (Board Region) используется для описания заданной пользователем области платы, которой может быть назначен уникальный стек слоев.

Новая плата по умолчанию включает в себя один регион – контур формы платы. Если в конструкции платы необходимо множество стеков слоев, вы можете разделить этот единый регион платы по умолчанию на множество регионов и назначить каждому из них свой стек слоев.

На изображении ниже форма платы была разделена на три отдельных региона: верхний круглый, средний прямоугольный и нижний круглый. Эти регионы были созданы путем размещения двух горизонтальных линий разделения, отображенных синим пунктиром. Обратите внимание на оранжевые пунктирные линии – это линии сгиба, размещенные исходя из того, что эта конструкция гибко-жесткой платы будет сложена при сборке.

Обратите внимание, что форма платы была разделена на три отдельных региона с помощью двух синих пунктирных горизонтальных линий разделения.
Обратите внимание, что форма платы была разделена на три отдельных региона с помощью двух синих пунктирных горизонтальных линий разделения.

Разделение платы на регионы

Разделение платы на два региона осуществляется путем размещения линии разделения в режиме Board Planning Mode редактора плат.

В меню View доступны команды для выбора режима редактора плат, с легко запоминаемыми клавишами для переключения между ними:

  • Board Planning Mode (режим планирования платы, клавиша 1)
  • 2D Layout Mode (режим 2D-компоновки, клавиша 2)
  • 3D Layout Mode (режим 3D-компоновки, клавиша 3)

Если при переключении между режимами необходимо видеть одно и то же место и ориентацию платы, используйте сочетания клавиш Ctrl+Alt+2 и Ctrl+Alt+3. Если вы работаете над различными областями платы, используйте клавиши 2 и 3.

Меню редактора будет включать в себя команды, соответствующие выбранному режиму. Если вы обычно находите команды, относящиеся к форме платы, в меню Design, но больше не видите их, убедитесь, что активен нужный режим.

Размещение линии разделения

Для размещения линии разделения:

  1. Выберите команду View » Board Planning Mode (или нажмите клавишу 1), чтобы перейти в режим Board Planning Mode.
  2. Выберите команду Design » Define Split Line, чтобы перейти в режим размещения линии разделения.
  3. Щелкните ЛКМ внутри формы платы, чтобы начать процесс определения линии разделения. Один конец линии будет присоединен к ближайшей точке на контуре платы, другой конец будет присоединен к курсору.
  4. Наведите курсор мыши в нужное место, щелкните ЛКМ один раз для размещения второго конца.

Плата разделена на отдельные регионы путем размещения линии разделения, которая проходит от одного края формы платы до другого.
Плата разделена на отдельные регионы путем размещения линии разделения, которая проходит от одного края формы платы до другого.

Плата разделена на несколько регионов путем размещения линии разделения. Обратите внимание, что также были размещены линии сгиба.
Плата разделена на несколько регионов путем размещения линии разделения. Обратите внимание, что также были размещены линии сгиба.

Перемещение линии разделения

Для перемещения линии разделения:

  1. Выберите команду View » Board Planning Mode (или нажмите клавишу 1), чтобы перейти в режим Board Planning Mode.
  2. Чтобы переместить конец линии, перетащите ее с зажатой ЛКМ в нужное место на контуре формы платы. Перемещения курсора будут ограничены текущей сеткой привязки.
Линия разделения будет оставаться синей при перетаскивании в допустимое положение, при котором будет получено корректное разделение. Если новое положение перемещаемого конца линии будет некорректным (например, он будет находиться на том же крае платы, что и другой конец), линия разделения будет отображена красным. Если отпустить ЛКМ в тот момент, когда линия разделения отображается красным, она будет удалена.

Удаление линии разделения

Для удаления линии разделения:

  1. Выберите команду View » Board Planning Mode (или нажмите клавишу 1), чтобы перейти в режим Board Planning Mode.
  2. Зажмите ЛКМ на одном из концов линии и нажмите клавишу Delete. Либо перетащите с зажатой ЛКМ конец линии куда-либо на контур формы платы так, чтобы линия стала отображаться красным (что укажет на некорректное разделение), и отпустите ЛКМ.

Назначение стека слоев и редактирование названия региона платы

Связанная страница: Определение стека слоев

Новая плата по умолчанию включает в себя один регион под названием Default Layer Stack Region. Этому региону назначен стек слоев по умолчанию под названием Board Layer Stack.

При разделении формы платы на множество регионов, каждому новому региону назначается стек слоев по умолчанию. Если нужные стеки слоев были определены в Layer Stack Manager, то каждому региону можно назначить свой стек и задать осмысленное название.

Каждый регион отображает метку с названием региона и названием назначенного стека слоев в формате Название региона - Название стека слоев. Если стек слоев настроен как гибкий, это будет обозначено надписью (flex). Включение настройки для обозначения стека как гибкого осуществляется в Layer Stack Manager.

Чтобы назначить региону стек слоев и задать ему название:

  1. Выберите команду View » Board Planning Mode (или нажмите клавишу 1), чтобы перейти в режим Board Planning Mode.
  2. Щелкните ЛКМ по вкладке Multi-Layer под проектной областью, чтобы сделать этот слой активным (если вкладка слоя не отображается, нажмите L, чтобы открыть панель View Configuration и включить этот слой).
  3. Дважды щелкните ЛКМ по региону платы, чтобы открыть диалоговое окно Board Region. Если регион не выделяется и диалоговое окно не открывается, убедитесь, что регионы включены в Selection Filter.
  4. Назначьте нужный стек слоев, выбрав его в выпадающем списке Layer stack.
  5. Измените название региона в поле Name, если нужно.
  6. Нажмите OK, чтобы принять настройки и закрыть диалоговое окно.

Дважды щелкните ЛКМ по региону платы, чтобы определить его название и назначить стек слоев.
Дважды щелкните ЛКМ по региону платы, чтобы определить его название и назначить стек слоев.

Диалоговое окно Board Region также можно открыть, дважды щелкнув ЛКМ по нужному региону стекапа в режиме Layer Stack Regions панели PCB. Панель PCB автоматически отображается в этом режиме при переключении в Board Planning Mode.

Размещение и перемещение линии сгиба

Для определения того, как должна сгибаться гибкая плата, необходимо разместить одну или несколько линий сгиба. Линия сгиба определяет, где на поверхности гибкого региона находится сгиб. Линия сгиба также определяет угол и радиус сгиба, а также ширину сгибаемого участка поверхности платы. Размещение и редактирование линий сгиба осуществляется в редакторе плат в режиме Board Planning Mode (View » Board Planning Mode или клавиша 1).

Линию сгиба можно разместить только на регионе, который задан как Flex в Layer Stack Manager.

Размещение линии сгиба

Для размещения линии сгиба:

  1. Выберите команду View » Board Planning Mode (или нажмите клавишу 1), чтобы перейти в режим Board Planning Mode.
  2. На вкладке Mutli-layer выберите команду Design » Define Bending Line.
  3. Щелкните ЛКМ внутри региона платы, где должна быть размещена линия сгиба. Один конец линии сгиба будет присоединен к ближайшей точке на контуре региона, другой конец будет присоединен к курсору.
  4. Наведите курсор мыши в нужное место, щелкните ЛКМ один раз для размещения второго конца.
  5. Вы останетесь в режиме размещения линии сгиба для размещения еще одной линии, если это необходимо. В противном случае, щелкните ПКМ или нажмите клавишу Esc, чтобы выйти из режима размещения линии сгиба.

Панель PCB в режиме Layer Stack Regions отображает данные о линиях сгиба (Bending Lines). Дважды щелкните ЛКМ по строке, чтобы открыть диалоговое окно Bending Line.

На этом гибком регионе платы были размещены три линии сгиба. Шириной оранжевой полосы является значение Affected area width.
На этом гибком регионе платы были размещены три линии сгиба. Шириной оранжевой полосы является значение Affected area width.

Когда региону платы назначается гибкий стек слоев, на него автоматически добавляется линия сгиба, проходящая вертикально через его геометрический центр. Удалите эту линию сгиба либо переместите и задайте ее настройки нужным образом.

Перемещение линии сгиба

Для изменения положения существующей линии сгиба:

  1. Щелкните ЛКМ по региону платы, которая содержит линию сгиба. Будут отображены ручки управления всех линий сгиба внутри этого региона.
  2. Зажмите ЛКМ на ручке управления линии сгиба, чтобы переместить ее в новое место, и отпустите ЛКМ.

Точное размещение линии сгиба

При перемещении линии сгиба, ручка управления будет привязываться к узлам текущей сетки привязки. Она также может привязываться к существующим проектным объектам, таким как линии на механическом слое. На изображении ниже показана ручка управления линии сгиба, размещаемая на конце линии на слое Mechanical 2 (выделен номером 1). Обратите внимание, что механический слой должен быть активным для возможности привязки.

Номер 1 относится к ручке управления линией сгиба, которая привязывается к линии на активном слое Mechanical 2.
Номер 1 относится к ручке управления линией сгиба, которая привязывается к линии на активном слое Mechanical 2.

Чтобы продемонстрировать этот процесс подробнее, на изображениях ниже показаны вспомогательные линии, размещенные на слое Mechanical 2 в 2D Layout Mode, которые точно задают верхние и нижние опорные точки, используемые для размещения линий сгиба под углом 45 градусов.

Плата в режиме 2D Layout Mode, где показаны вспомогательные линии для точного размещения диагональных линий сгиба.Плата в режиме 2D Layout Mode, где показаны вспомогательные линии для точного размещения диагональных линий сгиба.

Плата в режиме 2D Layout Mode, где показаны диагональные линии сгиба, построенные с помощью привязок к вспомогательным линиям на слое Mechanical 2.Плата в режиме 2D Layout Mode, где показаны диагональные линии сгиба, построенные с помощью привязок к вспомогательным линиям на слое Mechanical 2.

Удаление линии сгиба

Для удаления линии сгиба зажмите ЛКМ на одном из концов линии и нажмите клавишу Delete.

Когда региону платы назначается гибкий стек слоев, на него автоматически добавляется линия сгиба, проходящая вертикально через его геометрический центр. Удалите эту линию сгиба либо переместите и задайте ее настройки нужным образом.

Настройка свойств линии сгиба

Просмотр и редактирование регионов платы, линий разделения и линий сгиба осуществляется в режиме Board Planning Mode (нажмите клавишу 1). Линии сгиба могут быть отредактированы в проектной области интерактивно или через панель PCB в режиме Layer Stack Regions. Чтобы отобразить панель, нажмите кнопку Panels в нижней правой части окна Altium Designer и выберите команду PCB из открывшегося меню. В панели выберите Layer Stack Regions из выпадающего списка вверху.

При переходе в режим Board Planning Mode, в панели PCB будет автоматически выбран режим Layer Stack Regions.

Для изменения свойств линии сгиба в панели PCB:

  1. Линии сгиба могут быть изменены как в режиме 2D Layout Mode (нажмите клавишу 2), так и в режиме Board Planning Mode (нажмите клавишу 1).
  2. Включите опцию Select в верхней части панели.
  3. Выберите нужный регион в разделе Stackup Regions панели.
  4. В разделе Bending Lines панели будет приведен список всех линий сгиба внутри выбранного региона. Дважды щелкните ЛКМ по линии сгиба в панели, чтобы открыть диалоговое окно Bending Line, как показано на изображении ниже.

  5. В диалоговом окне Bending Line измените два из первых трех свойств, например Radius и Bending Angle. Третье свойство будет вычислено автоматически (подробнее об этом далее). Обратите внимание, что значение ширины Affected area width линии сгиба отображается оранжевой затененной областью.
  6. В диалоговом окне Bending Line задайте нужное значение Fold Index для определения порядка сгибов при использовании ползунка Fold State в панели PCB или команды View » Fold/Unfold для складывания платы в режиме 3D.
У одного из регионов платы должен быть включен флажок 3D Locked в диалоговом окне Board Region. Это необходимо для определения физической опоры для 3D-режима представления (где Z = 0). В противном случае, ширина Affected area width линий сгиба не будет показана.

 

Диалоговое окно Bending Line также можно вызвать, нажав клавишу Tab при размещении или перемещении ручки управления линии сгиба или дважды щелкнув ЛКМ по ручке управления линии сгиба.

 

У линий сгиба есть следующие взаимозависимые свойства:

  • Bending Angle (a) – угол, на который должна сгибаться поверхность гибкого региона.
  • Radius (r) – расстояние от поверхности сгиба, на котором находится центр сгиба.
  • Affected area width (w) – ширина области поверхности, которая будет согнута на заданный радиус Radius и угол сгиба Bending Angle.

Взаимосвязь значений Bending Angle, Radius и Affected area width может быть выражена следующим образом:

  • w = a/360 * 2*Pi*r
  • или Ширина зоны влияния = Доля сгибаемой окружности * Длина окружности

3D-представление гибко-жесткой платы

Altium Designer включает в себя включает в себя мощное ядро 3D-визуализации, которое позволяет отображать реалистичное 3D-представление печатного узла. Это ядро также поддерживает гибко-жесткие платы, и при использовании ползунка Fold State оно позволяет проверить гибко-жесткую конструкцию в плоском состоянии, в полностью сложенном состоянии и в любом промежуточном состоянии.

Чтобы переключиться в режим 3D-представления, используйте команду View » 3D Layout Mode или нажмите клавишу 3 (нажмите клавишу 2, чтобы вернуться в 2D, или 1, чтобы вернуться в режим Board Planning Mode). Плата будет отображена в 3D. Если в посадочные места компонентов добавлены 3D-модели, которые определяют смонтированные компоненты, они также будут отображены.

Чтобы применить все линии сгиба, перемещайте ползунок Fold State в панели PCB, когда она находится в режиме Layer Stack Regions. Сгибы будут применены в порядке, заданном их номерами Sequence, отображенными в панели PCB. У линий сгиба может быть один индекс – в этом случае, при использовании ползунка Fold State они будут применяться одновременно. Плату также можно складывать/раскладывать с помощью команды View » Fold/Unfold (или клавиши 5).

Вы можете согнуть плату, если только у одного из гибких регионов включен флажок 3D Locked в диалоговом окне Board Region. Altium Designer необходимо это, чтобы знать, какая часть платы должна быть зафиксирована при складывании.

 

Поддержка гибко-жестких плат средством создания 3D-роликов

Главная страница: 3D-видео платы

Складывание гибко-жесткой платы можно зафиксировать в виде 3D-ролика. Это очень просто, и для этого не нужно использовать ключевые кадры, показывающие промежуточные состояния складывания.

Перейдите на главную страницу, ссылка на которую приведена выше, для получения подробной информации о том, как создавать 3D-ролики. Краткое руководство приведено ниже.

  1. Переключитесь в 3D-режим редактора плат.
  2. Откройте панель PCB 3D Movie Editor, создайте новое видео и задайте ему новое название Movie Title в верхней части панели.
  3. Создайте начальный ключевой кадр (Key Frame), показывающий плату в разложенном состоянии.
  4. Переместите ползунок Fold State, чтобы показать гибко-жесткую плату в сложенном состоянии, затем расположите сложенную плату нужным образом.
  5. Создайте второй ключевой кадр для этого вида и задайте время, которое необходимо на складывание гибко-жесткой платы (настройка Duration(s)). Обычно это несколько секунд.
  6. Чтобы проверить, что видео корректно отображает процесс складывания, нажмите кнопку .
  7. Для формирования файла ролика добавьте выходной документ PCB 3D Video в файл Output Job. Задайте настройки формата видео в диалоговом окне Video settings.
  8. Нажмите Generate Content в файле Output Job, чтобы создать файл ролика.

Видео ниже было создано с помощью этого процесса. В нем присутствует два ключевых кадра, как описано выше, а также один дополнительные ключевой кадр, который был добавлен для показа конечного положения в течение одной секунды.

Простой 3D-ролик, созданный из трех ключевых кадров. Последовательность сгибов определена индексами линий сгиба.
Простой 3D-ролик, созданный из трех ключевых кадров. Последовательность сгибов определена индексами линий сгиба.

Экспорт сложенной гибко-жесткой платы в STEP

Altium Designer поддерживает экспорт гибко-жесткой платы в файл 3D STEP (File » Export » STEP 3D). Эта поддержка включает в себя возможность определить степень складывания при экспорте в STEP, значением по умолчанию которого является состояние, заданное в данный момент в редакторе плат, как показано ниже.

Текущее состояние складывания, заданное в редакторе плат, используется в качестве состояния складывания при экспорте в STEP. Задайте значение Rate нужным образом в диалоговом окне Export Options.Текущее состояние складывания, заданное в редакторе плат, используется в качестве состояния складывания при экспорте в STEP. Задайте значение Rate нужным образом в диалоговом окне Export Options.

Поддержка сборок Multi-board для гибко-жестких плат

В предыдущих версиях Altium Designer, гибко-жесткая плата, добавленная в сборку Multi-board, была в разложенном состоянии.

Теперь гибко-жесткая плата добавляется в сборку Multi-board в полностью сложенном состоянии для ее лучшего моделирования в конечной сборке.

Обратите внимание, что гибко-жесткая плата полностью сложена в сборке Multi-board для ее лучшего моделирования в конечной сборке.Обратите внимание, что гибко-жесткая плата полностью сложена в сборке Multi-board для ее лучшего моделирования в конечной сборке.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: