Altium Designer Documentation

Работа с панелью Explorer – Практические советы по использованию_AD

Created: 02.04.2020 | Updated: 03.04.2020
Полное содержание

Главная страница: Работа с сервером управляемых данных

Панель Explorer в Altium Designer предоставляет прямой интерфейс к серверу управляемых данных. Из панели Explorer вы можете выполнять различные операции, такие как:

  • Создание организационной структуры сервера и управление ей.
  • Создание любого количества объектов (Item), каждый из которых представляет проектный объект.
  • Прямое редактирования и размещение ревизий объектов.
  • Просмотр жизненного цикла ревизий объектов и управление ими.
  • Определение использования определенной ревизии объекта (Where-Used).
  • Просмотр информации о цепочке поставок для компонентов и управление ей.

На этой странице собраны некоторые советы и трюки по использованию панели, которые могли быть упущены среди других ее функциональных возможностей. Воспринимайте эту страницу как шпаргалку по набору возможностей, которые могут заметно повысить производительность при работе в панели Explorer.

Для повседневных задач, связанных с управлением компонентами, особенно с управляемыми компонентами на сервере, вы будете часто использовать панель Components. Эта панель предоставляет эффективный интерфейс для работы со всеми компонентами, как управляемыми (серверными), так и библиотечными (локальными). Для управляемых компонентов панель предоставляет возможность параметрического поиска на основе фильтров (фасетного поиска) путем указания параметров целевых компонентов. Кроме того, панель также предлагает возможности редактирования управляемого компонента через редактор Component Editor (в режиме Single Component Editing), просмотр компонента на исходном сервере и выполнение команд управления компонентом, таких как создание и клонирование компонента и изменение вариантов выбора и типа выбранного компонента. В общем, панель Components предоставляет удобный интерфейс специально для работы с управляемыми компонентами, без необходимости использования панели Explorer.
Эта страница не является исчерпывающей справкой по всем возможностям панели Explorer. Многие из ее функциональных возможностей описаны в различных местах документации, где рассматривается Работа с сервером управляемых данных, в частности Работа с управляемыми компонентами и Выпуск проекта платы.

Панель Explorer предоставляет прямой интерфейс к серверу управляемых данных из Altium Designer.Панель Explorer предоставляет прямой интерфейс к серверу управляемых данных из Altium Designer.

Изменение используемого сервера

Панель Explorer может взаимодействовать одновременно только с одним сервером управляемых данных. Поле в верхней левой части панели отображает открытый в данный момент сервер, т.е. тот сервер, содержимое которого вы можете просматривать и изменять. Чтобы выбрать другой сервер, щелкните мышью по названию сервера и выберите другой сервер из списка подключенных в данный момент серверов.

Доступ к элементам управления для изменения используемого сервера. Текущий сервер отображается жирным шрифтом.Доступ к элементам управления для изменения используемого сервера. Текущий сервер отображается жирным шрифтом.

Все подключенные в данный момент серверы (активный сервер и известные для экземпляра Altium Designer серверы) представлены на странице Data Management - Servers диалогового окна Preferences. Хотя вы одновременно можете войти только на один сервер управляемых данных, вы можете быть подключены к другим серверам, в том числе к устаревшему Altium Personal Vault. Активный сервер (тот, на который вы вошли) отличается иконкой .

Загрузка содержимого папки

При щелчке мышью по какой-либо папке в области Server Folders структуры серверных папок панели Explorer, изначально будет загружена только часть содержимого этой папки, где это применимо. Это значительно сокращает начальное время загрузки папки. При прокрутке начального содержимого будет загружена дополнительная порция объектов в этой папке.

Частичная загрузка содержимого папки ускоряет доступ к этой папке, особенно если она содержит большое количество объектов.Частичная загрузка содержимого папки ускоряет доступ к этой папке, особенно если она содержит большое количество объектов.

Чтобы загрузить всё содержимое папки, нажмите кнопку  в верхней части панели и используйте опцию Load all pages меню для переключения между частичной загрузкой содержимого папки (опция отключена) и полной загрузкой содержимого папки (опция включена).

Перемещение папок и объектов

Одну или множество серверных папок или объектов в папке можно быстро переместить путем перетаскивания мышью:

  • Папки – выберите папки, которые необходимо переместить (с помощью стандартных сочетаний Ctrl+ЛКМ и Shift+ЛКМ), затем перетащите выбранные папки с зажатой ЛКМ в нужное место в структуре, которое будет обозначенное горизонтальным индикатором.
  • Объекты – выберите объекты, которые необходимо переместить (с помощью стандартных сочетаний Ctrl+ЛКМ, Shift+ЛКМ, Ctrl+A), затем перетащите выбранные объекты с зажатой ЛКМ в другую папку в структуре.

Быстрая систематизация серверных папок и объектов путем перетаскивания мышью.Быстрая систематизация серверных папок и объектов путем перетаскивания мышью.

Папки и объекты также можно переместить с помощью соответствующей команды, доступной в контекстном меню (в команде будет отражено, перемещается одна или множество папок/объектов). При запуске команды будет открыто диалоговое окно для выбора целевой папки, в которую необходимо переместить выбранные папки или объекты.

Удаление папки

Серверные данные нельзя восстановить после их удаления. Поскольку они являются ценной информацией, перед удалением папки необходимо удалить все объекты, которые в ней содержатся. После этого вы можете удалить пустую папку с помощью команды Delete Folder контекстного меню.

Для упрощения систематизации серверной структуры папок поддерживается удаление множества пустых папок в одно действие:

  • Удаление выбранных папок – выберите пустые папки (с помощью стандартных сочетаний Ctrl+ЛКМ или Shift+ЛКМ), щелкните ПКМ по выделенной группе и выберите команду Delete Folders.
  • Рекурсивное удаление папок – удалите дерево пустых папок с помощью команды Delete Folder контекстного меню родительской папки. Родительская папка и все вложенные дочерние папки будут удалены.

Размещение путем перетаскивания мышью

Размещать определенные серверные объекты в проекте платы Altium Designer удобно путем перетаскивания мышью ревизий этих объектов на активный (и подходящий) документ непосредственно из панели Explorer. Поддерживается перетаскивание следующих сущностей:

  • Ревизия объекта Component Item – в активный документ схемы (или платы). Под курсором появится подходящая модель для выбранного домена.
  • Ревизия объекта Managed Schematic Sheet Item – в активный документ схемы. Под курсором появится символ листа, ссылающийся на этот лист.
  • Ревизия объекта 3D Model Item – в документ платы или библиотеки посадочных мест. Будет создана 3D-модель (примитив 3D Body), ссылающаяся на эту ревизию объекта.

Найдите на сервере объект, который нужно разместить. Размещаться будет определенная ревизия этого объекта, поэтому разверните главную запись объекта, чтобы увидеть список всех ревизий (нажмите кнопку  в правой верхней части панели и отключите параметр Show only latest, чтобы увидеть все предыдущие ревизии). Затем зажмите ЛКМ на нужной ревизии и перетащите ее экземпляр в проектный документ.

Перетащите мышью запись верхнего уровня самого объекта, чтобы разместить экземпляр самой новой ревизии этого объекта.
При перетаскивании будет размещен один экземпляр ревизии объекта. Если необходимо разместить множество экземпляров, щелкните ПКМ по ревизии объекта (или по записи верхнего уровня самого объекта для самой новой ревизии) и используйте команду Place.

Кроме того, Altium Designer поддерживает доступ к управляемым компонентам и их размещение из панели Components. Для получения более подробной информации перейдите в раздел Размещение из панели Components на странице Работа с управляемыми компонентами.

Пакетная загрузка объектов

Панель Explorer поддерживает возможность выбора множества объектов на сервере управляемых данных и массовой загрузки исходных сущностей этих объектов в новую единую исходную библиотеку или папку, если это применимо. Этой возможностью поддерживаются следующие типы объектов:

  • Объекты символов – символы выбранных объектов загружаются в схемную библиотеку (*.SchLib).
  • Объекты посадочных мест – 2D/3D-модели компонентов выбранных объектов загружаются в библиотеку посадочных мест (*.PcbLib).
  • Объекты компонентов – выбранные объекты компонентов загружаются в zip-архив, содержащий в себе исходные библиотеки символов и моделей, а также исходный пакет интегрированной библиотеки (*.LibPkg).
  • Объекты имитационных моделей – выпущенные данные в каждом применимом выбранном объекте (*.SimModel, *.mdl, *.ckt) загружаются в отдельную подпапку.

Чтобы загрузить множество объектов символов:

  1. Перейдите к серверной папке, которая содержит интересующие объекты символов.
  2. Выберите объекты для загрузки с помощью стандартных сочетаний клавиш для множественного выделения (Ctrl+ЛКМ, Shift+ЛКМ).
  3. Щелкните ПКМ по выделенным объектам и выберите команду Operations » Download selected symbol in library.
  4. Используйте диалоговое окно Choose destination file, чтобы определить, где и под каким именем будет сформирован новый файл схемной библиотеки.
  5. Нажмите Save – будет создан файл SchLib, с отображением прогресса в отдельном диалоговом окне Downloading.

По завершении загрузки, из диалогового окна Downloading вы сможете просмотреть загруженное содержимое в Проводнике Windows (нажмите Explore) или открыть библиотеку в Altium Designer (нажмите Open).

Пример загрузки множества выбранных объектов символов в документ схемной библиотеки.Пример загрузки множества выбранных объектов символов в документ схемной библиотеки.

Каждый символ называется в соответствии с полем Name исходного объекта.

Итоговый документ схемной библиотеки с загруженными символами.Итоговый документ схемной библиотеки с загруженными символами.

Чтобы загрузить множество объектов посадочных мест:

  1. Перейдите к серверной папке, которая содержит интересующие объекты посадочных мест.
  2. Выберите объекты для загрузки с помощью стандартных сочетаний клавиш для множественного выделения (Ctrl+ЛКМ, Shift+ЛКМ).
  3. Щелкните ПКМ по выделенным объектам и выберите команду Operations » Download selected footprint in library.
  4. Используйте диалоговое окно Choose destination file, чтобы определить, где и под каким именем будет сформирован новый файл библиотеки посадочных мест.
  5. Нажмите Save – будет создан файл PcbLib, с отображением прогресса в отдельном диалоговом окне Downloading.

По завершении загрузки, из диалогового окна Downloading вы сможете просмотреть загруженное содержимое в Проводнике Windows (нажмите Explore) или открыть библиотеку в Altium Designer (нажмите Open).

Пример загрузки множества выбранных объектов посадочных мест в документ библиотеки посадочных мест.Пример загрузки множества выбранных объектов посадочных мест в документ библиотеки посадочных мест.

Каждое посадочное место называется в соответствии с полем Name исходного объекта.

Итоговый документ библиотеки посадочных мест с загруженными посадочными местами.Итоговый документ библиотеки посадочных мест с загруженными посадочными местами.

Чтобы загрузить множество объектов компонентов:

  1. Перейдите к серверной папке, где находятся объекты компонентов, которые вы хотите загрузить.
  2. Выберите ревизии объектов компонентов, которые вы хотите включить в загрузку. Вы можете выбрать только одну ревизию объекта компонента (как правило, это самая новая ревизия), но вы можете включить в загрузку любое необходимое количество объектов компонентов.
  3. Щелкните ПКМ по какой-либо выделенной записи и выберите команду Operations » Download selected component to zip из контекстного меню.
  4. В диалоговом окне Save As укажите имя и расположение формируемого zip-архива. По умолчанию, файлу будет задано имя в формате Components - <Дата> - <Время>.zip.
  5. Нажмите кнопку Save, чтобы начать загрузку и формирование zip-архива. Будет создан пакет интегрированной библиотеки (*.LibPkg), со сформированными и добавленными в него исходными файлами SchLib (с символами, параметрами и ссылками на модели) и PcbLib (с посадочными местами). Далее они упаковываются в zip-архив, который формируется в указанной папке. Информационное диалоговое окно подтвердит успешное создание файла.

Пример загрузки множества выбранных объектов компонентов в zip-архиве.Пример загрузки множества выбранных объектов компонентов в zip-архиве.

Используйте исходные файлы в zip-архиве для быстрого создания интегрированной библиотеки, в которой будут находиться выбранные компоненты.

Итоговый zip-архив с исходными данными загруженных компонентов.Итоговый zip-архив с исходными данными загруженных компонентов.

Чтобы загрузить множество объектов имитационных моделей:

  1. Перейдите к серверной папке, которая содержит интересующие объекты имитационных моделей.
  2. Выберите объекты для загрузки с помощью стандартных сочетаний клавиш для множественного выделения (Ctrl+ЛКМ, Shift+ЛКМ).
  3. Щелкните ПКМ по выделенным объектам и выберите команду Operations » Download selected sim model to folder.
  4. Используйте диалоговое окно Browse For Folder, чтобы определить корневую папку для загрузки моделей.
  5. Нажмите OK – начнется загрузка, с отображением прогресса в отдельном диалоговом окне Downloading.

По завершении загрузки, из диалогового окна Downloading вы сможете просмотреть загруженное содержимое в Проводнике Windows (нажмите Explore).

Пример загрузки множества выбранных объектов имитационных моделей в указанной папке.Пример загрузки множества выбранных объектов имитационных моделей в указанной папке.

В указанной папке будет создана подпапка для каждого выбранного объекта, названная в соответствии с идентификатором Item-Revision ID. Данные выпуска могут быть найдены в подпапках Released.

Доступ к данным объектов имитационных моделей, включенных в пакетную загрузку.Доступ к данным объектов имитационных моделей, включенных в пакетную загрузку.

Пакетное изменение состояния жизненного цикла

Связанная страница: Управление жизненным циклом объектов

У всех проектных объектов, которые хранятся на сервере управляемых данных, есть состояние жизненного цикла (Lifecycle State). Состояние жизненного цикла отражает готовность этого объекта к использованию. Например, объект может быть в состоянии New From Design (Новый из проекта), In Production (В производстве) или Deprecated (Нерекомендуемый). Состояние жизненных циклов множества объектов можно изменить в едином пакетном процессе.

Чтобы выполнить пакетное изменение, сделайте следующее:

  1. Выберите нужные объекты в панели Explorer.
  2. Щелкните ПКМ и выберите команду Operations » Change state из контекстного меню.
  3. Будет открыто диалоговое окно Batch state change. В столбце Next State будет представлено следующее состояние жизненного цикла по умолчанию для каждого объекта. Его можно изменить для отдельных объектов, но для быстрого определения нужного состояния для множества объектов также поддерживается редактирование множества выбранных записей.
  4. После того, как нужное следующее состояние Next State задано, нажмите кнопку Process, чтобы применить изменения состояния жизненного цикла.
  5. Будет открыто диалоговое окно Confirm. Если необходимо, введите здесь комментарий (который будет храниться в истории объекта) и нажмите Yes, чтобы завершить пакетное изменение состояния жизненного цикла.

Пример быстрого изменения состояния жизненного цикла двух объектов компонентов.Пример быстрого изменения состояния жизненного цикла двух объектов компонентов.

Интерактивные URL-адреса

Для дальнейшего повышения удобства использования сервера управляемых данных, панель Explorer поддерживает интерактивные URL-адреса. Эту функциональность можно найти в различных местах, в том числе:

  • При щелчке мышью по параметру объекта компонента, который является URL-адресом, во внешнем веб-браузере будет открыта целевая страница.
  • При щелчке мышью по URL-адресу в информации о цепочке поставок объекта компонента, во внешнем веб-браузере будет открыта целевая страница.
  • При щелчке мышью по документу в области Released Documents из вкладки аспектного вида Preview ревизии объекта PCB Fabrication Data Item, PCB Assembly Data Item или PCB Project Design Item, будет открыт этот документ.
Для параметров объектов компонентов и выпущенных документов объектов, относящихся к проектам, эта функциональная возможность также доступна при просмотре полной информации об объекте непосредственно в Altium Designer. Чтобы открыть этот просмотр, щелкните ПКМ по записи объекта в панели Explorer и выберите Full Item History из контекстного меню.

Для выпущенного объекта компонента на сервере управляемых данных, на вкладке аспектного вида Preview представлена область параметров этого компонента. Для параметра, значением которого является URL, например, даташит, спецификация упаковки или веб-сайт производителя, щелкните мышью по этому URL, чтобы открыть его во внешнем веб-браузере.

Значением такого параметра может быть URL-ссылка (начинающаяся с http:// или www.), ссылка на FTP, ссылка на общую сетевую папку или ссылка на локальную папку.
Если ссылка ведет на документ PDF, этот документ будет открыт либо в браузере, либо во внешнем средстве просмотра документов PDF, в соответствии с заданными для браузера настройками.

Пример интерактивных URL-адресов параметров на вкладке аспектного вида Preview объекта компонента в панели Explorer.Пример интерактивных URL-адресов параметров на вкладке аспектного вида Preview объекта компонента в панели Explorer.

У каждого выпущенного объекта компонента на сервере управляемых данных может быть задана информация о цепочке поставок в виде вариантов выбора компонента (Part Choices). Они представлены на вкладке аспектного вида Part Choices. Источником фактических данных о цепочке поставок является локальный каталог компонентов сервера и соответствующий источник компонентов – агрегированная база данных компонентов Altium Parts Provider (которая сама взаимодействует со включенными поставщиками и собирает компоненты от них) или подключенная локальная база данных компонентов (источник компонентов, настроенный как Custom Database Parts Provider). Интерактивными URL-адресами, связанными с вариантом выбора компонента, являются:

  • Название производителя и номер компонента производителя – интерактивная ссылка на веб-сайт Octopart, предоставляющий информацию об этом компоненте производителя.
  • Номер компонента поставщика (в плитке SPN) – интерактивная ссылка на веб-сайт поставщика этого компонента.

Щелкните мышью по URL-адресу, чтобы открыть ее во внешнем веб-браузере.

Пример интерактивных URL-адресов, связанных с вариантом выбора объекта компонента на сервере.Пример интерактивных URL-адресов, связанных с вариантом выбора объекта компонента на сервере.

После выпуска проекта – печатной платы (объект PCB Fabrication Data Item) или печатного узла (объект PCB Assembly Data Item) – вы можете открыть любой документ этого проекта. Сначала убедитесь, что вы просматриваете папку нужного проекта в его классическом виде (нажмите кнопку  в верхней правой части панели Explorer и выберите команду Classic View из меню). Найдите нужную ревизию объекта и переключитесь на вкладку аспектного вида Preview этой ревизии. Затем в области Released Documents наведите курсор мыши на какой-либо сформированный выходной документ – курсор изменит свой вид, как для URL-адресов. Щелкните мышью по URL, чтобы открыть документ. Документы Altium Designer будут открыты для просмотра непосредственно в Altium Designer. Документы не в формате Altium Designer, такие как выходные файлы PDF, Excel-отчеты о составе изделия, будут открыты в подходящем программном приложении (если оно установлено).

Эти функциональные возможности также поддерживаются для исходных данных проекта, выпущенных автоматически в следующую ревизию подходящего объекта PCB Project Design Item с помощью средства Project Releaser. Документы открываются только для просмотра, без возможности редактирования. В отдельно открытом документе схемы об этом гласит соответствующий водяной знак.
Документ также может быть открыт для просмотра с помощью команды View контекстного меню.

Щелкните мышью, чтобы открыть выпущенный документ. Документы не в формате Altium Designer будут открыты в соответствующих приложениях (где это применимо).Щелкните мышью, чтобы открыть выпущенный документ. Документы не в формате Altium Designer будут открыты в соответствующих приложениях (где это применимо).

Поддержка многосекционных компонентов

При просмотре символа объекта многосекционного компонента, на вкладке аспектного вида Preview графика каждого символа будет отображена в отдельной вкладке. Кроме того, в меню Place будет представлено подменю всех подходящих компонентов, которые могут быть размещены для этого объекта компонента.

Перейдите к нужному многосекционному объекту компонента на сервере управляемых данных и убедитесь, что активна вкладка аспектного вида Preview. Символы отдельных секций можно просмотреть в области предварительного просмотра. Щелкните мышью по вкладке в нижней части для выбора секции.

Просмотр секций объекта многосекционного компонента на уровне компонента.Просмотр секций объекта многосекционного компонента на уровне компонента.

Дважды щелкните мышью по записи дочернего объекта символа, чтобы перейти к входящим в состав компонента секциям на уровне символа. Опять же, убедитесь, что активна вкладка Preview.

Просмотр секций объекта многосекционного компонента на уровне дочернего символа.Просмотр секций объекта многосекционного компонента на уровне дочернего символа.

При размещении ревизии объекта многосекционного компонента на листе схемы щелкните ПКМ по записи ревизии и наведите курсор на команду Place, чтобы отобразить подменю, содержащее в себе все секции этого компонента. Выберите нужную для размещения секцию.

С помощью перетаскивая мышью из панели Explorer можно разместить только первую секцию (Part A) компонента.

Подменю размещения со всеми компонентами многосекционного компонента.Подменю размещения со всеми компонентами многосекционного компонента.

Копирование-вставка структуры папок сервера

Для повышения гибкости управления данными на сервере, панель Explorer поддерживает возможность копирования и вставки папок (и их вложенной структуры). По сути, это позволяет быстро клонировать области структуры серверных папок, что может значительно сэкономить время, например, при подготовке сервера к большому количеству данных о компонентах, где структура родительской папки и подпапок для различных доменных моделей схожа.

Для использования этой возможности выполните следующее:

  1. Выберите в существующей структуре папку, структуру которой вы хотите скопировать.
  2. Щелкните ПКМ и выберите команду Operations » Copy Folder Structure из контекстного меню.
  3. Выберите папку, в которую вы хотите вставить клонированную структуру папок.
  4. Щелкните ПКМ и выберите команду Operations » Paste Folder Structure из контекстного меню.

После вставки вы можете внести необходимые изменения в клонированную структуру папок.

Вы можете скопировать только одну выбранную папку (и ее вложенную структуру). Эта команда недоступна, если выбрано множество папок.
Обратите внимание, что будет вставлена только структура папок – объекты в скопированной структуре папок скопированы не будут.

Помните, что при вставке у двух папок не может быть одинаковых названий в одной и той же области структуры папок. Если попытаться сделать это, возникнет ошибка Duplicate Folder HRID. И хотя родительская папка не будет вставлена, будет вставлена ее вложенная структура, на верхний уровень структуры папок. Поэтому если вы хотите быстро создать набор клонированных папок в одной родительской области "дерева", то вы можете вставить структуру папок в другую, временную область главной структуры папок сервера. Затем переименуйте папку верхнего уровня, внесите прочие необходимые изменения и перетащите папку туда, где она должна быть.

Чтобы быстро настроить структура папок сервера, воспользуйтесь копированием и вставкой ветвей структуры.Чтобы быстро настроить структура папок сервера, воспользуйтесь копированием и вставкой ветвей структуры.

Сравнение ревизий объектов

С помощью мощной технологии сравнения файлов в собственном формате Altium Designer, сервер управляемых данных поддерживает визуальное сравнение двух ревизий одного или разных объектов для некоторых типов данных непосредственно в панели Explorer. Доступно сравнение ревизий объектов следующих типов:

  • Component Item
  • Symbol Item
  • Footprint Item
  • Managed Schematic Sheet Item
  • Schematic Template Item
  • PCB Fabrication Data Item
  • PCB Assembly Data Item
  • PCB Project Design Item

В панели Explorer перейдите к нужной папке, выберите две ревизии объектов, которые вы хотите сравнить, затем щелкните ПКМ и выберите Operations » Compare из контекстного меню.

При сравнении двух ревизий объектов Component Item, после нажатия Compare происходит следующая последовательность событий:

  • Сравниваются ревизии подключенных объектов Footprint Item.
  • Сравниваются ревизии подключенных объектов Symbol Item.
  • Сравниваются параметрические данные двух ревизий объектов Component Item.

Результаты сравнения отображаются в диалоговом окне Compare component revisions.

Пример сравнения двух ревизий объектов Component Item.Пример сравнения двух ревизий объектов Component Item.

Диалоговое окно разделено на три области, отображающих результаты сравнения параметрических данных, посадочных мест и символов. Если значения параметров отличаются, их фон будет подсвечен. Для посадочных мест и символов будет отображен текст, обозначающий, являются ли они идентичными (Identical) или нет (Not identical).

Отключите опцию Show unchanged, чтобы оставить только отличающиеся элементы.
Для символов и посадочных мест вы можете запустить сравнение соответствующих ревизий объектов непосредственно из диалогового окна Compare component revisions, щелкнув мышью по элементу управления Compare.

При сравнении двух ревизий объектов Symbol Item, после нажатия Compare осуществляется графическое сравнение, и все найденные различия приводятся в списке в панели Differences. Документы SchLib этих двух ревизий открываются в рабочем пространстве – их отображение рядом друг с другом в окне редактора позволит вам ознакомиться с различиями визуально. Щелкните мышью по папке верхнего уровня найденного различия, чтобы подсветить это различие одновременно в обоих документах.

Это работает так же, как при запуске команды Project » Show Physical Differences для двух исходных документов.

Пример сравнения двух ревизий объекта Symbol Item.Пример сравнения двух ревизий объекта Symbol Item.

При сравнении двух ревизий объектов Footprint Item, после нажатия Compare осуществляется графическое сравнение, и все найденные различия приводятся в списке в диалоговом окне Compare Components.

Это работает так же, как при запуске команды Tools » Update From PCB Libraries в редакторе плат, которая ищет различия между размещенным экземпляром посадочного места и его исходными данными в соответствующей библиотеке.
Обратите внимание, что документы PcbLib двух ревизий не открываются для визуального изучения различий в рабочем пространстве.

Пример сравнения двух ревизий объекта Footprint Item. Исходные библиотеки не открываются в рабочем пространстве – предварительные виды посадочных мест доступны здесь (взятые из панели Explorer) для отображения существующих различий.Пример сравнения двух ревизий объекта Footprint Item. Исходные библиотеки не открываются в рабочем пространстве – предварительные виды посадочных мест доступны здесь (взятые из панели Explorer) для отображения существующих различий.

Посадочное место разбивается на квадратные ячейки, и производится анализ на различия каждой ячейки. Ячейки, где есть различия, отображаются в нормальном цвете, подсвечивая эти различия. Вкладки слоев показывают, у скольких примитивов есть различия на каждом слое, по которым происходит сравнение, и щелчок мышью по вкладке позволяет более детально изучить различия.

При сравнении двух ревизий объектов Managed Schematic Sheet Item, после нажатия Compare осуществляется графическое сравнение, и все найденные различия приводятся в списке в панели Differences. Документы SchDoc этих двух ревизий открываются в рабочем пространстве – их отображение рядом друг с другом в окне редактора позволит вам ознакомиться с различиями визуально. Щелкните мышью по папке верхнего уровня найденного различия, чтобы подсветить это различие одновременно в обоих документах.

Это работает так же, как при запуске команды Project » Show Physical Differences для двух исходных документов.

Пример сравнения двух ревизий объекта Managed Schematic Sheet Item.Пример сравнения двух ревизий объекта Managed Schematic Sheet Item.

При сравнении двух ревизий объектов Schematic Template Item, после нажатия Compare осуществляется графическое сравнение, и все найденные различия приводятся в списке в панели Differences. Документы SchDot этих двух ревизий открываются в рабочем пространстве – их отображение рядом друг с другом в окне редактора позволит вам ознакомиться с различиями визуально. Щелкните мышью по папке верхнего уровня найденного различия, чтобы подсветить это различие одновременно в обоих документах.

Это работает так же, как при запуске команды Project » Show Physical Differences для двух исходных документов.

Пример сравнения двух ревизий объекта Schematic Template Item.Пример сравнения двух ревизий объекта Schematic Template Item.

При сравнении двух ревизий объекта PCB Fabrication Data Item, PCB Assembly Data Item или PCB Project Design Item, результаты сравнения будут представлены в диалоговом окне Compare Project Revisions. Это будет сравнение сформированной структуры файлов и проверка файлов в этой структуре. Для отображения того, что файлы были изменены, не изменены, добавлены или удалены, используется цветовая индикация. Вы можете включать/отключать отображение этих элементов.

Убедитесь, что вы просматриваете папку нужного проекта в его классическом виде (нажмите кнопку  в верхней правой части панели Explorer и выберите команду Classic View из меню).

Пример сравнения двух ревизий объекта PCB Assembly Data Item.Пример сравнения двух ревизий объекта PCB Assembly Data Item.

Возможность клонирования серверных объектов

Панель Explorer позволяет клонировать различные серверные объекты. Вместо создания с нуля нужного компонента, доменной модели, схемного листа или шаблона, вы можете клонировать объект. Прямое редактирования обеспечит простое внесение изменений в копию исходных данных ревизии объекта и выпуск этих изменений в начальную ревизию нового объекта того же типа. Таким образом, вы можете создать нужные управляемые данные в рекордно короткие сроки.

Можно клонировать объекты следующих типов:

  • Component Item
  • Footprint Item
  • Symbol Item
  • Simulation Model Item
  • Component Template Item
  • Managed Schematic Sheet Item
  • Schematic Template Item
  • Project Template Item
  • Draftsman Document Template Item
  • Draftsman Sheet Template Item
  • Layerstack Item
  • BOM Template Item
  • OutputJob Item
  • Script Item

Доступ к командам для клонирования объекта одного из поддерживаемых типов осуществляется в панели Explorer следующими способами:

  • Щелкните ПКМ по записи исходной ревизии объекта и выберите команду Operations » Clone из контекстного меню.
  • Выберите запись исходной ревизии объекта и используйте сочетание клавиш Ctrl+D.

Команда Clone доступна в панели Explorer, где присутствует подходящая ревизия объекта, в том числе:

  • В главном списке объектов в папке.
  • На вкладке аспектного вида Children (при просмотре объекта Component Item или Managed Schematic Sheet Item).
  • На вкладке аспектного вида Where-used (при просмотре объекта Component Item, Symbol Item, Footprint Item, Simulation Model Item, Component Template Item или Schematic Template Item).
  • На вкладке аспектного вида Preview (при просмотре объекта Component Item, Managed Schematic Sheet Item или Schematic Template Item).
При просмотре главного списка объектов в определенной папке, вызовите команду Clone из записи верхнего уровня объекта, чтобы клонировать самую новую ревизию этого объекта.

Когда найдена нужная ревизия объекта и запущена команда Clone, процесс будет осуществлен следующим образом:

  1. Будет запущен сеанс прямого редактирования, где копия исходного документа, сохраненная в выбранной ревизии объекта, будет открыта в соответствующем временном редакторе. Для ревизии объекта Project Template Item, временная копия проекта будет открыта для редактирования в панели Projects.
  2. Внесите необходимые изменения.
  3. Сохраните документ.
  4. Нажмите кнопку  в панели быстрого доступа Quick Access Bar, чтобы выпустить документ на сервер (сочетание клавиш Ctrl+Alt+S). Для шаблона проекта, выберите команду Release to server, доступную в контекстном меню записи проекта в панели Projects. Будет открыто диалоговое окно Create New Item. По умолчанию, клонированный объект будет использовать ту же схему именования ревизий и определение жизненного цикла, что и исходный объект, и он будет создан в той же папке. Эти свойства можно изменить, если необходимо. Убедитесь, что новому объекту заданы название (Name) и описание (Description).
  5. После того, как свойства объекта заданы нужным образом, нажмите OK. Будут созданы новый объект и его начальная ревизия, документ будет выпущен и временный редактор будет закрыт. Результат клонирования будет отображен в панели Explorer.

Доступ к параметрическому виду компонентов

Папка типа Components поддерживает два режима отображения: классический вид (Classic View) и вид компонентов (Components View). Второй вариант является режимом по умолчанию для папок этого типа, и он позволяет просматривать параметрические данные, связанные со всеми объектами Component Item в текущей папке. Более того, вы можете настроить необходимый вид для различных папок компонентов, и эта настройка будет сохранена между сеансами.

Для переключения между этими двумя режимами отображения перейдите в папку компонентов в панели Explorer, нажмите кнопку  вверху спрва от списка компонентов и выберите команду View » Classic View или View » Components View из соответствующего меню.

Включите вид Components View в папке компонентов для отображения параметрических данных объектов компонентов. Наведите курсор мыши на изображение, чтобы увидеть результат переключения на вид Classic View.Включите вид Components View в папке компонентов для отображения параметрических данных объектов компонентов. Наведите курсор мыши на изображение, чтобы увидеть результат переключения на вид Classic View.

Для получения более подробной информации по работе с видом Components View обратитесь к разделам ниже.

Каждый столбец в этом режиме отображения соответствует определенному параметру. Настройка того, какие столбцы должны отображаться, т.е. какая информация о параметрах должна быть представлена, осуществляется из диалогового окна Select Columns. Откройте диалоговое окно, щелкнув ПКМ в области заголовков столбцов и выбрав команду Select Columns из контекстного меню.

По умолчанию представлены следующие параметры: Revision ID, Revision State, Name, Description.

Диалоговое окно Select Columns является центром управления для определения того, такие параметрические данные должны быть отображены в режиме Components View. Наведите курсор мыши на изображение, чтобы увидеть пример, где выбраны дополнительные параметры и где на виде отображаются дополнительные столбцы.Диалоговое окно Select Columns является центром управления для определения того, такие параметрические данные должны быть отображены в режиме Components View. Наведите курсор мыши на изображение, чтобы увидеть пример, где выбраны дополнительные параметры и где на виде отображаются дополнительные столбцы.

Порядок столбцов доступен для настройки. Зажмите ЛКМ на заголовке столбца и перетащите его в горизонтальном направлении в новое место. Корректное положение подсвечивается вертикальными стрелками-указателями.

Либо измените порядок в списке Selected Columns в диалоговом окне Select Columns. Перетащите мышью запись параметра в нужное новое положение в списке.
За исключением столбца, содержащего в себе иконку компонента, ширину столбцов можно изменять перетаскиванием с зажатой ЛКМ правого разделителя заголовка столбца.

Компоненты могут быть сгруппированы по заголовкам видимых столбцов. Для этого зажмите ЛКМ на заголовке столбца и перетащите его в область текста Drag a column header here to group by that column.

Путем формирования вложений заголовков столбцов может быть создана иерархия групп. В области сгруппированных столбцов используйте перетаскивание для переопределения "порядка сортировки" групп необходимым образом. Крайняя левая запись заголовка столбца является верхним уровнем иерархии.

Пример пользовательской группировки (по параметрам Case/Package и Value).Пример пользовательской группировки (по параметрам Case/Package и Value).

Параметры могут быть отсортированы по определенному столбцу щелчком ЛКМ по заголовку этого столбца. Щелкните ЛКМ один раз, чтобы отсортировать по возрастанию (на основе содержимого этого столбца). Щелкните ЛКМ еще раз, чтобы отсортировать по убыванию.

Вы можете задать сортировку по множеству столбцов. Когда параметры уже отсортированы по определенному столбцу, используйте Shift+ЛКМ для другого столбца, чтобы задать "сортировку более низкого уровня" по содержимому этого столбца.

Чтобы удалить сортировку по столбцу, используйте Ctrl+ЛКМ на его заголовке.

Подобно электронной таблице Excel, параметры можно отфильтровать по содержимому каждого столбца. Для этого щелкните мышью по небольшой иконке воронки (фильтра), расположенной в правой части заголовка столбца (). Будет открыто меню, содержащее в себе флажки для каждого значения в этом столбце. Включите нужные флажки и нажмите OK, чтобы в списке отображались только параметры с этими значениями.

Когда к столбцу применен фильтр, иконка фильтра отображается синим цветом (), что означает, что применен фильтр на основе этого столбца. Фильтрация может быть применена ко множеству столбцов данных. Каждый новый фильтр столбца добавляется как дополнительное условие к общему фильтру (т.е. будут отображены только те записи ссылок на модели, которые соответствуют всем условиям фильтра). Текстовое представление текущей фильтрации представлено в нижней части области.

Пример действующей фильтрации столбцов.Пример действующей фильтрации столбцов.

Чтобы очистить фильтрацию по столбцу, выберите (Select All) из выпадающего списка фильтра. Чтобы полностью удалить фильтрацию, нажмите кнопку  справа от текстового представления фильтра. Чтобы отключить фильтр, снимите флажок слева от его текстового представления. Чтобы снова включить его, поставьте флажок.
Доступна история недавно использовавшихся фильтров. Щелкните мышью по кнопке выпадающего списка справа от текстового представления фильтра, чтобы отобразить историю. Эта кнопка отображается, когда ранее был применен хотя бы один фильтр.

Отображение только самых новых ревизий объектов

При разработке проектных объектов на сервере, они могут претерпевать различные изменения, каждое из которых приводит к созданию новой ревизии для хранения измененных данных. При просмотре объектов, как правило, нужны лишь их самые новые ревизии, в то время как предыдущие ревизии могут мешать просмотру. Поэтому в панели Explorer по умолчанию отображаются только самые новые ревизии объектов.

Чтобы отображать все ревизии объектов в панели Explorer, щелкните мышью по элементу управления  вверху справа от области Items панели и отключите опцию Show only latest в соответствующем меню.

Эта опция является глобальной настройкой, которая применяется ко всем объектам на сервере, независимо от их типа и папки, в которой они находятся.

По умолчанию, в панели Explorer отображаются только самые новые ревизии объектов. Наведите курсор мыши на изображение, чтобы увидеть пример, когда соответствующая опция отключена.По умолчанию, в панели Explorer отображаются только самые новые ревизии объектов. Наведите курсор мыши на изображение, чтобы увидеть пример, когда соответствующая опция отключена.

Чтобы вернуться к отображению только самых новых ревизий, снова щелкните мышью по этой опции.

Отображение скрытых ревизий

Связанная страница: Управление видимостью и возможностью применения ревизий объектов

Если ревизия объекта переходит в состояние жизненного цикла, у которого отключен параметр Visible in Vault panels, то по умолчанию эта ревизия не будет отображаться в панели Explorer. Если эта ревизия объекта является самой новой, то запись этого объекта будет скрыта. Видимость, заданную на уровне состояния, можно переопределить глобально для всех объектов.

Для отображения всех ревизий объектов, которые в данный момент не отображаются, щелкните мышью по элементу управления  вверху справа от области Items панели и включите опцию Show Hidden Revisions в меню.

Отображение скрытых ревизий объектов при просмотре содержимого в панели Explorer. Наведите курсор мыши на изображение, чтобы увидеть результат.Отображение скрытых ревизий объектов при просмотре содержимого в панели Explorer. Наведите курсор мыши на изображение, чтобы увидеть результат.

Управление видимостью параметров при размещении управляемых компонентов

При размещении компонентов непосредственно из панели Explorer, управление видимостью связанных с этими компонентами параметров (или, точнее, их значений) осуществляется из диалогового окна свойств родительской папки.

Типом папки должен быть Components.

Щелкните ПКМ по родительской папке и выберите команду Properties. Будет открыто диалоговое окно Edit Folder. Включите опцию Configure Parameters Visibility on Add справа. В списке в этой области будут отображены параметры, взятые из всех компонентов в папке. Используйте флажок в столбце Visible On Add, связанный с параметром, для управления его видимостью при размещении компонента с этим параметром на листе схемы.

В список также включен параметр Name/Comment. Этот параметр является системным.
Информация о видимости параметров хранится на самом сервере в свойствах серверной папки, и она является глобальной для всех пользователей сервера, кому была опубликована соответствующая папка. Также учитывается иерархия папок, поэтому видимость параметров, настроенная для родительской папки, будет применена ко всем дочерним папкам.

На уровне папки задайте, какие параметры должны быть видимыми при размещении в проекте компонентов, которые используют эти параметры.На уровне папки задайте, какие параметры должны быть видимыми при размещении в проекте компонентов, которые используют эти параметры.

Копирование информации о параметрах компонента в буфер обмена

Информацию о параметрах ревизии объекта Component Item можно скопировать в буфер обмена для ее последующего использования где-либо в проекте или для вставки во внешнее приложение (например, Microsoft Excel). При просмотре вкладки аспектного вида Preview ревизии объекта Component Item выберите нужные параметры в области Parameters и используйте сочетание клавиш Ctrl+C либо щелкните ПКМ в области и выберите команду Copy из контекстного меню.

Для выбора множества параметров используйте стандартные сочетания (Ctrl+ЛКМ, Shift+ЛКМ).

Скопируйте информацию о параметрах ревизии объекта Component Item в буфер обмена для ее последующего использования.Скопируйте информацию о параметрах ревизии объекта Component Item в буфер обмена для ее последующего использования.

Экспорт таблицы данных

Панель Explorer поддерживает экспорт данных из табличного вида в файл формата csv или xls. Примеры, где доступна эта возможность:

  • Таблица объектов Component Item (как в режиме Classic View, так и в режиме Components View).
  • Таблица объектов.
  • Таблица подключенных моделей на вкладке аспектного вида Preview (для выбранного объекта Component Item).
  • Таблица результатов поиска.
  • Таблица объектов на вкладке аспектного вида Where-used.
  • Таблица объектов на вкладке аспектного вида Children.

Щелкните ПКМ в таблице и выберите команду Operations » Export Data из контекстного меню. Будет открыто диалоговое окно Select columns for data export. Используйте его, чтобы определить, какие данные нужно экспортировать. Диалоговое окно содержит в себе все возможные столбцы таблицы. Те, которые в данный момент отображаются в панели, по умолчанию включены для экспорта. При нажатии OK будет открыто стандартное диалоговое окно Windows Save As. Используйте его, чтобы задать, где и под каким именем будет сохранен экспортированный файл. Используйте поле Save as type, чтобы выбрать формат файла – файл с разделенными запятыми данными (*.csv) или файл Excel (*.xls).

Прогресс экспорта отображается в диалоговом окне Export Data. После успешного экспорта используйте кнопку Explore, чтобы быстро перейти к папке экспорта. Либо используйте кнопку Open, чтобы открыть сам файл.

Пример экспортированных данных (моделей, подключенных к выбранной ревизии объекта Component Item) в файл формата Excel.Пример экспортированных данных (моделей, подключенных к выбранной ревизии объекта Component Item) в файл формата Excel.

Изменение на лету типа выпущенного компонента

После выпуска одного или множества компонентов вы можете на лету изменить их тип на совершенно другой. В панели Explorer выберите ревизии компонентов, которые вы хотите изменить, затем щелкните ПКМ и выберите команду Operations » Change component type из контекстного меню. Будет открыто диалоговое окно Component Type, в котором вы можете выбрать новый тип компонента.

Пример изменения типа компонента для выбранных ревизий объектов Component Item, которые были выпущены с неправильным типом.Пример изменения типа компонента для выбранных ревизий объектов Component Item, которые были выпущены с неправильным типом.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: