Altium NEXUS Documentation

Accessing, Defining & Managing Project Options in Altium NEXUS

Created: 21.03.2022 | Updated: 20.05.2022
Javascript

Tabs of the Project Options dialog

Summary

An existing or newly created project is associated with a range of option settings that are specific to that project. These are stored in the project file (*.PrjPcb, for example) and will vary depending on the type of project. The option settings are configured in the Project Options dialog.

Access

The Project Options dialog is accessed in one of the following ways:

  • Right-click on the project entry in the Projects panel then click Project Options from the context menu.
  • Click the  icon in the Projects panel when the desired project is focused in the panel.
  • From any editor, select Project » Project Options from the main menus.

Dialog Tabs

The General tab of the Project Options dialog enables you to control the online availability and synchronization of a Workspace project available in an Altium 365 Workspace.

This tab of the Project Options dialog is available only when connected to an Altium 365 Workspace.

Options/Controls

When accessed for a non-Workspace project, the General tab of the Project Options dialog will only display the Make Project Available Online button. Click the button to open the Make Available Online dialog, which will add your project to the Workspace after going through the necessary steps. Once completed, all options within the dialog tab will be available:

General

  • Description - use this field to provide an optional description of the project, which will be reflected in the description field when browsing your project within the Workspace browser interface.

Online Availability and Synchronization

  • Version Control - checking this box will reflect the current style of online availability. Enable this option to store this project under VCS within the Workspace's Versioned Storage Git design repository, or disable it to partake in simple synchronization. Enabling formal version control allows multiple users to work on this project given that it will be shared with all other contributors connected to your Workspace.
  • Migrate to Altium 365 Versioned Storage - enable this option to migrate a project that uses an external VCS system to Altium 365 Workspace Native VCS. The converted design project, which will retain the previous history of VCS commits, can then benefit from the Workspace's native VCS-enabled features, such as the event-based history timeline. This option is available only for a mirrored project.
  • Server Folder - the Workspace folder in which the project resides.
  • Enable Conflict Prevention Notifications - enable this option to manage file editing access by receiving an alert when a team member is editing the same document from a managed project to avoid the possibility of data conflicts.

  • Turn Off Synchronization - click this button to turn off synchronization, which ensures that the local project copy will no longer be linked to the one that resides on the Workspace. The project located on the Workspace will remain untouched.

    Note that if you are making a local project available online again after having turned off synchronization, you may need to change the project name. Since turning off synchronization does not remove the project in the Workspace, this project, with the same name and folder location, may still exist. If you need to have the same project name, then the previous project instance in the Workspace can always be removed.

The Error Reporting tab of the Project Options dialog enables you to define the reporting levels for each of the possible electrical and drafting violations that can exist on source schematic documents when validating the project. When the project is validated, these violation settings will be used in conjunction with the settings on the Connection Matrix tab to test the source documents for connectivity violations.

For information about PCB design validation and a reference describing possible design violations, refer to Verifying Your Design Project.

For information about Multi-board design validation and a reference describing possible design violations, refer to Multi-board Schematic Validation and Configuring the Verification Options.

When working with an Integrated Library project (*.LibPkg), the Error Reporting tab is part of the Options for Integrated Library dialog - a variation of the dialog described here. Only those violation types pertinent to validation of this project type will be listed.

Options/Controls

Violations List

This list presents all possible electrical and drafting violations that can exist on the source documents of the project. Violations themselves are gathered into the following categories:

Each specific violation type is presented with the following fields:

  • Violation Type Description - a short description of the type of violation.
  • Report Mode - use this field to specify the severity level associated with violating the check. Use the drop-down to choose from the following reporting levels:

Right-Click Menu

The following commands are available from the right-click menu:

  • All Off - set the Report Mode for all violation types to No Report.
  • All Warning - set the Report Mode for all violation types to Warning.
  • All Error - set the Report Mode for all violation types to Error.
  • All Fatal - set the Report Mode for all violation types to Fatal Error.
  • Selected Off - set the Report Mode for all selected violation types to No Report.
  • Selected To Warning - set the Report Mode for all selected violation types to Warning.
  • Selected To Error - set the Report Mode for all selected violation types to Error.
  • Selected To Fatal - set the Report Mode for all selected violation types to Fatal Error.
  • Default - set the Report Mode for all violation types back to their default settings.
Multiple violation types can be selected using standard multi-select techniques (Ctrl+Click, Shift+Click).
  • Report Suppressed Violations in Messages Panel - enable this option to display violations in the Messages panel even if they have been suppressed through this tab.

Additional Option

  • Set To Installation Defaults - click to set the options of the tab to installation defaults.

The Connection Matrix tab of the Project Options dialog delivers a matrix providing a mechanism to establish connectivity rules between component pins and net identifiers, such as Ports and Sheet Entries. It defines the logical or electrical conditions that are to be reported as warnings or errors. For example, an output pin connected to another output pin would normally be regarded as an error condition, but two connected passive pins would not. When the project is validated, these violation settings will be used (in conjunction with the defined settings on the Error Reporting tab) to test the source documents for violations.

Options/Controls

Connection Matrix

The matrix presents all possible wiring connection checks between combinations of pins, ports, and sheet entries, as well as testing for unconnected entities. The matrix is read in an across/down fashion and the color of the matrix element at the row-column intersection specifies how the Compiler will respond when testing for that particular condition.

To change the reporting mode for a violation check in the matrix, click on the colored square where the row and column of two entities intersect. Each time you click, the mode will move to the next report level. The following levels are supported:

  • No Report
  • Warning
  • Error
  • Fatal Error
As you hover over a square, text is displayed below the matrix to describe the connectivity violation and the reporting mode in force.

Right-Click Menu

The following commands are available from the right-click context menu:

  • All Off - set all entries in the matrix to No Report.
  • All Warning - set all entries in the matrix to Warning.
  • All Error - set all entries in the matrix to Error.
  • All Fatal - set all entries in the matrix to Fatal Error.
  • Default - set all entries to their defaults.

Additional Option

  • Set To Installation Defaults - click to set the options of the tab to installation defaults.

This tab of the Project Options dialog enables you to configure and control class generation. Classes are a logical collection of a particular type of design object. For example, a group of related components could be grouped into their own Component Class, which could then be used as the basis for creating a targeted rule. This tab provides controls to determine which classes are automatically generated and which user-defined classes are generated when the source schematic documents are synchronized with the PCB design document.

Access

This tab is one of multiple available when configuring the options for a project and is accessed from within the Project Options dialog. To access the Project Options dialog:

  • From the PCB or schematic editor, click Project » Project Options.
  • Right-click on the project name on the Projects panel then click Project Options from the context menu.

Options/Controls

Automatically Generated Classes

  • Generate Net Classes for Buses - check this option to automatically generate a net class for each bus in the design. The members of a class will be the individual constituent nets of the bus (from which that class was generated).

    A generated net class will be named using the name of the bus.
  • Generate Net Classes for Components - check this option to automatically generate a net class for each component in the design. The members of a class will be the associated nets to which the pins of the component (from which that class was generated) are connected.

    A generated net class will be named using the designator of the component in the format <ComponentDesignator>_Nets.
  • Generate Separate Net Classes for Bus Sections - check this option to automatically generate a separate net class for each bus section. A bus section is created by specifying a bus which is actually a section of a larger bus, for example, D[15..8], from the bus D[15..0].
  • Generate Net Classes for Named Signal Harnesses - enable this option to automatically generate a net class for each named signal harness in the design. The members of a class will be the nets associated with the signals gathered by the named signal harness (from which the class was generated).

    A named signal harness is one that has a net label attached to it. A generated net class will be named using the name of the net label attached to the signal harness.
  • Sheet-Level Class Generation Grid - this region allows you to control the automatic generation of component and/or net classes at the individual schematic sheet level. All source schematic sheets for the project are listed with the following information presented for each:
    • Sheet Name - the name of the schematic document.
    • Full Path - the absolute path to the folder in which the document resides.
    • Component Classes - check this option to have a component class generated for the sheet.
    • Net Classes Scope - use this field to determine whether to have a net class generated for the sheet and, if so, the scope of generation. The field's drop-down provides the following choices:
      • None - do not generate a net class for this sheet.
      • Local Nets Only - generate a net class for this sheet but only containing member nets that are local to the sheet.
      • All Nets - generate a net class for this sheet that contains all member nets associated with the sheet (local and those that go elsewhere).
    • Structure Classes Generate Structure - check this option to have a structure class generated for the sheet.

      A Structure Class is a special type of class that can hold, as its members, any type of class (net class, component class, etc.). By automatically generating a Structure Class from each schematic sheet in the project – containing components and/or nets – when transferring the design to the PCB, the structure of the project can be faithfully represented on the PCB side. Structure Classes not only allow for the reproduction of the schematic document structure within the PCB domain, for advanced navigation, but can also be used in logical queries, for example when scoping design rules, or filtering.

Enable/disable component class generation or set the scope for net class generation as a whole using commands available from the right-click context menu for a column. Multiple sheet entries can be selected using standard multi-select techniques (Ctrl+Click, Shift+Click, Click&Drag).
For components and/or nets on the top sheet, the respective component and/or net class will be named using the schematic document name. For components and/or nets on child sheets, the respective component and/or net classes will be named using the sheet symbol designators.
The text at the bottom of this region dynamically changes based on the choices made and provides a summary of which classes will be automatically generated.

User-Defined Classes

  • Generate Component Classes - check this option to generate user-defined component classes when the design is transferred to the PCB. Component classes are manually defined on the schematic by adding a ClassName parameter to targeted components and setting its value to the desired class name.
  • Generate Rooms for Component Class - check this option to generate rooms based on the user-defined component classes. These components need to have the component parameter with 'ClassName' as its parameter name.
  • Generate Net Classes - check this option to generate user-defined net classes when the design is transferred to the PCB. Net classes are manually defined on the schematic through the use of the Net Class directive. To make a net a member of a Net Class, attach a Net Class directive to the relevant wire or bus (or a blanket) and set the value of its ClassName parameter to the desired class name.

Learn how to create a user-defined Net Class

Learn how to create a user-defined Component Class

Additional Option

  • Set To Installation Defaults - click to set the options of the tab to installation defaults.

Notes

  • To generate classes (automatic and/or user-defined) when transferring the design to the PCB, you must ensure that the respective Comparator settings have been set to Find Differences on the Comparator tab of the Project Options dialog, as follows:
    • Net Classes - set the Extra Net Classes comparison type (in the Differences Associated with Nets category) to Find Differences.
    • Component Classes - set the Extra Component Classes comparison type (in the Differences Associated with Components category) to Find Differences.
  • In addition, on the ECO Generation tab of the Project Options dialog, you must ensure that the respective ECO settings have been set to Generate Change Orders.
    • Net Classes - set the Add Net Classes modification type (in the Modifications Associated with Nets category) to Generate Change Orders.
    • Component Classes - set the Add Component Classes modification type (in the Modifications Associated with Components category) to Generate Change Orders.

The Comparator tab of the Project Options dialog enables you to define which types of differences to find and which to ignore when comparing documents. For each possible comparison, you can choose to either find or ignore differences using the associated drop-down in the Mode column. You can set up to find differences with components, nets, parameters, and physical objects as required.

Options/Controls

This dialog is divided into two main regions:

  • The upper region, titled Comparison Type Description/Mode, lists the description and comparison mode of each available comparison type.
  • The lower region, titled Object Matching Criteria, is used to define the matching criteria for NetNet ClassComponent Class, Differential Pair, and Structure Class.

Comparison Type Description/Mode

  • Comparison Type Description - this region lists the descriptions of each available comparison type within the project. Use the scroll bar on the far right to scroll to Differences Associated with ComponentsDifferences Associated with NetsDifferences Associated with Parameters, Differences Associated with Physical, and Differences Associated with Structure Classes in order to view/change comparison modes within each area.
  • Mode - click on an entry to change the comparison mode using the drop-down:
    • Find Differences - select this option to find differences within that comparison type.
    • Ignore Differences - select this option to ignore any differences within that comparison type (no comparison will be done for that comparison type).

      If Mode is set to Ignore Differences, any differences that exist of that type will not be shown in the Differences between dialog when a comparison is performed.

Object Matching Criteria

  • Object Type - list of types of objects such as Net, Net Class, Component Class, Differential Pair, and Structure Class.
  • Min Match % - enter desired minimum match percentage value or click in the right side of the column then use the up and down arrow keys to increase or decrease value.
  • Min Matched Members - enter the desired minimum matched members or click in the right side of the column then use the up and down arrow keys to increase or decrease value.
  • Use Name Matching - click entry or use the drop-down to select After member matching or Never.
  • Show Manual Matching Dialog - click entry or use the drop-down to select For unmatched objects or Never.

Additional Options

  • Ignore Rules Defined in PCB Only - check this option to ignore rules defined in the PCB only within the design project. For instance, when you do an engineering order change, changes can be applied from schematic to PCB and if this option is enabled, the rules in PCB only are ignored. If there are no corresponding rules in schematic sheets of the same project, then the comparator will not try to add new rules.
  • Set To Installation Defaults - click to set the options of the tab to installation defaults.

The ECO Generation tab of the Project Options dialog enables you to configure which modification types can be included when generating an Engineering Change Order (ECO) based on differences found by the Comparator.

Configuration of modification types on this tab should be performed in conjunction with configuration of the comparison types on the Comparator tab of the Project Options dialog.

Options/Controls

Modification Type list

This list presents all possible modifications that can be made through an Engineering Change Order when synchronizing the source schematic documents with the PCB design document. The list entries include categories for modification types associated with Components, Nets, Parameters, Structure Classes, etc.

Each specific modification type includes the following fields:

  • Modification Type Description – this is a short description of the type of modification (the action to be taken by the Synchronizer).
  • Mode – use this field to control whether the modification type is included in any generated ECO or not. Use the drop-down to choose from the following:
    • Generate Change Orders - include the modification type in a generated ECO.
    • Ignore Differences - exclude the modification type from a generated ECO.
If a modification type has its Mode set to Ignore Differences, any design update that results in an action of that modification type will not be transferred to the Engineering Change Order dialog when the ECO is created. The modification action will also be excluded from the ECO if the modification type has its Mode set to Generate Change Orders and the relevant source comparison type is set to Ignore Differences.

Right-Click Menu

The following command is available from the right-click context menu:

  • Report – use this command to generate a report of the currently configured modification modes. The Report Preview dialog will appear with the report already loaded. Use this dialog to inspect the report using various page/zoom controls before ultimately exporting it to file or printing it.

Additional Options

  • Push Component Designator Changes to Annotation File (if any) – check to include component designator changes in the annotation file.
  • Set To Installation Defaults – click to set the options of the tab to installation defaults.

The Options tab of the Project Options dialog enables you to specify the output path and related options for generated outputs for the project. You can also specify various netlisting options and the Net Identifier Scope.

Options/Controls

  • Output Path – the default output path for the generation of output files from the current design project (*.PrjPcb).
  • ECO Log Path – the default output path for ECO log files.
  • Schematic Template Location – use this field to specify a directory in which to source schematic template files (*.SchDot, *.SchDoc) for the project.
Use the browse icon to the right of each of the above fields to search for and select a different path/location.

Output Options

  • Open outputs after compile – enable to open files that were generated after compiling the design project.
  • Timestamp folder – enable to create a timestamped folder for the generated output, such as a BOM report (Reports » Bill of Materials). The folder name is in the format <FolderName> Date Time where the <FolderName> is specified in the Output Path field and Date and Time are in the same format as your system settings.
  • Archive project document – enable to archive the project document. For example, when generating manufacturing outputs from a PCB design (File » Fabrication Outputs and File » Assembly Outputs) the target Output folder will include a copy of the related PCB document.
  • Use separate folder for each output type – enable to create separate folders for each output type generated for the design project. This folder structure also will be represented in the Projects panel.

Netlist Options

  • Allow Ports to Name Nets – enable to name a net using the Name property of a wired port rather than using a default, system-generated net name.
  • Allow Sheet Entries to Name Nets – enable to name a net using the sheet entry name rather than using a default, system-generated net name.
  • Allow Single Pin Nets – enable to allow the existence of nets containing only a single pin.
  • Append Sheet Numbers to Local Net – enable to append the value for a schematic document's Sheet Number parameter (a document-level parameter) to nets that are local to that sheet. A local net is a net that does not leave the sheet. For a net that does leave the sheet (and is therefore not local), this option does not apply.

    If the Net Identifier Scope option is set to Global, then all nets with the same net label will be connected together on all sheets. Since these nets are not local, the Append Sheet Numbers to Local Net option is not applied.
    The Append Sheet Numbers to Local Nets option will work only if each schematic sheet has been assigned a unique SheetNumber. The SheetNumber parameter is assigned on the Parameters tab of the Properties panel in Document Options mode for each schematic sheet. As an alternative to manually assigning a unique number to each schematic sheet, run the Number Schematic Sheets command, which opens the Sheet Numbering for Project dialog. This can be used to assign unique SheetNumbers (a simple numeric value for each sheet) and DocumentNumbers (typically used for a company-assigned document numbering) to all sheets.
  • Higher Level Names Take Priority – enable to have the net labels used on higher sheets in the hierarchy name the nets on the lower sheets.
  • Power Port Names Take Priority – the software has the ability to localize a global power net by wiring a power port to a normal port. This would force all pins on that sheet connected to that power port to be in a separate net. Enabling this option would force net naming using the name of the net assigned to the power port.

    If only Higher Level Names Take Priority is enabled, the naming order of precedence is as follows: Net labels, power ports, ports, pins. However, if the Power Port Names Take Priority option is also enabled, then the naming order of precedence is Power ports, net labels, ports, pins.

Net Identifier Scope

Multi-sheet designs are defined at the electrical (or connective) level by Net Identifiers. Net identifiers (net labels, ports, sheet entries, power ports, and hidden pins) create logical connections between points in the same net. This can be within a sheet or across multiple sheets. Physical connections exist when one object is attached directly to another electrical object by a wire. Logical connections are created when two net identifiers of the same type (e.g., two net labels) have the same Net property.

When the connectivity model of the design is created, you must define how you want net identifiers to connect to each other – this is known as setting the Net Identifier Scope. There are essentially two ways of connecting sheets in a multi-sheet design: either horizontally, directly from one sheet to another sheet to another sheet, etc., or vertically, from a sub-sheet to the sheet symbol that represents it on the parent sheet. In horizontal connectivity, the connections are from port to port (net label to net label is also available). In vertical connectivity, the connections are from sheet entry to port.

The scope of net identifiers should be determined at the beginning of the design process.

Use the drop-down list to choose from the following scopes:

  • Automatic (Based on project contents) – this mode automatically selects which of the net identifier modes to use based on the following criteria: if there are sheet entries on the top sheet, then Hierarchical is used; if there are no sheet entries, but there are ports present, then Flat is used; if there are no sheet entries and no ports, then Global is used.

    The Automatic mode defaults to use the standard Hierarchical mode if need be, with power ports connecting globally. To use Strict Hierarchical, manually set the Net Identifier Scope accordingly. Hidden pins are always deemed to be global.
  • Flat (Only ports global) – ports connect globally across all sheets throughout the design. With this option, net labels are local to each sheet, i.e. they will not connect across sheets. All ports with the same name will be connected on all sheets. This option can be used for flat multi-sheet designs. It is not recommended for large designs as it can be difficult to trace a net through the sheets.
  • Hierarchical (Sheet entry <-> port connections, power ports global) – connect vertically between a port and the matching sheet entry. This option makes inter-sheet connections only through sheet symbol entries and matching sub-sheet ports. It uses ports on sheets to take nets or buses up to sheet entries in corresponding sheet symbols on the parent sheet. Ports without a matching sheet entry will not be connected even if a port with the same name exists on another sheet. Net labels are local to each sheet, i.e. they will not connect across sheets. However, power ports are global – all power ports with the same name are connected throughout the entire design. This option can be used to create designs of any depth or hierarchy and allows a net to be traced throughout a design on the printed schematic.
  • Strict Hierarchical (Sheet entry <-> port connections, power ports local) – this mode of connectivity behaves in the same way as the Hierarchical mode, with the difference being that power ports are kept local to each sheet, i.e. they will not connect across sheets to power ports of the same name.
  • Global (Netlabels and ports global) – ports and net labels connect across all sheets throughout the design. With this option, all nets with the same net label will be connected together on all sheets. Also, all ports with the same name will be connected on all sheets. If a net connected to a port also has a net label, its net name will be the name of the net label. This option can also be used for flat multi-sheet designs, however, it is difficult to trace from one sheet to another since visually locating net names on the schematic is not always easy.
If the design uses sheet symbols with sheet entries, the Net Identifier Scope should be set to Hierarchical or Strict Hierarchical. In either of these modes, the top sheet must be wired. If not using sheet symbols with sheet entries, connectivity can be established via Ports and/or Net labels, therefore, one of the other two net identifier scopes (Flat or Global) should be used accordingly.
Remember that net labels do not connect to ports of the same name.

Allow Pin-Swapping Using These Methods

In the PCB editor, Pin, Differential Pair and Part swaps are performed by exchanging nets on component pads and their corresponding copper. When the changes are merged into the schematics, there are two ways that a pin swap can be handled:

  • Adding / Removing Net-Labels – enable to allow swapping of pins on a component symbol. Performing the swap on the schematic by swapping net labels can only be done if the connectivity is established through the net labels, i.e. if the pins are not hardwired together.

    The advantage of this approach is that the component symbol does not change and can be updated from the library at a later date. This approach is the best choice for a complex component, such as an FPGA, where physically moving two pins on the symbol could result in an I/O bank-based symbol presenting incorrectly.
  • Changing Schematic Pins – enable to allow swapping of net labels on the wires attached to the pins of a component. Swapping Pins will be the only option available when nets have been physically hardwired to a component. This method can be used on simple components (such as a resistor array) or where there is no alternative because of the structure of the schematic design.

    Swapping the pins will always work on the schematic, but it may mean that the instance of the component symbol is no longer the same as it was defined in the library. In this situation, it means the symbol can no longer be updated from the library without destroying swapping information. It also means that other instances of the same component in this design will have a different pin arrangement, which could be a source of confusion to someone reading the schematic.

General

  • Automatic Sheet Numbering – enable this option to automatically number the schematic sheets in this project. This allows control over the sheet designation and stores them as parameters within the respective schematic documents.
  • Automatic Cross References – enable this option to automatically add port, off sheet connectors and sheet entries cross-referencing information to all source schematic documents in the active project. This feature helps trace net connectivity in a non-hierarchical design.

    Cross Reference values are displayed in the Properties panel for PortsOff Sheet Connectors, and Sheet Entries, simplifying the task of identifying the Cross Reference(s) being applied to the selected Port or Off Sheet Connector.
  • New Indexing of Sheet Symbols – enable to use any digit or number as the first or last index of a repeated Sheet Symbol, including 0. Negative numbers are not allowed. The last index must always be larger than the first index.

Cross References

  • Sheet Style – choose one of the following sheet styles for the cross referencing of ports on a schematic sheet or schematic sheets within a project.
    • None – no sheet style is added in the cross reference string of all ports.
    • Name – names of the sheets that the ports are linked to are added in the cross reference strings.
    • Number – the sheet numbers of the sheets that the ports are linked to are added in the cross reference strings.
  • Location Style – choose one of the following location styles for the cross referencing of ports on a schematic sheet or schematic sheets within a project.
    • None – no location style is added in the cross reference string of all ports.
    • Zone – the reference zone numbering (the sheet borders have the zones) is added in the cross reference strings of all ports that are associated with the parent objects such as the location of sheet symbols.
    • Location X,Y – the locations of the ports are published in brackets in the cross reference strings for all ports that are associated with the parent objects such as the location of sheet symbols.
  • Follow Cross References settings in Preferences – when this option is enabled, the values of the Sheet Style and Location Style options will be inherited from the options in the Port Cross References region of the Schematic – General page of the Preferences dialog.
  • Display Cross References for:
    • Ports – use the drop-down to select mode of displaying cross references for ports.
      • Disabled – no cross reference is added to ports.
      • Only Related Sheet Entry – display cross reference to the associated sheet entry on the parent schematic sheet.
      • Only Related Ports – display cross references to the associated ports.
      • Sheet Entry & Ports – display cross references to both sheet entry and ports.
    • Off-sheet Connectors – enable this option to display cross references for off-sheet connector objects.
    • Sheet Entries – enable this option to display cross references for sheet entry objects.

Diff Pairs

  • Custom Diff Pair Suffix Grid – lists the default differential pair suffixes (_P_N) and all defined custom differential pair suffixes, in terms of:
    • Positive Suffix – the suffix for the positive net of a differential pair.
    • Negative Suffix – the suffix for the negative net of a differential pair.
    To modify a custom suffix, click it in the grid and type in the desired suffix.
    The first character of a custom suffix must be the underscore character ('_'); it will be added automatically if not typed in. A custom suffix cannot contain spaces and other underscore characters. A custom suffix cannot be empty and must be unique (i.e. it cannot be added if already used as another suffix).
  • Add – click to add a new suffix pair to the list.
  • Remove – click to delete the selected suffix pair(s) from the list.
The default differential pair suffixes (_P_N) cannot be modified or deleted.
Be aware that custom differential pair suffixes are not backward compatible. If this feature is used in your projects, the differential pairs using custom suffixes will not be maintained in a version of the software earlier than Altium NEXUS 5.3.

The Multi-Channel tab of the Project Options dialog enables you to define the room naming scheme and component designator format for use with multi-channel designs. Multi-channel design is the ability to reference the same sub-sheet in the project multiple times. This can be done by placing multiple sheet symbols that reference the same sub-sheet, or by including the Repeat keyword in the designator of a Sheet Symbol to instantiate it multiple times.

Altium NEXUS offers true multi-channel design, meaning that you can reference single sheets repeatedly in a project. Any changes that might need to be made can be applied in one place and recompiling the project then propagates those changes through each instantiation. Altium NEXUS not only supports multiple channels, it also allows them to be nested.

The mapping from the single logical component on the schematic to the multiple physical instances on the PCB is controlled by the multi-channel designator scheme defined on this tab.

Options/Controls

Room Naming

  • Room Naming Style - use this field to specify the style that is to be used to name the rooms. As you select a style from the list, the image below is updated to reflect the naming convention that will appear in the design. When the design is compiled, a room is created for each sheet in the design, including each bank and each lower-level channel. There are five styles available — two flat and three hierarchical (those including path):
    • Flat Numeric With Names
    • Flat Alpha With Names
    • Numeric Name Path
    • Alpha Name Path
    • Mixed Name Path
    Hierarchical channel names are formed by concatenating all channelized sheet symbol designators (ChannelPrefix + ChannelIndex) in the relevant channel path hierarchy.
  • Level Separator for Paths - use this field to specify the required character/symbol for separating the path information when using the hierarchical naming styles (those styles that include the path). By default, the underscore character (_) will be used.

    There is no restriction on the entry used for the level separator, although to retain visual clarity, it is advisable to keep it to a single non-alphanumeric character.
  • Preview - as you make changes to the Room Naming Style and/or Designator Format, the image in this region dynamically updates to reflect the naming convention that will appear in the design. The image gives an example of a 2 x 2 nested channel design. The larger cross-hatch regions represent the two upper-level channels (or banks) and the shaded regions within represent the lower-level channels (with two sample components shown in each).

Component Naming

  • Designator Format - use this field to specify the format used when assigning designators to the design components. The following eight predefined formats are available from the field's drop-down list: five flat and three that can be used in a hierarchical context (containing the channel naming):
    • $Component_$RoomName
    • $RoomName_$Component
    • $Component$ChannelAlpha
    • $Component_$ChannelPrefix$ChannelAlpha
    • $Component_$ChannelIndex
    • $Component_$ChannelPrefix$ChannelIndex
    • $ComponentPrefix_$ChannelIndex_$ComponentIndex
    • $ComponentPrefix_$RoomName_$ComponentIndex
    The flat designator formats name each component designator in a linear progression, starting from the first channel. The hierarchical formats include the Room name ($RoomName) in the designator for a component. If the Room Naming Style chosen is one of the two possible flat styles, then the style for the component designator will also be flat. However, if a hierarchical style has been chosen for room naming, the component designator will also be hierarchical because the path information will be included in the format.
The Room Naming Style is only relevant for component naming if the $RoomName string is included in the Designator Format.

Defining Your Own Designator Format

You also can define your own component designator format by typing directly into the Designator Format field. The following keywords can be used when constructing the format string:

  • $RoomName - this is the name of the associated channel as determined by the style chosen in the Room Naming Style field.
  • $Component- this is the component logical designator.
  • $ComponentPrefix - this is the component logical designator prefix (e.g., U for U1).
  • $ComponentIndex - this is the component logical designator index (e.g., 1 for U1).
  • $ChannelPrefix - this is the logical sheet symbol designator.
  • $ChannelIndex - this is the channel index.
  • $ChannelAlpha - this is the channel index expressed as a character.

Notes

  • The alpha indexing for a channel is only really useful if your design contains less than 26 channels in total or if you are using a designator format that is hierarchical in nature.
  • For a multi-channel design, tabs are displayed along the bottom of the schematic sheet in the design window, one for each channel (or bank). The tab names are the sheet symbol names plus the channel number, e.g., BANKA. These are the compiled views (physical views) of the design, while the logical design remains as before on the Editor tab.

The Default Prints tab of the Project Options dialog enables you to set up the default print outputs for various editors of Altium NEXUS. It is these nominated defaults that are used when running the following print commands from the editors' main menus:

  • File » Print
  • File » Print Preview » Print
These defaults are also applied from the Projects panel when using the right-click Print and Print Preview commands for a document.
To access the Default Prints tab, the Value field for the UI.ProjectOptions.DefaultPrints option on the Advanced Settings dialog must be enabled. The Advanced Settings dialog is accessed by clicking the Advanced button on the System – General page of the Preferences dialog. If any changes are made in the Advanced Settings dialog, the software must be restarted in order for the changes to take effect.

Options/Controls

The main area of the tab presents a listing of all supported print-based outputs that can be generated from the schematic and PCB editors. Output types are grouped into the following categories:

  • Assembly Outputs
  • Documentation Outputs
  • Fabrication Outputs
  • Other Outputs
  • Report Outputs
  • Validation Outputs

For each entry, the following information is displayed:

  • Output Description – what is output by using this print output type.
  • Supports – the editor for which this print output type is supported.
  • Default Print – indicates whether this print output type is to be used as the default print type (enabled) or not (disabled).

    Only one print output type can be set as the default print type for each editor.

Additional Options

  • Configure – click this button to access an associated dialog with which to configure the currently selected print output. The dialogs involved include:
  • Page Setup – click to access a page setup dialog for the currently selected print output. In the dialog, you can configure the printout with the chosen printer in terms of paper, scaling, and color settings. You can also access the relevant configuration dialog, the printer setup dialog, preview the printout, and ultimately print the output from the selected printer.

The Search Paths tab of the Project Options dialog enables you to specify the search paths to library and model files for the project.

The Search Paths tab of the Project Options dialog is only available after enabling the UI.ProjectOptions.SearchPaths option in the Advanced Settings dialog (the Value field must be enabled, it is disabled by default). The Advanced Settings dialog is accessed by clicking the Advanced button on the System - General page of the Preferences dialog. If any changes are made in the Advanced Settings dialog, the software must be restarted in order for the changes to take effect.

Options/Controls

Ordered List of Search Paths

This grid shows the ordered list of search paths for library and model files (e.g., PCB footprint libraries, Simulation and SI models). For each path, you can specify the filter and the recursive settings.

  • Path - location of the search path.
  • Filter - the filter for the search. By default, the filter searches for all files.
  • Recursive - check to search all the sub-directories of the search path directory. Double-click on a search path to edit this path.
The above areas are defined using the Edit Search Path dialog, accessed by selecting an entry then clicking Properties.
  • Add - use to open the Edit Search Path dialog to add a new search path.
  • Delete - use to remove a selected search path.
  • Properties - use to access the Edit Search Path dialog to edit the properties of the selected search path.
  • Move Up - use to move the selected search path up one line.
  • Move Down - use to move the selected search path down one line.

Files Found on All Search Paths

This grid shows the library and model files that are found from the Ordered List of Search Paths list. Use the Refresh List button to view an updated list.

Setting up a path does not mean that the libraries on that path are installed in the project. You are only setting up 'pointers' to where those libraries reside on the hard disk.

The paths you define are local to the current project. If you want to make libraries available to each project within the application, you will need to add the libraries to the Installed Libraries list. This is a list of pointers to library files that exist on the hard disk. Adding libraries to the Installed Libraries list is a separate and distinct operation.

The search paths specified in this tab will be used in the order that they are listed. A default search path exists, which is the path to the actual project document. This default path will be searched first before searching the paths defined in the tab.

This tab of the Project Options dialog enables you to manage parameters defined for the project, often referred to as project-level parameters. Parameters defined at the project level are available for use across all schematic sheets and PCB documents in the project through the use of special strings: =<ProjectParameterName> on a schematic (e.g., =Project) and .<ProjectParameterName> on a PCB (e.g., .Project). Parameters can be used to provide additional design information. Project-level parameters, for example, can be used in global fashion as the source for special string parametric data to be added to schematic sheets and/or the PCB document – the latter of which does not support localized parameters.

Workspace-side project parameters are saved in the Workspace with the project and can only be edited within the Workspace. By contrast, design-side project parameters are saved in the project file (*.PrjPcb), and can be edited in Altium NEXUS. Workspace-side project parameters appear in the Parameter tab of the Project Options dialog with a blue icon (), while design-side project parameters appear with an orange icon ().

When using the project parameter with a schematic template (*.SchDot), place the parameter as a =<ProjectParameterName> special string in the title block of the template.

Altium NEXUS supports parameters at various levels of the project – project-level parameters, document-level parameters (defined for a schematic sheet), and variant-level parameters. They also have a hierarchy, which means you can create a parameter with the same name at different levels of the project, each having different values. Altium NEXUS resolves this with the following order of precedence: Variant (highest priority) ---> Schematic Document ---> Project (lowest priority). That means the parameter value defined in the schematic document overrides the value defined in the project options, and the value defined in the variant overrides the value defined in the schematic document.

Note that schematic-level parameters are not available on the PCB or in the BOM; for these types of documents, you should use project or variant parameters.

For information about linking components to your company database, click here.

Options/Controls

  • Parameters Grid – the main region lists all of the parameters currently defined for the project, in terms of:
    • Name – the name of the parameter.
    • Value – the value of the parameter.
    A parameter can be modified with respect to either of these attributes directly in the grid.
  • Add – click to open the Parameter Properties dialog, where you may add a parameter and specify the properties of a parameter when attached at the project or variant level.
  • Remove – click to delete the selected parameter(s) from the list of parameters. This option is unavailable for server-side project parameters due to the fact that they may only be removed or edited in the Workspace.
  • Edit – click to open the Parameter Properties dialog, where you may modify the contents of the currently selected parameter. This option is unavailable for server-side project parameters due to the fact that they may only be removed or edited in the Workspace.
  • Refresh – click to revert the last changes made to the design-side project parameter. For server-side project parameters, click to ensure you contain the latest version of the parameter. Changes made to server-side project parameters within the Workspace will not be reflected in this dialog until this option is used.

Right-Click Menu

The following commands are available on the right-click menu:

  • Edit – use to modify the currently selected parameter in the Parameter Properties dialog.
  • Add – use to add a new parameter to the list in the Parameter Properties dialog.
  • Remove – use to delete the selected parameter(s) from the list.
  • Copy – use to copy the selected parameter(s) to the Windows clipboard.
  • Paste – use to paste parameter(s) on the Windows clipboard into the parameters list.
The Copy and Paste commands support the ability to define a set of parameters in an external spreadsheet (such as Microsoft Excel) and paste them into the tab. If a parameter being pasted has the same name as an existing parameter in the list, the value for the existing parameter will be overwritten with the one being pasted.

The Device Sheets tab of the Project Options dialog enables you to specify the folders in which the device sheets can be found and their order.

Options/Controls

  • Main region - lists the Device Sheet Folders paths for the current project. Check Include Sub-folders to include the sub-folders of the listed parent folders.
  • Move Up - use to move the selected device sheet folder up one level at a time.
  • Move Down - use to move the selected device sheet folder down one level at a time.
  • Add - use to open a dialog to search for a new folder to add.
  • Remove - use to remove the selected device sheet folder.

The Managed OutputJobs tab of the Project Options dialog allows you to configure a list of output job templates that are available through your connected Workspace to be used with the project.

Options/Controls

  • Outputjob List - lists all the Workspace outputjobs in terms of Item Revision, Revision State, Description, and Name.
  • Add - click to open the Select configuration item (Output Jobs) dialog to select the desired outputjob(s).
  • Remove - click to remove the selected output job(s).

The Library Options tab of the Project Options dialog allows you to select the format for an integrated library project.

Options/Controls

  • Integrated Library Format
    • Original - select to use the original integrated library format. This is used for compatibility with Protel DXP (DXP 2002) software, prior to the advent of Altium NEXUS.
    • Altium NEXUS- select to use Altium NEXUS as the integrated library format (used in all versions of the software since the original Altium NEXUS 2004).

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: