RunQuery

Последнее изменение: Susan Riege; 17.07.2018

Parent page: PCB Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: Apply=True|Source=Favorite|Index=n|Zoom=True|Select=True (where n is in the range 0 to 9)

Summary

This command is used to apply filtering to the current document, using the indicated favorite filter logical query expression. A logical query expression is a string you enter using specific keywords and syntax - from an established Query Language - which will return the targeted objects when the filter is applied.

Access

The related indexed commands are available from the PCB Editor and the PCB Library Editor from the top of the Filter pop-up menu, which is accessed by pressing Y in the design workspace.

The ten most recently added queries to the favorites list will be displayed on the menu (most recent at the top), enabling you to quickly access and reuse your favorite query expressions.

Use

After launching the command, filtering will be applied to the active document using the indicated favorite query expression. All design objects that fall under the scope of the filter will remain fully visible, with all other design objects becoming dimmed.

Tips

  1. The full list of favorite filter expressions can be found on the Favorites tab of the Expression Manager dialog.
  2. Adjust the level of masking applied to objects not falling under the scope of the active filter, by using the Masked Objects slider bar, accessed in the Mask and Dim Settings section, on the View Options tab of the View Configuration panel.


Applied Parameters: Action=ShowFavorites

Summary

This command is used to access the Favorites tab of the Expression Manager dialog, from where you can manage the list of favorite queries as required. A logical query expression is a string you enter using specific keywords and syntax - from an established Query Language - which will return the targeted objects when the filter is applied.

Access

This command can be accessed from the PCB Editor and PCB Library Editor by choosing the Organize Favorites command from the Filter pop-up menu, which is accessed by pressing Y in the design workspace.

In the Filter panels - the PCB Filter panel (if the active document is a PCB) or PCBLIB Filter panel (if the active document is a PCB library) - the Favorites tab of the Expression Manager dialog can also be quickly accessed by clicking the Favorites button located below the Filter region.

Use

After launching the command, the Expression Manager dialog will open with the Favorites tab presented as the active tab. From here you can:

  • Edit the name of a selected favorite query in the list. When a query expression is added to the favorites list, it is assigned a unique name in the default format Favorite_n, where n is the next available unused number. Change this to a more meaningful name – for example, a name that conjures the intent of the expression.
  • Edit the logical query expression for a selected favorite query in the list, changing it as required to more accurately target the required set of objects (or a completely different set of objects). Highlighting options can also be modified (what to do with objects falling and not falling, under the scope of the filter).
  • Remove a selected favorite query from the list.
  • Apply a selected favorite query expression. Depending on from where the dialog was accessed, this will either load the expression into the filter panel or apply filtering using the expression in the workspace.

Tips

  1. The Expression Manager dialog also offers a History tab. This provides a list of all previously used, historical query expressions. A selected historical expression can be quickly added to the Favorites list.


Applied Parameters: Apply=True|Source=History|Index=n|Zoom=True|Select=True (where n is in the range 1 to 9)

Summary

This command is used to apply filtering to the current document using the indicated historical filter logical query expression. A logical query expression is a string you enter using specific keywords and syntax - from an established Query Language - which will return the targeted objects when the filter is applied.

Access

The related indexed commands are available from the PCB Editor and PCB Library Editor from the top of the Filter pop-up's History sub-menu, which is accessed by pressing Y in the design workspace.

The nine most recently used queries from the history list will be displayed on the menu (most recently used at the top), enabling you to quickly access and reuse your historical query expressions.

Use

After launching the command, filtering will be applied to the active document using the indicated historical query expression. All design objects that fall under the scope of the filter will remain fully visible, with all other design objects becoming dimmed.

Tips

  1. The full list of historical filter expressions can be found on the History tab of the Expression Manager dialog.
  2. Adjust the level of masking applied to objects not falling under the scope of the active filter by using the Masked Objects slider bar in the Mask and Dim Settings section on the View Options tab of the View Configuration panel.


Applied Parameters: Action=ShowHistory

Summary

This command is used to access the History tab of the Expression Manager dialog, from where you can manage the list of historical queries as required. A logical query expression is a string you enter using specific keywords and syntax - from an established Query Language - which will return the targeted objects when the filter is applied.

Access

This command can be accessed from the PCB Editor, and PCB Library Editor, by choosing the History » More command from the Filter pop-up menu, which is accessed by pressing Y in the design workspace.

In the Filter panels - the PCB Filter panel (if the active document is a PCB) or PCBLIB Filter panel (if the active document is a PCB library) - the History tab of the Expression Manager dialog can also be quickly accessed by clicking the History button located below the Filter region.

Use

After launching the command, the Expression Manager dialog will open with the History tab presented as the active tab. From here you can:

  • Add a selected historical query expression to the Favorites list.
  • Apply a selected historical query expression. Depending on from where the dialog was accessed, this will either load the expression into the filter panel or apply filtering using the expression, in the workspace.
  • Clear the list - essentially purging all historical query expressions.

Tips

  1. The Expression manager dialog also offers a Favorites tab. This provides a list of all favorite query expressions. When added as a favorite, you have the ability to edit the logical query expression for a selected favorite query in the list - changing it as required to more accurately target the required set of objects (or a completely different set of objects). Highlighting options can also be modified (what to do with objects falling and not falling, under the scope of the filter).


Applied Parameters: Clear=True

Summary

This command is used to clear the filter that is currently being applied to the active document.

Access

This command can be accessed from the PCB Editor and PCB Library Editor by:

  • Right-clicking in the design workspace and choosing the Clear Filter command from the context menu.
  • Clicking the  button on the PCB Standard toolbar (PCB Editor) or the Filter toolbar (PCB Editor).
  • Using the Shift+C keyboard shortcut.

Use

After launching the command, the current filter that is being applied to the document will be cleared and all design objects that were previously made unavailable by the application of the filter (i.e. were dimmed out) will be made available once again for normal editing.

Tips

  1. Current filtering can also be cleared by applying an empty query expression from the relevant filter panel for the active document.


Applied Parameters: Action=FindSimilar

Summary

This command is used to access the Find Similar Objects dialog in which you can set up search criteria for the Find Similar Objects (FSO) process. This process uses the attributes of a target object as a reference for finding several other objects with similar characteristics. This provides a fast, efficient method with which to select multiple similar objects for simultaneous editing.

Access

This command can be accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the Edit » Find Similar Objects command from the main menus.
  • Using the Shift+F keyboard shortcut.

Use

After launching the command, the cursor will change to a cross-hair and you will be prompted to choose a design object in the workspace. Position the cursor over the object required then click or press Enter. The Find Similar Objects dialog will open.

The dialog has three columns; the first (left) column lists the object's parameters, the second (middle) column lists the parameter's current value, and the third (right) column is used to specify how that parameter should be used to select additional objects. By default, the Object Kind parameter will be set to Same, with all other parameters set to Any. This basically means 'find all objects of the same kind, regardless of other parameteric values'. Make changes to narrow the search as required.

To search for objects with different values, enter the search pattern into the attribute value column directly; the '*' character can be used as a wildcard for finding any group of characters – i.e. C* will find C1, C2, C20, C397, Cap5, etc. Edits made to the attribute value in the dialog will not alter the attributes of the reference object.

Below the three columns are a number of options that can be set according to the desired operation once the find is executed. To select objects according to filter settings in the Find Similar Objects dialog, ensure the Select Matched option is enabled before clicking OK to execute the find. Also take note of the Clear Existing option and ensure it is enabled unless cumulative selection is required.

Having found the group of objects required, simultaneous property-editing of multiple objects can be performed using the relevant List panel.

Tips

  1. Use the Apply button to test and fine tune search criteria to yield the desired results without closing the dialog.
  2. If the highlighting method in the dialog has been set to Mask, adjust the level of masking applied to objects not falling under the scope of the active filter by using the Masked Objects slider bar in the Mask and Dim Settings section on the View Options tab of the View Configuration panel. If the highlighting method in the dialog has been set to Dim, adjust the level of dimming applied to objects not falling under the scope of the active filter by using the Dimmed Objects slider bar in the Mask and Dim Settings section of the same panel.
  3. The current filtering can be quickly cleared using the Shift+C keyboard shortcut.


Applied Parameters: Action=FindSimilarUnderCursor

Summary

This command is used to access the Find Similar Objects dialog, in which you can set up search criteria for the Find Similar Objects (FSO) process. This process uses the attributes of the object under the cursor as a reference for finding several other objects with similar characteristics. This provides a fast, efficient method with which to select multiple similar objects for simultaneous editing.

Access

This command is accessed from the PCB Editor and PCB Library Editor by right-clicking over a placed design object and choosing the Find Similar Objects command from the context menu.

Use

First, position the cursor over the required object in the main design workspace that are similar objects you wish to find.

After launching the command, the Find Similar Objects dialog will open.

The dialog has three columns; the first (left) column lists the object's parameters, the second (middle) column lists the parameter's current value, and the third (right) column is used to specify how that parameter should be used to select additional objects. By default, the Object Kind parameter will be set to Same, with all other parameters set to Any. This basically means 'find all objects of the same kind, regardless of other parameteric values'. Make changes to narrow the search as required.

To search for objects with different values, enter the search pattern into the attribute value column directly; the '*' character can be used as a wildcard for finding any group of characters – i.e. C* will find C1, C2, C20, C397, Cap5, etc. Edits made to the attribute value in the dialog will not alter the attributes of the reference object.

Below the three columns are a number of options that can be set according to the desired operation once the find is executed. To select objects according to filter settings in the Find Similar Objects dialog, ensure the Select Matched option is enabled before clicking OK to execute the find. Also take note of the Clear Existing option and ensure it is enabled unless cumulative selection is required.

Having found the group of objects required, simultaneous property-editing of multiple objects can be performed using the relevant List panel.

Tips

  1. Use the Apply button to test and fine tune search criteria to yield the desired results without closing the dialog.
  2. If the highlighting method in the dialog has been set to Mask, adjust the level of masking applied to objects not falling under the scope of the active filter by using the Masked Objects slider bar in the Mask and Dim Settings section on the View Options tab of the View Configuration panel. If the highlighting method in the dialog has been set to Dim, adjust the level of dimming applied to objects not falling under the scope of the active filter by using the Dimmed Objects slider bar in the Mask and Dim Settings section of the same panel.
  3. The current filtering can be quickly cleared using the Shift+C keyboard shortcut.

 

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.