Altium NEXUS Documentation

SwitchTo2D

Created: 21.06.2017 | Updated: 16.01.2020

Parent page: PCB Commands

The following pre-packaged resource, derived from this base command, is available:


Applied Parameters: None

Summary

This command is used to switch the display of the PCB workspace to 2D Layout Mode. This is the traditional, two-dimensional, multiple-layered view of the PCB.

Access

This command can be accessed from the PCB Editor and PCB Library Editor by:

  • Choosing the View » 2D Layout Mode command from the main menus.
  • Using the 2 keyboard shortcut.

Use Ctrl+Alt+2 to switch the display of the PCB workspace to 2D Layout Mode and see the same location and orientation of the board as you switch.

Use

After launching the command, the workspace will change to display the board in 2D Layout Mode. This mode includes a number of features to help find, identify and manage the display of design content - collectively, these features are known as the Board Insight System.

2D Board Insight features include:

  • Insight Pop-up - displays detailed information about the components and nets (Shift+X), and violations (Shift+V) currently under the cursor in a pop-up window.
  • Heads Up Display - presents (configurable) detail about the objects currently under the cursor (Shift+H to toggle. This is configured in the PCB Editor - Board Insight Modes page of the Preferences dialog).
  • Single Layer Mode - displays just the current layer; other layers can be hidden, gray-scaled or monochromed (Shift+S to toggle the feature on then cycle through the supported single layer modes).
  • Live Highlighting - highlight all objects in the net under the cursor including their locked status (configure in the PCB Editor - Board Insight Display page of the Preferences dialog).
  • Enhanced Object Labeling - display detail on objects in the workspace including: pad number, testpoint status, and component origin (configure in the System Colors section on the Layers & Colors tab and Additional Options section on the View Options tab of the View Configuration panel).
  • Layer Transparency - allows you to see though objects to other objects underneath (configure in the Object Visibility section on the View Options tab of the View Configuration panel).

Tips

  1. To switch to Board Planning Mode or 3D Layout Mode, use the commands of the same name from the main View menu, or use the 1 or 3 keyboard shortcuts respectively.

 

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: