ChangeObject

Последнее изменение: Jason Howie; 02.10.2017

Parent page: WorkspaceManager Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: ObjectKind=OutputSingle

Summary

This command is used to launch the associated configuration dialog (where available) for the selected output, in the active Output Job Configuration file. From here you can define exactly how, and what, you wish to be generated.

For a high-level look at Output Job Configuration files, see Preparing Multiple Outputs in an OutputJob.

Access

With the required output selected, this command can be accessed from the OutputJob Editor by:

  • Choosing the Edit » Configure command, from the main menus.
  • Using the Alt+Enter keyboard shortcut.
  • Right-clicking on the output and choosing the Configure command from the context menu.

Use

First, ensure that the output you wish to configure, is selected in the main job configuration window.

After launching the command, the associated configuration dialog will appear. Use the dialog to define setup options for the particular output files you wish to generate. Any options defined will be used when that output is next generated.

Tips

  1. The associated configuration dialog can also be accessed by double-clicking on the entry for the required output.
  2. The type of dialog (and indeed whether a configuration dialog appears at all) depends on the output you have selected. An output that generates data directly will have no dialog appear when this command is used (e.g. generation of a Design Rules Check validation report).


Applied Parameters: ObjectKind=DatabaseLink|Object=Component

Summary

This command is used to edit the selected component in the active DbLib/SVNDbLib file, without having to open the external database.

Access

This command is accessed from the Database Library Editor, and SVN Database Library Editor, by right-clicking on the required part on the Table Browser tab, and choosing the Edit Component command, from the context menu.

Use

First, ensure that the database table, containing the required part record, is selected in the Tables region of the main document window. Also, ensure that the Table Browser tab is the active tab.

After launching the command, the Edit Database Component dialog will appear. The dialog lists all of the fields defined in the parent database table, along with their values currently defined for the chosen component. Simply click on a Field Value entry to edit it. After all desired changes have been made, click OK - the changes will be committed to the table in the external database, and are reflected by the corresponding updated entries for that component, back on the Table Browser tab.


Applied Parameters: ObjectKind=DatabaseLink|Object=Symbol

Summary

This command is used to open the Schematic Library referenced by the selected component in the active DbLib/SVNDbLib file, with the referenced schematic symbol within that library made active, ready for editing.

Access

This command is accessed from the Database Library Editor, and SVN Database Library Editor, by right-clicking on the required part on the Table Browser tab, and choosing the Open Symbol command, from the context menu.

Use

First, ensure that the database table, containing the required part record, is selected in the Tables region of the main document window. Also, ensure that the Table Browser tab is the active tab.

After launching the command, the parent Schematic Library containing the referenced schematic symbol for the chosen part will be opened as the active document in the main design window. The schematic symbol will be made active - make changes as required, then save and close the library file.

If modifying the symbol as part of an SVN Database Library, ensure that the modification - which will reside only in your local working copy of the library - is then committed back to the version control repository. This is performed through the Storage Manager panel.

Tips

  1. The command will only work provided the software has knowledge of where to find the Schematic Library:
    1. For a Database Library (DbLib) - ensure that the applicable symbol search path is included on the Symbol & Model Search Paths tab of the Database Library Options dialog. Also ensure that the relevant Schematic Library is actually resident along that declared path.
    2. For an SVN Database Library (SVNDbLib) - ensure that the version control repository base directory, under which the schematic symbols reside, is specified in the Symbols field, on the SVN Repository tab of the Database Library Options dialog. Also, ensure that the local working directory is specified, into which the Schematic Libraries from the repository will be checked out for local modification. This is specified in the Working Folder field, on the Data Management - SVN Libraries page of the Preferences dialog. Finally, ensure that the relevant libraries have been checked out to this local working folder, and are therefore available to the software (this can be peformed quickly, if not done already, by using the Tools » Check Out All Working Folders command, from the main menus).


Applied Parameters: ObjectKind=DatabaseLink|Object=Footprint|Index=n (where n is in the range 1 to 5)

Summary

This command is used to open a PCB Library referenced by the selected component in the active DbLib/SVNDbLib file, with the referenced PCB Footprint within that library made active, ready for editing.

Access

This command is accessed from the Database Library Editor, and SVN Database Library Editor, by right-clicking on the required part on the Table Browser tab, and choosing the Open Footprint command, from the context menu.

If multiple footprint references have been defined for the chosen part in the database, there will be a dedicated command entry for each - up to 5. Simply pick the command corresponding to the footprint you wish to edit.

Use

First, ensure that the database table, containing the required part record, is selected in the Tables region of the main document window. Also, ensure that the Table Browser tab is the active tab.

After launching the command, the parent PCB Library containing the referenced PCB Footprint for the chosen part will be opened as the active document in the main design window. The footprint will be made active - make changes as required, then save and close the library file.

If modifying the footprint as part of an SVN Database Library, ensure that the modification - which will reside only in your local working copy of the library - is then committed back to the version control repository. This is performed through the Storage Manager panel.

Tips

  1. The command will only work provided the software has knowledge of where to find the PCB Library:
    1. For a Database Library (DBLib) - ensure that the applicable footprint search path is included on the Symbol & Model Search Paths tab of the Database Library Options dialog. Also ensure that the relevant PCB Library is actually resident along that declared path.
    2. For an SVN Database Library (SVNDbLib) - ensure that the version control repository base directory, under which the PCB footprint models reside, is specified in the Footprints field, on the SVN Repository tab of the Database Library Options dialog. Also, ensure that the local working directory is specified, into which the PCB Libraries from the repository will be checked out for local modification. This is specified in the Working Folder field, on the Data Management - SVN Libraries page of the Preferences dialog. Finally, ensure that the relevant libraries have been checked out to this local working folder, and are therefore available to the software (this can be peformed quickly, if not done already, by using the Tools » Check Out All Working Folders command, from the main menus).


Applied Parameters: ObjectKind=DatabaseLink|Object=SupplierLinks

Summary

This command is used to access the Supplier Links dialog, which provides controls to add or remove supplier links for the selected component in the active DbLib/SVNDbLib file. A Supplier Link provides the live link between an Altium NEXUS component and a real-world manufactured item in a supplier's database of electronic components.

Access

This command is accessed from the Database Library Editor, and SVN Database Library Editor, by right-clicking on the required part on the Table Browser tab, and choosing the Edit Supplier Links command, from the context menu.

Use

First, ensure that the database table, containing the required part record, is selected in the Tables region of the main document window. Also, ensure that the Table Browser tab is the active tab.

After launching the command, the Supplier Links dialog will appear. The dialog lists all of the currently defined links for the component. The upper pane shows information for added supplier items, including Manufacturer, Manufacturer Part Number, Description, and Unit Price. You can add or remove supplier items to/from this area. The lower pane shows the detailed Parameters, Documents, Pricing and Stock information for a selected item in the upper pane.

To add an additional Supplier Link, simply click on the Add button. The Add Supplier Links dialog will appear, from where you can search for, and add a link to, the required item.

To delete a Supplier Link for the component, simply select its entry, in the upper region of the Supplier Links dialog, then click the Remove button.

Once you have finished editing supplier links as required, click OK. The record for the component in the database will be updated, with additional fields for Supplier n and Supplier Part Number n added, for each newly added link. These field pairings carry the interger suffix n, to distinguish multiple defined supplier links.

Tips

  1. If an existing supplier link is removed, the fields relating to that link will still remain in the database, but their values will be cleared. If a new supplier link is added in the future for that same component, those empty fields will be reused, rather than additional fields being added.
  2. Many suppliers offer discounts for bulk orders. Use the Order Quantity field to see how pricing changes, per unit, based on quantity of item ordered from the supplier. In addition, you can also change the currency used for the Unit Price - simply select from a range of supported currencies in the drop-down field to the left of the Order Quantity field. Currency conversion will use the latest daily rates, provided you are signed in to your Altium account.

 

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.