OpenObject

Последнее изменение: Susan Riege; 04.09.2019

Parent page: WorkspaceManager Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: ObjectKind=NewAnything|Kind=SCH

Summary

This command is used to create a new schematic document. The electronic circuit is captured across one or more schematic sheets, built up from libraries of component symbols that are placed and wired together.

Access

This command is accessed from any editor by choosing the File » New » Schematic command from the main menus.

Use

Ensure that the project that you want to add the new document to is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new schematic document (Sheet1.SchDoc) will be created and opened as the active document in the main design window. The document will be added as an additional source document to the active (or focused) project.

Tips

  1. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  2. If a default document has been specified on the System - New Document Defaults page of the Preferences dialog, the schematic will be created using that default as a template. A different default can be assigned for a schematic created as part of a PCB project or created as a free document.
  3. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=DefaultPcb

Summary

This command is used to create a new PCB document. The PCB provides the mechanical mounting for the electronic components that make up the design, as well as the electrical connections between them.

Access

This command is accessed from any editor by choosing the File » New » PCB command from the main menus.

Use

Ensure that the project that you want to add the new document to is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new PCB document (PCB1.PcbDoc) will be created and opened as the active document in the main design window. The document will be added as an additional source document to the active (or focused) project. The document will contain a default board shape with a size of 6,000 x 4,000 mils.

Tips

  1. If no projects are currently open, or if the active document is a free document, the new document will be opened as a free document.
  2. If a default document has been specified on the System - New Document Defaults page of the Preferences dialog, the PCB will be created using that default as a template. A different default can be assigned for a PCB created as part of a PCB project or created as a free document.
  3. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=SCHLIB

Summary

This command is used to create a new Schematic Library document. A Schematic Library can contain one or more schematic symbols and their respective links (can be thought of as a pointer only but not the actual model itself) to any model definitions that reside in separate model libraries.

Access

This command is accessed from any editor by choosing the File » New » Library » Schematic Library command from the main menus.

Use

Ensure that the project that you want to add the new document to is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new schematic library document (Schlib1.SchLib) will be created and opened as the active document in the main design window. The document contains a default component, Component_1 added to the Components list of the SCH Library panel and opened ready for editing.

Tips

  1. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  2. If a default document has been specified on the System - New Document Defaults page of the Preferences dialog, the Schematic Library will be created using that default as a template. A different default can be assigned for a Schematic Library created as part of a PCB project, an Integrated Library Package, or created as a free document.
  3. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=DefaultPcbLib

Summary

This command is used to create a new PCB Library document. A PCB Library is used to store one or more footprint models (i.e. 2D/3D component models, since each model can comprise a 2D footprint and any additional 3D body information).

Access

This command is accessed from any editor by choosing the File » New » Library » PCB Library command from the main menus.

Use

Ensure that the project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new PCB library document (PcbLib1.PcbLib) will be created and opened as the active document in the main design window. The document contains a default component, PCBCOMPONENT_1, added to the Components list of the PCB Library panel and opened, ready for editing.

Tips

  1. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  2. If a default document has been specified on the System - New Document Defaults page of the Preferences dialog, the PCB Library will be created using that default as a template. A different default can be assigned for a PCB Library created as part of a PCB project, an Integrated Library Package, or created as a free document.
  3. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=CmpLib

Summary

This command is used to create a new managed component, which is edited in a temporary instance of the Component Editor - in its Single Component Editing mode - and then released into the initial revision of a new Component Item in the managed content server to which you are actively signed in.

For more information on creating managed components, see Working with Managed Components.

Access

This command is accessed from any editor by choosing the File » New » Component command from the main menus.

Use

After launching the command, the Create new component dialog opens. Use the dialog to select the component type then click OK. The temporary Component Editor will open, in its Single Component Editing mode, ready for you to define the component in terms of Name, Description, Models, Parameters, and Part Choices.

Tips

  1. For a detailed look at using the Component Editor, see Component Editor - Single Component Editing Mode.


Applied Parameters: ObjectKind=NewAnything|Kind=PvLib

Summary

This command is used to create a new Pad Via Library document. A Pad Via Library is used to store one or more defined pad and/or via templates for quick reuse in designs.

Access

This command is accessed from any editor by choosing the File » New » Library » Pad Via Library command from the main menus.

Use

Ensure that the project that you want to add the new document to is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new Pad Via library document (PvLib1.PvLib) will be created and opened as the active document in the main design window.

Tips

  1. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  2. The document will be empty - use the associated Pad Via Library panel to add new Pad and/or Via templates.
  3. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=OutputJob

Summary

This command is used to create a new Output Job Configuration file. An OutJob (as it is commonly known) is a pre-configured set of outputs. Each output is configured with its own settings and its own output format, for example, output to a file or to a printer. OutJobs are very flexible; they can include as many or as few outputs as required and any number of OutJobs can be included in an Altium NEXUS project. The best approach is to use one OutJob to configure all outputs required for each specific type of output being generated from the project. For example, all outputs required to fabricate the bare board go in one OutJob, all outputs required to assemble the board go into a second OutJob, etc. OutJobs also can hold validation-type checks, such as ERC and DRC reports - useful for a final 'thumbs up' check just before generating the outputs. These reports can then be held as a record that the design was ready for release.

Portable in nature, OutJobs also can be re-used between designs by copying the Output Job file from one project to the next one and resetting the Data Source as required.

Access

This command is accessed from any editor by choosing the File » New » Output Job File command from the main menus.

Use

Ensure that the project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new Output Job Configuration file (Job1.OutJob) will be created and opened as the active document in the main design window.

Tips

  1. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  2. If a default document has been specified on the System - New Document Defaults page of the Preferences dialog, the Output Job file will be created using that default as a template. A different default can be assigned for an Output Job file created as part of a PCB project or created as a free document.
  3. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=DatabaseLib

Summary

This command is used to create a new Database Library document. Database Libraries provide the ability to place components directly from an external company database. In a database library, all the detail that makes the component complete is stored in the database itself - each record in the database thus represents a component, storing all of the parameters along with model links, datasheet references, or other component information. The record can include links to inventory or other corporate component data. When a component is placed from a database library, its parameter and model information is created on-the-fly, using the corresponding fields in the matched database record and in accordance with defined mapping in the intermediary link file. One or more of these parameters will then be used to maintain an ongoing link back to the database, enabling future design synchronization after placement.

Access

This command is accessed from any editor by choosing the File » New » Library » Database Library command from the main menus.

Use

Ensure that the project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new Database library document (Database_Libs1.DbLib) will be created and opened as the active document in the main design window.

Tips

  1. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  2. If a default document has been specified on the System - New Document Defaults page of the Preferences dialog, the Database Library will be created using that default as a template. A different default can be assigned for a Database Library created as part of a PCB project, an Integrated Library Package, or created as a free document.
  3. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=SVNDatabaseLib

Summary

This command is used to create a new SVN Database Library document. An SVN Database Library takes the ability to place components directly from a database and extends this method of linking to allow source-controlled libraries - housing the schematic symbols and footprint models within a Subversion-based repository. The link to the repository and to the external database is defined within an SVN Database Library file (*.SVNDbLib), an extension of the Database Library file (*.DbLib) and often referred to as a Version-Controlled Database Library.

Access

This command is accessed from any editor by choosing the File » New » Library » SVN Database Library command from the main menus.

Use

Ensure that the project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new SVN Database library document (SVNDatabase_Libs1.SVNDbLib) will be created and opened as the active document in the main design window.

Tips

  1. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  2. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=DatabaseLink

Summary

This command is used to create a new Database Link file. This file provides an efficient means of linking and keeping the components used in your design (or libraries) synchronized with the data entered in the external database declared in the link file.

Access

This command is accessed from any editor by choosing the File » New » Library » Database Link file command from the main menus.

Use

Ensure that the project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new Database Link file (Database_Links1.DbLink) will be created and opened as the active document in the main design window.

Tips

  1. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  2. If a default document has been specified on the System - New Document Defaults page of the Preferences dialog, the Database Link file will be created using that default as a template. A different default can be assigned for a Database Link file created as part of a PCB project, an Integrated Library Package, or created as a free document.
  3. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=CAMTastic

Summary

This command is used to create a new CAM document.

Access

This command is accessed from any editor by choosing the File » New » CAM Document command from the main menus.

Use

Ensure that the project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new CAM document (CAMtastic1.Cam) will be created and opened as the active document in the main design window.

Tips

  1. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  2. If a default document has been specified on the System - New Document Defaults page of the Preferences dialog, the CAM document will be created using that default as a template. A different default can be assigned for a CAM document created as part of a PCB project or created as a free document.
  3. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=IntegratedLibrary

Summary

This command is used to create a new Integrated Library Package - the set of design documents required to produce an integrated library. Schematic symbols are drawn in a library editor, and model references defined. Referenced models can include PCB footprints, circuit simulation models, signal integrity models, and three-dimensional mechanical models. Files that contain the models are added to the Integrated Library Package (*.LibPkg) or search paths are defined to identify their location. The source schematic symbol libraries and required models are then compiled into a single file referred to as an Integrated Library.

Access

This command is accessed from any editor by choosing the File » New » Library » Integrated Library command from the main menus.

Use

After launching the command, a new Integrated Library Package (Integrated_Library1.LibPkg) will be created and opened as the focused project in the Projects panel. The project will initially be empty, as reflected by the No Documents Added sub-folder.

Tips

  1. If a default Integrated Library Package has been specified on the System - New Document Defaults page of the Preferences dialog, the new Integrated Library Package will be created using that default as a template.
  2. The project is initially unsaved. When saving, the default location for new projects is defined as the entry for the Document Path on the System - Default Locations page of the Preferences dialog. This is \Users\Public\Documents\Altium for a default installation of the software.


Applied Parameters: ObjectKind=NewAnything|Kind=ScriptProject

Summary

This command is used to create a new Script project - the set of design documents that stores one or more Altium NEXUS scripts. This is a set of instructions that are interpreted whenever a script is executed in Altium NEXUS. The scripts are written and debugged in the same environment. There are two types of scripts; script units and script forms. A Script unit can use the Application Programming Interface (API) to modify design objects on a design document. A script form hosts controls, as well as using the API to a provide script dialog that acts on design documents open in Altium NEXUS.

Access

This command is accessed from any editor by choosing the File » New » Script » Script Project command from the main menus.

Use

After launching the command, a new Script project (Script_Project1.PrjScr) will be created and opened as the focused project in the Projects panel. The project will initially be empty as reflected by the No Documents Added sub-folder.

Tips

  1. If a default Script project has been specified on the System - New Document Defaults page of the Preferences dialog, the new Script project will be created using that default as a template.
  2. The project is initially unsaved. When saving, the default location for new projects is defined as the entry for the Document Path on the System - Default Locations page of the Preferences dialog. This is \Users\Public\Documents\Altium for a default installation of the software.


Applied Parameters: ObjectKind=NewAnything|Kind=BOM

Summary

This command is used to create a new BOM document. This is the user interface to Altium NEXUS's ActiveBOM system. ActiveBOM offers a live presentation of the design from the outset, providing early and ongoing cost estimation. It allows you to define target pricing at the individual item level. You then can track how actual costing fares against these estimates, and therefore, give a timely flag if any cost blow-outs are on the near horizon. In addition, you can quickly assess item availability complete with notification if there is a risk in the supply of a chosen part.

For a high-level walkthrough of the ActiveBOM system, see ActiveBOM.

Access

This command is accessed from any editor by choosing the File » New » ActiveBOM Document command from the main menus.

Use

Ensure that the project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new BOM document (BOM1.BomDoc) will be created and opened as the active document in the main design window.

Tips

  1. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  2. The document is initially unsaved.
  3. Only a single BOM document can be added to a board design project.


Applied Parameters: ObjectKind=NewAnything|Kind=PcbDrawing|Source=Rcs

Summary

This command is used to create a new Draftsman document. A Draftsman document (*.PCBDwf) is a multi-sheet format file, that allows it to contain individual pages (sheets) that are assigned to particular types of board project production information.

For a high-level look at how the Altium Draftsman Drawing System provides an interactive approach to the creation of production documentation for your PCBs, see Draftsman.

Access

This command is accessed from any editor by choosing the File » New » Draftsman Document command from the main menus.

Use

Ensure that the project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, the New Document dialog will open. The dialog allows for the selection of a predefined Draftsman Document Template (*.DwfDot). Three such templates are provided with the installation. Alternatively, choose the [Default] option, which will create a blank A4 document. Along with the desired Draftsman Document template, a specific Project and board Source Document can be selected where multiple files are open in Altium NEXUS. The new document will be associated with, and therefore, draw data from, the nominated project, which will become the active project. After setting the creation options as required then clicking OK, the Draftsman document will be created, added to the nominated project, and opened as the active document in the main design window.

Tips

  1. The listing of custom Draftsman Document Templates will be those found in the Templates Location specified on the Draftsman - Templates page of the Preferences dialog. For a default installation of the Draftsman extension, this will be the \ProgramData\Altium\Altium NEXUS {GUID}\Extensions\Draftsman\Templates folder.
  2. A Draftsman Sheet Template (*.DwsDot) can be applied once the new document has been created from the Page Options section of the Properties panel (when no objects are currently selected in the workspace).
  3. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  4. If a default document has been specified on the System - New Document Defaults page of the Preferences dialog, the Draftsman document will be created using that default as a template. A default can only be assigned for a Draftsman document created as part of a PCB project.
  5. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=SystemDesign

Summary

This command is used to create a new Multi-board Design project - the set of design documents required to manufacture a system-level design consisting of multiple, interconnected printed circuit boards. The logical system design is captured by placing Modules on a Multi-board Schematic document (*.MbsDoc), where each physical board in the system is represented by a Module. Each Module references the PCB project and the board within that project. Once the modules have been connected and board-to-board connectivity verified, the design is 'pushed over' to a Multi-board Assembly document (*.MbaDoc) - the physical representation of the system.

Access

This command is accessed from any editor by choosing the File » New » Project » Multi-board » <Default> command from the main menus.

Use

After launching the command, a new Multi-board Design project (MultiBoard_Project1.PrjMbd) will be created and opened as the focused project in the Projects panel. The project will initially be empty as reflected by the No Documents Added sub-folder.

Tips

  1. If a default Multi-board Design project has been specified on the System - New Document Defaults page of the Preferences dialog, the new Multi-board Design project will be created using that default as a template.
  2. The project is initially unsaved. When saving, the default location for new projects is defined as the entry for the Document Path on the System - Default Locations page of the Preferences dialog. This is \Users\Public\Documents\Altium for a default installation of the software.


Applied Parameters: ObjectKind=NewAnything|Kind=SdDoc

Summary

This command is used to create a new Multi-board Schematic document. The logical system design is captured by placing Modules on this document, where each physical board in the system is represented by a Module. Each Module references the PCB project and the board within that project.

Access

This command is accessed by choosing the File » New » Multi-board Schematic command from the main menus.

The command is available only when the parent Multi-board Design project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel. If the project already has a Multi-board Schematic document, the command will not be available.

Use

Ensure that the Multi-board Design project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new Multi-board Schematic document (MultiBoardSchematic1.MbsDoc) will be created and opened as the active document in the main design window. The document will be added as an additional source document to the active (or focused) project.

Tips

  1. If a default document has been specified on the System - New Document Defaults page of the Preferences dialog, the Multi-board Schematic will be created using that default as a template. A default can only be assigned for a Multi-board Schematic document created as part of a Multi-board Design project.
  2. The document is initially unsaved.
  3. Only a single Multi-board Schematic document can be added to a Multi-board Design project.


Applied Parameters: ObjectKind=NewAnything|Kind=MultiBoardAssembly

Summary

This command is used to create a new Multi-board Assembly document. This is the physical representation of your system-level design - a design consisting of multiple, interconnected printed circuit boards.

Access

This command is accessed by choosing the File » New » Multi-board Assembly command from the main menus.

The command is available only when the parent Multi-board Design project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel. If the project already has a Multi-board Assembly document, the command will not be available.

Use

Ensure that the Multi-board Design project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new Multi-board Assembly document (Assembly1.MbsDoc) will be created and opened as the active document in the main design window. The document will be added as an additional source document to the active (or focused) project.

Tips

  1. If a default document has been specified on the System - New Document Defaults page of the Preferences dialog, the Multi-board Assembly will be created using that default as a template. A default can only be assigned for a Multi-board Assembly document created as part of a Multi-board Design project.
  2. The document is initially unsaved.
  3. Only a single Multi-board Assembly document can be added to a Multi-board Design project.


Applied Parameters: ObjectKind=NewAnything|Kind=MDL

Summary

This command is used to create a new Simulation Model file.

Access

This command is accessed from any editor by choosing the File » New » Mixed-Signal Simulation » AdvancedSim Model command from the main menus.

Use

Ensure that the project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new Simulation Model file (Model1.MDL) will be created and opened as the active document in the main design window.

Tips

  1. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  2. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=NSX

Summary

This command is used to create a new Simulation Netlist file.

Access

This command is accessed from any editor by choosing the File » New » Mixed-Signal Simulation » AdvancedSim Netlist command from the main menus.

Use

Ensure that the project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new Simulation Netlist file (Sim_Netlist1.Nsx) will be created and opened as the active document in the main design window.

Tips

  1. If no projects are currently open, or if the active document is a free document, the new document will be opened as a free document.
  2. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=CKT

Summary

This command is used to create a new Simulation Sub-Circuit file.

Access

This command is accessed from any editor by choosing the File » New » Mixed-Signal Simulation » AdvancedSim Sub-Circuit command from the main menus.

Use

Ensure that the project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new Simulation Sub-Circuit file (Sub_Circuit1.Ckt) will be created and opened as the active document in the main design window.

Tips

  1. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  2. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=EditScriptDSUnit

Summary

This command is used to create a new DelphiScript Unit.

Access

This command is accessed from any editor by choosing the File » New » Script » Script Unit command from the main menus.

Use

Ensure that the project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new DelphiScript Unit (EditScript1.pas) will be created and opened as the active document in the main design window.

Tips

  1. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  2. If a default document has been specified on the System - New Document Defaults page of the Preferences dialog, the DelphiScript Unit will be created using that default as a template. A default can be assigned for a DelphiScript Unit created as part of a Script project.
  3. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Kind=EditScriptDSForm

Summary

This command is used to create a new DelphiScript Form.

Access

This command is accessed from any editor by choosing the File » New » Script » Script Form command from the main menus.

Use

Ensure that the project to which you want to add the new document is either the active project (by having one of its existing documents open as the active document) or, if no documents are currently open, is the focused project in the Projects panel.

After launching the command, a new DelphiScript Form (EditScript1.pas) will be created and opened as the active document in the main design window.

Tips

  1. If no projects are currently open or if the active document is a free document, the new document will be opened as a free document.
  2. If a default document has been specified on the System - New Document Defaults page of the Preferences dialog, the DelphiScript Form will be created using that default as a template. A default can be assigned for a DelphiScript Form created as part of a Script project.
  3. The document is initially unsaved.


Applied Parameters: ObjectKind=NewAnything|Index=n (where n is in the range 1 to 80)

Summary

This command is used to add a new instance of the indicated document type to the active or focused project, as applicable.

Access

The related indexed commands can be accessed in the following ways:

  • For the active project, choose the required document type from the Project » Add New to Project sub-menu.
  • For the focused project (right-click on the required project in the Projects panel), then choose the required document type from the Add New to Project sub-menu.

Use

If you want to add a new document to the active project, first ensure that one of its source documents is open as the active document in the main design window. For any other non-active project, access through the Projects panel as mentioned previously.

After launching the command, the indicated document type will be created, added to the active/focused project, and opened as the active document in the main design window.

Tips

  1. If the chosen document type can have defaults specified on the System - New Document Defaults page of the Preferences dialog, the chosen document type will be created using that default as a template.
  2. The document is initially unsaved.


Applied Parameters: None

Summary

This command is used to open any existing Altium NEXUS project or document file.

Access

This command can be accessed by:

  • Choosing the File » Open command from an editor's main menus.
  • Clicking the  button on the Quick Access Bar.
  • Clicking the  button on an editor's main toolbar.
  • Using the Ctrl+O keyboard shortcut.

Use

After launching the command, the standard Windows Choose Document to Open dialog will open. Use this dialog to locate and open the required project or document.

Tips

  1. Any document that is opened will be opened as a free document (appearing in the relevant sub-folder of the Free Documents folder in the Projects panel) and made the active document in the main design window. Any project file that is opened will be added to the Projects panel and made the focused project.
  2. When opening an Integrated Library (*.IntLib), an information dialog will open giving you the option of extracting its source library documents. Clicking Yes will effectively decompile the Integrated Library, creating a corresponding Integrated Library Package (using the name of the compiled document) with the source library (libraries) added. The Package is opened (added to the Projects panel) and is made the focused project. If you click No in the dialog, the compiled Integrated Library will be added to the Installed Libraries list, which can be seen on the Installed tab of the Available File-based Libraries dialog.


Applied Parameters: ObjectKind=FocusedDocument

Summary

This command is used to open the focused document in the Projects panel.

Access

This command is accessed from the Projects panel by right-clicking on the entry for the required document then choosing the Open command from the context menu.

Use

Ensure that the document you want to open is focused in the Projects panel.

After launching the command, the focused document will be opened and made the active document in the main design window.

Tips

  1. You also can open a document from the Projects panel by double-clicking on it. If you have enabled the Opens and shows documents/objects option in the Single Click region on the System - Projects Panel page of the Preferences dialog, then a single click on a document's entry in the panel will open it in the main design window.


Applied Parameters: ObjectKind=FocusedCategory

Summary

This command is used to open all documents within the focused category (sub-folder) in the Projects panel.

Access

This command is accessed from the Projects panel by right-clicking on the entry for the required category (sub-folder) then choosing the Open All command from the context menu.

Use

Ensure that the sub-folder whose documents you want to remove is focused in the Projects panel. Focus is obtained by clicking once on the folder's entry.

After launching the command, all documents residing within the focused sub-folder, and descendant folders thereof, will be opened (if not already).


Applied Parameters: ObjectKind=Project

Summary

This command is used to open any existing Altium NEXUS project.

Access

This command is accessed from any editor by choosing the File » Open Project command from the main menus.

Use

After launching the command, the Open Project dialog opens. Use this dialog to locate and open the required project. After clicking Open, the project will be opened and added to the Projects panel. If there is currently no active project or a free document is the active document, then the newly opened project will become the focused project.

Tips

  1. Attempting to open a project that is already open will result in no action.


Applied Parameters: ObjectKind=Workspace

Summary

This command is used to open any existing Design Project Group. A Design Project Group is a saved set of Altium NEXUS projects. This can prove to be a highly efficient option when working with multiple projects that are closely linked in some way.

Access

This command can be accessed from any editor by:

  • Choosing the File » Open Design Project Group command from the main menus.
  • Right-clicking on the entry for the currently active Design project Group in the Projects panel then choosing the Open Design Project Group command from the context menu.

Use

After launching the command, the standard Windows Choose Design Project Group to Open dialog will open. Use this dialog to locate and open the required Design Project Group file (*.DsnWrk). After clicking Open, any open projects (and documents thereof) of the previously active Design Project Group will be closed. You will be prompted to save any changes. The chosen Design Project Group is then opened and its constituent projects are made available in the Projects panel.

Tips

  1. Attempting to open a Design Project Group that is already open will result in the Design Project Group being closed and reopened. You will be prompted to save any changes made to open documents.
  2. The currently open Design Project Group is shown as an entry in the Projects panel.
  3. The last project in the list will be made the focused project when the Design Project Group is opened.


Applied Parameters: ObjectKind=RecentDocument|Index=n (where n is in the range 1 to 9)

Summary

This command is used to open the indicated, recently closed document.

Access

The related indexed commands can be accessed from any editor from the File » Recent Documents sub-menu.

Use

After launching the command, the listed document will be opened and made active in the main design window.

Tips

  1. The Recent Documents list shows the most recently closed documents (up to a maximum of nine documents). Position 1 (at the top) reflects the last document closed.
  2. If a document is opened that does not currently reside in an opened project in the Projects panel, it will be opened as a free document.


Applied Parameters: ObjectKind=RecentProject|Index=n (where n is in the range 1 to 9)

Summary

This command is used to open the indicated, recently closed project.

Access

The related indexed commands can be accessed from any editor from the File » Recent Projects sub-menu.

Use

After launching the command, the listed project will be opened and made available in the Projects panel.

Tips

  1. The Recent Projects list shows the most recently closed projects (up to a maximum of nine projects). Position 1 (at the top) reflects the last project closed.


Applied Parameters: ObjectKind=RecentWorkspace|Index=n (where n is in the range 1 to 9)

Summary

This command is used to open the indicated, recently closed design project group.

Access

The related indexed commands can be accessed from any editor from the File » Recent Workspaces sub-menu.

Use

After launching the command, any open projects (and documents thereof) of the previously active Design Project Group will be closed. You will be prompted to save any changes. The chosen Design Project Group is then opened and its constituent projects are made available in the Projects panel.

Tips

  1. The Recent Workspaces list shows the most recently closed design project groups (up to a maximum of nine design project groups). Position 1 (at the top) reflects the last design project group closed.


Applied Parameters: ObjectKind=RecentDocument

Summary

This command is used to choose what to open from a listing of recently closed documents, projects and design project groups.

Access

This command is accessed from any editor by:

  • Choosing the File » Recent Documents » All Recent Documents and Projects command from the main menus.
  • Choosing the File » Recent Projects » All Recent Documents and Projects command from the main menus.
  • Choosing the File » Recent Workspaces » All Recent Documents and Projects command from the main menus.

Use

After launching the command, the Recent Documents, Projects and Workspaces dialog will open. The dialog lists all recently closed documents, projects, and design project groups conveniently within one location.

Select what you want to open then either click OK to close the dialog and open your selection or Open Selected Documents to open your selection - keeping the dialog open for further selection.

Use the standard Windows shortcuts (Ctrl+click and Shift+click) to select multiple items from the list.

Tips

  1. Double-clicking on an entry in the dialog also will open the associated document, project or design project groups.
  2. If your selection includes documents and/or projects AND a design project groups, only the design project groups will be opened (and its constituent projects/documents).
  3. If a document is opened that does not currently reside in an opened project in the Projects panel, it will be opened as a free document.
  4. When opening a design project groups, any open projects (and documents thereof) of the previously active Design Project Group will be closed. You will be prompted to save any changes.


Applied Parameters: ObjectKind=SelectProjectDocument

Summary

This command is used to open one or more documents, either in the currently focused project or all open projects in the active design project groups.

Access

This command can be accessed from any editor by:

  • Choosing the Project » Project Documents command from the main menus.
  • Using the Alt+Ctrl+O keyboard shortcut.

Use

After launching the command, the Open Project Documents dialog will open. Use this dialog to select the documents that you want to open. You can restrict the view to only list documents in the project that is currently focused in the Projects panel or all projects open in the active design project groups.

Use the standard Windows shortcuts (Ctrl+click and Shift+click) to select multiple items from the list.

With the required document(s) selected, clicking OK will cause those documents to be opened.

Tips

  1. All selected documents will be opened as tabbed document views in the main design window. The last document selected will be the last document opened, with its parent project becoming the active project (and also the focused project) in the Projects panel.
  2. To display the current status of documents in the Projects panel, click the  button at the top of the panel, then enable the Open/modified status option within the Sorting grouping of pop-up controls. Alternatively, enable this option on the System - Projects Panel page of the Preferences dialog


Applied Parameters: Action=OpenExistingPDF|ObjectKind=OutputSelected

Summary

This command is used to open an existing PDF document that has been generated through a defined PDF output container in the active Output Job Configuration file.

Access

This command is accessed from the Output Job Editor by right-clicking on the required PDF output container (in the Output Containers region) then choosing the Open PDF command from the context menu.

The command is available only after the PDF has been generated and while the Output Job Configuration file remains open.

Use

Ensure that the PDF output container, from which the PDF you want to view was generated, is selected in the Output Containers region of the main job configuration window.

After launching the command, the PDF will be opened.

Tips

  1. If the Output Job Configuration file is closed and then reopened, the command will no longer be available even though the PDF exists. You will either need to generate the file again or browse for the file in the location in which it was created.
 
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.