CloseObject

Последнее изменение: Tiffany Cullen; 12.03.2019

Parent page: WorkspaceManager Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: ObjectKind=Document

Summary

This command is used to close the active document.

Access

This command can be accessed from the active document's editor by:

  • Choosing the File » Close command, from the main menus.
  • Using the Ctrl+F4 keyboard shortcut.

Use

After launching the command, the active document will be closed. If any changes have been made to the document since the last save, you will be prompted to save these changes first.

Tips

  1. If the document is a free document, its entry will be removed from the Projects panel upon closure.
  2. The active document can also be closed using the corresponding command from its document tab - right-click on the tab to access a context menu of commands.


Applied Parameters: ObjectKind=ProjectAndDocuments

Summary

This command is used to close the active project. A project is currently active when one of its associated design documents is active in the main design window.

Access

This command is accessed from the active document's editor by choosing the Project » Close Project command, from the main menus.

Use

First, ensure that one of the documents associated with the project you wish to close, is the active document in the main design window.

After launching the command, the active project will be closed. If changes have been made to only one of the project's associated open design documents, a dialog will appear and you will be prompted to save these changes first. If two or more associated open documents have been changed since the last save, the Confirm Save for Modified Documents dialog will appear, from where you can control which of the documents (if any) you want to save before the project is closed.


Applied Parameters: ObjectKind=ProjectDocuments

Summary

This command is used to close all currently open documents associated with the active project. A project is currently active when one of its associated design documents is active in the main design window.

Access

This command is accessed from the active document's editor by choosing the Project » Close Project Documents command, from the main menus.

Use

First, ensure that one of the documents associated with the project whose documents you wish to close, is the active document in the main design window.

After launching the command, all open design documents associated with the active project will be closed. If changes have been made to only one design document, a dialog will appear and you will be prompted to save these changes first. If two or more documents have been changed since the last save, the Confirm Save for Modified Documents dialog will appear, from where you can control which of the documents (if any) you want to save before they are closed.


Applied Parameters: ObjectKind=FocusedDocument

Summary

This command is used to close the focused document in the Projects panel.

Access

This command is accessed from the Projects panel by right-clicking on the entry for the required document and choosing the Close command, from the context menu.

The command will only be available provided the focused document is actually open.

Use

First, ensure that the document you wish to close is the focused document in the Projects panel.

After launching the command, the focused document will be closed. If any changes have been made to the document since the last save, you will be prompted to save these changes first.

Tips

  1. If the document is a free document, its entry will be removed from the Projects panel upon closure.
  2. The focused document can also be closed using the corresponding command from its document tab - right-click on the tab to access a context menu of commands.


Applied Parameters: ObjectKind=FocusedProjectAndDocuments

Summary

This command is used to close the currently focused project in the Projects panel.

Access

This command is accessed from the Projects panel by right-clicking on the entry for the required project and choosing the Close Project command, from the context menu.

Use

First, ensure that the project you wish to close is focused in the Projects panel.

After launching the command, the focused project will be closed. If changes have been made to only one of the project's associated open design documents, a dialog will appear and you will be prompted to save these changes first. If two or more associated open documents have been changed since the last save, the Confirm Save for Modified Documents dialog will appear, from where you can control which of the documents (if any) you want to save before the project is closed.


Applied Parameters: ObjectKind=FocusedCategory

Summary

This command is used to close all open documents within the focused sub-folder in the Projects panel.

Access

This command is accessed from the Projects panel by right-clicking on the entry for the required category (sub-folder) and choosing the Close All command, from the context menu.

The command will only be available provided the focused category contains at least one document that is actually open.

Use

First, ensure that the sub-folder whose documents you wish to close is focused in the Projects panel. Focus is given simply by clicking once on the folder's entry.

After launching the command, all currently open documents residing within the focused sub-folder, or descendant folders therein, will be closed. If changes have been made to only one design document, a dialog will appear and you will be prompted to save these changes first. If two or more documents have been changed since the last save, the Confirm Save for Modified Documents dialog will appear, from where you can control which of the documents (if any) you want to save before they are closed.


Applied Parameters: ObjectKind=FocusedProjectDocuments

Summary

This command is used to close all currently open documents associated with the focused project in the Projects panel.

Access

This command is accessed from the Projects panel by right-clicking on the entry for the required project and choosing the Close Project Documents command, from the context menu.

The command will only be available provided the focused project has at least one document that is actually open.

Use

First, ensure that the project you wish to close all documents for, is focused in the Projects panel.

After launching the command, all open design documents associated with the focused project will be closed. If changes have been made to only one design document, a dialog will appear and you will be prompted to save these changes first. If two or more documents have been changed since the last save, the Confirm Save for Modified Documents dialog will appear, from where you can control which of the documents (if any) you want to save before they are closed.


Applied Parameters: ObjectKind=WorkspaceDocuments

Summary

This command is used to close all currently open documents in the current Design Project Group. All projects that have been opened, will remain opened.

Access

This command is accessed from any editor by choosing the Window » Close Documents command, from the main menus.

Use

After launching the command, all open design documents in the current Design Project Group will be closed - both project-associated and free document types.

If changes have been made to only one design document, a dialog will appear and you will be prompted to save these changes first. If two or more documents have been changed since the last save, the Confirm Save for Modified Documents dialog will appear, from where you can control which of the documents (if any) you want to save before they are closed.

Tips

  1. The current Design Project Group is identified in the Projects panel. Unless a specific Design Project Group is opened, there will always be a default Design Project Group - Project Group 1.DsnWrk - which contains all currently open projects and/or free documents. Although this group exists in terms of carrying out certain Design Project Group-related commands (e.g. opening, closing and compiling), it is initially unsaved and therefore does not exist as an entity on the hard disk.
  2. All document can also be closed using the corresponding command from the right-click context menu of the document tabs area of the main design window.


Applied Parameters: ObjectKind=All

Summary

This command is used to close all currently open documents and projects in the current Design Project Group.

Access

This command can be accessed from any editor by:

  • Choosing the Window » Close All command, from the main menus.
  • Choosing the File » New » Design Project Group command, from the main menus.

Use

After launching the command, all open design documents and projects will be closed.

If changes have been made to only one design document, a dialog will appear and you will be prompted to save these changes first. If two or more documents have been changed since the last save, the Confirm Save for Modified Documents dialog will appear, from where you can control which of the documents (if any) you want to save before they are closed.

Tips

  1. The Projects panel will contain an empty Design Project Group, with the default name Workspace1.DsnWrk. This is ready to accept new or existing projects, added as required. The Design Project Group document itself is initially not saved. In addition, any Items from a managed content server that were previously opened under a direct editing session, but subsequently closed (without discarding or comitting) will appear listed under the <SourceServerName> folder, ready to continue editing should you desire.

 

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.