Tích hợp PLM
Môi trường làm việc Enterprise Server có thể được kết nối với một hoặc nhiều phiên bản PLM, với khả năng hỗ trợ trực tiếp choWindchill®,Arena®,Oracle® Agile™, ArasInnovator® và SiemensTeamcenter® (cần có giấy phép và cấu hình bổ sung). Việc cấu hình giao diện được thực hiện thông qua trang Tích hợp PLM trên giao diện trình duyệt Workspace, cung cấp một giao diện tự động để dễ dàng cấu hình kết nối, ánh xạ dữ liệu tham số và chỉ định hướng đồng bộ hóa dữ liệu. Khi giao diện đã được thiết lập và hoạt động, các tính năng và chức năng sẽ được cung cấp khi làm việc trong các lĩnh vực riêng biệt sau:
- Thư viện (thành phần) – hỗ trợ đồng bộ hóa một chiều hoặc hai chiều các thành phần, tham số thành phần và các lựa chọn bộ phận giữa Workspace và phiên bản PLM của bạn. Giao diện cấu hình cho phép bạn chỉ định tham số nào được quản lý chính trong hệ thống nào. Ngoài ra, tính năng ánh xạ tham số cho phép bạn cập nhật các thuộc tính trên Workspace (có thể cấu hình theo từng trường), mà không cần phải chính thức phát hành một phiên bản mới của Mục thành phần đó. Một quy trình làm việc Yêu cầu Phụ tùng PLM chuyên dụng cũng có sẵn, hỗ trợ việc tự động tạo Thành phần trong hệ thống PLM của bạn, đồng thời truyền các số phụ tùng PLM được tạo ra trở lại các thành phần trong Workspace.
- Thiết kế (dự án) – quy trình làm việc chuyên dụng “Tạo Dự án PLM” hỗ trợ tự động tạo mã linh kiện trong hệ thống PLM của bạn, sau đó truyền các mã này dưới dạng tham số của dự án Altium Designer. Các tham số này có thể được sử dụng trong các chuỗi văn bản đặc biệt (ví dụ: cho chú thích viền bản vẽ). Bạn có thể xuất bản thiết kế của mình lên hệ thống PLM, như một phần của quá trình chạy công cụ Project Releaser trong Altium Designer. Quy trình xuất bản PLM sử dụng một mẫu xuất bản – được định nghĩa như một phần của cấu hình tích hợp hệ thống PLM – để kiểm soát cách dữ liệu được truyền sang hệ thống PLM. Và nếu đây là lần xuất bản đầu tiên và các mã linh kiện (trên hệ thống PLM) chưa được liên kết với dự án, các mã linh kiện đó sẽ được tạo trong hệ thống PLM và liên kết với dự án như một phần của quá trình xuất bản ban đầu. Bạn cũng có thể định nghĩa các mục thành phần cho các thành phần thư viện Workspace trong phiên bản PLM, như một phần của quy trình xuất bản (tùy chọn, tùy thuộc vào cấu hình). Và bạn luôn có thể xem chính xác những gì đã được tạo ra, chẳng hạn như các số phần trong phiên bản PLM, như một phần của lịch sử quy trình làm việc (History tab).
Hỗ trợ PLM
Enterprise Server Workspace cung cấp hỗ trợ trực tiếp cho các hệ thống PLM sau:
- PTCWindchill® PLM phiên bản 12, 13 và PTC Windchill+ ( phiên bản SaaS của Windchill).
- Arena® PLM.
- Oracle® Agile™ PLM.
- ArasInnovator® Phiên bản 30.
Additional Setup for Aras Innovator
Để tích hợp PLM với Aras Innovator, máy chủ Altium của bạn cần được đăng ký với cài đặt xác thực Aras bằng cách thêm một phần nút mới vào sổ đăng ký khách hàng của nó. Sau khi đăng ký, một mã thông báo OAuth duy nhất sẽ được cấp cho máy chủ đã kết nối của bạn để xác thực quyền truy cập.
Các thay đổi cần thiết đối với cấu hình Aras Innovator được thực hiện bằng cách chỉnh sửa tệp đăng ký khách hàng OAuth của nó:
-
Trên máy chủ Aras, mở tệp
\OAuthServer\OAuth.configtệp để chỉnh sửa. -
Tìm và sao chép phần IOMApp – từ dòng
đến dòng. - Dán phần IOMApp đã sao chép ngay sau đó để tạo một phần mới (bản sao).
-
Trong phần nút mới này, đổi tên
IOMAppthànhNEXUS– kết quả là. Xem ví dụ tại . - Lưu lại và sau đó khởi động lại máy Aras.
-
SiemensTeamcenter®, kèm theo thiết lập tích hợp bổ sung.
- Duro PLM, được triển khai dưới dạng một phiên bản PLM của bên thứ ba – xem phần Hỗ trợ PLM của bên thứ ba bên dưới.
Lựa chọn giao diện thiết lập PLM
Kết nối của Altium Enterprise Server với hệ thống PLM được hỗ trợ có thể được thiết lập thông qua giao diện người dùng bán tự động nâng cao, như được mô tả chi tiết bên dưới, hoặc bằng cách sử dụng quy trình thủ công dựa trên việc chỉnh sửa các tệp XML cấu hình PLM. Phương pháp thứ hai yêu cầu kiến thức về cấu trúc dữ liệu của hệ thống PLM đích và sự quen thuộc với định dạng XML, trong khi hệ thống được cập nhật được trình bày dưới đây sẽ tự động lấy dữ liệu cần thiết từ PLM và Altium Workspace để điền vào các tùy chọn menu trong giao diện.
Bạn có thể cấu hình lại Workplace để hiển thị giao diện PLM trước đây – dựa trên việc chỉnh sửa thủ công các tệp XML – bằng cách bỏ chọn tùy chọn Enable new PLM Configuration page tùy chọn trong Admin – Settings – PLM Integration trang của giao diện Workspace. Hãy đảm bảo bạn đã lưu thay đổi, sau đó đăng xuất và đăng nhập lại.
► Xem phiên bản trước của trang này để biết thông tin chi tiết về cách cấu hình các tệp XML PLM và cách làm việc với giao diện PLM cũ.
Kết nối với PLM Instance của bạn
Các cấu hình PLM được tạo và quản lý trong Admin – PLM Integration trang của giao diện trình duyệt Workspace. Khi bạn đã kết nối thành công với hệ thống PLM, giao diện cấu hình sẽ cung cấp một loạt các tùy chọn tích hợp dựa trên dữ liệu được lấy từ cả Workspace và PLM đã kết nối.
Sử dụng nút “
” để bắt đầu quá trình kết nối và thực hiện theo hướng dẫn trong trình chiếu bên dưới.
|
Nhấp vào " Nhập một tên duy nhất Name/Description cho cấu hình mới, chọn loại PLM phù hợp từ Driver menu thả xuống, và (đối với ví dụ Aras này) một cơ sở dữ liệu làm việc cụ thể nếu có. Nhập Username/Password thông tin đăng nhập cho hệ thống PLM, sau đó nhấp vào Kết nối PLM thành công sẽ được xác nhận dưới tiêu đề Server Connection tiêu đề, và Workspace sẽ hiển thị trên giao diện các tùy chọn dữ liệu tham số được lấy từ cả dữ liệu thành phần của Workspace và dữ liệu thuộc tính PLM. Sau khi tải xong, giao diện sẽ hiển thị dữ liệu tham số và loại đã nhập dưới dạng các tùy chọn menu hoặc trường có thể chọn. |
Bất kỳ lỗi kết nối nào sẽ được đánh dấu màu đỏ khi đăng nhập vào hệ thống PLM đích. Viền dưới của hộp đánh dấu sẽ hiển thị chi tiết lỗi – xem ví dụ tại .
PTC Windchill SSO Support
Khả năng sử dụng xác thực Đăng nhập Một Lần (SSO) khi kết nối với hệ thống PLM Windchill hiện có sẵn và được thiết lập thông qua giao diện Workspace. Điều này cung cấp một phương pháp ủy quyền kết nối đơn giản và an toàn khi thực hiện các quy trình PLM trên Workspace như Tạo Dự án và Xuất bản lên PLM. Trên thực tế, cơ chế này cho phép cấp quyền truy cập Windchill thông qua tiêu chuẩn ủy quyền OAuth bằng dịch vụ nhà cung cấp danh tính như PingFederate.
Bạn có thể truy cập cài đặt SSO tại OAuth trong trang Workspace PLM Integration (Admin - PLM Integration), nơi có thể thêm nhiều thực thể nhà cung cấp OAuth.
Việc thiết lập ủy quyền nhà cung cấp OAuth được hoàn tất dựa trên dữ liệu có sẵn từ nhà cung cấp danh tính đã được cấu hình của bạn. Nhập tên và các thông tin cần thiết cho Workspace – ID, mã thông báo, URL, v.v. – vào các trường trên trang. Sau đó, lưu cấu hình đã hoàn tất.
Thông tin cần thiết để thiết lập một phiên bản OAuth SSO mới được lấy từ cấu hình nhà cung cấp OAuth hiện có.
Thực thể nhà cung cấp OAuth mới sẽ có sẵn khi tùy chọn OAuth Connection tùy chọn này được bật trong cấu hình Windchill PLM. Chọn từ OAuth Provider danh sách thả xuống khi có nhiều nhà cung cấp khả dụng. Hoàn tất thiết lập kết nối bằng nút “
” và làm theo hướng dẫn của nhà cung cấp nếu cần thiết.
Hỗ trợ PLM của bên thứ ba
Altium Enterprise Server cung cấp hỗ trợ bổ sung cho các cấu hình hệ thống PLM 'không gốc' do bên thứ ba phát triển. Hỗ trợ này được kích hoạt bởi Generic Connector, yêu cầu Altium PLM Generic Connector Addon license.
Khi thêm một PLM Instance trong Workspace cho hệ thống như vậy, các tệp XML được cấu hình sẵn do bên thứ ba cung cấp sẽ được tải lên cấu hình PLM Instance đó thông qua giao diện Tích hợp PLM. Một ví dụ về điều này là hỗ trợ Duro PLM trong Enterprise Server.
Thiết lập cấu hình
Sau khi kết nối thành công với một phiên bản PLM, giao diện Workspace PLM cung cấp các thiết lập cấu hình để xác định cách thức đồng bộ hóa linh kiện được thực hiện, việc ánh xạ chéo các tham số linh kiện và phương pháp truyền dữ liệu được sử dụng cho dữ liệu Lựa chọn Linh kiện. Các tùy chọn đồng bộ hóa này có sẵn trong Configuration trên giao diện.
Các tùy chọn cài đặt cấu hình có sẵn cho bạn (cùng với nhãn/chức năng của chúng) được xác định bởi loại hệ thống PLM và dữ liệu tham số được lấy từ cả Workspace và phiên bản PLM được kết nối.
Tham số đồng bộ
Phần giao diện PLM này xác định các loại thành phần sẽ được đồng bộ hóa, vị trí và cách thức tạo/cập nhật các thành phần mới, cũng như bất kỳ ràng buộc nào dựa trên tiêu chí tham số.
Cách đồng bộ hóa các thành phần được chỉ định riêng lẻ:
- Chọn một Altium Component Type trong danh sách tham số và thiết lập Sync Direction tùy chọn theo nhu cầu (Đến Altium/PLM hoặc cả hai) – các tùy chọn loại thành phần được lấy từ dữ liệu thành phần hiện tại trong Workspace.
- Chọn tên thuộc tính PLM liên quan từ PLM Type menu – các tùy chọn có sẵn được lấy từ phiên bản PLM đã kết nối.
- Trong Altium Target Folder trường (dưới mục Sync to Altium) duyệt đến và chọn một thư mục thành phần Workspace làm vị trí đồng bộ hóa cho thành phần này.
- Chỉ định một Sync Mode để xác định liệu các thành phần mới sẽ được tạo trong quá trình đồng bộ hóa, hay chỉ các thành phần hiện có được cập nhật – hoặc cả hai.
-
Đặt Component Template sẽ được sử dụng để xác định các loại tham số của thành phần khi đồng bộ hóa thành phần này. Cài đặt này sẽ mặc định là tùy chọn đã chọn Altium Component Type (ví dụ:
Capacitors) nếu có sẵn mẫu Workspace liên quan. - Sử dụng Add Parameter Criteria tùy chọn này để chỉ định giá trị tham số mà quá trình đồng bộ hóa sẽ bị ràng buộc bởi. Một thành phần sẽ không được đồng bộ hóa trừ khi nó thỏa mãn tiêu chí này. Thêm các tiêu chí tham số khác nếu cần.
Các tùy chọn bổ sung sẽ có sẵn khi kết nối với hệ thống PTC Windchill PLM hỗ trợ hệ thống PartsLink của Windchill. Hệ thống PartsLink hệ thống này cho phép phân loại các bộ phận thành các nhóm để việc nhắm mục tiêu thuận tiện và nhanh chóng hơn, đồng thời có thể bao gồm các cặp Thuộc tính/Giá trị liên quan để cung cấp định nghĩa chi tiết hơn trong phạm vi Phân loại đó. Xem phần có thể thu gọn bên dưới để biết thêm thông tin.
- Chọn Add Classification Name Criteria từ Filter Criteria để thêm bộ lọc phân loại. Sử dụng menu tên để chọn nhóm phân loại mà quá trình đồng bộ hóa sẽ được lọc theo.
-
Để kiểm soát chi tiết hơn, hãy chọn Add Classification Attribute Criteria tùy chọn này và chỉ định Attribute và Giá trị liên quan của nó. Trong ví dụ được hiển thị ở đây, chỉ các tụ điện thuộc
102-CapcitorscóCapacitancegiá trị10uFsẽ được đồng bộ hóa.
More on Windchill PartsLink
Trong chính Windchill, một Phân loại PartsLink được định nghĩa bằng cách tạo một binding attribute có thể áp dụng cho một loại bộ phận. Sau đó, một Thuộc tính Phân loại bộ phận sẽ được thêm vào lớp Phân loại đã định nghĩa.
Các mục thành phần trong Windchill sẽ tích hợp Phân loại đã định nghĩa và bất kỳ tham số Thuộc tính Phân loại nào được chỉ định, từ đó các thông tin này sẽ có sẵn cho quy trình đồng bộ hóa thành phần PLM trong Workspace.
Khi một mục thành phần được đồng bộ hóa từ Windchill sang Workspace và tương tác PartsLink đã được chỉ định trong cấu hình PLM của Workspace, các Thuộc tính cấu hình của Windchill cho bộ phận đó sẽ được truyền sang Altium Designer.
Khi Sync Direction được đặt thành To PLM hoặc để đồng bộ hai chiều (To PLM & To Altium) thì Add Filter Criteria tùy chọn sẽ xuất hiện dưới mục Sync To PLM. Sử dụng tùy chọn này để thiết lập các tiêu chí về Thông số hoặc Thư mục nhằm kiểm soát các thành phần Workspace nào sẽ được truyền sang hệ thống PLM.
Có thể thêm nhiều tiêu chí Thông số để hạn chế chặt chẽ việc đồng bộ hóa các thành phần Workspace sang PLM. Các tiêu chí có sẵn cũng bao gồm OR và NOT các tùy chọn mệnh đề để thiết lập kiểm soát chính xác hơn đối với việc lọc các thành phần được chấp nhận để đồng bộ hóa với PLM.
Phần Sync to PLM phần này cung cấp các tùy chọn bổ sung về đánh số bộ phận và tiền tố/hậu tố khi nhắm đến hệ thống Arena PLM. Các sơ đồ PLM được định nghĩa sẵn này có sẵn để lựa chọn trong Numbering Scheme và Code , và sẽ xác định định dạng Số Mục của các bộ phận được tải lên Arena.
Ánh xạ tham số thành phần
Tiếp tục quy trình tương tự như trên để chỉ định cấu hình thông số đồng bộ cho tất cả các thành phần mà bạn muốn đồng bộ hóa với PLM. Vì các thông số thành phần ở phía Workspace không nhất thiết phải trùng khớp với các thông số ở phía PLM, nên phần Component Parameter Mapping phần giao diện có thể được sử dụng để ánh xạ các tham số giữa hai bên. Lưu ý rằng khi các tham số được ánh xạ, giá trị của chúng sẽ được đồng bộ hóa từ bên này sang bên kia như thể chúng là cùng một tham số.
Sử dụng lệnh Add Parameter để tạo một mục ánh xạ tham số Workspace/PLM áp dụng cho tham số hiện đang được chọn Altium Component Type (như đã chọn trong Sync Parameters). Các tùy chọn của PLM và Altium Parameter Name là các tùy chọn có sẵn trong các hệ thống tương ứng. Một Revision Cài đặt trong Item/Revision sẽ khiến một phiên bản linh kiện mới được tạo ra khi tham số thay đổi, trong khi với Item cài đặt này, chỉ tham số thành phần mới được cập nhật trong quá trình đồng bộ hóa.
Sử dụng biểu tượng “
” liên quan để xóa một mục ánh xạ.
Có thể ánh xạ bất kỳ số lượng tham số nào theo cách này, tuy nhiên có thể sẽ có một loạt các tham số Workspace/PLM chung cần được ánh xạ cho tất cả các thành phần. Phương pháp ánh xạ toàn cục này có sẵn khi All Types được chọn làm Altium Component Type.
Tạo các mục ánh xạ (Add Parameter) sẽ áp dụng cho tất cả các thành phần bằng cách bao gồm các cặp tham số chung đã biết. và thiết lập Item/Revision và Sync Direction theo yêu cầu. Điều quan trọng là phải chỉ định một mục tham số được ánh xạ làm Primary Key – đây là cặp tham số chung đóng vai trò là chỉ số tham chiếu giữa hai tập dữ liệu tham số. Khi đây là Mã Phần PLM (được khuyến nghị), số được tạo ở phía PLM sẽ được truyền ngược lại phía Altium, tạo ra một liên kết tham chiếu đã biết giữa các tập dữ liệu linh kiện được đồng bộ hóa.
Thuộc tính phân loại PLM
Đối với hệ thống PLM PTC Windchill được kết nối, hỗ trợ nhóm linh kiện dưới dạng Phân loại, các thuộc tính và giá trị PLM liên quan có thể được ánh xạ sang các tham số linh kiện trong Workspace tại phần này.
Để trích xuất giá trị Thuộc tính Phân loại cụ thể từ Windchill – ví dụ: giá trị điện dung cho Tụ điện trong 102-Capacitor lớp – hãy thêm Phân loại và Giá trị của nó (Capacitance) làm PLM Parameter Name và tham số thành phần Altium đích (Value) làm Altium Parameter Name. Có thể thêm các định nghĩa cho tất cả các Loại linh kiện, bao gồm nhiều định nghĩa cho cùng một loại linh kiện.
► Xem thông tin PartsLink ở trên để biết thêm về Phân loại Windchill.
Lựa chọn linh kiện
Sử dụng Sync Direction để chỉ định hướng đồng bộ hóa dữ liệu Lựa chọn Phụ tùng của nhà sản xuất giữa Workspace và hệ thống PLM, hoặc vô hiệu hóa đồng bộ hóa Lựa chọn Phụ tùng bằng tùy chọn OFF tùy chọn này.
Tùy thuộc vào loại hệ thống PLM được kết nối, Part Choice information tùy chọn này sẽ cung cấp tính năng đồng bộ hóa ở định dạng tương thích với các bộ phận sản xuất đã được phê duyệt của chính hệ thống PLM (Native PLM Manufacturer Parts) hoặc dưới dạng dữ liệu tham số linh kiện thông thường (PLM Part Attributes). Loại thứ hai có thể là nhiều bộ thuộc tính tham số Nhà sản xuất:Mã số bộ phận – MFR1:MPN1, MFR2:MPN2, chẳng hạn.
Dữ liệu Lựa chọn Phụ tùng PLM gốc
Đặt Part Choice Information menu thành Native PLM Manufacturer Parts tùy chọn này để đồng bộ hóa thông tin Lựa chọn Phần tử Altium với dữ liệu nguồn cung ứng phần tử 'bản địa' (hoặc tích hợp sẵn) của hệ thống PLM được kết nối. Một ví dụ về mối quan hệ này là Manufacturer Parts trong Windchill.
Thông tin nguồn cung cấp linh kiện trong Arena chủ yếu được lưu trữ dưới dạng Vendor tham số, với mối quan hệ thứ cấp (gián tiếp) của Manufacturer tham số. Giao diện PLM của Enterprise Server đáp ứng điều này bằng cách cung cấp tùy chọn đồng bộ hóa với Arena thông qua một direct hoặc indirect mối quan hệ nguồn cung cấp bộ phận.
Khi chỉ định các tùy chọn Lựa chọn Phụ tùng trong cấu hình Arena của bạn, các Part Choice Information các tùy chọn trong menu thả xuống là:
-
Native PLM Manufacturer Parts: Direct Source Relationship – Chọn tùy chọn này để liên kết dữ liệu Lựa chọn Linh kiện của Altium với Vendor dữ liệu mối quan hệ cung ứng của Arena. Đây là điều kiện mặc định trước đây, do đó bất kỳ
ToPLMhiện có đều đã nhắm đến mối quan hệ Nhà cung cấp. - Native PLM Manufacturer Parts: Indirect Source Relationship – Chọn tùy chọn này để liên kết dữ liệu Altium Part Choice với Manufacturer của Arena. Dữ liệu nhà sản xuất linh kiện Altium sau đó sẽ tương ứng với các mục dữ liệu nhà sản xuất trên hệ thống PLM.
-
PLM Part Attributes – Như đã nêu ở trên, hãy chọn tùy chọn này để thiết lập đồng bộ hóa Part Choice ‘không gốc’ dựa trên dữ liệu tham số linh kiện thông thường được hình thành bởi các tập hợp
Manufacturer:PartNumberthuộc tính, được chọn thông qua Attribute Definitions.
Teamcenter Tích hợp PLM vốn hỗ trợ đồng bộ hóa hai chiều các lựa chọn linh kiện của nhà sản xuất giữa Enterprise Server và phiên bản Teamcenter PLM. Dữ liệu lựa chọn linh kiện (Manufacturer Part Number và Manufacturer) ở phía Altium có thể được đồng bộ hóa trực tiếp với các tùy chọn linh kiện 'bản địa' Manufacturer Part và Vendor tham số 'bản địa' ở phía Teamcenter, những thông tin này sẽ có sẵn khi các tính năng Quản lý Nhà cung cấp của Teamcenter được kích hoạt.
XML cấu hình dự án
Phần này cung cấp danh sách cấu hình XML cơ bản xác định cấu hình PLM ban đầu cho hệ thống PLM được kết nối. Phiên bản đã tải xuống của tệp XML cấu hình cơ bản này (Download Sample Configuration) bao gồm các chú thích chi tiết nêu rõ chức năng của hầu hết các phần Entity và Attribute.
Cuối cùng, cấu hình mà bạn xác định trong giao diện Tích hợp PLM sẽ được lưu dưới dạng các tệp XML hệ thống, có thể được lưu cục bộ thông qua Export Configuration lệnh liên quan đến Server Connection phần chi tiết ở đầu trang cấu hình.
Một Import Configuration tùy chọn cũng được bao gồm, cho phép bạn áp dụng tệp XML cấu hình hiện có vào một cấu hình PLM mới (hoặc đã chỉnh sửa), từ đó sẽ sao chép lại thiết lập PLM đó. Ngoài ra, trong trường hợp cần thực hiện các thay đổi chuyên biệt đối với cấu hình PLM hiện có, tệp XML đã xuất của cấu hình đó sẽ được chỉnh sửa thủ công và sau đó nhập lại vào cấu hình.
Bổ sung Mẫu Xuất bản
Cấu hình PLM yêu cầu bổ sung một Publishing Template để hỗ trợ các quy trình Workspace gửi toàn bộ dữ liệu dự án – tệp thiết kế, dữ liệu đầu ra về linh kiện và sản xuất – đến hệ thống PLM trong một thao tác 'xuất bản' duy nhất. Các quy trình này bao gồm “Publish to PLM”, nơi người dùng chỉ định dữ liệu đầu ra cần gửi, và “Project Releaser with Publish”, gửi dữ liệu đã tạo đến PLM như bước cuối cùng trong quy trình “Project Release” của Altium Designer.
Thêm tệp XML Mẫu Xuất bản phù hợp vào tab Publish Template khi tạo hoặc chỉnh sửa cấu hình PLM của bạn. Sử dụng Sample Project Configurations liên kết này để tải xuống bộ sưu tập các mẫu đã được nén dành cho các hệ thống PLM được hỗ trợ.
Một Publishing Template bao gồm các tham chiếu về chi tiết dự án, chuyển dữ liệu linh kiện, vị trí nguồn dữ liệu và phân phối tệp dữ liệu Thiết kế, Lắp ráp và Sản xuất. Các ví dụ đã tải xuống bao gồm các mẫu cho tất cả các hệ thống PLM được hỗ trợ, trong đó mỗi mẫu sẽ bao gồm bất kỳ Quy tắc Xuất bản bổ sung nào áp dụng cho loại PLM cụ thể đó cùng với các chú thích chi tiết để hướng dẫn bạn về những gì cần cấu hình và cách thực hiện.
Publishing Folder Support for Windchill PLM
Khi cấu hình một phiên bản Tích hợpPLM Windchill® sẽ được sử dụng cho các quy trình Xuất bản sang PLM, bạn cũng có thể chỉ định (và tạo) một thư mục Windchill đích cho các tài liệu được xuất bản từ Không gian làm việc.
Các tham số thư mục Windchill liên quan được định nghĩa trong tệp XML Mẫu Xuất bản được áp dụng cho mục tích hợp Windchill PLM của bạn trong Workspace (xem ở trên). Các nút định nghĩa thư mục có định dạng thẻ – trong đó pt là không gian tên hiện tại và xxx là đường dẫn đầy đủ của thư mục – và được đặt dưới dạng quy tắc xuất bản trong phần FileDistribution phần dành cho từng loại tài liệu (chẳng hạn như PCB.zip Kết quả chế tạo chẳng hạn).
Một ví dụ về cấu trúc phân cấp XML xuất bản sẽ là:
PRODUCT/Projects/${project.name}/FAB data
Dòng mục cuối cùng sẽ chỉ định (hoặc tạo) một thư mục đích xuất bản cho PCB.zip kết quả sản xuất theo cấu trúc thư mục Windchill (trong đó tên dự án là MyProject):
PRODUCT
Projects
MyProject
FAB data
Lưu ý rằng đường dẫn thư mục được định nghĩa trong tệp XML Xuất bản là đường dẫn tuyệt đối (chứ không phải tương đối), và có thể bao gồm các thuộc tính dự án khác như Tên dự án (${project.name}) và Số lắp ráp (${project.PLM_ASSEMBLY_NUMBER}).
Sửa đổi mẫu XML mẫu theo yêu cầu và tải tệp lên cấu hình PLM của bạn thông qua Add Publish Template cửa sổ được mở từ nút “
”. Lưu ý rằng một cấu hình PLM hỗ trợ nhiều mẫu xuất bản.
Đồng bộ hóa thành phần
Việc đồng bộ hóa dữ liệu thành phần giữa Altium 365 Workspace của bạn và hệ thống PLM được kết nối được xác định bởi ánh xạ tham số và hướng được kích hoạt như đã nêu ở trên, và sẽ diễn ra khi quá trình đồng bộ hóa được kích hoạt thủ công hoặc tự động vào thời gian đã lên lịch. Quá trình đồng bộ hóa này được điều khiển bởi LibSync .
Trong một phiên bản cấu hình PLM, các tùy chọn đồng bộ hóa liên quan được truy cập trong tab Component Synchronization , nơi quy trình có thể được kích hoạt thủ công hoặc đặt theo lịch trình. Đối với trường hợp sau, hãy bật tùy chọn Synchronize on a schedule tùy chọn này và chọn khoảng thời gian từ menu thả xuống liên quan.
Bạn có thể sử dụng các tùy chọn trong menu “
” để kích hoạt thủ công LibSync quy trình dưới dạng Incremental hoặc Full sự kiện đồng bộ hóa:
-
Incremental – chỉ áp dụng cho những thành phần đã được sửa đổi kể từ lần đồng bộ hóa gần nhất (tức là dấu thời gian của chúng muộn hơn ngày đồng bộ hóa gần nhất) và đáp ứng các tiêu chí đồng bộ hóa trong cấu hình. Lưu ý rằng đây là chế độ được sử dụng khi sự kiện đồng bộ hóa được kích hoạt từ điều khiển “
” trên trang chính “PLM Integration” – xem bên dưới.
- Full – chế độ này buộc thực hiện đồng bộ hóa toàn bộ. Tất cả các thành phần đáp ứng các tiêu chí đồng bộ hóa trong cấu hình sẽ được bao gồm.
Thực hiện đồng bộ hóa thành phần
Việc đồng bộ hóa thành phần (thư viện) có thể được thực hiện dưới dạng quy trình thủ công từ mục nhập phiên bản PLM trên trang Tích hợp PLM của Không gian làm việc, hoặc dưới dạng chu kỳ tự động được chỉ định trong thiết lập phiên bản – xem ở trên. Nhấp vào điều khiển “
” liên quan đến phiên bản PLM để gọi thủ công quy trình đồng bộ hóa, quy trình này sẽ tiến hành theo LibSync quy trình làm việc bằng cách sử dụng các cài đặt được định nghĩa trong cấu hình PLM liên quan.
Nút Actions nút điều khiển sẽ chuyển thành “
”, cho phép bạn dừng quy trình đồng bộ hóa nếu cần thiết, và Sync Status mục này sẽ hiển thị rằng quá trình đang diễn ra. Trạng thái sẽ chuyển sang Completed khi quá trình đồng bộ hóa đã hoàn tất.
Khi quá trình đồng bộ hóa thành phần được thực thi, dù là thủ công hay theo lịch trình, LibSync quá trình sẽ di chuyển qua Quy trình làm việc (Workflow) được định nghĩa sẵn cho đến khi hoàn tất hoặc gặp lỗi. Bạn có thể làm mới trình duyệt (F5) để xem trạng thái hiện tại của quá trình đồng bộ hóa.
Để truy cập chi tiết của một sự kiện đồng bộ hóa đã hoàn tất, hãy nhấp vào biểu tượng
trong Last Sync cột để tải xuống tệp nhật ký liên quan (xem ví dụ), hoặc chọn ngày liên quan để mở mục sự kiện trong Synchronization Status tab. Lưu ý rằng trong chế độ xem này, các sự kiện đồng bộ hóa đã hoàn tất sẽ được liệt kê khi Closed tùy chọn này được chọn, và bất kỳ sự kiện nào đang chạy hoặc bị tạm dừng sẽ xuất hiện khi Active chế độ xem được chọn.
Các tab con của chế độ xem Trạng thái cung cấp các thông tin sau:
- Diagram – một biểu đồ minh họa quy trình làm việc, với vị trí bước hiện tại được đánh dấu (Đã hoàn thành hoặc trạng thái lỗi/thất bại).
- Data – bản tóm tắt thông tin về hành động quy trình, bao gồm kết quả thành công hoặc thất bại của các bước và liên kết đến báo cáo quy trình đã được ghi lại – xem ví dụ tại .
- History – nhật ký thời gian của các sự kiện đồng bộ hóa Workspace chính được liệt kê theo thứ tự.
Bất kỳ sự kiện đồng bộ hóa nào bị dừng sớm, chẳng hạn như khi gặp lỗi, sẽ được liệt kê khi chế độ xem ở Active chế độ này. Các mục này có thể được xóa khỏi danh sách bằng Terminate , hoặc chính xác hơn là được đánh giá và giải quyết từ ô Nhiệm vụ liên quan được tạo trong chế độ xem Nhiệm vụ của Workspace. Lưu ý rằng sự kiện đồng bộ hóa đã bị chấm dứt/đã được giải quyết sẽ được chuyển sang Synchronization Status danh sách Closed với một Status, chẳng hạn như Failed.
Truy cập các quy trình liên quan đến PLM
Các mẫu quy trình làm việc liên quan đến hệ thống PLM được kết nối có sẵn trong các tab chủ đề quy trình trên trang Quy trình trong Không gian làm việc. Nói chung, các mẫu này không thể được sử dụng trực tiếp, mà phải được lưu lại dưới một tên khác để có hiệu lực.
► Xem tài liệu Quy trình & Luồng công việc để biết thêm thông tin.
Quản trị viên Workspace có thể khởi chạy một phiên bản mới của bất kỳ định nghĩa quy trình nào đã được kích hoạt trực tiếp từ danh sách quy trình trên Processes bằng cách nhấp vào nút “
”. Người dùng Workspace không phải quản trị viên cũng có thể khởi tạo các quy trình đang hoạt động từ Workspace, chẳng hạn như:
-
Một Part Request with PLM quy trình từ nút “
” trên trang “Part Request”.
-
Một Publish to PLM quy trình từ nút “
” trên các trang “Tasks” và “Activities” của một dự án đang mở.
-
Một Publish to PLM quy trình từ nút “
” trên trang “Dự án” chính.
-
Một Project with Initialize in PLM quy trình từ nút "
" trên trang "Projects" chính, hoặc khi sao chép (clone) một dự án từ menu của nút "
".
Tuy nhiên, trên thực tế, các quy trình liên quan đến PLM thường được khởi chạy từ Altium Designer trong quá trình thiết kế và phát triển dự án. Các quy trình liên quan đến PLM được truy cập từ Altium Designer theo các cách sau:
-
Part Request with PLM Part Create – Truy cập từ Altium Designer Explorer, Manufacturer Part Search và Components
► Xem Yêu cầu linh kiện dựa trên quy trình để biết thông tin chi tiết. -
Publish to PLM (User selects) – Truy cập từ Project » Project Activities menu con của dự án Altium Designer đang hoạt động.
► Xem phần “Đăng tải lên hệ thống PLM – do người dùng chọn” để biết thông tin chi tiết. -
Project Releaser with Publish – Truy cập như giai đoạn cuối cùng của “Project Releaser” từ Project » Project Releaser trong menu con của dự án Altium Designer đang hoạt động.
► Xem “Phát hành dự án thiết kế – xuất bản lên PLM” để biết thông tin chi tiết. -
Project with initialise in PLM – Truy cập khi tạo dự án Altium Designer mới từ File » New » Project in
menu con, hoặc khi sao chép (Clone) một dự án.
► Xem Xuất bản lên PLM – Khởi tạo trong PLM để biết thông tin chi tiết.
Quy trình làm việc
Các định nghĩa quy trình sau đây (và các quy trình làm việc cơ bản) có sẵn thông qua Workspace, nhằm hỗ trợ tích hợp PLM:
-
Part Requests Chủ đề quy trình:
-
Part Request with PLM Part Create– hỗ trợ việc tự động tạo một Thành phần trong phiên bản PLM của bạn, sau đó truyền số bộ phận được tạo ra trở lại thành phần trong Workspace. Sơ đồ quy trình làm việc được hiển thị bên dưới.
Một điều quan trọng cần lưu ý là khi bạn sửa đổi định nghĩa mẫu này để tạo định nghĩa của riêng mình, bạn phải chỉ định hệ thống PLM mà các bộ phận sẽ được tạo ra. Chọn Create Part in PLM thực thể trong sơ đồ quy trình làm việc và chọn phiên bản PLM từ menu thả xuống liên quan đến PLM Instance trường này. Menu này liệt kê tất cả các phiên bản PLM hiện đã được định nghĩa (như được định nghĩa trên PLM Integration trang của giao diện).
► Xem Tạo và Quản lý Quy trình để biết thêm thông tin về cách làm việc với các quy trình công việc.
-
-
Project Activities chủ đề quy trình:
-
Publish to PLM (User selects)– Xuất bản các kết quả dự án Workspace đã được phát hành lên hệ thống PLM tích hợp, nơi người dùng có thể chọn chính xác các kết quả nào sẽ được xuất bản. Sơ đồ luồng công việc được hiển thị bên dưới.
-
Project Releaser with Publish– Xuất bản lên hệ thống PLM tích hợp như một giai đoạn bổ sung của công cụ Project Releaser. Sơ đồ luồng công việc được hiển thị bên dưới.
-
-
Project Creations Chủ đề quy trình:
-
Project with initialise in PLM– Hỗ trợ việc tạo tự động các mã bộ phận trong hệ thống PLM của bạn, sau đó truyền các mã này dưới dạng các tham số của dự án thiết kế Workspace. Sơ đồ quy trình làm việc được hiển thị bên dưới.
-
.
.
