Tích hợp PLM
Workspace Enterprise Server có thể được kết nối với một hoặc nhiều phiên bản PLM, với hỗ trợ trực tiếp cho Windchill®, Arena®, Oracle® Agile™, Aras Innovator® và Siemens Teamcenter® (cần thêm giấy phép và thiết lập). Việc cấu hình giao diện được thực hiện thông qua trang PLM Integration page trong giao diện trình duyệt của Workspace, cung cấp một giao diện tự động để dễ dàng cấu hình kết nối liên thông, ánh xạ dữ liệu tham số và chỉ định chiều đồng bộ dữ liệu. Khi giao diện đã được thiết lập và hoạt động, các tính năng và chức năng sẽ khả dụng khi làm việc trong các khu vực riêng biệt sau:
- Thư viện (linh kiện) – hỗ trợ đồng bộ một chiều hoặc hai chiều các linh kiện, tham số linh kiện và lựa chọn part giữa Workspace của bạn và phiên bản PLM. Giao diện cấu hình cho phép bạn chỉ định tham số nào được quản lý chính ở hệ thống nào. Ngoài ra, tính năng ánh xạ tham số cho phép bạn cập nhật thuộc tính ở phía Workspace (có thể cấu hình theo từng trường) mà không cần chính thức phát hành một revision mới cho Component Item đó. Ngoài ra còn có quy trình Part Request workflow chuyên dụng cho PLM, hỗ trợ tự động tạo một Component trong phiên bản PLM của bạn, đồng thời đưa các mã part PLM được tạo trở lại các linh kiện trong Workspace.
- Thiết kế (dự án) – có sẵn quy trình Project Creation workflow chuyên dụng cho PLM, hỗ trợ tự động tạo mã part trong phiên bản PLM của bạn, sau đó truyền các mã này thành tham số của dự án Altium Designer. Các tham số này có thể được dùng trong các chuỗi đặc biệt (ví dụ: cho chú thích khung bản vẽ). Bạn cũng có thể publish your design lên phiên bản PLM của mình như một phần khi chạy Project Releaser trong Altium Designer. Thao tác xuất bản lên PLM sử dụng một publishing template – được định nghĩa như một phần của cấu hình tích hợp phiên bản PLM – để kiểm soát cách dữ liệu được truyền sang PLM. Và nếu bạn xuất bản lần đầu tiên và các mã part (ở phía PLM) chưa được liên kết với dự án, thì các mã part đó sẽ được tạo trong PLM và gắn với dự án như một phần của lần xuất bản ban đầu đó. Bạn cũng có thể định nghĩa các mục linh kiện cho các linh kiện thư viện Workspace trong phiên bản PLM như một phần của thao tác xuất bản (tùy chọn, tùy theo cấu hình). Đồng thời, bạn luôn có thể xem chính xác những gì đã được tạo, chẳng hạn như các mã part trong phiên bản PLM, như một phần của process workflow's history (History tab).
Hỗ trợ PLM
Workspace Enterprise Server cung cấp hỗ trợ trực tiếp cho các hệ thống PLM sau:
-
PTC Windchill® PLM phiên bản 12, 13, và PTC Windchill+ (biến thể SaaS variant của Windchill).
-
Arena® PLM.
-
Oracle® Agile™ PLM.
-
Aras Innovator® Release 30.
Additional Setup for Aras Innovator
Để đạt được tích hợp PLM với Aras Innovator, máy chủ Altium của bạn cần được đăng ký với thiết lập Aras Authentication setup bằng cách thêm một phần node mới vào client registry của nó. Sau khi đăng ký, một token OAuth duy nhất sẽ được cấp cho máy chủ đã kết nối của bạn để xác thực truy cập.
Các thay đổi cần thiết đối với cấu hình Aras Innovator được thực hiện bằng cách chỉnh sửa tệp client registry OAuth của nó:
-
Trên máy chủ lưu trữ Aras, mở tệp
\OAuthServer\OAuth.configđể chỉnh sửa. -
Tìm và sao chép phần IOMApp – từ dòng
<clientRegistry id="IOMApp" enabled="true">đến dòng</clientRegistry>. - Dán phần IOMApp đã sao chép ngay phía sau để tạo một phần mới (bản sao).
-
Trong phần node mới này, đổi tên
IOMAppthànhNEXUS– kết quả là<clientRegistry id="NEXUS" enabled="true">. Xem ví dụ. - Lưu lại rồi khởi động lại máy Aras.
-
Trên máy chủ lưu trữ Aras, mở tệp
-
Siemens Teamcenter®, với integration setup bổ sung.
-
Duro PLM, được triển khai như một phiên bản PLM của bên thứ ba – xem Third Party PLM Support bên dưới.
Lựa chọn giao diện thiết lập PLM
Kết nối của Altium Enterprise Server tới một hệ thống PLM được hỗ trợ có thể được thiết lập thông qua giao diện người dùng bán tự động nâng cao như mô tả bên dưới, hoặc bằng quy trình thủ công dựa trên việc chỉnh sửa các tệp XML cấu hình PLM. Cách thứ hai đòi hỏi hiểu biết về cấu trúc dữ liệu của hệ thống PLM đích và sự quen thuộc với định dạng XML, trong khi hệ thống cập nhật được trình bày bên dưới sẽ tự động lấy dữ liệu cần thiết từ PLM và Altium Workspace để điền các lựa chọn menu trong giao diện.
Bạn có thể cấu hình lại Workplace để hiển thị giao diện PLM trước đây – dựa trên việc chỉnh sửa thủ công các tệp XML – bằng cách bỏ chọn tùy chọn Enable new PLM Configuration page trong trang Admin – Settings – PLM Integration của giao diện Workspace. Hãy nhớ lưu thay đổi, sau đó đăng xuất và đăng nhập lại.
► Xem previous version of this page để biết thông tin chi tiết về cấu hình các tệp XML PLM và làm việc với giao diện PLM cũ.
Kết nối tới phiên bản PLM của bạn
Các PLM Configuration được tạo và quản lý trong trang Admin – PLM Integration của giao diện trình duyệt Workspace.
Khi bạn đã kết nối thành công với hệ thống PLM, giao diện cấu hình sẽ cung cấp một loạt tùy chọn tích hợp dựa trên dữ liệu lấy từ cả Workspace và PLM đã kết nối.
Sử dụng nút
để bắt đầu quá trình kết nối và thực hiện theo hướng dẫn trong trình chiếu bên dưới.
|
Nhấp Nhập Name/Description duy nhất cho cấu hình mới, chọn đúng loại PLM từ menu thả xuống Driver, và (trong ví dụ Aras này) một cơ sở dữ liệu làm việc cụ thể nếu áp dụng. Nhập thông tin xác thực Username/Password của bạn cho hệ thống PLM rồi nhấp Kết nối PLM thành công được xác nhận dưới tiêu đề Server Connection, và sau đó Workspace sẽ điền vào giao diện các tùy chọn dữ liệu tham số lấy từ cả dữ liệu linh kiện của Workspace và dữ liệu thuộc tính của PLM. Sau khi tải xong, giao diện sẽ hiển thị dữ liệu tham số và dữ liệu kiểu đã nhập dưới dạng các tùy chọn menu hoặc trường có thể chọn. |
Mọi lỗi kết nối sẽ được tô đỏ khi đăng nhập vào hệ thống PLM đích. Viền dưới của khung tô sáng sẽ bao gồm chi tiết lỗi – xem ví dụ.
PTC Windchill SSO Support
Khả năng sử dụng xác thực Single Sign On (SSO) khi kết nối tới hệ thống Windchill PLM hiện có sẵn và được thiết lập thông qua giao diện Workspace. Điều này cung cấp phương thức xác thực kết nối đơn giản và an toàn khi thực hiện các quy trình PLM của Workspace như Project Creation và Publish to PLM. Trên thực tế, cơ chế này cho phép cấp quyền truy cập Windchill bằng OAuth delegation standard thông qua một dịch vụ identity provider như PingFederate.
Truy cập phần thiết lập SSO có sẵn trong tab OAuth của trang PLM Integration trong Workspace (Admin - PLM Integration), nơi có thể thêm nhiều phiên bản OAuth provider.
Việc thiết lập xác thực OAuth provider được hoàn tất từ dữ liệu có sẵn từ identity provider đã cấu hình của bạn. Nhập tên và thông tin mà Workspace yêu cầu – ID, token, URL, v.v. – vào các trường trên trang, sau đó lưu cấu hình đã hoàn tất.
Thông tin cần thiết để thiết lập một phiên bản SSO OAuth mới được lấy từ cấu hình OAuth provider hiện có.
Phiên bản OAuth Provider mới sẽ khả dụng khi tùy chọn OAuth Connection được bật trong cấu hình Windchill PLM. Chọn từ danh sách thả xuống OAuth Provider nếu có nhiều provider. Hoàn tất thiết lập kết nối bằng nút
và làm theo các lời nhắc của provider nếu cần.
Hỗ trợ PLM của bên thứ ba
Altium Enterprise Server cung cấp hỗ trợ bổ sung cho các cấu hình hệ thống PLM “không native” do bên thứ ba phát triển. Hỗ trợ này được kích hoạt bởi Generic Connector của Altium, yêu cầu Altium PLM Generic Connector Addon license.
Khi thêm một Workspace PLM Instance cho hệ thống như vậy, các tệp XML cấu hình sẵn do bên thứ ba cung cấp sẽ được tải lên cấu hình PLM Instance đó thông qua PLM Integration interface. Một ví dụ là Duro PLM support in the Enterprise Server.
Thiết lập cấu hình
Sau khi kết nối thành công tới một phiên bản PLM, giao diện PLM của Workspace cung cấp các thiết lập cấu hình để xác định cách đồng bộ linh kiện được thực hiện, cách ánh xạ chéo các tham số linh kiện và phương thức truyền dữ liệu dùng cho dữ liệu Part Choices. Các tùy chọn đồng bộ này có sẵn trong tab Configuration của giao diện.
Các tùy chọn thiết lập cấu hình mà bạn có (cũng như nhãn/chức năng của chúng) được xác định bởi loại hệ thống PLM và dữ liệu tham số lấy từ cả Workspace lẫn phiên bản PLM đã kết nối.
Đồng bộ tham số
Phần này của giao diện PLM xác định những loại linh kiện nào sẽ được đồng bộ, nơi và cách tạo/cập nhật linh kiện mới, cũng như mọi ràng buộc dựa trên tiêu chí tham số.
Cách đồng bộ các linh kiện được chỉ định riêng lẻ:
- Chọn một Altium Component Type trong danh sách tham số và đặt tùy chọn Sync Direction của nó theo nhu cầu (To Altium/PLM hoặc cả hai) – các tùy chọn loại linh kiện được lấy từ dữ liệu linh kiện hiện tại của Workspace.
- Chọn tên thuộc tính PLM liên quan từ menu PLM Type – các tùy chọn khả dụng được lấy từ phiên bản PLM đã kết nối.
- Trong trường Altium Target Folder (bên dưới Sync to Altium), duyệt đến và chọn một thư mục linh kiện Workspace làm vị trí đồng bộ cho linh kiện này.
- Chỉ định Sync Mode để xác định liệu linh kiện mới sẽ được tạo trong quá trình đồng bộ, hay chỉ cập nhật các linh kiện hiện có – hoặc cả hai.
-
Đặt Component Template sẽ được dùng để xác định kiểu tham số linh kiện khi đồng bộ linh kiện này. Thiết lập này sẽ mặc định theo Altium Component Type đã chọn (ví dụ;
Capacitors) nếu có sẵn template Workspace liên kết. - Sử dụng tùy chọn Add Parameter Criteria để chỉ định một giá trị tham số làm điều kiện ràng buộc cho việc đồng bộ. Một linh kiện sẽ không được đồng bộ trừ khi đáp ứng tiêu chí này. Hãy thêm các tiêu chí tham số khác nếu cần.
Các tùy chọn bổ sung có sẵn khi kết nối với PTC Windchill PLM, hỗ trợ hệ thống PartsLInk system của Windchill. Hệ thống PartsLink cho phép phân loại part thành các nhóm để nhắm mục tiêu thuận tiện và nhanh hơn, đồng thời có thể bao gồm các cặp Thuộc tính/Giá trị liên quan để định nghĩa chi tiết hơn trong Classification đó. Xem phần thu gọn bên dưới để biết thêm thông tin.
- Chọn Add Classification Name Criteria từ menu Filter Criteria để thêm bộ lọc classification. Dùng menu tên để chọn nhóm classification mà quá trình đồng bộ sẽ lọc theo.
-
Để kiểm soát chi tiết hơn, chọn tùy chọn Add Classification Attribute Criteria và chỉ định Attribute của classification cùng với Giá trị liên quan của nó. Trong ví dụ minh họa ở đây, chỉ các tụ điện từ lớp
102-Capcitorscó giá trịCapacitancelà10uFmới được đồng bộ.
More on Windchill PartsLink
Trong chính Windchill, một PartsLink Classification được định nghĩa bằng cách tạo một binding attribute có thể áp dụng cho một loại part. Sau đó, một Classification Attribute của part sẽ được thêm vào một lớp Classification đã định nghĩa.
Các mục linh kiện trong Windchill sẽ kết hợp Classification đã định nghĩa của chúng và mọi tham số Classification Attribute được chỉ định; các thông tin này sau đó sẽ khả dụng cho quy trình đồng bộ linh kiện PLM của Workspace.
Khi một mục linh kiện được đồng bộ từ Windchill sang Workspace và tương tác PartsLink đã được chỉ định trong cấu hình PLM của Workspace, các Configuration Attributes của Windchill cho part đó sẽ được truyền sang Altium Designer.
Khi Sync Direction được đặt thành To PLM hoặc cho đồng bộ hai chiều (To PLM & To Altium), một tùy chọn Add Filter Criteria sẽ được hiển thị dưới Sync To PLM. Sử dụng tùy chọn này để đặt tiêu chí Parameter hoặc Folder, nhằm kiểm soát những linh kiện Workspace nào sẽ được truyền sang hệ thống PLM.
Có thể thêm nhiều tiêu chí Parameter để ràng buộc chặt chẽ việc đồng bộ các linh kiện Workspace sang PLM. Các tiêu chí khả dụng cũng bao gồm các tùy chọn mệnh đề OR và NOT để thiết lập khả năng kiểm soát chính xác hơn đối với bộ lọc các linh kiện được chấp nhận để đồng bộ sang PLM.
Phần Sync to PLM cung cấp thêm các tùy chọn đánh số part và tiền tố/hậu tố khi nhắm tới hệ thống Arena PLM. Các sơ đồ PLM được định nghĩa sẵn này sẽ có sẵn để chọn trong các menu Numbering Scheme và Code, và sẽ xác định định dạng Item Number của các part được tải lên Arena.
Ánh xạ tham số linh kiện
Tiếp tục quy trình tương tự như trên để chỉ định cấu hình tham số đồng bộ cho tất cả các linh kiện mà bạn muốn đồng bộ với PLM. Vì các tham số linh kiện ở phía Workspace không nhất thiết khớp với phía PLM, phần Component Parameter Mapping của giao diện có thể được dùng để ánh xạ tham số giữa hai bên. Lưu ý rằng khi các tham số được ánh xạ, giá trị của chúng sẽ được đồng bộ từ bên này sang bên kia như thể chúng là cùng một tham số.
Sử dụng lệnh Add Parameter của phần này để tạo một mục ánh xạ cho tham số Workspace/PLM áp dụng cho Altium Component Type hiện đang được chọn (như được chọn dưới Sync Parameters). Các tùy chọn PLM và Altium Parameter Name là những tùy chọn có sẵn trong các hệ thống tương ứng. Thiết lập Revision trong cột Item/Revision sẽ làm tạo một revision linh kiện mới khi tham số thay đổi, trong khi với thiết lập Item thì chỉ tham số linh kiện được cập nhật trong quá trình đồng bộ.
Sử dụng biểu tượng
liên quan để xóa một mục ánh xạ.
Có thể ánh xạ bao nhiêu tham số cũng được theo cách này, tuy nhiên nhiều khả năng sẽ có một nhóm các tham số Workspace/PLM phổ biến cần được ánh xạ cho tất cả linh kiện. Cách tiếp cận ánh xạ toàn cục này khả dụng khi All Types được chọn làm Altium Component Type.
Tạo các mục ánh xạ (Add Parameter) sẽ áp dụng cho tất cả linh kiện bằng cách thêm các cặp tham số phổ biến đã biết là tương ứng. Và đặt các tùy chọn Item/Revision và Sync Direction theo yêu cầu. Điều quan trọng nữa là phải chỉ định một mục tham số đã ánh xạ làm Primary Key – đây là một cặp tham số chung đóng vai trò chỉ mục tham chiếu giữa hai tập dữ liệu tham số. Khi đây là một PLM Part Number (khuyến nghị), số được tạo ở phía PLM sẽ được truyền trở lại phía Altium, tạo ra một liên kết tham chiếu đã biết giữa các tập dữ liệu linh kiện đã đồng bộ.
Thuộc tính Classification của PLM
Đối với PTC Windchill PLM đã kết nối, hệ thống hỗ trợ nhóm linh kiện dưới dạng Classification, các thuộc tính và giá trị PLM liên quan có thể được ánh xạ tới các tham số linh kiện Workspace trong phần này.
Để trích xuất một giá trị Classification Attribute cụ thể từ Windchill – ví dụ như giá trị điện dung cho các tụ điện trong lớp 102-Capacitor – hãy thêm Classification và Giá trị của nó (Capacitance) làm PLM Parameter Name và tham số linh kiện Altium đích (Value) làm Altium Parameter Name. Có thể thêm định nghĩa cho tất cả Component Types, bao gồm nhiều định nghĩa cho cùng một loại linh kiện.
► Xem PartsLink information ở trên để biết thêm về Windchill Classifications.
Part Choices
Sử dụng menu thả xuống Sync Direction để chỉ định dữ liệu Part Choices của nhà sản xuất sẽ được đồng bộ theo hướng nào giữa Workspace và hệ thống PLM, hoặc tắt đồng bộ Part Choices bằng tùy chọn OFF.
Tùy theo loại PLM được kết nối, tùy chọn Part Choice information sẽ cung cấp việc đồng bộ theo định dạng tương thích với các part sản xuất được phê duyệt riêng của PLM (Native PLM Manufacturer Parts) hoặc dưới dạng dữ liệu tham số linh kiện thông thường (PLM Part Attributes). Cách sau có thể là nhiều bộ thuộc tính tham số Manufacturer:PartNumber – MFR1:MPN1, MFR2:MPN2, chẳng hạn.
Dữ liệu Part Choice native của PLM
Đặt menu Part Choice Information thành tùy chọn Native PLM Manufacturer Parts để đồng bộ thông tin Altium Part Choice với dữ liệu tìm nguồn part “native” (hoặc tích hợp sẵn) của PLM đã kết nối. Một ví dụ của mối quan hệ này là Manufacturer Parts trong Windchill.
Thông tin tìm nguồn part trong Arena chủ yếu được lưu dưới dạng các tham số Vendor, với một mối quan hệ thứ cấp (gián tiếp) là các tham số Manufacturer. Giao diện PLM của Enterprise Server hỗ trợ điều này bằng cách cung cấp lựa chọn đồng bộ với Arena bằng quan hệ tìm nguồn part direct hoặc indirect.
Khi chỉ định các tùy chọn Part Choices trong cấu hình Arena của bạn, các tùy chọn menu thả xuống Part Choice Information là:
-
Native PLM Manufacturer Parts: Direct Source Relationship – Chọn tùy chọn này để nhắm dữ liệu Altium Part Choice vào dữ liệu quan hệ tìm nguồn Vendor của Arena. Đây là điều kiện mặc định trước đây, vì vậy mọi sự kiện đồng bộ
ToPLMhiện có đều đã nhắm tới quan hệ Vendor. - Native PLM Manufacturer Parts: Indirect Source Relationship – Chọn tùy chọn này để nhắm dữ liệu Altium Part Choice vào dữ liệu quan hệ tìm nguồn Manufacturer của Arena. Khi đó dữ liệu nhà sản xuất part của Altium sẽ tương ứng với các mục dữ liệu nhà sản xuất ở phía PLM.
-
PLM Part Attributes – Như đã nêu ở trên, chọn tùy chọn này để thiết lập đồng bộ Part Choice “không native” dựa trên dữ liệu tham số linh kiện thông thường được tạo thành từ các bộ thuộc tính
Manufacturer:PartNumber, được chọn bằng Attribute Definitions đi kèm.
TeamcenterTích hợp PLM vốn hỗ trợ đồng bộ hai chiều dữ liệu Part Choice của nhà sản xuất giữa Enterprise Server và phiên bản Teamcenter PLM. Dữ liệu Component Part Choice (Manufacturer Part Number và Manufacturer) ở phía Altium có thể được đồng bộ trực tiếp với các tham số “native” Manufacturer Part và Vendor ở phía Teamcenter, vốn khả dụng khi các tính năng Vendor Management của Teamcenter được bật.
Cấu hình XML của Dự án
Phần này cung cấp danh sách cấu hình XML cơ sở xác định cấu hình PLM ban đầu cho hệ thống PLM được kết nối. Phiên bản đã tải xuống của XML thiết lập cơ sở này (Download Sample Configuration) bao gồm các chú thích chi tiết làm nổi bật chức năng của hầu hết các phần Entity và Attribute.
Cuối cùng, cấu hình thiết lập mà bạn xác định trong giao diện PLM Integration sẽ được lưu dưới dạng các tệp XML của hệ thống, và có thể được lưu cục bộ từ lệnh Export Configuration liên kết với phần Server Connection ở đầu trang cấu hình.
Một tùy chọn Import Configuration cũng được cung cấp, cho phép bạn áp dụng một tệp XML cấu hình hiện có cho một cấu hình PLM mới (hoặc đã chỉnh sửa), từ đó sao chép thiết lập PLM đó. Ngoài ra, trong trường hợp cần thực hiện các thay đổi chuyên biệt cho một cấu hình PLM hiện có, tệp XML đã xuất của cấu hình đó có thể được chỉnh sửa thủ công rồi nhập lại vào cấu hình.
Thêm Publishing Template
Cấu hình PLM yêu cầu bổ sung một Publishing Template dựa trên XML để hỗ trợ các quy trình Workspace gửi toàn bộ dữ liệu dự án – tệp thiết kế, dữ liệu linh kiện và dữ liệu đầu ra sản xuất – đến hệ thống PLM trong một thao tác “publish” duy nhất. Các quy trình này bao gồm Publish to PLM, nơi người dùng chỉ định dữ liệu đầu ra sẽ được gửi, và Project Releaser with Publish gửi dữ liệu được tạo đến PLM như bước cuối cùng trong Project Release process của Altium Designer.
Thêm một tệp XML Publishing Template phù hợp trong tab Publish Template khi tạo hoặc chỉnh sửa cấu hình PLM của bạn. Sử dụng liên kết Sample Project Configurations để tải xuống bộ sưu tập mẫu đã nén dành cho các hệ thống PLM được hỗ trợ.
Một Publishing Template bao gồm các tham chiếu cho chi tiết dự án, truyền dữ liệu linh kiện, vị trí nguồn dữ liệu và phân phối tệp của dữ liệu Thiết kế, Lắp ráp và Chế tạo. Các ví dụ tải xuống bao gồm các mẫu cho tất cả các hệ PLM được hỗ trợ; mỗi mẫu sẽ bao gồm mọi Publishing Rule bổ sung áp dụng cho loại PLM cụ thể đó và các chú thích chi tiết giúp hướng dẫn bạn cần cấu hình gì và cấu hình như thế nào.
Publishing Folder Support for Windchill PLM
Khi cấu hình một phiên bản PLM Integration® Windchill sẽ được dùng cho các quy trình Publish to PLM processes, bạn cũng có thể chỉ định (và tạo) một thư mục Windchill đích cho các tài liệu được publish từ Workspace.
Các tham số thư mục Windchill liên quan được xác định trong tệp XML Publishing Template được áp dụng cho mục tích hợp Windchill PLM của bạn trong Workspace (xem ở trên). Các node định nghĩa thư mục có định dạng thẻ <pt:Folder>xxx</pt:Folder> – trong đó pt là namespace hiện tại và xxx là đường dẫn đầy đủ của thư mục – và được đặt dưới dạng một publishing rule trong phần FileDistribution cho từng loại tài liệu (ví dụ như đầu ra PCB.zip Fabrication).
Một ví dụ về phân cấp cấu trúc XML Publishing sẽ là:
<pt:EntityRule id="FAB">
<pt:FileDistributions>
<pt:FileDistribution archiveName="PCB.zip">
<pt:Folder>PRODUCT/Projects/${project.name}/FAB data</pt:Folder>
Dòng mục nhập cuối cùng sẽ chỉ định (hoặc tạo) một thư mục đích publish cho đầu ra PCB.zip Fabrication với cấu trúc thư mục Windchill (trong đó tên dự án là MyProject):
PRODUCT
Projects
MyProject
FAB data
Lưu ý rằng đường dẫn thư mục được xác định trong tệp XML Publishing là đường dẫn tuyệt đối (thay vì tương đối), và có thể bao gồm các thuộc tính dự án khác như Tên dự án (${project.name}) và Số Lắp ráp (${project.PLM_ASSEMBLY_NUMBER}).
Support for Variant-level Parameters
Việc phân giải các biến trong tệp XML được thực hiện như sau:
-
Đối với thiết kế cơ sở (không có biến thể), giá trị của tham số cấp dự án sẽ được sử dụng.
-
Đối với một biến thể, giá trị của tham số cấp biến thể sẽ được sử dụng.
Điều này có thể được dùng để kiểm soát tốt hơn phần định danh của tên tài liệu.
Sửa đổi tệp mẫu XLM ví dụ nếu cần và tải tệp đó lên cấu hình PLM của bạn thông qua cửa sổ Add Publish Template, được mở từ nút
. Lưu ý rằng một cấu hình PLM hỗ trợ nhiều Publish Template.
Đồng bộ hóa Linh kiện
Việc đồng bộ dữ liệu linh kiện giữa Workspace Altium 365 của bạn và hệ thống PLM được kết nối được xác định bởi ánh xạ tham số đã bật và hướng đồng bộ được nêu ở trên, và sẽ diễn ra khi quy trình đồng bộ được kích hoạt thủ công hoặc tự động theo lịch. Bản thân quy trình đồng bộ được điều khiển bởi một Workflow quy trình LibSync tích hợp sẵn.
Trong một phiên bản cấu hình PLM, các tùy chọn đồng bộ liên quan được truy cập trong tab Component Synchronization, nơi quy trình có thể được kích hoạt thủ công hoặc đặt lịch. Với trường hợp sau, hãy bật tùy chọn Synchronize on a schedule và chọn khoảng thời gian từ menu thả xuống liên quan.
Bạn có thể dùng các tùy chọn menu
để kích hoạt thủ công một quy trình LibSync dưới dạng một sự kiện đồng bộ Incremental hoặc Full:
-
Incremental – chỉ áp dụng cho những linh kiện đã được sửa đổi kể từ lần đồng bộ gần nhất được chạy (tức là dấu thời gian của chúng muộn hơn ngày đồng bộ gần nhất), và thỏa mãn các tiêu chí đồng bộ trong cấu hình. Lưu ý rằng đây là chế độ được dùng khi một sự kiện đồng bộ được kích hoạt từ điều khiển
trên trang chính PLM Integration – xem bên dưới.
- Full – chế độ này buộc thực hiện đồng bộ toàn bộ. Tất cả linh kiện thỏa mãn các tiêu chí đồng bộ trong cấu hình sẽ được bao gồm.
Thực hiện Đồng bộ hóa Linh kiện
Đồng bộ hóa linh kiện (thư viện) có thể được thực hiện thủ công từ một mục phiên bản PLM trên trang PLM Integration của Workspace, hoặc dưới dạng chu kỳ tự động được chỉ định trong thiết lập phiên bản – xem ở trên. Nhấp vào điều khiển
gắn với phiên bản PLM để gọi thủ công quy trình đồng bộ, quy trình này sẽ chạy qua workflow LibSync bằng các thiết lập được xác định trong cấu hình PLM liên quan.
Điều khiển Actions sẽ đổi thành
, cho phép bạn dừng quy trình đồng bộ nếu cần, và mục Sync Status sẽ cho biết rằng một quy trình đang diễn ra. Trạng thái sẽ chuyển thành Completed khi quy trình đồng bộ hoàn tất.
Khi đồng bộ hóa linh kiện được chạy, dù thủ công hay theo sự kiện định thời, quy trình LibSync sẽ đi qua Workflow được xác định trước cho đến khi hoàn tất hoặc gặp lỗi. Bạn có thể làm mới trình duyệt (F5) để hiển thị trạng thái hiện tại của quy trình đồng bộ.
Để truy cập chi tiết của một sự kiện đồng bộ đã hoàn tất, nhấp vào biểu tượng
trong cột Last Sync để tải xuống tệp nhật ký liên quan (view example), hoặc chọn ngày liên quan để mở mục sự kiện trong tab Synchronization Status. Lưu ý rằng trong chế độ xem này, các sự kiện đồng bộ đã hoàn tất được liệt kê khi tùy chọn Closed được chọn, và mọi sự kiện đang chạy hoặc bị tạm dừng sẽ xuất hiện khi chế độ xem Active được chọn.
Các tab con của chế độ xem Status cung cấp thông tin sau:
-
Diagram – đồ họa thể hiện workflow của quy trình, trong đó vị trí bước hiện tại được làm nổi bật (Hoàn tất hoặc trạng thái lỗi/thất bại).
-
Data – phần tóm tắt thông tin về hành động của quy trình, bao gồm sự thành công hoặc thất bại của các bước và liên kết đến báo cáo quy trình đã ghi log – view example.
-
History – nhật ký thời gian của các sự kiện đồng bộ chính của Workspace được liệt kê theo thứ tự.
Bất kỳ sự kiện đồng bộ nào đã dừng sớm, chẳng hạn khi gặp lỗi, sẽ được liệt kê khi chế độ xem ở chế độ Active. Các mục này có thể được xóa khỏi danh sách bằng điều khiển Terminate , hoặc đúng hơn là được đánh giá và xử lý từ ô Task liên quan được tạo trong Tasks view của Workspace. Lưu ý rằng một sự kiện đồng bộ đã chấm dứt/được xử lý sẽ được chuyển đến danh sách Closed của chế độ xem Synchronization Status với một Status chỉ báo, chẳng hạn như Failed.
Truy cập các Quy trình liên quan đến PLM
Các workflow Process mẫu liên quan đến một hệ thống PLM được kết nối có sẵn trong các tab chủ đề quy trình trên Workspace Processes page. Nói chung, các mẫu này không thể được dùng trực tiếp mà phải được lưu lại với tên khác để trở thành hoạt động.
► Xem tài liệu Processes & Workflow để biết thêm thông tin.
Quản trị viên Workspace có thể khởi chạy một phiên bản mới của bất kỳ định nghĩa quy trình nào đã được kích hoạt trực tiếp từ danh sách quy trình trên trang Processes bằng cách nhấp vào điều khiển
. Người dùng Workspace không phải quản trị viên cũng có thể khởi tạo các Process đang hoạt động từ Workspace, chẳng hạn như:
-
Một quy trình Part Request with PLM từ nút
trên Part Request page.
-
Một quy trình Publish to PLM từ nút
trên các trang Tasks và Activities của một dự án đang mở.
-
Một quy trình Publish to PLM từ nút
trên trang chính Projects page.
-
Một quy trình Project with Initialize in PLM từ nút
trên trang chính Projects page, hoặc khi Cloning a project từ menu nút
.
Tuy nhiên trong thực tế, các quy trình liên quan đến PLM thường được gọi từ Altium Designer trong quá trình thiết kế và phát triển dự án. Các quy trình liên quan đến PLM được truy cập từ Altium Designer theo các cách sau:
-
Part Request with PLM Part Create – Được truy cập từ các panel Explorer, Manufacturer Part Search và Components của Altium Designer.
► Xem Process-based Part Requests để biết thông tin chi tiết. -
Publish to PLM (User selects) – Được truy cập từ menu con Project » Project Activities cho dự án Altium Designer đang hoạt động.
► Xem Publishing to a PLM – user-selects để biết thông tin chi tiết. -
Project Releaser with Publish – Được truy cập như giai đoạn Project Releaser cuối cùng từ menu con Project » Project Releaser cho dự án Altium Designer đang hoạt động.
► Xem Design Project Release – publishing to PLM để biết thông tin chi tiết. -
Project with initialise in PLM – Được truy cập khi tạo một dự án Altium Designer mới từ menu con File » New » Project in <Workspace>, hoặc khi sao chép một dự án.
► Xem Publishing to a PLM – initialize in PLM để biết thông tin chi tiết.
Workflow Quy trình
Các định nghĩa quy trình sau đây (và các workflow nền tảng) hiện có sẵn thông qua Workspace để hỗ trợ tích hợp PLM:
-
Part Requests chủ đề quy trình:
-
Part Request with PLM Part Create– hỗ trợ tự động tạo một Component trong phiên bản PLM của bạn, sau đó truyền mã part number đã tạo ngược về linh kiện trong Workspace. Sơ đồ workflow được hiển thị bên dưới.
Một điều quan trọng cần lưu ý là khi bạn sửa đổi định nghĩa mẫu này để tạo định nghĩa riêng, bạn phải chỉ định phiên bản PLM nơi các part sẽ được tạo. Chọn thực thể Create Part in PLM trong sơ đồ workflow và chọn phiên bản PLM từ menu thả xuống liên kết với trường PLM Instance. Menu này liệt kê tất cả các phiên bản PLM hiện được định nghĩa (như được định nghĩa trên trang PLM Integration của giao diện).
► Xem Creating and Managing Processes để biết thêm thông tin về làm việc với workflow quy trình.
-
-
Project Activities chủ đề quy trình:
-
Publish to PLM (User selects)– publish các đầu ra dự án Workspace đã phát hành tới phiên bản PLM được tích hợp, trong đó người dùng có thể chọn chính xác đầu ra nào sẽ được publish. Sơ đồ workflow được hiển thị bên dưới.
-
Project Releaser with Publish– publish tới phiên bản PLM được tích hợp như một giai đoạn bổ sung của Project Releaser. Sơ đồ workflow được hiển thị bên dưới.
-
-
Project Creations chủ đề quy trình:
-
Project with initialise in PLM– hỗ trợ tự động tạo part number trong phiên bản PLM của bạn, sau đó truyền các giá trị này dưới dạng Parameters của dự án thiết kế Workspace. Sơ đồ workflow được hiển thị bên dưới.
-


