Altium 365 FAQs

Created: November 13, 2018 | Updated: November 19, 2021

Contents

All Contents
For additional answers to the questions you may have in relation to Altium 365, take a look at the Altium Knowledge Base, whose content is curated based on support questions fielded each and every day.

General

What is Altium 365? Is it a product or a platform?

Altium 365 is a cloud-based infrastructure platform used to host Altium applications in the cloud. It is a platform, not a product, therefore you can not buy or download Altium 365. Another way to think about Altium 365 is as an operating system for cloud-based Altium applications. Just as Windows enables the execution of application software on your local hardware, the Altium 365 platform enables the execution of Altium products in the cloud.

What Altium products run on Altium 365 today?

Altium 365 Workspace and Altium 365 Viewer are available on Altium 365 today. More products will be added over time.

An Altium 365 Workspace is included as part of an Altium Subscription Plan. Both the Standard and Pro Subscription Plans give you the ability to activate a single Workspace for your company, which is a cloud-based server hosted on the Altium 365 platform.

How do I get access to Altium 365?

Altium 365 is a platform, not a product. The Altium 365 platform provides an interface to different products and services. There are three levels of access to the Altium 365 platform and the services it provides:

  • Personal - for those who want to experience the collaborative aspect of Altium 365, without the need for a connected Workspace in which to store their data. Persistent storage of design 'snapshots' (from various ECAD platforms) and Gerber manufacturing data on the Altium 365 platform is supported, with the ability to share with anyone for comments and redlining. There is also web-based access to live/WIP designs - for viewing and commenting - that have been shared outside of a Workspace.

Requires registration to AltiumLive, but does not require an active Altium Subscription Plan. There is no real integration with Altium Designer, with functionality experienced primarily through your Web browser.

  • Standard - for those who want the full Global Sharing benefits of Altium 365 and the convenience of having their designs and components available in a single, connected company Workspace, but without a heavy formality and structure to their managed data. Offers the ability to store and share live designs with anyone in the world for viewing and commenting, or editing, and to use simple cloud libraries of components. Support for ECAD-MCAD CoDesign is also included.

Requires registration to AltiumLive and Altium Designer with an active Standard Subscription Plan. Functionality is experienced from within Altium Designer and through your Web browser.

  • Pro - for those who want the full formality and structure of data management and to experience all that the Altium 365 platform has to offer. All of your managed data is created and stored in a single, connected company Workspace. Offers the ability to store and share live designs with anyone in the world for viewing and commenting, or editing. An extended level of support for ECAD-MCAD CoDesign is also included. Additional services, features and functionality are made available, including full managed components with component validation and where-used capability, component templates, managed output jobs, and part requests.

Requires registration to AltiumLive and Altium Designer with an active Pro Subscription Plan. Functionality is experienced from within Altium Designer and through your Web browser.

In addition you can also experience Altium 365 through the standalone Altium 365 Viewer - free access to view and share your electronic designs (for a time-limited duration) through your Web Browser. No downloads, no installations and no registration to AltiumLive required.

There is no limit on accessing the Altium 365 Platform Interface from your Web browser. Access to a Workspace through its browser interface, or from MCAD design software is free. An Altium Subscription Plan is needed solely for when you wish to connect to Altium 365 (and specifically your Altium 365 Workspace) from within Altium Designer.
To see a detailed list of what is included with the Standard/Pro Subscription Plans, take a look at the Full Plans Comparison.

What are the fees to access Altium 365?

Altium 365 is a platform not a product. There are therefore no fees for Altium 365 since it is not an entity that can be purchased. You experience, or rather access Altium 365, based on your relationship with Altium. See the previous question for how you can get access to Altium 365.

How is my design data protected on Altium 365?

Please visit the Altium 365 Trust Center, which connects you to the latest information on the security, reliability, privacy, and compliance of the Altium 365 cloud platform.

Can I access my Altium 365 data off-line?

Altium 365 is a platform not a product. There is no data to access. However, the data from your Altium 365 Workspace (hosted on the platform) is cached locally and is accessible in the event you are offline. When projects are opened from the Workspace, they are copied locally for offline access. The same is true with components; the Components panel caches all component data required for placement and ECO’s locally. Please note however, that new components/projects cannot be created in the Workspace, and projects cannot be committed to the Workspace, when you are offline.

Where is the server/will there be lag?

Worldwide, there are four regional servers - Asia, Europe, US East Coast, and US West Coast.

Do I have to download Altium 365?

No, Altium 365 is a cloud platform so there is nothing to download!

How many users can access My Workspace on Altium 365 at one time?

There is no limit on:

  • How many users can connect to a Workspace instance through its browser interface.
  • How many users can connect to a Workspace instance through Altium Designer (naturally limited to the licensed number of seats of Altium Designer with an active Altium Subscription Plan).
  • The number of users added to the team for a Workspace instance.
  • The number of MCAD Engineers connecting and collaborating on projects that are managed within a Workspace instance.

Are all Web browsers supported for Altium 365 viewing?

Officially supported Web Browsers can be found here.

You regularly mention the term Workspace. What is it?

The Workspace is a dedicated cloud-hosted server for all your managed content. It facilitates the seamless connectivity of, and the mechanics for moving data between, the design, manufacturing and supply domains. Interactive, browser-based ECAD collaboration that requires no tools or tool knowledge from those who use it. Connecting ECAD designers, procurement, and board fabricators and assemblers in a way that makes it easy for them to work together in ways that they could not before. It is an isolated and secure environment, where you control membership, configuration, defaults, etc... It is a place where all your design and component data is stored. Access to the Workspace is controlled by inviting people into that Workspace's Team - typically employees of the organization.

Where are the Workspaces hosted?

We utilized the Amazon AWS infrastructure to build the Altium 365 platform. Worldwide, there are four regional servers - Asia, Europe, US East Coast, and US West Coast - that you can choose from to host your Workspace when activating it for your organization. Once the location is selected data stays within that region, so you are able to control its physical location.

Is there any Documentation available for Altium 365?

When connected to your Workspace, the Get Started page of the interface provides access to a Quick Start Guide of sorts to give you an overview of, and get you up and running with, Altium 365. The following additional resources are also available to you:

  • Altium 365 Getting Started User Guide - which is available from the my.altium.com site.
  • The full technical documentation for Altium 365, the parent landing page for which can be found here.

What is my storage limit for a Workspace on Altium 365?

There is no hard limitation and a fair usage policy is in place. In the case where you are overusing the service and consuming resources on a level that is significantly above the average, we will work with you individually to figure out a solution.

Can you use the Workspace on Altium 365 to release project documents to the Contract Manufacturer or PCB fabricator?

You can send a Manufacturing Package - created from a specific release of a design project - to your manufacturer or fabricator directly from the Workspace's browser interface:

  1. Release the design to your Workspace using Altium Designer's Project Releaser.
  2. In the Workspace's browser interface, navigate to the Projects page, then double-click on the project to access the detailed management page for that project.
  3. Navigate to the Releases view, then click the  button associated to the release you wish to send.
  4. The Sending to Manufacturer window will be presented, in which to configure the content of the package and to whom it will be sent - your Contract Manufacturer or PCB fabricator.
Your Contract Manufacturer or PCB fabricator will receive an email invite to access the package on Altium 365. Once they click the  button in the email they will be taken to the Altium 365 Sign In page (unless already signed in to the platform, or their AltiumLive account). Upon signing in, they will be taken to the Manufacturing Package Viewer, with the shared package loaded. If the manufacturer does not have an AltiumLive account, they will need to register for one first - a link is provided on the Altium 365 Sign In page.

How many Workspaces can my company have on Altium 365?

A single Altium 365 Workspace can be activated per company. This facilitates a ‘single source of design truth’ - one place in which to create and store all design data for your company (designs, components, templates, and so on) with the highest integrity. A single source from which all of your designers can come for the building blocks they need for future design projects. A single focal point of design to facilitate global collaboration.

What versions of Altium Designer are supported?

Following industry best practices for security and data integrity, Altium 365 supports TLS (Transport Layer Security) 1.2. As such, to be able to connect to an Altium 365 Workspace from your design software, you must be using Altium Designer 20.1.14 or later, which includes support for TLS 1.2. It is always advisable to use the latest available version of Altium Designer.


Connecting to a Workspace on Altium 365

Where do I go to activate my Company’s Workspace?

If you are a user added to your company's account with Altium, that account has Altium Designer licensing with active Altium Subscription and your company has not yet activated their Workspace, then you will be guided to do so.

To be able to activate and use a Workspace for your company, you need to be registered with AltiumLive and have an active Altium Subscription Plan for Altium Designer. If your company hasn't got an active Subscription Plan for its Altium Designer licensing, you'll be advised of that requirement and guided through to learn more at https://www.altium.com/subscription.

There are various places in which to find controls to facilitate this:

  • From the https://www.altium.com/subscription/start-now page - follow the prompts to sign in to your account with Altium and then to activate your company's Workspace. If you don't have an account, you will be able to register from here and choose your subscription plan.
  • From the altium.com/365-intro/workspace site - offering a control to activate a Workspace from any of its pages.
  • From the Altium 365 Platform Interface - a control is provided in a generic Workspace region that presents within your Personal Space.
  • From your AltiumLive profile page - a control is presented under the Workspaces region of the page.
  • From within Altium Designer - most features that require connection to a Workspace will offer a control to activate it, if needed.

In any of these areas, click the available control to start the process of Workspace activation. You will be taken directly to a dedicated web page (https://www.altium.com/365-intro/activate-new) with which to do so. Then just follow a few steps:

  1. Enter the name you wish to call your Workspace. By default this field will be pre-filled with the name of your Altium account.
  2. Choose a location from the drop-down to which you and your team are closest. By default the location will be preselected based on the Country entry from your AltiumLive profile contact information.
  3. Add an optional description.
  4. Choose whether or not you want sample data created in your Workspace. This can be very handy because it gives you a collection of projects, components and templates with which to explore the capabilities of the Workspace. To make use of this, leave the Include sample data option enabled.
  5. Click .
Once you have activated your organization's Workspace, or have been added as part of a Workspace's Team, you will be able to access its browser interface directly by signing in to the Altium 365 Platform Interface ( https://365.altium.com).

How do I connect to my Workspace from within Altium Designer?

  1. First, ensure that you are signed in to your Altium account through Altium Designer. To do so, click on the  control at the top-right of the main application window, then click the  entry on the associated menu. Use the subsequent Sign In dialog that appears to enter your AltiumLive account credentials, then click . Alternatively, sign in using your Google® or Facebook® account and, in doing so, link/associate that account with your AltiumLive account. If you don't have an AltiumLive account, you can click the control to register for one.

If you have a Pro Subscription Plan and your organization is set up for SAML Single Sign-On (SSO) with an Identity Provider (e.g. Okta®), then you can sign in to Altium 365 (or more specifically AltiumLive) in this way by clicking the  button.

How you are permitted to sign in to your organization's Altium account is determined by an Administrator for that account on the Authentication page of the Altium Dashboard. An Administrator can configure and enable SSO to AltiumLive (the service) through from this page. This entails providing the SAML configuration for your Identity Provider (IDP) - either through upload of a Metadata XML file acquired from that provider, or by configuring the SSO connection manually.
Linked accounts (Google® or Facebook®) will be listed on your AltiumLive profile page. Controls are provided there to unlink accounts if required.
  1. Then, click on the  control at the top-right of the main application window. In the subsequent menu all Workspaces that are available to you will be listed across two sections:
  • My Workspaces - the Workspace activated for your own organization and to which you have been added as a team member. Note that each organization can activate a single Workspace.
  • Shared With Me - those Workspaces of other organizations to which you have been invited to, and subsequently added as, a team member.

Click the entry for the specific Workspace you wish to connect to.

For more detailed information, see Access from within Altium Designer.

How do I connect to my Workspace from a Web Browser?

The browser-based interface to a Workspace is actually presented as a constituent part within the overall Altium 365 Platform Interface.  Access to this interface can be performed quickly in the following ways:

  • Access the Altium 365 Platform Interface through its direct URL: https://365.altium.com. Sign in using your AltiumLive credentials. Alternatively, sign in using your Google® or Facebook® account and, in doing so, link/associate that account with your AltiumLive account. If you don't have an AltiumLive account, you can click the control to register for one.

If you have a Pro Subscription Plan and your organization is set up for SAML Single Sign-On (SSO) with an Identity Provider (e.g. Okta®), then you can sign in to Altium 365 (or more specifically AltiumLive) in this way by clicking the  button.

How you are permitted to sign in to your organization's Altium account is determined by an Administrator for that account on the Authentication page of the Altium Dashboard. An Administrator can configure and enable SSO to AltiumLive (the service) through from this page. This entails providing the SAML configuration for your Identity Provider (IDP) - either through upload of a Metadata XML file acquired from that provider, or by configuring the SSO connection manually.
Linked accounts (Google® or Facebook®) will be listed on your AltiumLive profile page. Controls are provided there to unlink accounts if required.

You will be presented with the Altium 365 Platform Interface. The top-right entry reflects that you are currently signed in to the interface, along with your picture (if defined), and either the name of the active Workspace (if connected to one) or My Personal Space (if currently accessing your personal space). Click the entry to access a menu, which will present any Workspaces available to you - click an entry to switch to it.

  • Sign in to AltiumLive, then click on your photo/picture at the far right of the top banner on pages of the altium.com website. This gives you access to the AltiumLive account menu, which presents the Workspace(s) available to you. Click on the Workspace Name entry for the specific Workspace you wish to access. You will be presented with the Altium 365 Platform Interface, with the chosen Workspace loaded.
  • Sign in to AltiumLive, access your AltiumLive Profile page (using the URL: https://accounts.live.altium.com/), then click on the Workspace Name entry for the specific Workspace you wish to access. You will be presented with the Altium 365 Platform Interface, with the chosen Workspace loaded.

Any additional IT requirements/documentation to use component (PLM) sync, ports for example, or indeed access my Workspace on Altium 365 in general?

All you need is access to the Internet and uninterrupted access to the altium.com resources over https protocol (using port 443).

Also check your company firewall settings. Access must be allowed to the following URLs:

  • portal365.altium.com
  • *.api.altium.com

Following industry best practices for security and data integrity, Altium 365 supports TLS (Transport Layer Security) 1.2. In terms of Altium Designer, you must be using version 20.1.14 or later, which includes support for TLS 1.2.

We can work with you, if your IT department requires a specific list of the domain names, IP ranges, or have complex proxy configurations.

Can I change the server URL for my Workspace?

Yes you can. This is performed from the Admin - Settings - General page of the Workspace's browser interface, as illustrated in the image below.

Note that changes can only be made by the Administrator who is also the Owner of the Workspace, and not by any other Administrator of that Workspace.

Why can I no longer connect to Altium 365 from within Altium Designer?

Following industry best practices for security and data integrity, Altium 365 supports TLS (Transport Layer Security) 1.2. As such, to be able to connect to an Altium 365 Workspace from your design software, you must be using Altium Designer 20.1.14 or later, which includes support for TLS 1.2.

If you are on a version of Altium Designer earlier than 20.1.14, you will encounter the following error when trying to connect to your Altium 365 Workspace:

"An error occurred while making the HTTP request to https://xxx.365.altium.com/servicexxx. This could be due to the fact that the server certificate is not configured properly with HTTP.SYS in the HTTPS case. This could also be caused by a mismatch of the security binding between the client and the server."

To ensure that your company can continue to use Altium 365 without interruption:

  • Make sure you are using Altium Designer 20.1.14 or later.
  • Check your company firewall settings. It should allow access to the following URLs:
    • portal365.altium.com
    • *.api.altium.com

Components

How do I get my existing components into my Workspace?

Altium Designer provides a streamlined, simple process to quickly migrate your existing libraries to your Altium 365 Workspace. The GUI to this process - the Library Migrator - presents an intuitive flow that takes initial selected libraries, and migrates them to your Workspace. Catering for all types of libraries relating to older component management methodologies - SCHLIB, PCBLIB, INTLIB, DBLIB, SVNDBLIB - the Library Migrator is the perfect solution to quickly building your company's set of managed components, and the many benefits that such components enjoy (high-integrity, lifecycle management, centralized storage and management, where-used functionality, ease of design reuse).

Lifecycle management and where-used functionality is not available with the Standard Subscription Plan.

The Library Migrator offers a minimalist Simple interface mode where the selected file-based component libraries are migrated to managed server components through a single step, while the migrator automatically takes care of type classification, the target source folder, parameter inclusion and value type, and the transfer of all relevant data. The interface is also available in an Advanced mode that provides a full preview of the proposed library migration, and access to its related data and settings. And while the migration is a single-click process by default, the migrator also offers advanced configuration options through the Properties panel for enhanced control over exactly how that migration is performed.

All information that is present in an original source library is migrated to the server-based managed components, including all referenced domain models (schematic symbols, PCB footprints, Simulation Models), parametric information, assigned part choices, datasheet files, etc. Component Templates are also created where necessary, and may then be refined and used for subsequent library migrations. If your original components have multiple PCB footprints defined, the Library Migrator will bring those models across and keep the current default footprint. And if you only work with PCB libraries - your only concern is PCB layout - then the Library Migrator supports migration of just those libraries, or it can be switched to a models only migration mode where specified models types are migrated from Integrated or Database libraries. Libraries that include multiple component types (monolithic libraries) are automatically detected and processed as well.

The Library Migrator is accessed from the main File menu in Altium Designer. For more detailed information, see Streamlined Migration of Existing Libraries to Your Managed Content Server.

How do I create a new component in my Workspace?

Once connected to your Workspace a new component can be created in that Workspace using the Component Editor in its Single Component Editing mode, by using the File » New » Component command, accessible from any editor.

Not only can you create the domain models at the same time, as part of component creation, you can also search for an existing real world part and create a new managed component off that, in your Workspace, directly.

Can I add datasheets to my Components?

Absolutely! One or more datasheets can be attached (uploaded) to a component - essentially creating a link between the component and the datasheet(s) - when creating/editing that component through the Component Editor.

For an existing component in your Workspace, one or more datasheets can be attached (uploaded) through Altium Designer’s Explorer panel. While browsing the required component, switch to its Data Sheet aspect view.

By far the easiest method to attach a datasheet to a component is to select it within your Windows File Explorer, then drag and drop it onto the Parameters region (Component Editor), or the indicated area of the Data Sheet aspect view (Altium Designer’s Explorer panel). You can attach any number of datasheets to a component. Once dropped, the file(s) will be uploaded.

How do I switch existing components in a design with my Workspace components?

This can be achieved using Altium Designer’s Item Manager - accessed from the main Tools menu. Using a highly configurable rule system to target suitable components in the Workspace, the Item Manager provides a fast and effective way to convert the current PCB project to one that uses your cloud components.

The Item Manager provides two key abilities in relation to components and sheets of re-usable schematic circuitry in a board design project:

  • Migration - firstly, it allows the conversion of a design project from using components and schematic sheets based on traditional unmanaged files to using components and schematic sheets stored in your Workspace. In this respect it can be thought of as providing a 'convert to using cloud data' function.
  • Synchronization - secondly, once a design has been converted to using components and schematic sheets from your Workspace, the Item Manager provides a simple way to synchronize the Items used in the design to any corresponding source Items in the Workspace that have been updated. In this respect, it can be thought of as providing an 'update from cloud data' functionality.
For more information, see Managing Items with the Item Manager.

Collaboration

How do I work with projects in Altium 365?

There are essentially three ways to work with projects:

  • The recommended and most powerful method is to create a new project directly within the connected Workspace. If you have an existing project, you can bring it into your Workspace by making it available online and opting to enable version control. In each case, the project will be stored and managed through the Workspace’s native Version Control System. This gives you the full functionality for a managed project when working with it through Altium Designer. Having your project fully managed by the Workspace is the only way to share that project with multiple people for editing through Altium Designer.
  • A local project that is not under version control can be registered with your Workspace using a methodology called Simple Sync. A mirror of your project is created in the Workspace and synchronized. Saved local files are automatically synchronized with their mirrored project counterparts in the Workspace.
  • A local project that is under external version control can also be registered with your Workspace using the Simple Sync methodology. A mirror of your project is created in the Workspace and synchronized. Once local file changes are saved and committed to the external design repository, those changes are automatically synchronized with their mirrored project counterparts in the Workspace.

Simple Sync allows you to enjoy the collaborative features available through the Altium 365 platform, while keeping your original project right where it is. However, bear in mind that for a local design project (not under external VCS), that project can be edited by a single person only (the owner of that project - the one who made it available online to the Workspace).

For more information on projects under the management of the Workspace’s native VCS, see Management of Projects from within Altium Designer. For more information on the Simple Sync methodology, see Making an Existing Unmanaged Project Available Online.
If your project is under external version control, you can migrate it to be a fully-managed project in the Workspace that hosts the design files in the server's own Git repository (effectively switching to the Workspace's native VCS). For detailed information on how to do this, see Moving from External VCS to Workspace Native VCS.

What’s the difference between sharing a project with someone inside the team and outside the team?

Sharing with a member of your Workspace team gives them full functionality. You can share with either Read-only access rights, or full editing rights. Either way, they can open the project in Altium Designer, or through the web-based Altium 365 Platform Interface.

Sharing with a person outside of your Workspace team can be either for viewing and commenting only, or for editing - without the need to invite them into that team. This allows invited stakeholders to view/edit (as applicable) a live, work-in-progress design project, without gaining access to your full server of design data.

  • If granted viewing access only, the invited stakeholder can view and comment on the design from within Altium Designer, or through the Altium 365 Platform Interface. As people with editing rights make changes to the design and commit them, those changes can be viewed 'live' by those external people. To view the shared design through the web interface, from anywhere, all that's needed is registration with AltiumLive to gain access.
  • If the invited stakeholder has been granted editing rights to the design, then they can open and edit from within Altium Designer - perfect for external contractors.

The person with whom you shared the design will receive an email invite to access it through Altium 365. They can view it and comment on it, but you can control whether they can also download and reshare it with others.

Sharing of a project can be performed from within Altium Designer or from the web-based Altium 365 Platform. For more information on the former, see Sharing a Design from within Altium Designer. Support for sharing a project outside of the Workspace from within Altium Designer - for viewing and commenting only - was made available in Altium Designer 20.1. To be able to share a project outside of the Workspace for editing from within Altium Designer, and indeed to open such a shared project for editing, requires Altium Designer 20.2 or later.

If we save a component to the server, is that available only to our team or is it available to everyone?

This is your private Workspace and only people you have invited into that Workspace can see the data. No one outside of the Workspace will see the data, unless you decide to share something explicitly.

How do I allow authorized 3rd parties to view my design data on Altium 365?

One of the most powerful aspects of the Altium 365 infrastructure platform is its support for collaboration on a global scale. At the heart of this is the platform's support for Global Sharing. With Altium 365, you can effortlessly share your current design progress with management, or purchasing, or a potential manufacturer, in a way that is also easy for them - simplified, interactive collaboration, from any device. Data can be shared with anyone, anywhere in the world. What you share, and with whom, is down to you, and could include:

  • Sharing your electronic designs and CAM manufacturing data through your Web Browser using the free, web-based Altium 365 Viewer. This level of sharing supports viewing of designs only - no commenting.
  • Sharing live (WIP) designs with people outside of your Workspace team - for viewing and commenting only, or for editing - without the need to invite them into that team. This allows invited stakeholders to view/edit (as applicable) a live, work-in-progress design project, without gaining access to your full server of design data.
  • Sharing 'snapshots' of your designs - uploaded to your Personal Space on the Altium 365 Platform - with anyone on a permanent basis. This level of sharing supports viewing and commenting of the shared snapshot, but keep in mind it is just that - a static snapshot of the design at a particular point in time, and not the live (WIP) design.
  • Sharing design data with members of your Workspace team. Share projects, folders and items as required. With projects for example, you might share read-only access to garner comment and feedback. Or perhaps grant read/write access to allow full, global collaboration by a geographically dispersed team (with editing performed through Altium Designer).
  • Sharing of release data with your manufacturer through a defined Manufacturing Package, which they can then peruse through the Altium 365 platform's dedicated Manufacturing Package Viewer - without them having access to your Workspace and therefore keeping your design data out of sight. They can then download the Build Package with which to get your board fabricated and assembled.
Sharing of a design project - be it a temporary link, a snapshot, or the live design itself - can be performed directly from within Altium Designer. Support for sharing a project outside of the Workspace from within Altium Designer - for viewing and commenting only - was made available in Altium Designer 20.1. To be able to share a project outside of the Workspace for editing from within Altium Designer, and indeed to open such a shared project for editing, requires Altium Designer 20.2 or later. For more information see Sharing a Design from within Altium Designer.

Can authorized 3rd parties edit my design data?

Yes. Sharing with a person outside of your Workspace team can be either for viewing and commenting only, or for editing - without the need to invite them into that team. This allows invited stakeholders to view/edit (as applicable) a live, work-in-progress design project, without gaining access to your full server of design data.

  • If granted viewing access only, the invited stakeholder can view and comment on the design from within Altium Designer, or through the Altium 365 Platform Interface. As people with editing rights make changes to the design and commit them, those changes can be viewed 'live' by those external people. To view the shared design through the web interface, from anywhere, all that's needed is registration with AltiumLive to gain access.
  • If the invited stakeholder has been granted editing rights to the design, then they can open and edit from within Altium Designer - perfect for external contractors.

The person with whom you shared the design will receive an email invite to access it through Altium 365. They can view it and comment on it, but you can control whether they can also download and reshare it with others.

Sharing of a project can be performed from within Altium Designer or from the web-based Altium 365 Platform. For more information on the former, see Sharing a Design from within Altium Designer. Support for sharing a project outside of the Workspace from within Altium Designer - for viewing and commenting only - was made available in Altium Designer 20.1. To be able to share a project outside of the Workspace for editing from within Altium Designer, and indeed to open such a shared project for editing, requires Altium Designer 20.2 or later.

Once an unmanaged project has been made available online, controls over its online availability and synchronization are provided through the General tab of the Project Options dialog.

Should you wish to stop the synchronization between your local project, and the managed incarnation of it that was made available in the Workspace, click the  button. The Turn off project synchronization window will appear. Click on the Unlink option, then click OK back in the Project Options dialog. The local project will no longer be associated with the project in the Workspace.

This is reflected in the Projects panel after saving the local project, by the project being presented under the active Project Group (*.DsnWrk), rather than as an entry under the active Workspace. A save is required since the links to the project in the Workspace are removed from the project file.

The project in the Workspace remains untouched - it is not removed by this action.

You could also use the Project Packager to obtain an unlinked local project again. In the Managed Projects region on the Zip File Options page of the wizard, make sure to enable the option to Unlink project from the server during packaging. This will ensure the link information to the mirrored project in the Workspace - which resides within the project file (*.PrjPcb) - is removed as part of the packaging process.

I have a Standard Subscription Plan - how can I control access rights without roles?

While there is no support for 'roles' with the Standard Subscription Plan, there are essentially two levels for defining access rights to your Workspace and its content (which equally apply for Standard and Pro level of access to Altium 365):

You can determine whether a team member for the Workspace is an Administrator, or a regular user. The former is bestowed by assigning that member to the Administrators role. This can be performed by a Workspace Administrator when inviting that person to the team, or at any stage thereafter. Administrators for the Workspace have full access to, and editing rights for, all data in the Workspace.

For regular team members, you also can determine, per person, the access they have to content within the Workspace. A Workspace provides the following sharing capabilities:

  • Folder-level Sharing - providing the ability to control who is able to see what content in the Workspace by sharing server folders. This allows control over whether other users can simply view a folder and its content, or also edit it (effectively releasing/committing/uploading design data into it). A single Workspace can be partitioned into various effective 'zones' of content, but with controlled folder-level permissions, the content can be made selectively visible, or hidden, as required, giving the right people, the right access, to the right data.
  • Item-level Sharing - providing the ability to control who is able to see which Items in a shared folder. Think of this as a finer level of sharing, in contrast to the coarser level of sharing provided through folder access control. Provided a user has access to the folder itself, they will then be able to view/edit (as permitted) Items within that folder that are shared with them.
From the Admin - Explorer page of the Workspace’s browser interface, sharing controls are accessed by right-clicking over the entry for the folder (or Item), and using the Share Folder (or Share Item) command from the context menu. The Share window will appear, from where access permissions for the folder/Item can be modified as required. For more information, see Managing Content Structure and Access.
Access permissions for folders and Items can also be defined from within Altium Designer, through the Explorer panel. For more information, see Controlling Access to Server Content.

I’m a team member but I don’t see a shared project on the Shared With Me page of the web interface?

A member of the Workspace team accesses projects that have been shared with them from the Projects page of the Workspace’s browser interface.

The Shared with Me page is not part of the Workspace’s browser interface, but rather part of the parent Altium 365 Platform Interface, of which the active Workspace is presented as a constituent part. It is available to anyone accessing the Altium 365 platform using their AltiumLive credentials. In other words, it is available without having access to a Workspace.

The Shared with Me page presents the following types of shared data - all part of Altium 365’s Global Sharing paradigm:

  • Shared Live/WIP designs.
  • Shared design snapshots.
  • Shared manufacturing packages.

Reliability

What happens if the Altium 365 platform goes down?

Altium 365 is backed up by AWS with system-wide weekly backups as well as 24 hour individual backups. Your data is cached locally so in the worst case scenario, you will still be able to continue the majority of your work: placement, design, routing, and commit data to the server once connection is restored.

There is no requirement to be always connected to the platform.

How is my component data protected on Altium 365?

Please visit the Altium 365 Trust Center, which connects you to the latest information on the security, reliability, privacy, and compliance of the Altium 365 cloud platform.

What happens to my data if I do not renew my Altium Subscription Plan?

If a Workspace team member attempts to connect to your Workspace, but the Altium Subscription Plan for their Altium Designer license has expired, they will be alerted to this fact on connection. They will be given the choice to temporarily connect to the Workspace with full access, or to contact an Altium representative to discuss subscription renewal.

If there is no active Altium Subscription Plan across any of the Altium Designer licensing for your company account with Altium (to which your Workspace is associated), then the Workspace will switch over to being Read-only. All team members will still be able to view/work with existing content in the Workspace, but will not be able to modify that existing content in any way, nor create any new content.

If you were enjoying the pro level of access, where your Workspace benefited from having the feature set associated to having a Pro Subscription Plan, note that upon expiration the Workspace view will be limited to that of of the Standard Subscription Plan, and for Read-only data extraction.

In addition, this use of existing content is only permitted for the time period defined in the Data Retention Policy.

Data can be extracted from the instance prior to that by:

  • Exporting components to IntLib format.
  • Checking out designs.
  • Downloading release packages.

How often will my Workspace data be backed up on Altium 365?

It will be backed up every 24 hours.

Is it possible to export component libraries from the cloud service for offline access and backup?

Yes, you can export them for backup purposes. Component data is automatically cached for offline access in Altium Designer, you do not need to worry about offline access.

Can you create an offline backup?

This functionality is not currently available. We do automatically backup your data every 24 hours.

I’m already using version control (git, svn etc.) to keep my data in a cloud. Why do I need a Workspace on Altium 365 and do I need to give up my existing setup?

You can continue using existing, on-site or cloud-based VCS, same as before, and just register your designs (making them available to your Workspace). This will unlock the majority of the Workspace functionality for you, and as applicable depending on the Altium Subscription Plan you have:

  • Where used
  • Web design viewer
  • MCAD CoDesigner
  • Commenting/redlining
  • Etc...

Alternatively, you can migrate it to be a fully-managed project in the Workspace that hosts the design files in the server's own Git repository (effectively switching to the Workspace's native VCS). For detailed information on how to do this, see Moving from External VCS to Workspace Native VCS.

Can I maintain a local copy of my component data?

You can, but it is not recommended and it is a time-intensive process. The majority of the component data is cached on each machine accessing the Workspace (with the exception of data that is dynamic in nature - prices, statuses, etc...).

You will have a grace period to move your data from the Workspace, if you decide to opt-out of the service.


ECAD-MCAD CoDesign

The features available to you depend on your level of access to Altium 365 - determined by the Altium Subscription Plan you have. Take a look at the Full Plans Comparison page to see the differences.

What is Altium MCAD CoDesigner and how does it differ from other ways of ECAD-MCAD data exchange?

MCAD CoDesigner allows you to exchange PCB data between electrical and mechanical engineers without performing manual operations on files. It works directly with ECAD and MCAD data, through a panel in Altium Designer on the ECAD side, and as a plugin to your MCAD software on the other.

The main advantages, when compared to regular file exchange, are:

  • It works much faster than regular file export/import.
  • It allows the transfer of more design data (board shape with cutouts, components placed on MCAD-side, copper, silkscreen, etc).
  • Changes can be applied selectively, control what changes are applied each time a Pull is performed.
  • It simplifies the synchronization of changes significantly.

You can learn more details in the Technical Documentation.

Which MCAD tools are supported?

The following MCAD platforms are supported when using the latest Altium CoDesigner plugins:

  • Dassault Systemes SOLIDWORKS®
  • Autodesk Inventor Professional®
  • PTC Creo Parametric®
  • Autodesk Fusion 360®
  • Siemens NX® (for NEXUS solution users only)

The versions of MCAD tools officially supported will depend on the version of Altium CoDesigner plugin being used. This information can be found on the New in CoDesigner page for Altium Designer and NEXUS.

Does it require any additional licenses to be purchased?

Use of the ECAD-MCAD capability requires no additional licensing when you are designing with Altium Designer + Altium 365.

Which types of PCB are currently supported?

The following types of board are currently supported:

  • Regular boards - with all supported MCAD tools.
  • Rigid-flex boards - with SOLIDWORKS and PTC Creo only for now.
  • PCB Variants

Multi-boards are not currently supported.

Is it possible to use our native MCAD models of components?

Yes. First, CoDesigner allows to place your key components on the MCAD side and to recognize them on the ECAD side (for all supported MCAD tools except Autodesk Fusion 360). Secondly, it supports the automatic placement of models directly from a data management system used on the MCAD side, for all components coming from the ECAD side (available for SOLIDWORKS and Creo only for now).


Standalone Altium 365 Viewer

Where do I go to access Altium 365 Viewer?

Access Altium 365 Viewer on the Altium website using its direct URL: altium.com/viewer.

Which CAD Tools are supported?

Altium 365 Viewer currently offers support for loading and viewing designs in Altium Designer, Autodesk® EAGLE™, KiCad® and CircuitStudio CAD formats. Support for additional CAD formats will be added over time. You can even vote for which design format you would like to see supported next!

What support is there for CAM data?

Altium 365 Viewer currently offers support for loading and viewing manufacturing data in Gerber RS-274X and Gerber X2 formats (along with corresponding NC Drill data).

Why can’t I download any outputs?

This functionality is not available when using Altium 365 Viewer on altium.com. It is available, and can be customized, when embedding Altium 365 Viewer on your own website.

You can generate and download a number of different outputs from your embedded view. Currently supported are: the source design itself, Gerber, IDFX, IPC2581, ODB++, STEP, PDF (Schematic Prints, PCB Prints, PCB 3D Print and PDF 3D).

What do I upload to Altium 365 Viewer?

In terms of CAD designs, you can upload a full design (in a Zip, Rar, or 7z archive) or an individual design file (schematic or PCB document). When uploading a Zip, Rar, or 7z file, the following considerations apply:

  • For Altium Designer and CircuitStudio based designs, the Zip, Rar, or 7z archive must contain a single PCB design project only.
  • For EAGLE based designs, the Zip, Rar, or 7z archive must contain a single PCB design only (so .sch and .brd files for a single design only).
  • For KiCad based designs, the Zip, Rar, or 7z archive must contain a single PCB design only (so .pro , .sch , .kicad_pcb, and .lib files for a single design only).
  • Altium 365 Viewer will ignore all unsupported file formats in the uploaded Zip, Rar, or 7z. This means you can literally just Zip, Rar, or 7z your full project folder and upload it.
For Altium Designer and CircuitStudio based designs, the project file is used to obtain the ordering of schematic source documents. If the project file is not included in the Zip, Rar, or 7z archive, a default is created and the schematic documents are added without any rules.
For a PCB design project in Altium Designer, quickly obtain a Zip archive of the project by using the Project Packager.

In terms of CAM manufacturing files, you can upload a full set of Gerber files plus NC Drill data (within a Zip, Rar, or 7z archive), or an individual Gerber file. When uploading a Zip, Rar, or 7z file, the following considerations apply:

  • Ensure that there is only a single folder of Gerbers inside the archive.
  • Ensure that the drill files are in the same folder as the Gerber files. If located in a separate folder, they will be ignored.
You can either upload a design OR Gerber data, but not both at the same time. If you have both design and Gerber file data in the same Zip/Rar/7z archive, only the design will be processed and presented in Altium 365 Viewer.

How do I get Altium 365 Viewer on my own website?

Altium 365 Viewer can be embedded on any web page as an iframe. To embed the viewer you need to place the following code into the <head> section of the webpage:

<script src="https://viewer.altium.com/client/static/js/embed.js"></script>

This code attaches event listeners used to properly initialize the iframe. After that you need to add a placeholder for the iframe on your page:

<div id="my_viewer-frame_container"
    class="altium-ecad-viewer"
    data-project-src="http://example.com/mydesign.zip"
    style="border-radius: 0px 0px 4px 4px; height: 500px;
         border-style: solid; border-width: 1px;
         border-color: rgb(241, 241, 241);
         overflow: hidden; max-width: 1280px;
         max-height: 700px; box-sizing: border-box;">

</div>

Note:

  • class="altium-ecad-viewer" - this must not be changed, as it is used by the event listeners.
  • data-project-src - this is the link to the design or manufacturing data you want to display. This link should be a public link containing a Zip, Rar, or 7z archive with your PCB project or manufacturing data files.
  • style - this can be changed as required to suit your presentation preferences.

For more information, see Embedding Altium 365 Viewer on Your Own Website.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: