Preparing Printed Data

Print-based output for your PCB project in Altium Designer is available by creating an output job configuration file (*.OutJob). When you create a job output, there is a range of manufacturing documentation available for output including common two-dimensional PCB printouts, such as composite drawings and schematic drawings.

While OutputJob files facilitate streamlined preparation of outputs for your designs and their subsequent generation using the high-integrity project release process, print-based outputs for the active document can also be generated directly from the appropriate editor using the File » Print command from the main menus. Configuration options defined here are distinct and separate from those defined for the same output type in an Output Job file. In the case of the former, the settings are stored in the project file; for the latter, they are stored in the Output Job file. Setup options accessed from the File menu with respect to page and printer are also separate from those defined when accessed from within an Output Job file. Again, the former will be stored with the project file, the latter with the Output Job file.

Preparing Schematic Print-based Output

Schematic print-based outputs can be added to the active Output Job file by selecting an option from the Schematic Prints menu of the [Add New Documentation Output] control in the Documentation Outputs region of the file or from the Edit » Add Documentation Outputs » Schematic Prints sub-menu of the main menus.

The schematic prints are configured in the Print dialog.

Preparing 2D Print-based PCB Output

PCB printouts differ from other printouts, in that they can be configured to include any number of printouts (pages), and each printout can include any combination of layers used in the design, including mechanical and system layers.

Print-based PCB outputs can be added to the active Output Job file from the menus of the following controls:

  • the [Add New Documentation Output] control in the Documentation Outputs region (or the Edit » Add Documentation Outputs sub-menus of the main menus) - Composite Drawing, PCB Prints.
  • the [Add New Assembly Output] control in the Assembly Outputs region (or the Edit » Add Assembly Outputs sub-menus of the main menus) - Assembly Drawings.
  • the [Add New Fabrication Output] control in the Fabrication Outputs region (or the Edit » Add Fabrication Outputs sub-menus of the main menus) - Composite Drill Guide, Drill Drawings, Final, Mask Set, Power-Plane Set.

Right-click on the desired output then choose Configure to access the Print dialog in which you can define what is printed, view printouts, and edit their setup definitions.

  • Note that the preview will not be generated automatically when accessing the Print dialog from an Outjob file. Press the F5 key or click the Refresh (F5) link above or within the Preview area to generate the preview.
  • Note that copper shapes and solder masks for not fitted components are displayed in PCB printouts even if their variant(s) is/are set as Not Fitted. This feature is available when the PCB.PrintNotFittedComponents option is enabled in the Advanced Settings dialog.

The options and controls of the Print dialog are located on three tabs:

  • The General tab has options to configure your printer and page settings.
  • The Pages tab includes display options, options to manage layer settings, and allows you to add/remove pages.
  • The Advanced tab provides designator setting options as well as font and color options.

The preview region on the right-hand side of the dialog reflects changes in the settings. Refreshing (F5) is needed when settings change.

Configuring General Settings of the Printout

Basic settings of the printout are configured on the General tab of the Print dialog.

The settings on this tab include:

  • Printer and presets settings (note that when accessing the Print dialog from an OutJob file, the Printer field is not configurable as the printer settings are defined in the OutJob file itself).
  • Page settings, including the color set you want to use for the printed output (grayscale, monochrome, or color), page size and orientation.
  • Scale and position settings.
  • Area of the PCB document to print (entire sheet or a specific area that can be defined by typing in the coordinates of the area's opposite points or interactively in the PCB document).

Adding a New Page

A new printout page can be added to the current configuration by clicking the Add Page button on the Pages tab of the dialog.

Adding a new page to the printout.
Adding a new page to the printout.

The page will be added beneath existing printouts and will be given a default name of New PrintOut. Use Move Page Up/Move Page Down (accessed by clicking ) to move the selected page upward or downward in the list, which changes the page printing order.

Configuring a Page

A newly added printout page can be configured (and an existing page's configuration can be edited) through the associated Printout Properties region when the page is selected in the page list of the dialog's Pages tab.

Configure the selected page through the Printout Properties region of the dialog.
Configure the selected page through the Printout Properties region of the dialog.

The following options and controls are available when configuring the selected page:

  • The Edit command (accessed by clicking ) allows you to change the name for the page as required to assign a more meaningful name that will readily identify the nature and purpose of the page.
  • The options below the page name can be enabled to control which components are included in associated printouts (such as whether or not you choose to show surface-mountable components), as well as additional controls (such as showing mirror layers).
  • The Pad Display Options region provides options that allow you to control the display of pads on the printout, i.e. whether or not pad numbers and associated nets are shown.
  • The Pad Font Size option allows you to determine the size of the font used for pad numbers and net text.

Managing Page Layers

The 'heart' of page configuration is the layer management area of the Print dialog, which provides the necessary controls to define the layer set of the page, order the layers that are to make up the page and configure the settings of each layer. To access this area, select a page in the list on the dialog's Pages tab then click the Edit Layer button, or double-click the page directly in the list.

Configure layers of the selected page by accessing the appropriate area of the Print dialog.
Configure layers of the selected page by accessing the appropriate area of the Print dialog.

Enable the layers intended to be printed using the checkbox. Use the color swatch to control the coloring that is used for that layer.
 

Configuring a Layer

A layer in the layer set of a printout page can be configured through the associated Settings region when the layer is selected in the layer list.

Configure the selected layer through the Settings region.
Configure the selected layer through the Settings region.

The following options and controls are available when configuring the selected layer:

  • First Drill Layer – use the drop-down to specify the starting layer for the required drill pair. The drop-down lists all available signal and internal plane layers defined in the board's layer stack.
  • Last Drill Layer – use the drop-down to specify the finishing layer for the required drill pair. The drop-down lists all available signal and internal plane layers defined in the board's layer stack.
  • Configure Drill Symbols – click to open the Drill Symbol dialog in which you can assign symbols/letters to each drill size.
  • Free Primitives – select to determine how the free primitives on a layer are displayed on the printout.
  • Component Primitives – select to determine how the component primitives on a layer are displayed on the printout.
  • Other – select to determine how other objects on a layer are displayed on the printout.

Consider, as an example, an assembly drawing that includes the following layers:

  • Component overlay
  • Top layer (for surface mount pads)
  • Multilayer (for through-hole pads)

The top layer would be configured to display the component primitives so the surface mount pads are visible and hide the free primitives so the routing is not visible. The multilayer would also be configured to display the component primitives so the through-hole component pads are visible and hide the free primitives so that the vias are not visible.

Configuring Advanced Settings of the Printout

Advanced settings of the printout are configured on the Advanced tab of the Print dialog.

Advanced settings of the printout are configured on the Advanced tab of the Print dialog.
Advanced settings of the printout are configured on the Advanced tab of the Print dialog.

The settings on this tab include:

  • Designator Print Settings - select the type of designator information to be included on the printouts. 
  • The Print Keepout Objects option gives you full control over whether keepout design objects are included on the printed document or not.
  • Font replacement – each of the three standard fonts used in the PCB Editor (Default, Serif, and SansSerif) can be replaced with a different Windows font when the printout is generated. Use the options in the Replace Stroke fonts by TT fonts region to enable font replacement and fonts.
  • Color settings – use controls in the Color Settings region to define global settings of coloring that will be used for the current printout. The options include using the net override color rather than the layer color (the Use Net override color option) and applying the colors configured for the PCB design in the PCB Editor (the Retrieve Layer Colors from PCB button). Controls for setting the current color configuration as the default one and resetting the current configuration to the default one are also provided.

Preparing 3D Print-based PCB Output

The PCB 3D Print Settings dialog enables you to select or create 3D printouts of your PCB for inclusion in the job output file. Remember, you can have multiple instances of any printout (use the Add New Documentation Output control from the OutJob in the Output Containers region to do this), which is particularly useful for 3D since you can print out views of the board from differing perspectives if you wish.

The PCB 3D Print Settings dialog
The PCB 3D Print Settings dialog

The dialog is divided into four regions:

  • Render Resolution – includes options for the quality of the "picture" of the 3D model to be printed. The available resolutions are not printer-dependent.
  • View to Print – enables you to select from flat views of the board, that is, the camera perspective perpendicular to the board, either from above or from below, or a Custom view.
  • View Configuration – enables you to apply the current view configuration for surface colors, visibility, opacity, and board thickness.
  • Preview – shows you exactly what will be printed.

Creating Custom 3D Printouts

A custom view of your board can include it being rotated to an angle, zoomed, and having various settings for surface colors, visibility, opacity, and board thickness. You can use these options to generate views that provide high levels of detail to highlight areas of your design or even create effects.

To create a custom 3D view of your board as a printout, perform the following steps:

  1. Go to the PCB Editor window and enter 3D mode (shortcut: 3).
  2. Use the 3D view controls to achieve the desired perspective.
  3. Return to the job output file and double-click anywhere on the PCB 3D Print row (or right-click on it and select Configure from the shortcut menu) to open the PCB 3D Print Settings dialog.
  4. Click the Custom option then press the Take Current Camera Position button. The Preview pane will update with the new perspective.
  5. Click OK to apply the custom setting to the current PCB 3D printout.

If you would like to apply custom surface colors, etc., perform the following steps:

  1. Go to the PCB Editor window and open the View Configuration panel (View » Panels » View Configuration from the main menus, or click the Panels button at the bottom right of the main editor and select View Configuration, or use the L shortcut.
  2. Set the options required. Note that you do not have to save the options to apply it to a PCB 3D printout.
  3. Return to the job output file, open the PCB 3D Print Settings dialog, enable the Custom option then press the Take Current View Configuration button. The Preview pane will update with the new view configuration settings. Once you apply the view configuration, it will apply to all of the View to Print options.
  4. Click OK to apply the view configuration to the current PCB 3D printout.
  5. Save the OutJob file to keep any new 3D printouts.

Preparing Draftsman Print-based Output

Draftsman print-based outputs can be added to the active Output Job file by selecting an option from the Draftsman menu of the [Add New Documentation Output] control in the Documentation Outputs region of the file or from the Edit » Add Documentation Outputs » Draftsman sub-menu of the main menus.

Right-click on the desired output then choose Page Setup to access the PCBDrawing Properties dialog in which you can configure the printout in terms of paper, scaling, and color settings.

When generating output directly from Draftsman using the File » Print menu command, the Print dialog is used to configure the output.

Preparing Printed Material with the Smart PDF Wizard

The Smart PDF Wizard generates a single PDF for either a selected document(s) or the entire project, including schematics, PCB, and Bill Of Materials. PDF bookmarks are created for each net and component in the design. You can save the Smart PDF settings to an OutJob file so your PDF can be regenerated with a single click.

The Smart PDF Wizard
The Smart PDF Wizard

The Smart PDF Wizard is launched by selecting File » Smart PDF from the main menus.

After launching the command, the Smart PDF Wizard will appear. Follow the wizard's set of progressive (and intuitive) pages to collectively gather the information to effectively export your design to a single PDF document, as you require. The wizard supports:

  • Documenting either the active document, or any or all documents in the entire project - including schematics, PCB and Bill Of Materials.
  • Configuring printout settings when exporting a PCB document.
  • Adding additional information including net information (added as pin and/or net label and/or port bookmarks), component parameters, and global bookmarks for components and nets.
  • Controlling coloring for schematic and PCB content - either color, greyscale, or monochrome.
  • Managing specific items that can be included on, or excluded from, schematic sheets - No ERC Markers, Parameter Sets, Probes, Blankets, Notes.
  • Ability to define a print quality, in terms of dots per inch (dpi).
  • Choosing whether to export the logical or physical design. For the latter, you have control over which design variant is used, and whether expanded physical names are used for various net identifiers.
  • Saving the settings to an Output Job Configuration File (*.OutJob) - in this way you can publish the same job, with the same settings, over and over, without having to step through the wizard each time.

With the various pages of the wizard configured as required, click Finish to generate the PDF. If you opted to have the PDF opened after generation, it will be presented in the default Acrobat Reader installed on your PC. The generated PDF groups documents according to their type: Schematic, PCB or BOM:

  • For each Schematic, bookmarks are provided based on your settings which enable you to browse documents as well as individual components and nets residing on that document. If the source schematics are hierarchical, the hierarchy will be reflected in the PDF bookmarks with the top-level sheet appearing at one level and all sub-sheets appearing as sub-bookmarks. If you enabled the option to Use Physical Structure as part of the export process, the resulting PDF document will contain separate sheets for each channel in a multi-channel design.
  • For a PCB document, bookmarks are provided for each of the exported printouts.
  • For the Bill of Materials, bookmarks are provided so you can browse to each component.

If you have enabled Additional Bookmark settings to generate net information for Pins, Net Labels and Ports, you will see these when browsing a Schematic or a PCB (pins only).

Clicking on a bookmark will zoom to the area of the document where that object resides. The level of zoom applied is determined by the zoom control slider bar setting configured in the wizard. Where possible, the object will be centered within the main display window of the PDF Viewer. Highlighting will be applied when browsing by Components, Pins, Ports or Net Labels for ease of reference.

  • Only schematic, PCB, and BOM documents may be exported in PDF format using the Smart PDF Wizard.
  • If you did not enable the option to generate net information, only component information will be available in the generated PDF.
  • Export options defined within the wizard are stored with the design project.
  • The same Smart PDF generator is used when generating PDF output from an Output Job file, as when generating a PDF directly using the Smart PDF wizard.
  • The settings for the outputs can be re-configured from the generated OutJob document. For example, the BOM can be re-configured to use a different template and re-published with the Publish to PDF command.

The OutputJob Editor

Your Smart PDF settings can be saved to an Output Job document. Modify this document in the OutputJob Editor, which becomes active when the active document is an *.OutJob file.

Paper Sizes for Generated PDF

The paper sizes used by the PDF Generator are not 'acquired' from your computer's current Windows Default Printer. The sizes available for PDF generation are fixed and independent of those offered by the default printer, and remain independent regardless of the type of printer chosen as the default. In other words, selecting an A3 paper size when generating a PDF through an Output Job file will remain at that size, even if you switch your default printer to the small A4 Inkjet down the hall. The following fixed set of paper sizes are available for use by the PDF Printer:

  • A0
  • A1
  • A2
  • A3
  • A4
  • A5
  • A6
  • A
  • B
  • C
  • D
  • E
  • Legal
  • Letter
  • Tabloid

System Printer Settings

You can also define custom page sizing with respect to output generated in PDF format. Custom page sizing is defined on the System - Printer Settings page of the Preferences dialog. The drop-down menu associated with the Add button on the Preferences dialog presents a variety of predefined custom sizes:

  • ARCH A
  • ARCH B
  • ARCH C
  • ARCH D
  • ARCH E
  • ARCH E1
  • C5 Envelope (162 x 229 mm)
  • DL Envelope (110 x 220 mm)
  • Folio (8.5 x 13 in)
  • JIS B1
  • JIS B2
  • JIS B3
  • JIS B4
  • JIS B5
  • Ledger (17 x 11 in)
  • Monarch Envelope (3.87 x 7.5 in)
  • No.10 Envelope (4.125 x 9.5 in)
  • Note (7.5 x 10 in)
  • Statement (5.5 x 8.5 in)

Choose an entry to have that size added to the list. If you need a different sizing, simply add a predefined sizing, select its entry in the list then click the Edit Page button. A dialog will appear from where you can specify:

  • Title for the custom page sizing - something meaningful, perhaps containing the width and height (and units!) for easy reference.
  • The page Width and Height.
  • Units of measurement (mm or in).

The defined custom page sizes will be presented on the Size field menu when configuring page properties prior to exporting to PDF.

Indication of Unsupported Paper Size in Target

When the target for an applicable output generator is changed from a PDF Output Container to a physical printer (Hard Copy), it is quite possible that the paper size defined for the generator - through the relevant properties dialog (right-click, Page Setup) - may not be supported by the target medium. In this case, the connecting line from generator to medium is colored red.

You will be prevented from generating content (PDF Output Container) or previewing/printing (Hard Copy) in this state. You can either change the paper size for the output generator (and thus return the connecting line to a green state) before the applicable output can be successfully generated, or simply change the target medium to one that does support your chosen paper size.
When a paper size mismatch exists and you opt to change the paper size for the configured output generator, using the Page Setup command for the generator will bring up an information dialog. This alerts you to the issue and notifies you that the paper sizing has been restored to its default. What this means is that the paper size drop-down in the configuration dialog is refreshed with the standard set of supported paper sizes (PDF Output Container) or the set of paper sizes supported by the target printer (Hard Copy).

Browsing the Generated PDF

The generated PDF groups documents according to their type: Schematic, PCB and BOM. For each schematic, bookmarks are provided based on your settings, which enables you to browse documents as well as individual components and nets residing on that document.

If the source schematics are hierarchical, the hierarchy will be reflected in the PDF bookmarks with the top-level sheet appearing at one level and all sub-sheets appearing as sub-bookmarks. If you have enabled the option to Use Physical Structure as part of the export process, the resulting PDF document will contain separate sheets for each channel in a multi-channel design.

For a PCB document, bookmarks are provided for each of the exported printouts.

For the Bill of Materials, bookmarks are provided so you can browse to each component.

If you enabled additional bookmarks on the Additional PDF Settings page of the Wizard to generate net information for Pins, Net Labels, and Ports, you will see these when browsing a schematic or a PCB (pins only).

Clicking on a bookmark will zoom to the area of the document where that object resides. The level of zoom applied is determined by the zoom control slider bar setting on the Additional PDF Settings page. Where possible, the object will be centered within the main display window of the PDF Viewer. Highlighting will be applied when browsing by Components, Pins, Ports, or Net Labels for ease of reference.

If you did not enable the option to generate net information, only component information will be available in the generated PDF.

Component Parameters in PDF Output

Altium Designer includes component parameters in generated PDF output. Once generated, you can click on a component on a sheet in your PDF and peruse its parameters in a convenient pop-up. If you do not want to allow component parameters to be viewed in this way, disable (uncheck) the Include Component Parameters option in the Additional Information region of the Additional PDF Settings page.

This feature works regardless if generating a PDF of a single schematic sheet or of the entire project.

If a component contains a parameter whose value is a URL to a web page in the format http://<siteaddress>, that entry will be a live link in the parameter pop-up. You can click it to follow the link and access the URL in your external Web browser.

Inclusion of the "http://" prefix is required. Shortened forms of URL are not supported, such as www.altium.com, or live.altium.com.

Note

When generating a print-based output directly from the appropriate editor using the File » Print menu command, this facility is configured separately to configurations defined in an OutJob file. In this case, use the Default Prints tab of the Project Options dialog (Project » Project Options) to configure the default print configuration and page layout for each of the print-related outputs that can be generated.

To access the Default Prints tab of the Project Options dialog, the Value field for the UI.ProjectOptions.DefaultPrints on the Advanced Settings dialog must be enabled.

The Default Prints tab of the Project Options dialog
The Default Prints tab of the Project Options dialog

Note

The features available depend on your level of Altium Designer Software Subscription.

Content