Creating a Project in Altium Designer

Created: January 31, 2023 | Updated: January 31, 2023
All Contents

Parent page: Working with Projects

There are essentially three ways in which a new project can be created from within Altium Designer:

  • Creation of a new project through the Create Project dialog.
  • Creation of a new Workspace project under the control of an active process definiton. Note that this functionality is only available when using Altium Designer with active Altium Designer Enterprise Subscription and a connected Workspace.
  • Cloning an existing project.

The following sections take a closer look at creating a new project.

Creating a New Project Using the Create Project Dialog

A new project can be created from within Altium Designer using the Create Project dialog (File » New » Project).

As well as creating a new project in your connected Workspace, the Create Project dialog also supports creating and adding a new project to an existing external version control repository (with a working copy in your preferred location), or creating a new project in a specified folder on your local hard drive.

Setting up the Create Project dialog to create a new managed project from within Altium Designer. Note that the Advanced options will be appropriate by default.
Setting up the Create Project dialog to create a new managed project from within Altium Designer. Note that the Advanced options will be appropriate by default.

  1. In the Locations list, select the entry for your Workspace (it will appear with the name defined for it) – you must be actively connected to the Workspace to see this option in the listing. This will be the target server in which to store your new Workspace project.
  2. In the Project Type list, choose the type of project you wish to create, and choose from the applicable templates available as required. If you have project templates created and saved into your Workspace, these will appear listed as the only available templates from which to choose. The <Empty> entry will create a shell project with no initial source documents.
  3. Enter a Project Name and optionally, a project Description.

    The project name should start with, and can contain A-Z, a-z, or 0-9. Underscores, dashes, and spaces are allowed, but the latter can only be used within the middle of the name (leading and trailing spaces will be ignored). You can not use the following words: AUX, COM1-COM9, LPT1-LPT9, CON, NUL, and PRN. In addition, the name cannot contain the following characters: \ . / ? % * : | " < >.

The Create Project dialog includes further options:

  • Check the Version Control option (the default) to impose all VCS capabilities on the project, such as history and advanced sharing capabilities. When unchecked, the project is stored in the Workspace and synchronized with the local copy – a 'mirrored' project in the Simple Sync format. ► More information.

    The Version Control option is available only when connected to an Altium 365 Workspace. When connected to an Enterprise Server Workspace, this option is effectively checked.
  • When connected to an Enterprise Server Workspace, the Repository drop-down menu (if present) will list all design repositories managed through Workspace's Version Control Service, and which have been shared with you to use. Choose the repository in which to store the new project and its files – there is a single Git-based repository (Versioned Storage) available by default. If a SVN type repository is selected, an additional Repository Folder option is available for specifying or browsing to an alternative target folder within the repository itself.

  • Click the Advanced control to specify folder paths.
    • Use the Folder field to specify where the folder for the project – within the Workspace's folder structure – is to be created. The default path for new projects is specified on the Admin – Settings – Projects page of the Workspace's browser interface (by default, this will be Projects\<ProjectName>). Click the button to browse to and select a different Workspace folder, if required.
    • Use the Local Storage field to specify where the local version of the project will be stored on your hard drive. The default location is defined on the System – Default Locations page of the Preferences dialog. Click the button to browse to and select a different folder location, if required. This is the 'working' folder for the project and the local Git repository it is committed to. The project is ultimately, or at the time of committal, pushed to the centralized design repository in the Workspace (Versioned Storage), which is the remote Git repository.
  • Use the Parameters list area to add or remove custom Name/Value parameter pairs that are associated with the project and saved in the Workspace. Use the button to add a new parameter Name-Value pairing to the list. These managed project parameters are saved in the Workspace with the new project, and can be edited within the Workspace. By contrast, Project type parameters are saved in the project file (*.PrjPcb), and can be edited in Altium Designer. Both parameter types may be used as Special Strings in Altium Designer – access from the Properties panel with a placed Text String selected in the design workspace. Parameters defined for the project can also be viewed on the Parameters tab of the Project Options dialog (Project » Project Options).

With the project defined as required, click the button. The new project structure will be created in the specified local and Workspace folders. The project will be opened in the Projects panel, which will reflect the fully synchronized state that exists between the files in the remote design repository (in the Workspace) and the local (working copy) repository – as indicated by the associated icons. If created with the Version Control option unchecked (available in an Altium 365 Workspace only), the mirrored project will be shown in the Projects panel with an associated icon.

The newly created project committed to the Versioned Storage design repository in the Workspace.The newly created project committed to the Versioned Storage design repository in the Workspace.

Alternatively, if the new project has not been assigned a template with constituent documents, the project file (*.PrjPcb) and therefore the structure of the project only will be created. The project is then opened in the Projects panel, which will show it as being Scheduled for addition, denoted by the associated icon. At this point you can add documents to the project, or simply save the structure to the Workspace in its current shell state. To do so, click the Save to Server control associated with the project entry in the Projects panel – also available from the right-click context menu, and from the main File menu. In the following Save to Server dialog, select/deselect files for inclusion, add an optional Comment, and then confirm the save process with the button. Once the project is added to the server, the Projects panel will reflect the fully synchronized state that exists between the files in the server repository and the local working copy, as indicated by the icons.

  • The project will appear in the Projects panel under an entry for the target Workspace, reflecting the name of that Workspace.
  • In addition, an entry for the project will appear on the Projects page of the Workspace's browser interface.
  • The project will initially be shared for Read/Write access with the designer who created it (Owner), and all Administrators for the Workspace.

    ► See Sharing a Project for more information on configuring project access permissions.

  • A new project also can be created directly in a Workspace through its browser interface on the designs page (select Projects), and subsequently opened for editing and addition in Altium Designer.
  • Along with the project file (*.PrjPcb), the project structure file (*.PrjPCBStructure) is created. This file contains information about the project hierarchy whether it is flat or hierarchical. This file is regenerated upon the dynamic compilation of the project (when a project document opens).
  • The Create Project dialog can also be accessed by right-clicking on the Workspace entry within the Projects panel and choosing the Create Project command from the menu.

Creating a New Process-based Workspace Project

Related pages: Processes & Workflows (Altium 365 Workspace, Enterprise Server Workspace), Creating & Managing Processes (Altium 365 Workspace, Enterprise Server Workspace)

When one or more process definitions for the Project Creations process theme are active, the ability to create a new Workspace project through the Create Project dialog described in the previous section is restricted to Local and VCS type projects only. Instead, the creation of Workspace-based projects comes under the control of active process definitons.

Note that this functionality is only available when using Altium Designer with active Altium Designer Enterprise Subscription and a connected Workspace.

From within Altium Designer, activated process definitions that are part of the Project Creations theme can be accessed from the main File » New » Project in <WorkspaceName> sub-menu. After launching the chosen command, the Create New Project dialog (actually named after the chosen process) opens. Use the General tab of the dialog to give the project a name and description, specify its type, and assign a template, if desired. On the Advanced tab, you can specify the local working directory for the project, choose the target repository and folder and also specify in which folder, within the Workspace's folder structure, it is to reside. Once ready, click Start to create the new Workspace project in accordance with the underlying workflow for that process.

The dialog with which to start creation of a project, based on a define process workflow. Note that the name of the dialog will reflect the name of the chosen process.The dialog with which to start creation of a project, based on a define process workflow. Note that the name of the dialog will reflect the name of the chosen process.

General Tab

  • Project Name - enter a suitable name for the Workspace project.
The project name must start with and can contain lower or uppercase letters or 0-9. Underscores, dashes, and spaces are allowed but can only be used in the middle of the name (beginning and ending spaces will be ignored). You cannot use the following words: AUXCOM1-COM9LPT1-LPT9CONNUL, or PRN. In addition, the name cannot contain the following characters: \ . / ? % * : | " < >.
  • Description - enter a meaningful description of the project.
  • PCB Project Type - use the drop-down to select a suitable project type.
  • Project Template - use the drop-down to select the desired template from a list of installed templates. Click  to open a version of the Explorer panel (titled Select Project Template) to select the desired template.
  • Start - when clicked, the project will be created in accordance with the underlying workflow process.

Advanced Tab

  • Location - use to specify the location where the project will be located. Click  to browse and select the desired location.
  • Create Project Folder - check to create a new project folder automatically.
  • Repository - use the drop-down to select the desired repository for the project.
  • Repository Folder - click  to open the Add to Version Control dialog in which you can specify the repository folder.
The folder name must start with and can contain lower or uppercase letters or 0-9 and underscores. dashes, and spaces are allowed but can only be used in the middle of the name (beginning and ending spaces will be ignored). You cannot use the following words: AUXCOM1-COM9LPT1-LPT9CONNUL, or PRN.
  • Server Folder - use to specify the server folder. Click  to open the Choose Folder dialog in which you can choose the desired folder.
The server folder path can start with any symbol except space or slash and can contain any symbol except space at the end. Spaces are allowed in the middle of the server folder name.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: