Altium Designer Documentation

Create Project (File Menu)

Modified by Susan Riege on Mar 4, 2020


The Create Project dialog

Summary

The Create Project dialog is used to create a new project. Every design starts with a project file that stores project level settings, such as links to each of the design documents within that project. As well as creating the new project file on the hard drive, this dialog supports adding the new project to version control or creating it as a managed project in your server or workspace.

The new project can be created:

  • As a managed project in an Altium Designer workspace.
  • As a managed project in an on-site server.
  • In your version control system with a working copy in your preferred location.
  • In a folder on the local hard drive.

Access

The dialog is accessed by choosing File » New » Project from the main menus.

Options/Controls

Locations

Select the target location of the project. 

 The Create Project dialog when not signed in on the left, and when connected to a Workspace on the right.

If you are not connected to a Workspace, do so by clicking the corresponding button for the Workspace in the main area of the dialog. 
  • Project Type - use to select the type and template of the project. All available templates are listed.
  • Project Name - a default name appears; enter a meaningful name for the project.
  • Description - enter a meaningful description of the project.
  • Enable Formal Version Control - allows multiple contributors to work on this project - enable this option using the checkbox, if desired. 
  • Parameters - use this region to add custom Parameters to the project as the project is being created. Project Parameters for a managed project are read-only and can be accessed on the Server Parameters tab of the Project Options dialog (Project » Project Options).
    • Name - the name of the parameter.
    • Value - the parameter's value.
    • Add - click to add a parameter.
    •  - click to delete the selected parameter(s).

  The Create Project dialog when not signed in on the left and when signed in to a managed content server on the right. 

If you are not currently signed in to your server, do so by clicking the corresponding button for the server in the main area of the dialog. All known on-site servers will be listed in which you will be prompted to sign in using your server credentials unless Sign in Automatically has been enabled from your Sign In dialog. Alternatively, you can sign in to a different server using the Custom button. Remember that while it is possible to have connections to different servers (these are listed as Known Servers), you can only be actively signed into one managed content server through the software at a time. You can check which servers you are connected to from the Data Management - Servers page of the Preferences dialog. 
  • Project Type - use to select the type and template of the project. All available templates are listed.
  • Project Name - a default name appears; enter a meaningful name for the project.
  • Description - enter a meaningful description of the project.
  • Enable Formal Version Control - allows multiple contributors to work on this project - enable this option to allow version control. 
  • Folder - enter a name for the folder of this project in the repository. Use  to open the Choose Folder dialog in which you can navigate to and select the desired folder within the repository.  
  • Local Storage - use  to open a dialog in which you can browse to and select the desired local storage location.
  • Parameters - use this region to add custom Parameters to the project as the project is being created. Project Parameters for a managed project are read-only and can be accessed on the Server Parameters tab of the Project Options dialog (Project » Project Options).
    • Name - the name of the parameter.
    • Value - the parameter's value.
    • Add - click to add a parameter.
    •  - click to delete the selected parameter(s).

The Create Project dialog when creating a project under Version Control

  • Project Name - a default name appears; enter a meaningful name for the project.
  • Repository - use the drop-down to display the connected repositories defined in the Data Management - Design Repositories page of the Preferences dialog. Click  to open the Preferences dialog from where you can connect to a repository.
  • Repository Folder - enter a name for the folder of this project in the repository. Use  to open the Choose Folder dialog in which you can navigate to and select the desired folder within the repository.  
  • Local Storage - use  to open a dialog in which you can browse to and select the desired local storage location.
  • Parameters - use this region to add custom Parameters to the project as the project is being created. Project Parameters for a version-controlled project can be accessed on the  Parameters tab of the Project Options dialog (Project » Project Options).
    • Name - the name of the parameter.
    • Value - the parameter's value.
    • Add - click to add a parameter.
    •  - click to delete the selected parameter(s).

The Create Project dialog when creating a Local Project 

  • Project Name - a default name appears; enter a meaningful name for the project.
  • Folder - a default name appears; enter a meaningful name for the project. Use  to open a dialog in which you can browse to and select the desired local folder.
  • Parameters - use this region to add custom Parameters to the project as the project is being created. Project Parameters for a local project can be accessed on the Parameters tab of the Project Options dialog (Project » Project Options).
    • Name - the name of the parameter.
    • Value - the parameter's value.
    • Add - click to add a parameter.
    •  - click to delete the selected parameter(s).

Additional Controls

  • Create - click to create and save the project and associated files. The new project will be listed in the Projects panel.
When you click Create for a version-controlled or managed project, it will be added to the specified folder within the target repository then checked out to the local working folder defined in the Local Storage field. 
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.