Additional Features and Enhancements (New Feature Summary)

Created: July 10, 2019 | Updated: March 19, 2020
This documentation page references Altium NEXUS/NEXUS Client (part of the deployed NEXUS solution), which has been discontinued. All your PCB design, data management and collaboration needs can now be delivered by Altium Designer (with Altium Designer Enterprise Subscription) and a connected Altium 365 Workspace. Check out the FAQs page for more information.

Contents

All Contents

Data Management Enhancements

Improved Components Panel Search Results Priority

The search functionality of the Components panel has been improved to correctly prioritize results according to the entered search criteria.

New Merge Component Types Feature

This new feature allows you to merge selected component types into a single, specified component type. The feature is accessed from the Data Management - Component Types page of the Preferences dialog by selecting one or more component types then right-clicking and choosing Merge. The Merging dialog opens and functions as described below:

  • If one component type was selected, use the Merge to drop-down to select the desired target component type (shown in the first image below).
  • If several component types were selected (using Shift+Ctrl) including the target type, use the Merge to drop-down to select the target type from the previously selected types (shown in the second image below).
As the dialog states, the merging action cannot be undone so use caution before clicking the Merge button in the dialog.

One component selected opens the Merging dialog with all available target component types in the drop-down.

Multiple components selected opens the Merging dialog with the selected component types in the drop-down.

New Mapping Feature for Component Types

A new feature has been added that allows you to control the mapping between component types and component templates. The feature is accessed from the Data Management - Component Types page of the Preferences dialog by clicking the Templates button. In the Edit templates dialog that opens, click in the Component Type field of the type you want to change then use the drop-down to assign the component type to the associated template.  

Added Support for Arrow Key Functions in the Categories List of the Components Panel

Added the ability to use the arrow keys on the keyboard to move through the categories in the Category drop-down area of the Components panel (shown in the image below). Use the up/down arrow keys to move through the list; use the left/right arrow keys to open or close branches. 

Added Ability to Push Column Visibility Settings in the Components Panel from Parent to Child Categories

A new command has been added that allows you to push the column visibility settings of the parent category to all child categories. The command is accessed by right-clicking on a selected category that has at least one child category then selecting Apply Column Visibility to Child Categories.  When the command is clicked, the column visibility and order of the child category(ies) will be the same as the selected parent category.

Sharing Components Panel Settings

The ability to share Components panel settings between installations has been added through the use of DXP preference files.

Added Capability to Edit a Footprint When the Schematic Library has a Valid Footprint

The Models region of the Components panel now allows you to edit a footprint when the schematic library has a valid and linked footprint.

Added BOM Report Output When No Schematic is Present

Bill of Materials has been added to Report Outputs in an Outjob file (*.OutJob) if there are no schematic documents in the project. In such an instance, the Bill of Materials report is sourced from the PCB.

BOM report for Outjob when no schematic is present

Access to Altium Content Vault Removed from Explorer Panel

The ability to browse the content of the Altium Content Vault directly through the Explorer panel has been removed. The content from the Altium Content Vault has, in reality, been ported behind the scenes in support of Manufacturer Part searching. This is highlighted in the Manufacturer Part Search panel through the use of the  icon. Component entries listed with this icon have schematic symbol and footprint model items defined and referenced, and therefore, can be placed, downloaded or acquired. The Manufacturer Part Search panel provides the ability to search for real-world manufactured parts by offering a sophisticated search feature based on categories and parametric filtering. The panel harnesses the manufacturer and supplier data resources of the Altium Parts Provider service to source the most pertinent and up-to-date component data. A selected manufactured part can be downloaded as a library or acquired into your active managed content server, or its parameters and datasheets can be added to an existing part in the design space.

Added 'Content Vault replaced with Manufacturer Part Search' Dialog

The Content Vault replaced with Manufacturer Part Search dialog has been added in order to redirect users to the Manufacturer Part Search panel. The dialog is accessed when Altium Content Vault is chosen from the server drop-down in the Explorer panel.

Altium Content Vault models are now included in the Manufacturer Part Search panel, therefore, this dialog opens in which you can choose from the following options:

  • Proceed with Search - choose this option to open the Manufacturer Part Search panel.
  • Learn More - choose this option to open the documentation page of the Manufacturer Part Search panel.

Schematic Editor Enhancements

Restored Elliptical Arc Object Placement in Schematics

The Elliptical Arc object can once again be placed in schematics.

Elliptical Arc Placement

New Update Port Cross Reference Command

A new Update On Project command has been added to the Reports » Port Cross Reference sub-menu that updates cross-references of all schematic documents (from within the targeted project) that have changed.

Ability to Navigate By Objects in an Interactive (Smart) PDF Schematic

In a Smart PDF schematic, you can now click on an object and it will navigate to a child page, port or sheet entry, or a corresponding off-sheet connector. This new navigation feature includes:

  • Clicking on a sheet symbol will navigate to a child schematic page.
  • Clicking on a sheet entry will navigate to a port on a child schematic page.
  • Clicking on port will navigate to a connected port or sheet entry.
  • Clicking on an off-sheet connector will navigate to a corresponding off-sheet connector.

If the clicked item is connected with more than one item (for example, multi-channel sheet symbol, several ports with the same name, etc.,), the navigation will jump to the first item.

Added Option to Exclude Specific Component Parameters in the Smart PDF Wizard

An option has been added in the Smart PDF Wizard (File » Smart PDF) that allows you to exclude specific component parameters in the generated PDF document. The new Exclusions button is on the Additional PDF Settings page of the Wizard, as shown below. 

Additional PDF Settings page of the Smart PDF Wizard

Click the Exclusions button to open the Exclude Parameters dialog. In the dialog, enter the parameter name you want to exclude then click the Add button. Enter additional parameters, if desired, clicking Add after each entry.

Exclude Parameters dialog

PCB Editor Enhancements

Added 'Ignore Internal Layers' Option to Creepage Rule

An Ignore Internal Layers option has been added to the Creepage rule that allows you to specify that the rule should only be applied to outer layers.

Added 'Tented' Option for SolderMaskExpansion Design Rule

When this option is enabled (checked), the pad/via has no solder mask opening on the top/bottom of the board and is therefore tented.

Added Ability to Apply the Show or Hide Nets Command to Multiple Selected Components

It is now possible to show or hide identical nets for multiple selected components. The feature is accessed by selecting more than one component, right-clicking then choosing Component Actions » Show Nets/Hide Nets.

Added Ability to Create 3D Bodies from Selected Primitives in a PCBLIB Document

The ability to create a 3D body from selected primitives was previously available for a PCB document, and with this release, it is now available for a PCBLIB document as well. The command for this new feature is accessed by choosing Tools » Convert » Create 3D Body From selected primitives in a PCBLIB document.

Added Ability to Add Designators for Assembly Drawings

The .Designator string can now be automatically added to all components using the Tools » Add Designators for Assembly Drawing command. The string is added according to the current Designator default preferences (PCB Editor - Defaults page of the Preferences dialog, and is placed in the geometric center of the component. Use the command in the PCB editor to apply to all component footprints on the board, or in the PCB library editor to apply to all footprints in the library. The .Designator string is placed on the top-side layer of a mechanical Component Layer Pair with a Layer Type of Designator, if no suitable component layer pair is present they can be added automatically.

New 'Delete Selected Unions' Command

A Delete Selected Unions command has been added to the PCB panel in Unions mode. The command is accessed by selecting one or more unions in the PCB panel in Unions mode then right-clicking and choosing Delete Selected Unions. When the Delete Selected Unions command is clicked, the selected unions will be deleted from the panel.

Added PCB Library 'Measure 3D Objects' Feature

In the PCB Library editor in 3D Layout Mode (View » 3D Layout Mode or shortcut 3), the Reports menu now includes a Measure 3D Objects command that allows you to verify that 3D files for the component display the correct height as defined in its datasheet. 

Workspace Enhancements

New Customer Experience Improvement Program

The new Altium Customer Experience Improvement Program (previously known as the Altium Product Improvement Program) allows you to be a part of our analytic gathering process to help improve our products by understanding how our products are used. During a new installation, the below page appears as the last step before installation begins. Check Yes, I want to participate to share information with Altium regarding how you use our desktop and cloud products. Check Don't Participate to opt-out. 

Fractal Panels Option

A new option has been added to the Advanced Settings dialog (accessed from the System - General page of the Preferences dialog) - UI.DisableFractalMode. When enabled, this option prevents any further combination of workspace panels in a fractal nature. Note that it does not separate those grouped panels that already existed in a fractal layout prior to enabling the option. You will need to move the panels in those pre-existing groupings yourself, taking them out of fractal mode manually. However, once that is done, and after having set up your panels exactly the way you like them, you will not experience fractal paneling from that point on (and provided you keep the UI.DisableFractalMode option enabled!).

Added the Ability to Enable or Disable Scrollbars in PCB/PCBLIB and SCH/SCHLIB Editors

An option that allows you to enable/disable scrollbars in PCB/PCBLIB and SCH/SCHLIB editors has been added to the Advanced Settings dialog. When the UI.UseScrollbarsInEditors option is enabled, scrollbars appear to the right of the design space. 

Added Ability to Disable Anti-aliasing in Schematics

An option that allows you to enable/disable anti-aliasing in schematics has been added to the Advanced Settings dialog. When the Schematic.Drawing.UseAntiAlaising option is checked, anti-aliasing is enabled. To disable, uncheck the option.

Restored 'Multiline documents bar' Option on the System - View Preferences Page

Multiline documents bar option has been added to the System - View page of the Preferences dialog. This option is useful if there are more document tabs that can fit on a single document bar; a new document bar will appear with the extra tabs. When this option is disabled, only one document bar can host document tabs; if there are more than can fit on the document bar, two arrows will appear allowing you to click to move forward/backward along the bar.

Multiline document bars option

New Navigator and Projects Panels Refresh Command

The Navigator and Projects panels now include a Refresh command. Use the command to update the respective panel with any changes you have made. The command is accessed in the following ways:

  • From the Navigator panel: right-click anywhere in the panel then choose Refresh.
  • From the Projects panel: right-click in the top region of the panel then choose Refresh.

Navigator and Projects panels new Refresh command

The To-Do Panel Has Been Restored

The To-Do panel has been restored. The panel lists all To-Do items that are currently defined for the active project. A To-Do item can be added in the Edit To-Do Item dialog and is used as a reminder for a task that needs to be carried out at a later stage in relation to a document. The panel is accessed by clicking the Panels button at the bottom-right of the design space then choosing To-Do. The panel also can be accessed from the main menus by clicking View » Panels » To-Do.

To-Do Panel

To access the panel, the Value field for the UI.PanelToDoList Preference Name on the Advanced Settings dialog must be enabled (it is disabled by default). The Advanced Settings dialog is accessed by clicking the Advanced button on the System - General page of the Preferences dialog. If any changes are made in the Advanced Settings dialog, the software must be restarted in order for the changes to take effect.

The Clipboard Panel Has Been Restored

The Clipboard panel has been restored in this version. This panel stores and displays copied objects that can be added (pasted) to Altium NEXUS documents at any stage, allowing for multiple copy/paste operations.

To access the panel, the Value field for the UI.PanelClipboard Preference Name on the Advanced Settings dialog must be enabled (it is disabled by default). The Advanced Settings dialog is accessed by clicking the Advanced button on the System - General page of the Preferences dialog. If any changes are made in the Advanced Settings dialog, the software must be restarted in order for the changes to take effect.

'Mechanical CAD Collaboration' Extension Renamed 'MCAD IDX Exchange'

The Mechanical CAD Collaboration extension has been renamed MCAD IDX Exchange. The extension can be found on the Extensions & Updates page (accessed by clicking the  User drop-down control at the top-right of the workspace then choose Extensions and Updates from the menu). For information about installing extensions, refer to Extending Altium NEXUS.

MCAD IDX Exchange extension

Dialog Enhancements

Detailed Information and Search Function Added to the Open Project Dialog 

The Open Project dialog has been enhanced to view detailed information without the need to open a project and to help you find projects.

Project Details

The dialog now displays detailed information about the selected project. The details are displayed on the right-hand side of the dialog and include an image of the project, last modified date and time, the parameters associated with the project, and other information about the project. The details region is toggled on and off by clicking the  /  button.

You now can search for a project by entering a local location in the search field at the top of the dialog. Additionally, you can use  in the search field to navigate to the folder up. To navigate to "Top", hold the Alt key while clicking .

 

New 'Change System Component Parameters' Option in Project Options Dialog

A Change System Component Parameters option has been added to the ECO Generation tab of the Project Options dialog. This option can be used to control whether or not to generate change orders or ignore modifications to the system component parameters when performing an Engineering Change Order. The new option is set to Generate Change Orders by default.

Relative Coordinates Added to PCB Jump To Location Dialog

For faster creation of lines, polygons, etc., relative coordinate options (Delta X and Delta Y) have been added to the Jump To Location dialog (Edit » Jump » New Location). When the Delta X or Delta Y options are updated, the X and Y fields will be affected and updated accordingly. 

Jump To Location (PCB) Dialog

New Thermal Relief Overrides Option 

A Thermal Relief Overrides option has been added to the Component(s) Update Options dialog. When the option is disabled, incoming changes for thermal reliefs from the PCB Library will be ignored. This option is enabled by default.

Thermal Relief Overrides option

Polygons Grouped By Layer in the Polygon Pour Manager Dialog

The ability has been added to group polygon pours by layer in the Polygon Pour Manager dialog. The Pour Order list will present only those polygon pours on the same layer as the currently selected polygon pour (or first selected if multiple pours are selected across different layers).

Added Controls in the Edit Component Variation Dialog

The Edit Component Variation dialog now includes additional information for Alternate Parts, which varies depending on how the dialog was accessed. Additionally, the new Replace Component button opens the Replace Component (File-based) dialog, which is populated with ready-to-place components from your managed content server and file-based library sources.

New 'Skip Hidden 3D Bodies' Option in Export Options Dialogs

A Skip Hidden 3D Bodies option has been added to all variations of the Export Options dialog. Enable the option to skip (i.e. not export) hidden 3D bodies.

 

Added Search Function in PCB Rules and Constraints Dialog

The PCB Rules and Constraints dialog now includes a Search feature. This new feature allows you to quickly find the rules pertaining to your needs at the time. Enter a text string to filter the dialog to show only rules with that text.

Improved the PCB Library Footprint Dialog

The PCB Library Footprint dialog has been improved by adding the ability to resize the dialog, adding an Area field, and allowing more room for the Name field.

Alternate Part Default Footprint Used in the Variant Management Dialog

When choosing to use an alternate part in the Variant Management dialog, the default footprint is now used rather than leaving the field empty.

New Options in the Unused Pad Shapes Dialog 

The Unused Pad Shapes dialog has two new options. In the Scope region, the Both option has been added. Selecting this option will target both pads and vias. The Operation region now includes the Update unused option, which restores then removes unused pad shapes. 

New Copper Area in Board Report Dialog

Copper Area has been added to the Board Report dialog as an item that can be included in the report.

Fixed 'Height' Label Alignment in the Cartesian Grid Editor Dialog

The Height field label in the Cartesian Grid Editor dialog has been aligned properly with the associated textbox.

New 'Apply to All Libraries' Option in the Extract Sources or Install Dialog 

The new Apply to all libraries option in the Extract Sources or Install dialog allows you to apply the chosen action (Extract Sources or Install Library) to all file-based libraries.

Panel Enhancements

PCB List Panel

The ability to perform a layer change for components in the PCB List panel has been restored. While in Edit mode, use the drop-down in the PCB List panel Layer field to choose the desired layer.

View Configuration Panel Enhancements 

Defining Transparency for Selected Primitives

The View Configuration panel has been improved to allow you to define the transparency for selected primitives on all layers. This feature has been added to the Object Visibility region of the View Options tab. You can use the Transparency slider bar to set the transparency or click the value and enter the desired percentage manually between 0 and 100 (0% is fully visible (solid); 100% is fully transparent (invisible)). Click the Advanced button to open a dialog that displays a grid with rows representing each layer in your design and columns representing each design object type. The dialog allows you to set a common transparency level for a particular object across different layers and also allows you to give different objects different transparencies on a specific layer.

New Object Visibility Dialog

The Object Visibility dialog enables you to set the transparency of each object type individually and on a per-layer basis for each layer. Select the object(s) and layer(s) in the grid then use the Transparency for selected slider bar to set the desired transparency. Further to the right increases transparency. 0% is fully visible (solid); 100% is fully transparent (invisible). You can enable the Only show used layers option to only display layers that are used in the current design.

Improved Projects Panel Server Node Entries

The options when right-clicking on a server in the Projects panel have been improved. Right-click then use Open Project to open the Open Project dialog to choose the project you want to open. Use the Show in Explorer option to open the Explorer panel. Use the Show in Web Browser option to open your server in a browser window.

New Messages Panel Warning When a File Has Been Removed From a Project

A warning is now displayed in the Messages panel while opening the project when a file has been implicitly removed from the project. This helps to clarify the reason for the project modification. 

Missing Files

Files missing from an opened project are now reported in the Messages panel versus error dialogs.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: