Часто задаваемые вопросы

Последнее изменение: Pavel Demidov; 07.05.2019

Чтобы быстро ознакомиться с программным обеспечением или какой-либо его составляющей, бывает полезно обратиться к списку часто задаваемых вопросов. Это могут быть как самые общие вопросы, вроде "Где мне найти ту или иную функцию?", так и более конкретные, например "Как мне экспортировать свой проект в формат xyz?".

В некоторых случаях мы стараемся упреждать вопросы, которые, на наш взгляд, могут быть заданы, или делаем акцент на важных аспектах программного обеспечения, о которых, как мы полагаем, вам следует знать. Кроме того, мы часто обращаемся к форумам Altium, отбирая частые вопросы по всем аспектам программного обеспечения от многих людей, которые используют ПО в своей повседневной работе.

Просмотрите на списки часто задаваемых вопросов, которые сгруппированы по категориям для вашего удобства. Там может находиться необходимый вам ответ на вопрос, который может помочь вам преодолеть препятствие и продолжить работу.

Этот список часто задаваемых вопросов, связанных с проектированием в системах Altium, отнюдь не является исчерпывающим, но он будет расширяться со временем, помогая раскрыть весь потенциал проектирования при использовании программного обеспечения.

Часто задаваемые вопросы сгруппированы по следующим разделам, вопросы в которых, в свою очередь, тоже разбиты на группы (там, где это имеет смысл):


Среда Altium NEXUS

Общее

Помимо того, что вы можете свободно располагать рабочие панели и панели инструментов и работать с документами на множестве мониторов, вы также можете настраивать меню, панели инструментов и сочетания клавиш в Altium NEXUS. Чтобы открыть диалоговое окно настройки текущего редактора:

  • Щелкните правой кнопкой мыши по строке меню или по панели инструментов и выберите команду Customize из контекстного меню.
  • Дважды щелкните мышью по пустому полю строки меню или панели инструментов.
  • Выберите команду View » Toolbars » Customize главного меню.
Altium NEXUS также поддерживает создание скриптов, что позволяет вам разрабатывать собственные команды в соответствии с потребностями вашего предприятия.

Чтобы избежать закрепления панели, когда вы перемещаете ее в плавающем состоянии, зажмите клавишу Ctrl.


Проекты

Общее

Да, конечно. Установка Altium NEXUS включает в себя несколько примеров проектов, которые находятся в папке Examples (\Users\Public\Documents\Altium\AD<НомерВерсии>\Examples для установки по умолчанию).

Управляемые проекты

Некоторые ключевые преимущества использования управляемых проектов:

  • Упрощенное хранение. Нет необходимости принимать решения о том, где сохранять проекты. Система берет на себя выполнение резервного копирования и прочих базовых функций.
  • Основа для совместной работы.
  • Обеспечение контроля версий.
  • Специальная система комментирования.
  • Уведомления и состояния. Состояние документа, в том числе внесение локальных изменений, видно всей проектной группе.
  • Одновременная работа над проектом платы работает без необходимости в сложной настройке.

Эффективность управляемых проектов заключается в том, что они находятся в системе контроля версий по умолчанию, и с ними можно работать совместно, не заботясь о настройке общих ресурсов, серверов, внутренних соглашений и т.д.

Изначально проект доступен только вам как тому, кто его создал, и всем администраторам сервера управляемых данных (в котором хранится содержимое). Чтобы проект стал доступен остальным, необходимо его опубликовать, настроив права доступа.

Если команда Convert to Managed Project для преобразования в управляемый проект не доступна, это значит, что в данный момент этот проект находится в системе контроля версий (в локальном или сетевом репозитории VCS) или был там ранее.

Это можно разрешить созданием "чистой" копии проекта (не связанной с VCS) в другой локальной папке и преобразованием этой версии в управляемый проект. Для этот необходимо:

  1. Открыть проект в Altium NEXUS:
    1. Для проекта, который находится в системе контроля версий, используйте команду File » Checkout, чтобы открыть (извлечь) проект из репозитория VCS в локальную рабочую папку.
    2. Для проекта, который уже не находится в системе контроля версий, используйте команду File » Open Project, чтобы найти и открыть проект из локальной папки.
  2. Используйте средство Project Packager (Project » Project Packager), чтобы создать единый zip-файл проекта, который по умолчанию будет сохранен в локальной папке проекта; как правило, это путь вроде C:\Users\Public\Documents\Altium\Projects\MyProject.
  3. В операционной системе создайте локальную рабочую папку специально для управляемых проектов, например: C:\Users\Public\Documents\Altium\ManagedProjects.
  4. Переместите zip-файл проекта в новую папку (...\ManagedProjects), распакуйте его содержимое (ПКМ - Extract All) и измените имя подходящим образом. Полученный путь папки-дубликата проекта будет C:\Users\Public\Documents\Altium\ManagedProjects\MyProject.
  5. Если проект ранее был управляемым проектом, откройте файл проекта (*.PrjPcb) в текстовом редакторе, например Блокнотом Windows, и удалите запись ManagedProjectGUID=, которая находится в первом разделе [Design]. Сохраните измененный файл проекта.
  6. Вернитесь в Altium NEXUS и откройте (File » Open Project) дубликат проекта из его папки – той, в которую был распакован проект.
  7. Щелкните ПКМ по файлу проекта и выберите команду Convert to Managed Project, которая теперь должна быть доступна.

Варианты проекта

Чтобы проверить варианты, вы должны скомпилировать проект и затем переключиться на скомпилированную вкладку схемы. В панели Projects будет отображена папка Variants проекта, и прямо под ней будет показан по крайней мере один вариант, заданный в проекте. Папка содержит записи для базового проекта ([No Variations]), а также все заданные варианты. Чтобы сделать какой-либо из представленных в списке вариантов активным, дважды щелкните по нему в панели мышью либо щелкните по нужному варианту ПКМ и выберите команду Set as current из контекстного меню. Этот способ также применим и для переключения на базовый вариант (запись [No Variations]).

Обратите внимание, что при переключении на скомпилированную вкладку доступные пункты меню будут изменены, отражая команды, которые могут быть активированы при просмотре физического проекта. При щелчке по вкладке логического проекта (Editor) в нижней части листа схемы вы вернетесь к стандартным меню редактирования.

Существует два способа управления альтернативными компонентами на плате:

  • Если посадочное место одно и то же – если выбранный альтернативный компонент имеет то же самое посадочное место, что и базовый компонент, то только один экземпляр этого посадочного места будет передан в плату. Поскольку компоненту может быть назначено множество посадочных мест, следует убедиться, что для каждого варианта в диалоговом окне Variant Management выбрано правильное посадочное место.
  • Если посадочные места отличаются – если имя посадочного места альтернативного компонента отличается от базового компонента, то в печатную плату будут переданы оба посадочных места. Вы как проектировщик должны затем решить, как разместить эти два посадочных места на плате. Обратите внимание, что у обоих посадочных мест будет одно и тоже позиционное обозначение, поскольку только один из этих двух компонентов будет смонтирован.

После выбора альтернативного компонента система проверяет совместимость по выводам между выбранным альтернативным компонентом и изначальным базовым компонентом. Чтобы компоненты были совместимы по выводам, у альтернативного компонента должно быть то же самое количество выводов, что и у изначального компонента, эти выводы должны находиться в тех же местах и они должны иметь те же электрические типы. Графические примитивы, используемые для представления символов этих двух компонентов, не обязательно должны быть идентичными.

Если система обнаружит, что альтернативный компонент не является совместимым по выводам, появится диалоговое окно Confirm, где нужно нажать OK, чтобы подтвердить замену. Хоть вы и можете использовать не совместимый по выводам альтернативный компонент, помните, что возможны потенциальные проблемы соединений и что вы также можете получить нарушение при выполнении последующей компиляции проекта.

Контроль версий

Интерфейс Altium NEXUS можно настроить для работы со следующими приложениями систем контроля версий:

  • Внутренняя копия системы контроля версий Subversion (SVN) в Altium NEXUS.
  • Встроенная в сервер управляемых данных система Subversion (SVN) с использованием централизованного подхода к контролю версий для доступа как на основе сервера, так и из внешних проектных репозиториев.

Компоненты и библиотеки

Общее

Каждый режим должен содержать одинаковое количество выводов, чтобы при компиляции проекта не производилось предупреждение. Это требуется потому, что можно задать только один набор отображений выводов к контактным площадкам каждого посадочного места. Если необходимо, для определенного режима выводы можно скрыть. Выводы не обязательно должны располагаться в одних и тех же местах.

Управляемые компоненты

И да, и нет. Всё зависит от того, есть ли в управляемом компоненте (объекте Component Item) связанные варианты выбора компонента (Part Choices) или нет. При первом выпуске исходного определения компонента полученный в результате Component Item, рассматриваемый как управляемый компонент, представляет собой вид этого компонента с точки зрения проектирования. По сути, это контейнер, в котором хранится вся информация, необходимая для моделирования этого компонента в проектном пространстве. Он включает в себя ссылки на все необходимые модели (схемный символ, посадочное место, имитационные модели), а также параметрическую информацию. Это крайне важно с точки зрения проектировщика, использующего этот компонент в проекте плате, но не имеет смысла за пределами проектного пространства. Чтобы стать действительно "Унифицированным компонентом", который объединяет области проектирования и цепочки поставок, объект Component Item должен быть отображен физическому, изготовленному компоненту. Это осуществляется путем указания Part Choices для этого компонента.

Именно это интеллектуальное отображение компонента из привычной области проектирования в "область изделия" более высокого уровня, которую видит остальное предприятие, и превращает скромный управляемый компонент в действительно унифицированный компонент!

У каждого размещенного компонента есть обратная ссылка на исходный Component Item на сервере. Эту информацию можно найти при просмотре свойств выделенного компонента в панели Properties. На этом самом низком уровне отдельного компонента обновить размещенный экземпляр до более новой ревизии того же Component Item (или изменить его на совершенно другой Component Item) можно нажатием кнопки ... справа от поля Design Item ID. Появится диалоговое окно Choose Item, в котором будет отображен связанный в данный момент объект Component Item (и его ревизия) в исходном сервере. Выберите более новую ревизию или другой Component Item, чтобы использовать его.

Для выполнения множества изменений в пакетном режиме из единого расположения используйте Item Manager (Tools » Item Manager). Здесь представлены все управляемые компоненты и/или символы листов, находящиеся на одном листе схемы (свободный документ) или множестве схем (в проекте платы). Здесь вы полностью управляете тем, какие управляемые элементы и каким образом будут обновлены. Выделите элемент и выберите более новую ревизию связанного Item. Выделите группу элементов, которые используют один и тот же связанный Item, и выберите нужную ревизию в один клик. Все предложенные изменения будут отображены в Item Manager.

После того, как изменения настроены необходимым образом, сформируйте и примените список Engineering Change Order (ECO), чтобы эти изменения были внесены.

Библиотеки на основе баз данных

Да. Если целевая база данных была создана с использованием множества файлов листов Excel (*.xls), есть предел на 64 листа, которые можно подключить, из-за ограничений драйвера ODBC.

При использовании Microsoft Access в качестве базы данных компонентов существует важное различие при использовании 32- и 64-разрядной версий ПО Altium для проектирования:

  • 64-разрядное ПО Altium для проектирования (Altium NEXUS 18.0 и более поздние версии) – требуют 64-разрядного Microsoft Access Database Engine для использования библиотек DbLib MS Access.
  • 32-разрядное ПО Altium для проектирования (Altium NEXUS 17.1 и более ранние) – требуют 32-разрядного Microsoft Access Database Engine для использования библиотек DbLib MS Access.

Обычно устанавливается та версия Microsoft Office, частью которой является Access. Но у многих пользователей, возможно, будут установлены на одном компьютере 32- и 64-разрядные версии ПО Altium. Проблема в том, что компания Microsoft официально не поддерживает установку 32- и 64-разрядных приложений и драйверов на одном компьютере. Для получения информации о трех возможных решениях этой проблемы см. Использование библиотек на основе баз данных при установленном на одном компьютере 32- и 64-разрядных версиях ПО Altium.

Связь с данными поставщиков

Использование динамических ссылок на данные поставщиков не требует входа в аккаунт Altium. Поиск осуществляется непосредственно по поставщикам через веб-службы. Тем не менее, для отображения цен в других валютах курсы валют обновляются ежедневно, для чего необходим вход в аккаунт.

Это происходит, если вы подключены к серверу управляемых данных вашего предприятия. Сервер централизованно определяет, какие поставщики будут использоваться на вашем предприятии. При подключении к серверу список поставщиков на странице Data Management - Suppliers диалогового окна Preferences будет отключен. Это будет лишь доступное только для чтения отражение централизованно определенного списка, заданного на странице Suppliers веб-интерфейса сервера.

Библиотеки шаблонов контактных площадок и переходных отверстий

Панель Libraries не используется для управления библиотеками КП/ПО и доступа к ним. Для этого существует панель PCB Pad Via Templates, которая обеспечивает управление как локальными (в документе платы), так и внешними (из библиотеки КП/ПО) шаблонами.


Ввод схем

Многолистовые и многоканальные проекты

Вы можете думать о плоских проектах как о большом листе схемы, разрезанном на множество более малых листов – в плоском проекте все листы существуют на одном уровне. Связь в плоском проекте осуществляется непосредственно между листами – такая связь называется горизонтальной.

В иерархическом проекте для создания взаимосвязи "родитель-потомок" присутствуют объекты Sheet Symbol, и связь осуществляется через объекты Sheet Entry в этих Sheet Symbol, а не непосредственно через порты (Port) на листах схем.

То, как вы хотите создать связь между листами, определяет параметр Net Identifier Scope, который находится на вкладке Options диалогового окна Options for Project.

Проект является плоским, если связь в нем осуществляется непосредственно от одного листа к другому – этот поведение задается параметром Net Identifier Scope с заданным значением Automatic, Flat или Global. Обратите внимание, что если вы используете объекты Port и Net Label для создания связи между листами, вы не можете использовать значение Automatic. В этом случае необходимо вручную задать параметру Net Identifier Scope значение Global.

Проект является иерархическим, если связь между листами в нем осуществляется только между объектами Sheet Entry на родительском листе и соответствующими объектами Port на дочернем – это поведение задается значением Automatic, Hierarchical или Strict Hierarchical параметра Net Identifier Scope.

Нет. Многоканальный проект должен быть иерархическим, поскольку система использует эту структурную модель для создания экземпляров каналов при компиляции проекта.

Для многоканального проекта задайте параметру Net Identifier Scope значение Automatic, Hierarchical или Strict Hierarchical.

Дублирование компонентов и цепей анализируется системой в соответствии со схемой именования, заданной на вкладке Multi-Channel диалогового окна Options for Project.

Аннотирование

По умолчанию позиционное аннотирование основано на положении позиционных обозначений компонентов. Если позиционное аннотирование происходит не так, как ожидается, убедитесь, что позиционные обозначения размещены корректно. Либо вы можете выбрать использование компонента (точнее, центра компонента) в качестве точки, принимаемой за его положение.

Выбор использования позиционного обозначения или компонента определяется в диалоговом окне Annotate.


Конструирование плат

Общее

Есть два способа добавления графики на плату:

Вставка из Буфера обмена Windows

Редактор плат поддерживает вставку метафайла непосредственно из Буфера обмена Windows на активный слой платы через стандартную команду вставки CTRL+V Windows. Обратите внимание, что не все графические редакторы помещают данные изображения в буфер обмена как данные метафайла. Один из способов обеспечить это – сначала вставить изображение в Microsoft Word, затем скопировать его оттуда и вставить в Altium NEXUS.

Поддерживаемые данные метафайла включают в себя растровые изображения, линии, дуги, простые заполнения и текст True Type, что позволяет легко вставлять логотипы и прочие графические символы. Импортируемые данные будут добавлены на активный слой в соответствии с цветом, выбранным для этого слоя. Объекты документа платы, созданные в процессе вставки, автоматически добавляются в объединение (Union). Для точной настройки размера вставленного изображения можно использовать ручки управления объединения. Объединения, полученные в результате вставки, также можно в любое время изменить с помощью команды Resize Union, доступной из контекстного меню (после запуска команды щелкните по нужному объединению мышью для его выбора).

Для настройки Paste from other applications (Вставка из других приложений) на странице PCB Editor - General диалогового окна Preferences можно задать параметру Preferred Format (Предпочтительный формат) значение Metafile или Text. На изображения этот параметр не влияет – каждая отдельная форма в изображении преобразуется в регион. При вставке текстовой строки каждый символ преобразуется в текстовую строку, если задано значение Metafile, либо вся строка вставляется как строка Altium NEXUS, если задано значение Text.


Логотип Altium, вставленный как графика, где каждая буква преобразована в регион.

Вставка графики как шрифта

Доступно создание пользовательского шрифта TrueType, который содержит изображение в качестве знака (одного из символов в шрифте), и последующее размещение строки в документе платы, который использует этот шрифт. Помимо простоты использования, еще одним преимуществом этого метода является то, что если знаки были созданы с использованием векторной графики, их размер можно точно изменить.

В конструкциях плат используется шрифт со множеством стандартных символов, в том числе "не содержит свинца", "переработка", "чувствителен к статическому электричеству", Earth, C-Tick, UL, CE, FCC и многие другие, который был создан одним из ведущих экспертов проектирования в Altium NEXUS Дарреном Муром (Darren Moore) из Mooretronics. Шрифт доступен для загрузки здесь (от июня 2015), либо вы можете найти более новую версию шрифта в наиболее поздних сообщениях ветки форума Altium NEXUS.

Шрифт лицензирован как Cardware. Обратитесь к файлу Readme.txt, включенному в ZIP-архив, для ознакомления с условиями использования. Файл readme также включает в себя список доступных изображений. Обратите внимание, что многие из них доступны с текстом или без него, нужная версия символа обозначена большой или маленькой буквой. На изображении ниже показан пример графики, доступной в шрифте.


Пример некоторых полезных символов в шрифте Mooretronics.

Плата

Линия Split Line остается синей при перетаскивании в допустимое расположение, которое приведет к корректному разделению. Если новое расположение конца линии при его перемещении окажется некорректным, например, конец будет перемещен на тот же край платы, что и зафиксированный конец, то линия станет красной. Попытка разместить линию, когда она красная, приведет к тому, что линия Split Line будет удалена.

Вы можете согнуть плату, только если у одного из жестких регионов включен параметр 3D Locked в диалоговом окне Board Region. Системе необходимо знать, какая часть платы должна оставаться неподвижной в процессе сгибания.

Правила проектирования и их проверка

Наиболее частой причиной того, что правило зазора для полигона не срабатывает, является то, что оно указывает на полигон как на единую сущность, а не на примитивы, из которых этот полигон состоит. Чтобы областью действия правила Clearance для полигонов являлись примитивы внутри этих полигонов, необходимо использовать ключевое слово InPolygon, InPoly или InNamedPolygon, а не IsPolygon.

Объекты Polygon Pour нужно воспринимать как контейнеры для объектов Region или Track, которые формируются повторно нужным образом при каждой перезаливке полигона. Трассы и регионы образуют проводящий рисунок, который формируется на этапе изготовления платы. Другими объектами, которые соответствуют проводящему рисунку, являются дуги, заполнения, строки, контактные площадки и переходные отверстия. Правило зазора будет работать только с этими так называемыми "проводящими объектами". Запрос правила зазора не будет работать, если он указывает на объекты Polygon Pour, например, если в качестве запроса используется ключевое слово IsPolygon. Запрос должен указывать на регионы или трассы, которые являются частью заливки полигона, с помощью, например, ключевого слова InPolygon.

Также необходимо убедиться, что правила зазора для полигонов имеют более высокий приоритет, чем общее правило зазора (область действия – между All и All). 1 является наивысшим приоритетом.

Примеры:

Настройка зазора между объектами Polygon Pour и прочими объектами:

Первый запрос InPolygon
Второй запрос All

Настройка зазора между объектами Polygon Pour, назначенными цепям класса Power, и прочими объектами:

Первый запрос InPolygon and InNetClass('Power')
Второй запрос All

Настройка зазора между объектами Polygon Pour и прочими объектами на слое Top Layer:

Первый запрос InPolygon
Второй запрос OnTopLayer

Настройка зазора между объектом Polygon Pour с именем PolyPower_VCC_1 и переходными отверстиями цепи GND:

Первый запрос InNamedPolygon('PolyPower_VCC_1')
Второй запрос InNet('GND') And IsVia

Трассировка

Чтобы всегда отображать линии соединения, включите параметр All Connections in Single Layer Mode в разделе Additional Options вкладки View Options панели View Configurations.

В процессе интерактивной трассировки, сегменты трассируемой цепи отображаются либо заштрихованными, либо пустыми. Все заштрихованные сегменты размещаются по щелчку мыши. Пустые сегменты называются упреждающими сегментами (Look Ahead). Они предназначены для того, чтобы вы могли планировать трассировку наперед, с учетом потенциального места размещения следующих сегментов без необходимости их фиксации.

Режим Look Ahead можно включать и отключать в процессе трассировки с помощью клавиши 1.

3D

Все операции по навигации в 3D осуществляются при зажатой правой кнопке мыши (ПКМ). Сама ПКМ служит для панорамирования, Ctrl+ПКМ – для изменения масштаба, Shift+ПКМ – для поворота.

Движение платы всегда осуществляется вокруг текущего положения курсора. Наведите курсор на нужное место перед использование какой-либо команды изменения вида.

Нажмите 0 (ноль), чтобы вернуть вид платы по умолчанию (сверху с нулевым углом поворота), или 9, чтобы изменить текущий вид на вид сверху под углом 90 градусов.

Используйте сочетание клавиш Ctrl+F, чтобы перевернуть плату и увидеть ее противоположную сторону.

Основным инструментом для навигации платы в режиме 3D является сфера, которая показана на изображении ниже. Зажмите клавишу Shift, чтобы отобразить сферу в текущем положении курсора. Затем, удерживая клавишу Shift, щелкните ПКМ, чтобы задействовать один из режимов поворота. Выбранный режим определяется тем, какой селектор движения был подсвечен при щелчке ПКМ. На изображении ниже видно, что подсвечена центральная точка, что означает, что при перемещении мыши плата будет вращаться вокруг сферы в любом направлении. Другими режимами являются вращение в плоскости экрана, вращение вокруг оси X и вращение вокруг оси Y. Наведите курсор на требуемый селектор движения перед щелчком ПКМ, чтобы выбрать соответствующий режим.


Shift с зажатой ПКМ для вращения платы вокруг сферы.

Другим способом использования сферы является использование 3D-мыши, такой как Space Navigator от 3Dconnexion, которая значительно упрощает процесс перемещения и поворота платы в режиме 3D-просмотра.

Опорных точек, доступных в импортированной 3D-модели, может быть не достаточно для позиционирования этого объекта в Altium NEXUS. Типичными опорными точками, которые проектировщик хочет использовать, являются центр отверстия и центр вывода.

Точки привязки можно добавить любой 3D-модели, независимо от ее типа: вытянутая модель, цилиндр, сфера, подключенная/встроенная модель (STEP, Parasolid, SOLIDWORKS) или объект 3D Model Item из сервера управляемых данных.

Процесс добавления точки привязки в центр окружности (отверстия) и в центр вывода одинаков:

  1. Выберите угол поворота и масштаб вида таким образом, чтобы можно было легко получить доступ к выводу или отверстию.
  2. Выберите команду Tools » 3D Body Placement » Add Snap Points from Vertices.
  3. Следя за строкой состояния Status Bar, наведите курсор на нужную целевую 3D-модель и щелкните мышью или нажмите Enter для выбора. Курсор перейдет в режим размещения в 3D-режиме (синий, шестиконечный).
  4. Теперь нажмите Пробел для перехода во второй режим команды, который служит для определения точки привязки по середине между двумя выбранными вершинами (что будет указано в строке состояния Status Bar).
  5. Наведите курсор на один край вывода или отверстия и щелкните мышью для выбора этой вершины.
  6. Наведите курсор на вторую вершину на противоположной стороне вывода или отверстия и щелкните мышью для выбора этой вершины.
  7. Точка привязки будет отображена в центре вывода или отверстия.

Выходные документы

Общее

Данные Altium NEXUS отображаются в BOM в формате Excel путем ввода записей Field=XXXX и Column=YYYY в шаблон Excel, используемого для формирования BOM. Например, Column=LibRef добавляет столбец со списком библиотечных ссылок всех компонентов, а Field=Title добавляет значение, заданное в параметре Title. Чтобы узнать больше, перейдите на страницу Добавление проектных данных в состав изделия в формате Excel.

Эта ошибка возникает, когда примитивы в документе платы не вписываются в область, указанную в настройках экспорта Gerber. Это может быть из-за того, что плата/панель слишком велика для этой области, либо если есть объекты за пределами платы, которые увеличивают область на большее ожидаемого значение.

Чтобы увеличить размер пленки:

  1. Выберите команду File » Fabrication Outputs » Gerber Files главного меню.
  2. В появившемся диалоговом окне Gerber Setup перейдите на вкладку Advanced.
  3. Введите подходящие значения X (horizontal) и Y (vertical) для размера пленки. Попробуйте сформировать файлы Gerbers заново.
  4. Если эти значения кажутся уже достаточно большими для платы, вернитесь в редактор плат и проверьте, есть ли объекты за пределами платы.

Поиск и удаление объектов за пределами платы:

Используйте команду View » Fit Document (сочетание клавиш Ctrl+Page Down). Если файл платы содержит объекты за пределами границ платы, размер экрана будет изменен таким образом, чтобы отобразить эти объекты. Если они находятся достаточно далеко, плата станет очень маленькой. Чтобы удалить эти объекты, выполните следующее:

  1. Снимите выделение всех объектов с помощью команды Edit » Deselect » All главного меню (последовательность клавиш X, A).
  2. Используйте команду Edit » Select » Outside Area главного меню (последовательность клавиш S, O) и проведите рамку вокруг всей платы.
  3. Теперь объекты за пределами платы будут выделены, и их можно удалить. Перед удалением может быть хорошо открыть панель PCB List (нажатием сочетание клавиш Shift+F12 или выбором команды View » Panels » PCB List) и проверить выделенные объекты. Щелкните ПКМ для выбора команды Remove Non-Selected, чтобы удалить невыделенные объекты из списка.

После удаления этих объектов, либо если вы вернули их на правильные места в пределах платы, сформируйте файлы Gerber заново. Ошибка не должна появиться вновь.

Таблица Drill Table обновляется автоматически в процессе формирования выходной документации. Также ее можно в любой момент обновить вручную щелчком по кнопке  в панели Properties, когда таблица выделена.

В Altium NEXUS 18.0 автоматическое обновление таблицы сверловки доступно с помощью настройки Advanced Setting, которая по умолчанию отключена. Обратите внимание, что включение автоматического обновления может привести к снижению производительности системы.

Документация по ГОСТ

Начиная с версии Altium NEXUS 19.0.12, обновленная версия этого модуля входит в состав офлайн-установщика Altium NEXUS. Для установки модуля GOST 2.701-2008/2.106-1996, перейдите в раздел Purchased страницы Extensions & Updates (узнать подробнее об управлении и установке дополнительных программных модулей: Расширение функциональных возможностей Altium NEXUS).


Установка, лицензирование и управление системой

Общее

Да, в Altium NEXUS есть возможность отправлять отчеты о сбоях разработчикам Altium в случае обнаружения ошибки в системе. Если появляется диалоговое окно ошибки/исключения, нажмите кнопку Send Report и добавьте описание действий, которые к этой ошибке привели. Чем более подробную информацию вы предоставите, тем более высоки шансы воспроизвести ошибку и устранить ее причину.

Обратите внимание, что если происходит сбой, но диалоговое окно исключения не появилось и система явно "зависла", используйте сочетание клавиш Ctrl+Alt+Insert, чтобы вызвать отчет о сбое принудительно. Диалоговое окно может появиться за окном приложения Altium NEXUS.

Установка

Хотя вы можете обновлять Altium NEXUS в рамках одной и той же номерной (мажорной) версии, обновиться с предыдущей номерной версии до более новой невозможно.

Поэтому если у вас установлен Altium NEXUS версии x.0.1, вы можете корректно обновиться до версии x.y.z, но не до версии x+1.y.z,

где:

  • x – текущая номерная версия;
  • x+1 – следующая номерная версия;
  • y – текущая минорная версия в рамках текущей мажорная версии;
  • z – текущее обновление в рамках текущей мажорная версии.

Поэтому есть два варианта действий, в зависимости от следующей версии системы, до которой вы хотите обновиться:

  • Обновление доступно в рамках одной и той же мажорной версии – вы можете обновить текущую версию или установить новую версию отдельно параллельно с текущей и использовать ту версию, которая наилучшим образом соответствует вашим потребностям в каждый момент времени.
  • Доступна следующая мажорная версия – вы можете продолжить использовать текущую версию или установить следующую версию для доступа к самым новым функциям. Либо вы можете установить обе версии и использовать ту версию, которая наилучшим образом соответствует вашим потребностям в каждый момент времени.
Установка различных версий позволяет быстро получать доступ непосредственно к предыдущей версии, в то время как обновление версии заменит текущую установленную копию системы более новой.
Для каждой версии системы существует отдельный установщик.

Существует два ключевых фактора, которые позволяют устанавливать множество версий системы:

  • Возможность задавать различные пути в процессе установки, как для папки Program Files, так и для папки Shared Documents.
  • Использование системой глобально-уникального идентификатора (Globally Unique Identifier – GUID) для каждой отдельной установки. Этот идентификатор, который использует стандартную 128-битную модель URN и отображен как 32-значное шестнадцатеричное число, используется для однозначного определения папок приложения, а также записей в реестре. При запуске той или иной установленной копии Altium NEXUS система работает только с файлами и записям реестра этой копии, используя идентификатор.

Для главных папок программы и общих документов вы можете задать осмысленные имена, что может быть очень полезно, если установлено множество версий системы. Но есть другие папки, которые можно отличить только по их идентификаторам GUID. Вы можете быстро определить GUID, перейдя в диалоговое окно Preferences открытой в данной момент версии системы и найти нужную папку через Проводник Windows.

Идентификатор GUID можно определить на следующих страницах диалогового окна Preferences (при стандартной установке Altium NEXUS по умолчанию):

Лицензирование

Нет, в этом состоит преимущество лицензии On-Demand – пользователю не нужно активировать лицензию. Нет процедуры активации и нет добавления файла лицензии вручную – для получения лицензии On-Demand необходимо только войти в свою учетную запись, и вам будут представлены все доступные лицензии.

Да, конечно. Altium NEXUS продолжает поддерживать использование лицензий типа Standalone. Лицензирование Standalone позволяет управлять использованием вашей лицензии через файл лицензии Standalone (*.alf). Этот файл можно сохранить, скопировать и создать его резервную копию, если необходимо. Файл .alf можно также использовать на домашнем компьютере (в соответствии с EULA), просто скопировав файл в определенную папку на этом компьютере и затем добавив файл в установленную копию системы на странице License Management (доступной по щелчку по кнопке  в верхней правой части приложения и выбору команды License Management меню).

При использовании лицензии Standalone вам необходимо входить в учетную запись Altium (через портал Altium) только в следующих случаях:

  • При первой активации лицензии.
  • При повторной активации лицензии (может понадобиться, например, если вы удалили лицензию и у вас нет резервной копии файла лицензии).
Администратор группы вашей учетной записи Altium может активировать лицензию Standalone непосредственно через веб-браузер с помощью Altium Dashboard. Это особенно полезно, если у рабочих мест по тем или иным причинам нет доступа в Интернет. Администратор, у которого есть доступ в Интернет, активирует эти лицензии и передает соответствующие файлы .alf пользователям на предприятии.

Да, возможно. Способ использования зависит от типа лицензии. При использовании лицензии On-Demand в режиме On-Demand просто освободите рабочее место лицензии, которую вы используете в офисе, перед тем, как уйти домой. Дома подключитесь к своей лицензии и освободите ее, когда закончите работу.

При использовании лицензии Standalone перенесите копию файла лицензии на свой домашний компьютер и продолжайте работу. Конечно, помните. что вы не можете запускать обе установки Altium NEXUS одновременно.

Вам необходимо быть подключенным к Интернету (войти в портал Altium) для использования лицензии On-Demand. Но это только один режим, в котором вы можете использовать лицензию On-Demand (режим On-Demand) – например, при использовании одной лицензии множеством пользователей, которые не используют Altium NEXUS все время. Чтобы использовать лицензию On-Demand в "офлайн"-режиме, т.е. без подключения к порталу, вы можете взять лицензию в роуминг (режим Roaming).

Касательно лицензии On-Demand, роуминг позволяет перейти в "офлайн"-режим – вы можете взять компьютер куда угодно, где есть подключение к Интернет или нет, и при этом остаться с лицензией. Подключаться к своей учетной записи будет необходимо, только если вы захотите вернуть лицензию раньше срока либо если понадобиться продлить период роуминга.

Максимальный период, на который вы можете заимствовать лицензию, равен времени действия самой лицензии On-Demand. В частности, это применимо ко временным лицензиям.

Если вы взяли лицензию On-Demand в роуминг и период роуминга истек, использование рабочего места лицензии будет приостановлено, без дополнительного времени.

Активацию лицензий Standalone и Private Server можно выполнить прямо через веб-браузер с помощью Altium Dashboard. Откройте Dashboard на компьютере, где не установлен Altium NEXUS. После получения нужных файлов лицензии (*.alf), вы можете перенести эти файлы на компьютер, не подключенный к сети, на котором установлен Altium NEXUS. Для получения более подробной информации см. Активация лицензии.

Обратите внимание, что только администраторы групп аккаунта Altium могут открывать и использовать Altium Dashboard.

Войдите в свою учетную запись – доступная вам лицензия Standalone будет отображена в области Available Licenses как больше не используемая. Чтобы снова взять ее использование, просто активируйте ее повторно с помощью опции Reactivate.

Либо, если вы являетесь администратором групп вашего аккаунта, вы можете активировать и загрузить файл лицензии через Altium Dashboard.

Портал Altium обеспечивает пользователям доступ к возможностям, надежно связанным с их учетными записями Altium. Лицензии On-Demand – это только одна из возможностей, работающих при подключении к порталу. Другими возможностями являются SUPPORTcenter и управление установкой. Все эти элементы доступны для использования через надежный (и уникальный) вход к порталу с помощью учетных данных Altium (AltiumLive).

Всё взаимодействие с серверами управления аккаунтами Altium через портал защищено благодаря https.

При использовании подключения Altium NEXUS к службам On-Demand, Altium может собирать следующую информацию:

  • MAC-адреса: Altium использует MAC-адрес компьютера для определения компьютера. Если вы входите со множества компьютеров, каждый вход будет уникальным образом записан.
  • Серийные номера HDD: Наряду с MAC-адресами, эта информация позволяет надежно определить компьютер в целях лицензирования.
  • Версия Altium NEXUS: Altium использует версию системы для различия продуктов, чтобы предоставлять корректные службы каждому из них.

Эта информация, наряду с учетными данными входа, позволяет серверу управления аккаунтами подтверждать корректное использование лицензии.

Altium не считывает и не собирает информацию о проектах и файлах, которые вы используете в Altium NEXUS. Все подключения к Порталу Altium через Altium NEXUS безопасны. Наряду с собранной информацией, информация, которую вы вводите, также будет передаваться в запросах на Портал Altium. Когда данные записываются с помощью Портала Altium, они будут содержать отметку времени, показывающую, когда они были записаны.

Если вы или ваше предприятие обеспокоены тем, что Altium знает об использовании вашей лицензии, вы можете брать лицензии в роуминг или использовать лицензии Standalone.

Вы не подключены к серверу постоянно. Altium NEXUS подключается к серверу управления аккаунтами через безопасный Портал Altium, делая запрос и получая ответ. После этого соединение закрывается. Осуществляется ряд запросов при входе, запрос для отображения доступных лицензий и т.п., но каждый запрос осуществляется независимо, после чего соединение закрывается.

При использовании лицензии On-Demand Altium NEXUS будет делать запросы через безопасный Портал Altium на сервер управления аккаунтами с определенной периодичностью для обновления лицензии и для проверки того, не отключена ли лицензия удаленно. Если по каким-либо причинам сервер управления аккаунтами не доступен, вы не потеряете лицензию и продолжите ее использование. Altium NEXUS будет регулярно пытаться восстановить подключение. Сначала Altium NEXUS будет делать это бесшумно – вы можете только заметить сообщения об ошибке в строке заголовка, которые пропадут после восстановления подключения. Если сервер управления аккаунтами не доступен в течение длительного периода (например, несколько часов), вы увидите информационные диалоговые окна с напоминаниями о необходимости восстановления Интернет-подключения к Порталу Altium. Вы все равно не потеряете свою лицензию.

Вы можете принудительно освободить рабочее место лицензии On-Demand, используемой как в режиме On-Demand, так и в режиме Roaming, непосредственно из Altium NEXUS. Например, если вы уходя домой забыли освободить рабочее место в офисе, вы можете освободить его с домашнего компьютера и использовать освободившееся рабочее место лицензии дома. Степень ваших полномочий здесь зависит от того, есть ли у вас административные права на лицензии:

  • Если у вас есть административные права, вы можете удаленно освободить любое используемое рабочее место. Используемое рабочее место будет освобождено, и пользователь потеряет лицензию.
  • Если административных прав нет, вы можете освободить только то рабочее место, которое используете вы (на другом компьютере). Рабочее место станет доступным для использования.
При принудительном освобождении лицензии, используемой на другом компьютере в режиме роуминга, вы должны будете пообещать, согласно Кодексу Чести Altium, что вы не будете использовать или позволять кому-либо использовать лицензию в роуминге после ее освобождения.
Администратор вашего аккаунта Altium также может принудительно освободить любое используемое рабочее место лицензии On-Demand через Altium Dashboard.

Если вы используете лицензию в режиме Roaming и она была освобождена удаленно, вы не получите никаких уведомлений до момента входа в учетную запись. Если вы используете лицензию в режиме On-Demand (либо подключены к учетной записи при использовании лицензии в режиме Roaming), то в в какой-то момент в течение следующих 20 минут появится диалоговое окно с предупреждением о том, что ваша лицензия была освобождена (с указанием того, кем именно), и вас попросят использовать другую лицензию для продолжения работы с Altium NEXUS. У вас будет 20 минут "дополнительного" времени использования лицензии, в течение которых нужно выбрать и использовать другую лицензию. По истечении этого периода появится второе диалоговое окно с предупреждением, и использование освобожденной лицензии прекратится. Обратите внимание, что если при использовании лицензии в режиме On-Demand вы вышли из учетной записи и вошли в нее вновь, что лицензия будет освобождена сразу, без дополнительного периода.

Все лицензии On-Demand имеют одно или множество рабочих мест, которые можно использовать одновременно. Пользователи могут брать лицензию в использование, пока есть ее свободные рабочие места. Следующие пользователи не смогут свободно использовать лицензию, но они могут использовать ее "сверх лимита". Система будет периодически проверять, появилось свободное рабочее место, и продолжит уведомлять пользователей о том, что они превысили лимит использования рабочих мест, пока не появится свободное рабочее место лицензии, которое затем будет взято в использование.

Каждая установленная копия Altium NEXUS будет использовать отдельное рабочее место лицензии On-Demand в режиме On-Demand.

Срок лицензий On-Demand не истечет. Если, по каким-либо причинам, происходят ошибки при фоновых проверках лицензии или обновления лицензии, вы можете продолжить использовать лицензию и сохранить свои наработки, но будете получать сообщения различного рода. Сообщение зависит от конкретной ситуации:

  • Если потеряно Интернет-соединение, в строке заголовка Altium NEXUS появится сообщение о том, что есть ошибка входа в учетную запись ("error signing in").
  • Если время вашего сеанса на портале по какой-либо причине истекло, может появится диалоговое окно входа в учетную запись.
  • В прочих ситуациях может появиться сообщение "The Altium portal was not able to renew your license. Altium NEXUS will retry shortly."

Время сеанса может истечь по нескольким причинам. Если в течение часа или более не был отправлен запрос на портал, время сеанса истекает. Сеанс также истекает примерно после 12 часов, независимо от предыдущей активности. Если портал перезагружается, когда вы подключены к учетной записи, это тоже регистрируется как истечение сеанса.

Вы можете увидеть использование лицензий на странице License Management в Altium NEXUS. Щелкните по знаку "+" слева от лицензии в таблице Available Licenses – будут показана подробная информация о том, кто использует рабочие места лицензии и в каком режиме.

Либо, если вы являетесь администратором аккаунта Altium, откройте страницу Reports в Altium Dashboard. На этой странице доступен ряд функций по отслеживанию использования лицензии и составлению отчетов для лицензий On-Demand. Эти отчеты можно использовать для проведения проверки того, как используются лицензии на вашем предприятии. Это полезно для обеспечения наилучшего использования доступных рабочих мест лицензий, прогнозирования будущих потребностей в лицензиях и определения использования лицензий отдельными пользователями.

Расширение функциональных возможностей Altium NEXUS

В Altium NEXUS управление дополнительными программными модулями осуществляется на специальной странице Extensions & Updates, которая открывается с помощью элемента управления  в верхней правой части рабочей области – выберите команду Extensions and Updates меню.

Открыть страницу Extensions & Updates также можно непосредственно со страницы License Management – щелкните Extensions and Updates под списком доступных лицензий.

Установочные файлы каждого модуля находятся в отдельной папке, названной в соответствии с этим модулем. Папку модулей можно найти по следующему пути: \ProgramData\Altium\Altium NEXUS <GUID>\Extensions. Кроме того, в корневой папке Extensions находится файл реестра ExtensionsRegistry.xml, который используется для отслеживания всех дополнительных программных модулей, установленных для этой копии Altium NEXUS.

Altium Dashboard

Только те, у кого есть права администратора (пользователи, состоящие в группе Group Administrators), имеют доступ к Dashboard и возможность просматривать и изменять аккаунт организации.

Пользователь является администратором аккаунта, если он добавлен в группу Group Administrators. Добавление может происходить двумя способами:

  • Если для аккаунта приобретается новая лицензия, то контакт для уведомлений (Notification Contact) этой лицензии автоматически добавляется в эту группу.
  • Пользователь может быть добавлен в группу вручную другим администратором аккаунта. Иными словами, участник группы Group Administrators может наделить другого пользователя административными правами, просто сделав его участником этой группы.

Загруженное изображение логотипа компании может быть 220x220 пикселей или меньше, в формате JPG или PNG.

Открыть профиль организации можно щелкнув по соответствующей ссылке на этот профиль на странице профиля ее любого пользователя. Ссылку на страницу профиля организации можно найти и в других областях сообщества AltiumLive, например, в посте форума или в отчете BugCrunch. Как правило, ссылка находится возле имени пользователя.

Чтобы сделать профиль организации приватным, т.е. скрытым от просмотра участниками сообщества AltiumLive, отключите параметр Public в области General Information на странице Profile в Dashboard.

Нового пользователя можно добавить в аккаунт только в том случае, если указываемый электронный адрес не используется существующим пользователем. Если вы пытаетесь создать новую учетную запись пользователя с дублирующимся электронным адресом, появится диалоговое окно, которое уведомит вас об этом.

Это осуществляется путем деактивации нужной учетной записи пользователя и ее повторной активацией. При активации будет сброшен пароль, и пользователю будет отправлено электронное сообщение, которое содержит новый временный пароль.

Пользователь может сбросить свой пароль вне Dashboard. Сделать это можно на странице входа в AltiumLive, щелкнув по ссылке Forgot Password. Пользователю будет отправлено электронное сообщение, которое содержит новый временный пароль.

Минимальная длина пароля – 8 символов. Пароль должен содержать только английские буквы, одну цифру, одну большую букву и одну маленькую букву. Пароль не может содержать пробелы.

Удаление нельзя отменить. Если вы удалили учетную запись пользователя по ошибке, вам необходимо добавить его тем же образом, как вы добавляете в аккаунт новые учетные записи пользователей.

Пользователя можно добавлять в любое число групп, определенных в аккаунте Altium.

Чтобы удалить пользователя из списка участников группы, снимите соответствующий флажок Member – при обновлении списка пользователь будет удален из него.

Нет, вы не можете ни добавлять, ни удалять лицензии из своего аккаунта через Dashboard. Вам необходимо связаться с отделом продаж Altium для приобретения лицензий для вашего аккаунта.

Это дата истечения подписки (Subscription) лицензии – дата, когда заканчивается право доступа к контенту и обновления программного обеспечения.

Лицензии типа On-Demand и Standalone можно назначать для использовании определенным группам в аккаунте. Это позволит вам точно управлять тем, у кого есть доступ к лицензиям и кто может их использовать. Для лицензий On-Demand со множеством рабочих мест вы можете назначать эти рабочие места одной или множеству групп. Это позволяет использовать глобальную плавающую лицензию, в соответствии с географической областью действия лицензии и условий EULA, без необходимости использования собственного сервера.

Для назначения лицензии через Dashboard вы можете перейти к определенной лицензии и назначить ее группам, либо вы можете перейти к определенной группе и назначить ей одну или множество лицензий. Это применимо только для лицензий типа On-Demand и Standalone.

Да. Просто найдите на странице нужную лицензию и нажмите кнопку Activate.

При активации лицензии Standalone вы можете активировать лицензию для любой поддерживаемой версии Altium NEXUS, но только для одной за раз. Для активации лицензии Private Server вам необходимо повторить процесс активации для каждой поддерживаемой версии Altium NEXUS, которые необходимо обслуживать этими лицензиями.


 

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Отлично! Знаете ли Вы, что мы предлагаем для студентов специальные скидки на лицензии? Для получения более подробной информации нажмите здесь.

А пока что Вы можете запросить пробную лицензию, заполнив форму ниже.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.