Guía de inicio rápido del analizador de potencia de Keysight

De un vistazo

Esta guía de inicio rápido presenta cómo Power Analyzer by Keysight le ayuda a evaluar la red de distribución de alimentación de CC de un diseño de PCB dentro de Altium Designer, para que pueda dejar de basarse en suposiciones y comprobar si los recorridos de cobre, los planos, las pistas y las vías pueden satisfacer las necesidades de alimentación de su diseño. Explica cómo se integra la extensión directamente con su proyecto actual, cómo instalarla e iniciarla, qué información de configuración se necesita antes de ejecutar un análisis y cómo empezar a definir y simular redes de alimentación. Si busca un punto de partida más claro para utilizar Power Analyzer by Keysight en su flujo de trabajo habitual, este artículo le muestra los pasos esenciales para comenzar. Siga leyendo para ganar confianza en el uso de la herramienta.

- Descubra qué hace Power Analyzer by Keysight en Altium Designer y cómo facilita el análisis de integridad de alimentación de CC utilizando los datos de diseño existentes de su proyecto.
- Conozca el flujo de trabajo básico para instalar la extensión, abrir el documento del analizador y preparar los ajustes de la placa y de las redes para la simulación.
- Comprenda los requisitos clave de preparación, como la sincronización entre el esquema y la PCB, las opciones de configuración, los requisitos de suscripción y la selección de redes de alimentación.
Profundiza con IA:

En los diseños digitales modernos, que incorporan circuitos de alta velocidad, placas con alta densidad de componentes y múltiples líneas de alimentación de baja tensión, las exigencias impuestas a la red de distribución de alimentación de CC requieren un enfoque analítico para su diseño. El análisis de CC de una red de distribución de alimentación, o los resultados de su análisis de integridad de alimentación de CC (PI-DC), tiene como objetivo garantizar que se haya dispuesto suficiente cobre en el recorrido desde las fuentes de tensión hasta las cargas; en otras palabras, que los planos, las pistas y las vías de la placa tengan el tamaño (y las características) suficientes para satisfacer los requisitos de consumo de los dispositivos de la placa.

Afortunadamente, es posible eliminar las conjeturas de la evaluación de la red de distribución de alimentación de una PCB mediante una herramienta de simulación de integridad de alimentación de CC (PI-DC) que analiza el comportamiento en CC del diseño de una placa a partir de sus propiedades eléctricas y físicas. Altium Designer dispone de una herramienta de este tipo: el Power Analyzer by Keysight.

Disponible como una extensión de Altium descargable, Power Analyzer se integra directamente con Altium Designer para permitir la simulación y el análisis PI-DC del proyecto de PCB actual. Como Power Analyzer funciona dentro de Altium Designer, no es necesario importar o exportar datos manualmente, convertir datos ni ejecutar aplicaciones independientes: inicie Power Analyzer desde el editor de esquemas o de PCB, establezca los parámetros de prueba deseados y ejecute la simulación. Los resultados se presentan principalmente mediante el modelado 2D/3D de la distribución del cobre de la placa de circuito, lo que permite evaluarlos rápidamente y realizar pruebas exploratorias de tipo «qué pasaría si» sobre el diseño de la PCB.

Acceso a las funciones de Power Analyzer by Keysight

Para acceder a las funciones de Power Analyzer by Keysight en Altium Designer, debe estar instalada la extensión de software Power Analyzer by Keysight . Esta extensión se puede instalar o eliminar manualmente.

Para obtener más información sobre la gestión de extensiones, consulte la página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Al hacer clic para descargar e instalar la extensión, se abre End-User License Agreement (). Al hacer clic en Accept, indica que acepta los términos y condiciones del EULA; al hacerlo, la instalación continuará. Al hacer clic en Close, indica que no acepta los términos y condiciones del EULA, y el proceso de instalación se detendrá.

Cuando la extensión de software Power Analyzer by Keysight está instalada, permite:

 
 
 
 
 
  • añadir un nuevo documento de análisis de alimentación o abrir uno existente; 

  • Button, Manage Power Nets configurar Power Analyzer y las redes de alimentación; 

  • Button, Show Power Net in Tree examinar la estructura de árbol de las redes;

  • Button, Show the Power Net Analysis on the PCB examinar los resultados de análisis de alimentación existentes;

  • Button, View the Power Net Analysis results as a Report ver los informes existentes y generar nuevos informes a partir de los resultados de análisis de alimentación existentes.

Sin embargo, para realizar un nuevo análisis de alimentación, necesita una suscripción vigente a Power Analyzer by Keysight. De lo contrario, al intentar iniciar un análisis de alimentación, se abrirá el cuadro de diálogo Analyze Your Power Nets, donde podrá solicitar una prueba gratuita ().

Inicio de Power Analyzer

Para empezar a trabajar con Power Analyzer, abra el documento de PCB del proyecto o uno de sus esquemas y seleccione Tools » Power Analyzer by Keysight en los menús principales.

El documento de Power Analyzer Keysight (<ProjectName>.pdnaK) se abrirá y se añadirá al área Source Documents del proyecto (en el panel Projects), como se muestra a continuación.

¿No aparece el comando Power Analyzer by Keysight en el menú? Compruebe que la extensión esté instalada y que tenga una suscripción a ella (más información).

Power Analyzer se puede iniciar desde los menús del editor de esquemas o del editor de PCB. Sin embargo, como Power Analyzer simula las estructuras de la PCB, cualquier cambio de diseño realizado en el esquema debe sincronizarse con la PCB antes de que pueda detectarse desde el documento del analizador (*.pdnaK). Si no se ha detectado un cambio de diseño, guarde, cierre y vuelva a abrir el documento del analizador.

Preparación para el análisis

¿Está listo para realizar un análisis, pero al hacer clic en el botón Analyze se abre un cuadro de diálogo que ofrece acceso a una versión de prueba? Compruebe que la extensión esté instalada y que disponga de una suscripción para ella (más información).

Power Analyzer necesita conocer las propiedades físicas de su placa. Estas incluyen las densidades de corriente máximas para las capas superficiales e internas, los diámetros mínimo y máximo de las vías, el tipo de cobre, la temperatura de trabajo y otros datos. Estas propiedades se definen en la región Configuration del documento del analizador.

Opciones de configuración

  • Los valores de densidad de corriente máxima y corriente máxima en las vías son los mismos para todas las redes, ya que dependen de la geometría del cobre.

  • Los ajustes de Max Current Density for Surface / Internal Layers especifican el valor admisible para las capas correspondientes de la PCB.

  • La corriente máxima en las vías se especifica para los tamaños mínimo y máximo de los orificios utilizados en el proyecto. Los valores del diámetro de los orificios se definen en los campos Min Via Diameter y Max Via Diameter, junto con el valor de Max Current permitido para ese tamaño de orificio.

  • El software divide el diseño de la PCB en mallas durante el proceso de simulación. De forma predeterminada, se utiliza un tamaño de malla dinámico. Al activar la casilla Simulation Mesh Size, puede definir el tamaño de malla necesario.

  • La configuración predeterminada excluye la red de tierra de los resultados del mapa de calor. Para incluir la red de tierra, desactive la casilla Skip Ground y, a continuación, seleccione la red GND en la lista desplegable Network / Net de la parte superior del panel Power Analysis by Keysight para explorar los resultados del mapa de calor. Tenga en cuenta que el mapa de calor admite estructuras poligonales en las capas de señal, pero no se puede simular el comportamiento de una capa de plano de alimentación.

  • El campo Copper Type especifica el tipo de cobre utilizado, junto con sus parámetros asociados y los parámetros de temperatura. 

  • El Work Temperature se utiliza para determinar la resistividad de los conductores, y el Temperature Compensation es una característica del propio material relacionada con su conductividad térmica. Los distintos materiales tienen diferentes coeficientes de conductividad térmica y, por tanto, afectan al calentamiento del material en función de la carga. Este calentamiento afectará a la resistencia interna del material, lo que a su vez afectará a la caída de tensión.

  • El Via Plating Thickness que se muestra en la región Global PCB Parameters se define en el panel Properties del administrador de apilado de capas: más información.

Modifique estos valores predeterminados según sea necesario para adaptarlos a su diseño.

Además de la densidad de corriente máxima y la corriente máxima en las vías, se debe especificar el valor de caída de tensión admisible para cada red de alimentación definida. Configure el DC Drop Limit de cada red, seleccionando un porcentaje predefinido o introduciendo un valor Custom.

Power Analyzer utiliza los Auto-Define Settings al intentar definir automáticamente las redes de alimentación de su diseño. Para ello, necesita saber cómo identificar elementos del circuito, como reguladores de tensión, conectores y componentes en serie. Además de utilizar indicios como los prefijos de los designadores de componentes, también puede añadir parámetros a determinados componentes para mejorar el proceso de detección automática. Para obtener más información, consulte la sección Requisitos de reconocimiento automático.

Añadir una red de alimentación para la simulación

Para añadir una red de alimentación para la simulación, haga clic en el botón  de la esquina superior izquierda para abrir el cuadro de diálogo Manage Nets. Active la casilla del Power Net Name requerido y configure el Reference Net correspondiente. Si una red no tiene un objeto de puerto de alimentación en el diseño esquemático, no aparecerá en la lista Power Net Name. Haga clic en Show Custom Nets para incluir todas las redes del diseño. Si es necesario, se pueden habilitar varias redes de alimentación. Las relaciones jerárquicas entre las redes de alimentación se resuelven automáticamente una vez que la red de alimentación está completamente configurada.

Cada red de alimentación requiere una fuente de alimentación; estas se configurarán a continuación.

También puede hacer clic en el botón  para que el software cree las redes de alimentación por usted. Para ello, intenta reconocer automáticamente la topología del proyecto basándose en los ajustes actuales de la región Auto-Define Settings de la sección Configuration del documento del analizador (*.pdnaK).

Añadir una fuente de alimentación

Para añadir una fuente de alimentación, haga clic en + (o en el control Administrar asociado) en la sección Sources del circuito de alimentación deseado. Si el circuito incluye más de una fuente de alimentación, haga clic en Administrar y seleccione los componentes restantes.

Para que un componente esté disponible como fuente, debe estar conectado al Power Net seleccionado, pero puede conectarse al Reference Net seleccionado a través de cualquier componente que esté conectado a ese Reference Net.

La tarjeta del componente

Cada componente incluido como fuente o carga se representa en el documento de Power Analyzer mediante una Component Card.

  • Pase el cursor sobre la tarjeta del componente para mostrar los botones Edit y Delete.
  • Haga doble clic en la tarjeta del componente para abrir el cuadro de diálogo Properties de ese componente.
  • Haga clic en el valor ID del elemento de diseño para localizar ese componente en el esquema mediante navegación cruzada. El nivel de zoom de la navegación cruzada se define en la sección Highlight Methods de la página System - Navigation del cuadro de diálogo Preferences.
  • Edite el valor principal de análisis de ese componente directamente en la tarjeta (o edite el componente para acceder a todas sus propiedades).

Extender una red

Las redes de alimentación de la placa pueden pasar a través de elementos pasivos, como fusibles o resistencias, que tendrán una red diferente al otro lado de ese componente. En esta situación, se recomienda extend the net incluyendo un componente intermedio y su segunda red como parte de la red principal. Para ello se utiliza la función Extend Nets.

Para extender una red, haga clic en el icono +Extender redes junto a su nombre para abrir el cuadro de diálogo <PowerNet> Extensions Manager. Haga clic en + para extender la red de destino. Power Analyzer solo muestra las redes que pueden conectarse a través de un único componente de extensión. Una vez que Add la red, se añadirá automáticamente un componente asociado en el cuadro de diálogo <PowerNet> Extensions Manager, que podrá cambiar si lo desea.

Las redes de alimentación pueden extenderse a través de un componente en serie.Las redes de alimentación pueden extenderse a través de un componente en serie.

A continuación, puede seguir extendiendo la red haciendo clic en el símbolo + , como se muestra en la siguiente imagen. Cuando termine, haga clic en Guardar en el cuadro de diálogo <PowerNet> Extensions Manager.

Siga añadiendo componentes en serie y redes.Siga añadiendo componentes en serie y redes.

Notas sobre la extensión de una red

  • Para cada componente en serie, puede definir su caída de tensión, resistencia y corriente máxima admisible, que se tendrán en cuenta durante el análisis (mostrar imagen).

  • Si define una red incorrecta, puede eliminarla pasando el cursor sobre su nombre y haciendo clic en el icono de eliminación que aparece.

  • Una vez guardada la red extendida, los componentes conectados a las redes extendidas aparecerán en la lista de cargas y podrá añadirlos.

  • Junto al nombre de la red de alimentación, puede ver el número de extensiones añadidas. Pase el cursor sobre el número para mostrar los nombres de las redes de extensión (como se muestra en la imagen anterior).

  • La compatibilidad de simulación con componentes en paralelo en una red extendida se añadió en la versión V1.0.6 de la extensión PABK, y la compatibilidad en la interfaz de usuario se añadió en la versión V1.0.9. Para definir componentes en paralelo, seleccione la red en el cuadro de diálogo emergente Extensions Manager y, a continuación, habilite todos los componentes en paralelo, como se muestra en la siguiente imagen. Pase el cursor sobre la imagen para mostrar el cuadro de diálogo una vez completada la extensión de la red.

    Seleccione todos los componentes en paralelo de la red.Seleccione todos los componentes en paralelo de la red.

Especificación de una carga

Para añadir un componente de carga, haga clic en + (o en el control Gestionar asociado) en la sección Loads y, a continuación, seleccione el componente deseado. Un componente aparece en la lista del cuadro de diálogo cuando está conectado a la red principal o a una red extendida.

Después de añadir un componente, puede especificar su consumo directamente en su tarjeta de componente o haciendo clic en el botón  para abrir el cuadro de diálogo <NetName>/<LoadName> Load Properties.

Notas sobre la configuración de una carga

  • Defina las propiedades de la carga, incluidos Load Type, Total Load Current, Min y Max Voltage.
  • Confirme que la red de alimentación IN esté configurada correctamente, así como las opciones Reference y Connected to reference through.
  • La corriente de carga se reparte automáticamente por igual entre todos los pines de alimentación identificados; modifique estos valores si es necesario.
  • Al configurar una carga del tipo IC (Current) , puede ver todos los pines del componente de carga que lo conectan con la fuente a través de distintos componentes en serie, con la posibilidad de seleccionar los pines necesarios.

Cuando el cuadro de diálogo Manage Loads (o Add Sources) está abierto, incluye una columna Design Item Id. Haga clic en una entrada de esta columna para localizar el componente correspondiente en el esquema mediante la función de localización cruzada, lo que facilita comprobar que está seleccionando el componente correcto.

El nivel de zoom de la localización cruzada se define en la sección Highlight Methods de la página System - Navigation del cuadro de diálogo Preferences.

Especificación de un VRM

Para definir un componente como módulo regulador de tensión (VRM), añádalo primero como carga. A continuación, abra el cuadro de diálogo Load Properties del componente (haga clic en el botón  ) para configurarlo.

Una vez configurada una carga como VRM, también aparecerá como fuente de la red de alimentación especificada como su red OUT.Una vez configurada una carga como VRM, también aparecerá como fuente de la red de alimentación especificada como su red OUT.

Notas sobre la configuración de un VRM

  • Especifique Load Type como el VRM del tipo deseado.
  • Especifique la tensión de salida en el campo Vout, junto con las demás propiedades del regulador.
  • Configure las redes IN y OUT en la sección Nets Management del cuadro de diálogo.
  • Si el VRM no se conecta directamente a la red de referencia o utiliza una referencia distinta, configure las opciones Reference y Connected to reference through según sea necesario.
  • Se crea automáticamente una red de alimentación secundaria en la jerarquía con ese VRM como fuente (como se muestra arriba).
  • Si el VRM tiene más de una red de salida, añada todas las redes necesarias mediante el enlace +Añadir red de salida del cuadro de diálogo Load Properties y especifique su corriente de salida en los campos correspondientes que aparecen.

La red de alimentación configurada

Cada red de alimentación configurada se presenta como una definición desplegable independiente en el documento *.pdnaK. A continuación se muestra la red PWR_IN configurada, con sus dos redes de alimentación secundarias, 3V3 y 1V8, ligeramente sangradas para indicar su condición de redes secundarias.

Descripción de la definición de la red de alimentación

  • Cada red de alimentación se presenta como un Power Net Definition desplegable independiente.
  • El encabezado de la definición de la red de alimentación incluye:
    • El nombre de la red de alimentación 
    • La red de referencia 
    • Un indicador que muestra el número de redes adicionales (), si la red se ha extendido. Pase el cursor sobre él para mostrar los nombres de las redes secundarias.
    • Un botón  ; haga clic en él para mostrar la estructura de conexión de los componentes de esta red en el contexto de toda la jerarquía de redes de alimentación.
    • Un botón  ; haga clic en él para eliminar esta red del proceso de análisis, junto con todas las redes secundarias.
    • Un botón  ; haga clic en él para analizar esta red, junto con las redes secundarias.
  • Cada componente de la red está representado por una tarjeta de componente.
  • Una vez analizada la red, los resultados de Voltage Drop, Current Density y Max Via Current de esa red se muestran en la definición de la red de alimentación, como se muestra en la imagen anterior.
    • Cada indicador muestra el valor simulado con respecto al límite especificado. Si el valor está completamente dentro del límite, la línea de la escala es verde. Si está cerca del límite, la línea es amarilla y, si se supera el límite, es roja. 
    • Haga clic en el botón  para cambiar la vista al editor de PCB y mostrar el cobre de esta red en la PCB. En el editor de PCB, utilice el panel Power Analyzer by Keysight para controlar el proceso de análisis.
    • Haga clic en el botón  para generar y abrir un informe detallado sobre esa red de alimentación. Dentro del informe, utilice  botón para guardar una copia en HTML.

La vista de árbol de las redes de alimentación

Cambie a una vista en forma de árbol de la red de alimentación configurada (y de las subredes definidas mediante VRM) haciendo clic en el botón  correspondiente. Se mostrará toda la estructura, con la red de alimentación específica y sus componentes asociados resaltados.

La vista de árbol permite comprobar rápidamente si se ha definido toda la red de alimentación según lo requerido y si está lista para el análisis. Para volver a la ventana principal, haga clic en el enlace Power Analyzer by Keysight de la esquina superior izquierda del documento .pdnaK.

Ejecutar un análisis

Una vez completada la configuración, puede ejecutar un análisis de una red específica haciendo clic en el botón  correspondiente. Se presenta un resumen de los resultados del análisis en la definición de la red de alimentación, como se muestra a continuación. Para ver los resultados en la PCB, haga clic en el botón  correspondiente.

Para analizar todas las redes configuradas en una sola acción, haga clic en el botón  (en la parte superior derecha del documento del analizador). Si elige analizar la red de alimentación de nivel superior de la estructura de árbol, también se analizarán todas las subredes (creadas mediante componentes VRM). Si se han analizado todas las redes, puede seleccionar qué red se resalta mediante el menú desplegable Network/Net situado en la parte superior del panel Power Analyzer by Keysight. 

Gestión de capas

Puede cambiar entre las capas de la simulación del mismo modo que al trabajar con una PCB: mediante las pestañas de capas situadas en la parte inferior de la ventana del editor de PCB. También puede centrarse en la capa actual con el atajo Shift+S; utilice este atajo para recorrer las opciones de visibilidad del modo de una sola capa.

Utilice las pestañas de capas de la PCB para cambiar rápidamente la visualización de los resultados del análisis. Aquí se muestran los resultados de la capa superior. Pase el cursor sobre la imagen para ver los de la capa inferior.Utilice las pestañas de capas de la PCB para cambiar rápidamente la visualización de los resultados del análisis. Aquí se muestran los resultados de la capa superior. Pase el cursor sobre la imagen para ver los de la capa inferior.

El panel Power Analyzer by Keysight

En el editor de PCB, el proceso de análisis y los resultados se controlan mediante el panel Power Analyzer by Keysight. Tenga en cuenta que el panel se añade a la lista de paneles disponibles (mediante el botón Panels) después de realizar un análisis de alimentación y hacer clic en el botón  .  

Red de alimentación / Red

  • Network / Net - se utiliza para seleccionar la red de alimentación () o la red () que desea mostrar como mapa de calor en el área de trabajo gráfica.
  • Only nets with violations - cuando esta opción está activada (de forma predeterminada), solo están disponibles en el menú desplegable las redes que presentan alguna infracción. Desactive esta opción para mostrar todas las redes de alimentación. 
  • Utilice las técnicas habituales del editor de PCB para desplazarse y aplicar zoom en el área de trabajo y examinar los resultados de la simulación.

Debajo del selector Network / Net, el panel tiene dos pestañas: General y Heatmap. Las opciones de estas pestañas se aplican a la red seleccionada en el menú desplegable Network / Net.

Seleccione la red que desea visualizar y, a continuación, configure las opciones generales o del mapa de calor de esa red.Seleccione la red que desea visualizar y, a continuación, configure las opciones generales o del mapa de calor de esa red.

Mapa de calor

La pestaña Heatmap del panel Power Analyzer by Keysight se utiliza para controlar qué datos se presentan como mapa de calor, ya sea la densidad de corriente o la caída de tensión, y cómo se aplica el color a la densidad de corriente o a la caída de tensión.

Utilice la pestaña Heatmap  del panel Power Analyzer by Keysight para cambiar los resultados de simulación que se presentan en la PCB. Aquí se muestran los resultados de densidad de corriente. Pase el cursor sobre la imagen para ver los resultados de caída de tensión.Utilice la pestaña Heatmap del panel Power Analyzer by Keysight para cambiar los resultados de simulación que se presentan en la PCB. Aquí se muestran los resultados de densidad de corriente. Pase el cursor sobre la imagen para ver los resultados de caída de tensión.

Las opciones de cada uno de estos modos se describen a continuación.

Mapa de calor de densidad de corriente
  • Toda la red se colorea para reflejar la densidad de corriente en cada punto de su recorrido: cuanto mayor sea la densidad de corriente, más cálido (más rojo) será el color. 
  • Show Heatmap - utilice este control para quitar rápidamente el mapa de calor y restablecer la visualización habitual de la PCB. 
  • Show Arrows of Current Direction - active esta opción para mostrar pequeñas flechas que indican el sentido del flujo de corriente en toda la red.
  • Use Noise Suppression - A medida que la corriente calculada se aproxima a cero, las flechas de dirección de corriente dan la impresión de que circula corriente por esa zona, cuando prácticamente no hay ninguna. Active esta opción para excluir estos valores de corriente más bajos que pueden resultar engañosos.
  • Scope Controller - la forma en que se aplica el color a la red para mostrar la intensidad, o el calor, se controla mediante Scope Controller. El valor de Max corresponde de forma predeterminada a la densidad de corriente máxima calculada en esa red (mostrar imagen), y el de Min es, de forma predeterminada, 0 A/mm2. Esta escala se muestra como una barra de colores debajo de la PCB y refleja los ajustes mínimo y máximo actuales, una escala determinada por el tipo de escala seleccionado y las unidades. Los valores de Min y Max se pueden ajustar haciendo clic y arrastrando el control deslizante, o introduciendo un nuevo valor en los campos Min o Max. Los valores calculados inferiores a Min se muestran en azul, y los superiores a Max se muestran en rojo. 
  • Use Logarithmic Scale - active esta opción para cambiar la escala de lineal a logarítmica. Una escala logarítmica concentra los valores más altos hacia el extremo hot de la escala de colores. Por ejemplo, puede activar la escala logarítmica para localizar rápidamente los tramos de trazado por los que circulan corrientes más altas y, a continuación, cambiar a la escala lineal para examinar la distribución de las densidades de corriente dentro de ese tramo.

El mapa de calor logarítmico de densidad de corriente muestra una zona que requiere atención; pase el cursor sobre la imagen para ver esa zona representada con la escala lineal.El mapa de calor logarítmico de densidad de corriente muestra una zona que requiere atención; pase el cursor sobre la imagen para ver esa zona representada con la escala lineal.

Mapa de calor de caída de tensión
  • Toda la red se colorea para reflejar la caída de tensión en cada punto de su recorrido: cuanto mayor es la tensión, más cálido (más rojo) es el color. Con este enfoque, cuanto más frío es el color, menor es la tensión (y mayor es la caída de tensión). 
  • Show Heatmap - utilice este control para quitar rápidamente el mapa de calor y restaurar la visualización estándar de la PCB. 
  • Show Arrows of Current Direction - active esta opción para mostrar pequeñas flechas que indican la dirección del flujo de corriente en toda la red.
  • Use Noise Suppression - A medida que la corriente calculada se aproxima a cero, las flechas de dirección de corriente dan la impresión de que circula corriente por esa zona, cuando en realidad es prácticamente nula. Active esta opción para excluir estos valores de corriente más bajos que pueden resultar engañosos.
  • Scope Controller - la forma en que se aplica el color a la red para mostrar la intensidad, o el calor, se controla mediante Scope Controller. El valor de Max se establece de forma predeterminada justo por debajo de la tensión máxima especificada para esa red, y el valor de Min es Max - calculated voltage drop (ver imagen). Esta escala se muestra como una barra de colores debajo de la PCB e indica la caída de tensión como valor absoluto o porcentaje, los ajustes actuales de mínimo y máximo, y las unidades. Los valores de Min y Max se pueden ajustar haciendo clic y arrastrando los controles deslizantes, o introduciendo un nuevo valor en los campos Min o Max. Los valores calculados inferiores a Min se muestran en azul, y los superiores a Max se muestran en rojo. 
  • Scale Type - la escala de caída de tensión se puede expresar en voltios (haga clic en el botón  ) o como porcentaje (haga clic en el botón  ).
  • Enable Visual Slider for Voltage Contour - cuando está activada, muestra las ubicaciones del mapa de calor donde la tensión es igual a los puntos de contorno de tensión especificados, lo que permite identificarlas fácilmente. Los valores de los puntos de contorno se pueden ajustar arrastrando los controles deslizantes o introduciendo valores en los campos Voltage Contour Points situados debajo. Se pueden añadir puntos y eliminar los existentes haciendo clic en el icono correspondiente.

Los puntos de contorno se pueden configurar para identificar rápidamente las ubicaciones de la placa donde la tensión tiene ese valor.Los puntos de contorno se pueden configurar para identificar rápidamente las ubicaciones de la placa donde la tensión tiene ese valor.

Detección de infracciones

Si la simulación detecta una infracción de tipo Voltage Drop, Current Density o Max Via Current, se muestra en la sección Violations del panel Power Analyzer by Keysight. Haga clic en una infracción del panel para localizar mediante sondeo cruzado el punto específico de la PCB donde se produjo el error. Si no puede leer toda la descripción de la infracción, sitúe el cursor sobre la sección Descripción de la infracción para mostrar una información emergente con todos los detalles.

Las infracciones se detallan automáticamente en la sección Violations del panel Power Analyzer by Keysight. Sitúe el cursor sobre la imagen para mostrar una infracción de corriente en una vía.Las infracciones se detallan automáticamente en la sección Violations del panel Power Analyzer by Keysight. Sitúe el cursor sobre la imagen para mostrar una infracción de corriente en una vía.

Tenga en cuenta que el modo de mapa de calor (densidad de corriente o caída de tensión) se selecciona automáticamente en función del tipo de infracción en el que haga clic. 

Sondas

La sección Sondas del panel Power Analyzer by Keysight se utiliza para colocar sondas de medición directamente en la PCB. Las sondas pueden medir la densidad de corriente o la caída de tensión; el tipo de medición viene determinado por el modo de mapa de calor actual de la placa.

Las sondas pueden ser:

  1. Una sonda individual, para medir un valor absoluto en la ubicación de la sonda, o
  2. Una sonda diferencial, para medir la diferencia entre las dos ubicaciones de la sonda. 

Ambos tipos de sondas se colocan haciendo clic en el botón  de la región Probes del panel. Para colocar una sonda individual, haga clic en la ubicación deseada y, a continuación, haga clic con el botón derecho del ratón (o pulse Esc). Para colocar una sonda diferencial, haga clic una vez para definir la primera ubicación de la sonda y, después, haga clic una segunda vez para definir la segunda ubicación. Una vez definida una sonda, los resultados de la medición se mostrarán en el panel.

Al colocar una sonda, se aplican las mismas funciones de ajuste que al colocar otros objetos de diseño en el editor de PCB. Para obtener más información sobre el sistema unificado de ajuste del cursor, consulte la página Trabajo con el sistema de ajuste del cursor.

Haga clic en el botón  para crear una imagen de la PCB en la ubicación de la última sonda en la que se haya hecho clic. La imagen se mostrará en la región Image Captures del panel, identificada con una insignia Probe. Sitúe el cursor sobre la captura de pantalla para mostrar los detalles de la sonda (ver imagen). 

Las sondas pueden medir tensión o corriente, ya sea como valor absoluto o como diferencia entre dos ubicaciones. Sitúe el cursor sobre la imagen para mostrar una sonda de corriente.Las sondas pueden medir tensión o corriente, ya sea como valor absoluto o como diferencia entre dos ubicaciones. Sitúe el cursor sobre la imagen para mostrar una sonda de corriente.

Si se realiza cualquier cambio en el diseño, se deben borrar las sondas existentes () y colocar otras nuevas.

Capturas de imagen

La función de captura de imágenes del panel Power Analyzer by Keysight permite obtener una captura de pantalla específica del diseño de la red seleccionada, que posteriormente se puede incluir en un informe.

Para obtener una imagen de una zona específica de la placa, primero ajuste la vista de la placa en el espacio de diseño principal para que los elementos que desea incluir en la captura estén visibles. Cuando esté listo, haga clic en el botón   de la región Image Captures del panel para realizar la captura de pantalla. Puede seguir cambiando la vista de la placa y Add más imágenes. Para eliminar una imagen, sitúe el cursor sobre ella para mostrar el botón  y, a continuación, haga clic una vez para eliminarla.

Las capturas de imagen no se conservan con el proyecto. Para guardar las imágenes, genere un informe de análisis.

Informe de análisis

Para generar un informe de análisis completo, haga clic en el botón  situado en la parte superior del documento del analizador. El informe completo incluye una sección para cada red de alimentación del sistema, como se muestra en la siguiente imagen. 

Dentro del informe, haga clic en una red de alimentación para ver un informe detallado de ella, que incluye:

  • Ajustes de configuración global
  • Apilado de capas de la placa
  • Mapas de calor de densidad de corriente para cada capa de señal
  • Mapas de calor de caída de tensión para cada capa de señal
  • La vista de árbol del sistema de alimentación, con la red elegida resaltada.
  • Detalles del análisis de la red elegida, que incluyen: consumo de potencia; detalles de los márgenes y resultados de aprobado/no aprobado; un resumen detallado del comportamiento de todas las vías de esa red; todas las capturas de pantalla definidas por el usuario.

  • Haga clic en el botón  para guardar el informe en formato HTML. Utilice el cuadro de diálogo Save Report Settings que aparece a continuación para configurar qué redes y datos específicos se incluirán en el informe.
  • El informe se almacena en una subcarpeta de la carpeta del proyecto, denominada \PowerAnalyzerByKeysight_Output\HTMLReport\<ProjectName> [PDNA]_<CurrentDate>_<CurrentTime>.
  • Todas las imágenes del informe se almacenan en una subcarpeta \Images.
  • Durante el análisis también se generan varios archivos de registro, que se almacenan en una subcarpeta de la carpeta del proyecto, denominada \PowerAnalyzerByKeysight_Output\<BoardName>\.

Requisitos para el reconocimiento automático

Además de añadir redes de alimentación manualmente, Power Analyzer by Keysight permite reconocer y añadir redes de alimentación automáticamente, incluidas las fuentes y las cargas, lo que reduce el tiempo necesario para definir una estructura de alimentación.

Configuración de la definición automática

Antes de iniciar el reconocimiento automático, debe configurar los parámetros del algoritmo para adaptarlos a su proyecto. Estos parámetros se configuran en el apartado Auto-Define Settings de la sección Configuration de la ventana del documento de Power Analyzer by Keysight.

Los componentes que no cumplan estos criterios de definición automática se tratarán como cargas normales. También puede añadir parámetros con nombre a componentes individuales del esquema para definir su tipo y sus propiedades dentro del sistema de alimentación. Estos parámetros pueden especificarse al crear el componente o añadirse posteriormente en el esquema.

Parámetro para componentes

Para que se reconozcan correctamente, todos los componentes relacionados con la alimentación deben cumplir los siguientes criterios:

  • Para detectar automáticamente un componente de fuente, este debe tener un parámetro denominado Component Type, con el valor Source.

  • Si no se encuentra el parámetro, la búsqueda se basará en Default Connectors Designators, que se definen en el área Auto-Define Settings de la sección Configuration del documento del analizador (*.pdnaK). Tenga en cuenta que solo se definirán los conectores con conexiones de alimentación, a menos que se haga referencia a ellos como parte de una red extendida.
  • Módulos reguladores de tensión (VRM):
    • Los reguladores lineales deben tener un parámetro denominado Component Type, con el valor VRM.
    • Para un regulador VRM de tipo SMPS, el parámetro Component Type debe tener el valor SMPS.
    • Si el VRM incluye una función de detección de tensión, el parámetro Component Type debe tener el valor Sense.

  • Si el parámetro no está definido, la búsqueda se basará en VRM Keywords, definidos en el área Auto-Define Settings de la sección Configuration del documento del analizador. De forma predeterminada, estas palabras clave son: PWR, REG, Regulator, Voltage, Switch.

  • El valor de consumo del componente (carga) debe definirse mediante un parámetro denominado Current Consumption. Preste atención al símbolo de separador decimal utilizado en el valor: puede ser . o , según las preferencias del sistema.

Si un componente tiene el parámetro Current Consumption, el valor especificado se divide entre todos los pines conectados al mismo circuito.

Sincronización de parámetros

Todos los parámetros deben estar sincronizados entre la PCB y el esquema. Para comprobarlo, seleccione un componente en la PCB y confirme que los parámetros de análisis de alimentación aparecen en la pestaña Parameters del panel Properties.

Para el diseño

  • Todas las redes de alimentación deben definirse:
    • mediante un objeto Power Port,
    • con la propiedad Power Net configurada de modo que la red incluya Supply Net Parameter (como se describe a continuación),
    • o con un nombre que pueda ser detectado por Name Mask (definido en el área Auto-Define Settings de la sección Configuration del documento del analizador).
  • Para obtener un valor de tensión mediante Name Mask, el nombre de la red de alimentación debe ajustarse al formato *V* o *.*V, donde * es un valor numérico, como se muestra en la imagen siguiente.

  • Otra forma de definir el valor de tensión de la red de alimentación es configurar la propiedad Power Net, definida en el panel Properties para cualquier hilo de la red. Para habilitar esta propiedad, primero coloque una directiva de conjunto de parámetros (Place » Directives » Parameter Set) en la red (sitúe el cursor sobre la imagen siguiente para ver una imagen de este proceso). El tamaño, el color y la etiqueta los define el usuario; es la presencia de la directiva lo que habilita la propiedad Power Net de esa red. Una vez añadida la directiva, seleccione un hilo de esa red, habilite la propiedad Power Net y configure Voltage de la red, como se muestra a continuación. 

  • Los componentes en serie deben ajustarse a los designadores definidos para resistencias, inductores y componentes en serie personalizados (tal como se definen en el área Auto-Define Settings de la sección Configuration del documento del analizador).

  • Los VRM deben estar conectados al menos a dos redes de alimentación.

Comandos de Power Analyzer

Los siguientes comandos están disponibles en los menús principales del editor de Power Analyzer.

Comando

Resumen y uso

Tools » Define Automatically

Intenta reconocer automáticamente la topología del proyecto a partir de la configuración actual del área Auto-Define Settings de la sección Configuration del documento del analizador (*.pdnaK). También puede acceder a este comando haciendo clic en el botón Define Automatically de la parte superior izquierda del editor.

File » Load from File

Carga un documento guardado de Power Analyzer by Keysight (*.pdnaK) en el editor de Power Analyzer.

Edit » Manage Nets

Abre el cuadro de diálogo Manage Nets, donde se seleccionan las redes de alimentación que se van a analizar. Al marcar una red, esta se añade al documento del analizador (*.pdnaK). Al desmarcarla, se elimina del documento junto con todas sus redes de alimentación secundarias. También puede acceder a este comando haciendo clic en el botón Manage Nets de la parte superior izquierda del editor. Obtenga más información sobre Gestión de redes.

File » Save

Guarda la configuración actual de Power Analyzer en un documento de Power Analyzer by Keysight (*.pdnaK).

File » Save As

Guarda la configuración actual de Power Analyzer en un documento de Power Analyzer by Keysight (*.pdnaK) con un nuevo nombre definido por el usuario.

Tools » Measurement Units » mil

Configura Power Analyzer para utilizar unidades de medida imperiales (mils).

Tools » Measurement Units » mm

Configura Power Analyzer para utilizar unidades de medida métricas (mm).

Limitaciones de Power Analyzer

Actualmente, Power Analyzer by Keysight no admite:

  1. Tensiones negativas.
  2. Componentes embebidos (componentes colocados en una capa interna). Obtenga más información sobre Diseño de una PCB con componentes embebidos.

 

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents