Captura del diseño lógico del sistema

De un vistazo

Aprende a capturar el diseño lógico de un sistema multitarjeta en Altium Designer vinculando proyectos de PCB secundarios a módulos de un esquema multitarjeta. Este artículo explica cómo preparar los conectores para la conectividad a nivel de sistema, definir los orígenes y las propiedades de los módulos e importar los datos de pines y redes de los conectores para completar las entradas de los módulos. Sigue leyendo para empezar a crear una representación clara de las conexiones entre las tarjetas de tu sistema.

- Comprende los pasos para crear un esquema multitarjeta y vincular módulos a proyectos de PCB secundarios.
- Aprende cómo el parámetro `System:Connector` identifica los conectores que se incluirán en el diseño a nivel de sistema.
- Descubre cómo validar los proyectos de PCB secundarios e importar sus datos de conectividad a las entradas de los módulos.
Profundiza con IA:

Los pasos esenciales para crear un diseño esquemático de un sistema multiplaca a partir de diseños de proyectos de PCB secundarios son:

  1. Cree un proyecto de diseño multiplaca y añada un documento esquemático multiplaca al proyecto.

  2. Coloque bloques gráficos (módulos) en el esquema multiplaca para representar lógicamente los proyectos de PCB secundarios.

  3. Vincule cada módulo a su proyecto secundario correspondiente.

  4. Importe los datos de conectividad de los proyectos secundarios al diseño multiplaca.

  5. Añada conexiones entre los módulos para crear el diseño lógico del sistema.

Para añadir un documento esquemático multiplaca (*.MbsDoc) al proyecto de diseño multiplaca, haga clic con el botón derecho en la entrada del proyecto en el panel Projects y, a continuación, seleccione Add New to Project » Multi-board Schematic en el menú contextual.

Cada proyecto de diseño multiplaca solo puede incluir un documento esquemático multiplaca.

Habilitación de proyectos de PCB para el diseño multiplaca

Los proyectos de PCB de Altium Designer que representan los diseños de las placas secundarias en un diseño multiplaca contendrán conexiones específicas, como conectores de borde o conectores macho/hembra de pines, que se incluyen como interfaz eléctrica y física con otras PCB del diseño del sistema.

Un documento de diseño esquemático (lógico) multiplaca debe detectar y procesar estas conexiones y sus redes eléctricas asociadas para establecer la conectividad entre placas en el diseño a nivel de sistema. Esta funcionalidad se habilita mediante la presencia de un parámetro de componente específico para los conectores del proyecto de PCB: un parámetro denominado System, con Connector como valor del parámetro.

Los conectores con el par Parámetro:Valor System:Connector se detectan cuando cada módulo a nivel de sistema se sincroniza con su proyecto de PCB secundario mediante el comando Import from Child Projects. Esto se explica en la sección Representación de proyectos de PCB secundarios en el esquema multiplaca, que aparece más adelante.

Para cada conector de un diseño de proyecto de PCB destinado a una interconexión a nivel de sistema, seleccione el componente del conector y, a continuación, añada el parámetro de componente especial a la lista de la sección Parameters, en la pestaña General del panel Properties, con el componente seleccionado.

Para obtener más información sobre las propiedades de los componentes, consulte la página Trabajo con componentes colocados.

La presencia del parámetro denominado System, con un valor de Connector, vincula este conector de PCB al esquema multiplaca.
La presencia del parámetro denominado System, con un valor de Connector, vincula este conector de PCB al esquema multiplaca.

Representación de proyectos secundarios en el esquema multiplaca

La conectividad entre los proyectos de PCB que componen un diseño multiplaca se establece colocando bloques representativos (módulos) en el esquema y uniendo sus conectores expuestos (entradas de módulo) mediante conexiones.

Los módulos, que representan diseños de proyectos de PCB secundarios y PCB específicas de dichos proyectos, se colocan en el espacio de diseño desde el menú Place » Module.

Para definir el origen de un módulo colocado, selecciónelo en el espacio de diseño y, en el panel Properties, utilice el botón  asociado al campo Project de la sección Source en la pestaña General para abrir el cuadro de diálogo Choose Project (una variante del cuadro de diálogo Open Project), desde el que puede buscar y seleccionar un proyecto de PCB o multiplaca como origen del módulo. Una vez elegido el proyecto requerido, seleccione el diseño de placa PCB o el ensamblaje multiplaca deseado dentro de ese proyecto mediante la lista desplegable Assembly/Board.

Un proyecto multiplaca configurado presenta una estructura jerárquica de documentos que incluye los documentos de origen y los subproyectos secundarios vinculados a los módulos del diseño esquemático del sistema. La estructura de un proyecto secundario se añade inmediatamente al proyecto multiplaca cuando un módulo del diseño del sistema se vincula a ese proyecto externo. Expanda la estructura del proyecto en el panel Projects para mostrar los archivos que componen el proyecto multiplaca y sus proyectos secundarios.

Para garantizar que el proyecto multiplaca extraiga y procese los datos correctos de sus subproyectos, la PCB de cada proyecto debe estar sincronizada con su esquema y no contener errores de diseño ni de dibujo. Para validar un subproyecto de PCB, haga clic con el botón derecho en su nombre en el panel y seleccione el comando Validate PCB Project <ProjectName>.PrjPcb; cualquier problema se mostrará en el panel Messages.

Javascript ID: Pnl_Properties_MBS_Module_Source
 
 
 
 
 
  • Se puede añadir un proyecto de PCB, otro proyecto multiplaca o un proyecto de diseño de arneses a la estructura del proyecto multiplaca haciendo clic con el botón derecho en la entrada de este último en el panel Projects, seleccionando el comando Add Existing to Project y, a continuación, buscando y seleccionando el archivo local *.PrjPcb, *.PrjMbd o *.PrjHar correspondiente. Si un proyecto de PCB o de diseño de arneses que deba formar parte del proyecto multiplaca ya está abierto en Altium Designer, puede arrastrar su entrada en el panel Projects hasta la entrada del proyecto multiplaca principal para añadirlo a su estructura (). Después, coloque manualmente un nuevo módulo en el documento esquemático multiplaca (del proyecto multiplaca principal) y, con el módulo seleccionado, elija el proyecto de PCB secundario (y su documento PCB) o el proyecto multiplaca secundario (y su documento de ensamblaje multiplaca) como origen de ese módulo en la lista desplegable del campo Source del panel Properties (). El proyecto de arneses se puede sincronizar con el proyecto multiplaca (consulte la página Definición del diagrama de cableado para obtener más información).

  • Para eliminar un proyecto de diseño de PCB o multiplaca secundario de la estructura del proyecto multiplaca principal, elimine todos los módulos que hagan referencia a ese proyecto secundario del documento esquemático multiplaca del proyecto principal. El proyecto secundario se eliminará automáticamente de la estructura.

  • También se puede eliminar un proyecto de PCB o de diseño de arneses secundario de la estructura del proyecto multiplaca principal arrastrando la entrada del proyecto secundario fuera de la estructura del proyecto multiplaca. Tenga en cuenta que, en este caso (y solo para un proyecto de PCB), los módulos que hacen referencia al proyecto secundario permanecerán en el documento esquemático multiplaca, al igual que los vínculos de estos módulos al proyecto secundario. Para eliminar por completo del proyecto multiplaca principal cualquier referencia al proyecto secundario eliminado, elimine estos módulos manualmente.

Utilice el panel Properties con un módulo colocado seleccionado para definir otras propiedades del módulo:

  • Utilice las propiedades Designator y Title de la sección Properties, en la pestaña General del panel, para especificar el identificador del módulo en el esquema y el texto del título, respectivamente. Utilice el botón  situado a la derecha del campo correspondiente para alternar su visibilidad en el esquema multiplaca y el botón  para permitir o impedir la edición del valor. Utilice los controles de fuente y Other para configurar la fuente del texto, su posición en el documento y, en el caso del texto del título, la visibilidad del nombre del parámetro.

  • La tabla de la sección Entries de la pestaña General del panel Properties, cuando el módulo está seleccionado, se rellenará cuando se añadan entradas al módulo: consulte más abajo.

  • Utilice los controles de la sección Graphical, en la pestaña General del panel, para configurar la apariencia del módulo: su tamaño (anchura y altura), el grosor, el estilo y el color de la línea de contorno del módulo y el color de relleno. Las opciones disponibles de grosor y estilo de línea se definen en la sección Line Styles del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Para obtener más información, consulte la página Configurar un documento de esquema multiplaca.

  • Utilice los controles de la pestaña Parameters del panel para añadir, modificar y eliminar parámetros del módulo y configurar su visibilidad en el espacio de diseño.  

Añada más módulos y sus vínculos a proyectos secundarios al diseño del esquema multiplaca, según sea necesario para el diseño completo del sistema.

Los módulos se rellenan con los datos de diseño de sus proyectos vinculados al importar los datos de los proyectos mediante los siguientes comandos de los menús principales o del menú contextual del espacio de diseño:

  • Design » Import From Child Projects – transferir los datos de diseño de todos los proyectos de origen (secundarios) a sus módulos especificados.

  • Design » Import From Selected Child Projects – transferir los datos de diseño de los proyectos de origen (secundarios) correspondientes a los módulos seleccionados actualmente.

Lo más importante es que este proceso trata los datos de pines y redes de cada conector de los proyectos secundarios que tenga asociado el parámetro especial System:Connector (consulte los detalles anteriores). Una vez completada la importación, se crea automáticamente una entrada de módulo para cada uno de estos conectores en la representación gráfica de su respectivo bloque de módulo. La entrada del conector queda vinculada a los pines y las redes del conector en el proyecto secundario. Seleccione la representación gráfica de una entrada de módulo en el espacio de diseño para ver sus detalles, como los pines y las redes del conector, en el panel Properties. Hasta que se conecte a la entrada de otro módulo, la lista de componentes y pines de la entrada en el panel mostrará el conector y los pines como no acoplados.

 
  • Aunque las entradas se colocan automáticamente al importar datos de los proyectos secundarios, también puede colocar una entrada de módulo manualmente seleccionando el comando Place » Entry en los menús principales.

  • Seleccione una entrada de módulo haciendo clic en su representación gráfica y, a continuación, arrástrela por el perímetro del módulo hasta una ubicación adecuada. Tenga en cuenta que el designador de la entrada se puede arrastrar de forma independiente a otra posición.

  • También puede mover un grupo de entradas de módulo seleccionando más de una entrada y arrastrando el grupo hasta la ubicación deseada.

  • El color de la entrada le ayudará a moverla y colocarla correctamente. Cuando esté fuera de un módulo, la entrada se mostrará parcialmente y aparecerá atenuada, y no podrá colocarla. Cuando esté sobre un módulo, aparecerá la entrada completa y en color, lo que indica que se puede colocar en esa ubicación.

Utilice el panel Properties con una entrada seleccionada para definir sus propiedades:

  • Utilice los controles de la sección Properties, en la pestaña General del panel, para cambiar el valor, la visibilidad y el estilo de Designator de la entrada y elegir su Type (Male/Female). En esta sección del panel también se indican el número de pines del conector de la entrada (Number of Pins) y el número identificador asignado a esta entrada en el módulo principal (Entry Number).

  • Active la opción System Entry para indicar que la entrada es una conexión a nivel de sistema que no está cableada a otro módulo; por ejemplo, una entrada que represente una toma de alimentación.

    Un proyecto multiplaca secundario tiene un módulo cuya entrada tiene activada la opción System Entry.

    Cuando se importen cambios al proyecto multiplaca principal, el conector de esta entrada se añadirá como una entrada de módulo del módulo del proyecto secundario.

     
  • Cuando la entrada se conecta mediante una conexión de arnés o cable (más información), la sección Mated Component del panel se rellena con los datos del componente acoplado.

  • En Mated Pins región del panel, la columna Pin enumera los pines individuales del conector y sus redes asociadas. Una vez conectada esta entrada, la columna Mated Pin se rellena con una lista de los pines acoplados. Además, una vez conectada esta entrada, la pestaña Addresses del panel Properties se rellena con una lista tabular de las rutas de conexión y las redes de la entrada (más información).

  • Utilice los controles de la pestaña Parameters del panel para añadir, modificar y eliminar parámetros de la entrada y configurar su visibilidad en el espacio de diseño.

Cuando se añaden entradas a un módulo, la tabla de la región Entries de la pestaña General del panel Properties se rellena con las entradas al seleccionar el módulo. La columna Part(s) muestra cada entrada del módulo mediante el designador y el nombre del conector de entrada en el diseño de origen. Estos datos se pueden editar para mayor comodidad: los nombres son locales al diseño multiplaca y no afectan a los proyectos secundarios de origen.

  • La columna Mated part(s) se rellena con datos una vez que la entrada se conecta a otra entrada del diseño multiplaca mediante una conexión. Para obtener más información, consulte la página Trabajar con conexiones.

  • Desde la lista, puede cambiar rápidamente la visibilidad del designador de la entrada (  /  ) y su tipo (  /  ). Utilice los botones  y  para añadir una nueva entrada sin definir al módulo y a la lista, y para eliminar del módulo la entrada seleccionada en la lista, respectivamente.

  • Utilice los botones  y  para dividir la conexión seleccionada en la lista en dos entradas de módulo relacionadas y para volver a unir las entradas divididas previamente en una sola entrada, respectivamente. Para obtener más información, consulte la página Trabajar con conexiones.

Compatibilidad con periféricos/componentes externos

Esta función está disponible cuando las opciones MBS.PlacePart y MBS.UseGeometryMaker están habilitadas en el cuadro de diálogo de configuración avanzada.

El documento esquemático multiplaca admite periféricos/componentes externos que no forman parte de los ensamblajes de PCB secundarios habituales (es decir, componentes «no PCB»). Esto podría incluir, por ejemplo, interruptores externos, sensores y cualquier otro módulo electrónico comercial de terceros. Esta capacidad se facilita mediante la compatibilidad con dos tipos de objetos:

  • Custom Part – una entidad similar a un módulo que permite vincular uno o varios componentes de biblioteca y que se añade al documento esquemático multiplaca mediante el comando Place » Custom Part de los menús principales. Utilice la región Linked Components del panel Properties, con la pieza personalizada colocada seleccionada en el espacio de diseño, para añadir componentes a la pieza personalizada y eliminarlos mediante los botones  y , respectivamente. Si la lista de componentes vinculados incluye componentes del espacio de trabajo desactualizados, haga clic en el botón  para actualizar los componentes a sus revisiones más recientes. Se añade automáticamente una entrada por cada componente vinculado.

  • Custom Connection – permite añadir un único componente de biblioteca al documento esquemático multiplaca arrastrando el componente deseado desde el panel Components y soltándolo en un espacio libre de la hoja. Se añade automáticamente una entrada por cada pin del componente.

    También puede crear un símbolo personalizado para un componente específicamente para su uso en un documento esquemático multiplaca. Al añadir nombres separados por comas al campo Name de las propiedades de un pin, puede agrupar varios pines en entradas, lo que permite crear símbolos visualmente más limpios con menos entradas y simplifica considerablemente la conexión de dichos componentes.

    Javascript ID: MBS_CustomConn_MultiplePins_AD24_5

    Al editar un símbolo esquemático, añada varios nombres separados por comas al campo Name de un pin.

    Cuando el componente se añade a una pieza personalizada en un esquemático multiplaca, se crea una entrada por cada pin del componente en lugar de una única entrada para el componente, y se crean entradas con varios pines.

    Cuando el componente se coloca en un esquemático multiplaca como una conexión personalizada, se crean entradas con varios pines.

Los componentes de biblioteca son los disponibles en su espacio de trabajo conectado y en las bibliotecas locales disponibles. Una vez colocados/definidos, puede conectar los componentes al resto del diseño, por ejemplo, mediante conexiones de cables y arneses.

Los componentes vinculados definidos mediante piezas personalizadas y/o conexiones personalizadas no se incluyen automáticamente en la lista de materiales (BOM) general del producto/sistema ni se muestran en el ensamblaje multiplaca (*.MbaDoc).

Navegación cruzada

Los comandos de navegación cruzada disponibles en el menú principal Design y en el menú contextual del espacio de diseño permiten navegar rápidamente desde el documento esquemático multiplaca hasta los elementos relacionados de los proyectos secundarios.

  • Para navegar desde el módulo o la entrada seleccionados actualmente hasta el documento PCB o el conector de dicho documento dentro del proyecto de diseño de PCB al que hace referencia ese módulo, utilice el comando Design » Crossprobe to PCB/Multi-board. Si el módulo hace referencia a un documento de ensamblaje multiplaca (*.MbaDoc) dentro de un proyecto multiplaca de origen (*.PrjMbd), la navegación cruzada se realizará al documento de ensamblaje multiplaca.

  • Para navegar desde el módulo o la entrada seleccionados actualmente hasta el esquemático de nivel superior o el conector del esquemático correspondiente dentro del proyecto de diseño de PCB al que hace referencia ese módulo, utilice el comando Design » Crossprobe to Schematic.

  • Para navegar desde el módulo o la entrada seleccionados actualmente hasta la placa, o el conector de dicha placa, en el documento de ensamblaje multiplaca (*.MbaDoc) dentro del proyecto multiplaca (*.PrjMbd), utilice el comando Design » Crossprobe to MBA.

  • Para navegar desde la conexión de arnés seleccionada actualmente en el documento esquemático multiplaca (*.MbsDoc) hasta un proyecto de arnés vinculado (*.PrjHar), utilice el comando Design » Crossprobe to Harness. Se abrirá el documento del diagrama de cableado del proyecto de arnés asociado.

Al realizar una navegación cruzada desde una entrada de módulo, los objetos de destino del documento esquemático/PCB se mostrarán de acuerdo con las opciones Highlight Methods definidas en la página Sistema – Navegación de Preferences cuadro de diálogo. El resaltado no se aplicará al documento esquemático multiplaca.

Imprimir o exportar a PDF

Para imprimir el documento esquemático multiplaca activo, seleccione File » Print en el menú principal (atajo de teclado: Ctrl+P). Se abrirá el cuadro de diálogo Print . En el lado izquierdo del cuadro de diálogo se muestra una vista previa de impresión escalable. Las opciones de impresión estándar están disponibles en el lado derecho del cuadro de diálogo. Estas permiten seleccionar una impresora específica, confirmar su ubicación, ver cuántos documentos hay actualmente en la cola de impresión, ajustar el número de copias que se imprimirán y configurar el tamaño y la orientación de la página. Tras hacer clic en , el conjunto de impresión se enviará al dispositivo de impresión seleccionado, de acuerdo con las opciones definidas.

El cuadro de diálogo Print
El cuadro de diálogo Print

Para exportar un documento esquemático multiplaca a un archivo PDF, seleccione File » Export to PDF en el menú principal.

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents