Definición del diagrama de cableado

De un vistazo

Este artículo explica cómo se crean, configuran y utilizan los diagramas de cableado de arneses en Altium Designer para definir las conexiones individuales por cable dentro de un proyecto de arnés. Describe cómo añadir un documento de diagrama de cableado y configurar sus principales opciones, como las unidades, las rejillas, los ajustes de página y las plantillas. También destaca funciones relacionadas, como la validación, los objetos de texto y dibujo y el guardado en formato ASCII. Además, explica cómo sincronizar los diagramas de cableado con proyectos multiplaca y cómo importar o colocar componentes manualmente, para ofrecerte una visión práctica del flujo de trabajo básico antes de empezar a desarrollar tu diseño. Sigue leyendo para conocer los pasos esenciales de configuración y sincronización que facilitan el trabajo con los diagramas de cableado de arneses.

- Cómo añadir y configurar un documento de diagrama de cableado de arnés, incluidas las unidades, las rejillas, las opciones de página y los ajustes predeterminados.
- Cómo la sincronización con un proyecto multiplaca importa los componentes de los conectores y la conectividad lógica al diagrama de cableado.
- Cómo colocar y gestionar los componentes en el diagrama de cableado, tanto si se importan de un diseño multiplaca como si se añaden manualmente.
Profundiza con IA:

Las conexiones cableadas individuales del arnés se especifican en el diagrama de cableado del arnés (*.WirDoc). Añada este documento al proyecto de arnés desde el panel Projects haciendo clic con el botón derecho en la entrada del proyecto y seleccionando Add New to Project » Harness Wiring Diagram en el menú contextual (o utilice el comando File » New » Harness Wiring Diagram de los menús principales).

Configuración de un documento de diagrama de cableado del arnés

Las opciones de un documento de diagrama de cableado del arnés se pueden configurar en el panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño del documento. Los ajustes principales son:

  • En la sección General de la pestaña General del panel: seleccione las unidades de medida que se aplican al documento y a sus elementos gráficos, y configure las rejillas para facilitar la colocación. Altium Designer ofrece tres tipos de rejilla: rejilla visible para la navegación, rejilla de ajuste para la colocación y distancia de ajuste para facilitar la creación de conexiones.

  • En la sección Page Options de la pestaña General del panel : configure el tamaño de la hoja del documento y el cajetín, o seleccione una de las plantillas de diagrama de cableado del arnés disponibles.

Las pestañas General y Parameters del panel Properties cuando no hay ningún objeto seleccionado en el documento de diagrama de cableado del arnés 
Las pestañas General y Parameters del panel Properties cuando no hay ningún objeto seleccionado en el documento de diagrama de cableado del arnés

  • La configuración de un documento de diagrama de cableado del arnés es similar a la de un documento esquemático (*.SchDoc) de un proyecto de diseño de PCB. Consulte la página Configuración de un documento esquemático para obtener más información.

  • Utilice el menú desplegable Length Units para elegir las unidades de longitud del documento. Los valores Strip Length y Pull Off Length de las cavidades de los contactos hembra se mostrarán con las unidades seleccionadas. Las unidades admitidas son mm, cm, m, in y ft. Las unidades de longitud predeterminadas de los documentos de diagrama de cableado nuevos se pueden definir en la página Diseño de arneses – General del cuadro de diálogo Preferences.

  • Para obtener más información sobre la creación de plantillas de documentos de cableado del arnés, consulte la página Creación de documentos de plantilla de arneses.

  • Las propiedades predeterminadas de los objetos del diagrama de cableado del arnés se pueden configurar en la página Diseño de arneses – Valores predeterminados del cuadro de diálogo Preferences. Estas propiedades se aplicarán a los objetos que se coloquen posteriormente.

  • Al crear un documento de diagrama de cableado del arnés, también puede utilizar objetos de texto y de dibujo. El trabajo con estos objetos en un documento de diagrama de cableado del arnés es similar al trabajo con ellos en un documento esquemático (*.SchDoc) de un proyecto de diseño de PCB. Consulte Trabajo con objetos de texto en un esquemático y Trabajo con objetos de dibujo en un esquemático para obtener más información sobre estos objetos.

    • Tenga en cuenta que los marcos de texto y las notas también admiten enlaces activos a objetos del diagrama de cableado del arnés (por ejemplo, cables y componentes) y a objetos del plano de disposición del arnés (por ejemplo, haces y puntos de conexión). Haga clic en un enlace del marco de texto o de la nota colocados para localizar ese objeto en el documento asociado mediante la navegación cruzada.

  • Para comprobar si el diagrama de cableado del arnés presenta infracciones lógicas, eléctricas o de dibujo, se dispone de diversas comprobaciones. Consulte la página Validación del diseño del arnés para obtener más información.

  • Un documento de diagrama de cableado del arnés se puede guardar en formato ASCII, lo que puede resultar útil para compartirlo. Utilice el comando File » Save As y seleccione Harness Wiring ascii (*.WirDoc) en el menú desplegable Save as type del cuadro de diálogo Save As que se abre. Al guardar un diagrama de cableado ASCII mediante el comando File » Save, se abrirá el cuadro de diálogo File Format, que le avisará de que se está utilizando el formato ASCII. Elija la versión ASCII en el cuadro de diálogo  para seguir utilizando este formato.

Sincronización de proyectos multiplaca y de arneses

 
 
 
 
 

Cuando el proyecto de arnés forma parte de un proyecto de diseño multiplaca, el diagrama de cableado del arnés se puede sincronizar a partir de los datos del documento esquemático multiplaca (*.MbsDoc). Para ello, seleccione el comando Design » Import Changes From <Multi-board Project> en los menús principales.

Para obtener más información sobre cómo añadir un proyecto de diseño de arnés a un proyecto multiplaca, consulte la página Diseño de arneses.

Si el documento esquemático multiplaca contiene más de una definición de conexión de arnés, se abrirá el cuadro de diálogo Select Harness Definition. Especifique la definición correspondiente al proyecto de arnés actual.

El cuadro de diálogo Select Harness Definition
El cuadro de diálogo Select Harness Definition

A continuación, se abrirá el cuadro de diálogo Engineering Change Order, que mostrará los componentes de conector del arnés y las redes del arnés definidos en el esquemático multiplaca, que constituirán la base del diagrama de cableado del arnés.

Utilice el cuadro de diálogo Engineering Change Order para importar datos del proyecto multiplaca. 
Utilice el cuadro de diálogo Engineering Change Order para importar datos del proyecto multiplaca. 

Tras ejecutar los cambios (), los datos del documento esquemático multiplaca se importan al diagrama de cableado del arnés. Los componentes de conector, cada uno representado por su símbolo esquemático, aparecerán en el documento de diagrama de cableado del arnés, inicialmente en posiciones arbitrarias.

Ejemplo de un diagrama de cableado del arnés justo después de la importación.
Ejemplo de un diagrama de cableado del arnés justo después de la importación.

Se mostrarán líneas de red entre los pines para representar las conexiones lógicas definidas en el esquemático multiplaca. Tenga en cuenta que, en esta etapa, no hay cables físicos en el diseño.

Tenga en cuenta que los datos de conectividad importados del proyecto multiplaca al proyecto de arnés se basan en los nombres de los pines de los componentes de conector, por lo que debe asegurarse de asignar nombres únicos y correctos a los pines de los componentes en la biblioteca de origen antes de importar los datos.

Trabajo con componentes

Además de sincronizarse desde el documento de esquema multiplaca, los componentes también se pueden colocar manualmente en el diagrama de cableado del arnés. Esto permite colocar componentes en un proyecto de arnés independiente (que no forme parte de un proyecto multiplaca), así como colocar componentes adicionales en un diagrama de cableado de arnés que forme parte de un proyecto multiplaca.

Utilice el panel Components para colocar los símbolos de los componentes necesarios. El proceso de colocación de componentes es similar al del editor de esquemas; consulte la página Búsqueda y colocación de componentes para obtener más información. Tenga en cuenta que no habrá líneas de red para los componentes añadidos manualmente, ya que no existe un diseño lógico de nivel superior que las determine.

  • Los componentes se colocan desde las bibliotecas disponibles y se representan mediante sus modelos de símbolo esquemático en un diagrama de cableado de arnés. Consulte Creación y mantenimiento de sus componentes y bibliotecas para obtener más información sobre la creación de componentes.

  • Los componentes de varias partes también se pueden colocar en un diagrama de cableado de arnés. Cuando los datos de diseño se importan al plano de disposición del arnés, los designadores se asignan correctamente a los componentes del plano de disposición del arnés. Si se colocan varias partes del mismo componente en el diagrama de cableado del arnés, solo se coloca una instancia del componente en el plano de disposición del arnés ().

  • Los conectores de arnés se pueden utilizar para establecer conexiones entre varios proyectos multiplaca en una configuración anidada.

  • Al pegar componentes de arnés cortados o copiados en un diagrama de cableado de arnés, los designadores de los componentes pegados respetan la opción Reset Parts Designators On Paste de la página Esquema – Edición gráfica del cuadro de diálogo Preferences. Cuando se pegan componentes con la opción habilitada, la parte numérica de sus designadores se restablece a ?.

Para mover un componente colocado (o un componente que se esté colocando desde el panel Components) a la posición deseada, mantenga pulsado el botón izquierdo del ratón sobre él y mueva el ratón. Durante el arrastre, utilice Spacebar para girar los componentes 90 grados y las teclas X y Y para voltearlos horizontal y verticalmente, respectivamente.

El diagrama de cableado del arnés después de mover los componentes
El diagrama de cableado del arnés después de mover los componentes

Las propiedades de un componente colocado se pueden configurar en el panel Properties cuando el componente está seleccionado en el espacio de diseño. El panel Properties de un componente incluye las siguientes pestañas:

 
 
 
 
 
  • General – propiedades generales del componente, como el designador y el comentario, la ubicación, los parámetros, etc.

  • Pins – la lista de pines del componente.

  • Cavities – permite asignar cavidades de contacto al componente (más información).

  • Associated Parts – permite asignar elementos adicionales al componente, como tubos termorretráctiles.

Pestañas del panel Properties cuando se selecciona un componente
Pestañas del panel Properties cuando se selecciona un componente

Asignación de cavidades de contacto

 
 
 
 
 

Se pueden asignar cavidades de contacto y su tipo a un componente de arnés. Seleccione un componente en el espacio de diseño para añadir una cavidad y su tipo. Seleccione un pin en la pestaña Cavities del panel Properties y, a continuación, haga clic en el botón  . Seleccione el tipo deseado en la lista desplegable. Se admiten los siguientes tipos de cavidad:

  • Crimp – se utiliza para proporcionar una conexión eléctrica comprimiendo el cilindro de un contacto alrededor de un conductor.

  • Seal – se utiliza para proporcionar protección ambiental sellando el punto de entrada del cable.

  • Plug – se utiliza para rellenar una cavidad abierta (sin usar) de un conector y mantener la integridad del sellado ambiental.

  • Other – se utiliza para especificar otras piezas o materiales adicionales, por ejemplo, soldadura.

Para el tipo de cavidad Crimp o las filas sin un tipo de cavidad añadido, puede especificar los siguientes valores:

  • Strip Length – la longitud a la que se corta el aislamiento del conductor.

  • Pull Off Length – la longitud a la que se retira del conductor el aislamiento cortado. Esto puede utilizarse cuando el extremo del cable no se pela por completo y el fragmento de aislamiento retirado se mantiene en el cable para evitar daños en los hilos.

Las unidades en las que se muestran estos valores en el panel Properties cuando se selecciona un componente se especifican mediante la lista desplegable Length Units de la pestaña General del panel Properties cuando no hay ningún objeto seleccionado en el documento.

En el cuadro de diálogo Select Connector que se abre, busque y seleccione el componente deseado. El tipo específico y la información pertinente se añadirán al pin en la pestaña, como se muestra en las imágenes siguientes para añadir un contacto de crimpado al pin 1.

Tenga en cuenta que los pines se muestran en la tabla de la pestaña Cavities por sus nombres (la columna Pins) y que la asignación de cavidades se basa en los nombres de los pines, por lo que debe asegurarse de asignar nombres únicos y correctos a los pines del componente.

En el caso de un contacto de crimpado, una junta de sellado o un tapón, solo se puede añadir una cavidad de un tipo determinado a un pin. Una vez añadida una cavidad de un tipo determinado, la opción deja de estar disponible (aparece atenuada) en la lista desplegable. Se puede añadir cualquier número de cavidades del tipo Other a un pin.

Los pines con contactos de crimpado asignados se indican mediante el símbolo  en el espacio de diseño, como se muestra en la imagen siguiente.

La región de cuadrícula de la pestaña Cavities admite la selección múltiple y las operaciones de copiar, pegar y eliminar para las entradas seleccionadas.

  • Se pueden seleccionar varias entradas de pines mediante los atajos Click, Hold&Drag, Ctrl+Click, Shift+Click y Ctrl+A.

  • Cuando haya varias entradas de pines seleccionadas, haga clic en  para añadir una cavidad a todos los pines seleccionados, o haga clic en  o pulse Delete para eliminar las cavidades añadidas de los pines seleccionados. 

  • Para cambiar la cavidad de un pin, seleccione su entrada y, a continuación, haga clic en  para abrir el cuadro de diálogo Select Connector y seleccionar la nueva cavidad.

  • Seleccione una o varias entradas de pines y utilice los atajos Ctrl+X/Ctrl+C para cortar o copiar las entradas seleccionadas; después, utilice el atajo Ctrl+V para pegar el contenido cortado o copiado en la entrada seleccionada actualmente.

Creación de conexiones en el diagrama de cableado del arnés

Los cables físicos se colocan en el documento del diagrama de cableado del arnés seleccionando el comando Place » Harness Wire en los menús principales (atajo: Shift+W).

Después de seleccionar el comando, haga clic en un pin de un conector (aparece una cruz roja en el cursor cuando este se encuentra sobre el punto de conexión de un pin) para colocar el punto inicial del cable del arnés. Sitúe el cursor y haga clic para fijar una serie de vértices que definan la forma del cable del arnés. Después de colocar el último vértice en el punto de conexión de otro pin, haga clic con el botón derecho para finalizar la colocación.

Al colocar un cable de arnés, pulse Shift+Spacebar para alternar entre los modos de colocación. El modo especifica cómo se crean las esquinas al colocar los cables y los ángulos con los que pueden colocarse. En el modo 90 Degree o 45 Degree (modos ortogonales puros), pulse Spacebar para alternar entre los submodos de inicio y fin. El modo y el submodo actuales se muestran en la barra de estado.

Al colocar un cable de arnés, las líneas de conexión se actualizan en tiempo real y muestran dónde conectar los cables, como se ilustra en el siguiente vídeo. Una vez completada una conexión, su línea de conexión desaparece del documento.

Demostración de la función de seguimiento en tiempo real

Una vez colocado y seleccionado un cable de arnés, se pueden arrastrar sus vértices para cambiar el ángulo entre dos tramos adyacentes (Mostrar ejemplo).

Seleccione un cable de arnés en el espacio de diseño para modificarlo en el panel Properties. Desde el panel, puede cambiar el nombre del cable de arnés seleccionado, modificar su anchura y color, y añadir parámetros que se pueden mostrar u ocultar en el espacio de diseño.

El panel Properties cuando hay un cable de arnés seleccionado
El panel Properties cuando hay un cable de arnés seleccionado

  • Un cable de arnés colocado se puede sustituir por un componente de cableado de arnés que incluya un solo cable. Para ello, seleccione el cable de arnés que desea sustituir y haga clic en el botón  situado a la derecha del campo Design Item ID en el panel Properties. En el cuadro de diálogo Replace Component que se abre, busque y seleccione el componente necesario. El cable colocado se actualizará con las propiedades y los parámetros del componente elegido, sin modificar su geometría. Consulte la sección Colocación de un componente de cableado de arnés para obtener más información.

  • El color principal de un cable se define mediante el parámetro Color, que se muestra de forma predeterminada en los cables de arnés colocados. Para editar el color, introduzca su nombre (p. ej., Red) o su código hexadecimal (escribiendo el carácter # seguido del número hexadecimal, p. ej., #9900FF) como valor del parámetro. También puede hacer clic en el botón de color situado a la izquierda del valor del parámetro y utilizar el selector de color que se abre, donde puede especificar el color del cable mediante un valor RGB o HEX, una selección libre o una serie de opciones predefinidas.

  • El diagrama de cableado del arnés admite cables de arnés multicolores mediante la selección de los colores secundario y terciario de un cable. En el panel Properties, haga clic en el menú desplegable  situado en la parte inferior de la región Parameters y, a continuación, elija Secondary y Tertiary para definir los colores deseados; el parámetro del color elegido aparecerá en la región Parameters . También puede definir el color del borde del cable de arnés mediante el mismo menú desplegable y seleccionando Border. Tenga en cuenta que el parámetro Color controla la visibilidad del valor combinado de los parámetros Color, Secondary Color y Tertiary Color definidos para el cable. Recorra la siguiente presentación de diapositivas para ver ejemplos.

    Javascript ID: Harness_WD_Pnl_Properties_Wire_Colors_AD25

    Un cable con solo el color principal definido

    Un cable con el color secundario definido

    Un cable con el color terciario definido

    Un cable con el color del borde definido

    Un cable con todas las opciones de color definidas

    Las tablas de los documentos de planos de fabricación de diseños de arneses (*.HarDwf) admiten cables multicolores: más información.

  • Si un cable de arnés tiene el valor No en su parámetro Include Cut, este cable no se mostrará en la lista de cableado ni en la tabla de conexiones del plano de fabricación.

  • Los parámetros Color, Min. Bending Radius, Thickness y Units de un cable de arnés se utilizan al sincronizar un proyecto de diseño de arnés con una herramienta MCAD mediante MCAD CoDesigner. Consulte la página Sincronización de un proyecto de diseño de arnés para obtener más información.

Adición de empalmes y derivaciones

En situaciones de diseño en las que sea necesario conectar un cable nuevo a uno ya colocado, primero se debe colocar un objeto de empalme (Place » Splice) o de derivación (Place » Tap).

  • Splice – el empalme divide el cable original en dos cables independientes.

    Javascript ID: Harness_WD_PlacingSplice_AD25

    Es necesario conectar otro cable al cable seleccionado (W4).

    Un empalme colocado en el cable. Observe que el empalme divide el cable original en dos en el punto donde se coloca.

    Se ha conectado otro cable al empalme.

    Cuando dos cables se conectan en forma de T, se coloca automáticamente un empalme en el punto de unión en T (Mostrar ejemplo).

  • Tap – el cable original permanece sin dividir.

    Javascript ID: Harness_WD_PlacingTap_AD25

    Es necesario conectar otro hilo al hilo seleccionado (W4).

    Una derivación colocada en el hilo. Tenga en cuenta que la derivación no divide el hilo original.

    Se ha conectado otro hilo a la derivación.

Las propiedades de un empalme o una derivación colocados (su ubicación y representación visual) se pueden configurar en el panel Properties cuando el objeto está seleccionado en el espacio de diseño.

El panel Properties cuando se selecciona un empalme o una derivación
El panel Properties cuando se selecciona un empalme o una derivación

La sección Associated Parts del panel Properties permite asignar componentes al empalme o la derivación seleccionados, y este componente se reflejará en la lista de materiales (BOM) del proyecto.

Adición de cables

Para definir uno o varios hilos como parte de un cable, puede colocar un objeto de cable en el diagrama de cableado del arnés (Place » Harness Cable).

Coloque un cable para definir uno o varios hilos como parte de un cable.
Coloque un cable para definir uno o varios hilos como parte de un cable.

Cuando se selecciona un objeto de cable, los hilos que abarca este cable se resaltan en verde neón en el espacio de diseño ().

Las propiedades de un objeto de cable colocado (su ubicación, representación visual y parámetros) se pueden configurar en el panel Properties cuando el objeto está seleccionado en el espacio de diseño.

El panel Properties cuando se selecciona un cable
El panel Properties cuando se selecciona un cable

Utilice el control de bloqueo/desbloqueo de los campos Width/Height del panel para alternar entre dimensiones bloqueadas y desbloqueadas. Cuando se arrastra el objeto mediante sus tiradores de edición, se mantiene la relación de aspecto según la configuración. De forma predeterminada, las dimensiones están bloqueadas, con una relación de aspecto de altura:anchura de 2:1.  Cuando se desbloquean, puede cambiar las dimensiones de forma independiente según sea necesario.

  • Si un cable está asociado a hilos en varios lugares del diagrama de cableado del arnés (es decir, cuando se colocan varios objetos de cable con el mismo designador sobre distintos hilos), al seleccionar un objeto se resaltarán todos los hilos asociados del grupo, y todos estos hilos aparecerán en la sección Cable Objects del panel Properties ().

  • Los parámetros Color, Min. Bending Radius, Thickness y Units de un cable se utilizan al sincronizar un proyecto de diseño de arneses con una herramienta MCAD mediante MCAD CoDesigner. Consulte la página Sincronización de un proyecto de diseño de arneses para obtener más información.

Apantallamiento y trenzado de hilos

Se puede añadir una pantalla (con o sin conexión, como una conexión de hilo de drenaje) a un grupo de hilos colocando un objeto de pantalla (Place » Shield) o un objeto de pantalla con conexión (Place » Shield with Connection).

En el ejemplo que se muestra a continuación, los hilos W1, W2 y W3 están apantallados mediante una pantalla sin conexión (SH1), y los hilos W4, W8 y W9 están apantallados mediante una pantalla con conexión (SH2). El hilo W10 se coloca para conectar SH2 a un pin de componente.

Coloque un objeto de pantalla o de pantalla con conexión para indicar que los hilos están apantallados.
Coloque un objeto de pantalla o de pantalla con conexión para indicar que los hilos están apantallados.

Cuando se selecciona un objeto de pantalla o de pantalla con conexión, los hilos que abarca se resaltan en verde neón en el espacio de diseño ().

Las propiedades de un objeto de pantalla o de pantalla con conexión colocado (ubicación y representación visual) se pueden configurar en el panel Properties cuando el objeto está seleccionado en el espacio de diseño. La sección Shield Objects del panel muestra los hilos que abarca el objeto seleccionado.

El panel Properties cuando se selecciona una pantalla
El panel Properties cuando se selecciona una pantalla

  • Utilice el control de bloqueo/desbloqueo de los campos Width/Height del panel para alternar entre dimensiones bloqueadas y desbloqueadas. Cuando se arrastra el objeto mediante sus tiradores de edición, se mantiene la relación de aspecto según la configuración. De forma predeterminada, las dimensiones están bloqueadas, con una relación de aspecto de altura:anchura de 2:1.  Cuando se desbloquean, puede cambiar las dimensiones de forma independiente según sea necesario.

  • Si una pantalla está asociada a hilos en varios lugares del diagrama de cableado del arnés (es decir, cuando se colocan varios objetos de pantalla con el mismo designador sobre distintos hilos), al seleccionar un objeto se resaltarán todos los hilos asociados del grupo, y todos estos hilos aparecerán en la sección Shield Objects del panel Properties ().

Se puede indicar que varios hilos están trenzados entre sí colocando un objeto de trenzado (Place » Twist). Un objeto de trenzado puede colocarse sobre dos o más hilos.

En el ejemplo siguiente, se indica que los hilos W1 y W2 están trenzados entre sí mediante el objeto de trenzado Tw1.

Coloque un objeto de trenzado para indicar que los hilos están trenzados entre sí.
Coloque un objeto de trenzado para indicar que los hilos están trenzados entre sí.

Cuando se selecciona un objeto de trenzado, los hilos que abarca se resaltan en verde neón en el espacio de diseño ().

Las propiedades de un objeto de trenzado colocado (su ubicación y representación visual) se pueden configurar en el panel Properties cuando el objeto está seleccionado en el espacio de diseño. La sección Twist Objects del panel muestra los hilos que abarca el objeto de trenzado seleccionado.

El panel Properties cuando se selecciona un objeto de trenzado
El panel Properties cuando se selecciona un objeto de trenzado

  • Utilice el control de bloqueo/desbloqueo de los campos Width/Height del panel para alternar entre dimensiones bloqueadas y desbloqueadas. Cuando se arrastra el objeto mediante sus tiradores de edición, se mantiene la relación de aspecto según la configuración. De forma predeterminada, las dimensiones están bloqueadas, con una relación de aspecto de altura:anchura de 1:1.  Cuando se desbloquean, puede cambiar las dimensiones de forma independiente según sea necesario.

  • Si un objeto de trenzado está asociado a hilos en varios lugares del diagrama de cableado del arnés (es decir, cuando se colocan varios objetos de trenzado con el mismo designador sobre distintos hilos), al seleccionar un objeto se resaltarán todos los hilos asociados del grupo, y todos estos hilos aparecerán en la sección Twist Objects del panel Properties ().

  • Los parámetros Vueltas por unidad de longitud y Thickness de un objeto de trenzado se utilizan al sincronizar un proyecto de diseño de arneses con una herramienta MCAD mediante MCAD CoDesigner. Consulte la página Sincronización de un proyecto de diseño de arneses para obtener más información.

Hilos sin conexión

Los extremos de hilo sin conexión se indican con un cuadrado sólido.

Indicación de un hilo sin conexión
Indicación de un hilo sin conexión

No se debe dejar un extremo de hilo sin conectar. Si el diseño requiere un extremo de hilo sin conexión, se debe colocar un objeto de «sin conexión» en dicho extremo (Place » No Connect).

Coloque un objeto de «sin conexión» en el extremo de un hilo que deba permanecer sin conectar.
Coloque un objeto de «sin conexión» en el extremo de un hilo que deba permanecer sin conectar.

Las propiedades de un objeto de «sin conexión» colocado (su ubicación y representación visual) se pueden configurar en el panel Properties cuando el objeto está seleccionado en el espacio de diseño.

El panel Properties cuando se selecciona un objeto de «sin conexión»
El panel Properties cuando se selecciona un objeto de «sin conexión»

Trabajo con varias hojas

Se puede definir un diagrama completo de cableado de arnés en varias hojas (con un diseño «plano», en el que todas las hojas se encuentran en el mismo nivel), cada una representada por su propio documento *.WirDoc. La conectividad se establece directamente entre cualquier hoja y cualquier otra mediante objetos de interrupción de hilo (Place » Wire Break) con el mismo designador de hilo.

Tras seleccionar el comando de colocación de interrupciones de hilo, sitúe el objeto de modo que su punto de conexión eléctrica (el extremo sujeto al cursor) toque el hilo al que desea conectarlo y, a continuación, haga clic o pulse Enter para colocarlo. Una interrupción de hilo colocada hereda las propiedades (designador y color) del hilo al que está conectada.

Seleccione una interrupción de hilo en el espacio de diseño para modificarla en el panel Properties. Desde el panel, puede definir el designador del hilo al que está conectada y su estilo: dirección (Left o Right) y color.

Sincronización de hilos

Los hilos del arnés conectados mediante una interrupción de hilo se reconocen incluso si tienen distintos ID de elemento de diseño. Además, se comparan todos los segmentos de hilo con el mismo designador conectados mediante la misma interrupción de hilo (número de pieza, comentario, color y todos los parámetros). Si se detecta alguna diferencia, se notifica la infracción Mismatched parameters in connected wire segments. También aparece una advertencia en el panel Properties del hilo y de la interrupción de hilo que indica que se ha detectado un conflicto entre los parámetros. Haga clic en Synchronize dentro de la advertencia para abrir el cuadro de diálogo Conflict Wire Parameters, que permite elegir qué parámetros utilizar para el segmento de hilo.

Propiedades y parámetros del hilo antes de la sincronización

Aparece una advertencia en el panel Properties que indica que existe un conflicto entre los parámetros. Al hacer clic en Synchronize en la advertencia, se abre el cuadro de diálogo Confirm Wire Parameters. Seleccione la opción deseada y haga clic en OK para realizar la sincronización.

La infracción Mismatched parameters in connected wire segments en el cuadro de diálogo Project Options

Tras la sincronización, las propiedades de los segmentos de hilo quedan sincronizadas. 

 
  • Tenga en cuenta que, al cambiar el color y el designador de una interrupción de hilo, el color y el designador del hilo al que está conectada se modifican en consecuencia y, a la inversa, al cambiar el color y el designador de un hilo, el color y el designador de la interrupción de hilo conectada a él se modifican en consecuencia.

  • También puede cambiar las propiedades de una interrupción de hilo durante su colocación pulsando Tab después de seleccionar el comando de colocación. Tenga en cuenta que, si se define un designador para la interrupción de hilo antes de colocarla, el hilo al que se conecte heredará el designador y el color de la interrupción de hilo.

  • Si se define un color de borde para un hilo al que está conectada una interrupción de hilo, esta también se mostrará con un borde de ese color. Además, el designador de la interrupción de hilo se mostrará en el color del borde del hilo conectado.

  • Las interrupciones de hilo no tienen propiedades de fuente independientes; utilizan las propiedades Document Font del documento de diagrama de cableado de arnés en el que se colocan.

  • Las interrupciones de hilo también se pueden utilizar para establecer conectividad dentro de una misma hoja de diagrama de cableado de arnés; por ejemplo, en lugar de colocar un hilo entre dos pines de conectores, puede colocar un hilo de arnés corto y una interrupción de hilo en cada uno de esos pines ().

Colocación de un componente de cableado de arnés

Cuando esté conectado a su Workspace, puede crear componentes con la estructura y las propiedades predefinidas que necesite en el Workspace conectado y, después, reutilizarlos en sus diseños de arneses, colocándolos directamente en documentos de diagrama de cableado de arnés.

Consulte la página Creación de un componente de cableado de arnés para obtener más información.

Se accede a estos componentes (cada uno con un modelo de cableado de arnés definido y asignado) desde el panel Components. Cuando el documento de diagrama de cableado de arnés deseado sea el documento activo en el espacio de diseño, coloque un componente haciendo clic con el botón derecho en su entrada del panel y seleccionando el comando Place <ComponentName> en el menú contextual. El comportamiento durante la colocación de un componente varía según si este incluye un único objeto de hilo o una estructura de cable (varios hilos u objetos adicionales: cables, blindajes, etc.).

  • Single wire – al colocar un componente que incluye un único objeto de hilo, se accede al modo de colocación de hilos de arnés. El hilo que se está colocando heredará las propiedades definidas durante la creación del componente. Consulte la sección Creación de conectividad en el diagrama de cableado de arnés anterior para obtener más información sobre la colocación de hilos de arnés.

  • Cable structure – al seleccionar el comando de colocación de un componente que incluye una estructura de cable, dicha estructura aparecerá unida al cursor exactamente como se definió durante la creación del componente. Haga clic en el lugar deseado del documento de diagrama de cableado de arnés para colocar el componente. Después podrá editar individualmente los objetos del componente, por ejemplo, para conectar los hilos que componen el cable a los pines de los conectores del arnés.

Actualización del diagrama de cableado desde las bibliotecas

Los siguientes objetos se pueden actualizar desde su biblioteca de origen del Workspace:

  • Componentes de arnés

  • Cavidades de los componentes de arnés

  • Piezas asociadas a los componentes de arnés

  • Hilos

Cuando se selecciona un objeto, la información sobre el componente vinculado del Workspace se encuentra en el panel Properties (por ejemplo, en la pestaña Associated Parts para las piezas asociadas a un componente de arnés).

Si hay disponible una revisión posterior del componente del Workspace, la entrada del estado de revisión lo indicará mediante el texto Out of date. Para cada objeto individual, el vínculo se puede actualizar a la última revisión del componente del Workspace haciendo clic en el botón .

Ejemplo de indicación de una revisión desactualizada de un componente de arnés​
Ejemplo de indicación de una revisión desactualizada de un componente de arnés

La función Update from Libraries (Tools » Update from Libraries) también se puede utilizar para actualizar los componentes desactualizados vinculados a los objetos enumerados anteriormente. Tenga en cuenta que, para incluir un objeto en la actualización mediante la función Update from Libraries, el componente asignado al objeto debe incluir un vínculo a un símbolo de esquema.

Anotación de objetos del diagrama de cableado de arnés

Utilice los comandos del menú Tools » Annotation para anotar los siguientes objetos del documento de diagrama de cableado de arnés:

  • Componentes de arnés

  • Hilos

  • Empalmes y derivaciones

  • Cables

  • Blindajes y blindajes con conexión

  • Trenzados

  • Objetos «Sin conexión»

La anotación de objetos en un documento de diagrama de cableado de arnés es similar a la anotación de componentes en un documento de esquema (*.SchDoc) de un proyecto de diseño de PCB. Utilice los siguientes enlaces para obtener más información sobre los comandos de anotación disponibles para un documento de diagrama de cableado de arnés:

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents