Creación y gestión de procesos

Altium Designer proporciona un potente entorno de diseño colaborativo. Parte de ello es la compatibilidad con Workflows, que guían a los diseñadores de una empresa a través de procesos de diseño típicos y cotidianos, tales como:

  • Solicitud de nuevas piezas de biblioteca del Workspace
  • Realización de revisiones de diseño
  • Creación de nuevos proyectos de Workspace.

Cada flujo de trabajo que se utiliza para implementar un proceso de diseño concreto se crea como parte de una Process Definition. Por lo tanto, puede denominarse el flujo de trabajo subyacente de ese proceso, o simplemente una Process Workflow.

Los procesos y sus flujos de trabajo se crean y administran a través de la interfaz del navegador del Workspace de Enterprise Server, por un administrador de ese Workspace.

Para las tres áreas de diseño mencionadas anteriormente, se incluyen flujos de trabajo de procesos predefinidos con la instalación del servidor. Algunos de ellos están activados para usarse desde el primer momento. Úselos, modifíquelos o cree los suyos propios según sea necesario, para adaptarlos a las necesidades de su empresa. Otros son ejemplos; estos no pueden activarse ni utilizarse tal cual. Por ello, cada uno de estos se parece más a una "plantilla": edítelo para adaptarlo a los requisitos de su empresa, asígnele un nombre y guárdelo como una nueva definición de proceso, que can luego activará y utilizará, junto con todas las demás definiciones.

Un potente Process Workflow Editor le brinda la flexibilidad de crear procesos con flujos de trabajo que pueden ser tan simples o tan complejos como se necesite, y en línea con los requisitos de su empresa.

Acceso a los procesos

Toda la administración de procesos se realiza desde el área Processes (Admin – Processes) de la interfaz del navegador del Workspace de Enterprise Server.

Debe haber iniciado sesión como administrador de su Workspace de Enterprise Server para poder ver el área Processes de la interfaz.

Acceso al área Processes de la interfaz del navegador del Workspace de Enterprise Server: el centro de control para trabajar con procesos y sus flujos de trabajo asociados.Acceso al área Processes de la interfaz del navegador del Workspace de Enterprise Server: el centro de control para trabajar con procesos y sus flujos de trabajo asociados.

La interfaz Processes se presenta en las siguientes cuatro pestañas:

  • Browser – proporciona un listado resumido de todos los procesos (activos o cerrados). Un "panel centralizado de procesos", por así decirlo.
  • Part Requests – proporciona un área dedicada para administrar los procesos relacionados con la temática de solicitud de piezas.
  • Project Activities – proporciona un área dedicada para administrar los procesos relacionados con la temática de trabajo con proyectos del Workspace, como revisiones de diseño y publicación en un sistema PLM.
  • Project Creations – proporciona un área dedicada para administrar los procesos relacionados con la temática de creación de nuevos proyectos de diseño en el Workspace.
Las tres últimas pestañas pueden denominarse Process Themes. Los temas de proceso permiten agrupar intuitivamente los distintos procesos por área de diseño. También permiten que el software facilite la creación de nuevos procesos, al admitir solo aquellos elementos del flujo de trabajo que se necesitan para un área concreta y, de este modo, simplificar la construcción del flujo de trabajo requerido. De cara al futuro, este enfoque proporciona una base para Altium mediante la cual ampliar la interfaz con la incorporación de nuevos temas, cuando sea necesario.

Las siguientes secciones examinan estas distintas pestañas con más detalle.

Pestaña Browser

Use esta pestaña para explorar de forma centralizada todos los procesos activos o cerrados, en todos los temas de proceso. De manera predeterminada, la pestaña presenta todos los procesos Active (en ejecución). Cambie a la visualización de todos los procesos Closed (por ejemplo, completados, rechazados o finalizados) usando el campo desplegable situado encima de la lista.

Explore todos los procesos activos desde una ubicación práctica. Pase el cursor sobre la imagen para ver un ejemplo de exploración de todos los procesos cerrados.
Explore todos los procesos activos desde una ubicación práctica. Pase el cursor sobre la imagen para ver un ejemplo de exploración de todos los procesos cerrados.

Para cada entrada, se presenta la siguiente información (cuando corresponda):

  • Status – el estado del proceso. Puede ser uno de los siguientes:
    • Active – el proceso está activo actualmente y su flujo de trabajo asociado está avanzando.
    • On hold – el proceso está activo actualmente, pero está a la espera de una entrada inicial, como la asignación de responsables, antes de que su flujo de trabajo pueda avanzar.
    • Closed – el proceso ya está cerrado; por ejemplo, se completó correctamente o fue rechazado.
    • Terminated – el proceso ya está cerrado y fue finalizado directamente por un administrador del Workspace.
  • Process Name – el nombre de la definición de proceso.
  • Title – este campo se utiliza para distinguir entre varias instancias del mismo proceso. El título es el nombre del proceso, con un sufijo de instancia (#1, #2, etc.).
  • State – este es el estado alcanzado actualmente dentro del flujo de trabajo asociado al proceso.
  • Assignee (solo proceso activo) – este es el usuario que ahora tiene una tarea que realizar para hacer avanzar el proceso desde su estado actual del flujo de trabajo.
  • Started By – el usuario que inició el proceso.
  • Started At – la fecha y la hora en que se inició el proceso.
  • Ended At (solo proceso cerrado) – la fecha y la hora en que se cerró el proceso.

Para un proceso activo, también hay un control Terminate (). Haga clic en él para finalizar forzosamente un proceso. El proceso pasará al listado de procesos Closed.

Los procesos pueden ordenarse por cualquier columna que tenga el control ; haga clic en el control o en el nombre de la columna. También es posible realizar búsquedas utilizando el campo Search situado en la parte superior de la lista. Los datos de todos los campos, excepto Status, Started At, Ended At y Terminate, pueden utilizarse para la búsqueda.
  • También puede importar una definición de proceso exportada previamente desde un archivo, directamente desde la pestaña Browser . Para ello, haga clic en el botón . En el cuadro de diálogo Open que aparece, navegue hasta el archivo de flujo de trabajo requerido y ábralo (*.aaw). Se detectará el tema de proceso correcto y el contenido del archivo se cargará en el Process Workflow Editor. Para más información, consulte Importación/Exportación de una definición de proceso.
  • Use el botón para exportar un informe de las actividades actualmente listadas (flujos de trabajo de procesos) como un archivo *.csv detallado delimitado por comas; ver ejemplo. Se pueden exportar actividades Active o Closed, y las entradas que se incluirán pueden filtrarse usando el campo Search de nombre del proceso. En el lado del diseño, el panel Explorer de Altium Designer incluye un botón equivalente, en la pestaña Activites al explorar un proyecto (usando la vista predeterminada Project ), para descargar los datos de las actividades actualmente listadas que se relacionan con ese proyecto.

Haga clic en una entrada de un proceso para ver un diagrama de su flujo de trabajo subyacente (en la pestaña Diagram debajo de la lista), que muestra qué debe ocurrir para que el proceso se complete y en qué punto del flujo se encuentra ese proceso, en términos de quién tiene ahora una tarea que realizar para hacerlo avanzar.

Haga clic en el control en la parte inferior derecha para resaltar el punto actual alcanzado en el flujo de trabajo; la entrada del/de los usuario(s) parpadeará momentáneamente.

Visualización del flujo de trabajo subyacente de un proceso seleccionado en su pestaña Diagram. Cada flujo de trabajo se crea de forma diagramática, lo que le permite ver de un vistazo en qué punto del flujo de trabajo se encuentra actualmente un proceso y quién tiene ahora la siguiente tarea para continuar el avance de ese proceso.Visualización del flujo de trabajo subyacente de un proceso seleccionado en su pestaña Diagram. Cada flujo de trabajo se crea de forma diagramática, lo que le permite ver de un vistazo en qué punto del flujo de trabajo se encuentra actualmente un proceso y quién tiene ahora la siguiente tarea para continuar el avance de ese proceso.

También están disponibles las siguientes pestañas adicionales:

  • Data – muestra todos los datos pertinentes del proceso. En un proceso de revisión de diseño, por ejemplo, esto puede incluir el proyecto y su conjunto de datos, el tipo de revisión, las personas involucradas en la revisión y cualquier archivo adjunto adicional. En un proceso de solicitud de piezas, esto puede incluir hojas de datos adjuntas, datos paramétricos y cualquier componente preliminar.

    Las entidades aplicables, como archivos adjuntos, hojas de datos, proyecto y conjunto de datos del proyecto (Item-Revision), aparecerán como hipervínculos para una navegación rápida o para abrirlos. También tiene la capacidad de configurar los datos paramétricos que serán visibles para el usuario estándar en esta pestaña. Al editar el flujo de trabajo de un proceso, y sin ningún elemento seleccionado, los datos que pueden presentarse en la pestaña Data se muestran en el panel derecho. Haga clic en el control Edit para acceder a su formulario relacionado (<ProcessName> Data).
  • History – muestra un historial de las acciones realizadas a lo largo del flujo de trabajo del proceso.

    Use las pestañas Data y History para explorar, respectivamente, más detalles del proceso y el rastro de actividad de su flujo de trabajo.Use las pestañas Data y History para explorar, respectivamente, más detalles del proceso y el rastro de actividad de su flujo de trabajo.

Pestañas Part Requests/Project Activities/Project Creations

Use estas pestañas, que reúnen procesos en temas específicos, para ver, crear y administrar flujos de trabajo de procesos que se utilizarán al solicitar una nueva pieza de biblioteca del Workspace, realizar revisiones de diseño o publicar en un sistema PLM, o crear nuevos proyectos de diseño, respectivamente.

De forma predeterminada, la región superior de una pestaña presenta todas las versiones Latest de los procesos definidos dentro del tema. Cambie a la visualización de los procesos definidos All (es decir, todas las versiones) utilizando el campo desplegable situado encima de la lista.

Ejemplo de exploración de las versiones más recientes de procesos definidos para un tema concreto (en este caso, el tema Project Activities).Ejemplo de exploración de las versiones más recientes de procesos definidos para un tema concreto (en este caso, el tema Project Activities).

Para cada entrada, se presenta la siguiente información:

  • Process Name : version – el nombre de la definición de proceso y su versión. Para asegurarse de que siempre está visualizando/trabajando con la versión más reciente, asegúrese de que el campo desplegable de versión situado encima de la lista esté establecido en Latest.
  • Instances (active / all) – el número de instancias de esta versión de la definición de proceso que están activas actualmente, junto con el número total de instancias que se han iniciado.
  • Created By – el usuario que ha creado esta versión de la definición de proceso.
  • Created At – la fecha y la hora en que se creó esta versión de la definición de proceso (se guardó y desplegó).
  • Active – muestra si esta versión de la definición de proceso está activa () y, por lo tanto, puede utilizarse, o si ha sido suspendida (), o si es una definición de ejemplo (plantilla) () y, por lo tanto, no puede utilizarse. Solo las definiciones de proceso activas aparecerán en el área correspondiente de la interfaz gráfica de Altium Designer, para su uso por los diseñadores. Haga clic en el icono para alternar el estado activo, cuando corresponda.

    Solo se puede utilizar (activar e iniciar) la versión más reciente de una definición de proceso. Las versiones anteriores no pueden utilizarse, pero sí pueden modificarse para producir una versión posterior. Además, las definiciones de proceso de ejemplo (cuyo estado Active se distingue por ) no pueden utilizarse listas para usar. Cada una de ellas se parece más a una "plantilla": edítela para adaptarla a los requisitos de su empresa, asígnele un nombre y guárdela como una nueva definición de proceso, que can luego activará y utilizará, junto con todas las demás definiciones.
  • Actions – haga clic en el control  para acceder a un menú de acciones para la definición de proceso:
    • Startcomo administrador, puede iniciar una nueva instancia de esta versión de la definición de proceso seleccionando este comando. Esto solo está disponible siempre que la definición de proceso haya sido activada. Si el proceso ha sido suspendido, o es una definición de ejemplo (plantilla), el comando aparecerá atenuado y no podrá iniciarse una instancia.
    • Edit – seleccione para modificar el flujo de trabajo subyacente de la definición de proceso. El diagrama de flujo de trabajo para esta versión de la definición de proceso se presentará en el Process Workflow Editor, como punto de partida para trabajar. Cualquier administrador puede modificar cualquier definición de proceso definida por el usuario, independientemente de quién la haya creado originalmente, y guardarla y desplegarla como la siguiente versión. Para las definiciones de proceso predeterminadas suministradas por Altium, puede crear una nueva definición de proceso basada en la edición de una de ellas (esencialmente una bifurcación), pero no puede modificar la predeterminada en sí. Para más información sobre la edición de una definición de proceso, consulte Edición de una definición de proceso existente.
    • Assign – seleccione para abrir la ventana Assign Access to This Workflow, desde donde puede definir qué usuarios y/o grupos pueden acceder al flujo de trabajo subyacente. Para más información sobre la administración del acceso a un flujo de trabajo, consulte Administración del acceso al flujo de trabajo del proceso.
    • Remove – seleccione para quitar (eliminar) esta versión de la definición de proceso. Tenga en cuenta que algunas de las definiciones de proceso predeterminadas suministradas por Altium no pueden eliminarse (y, por lo tanto, no tienen dicho control). Si se ha iniciado al menos una instancia de la definición de proceso, independientemente de si sigue activa o no, la definición no podrá eliminarse (el comando no aparecerá en el menú).
Las definiciones de proceso pueden ordenarse por cualquier columna que tenga el control ; haga clic en el control o en el nombre de la columna. También se pueden realizar búsquedas utilizando el campo Search situado en la parte superior de la lista. Los datos de las columnas Process Name : version y Created By pueden utilizarse para la búsqueda.

Haga clic en una entrada de una definición de proceso para ver su flujo de trabajo diagramático en la pestaña Diagram debajo de la lista. Si existe una instancia actualmente activa de un proceso, la vista mostrará en qué punto del flujo se encuentra ese proceso, en términos de quién tiene ahora una tarea que realizar para hacerlo avanzar.

Si varias instancias de un proceso están activas, la vista Diagram mostrará un estado combinado. Haga clic en el control en la parte inferior derecha para resaltar el punto actual alcanzado en el flujo de trabajo; la entrada del/de los usuario(s) parpadeará momentáneamente.

Visualización del flujo de trabajo subyacente de un proceso seleccionado en su pestaña Diagram.Visualización del flujo de trabajo subyacente de un proceso seleccionado en su pestaña Diagram.

Definiciones de proceso predeterminadas

Altium proporciona varias definiciones de proceso, en los tres temas de proceso, como parte de la instalación de Enterprise Server. Algunas de ellas están activadas para usarse desde el primer momento y pueden utilizarse tal cual, mientras que otras son ejemplos y no pueden activarse ni usarse directamente. Todas pueden utilizarse como punto de partida para crear sus propias definiciones de proceso según sea necesario. Use las siguientes secciones desplegables para acceder a información sobre las definiciones de proceso proporcionadas.

La instalación de Enterprise Server también incluye el proceso LibSync que sincroniza los datos de componentes entre Enterprise Server y una instancia de PLM de destino. Este es un flujo de trabajo de proceso "integrado" y de solo lectura, por lo que no es editable ni está incluido en la lista de procesos de la página Processes del Workspace (Admin » Processes). Consulte Sincronización de componentes con PLM para obtener más información.

Adición de una nueva definición de proceso

Related page: Definición de un flujo de trabajo de proceso

Los nuevos procesos pueden crearse utilizando el Process Workflow Editor dedicado. Para acceder al editor, active la pestaña del tema en el que desea crear su nuevo proceso y luego haga clic en el botón en la parte superior derecha de la página.

Es importante activar primero el tema para que el proceso se cree con el Type correcto.

Acceso al Process Workflow Editor. Asegurarse de activar el tema de proceso deseado antes del acceso garantizará que la nueva definición de proceso se establezca con el tipo de tema correcto.Acceso al Process Workflow Editor. Asegurarse de activar el tema de proceso deseado antes del acceso garantizará que la nueva definición de proceso se establezca con el tipo de tema correcto.

Asigne a su nueva definición de proceso un nombre significativo, luego construya el flujo de trabajo gráficamente y defina los aspectos requeridos de cada elemento de ese flujo. Para las tareas de usuario, se utiliza un User Form Editor para dar forma al formulario requerido que se presentará al usuario, para recibir su entrada cuando se le asigne una tarea en el punto correspondiente del flujo de trabajo.

El potente Process Workflow Editor le brinda la flexibilidad de crear procesos con flujos de trabajo que pueden ser tan simples o tan complejos como se necesite, y en línea con los requisitos de su empresa.El potente Process Workflow Editor le brinda la flexibilidad de crear procesos con flujos de trabajo que pueden ser tan simples o tan complejos como se necesite, y en línea con los requisitos de su empresa.

Una vez que se haya definido un proceso según sea necesario, haga clic en el botón para agregarlo a la lista de procesos disponibles para ese tema de proceso. La nueva definición de proceso quedará activada y lista para usarse.

El Editor marcará cualquier problema en su diagrama de flujo de trabajo que impida guardarlo y desplegarlo; por ejemplo, un diagrama debe tener un evento Start y al menos un evento End definido. Y una tarea de usuario debe tener al menos un campo de formulario y una persona asignada.

Edición de una definición de proceso existente

Cualquier administrador puede modificar cualquier definición de proceso definida por el usuario, independientemente de quién la haya creado originalmente, y guardarla y desplegarla como la siguiente versión. Para hacerlo, haga clic en el  control en la columna Actions de la definición de proceso que desea modificar y seleccione Edit del menú que aparece. El diagrama de flujo de trabajo para esta versión de la definición de proceso se mostrará en Process Workflow Editor, como punto de partida para trabajar.

Para las definiciones de proceso proporcionadas por Altium, puede crear una nueva definición de proceso basada en la edición de una de ellas (esencialmente, una bifurcación), pero no puede modificar el valor predeterminado en sí.

Ejemplo de edición de una definición de proceso existente: acceso a Process Workflow Editor, desde donde realizar los cambios necesarios.Ejemplo de edición de una definición de proceso existente: acceso a Process Workflow Editor, desde donde realizar los cambios necesarios.

Realice los cambios necesarios en el flujo de trabajo diagramático del proceso, incluidos los cambios en los formularios asociados a las tareas de usuario, y luego haga clic en el botón para guardar efectivamente la definición como la siguiente versión. En el ejemplo de aquí, la definición de proceso original Company Pre-release Review : 1 (versión 1) se modifica y se guarda para convertirse en Company Pre-release Review : 2 (versión 2).

Una vez realizadas las modificaciones, guarde y despliegue como la siguiente versión de esa definición de proceso.Una vez realizadas las modificaciones, guarde y despliegue como la siguiente versión de esa definición de proceso.

Usando el campo desplegable superior izquierdo y configurando la entrada en All, puede ver todas las versiones de las definiciones de proceso existentes. En la imagen de abajo, puede ver ambas versiones de la definición de proceso Company Pre-release Review.

Mostrando todas las versiones de la definición de proceso de ejemplo Company Pre-release Review. Tenga en cuenta que solo la versión más reciente (versión 2) puede activarse y utilizarse.Mostrando todas las versiones de la definición de proceso de ejemplo Company Pre-release Review. Tenga en cuenta que solo la versión más reciente (versión 2) puede activarse y utilizarse.

Solo puede usarse la versión más reciente de una definición de proceso (hacerse activa e iniciarse). Sin embargo, las versiones anteriores pueden utilizarse como punto de partida para crear una versión posterior. Si eliminara la versión más reciente de una definición de proceso, entonces la siguiente versión anterior pasará efectivamente a ser la más reciente, y podrá volver a activarse y utilizarse (iniciar instancias).

Importación/exportación de una definición de proceso

Las definiciones de proceso pueden exportarse e importarse, lo que le permite reutilizarlas rápidamente en distintas instancias de Enterprise Server, un verdadero ahorro de tiempo cuando el flujo de trabajo subyacente de un proceso puede ser particularmente complejo y tener que "reinventar la rueda", por así decirlo, sería una tarea abrumadora.

Para importar:

  1. Acceda a la pestaña de tema (Part Requests, Project Activities, Project Creations) correspondiente a la definición de proceso que desea importar.

    Si intenta importar una definición de proceso en el tema incorrecto, el software se lo advertirá y se impedirá la importación.
  2. Haga clic en el botón para crear una nueva definición de proceso y acceder a Process Workflow Editor.
  3. Haga clic en el botón . En el cuadro de diálogo Open que aparece, vaya hasta el archivo Workflow requerido (*.aaw) y ábralo. El contenido del archivo sobrescribirá por completo cualquier elemento definido actualmente para la definición de proceso (nombre, diagrama, etc.).
También puede importar una definición de proceso previamente exportada desde un archivo, directamente desde la pestaña Browser de la interfaz. Para ello, haga clic en el botón . En el cuadro de diálogo Open que aparece, vaya hasta el archivo Workflow requerido (*.aaw) y ábralo. Se detectará el tema de proceso correcto y el contenido del archivo se cargará en Process Workflow Editor.

Para exportar:

  1. Haga clic en el  control de la columna Actions para la versión requerida de la definición de proceso que desea exportar y seleccione Edit del menú que aparece para acceder al modo de edición.
  2. En Process Workflow Editor, haga clic en el botón . La definición de proceso se exportará como un archivo Workflow (<ProcessDefinitionName>.aaw) a la carpeta de descargas predeterminada definida para su navegador.
  3. Haga clic en la entrada Processes del árbol de navegación izquierdo de la interfaz del navegador del Workspace para salir de Process Workflow Editor sin realizar cambios en la definición de proceso.

Administración del acceso al flujo de trabajo del proceso

Como administrador, puede definir qué usuarios y/o grupos pueden acceder a un flujo de trabajo de proceso. Para ello, haga clic en el  control de la columna Actions para la definición de proceso cuyo acceso al flujo de trabajo subyacente desea configurar y seleccione Assign del menú que aparece. Se abrirá la ventana Assign Access to This Workflow.

Comience a escribir el nombre completo o el nombre de usuario de un usuario, o el nombre de un grupo, en el campo de texto para hacer aparecer una lista de usuarios/grupos coincidentes. Se pueden agregar varios usuarios/grupos. Para quitar a un usuario/grupo agregado del acceso al flujo de trabajo, haga clic en la cruz de eliminación situada a la derecha de su nombre.

Con los usuarios/grupos definidos según sea necesario, haga clic en para aplicar la asignación del flujo de trabajo. El flujo de trabajo ahora estará disponible solo para los usuarios/grupos agregados (y los miembros del grupo Administrators) cuando se acceda a él como se describe en la sección Acceso del diseñador a los flujos de trabajo de proceso a continuación.

Como se indica en la ventana Assign Access to This Workflow, si no se agrega ningún usuario/grupo, el flujo de trabajo estará disponible para todos los usuarios.

Acceso del diseñador a los flujos de trabajo de proceso

Related pages: Realización de revisiones de diseño, Publicación en un PLM, Solicitudes de piezas basadas en procesos

Una vez que el conjunto requerido de definiciones de proceso para cada tema de proceso disponible se haya creado según las necesidades de su empresa, aquellas definiciones que estén activadas estarán disponibles para su uso por los usuarios asignados una vez que estén conectados al Workspace de Enterprise Server. Las siguientes secciones muestran dónde puede un diseñador acceder e iniciar estos procesos activos, tanto a través de Altium Designer como de la interfaz del navegador del Workspace.

Los administradores del Workspace pueden, como se mencionó anteriormente, iniciar una nueva instancia de cualquier definición de proceso activada, directamente desde la pestaña del tema de proceso correspondiente dentro del área Processes de la interfaz del navegador del Workspace, haciendo clic en el  control de la columna Actions y seleccionando Start en el menú que aparece.

Solicitudes de piezas

Related page: Solicitudes de piezas basadas en procesos

Desde Altium Designer, las definiciones de proceso activadas que forman parte del tema Solicitudes de piezas pueden consultarse en los siguientes lugares:

  • Desde el panel Components. Haga clic con el botón derecho dentro del área principal del panel: las definiciones de proceso activas de solicitud de piezas están disponibles en el submenú Operations » Submit Request. Como alternativa, haga clic en el enlace Submit request bajo la sección Need more components?.

Si no hay definiciones de proceso activas disponibles para el tema de proceso Solicitudes de piezas, no se mostrará el submenú Submit Request. Es posible que deba cerrar sesión en el Workspace y volver a iniciarla, o reiniciar Altium Designer, para actualizar.
  • Desde el panel Manufacturer Part Search. Si el elemento de búsqueda actualmente seleccionado tiene el icono , el panel Information (al que se accede haciendo clic en ) mostrará el botón . Haga clic en la parte desplegable del botón para acceder a un menú con las definiciones de proceso activas de solicitud de piezas. Si hace clic directamente en la parte principal del botón, se iniciará la primera definición de proceso de la lista.
Solicitar una pieza a través del panel Manufacturer Part Search aporta la ventaja adicional de que se completará automáticamente información clave, incluidas todas las hojas de datos y la información paramétrica.

Si no hay definiciones de proceso activas disponibles para el tema de proceso Solicitudes de piezas, no se mostrará el botón . Es posible que deba cerrar sesión en el Workspace y volver a iniciarla, o reiniciar Altium Designer, para actualizar.

Si el elemento de búsqueda actualmente seleccionado tiene un icono , las definiciones de proceso activas de solicitud de piezas estarán disponibles en el menú asociado al botón (haga clic en la parte desplegable del botón).

Las definiciones de proceso activas de solicitud de piezas también pueden consultarse desde el menú contextual del área principal del panel, en el submenú Submit Request.

Si no hay definiciones de proceso activas disponibles para el tema de proceso Solicitudes de piezas, no se mostrará el submenú Submit Request. Es posible que deba cerrar sesión en el Workspace y volver a iniciarla, o reiniciar Altium Designer, para actualizar.
  • Desde el panel Explorer, en la carpeta Part requests o después de haber realizado una búsqueda. Estará disponible el botón , que al pulsarlo mostrará las definiciones de proceso activas de solicitud de piezas entre las que podrá elegir.

Tenga en cuenta que, si la función Legacy Part Requests ha sido habilitada, entonces el botón aparecerá como . También aparecerá en el menú una entrada adicional relacionada con nuevas solicitudes de piezas que usen esa funcionalidad heredada. Esta tendrá el sufijo (Legacy). Si no hay definiciones de proceso activas disponibles para el tema de proceso Solicitudes de piezas, y la función Legacy Part Requests no está habilitada, no se mostrará el botón Submit Request. Es posible que deba cerrar sesión en el Workspace y volver a iniciarla, o reiniciar Altium Designer, para actualizar.

Desde la interfaz del navegador del Workspace, las definiciones de proceso activadas que forman parte del tema Solicitudes de piezas pueden consultarse desde la página Part Requests, haciendo clic en el botón en la parte superior derecha de la página.

Acceso a las definiciones activadas de Solicitudes de piezas desde la página Part Requests de la interfaz del navegador del Workspace.Acceso a las definiciones activadas de Solicitudes de piezas desde la página Part Requests de la interfaz del navegador del Workspace.

Si no hay definiciones de proceso activas disponibles para el tema de proceso Solicitudes de piezas, el botón no estará disponible. Si solo existe una definición de proceso, el botón no aparecerá con funcionalidad desplegable y ese proceso se iniciará inmediatamente al hacer clic.

Actividades del proyecto

Related pages: Realización de revisiones de diseño, Publicación en un PLM, Integración con PLM.

Las definiciones de proceso activadas que forman parte del tema Actividades del proyecto pueden consultarse en varios lugares.

Revisión de diseño y publicación estándar en PLM

Desde Altium Designer, las definiciones de proceso activadas de revisión de diseño y publicación, que forman parte del tema Actividades del proyecto, pueden consultarse desde el submenú contextual Project Activities, al que se accede haciendo clic con el botón derecho en la entrada del proyecto de diseño en el panel Projects, o desde el menú principal Project » Project Activities.

Si no hay definiciones de proceso activas de revisión de diseño y publicación estándar en PLM disponibles para el tema de proceso Actividades del proyecto, los menús no serán visibles.

Desde la interfaz del navegador del Workspace, las definiciones de proceso activadas de revisión de diseño y publicación, que forman parte del tema Actividades del proyecto, pueden consultarse desde la página Projects de la interfaz. Seleccione el proyecto requerido y, a continuación, haga clic en el botón .

Acceso a definiciones activadas de Actividades del proyecto (revisión de diseño y publicación estándar en PLM) para un proyecto del Workspace, dentro del área Projects de la interfaz del navegador del Workspace.Acceso a definiciones activadas de Actividades del proyecto (revisión de diseño y publicación estándar en PLM) para un proyecto del Workspace, dentro del área Projects de la interfaz del navegador del Workspace.

Si no hay definiciones de proceso activas de revisión de diseño y publicación estándar en PLM disponibles para el tema de proceso Actividades del proyecto, no se mostrará el botón .

Publicación en PLM mediante Project Releaser

Desde Altium Designer, el proceso para publicar en una instancia de PLM como parte de Project Releaser puede consultarse desde el submenú Project » Project Releaser del proyecto activo, o haciendo clic con el botón derecho en la entrada del proyecto de diseño en el panel Projects y eligiendo el proceso desde la entrada Project Releaser del menú contextual.

Creaciones de proyectos

Desde Altium Designer, las definiciones de proceso activadas que forman parte del tema Creaciones de proyectos pueden consultarse en tres lugares:

  • Desde el submenú principal File » New » Project in <WorkspaceName>.

  • Desde el submenú contextual Convert to Managed Project, al que se accede haciendo clic con el botón derecho en la entrada de un proyecto local en el panel Projects.

  • Desde el submenú contextual Clone, al que se accede haciendo clic con el botón derecho en la entrada de un proyecto en el cuadro de diálogo Open Project dialog cuando se selecciona la ubicación del Workspace.

Tenga en cuenta que cuando al menos una definición de proceso para el tema de proceso Creaciones de proyectos está activa, la capacidad de crear un nuevo proyecto de Workspace mediante el cuadro de diálogo Create Project dialog (File » New » Project) queda deshabilitada: el Workspace conectado no está disponible como ubicación de destino. Los proyectos de tipo (Local) y VCS pueden crearse normalmente a través de este cuadro de diálogo.

Si no hay definiciones de proceso activas disponibles para el tema de proceso Creaciones de proyectos, que es el caso predeterminado en una instalación nueva de Enterprise Server, los menús de proceso no serán visibles y podrá crear un proyecto de Workspace mediante el cuadro de diálogo Create Project como de costumbre.

Tenga en cuenta también que en esta configuración predeterminada el comando Convert to Managed Project cambia a Make Project Available on Server.

Desde la interfaz del navegador del Workspace, las definiciones de proceso activadas que forman parte del tema Creaciones de proyectos pueden consultarse en los siguientes lugares:

  • Desde la página principal Projects de la interfaz, haciendo clic en el botón .

Acceso a definiciones activadas de Creaciones de proyectos desde el área principal Projects de la interfaz del navegador del Workspace.Acceso a definiciones activadas de Creaciones de proyectos desde el área principal Projects de la interfaz del navegador del Workspace.

  • Desde la página Projects de la interfaz, cuando se desea clonar un proyecto concreto. Seleccione el proyecto requerido y, a continuación, haga clic en el botón para acceder a los procesos del menú.

Acceso a definiciones activadas de Creaciones de proyectos cuando se desea clonar un proyecto del Workspace, dentro del área Projects de la interfaz del navegador del Workspace.Acceso a definiciones activadas de Creaciones de proyectos cuando se desea clonar un proyecto del Workspace, dentro del área Projects de la interfaz del navegador del Workspace.

  • Si no hay definiciones de proceso activas disponibles para el tema de proceso Creaciones de proyectos, que es el caso predeterminado en una instalación nueva de Enterprise Server, el menú ofrecerá la funcionalidad básica de clonación de proyectos (Clone). Esto no está relacionado con la funcionalidad de flujo de trabajo de procesos.
  • Para utilizar Constraint Manager para administrar las restricciones de diseño de su proyecto PCB de Workspace basado en procesos, asegúrese de asignar una plantilla de proyecto adecuada al crear dicho proyecto. Esta debe ser una plantilla guardada a partir de un proyecto PCB que se haya creado con la opción Constraint Management habilitada en el cuadro de diálogo Create Project dialog.
AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Contenido