Création et gestion des processus

Altium Designer offre un puissant environnement de conception collaborative. Une partie de celui-ci repose sur la prise en charge de Workflows, qui guident les concepteurs d'une entreprise à travers des processus de conception typiques et quotidiens, tels que :

  • Demander de nouveaux composants de bibliothèque Workspace
  • Effectuer des revues de conception
  • Créer de nouveaux projets Workspace.

Chaque workflow utilisé pour mettre en œuvre un processus de conception particulier est créé dans le cadre d'une Process Definition. Il peut donc être considéré comme le workflow sous-jacent de ce processus, ou simplement comme une Process Workflow.

Les processus, ainsi que leurs workflows, sont créés et gérés via l'interface navigateur du Workspace Enterprise Server, par un administrateur de ce Workspace.

Pour les trois domaines de conception mentionnés précédemment, des workflows de processus prédéfinis sont inclus avec l'installation de votre serveur. Certains sont activés et prêts à l'emploi. Vous pouvez les utiliser tels quels, les modifier ou créer les vôtres selon les besoins de votre entreprise. D'autres sont des exemples : ils ne peuvent pas être activés ni utilisés tels quels. Chacun d'eux s'apparente donc davantage à un « modèle » : modifiez-le selon les exigences de votre entreprise, nommez-le et enregistrez-le comme une nouvelle définition de processus, que vous can activerez ensuite et utiliserez avec toutes les autres définitions.

Un puissant Process Workflow Editor vous offre la flexibilité nécessaire pour créer des processus avec des workflows aussi simples ou aussi complexes que nécessaire, en accord avec les exigences de votre entreprise.

Accéder aux processus

Toute la gestion des processus s'effectue depuis la zone Processes (Admin – Processes) de l'interface navigateur du Workspace Enterprise Server.

Vous devez être connecté en tant qu'administrateur de votre Workspace Enterprise Server pour voir la zone Processes de l'interface.

Accès à la zone Processes de l'interface navigateur du Workspace Enterprise Server – le centre de commande pour travailler avec les processus et leurs workflows associés.Accès à la zone Processes de l'interface navigateur du Workspace Enterprise Server – le centre de commande pour travailler avec les processus et leurs workflows associés.

L'interface Processes se présente sous les quatre onglets suivants :

  • Browser – fournit une liste récapitulative de tous les processus (actifs ou fermés). Un « tableau de bord des processus » centralisé, en quelque sorte.
  • Part Requests – fournit une zone dédiée à la gestion des processus liés au thème des demandes de composants.
  • Project Activities – fournit une zone dédiée à la gestion des processus liés au thème du travail avec les projets Workspace, comme les revues de conception et la publication vers un système PLM.
  • Project Creations – fournit une zone dédiée à la gestion des processus liés au thème de la création de nouveaux projets de conception Workspace.
Les trois derniers onglets peuvent être appelés Process Themes. Les thèmes de processus permettent de regrouper intuitivement les différents processus par domaine de conception. Ils permettent également au logiciel de prendre en charge la création de nouveaux processus en ne proposant que les éléments de workflow nécessaires à un domaine particulier, ce qui simplifie la construction du workflow requis. À l'avenir, cette approche fournit à Altium une base permettant d'étendre l'interface par l'ajout de nouveaux thèmes selon les besoins.

Les sections suivantes examinent plus en détail ces différents onglets.

Onglet Browser

Utilisez cet onglet pour parcourir de manière centralisée tous les processus actifs ou fermés, dans tous les thèmes de processus. Par défaut, l'onglet présente tous les processus Active (en cours). Passez à l'affichage de tous les processus Closed (par exemple terminés, rejetés ou interrompus) à l'aide de la liste déroulante au-dessus de la liste.

Parcourez tous les processus actifs depuis un emplacement pratique. Survolez l'image pour voir un exemple de navigation parmi tous les processus fermés.
Parcourez tous les processus actifs depuis un emplacement pratique. Survolez l'image pour voir un exemple de navigation parmi tous les processus fermés.

Pour chaque entrée, les informations suivantes sont présentées (le cas échéant) :

  • Status – l'état du processus. Il peut être l'un des suivants :
    • Active – le processus est actuellement actif et son workflow associé est en cours.
    • On hold – le processus est actuellement actif, mais il attend une entrée initiale, comme l'affectation d'un responsable, avant que son workflow ne puisse progresser.
    • Closed – le processus est maintenant fermé, par exemple parce qu'il a été mené à bien ou rejeté.
    • Terminated – le processus est maintenant fermé et a été interrompu directement par un administrateur du Workspace.
  • Process Name – le nom de la définition du processus.
  • Title – ce champ est utilisé pour distinguer plusieurs instances d'un même processus. Le titre est le nom du processus, avec un suffixe d'instance (#1, #2, etc.).
  • State – il s'agit de l'état actuellement atteint dans le workflow associé au processus.
  • Assignee (processus actif uniquement) – il s'agit de l'utilisateur qui a maintenant une tâche à effectuer pour faire avancer le processus depuis son état actuel dans le workflow.
  • Started By – l'utilisateur qui a initié le processus.
  • Started At – la date et l'heure auxquelles le processus a été démarré.
  • Ended At (processus fermé uniquement) – la date et l'heure auxquelles le processus a été fermé.

Pour un processus actif, il existe également une commande Terminate (). Cliquez dessus pour mettre fin de force à un processus. Le processus sera déplacé vers la liste des processus Closed.

Les processus peuvent être triés selon toute colonne possédant la commande – cliquez sur la commande ou sur le nom de la colonne. Il est également possible d'effectuer une recherche à l'aide du champ Search en haut de la liste. Les données de tous les champs, à l'exception de Status, Started At, Ended At et Terminate, peuvent être utilisées pour la recherche.
  • Vous pouvez également importer une définition de processus précédemment exportée depuis un fichier, directement depuis l'onglet Browser . Pour ce faire, cliquez sur le bouton . Dans la boîte de dialogue Open qui apparaît, accédez au fichier Workflow requis (*.aaw) et ouvrez-le. Le thème de processus correct sera détecté et le contenu du fichier sera chargé dans le Process Workflow Editor. Pour plus d'informations, voir Importing/Exporting a Process Definition.
  • Utilisez le bouton pour exporter un rapport des activités actuellement listées (Process Workflows) sous la forme d'un fichier *.csv détaillé, délimité par des virgules – voir un exemple. Les activités Active ou Closed peuvent être exportées, et les entrées à inclure peuvent être filtrées à l'aide du champ Search du nom du processus. Côté conception, le panneau Explorer panel d'Altium Designer inclut un bouton équivalent – sous l'onglet Activites lors de la consultation d'un projet (en utilisant la vue par défaut Project ) – pour télécharger les données des activités actuellement listées relatives à ce projet.

Cliquez sur une entrée correspondant à un processus pour afficher un diagramme de son workflow sous-jacent (dans l'onglet Diagram sous la liste), montrant ce qui doit se produire pour que le processus soit achevé et où en est ce processus dans son flux, notamment en termes de personne ayant maintenant une tâche à exécuter pour le faire avancer.

Cliquez sur la commande en bas à droite pour mettre en évidence le point actuellement atteint dans le workflow – l'entrée du ou des utilisateurs clignotera momentanément.

Affichage du workflow sous-jacent d'un processus sélectionné dans son onglet Diagram. Chaque workflow est construit sous forme de diagramme, ce qui vous permet de voir en un coup d'œil à quel endroit du workflow se situe actuellement un processus, et qui a désormais la prochaine tâche pour poursuivre l'avancement de ce processus.Affichage du workflow sous-jacent d'un processus sélectionné dans son onglet Diagram. Chaque workflow est construit sous forme de diagramme, ce qui vous permet de voir en un coup d'œil à quel endroit du workflow se situe actuellement un processus, et qui a désormais la prochaine tâche pour poursuivre l'avancement de ce processus.

Les onglets supplémentaires suivants sont également disponibles :

  • Data – affiche toutes les données pertinentes pour le processus. Pour un processus de revue de conception par exemple, cela peut inclure le projet et son jeu de données, le type de revue, les personnes impliquées dans la revue et toute pièce jointe supplémentaire. Pour un processus de demande de composant, cela peut inclure des fiches techniques jointes, des données paramétriques et d'éventuels composants préliminaires.

    Les entités applicables, telles que les pièces jointes, les fiches techniques, le projet et le jeu de données du projet (Item-Revision), apparaîtront sous forme d'hyperliens pour une navigation ou une ouverture rapide. Vous avez également la possibilité de configurer les données paramétriques visibles pour l'utilisateur standard sur cet onglet. Lors de la modification du workflow d'un processus, et lorsqu'aucun élément n'est sélectionné, les données pouvant être présentées dans l'onglet Data sont listées dans le volet de droite. Cliquez sur la commande Edit pour accéder au formulaire associé (<ProcessName> Data).
  • History – affiche l'historique des actions effectuées tout au long du workflow du processus.

    Utilisez les onglets Data et History pour parcourir respectivement plus de détails sur le processus et l'historique de son activité de workflow.Utilisez les onglets Data et History pour parcourir respectivement plus de détails sur le processus et l'historique de son activité de workflow.

Onglets Part Requests/Project Activities/Project Creations

Utilisez ces onglets – qui regroupent les processus par thèmes spécifiques – pour afficher, créer et gérer les workflows de processus destinés respectivement à la demande d'un nouveau composant de bibliothèque Workspace, à l'exécution de revues de conception ou à la publication vers un système PLM, ou à la création de nouveaux projets de conception.

Par défaut, la région supérieure d'un onglet présente toutes les versions Latest des processus définis dans le thème. Passez à l'affichage des processus définis All (c'est-à-dire toutes les versions) à l'aide de la liste déroulante au-dessus de la liste.

Exemple de navigation parmi les dernières versions des processus définis pour un thème particulier (dans ce cas, le thème Project Activities).Exemple de navigation parmi les dernières versions des processus définis pour un thème particulier (dans ce cas, le thème Project Activities).

Pour chaque entrée, les informations suivantes sont présentées :

  • Process Name : version – le nom de la définition du processus et sa version. Pour vous assurer de toujours afficher/utiliser la dernière version, veillez à ce que la liste déroulante des versions au-dessus de la liste soit définie sur Latest.
  • Instances (active / all) – le nombre d'instances de cette version de la définition de processus qui sont actuellement actives, ainsi que le nombre total d'instances qui ont été démarrées.
  • Created By – l'utilisateur qui a créé cette version de la définition du processus.
  • Created At – la date et l'heure auxquelles cette version de la définition du processus a été créée (enregistrée et déployée).
  • Active – indique si cette version de la définition du processus est active () et peut donc être utilisée, ou si elle a été suspendue (), ou s'il s'agit d'une définition exemple (modèle) () et ne peut donc pas être utilisée. Seules les définitions de processus actives apparaîtront dans la zone correspondante de l'interface graphique d'Altium Designer, pour être utilisées par les concepteurs. Cliquez sur l'icône pour basculer l'état actif, le cas échéant.

    Seule la dernière version d'une définition de processus peut être utilisée (rendue active et démarrée). Les versions précédentes ne peuvent pas être utilisées, mais elles peuvent être modifiées pour produire une version ultérieure. De plus, les définitions de processus exemple (dont l'état Active est distingué par ) ne peuvent pas être utilisées telles quelles. Chacune d'elles s'apparente davantage à un « modèle » : modifiez-la selon les exigences de votre entreprise, nommez-la et enregistrez-la comme une nouvelle définition de processus, que vous can activerez ensuite et utiliserez avec toutes les autres définitions.
  • Actions – cliquez sur la commande  pour accéder à un menu d'actions pour la définition du processus :
    • Starten tant qu'administrateur, vous pouvez démarrer une nouvelle instance de cette version de la définition du processus en sélectionnant cette commande. Cela n'est disponible que si la définition du processus a été activée. Si le processus a été suspendu, ou s'il s'agit d'une définition exemple (modèle), la commande est grisée et une instance ne peut pas être démarrée.
    • Edit – sélectionnez cette option pour modifier le workflow sous-jacent de la définition du processus. Le diagramme de workflow de cette version de la définition du processus sera présenté dans le Process Workflow Editor, comme point de départ pour le travail. Tout administrateur peut modifier toute définition de processus définie par l'utilisateur, indépendamment de la personne qui l'a créée à l'origine, et l'enregistrer puis la déployer comme version suivante. Pour les définitions de processus par défaut fournies par Altium, vous pouvez créer une nouvelle définition de processus basée sur la modification de l'une d'elles (en substance, un fork), mais vous ne pouvez pas modifier directement une définition par défaut. Pour plus d'informations sur la modification d'une définition de processus, voir Editing an Existing Process Definition.
    • Assign – sélectionnez cette option pour ouvrir la fenêtre Assign Access to This Workflow, à partir de laquelle vous pouvez définir quels utilisateurs et/ou groupes peuvent accéder au workflow sous-jacent. Pour plus d'informations sur la gestion de l'accès à un workflow, voir Managing Process Workflow Access.
    • Remove – sélectionnez cette option pour supprimer cette version de la définition du processus. Notez que certaines définitions de processus par défaut fournies par Altium ne peuvent pas être supprimées (et ne disposent donc pas d'une telle commande). Si au moins une instance de la définition du processus a été démarrée, qu'elle soit encore active ou non, la définition ne peut pas être supprimée (la commande ne sera pas listée dans le menu).
Les définitions de processus peuvent être triées selon toute colonne possédant la commande – cliquez sur la commande ou sur le nom de la colonne. Il est également possible d'effectuer une recherche à l'aide du champ Search en haut de la liste. Les données des colonnes Process Name : version et Created By peuvent être utilisées pour la recherche.

Cliquez sur une entrée correspondant à une définition de processus pour afficher son workflow schématique dans l'onglet Diagram sous la liste. S'il existe une instance actuellement active d'un processus, la vue indiquera où ce processus se trouve dans son flux, notamment en termes de personne ayant maintenant une tâche à exécuter pour le faire avancer.

Si plusieurs instances d'un processus sont actives, la vue Diagram affichera un état combiné. Cliquez sur la commande en bas à droite pour mettre en évidence le point actuellement atteint dans le workflow – l'entrée du ou des utilisateurs clignotera momentanément.

Affichage du workflow sous-jacent d'un processus sélectionné dans son onglet Diagram.Affichage du workflow sous-jacent d'un processus sélectionné dans son onglet Diagram.

Définitions de processus par défaut

Un certain nombre de définitions de processus sont fournies par Altium – dans les trois thèmes de processus – dans le cadre de l'installation d'Enterprise Server. Certaines sont activées et prêtes à l'emploi, et peuvent être utilisées telles quelles, tandis que d'autres sont des exemples et ne peuvent pas être activées ni utilisées directement. Toutes peuvent servir de point de départ pour créer vos propres définitions de processus selon les besoins. Utilisez les sections repliables suivantes pour accéder aux informations sur les définitions de processus fournies.

L'installation d'Enterprise Server inclut également le processus LibSync qui synchronise les données des composants entre Enterprise Server et une instance PLM cible. Il s'agit d'un workflow de processus intégré en lecture seule et il n'est donc ni modifiable, ni inclus dans la liste des processus sur la page Processes du Workspace (Admin » Processes). Voir PLM Component Synchronization pour plus d'informations.

Ajout d'une nouvelle définition de processus

Related page: Définition d'un workflow de processus

De nouveaux processus peuvent être créés à l'aide du Process Workflow Editor dédié. Pour accéder à l'éditeur, activez l'onglet du thème dans lequel vous souhaitez créer votre nouveau processus, puis cliquez sur le bouton en haut à droite de la page.

Il est important d'activer d'abord le thème afin que le processus soit créé avec le bon Type.

Accès au Process Workflow Editor. S'assurer que le thème de processus souhaité est actif avant l'accès garantira que la nouvelle définition de processus sera définie sur le bon type de thème.Accès au Process Workflow Editor. S'assurer que le thème de processus souhaité est actif avant l'accès garantira que la nouvelle définition de processus sera définie sur le bon type de thème.

Donnez à votre nouvelle définition de processus un nom explicite, puis construisez le workflow graphiquement et définissez les aspects requis de chaque élément de ce flux. Pour les tâches utilisateur, un User Form Editor est utilisé pour concevoir le formulaire requis qui sera présenté à l'utilisateur afin de recueillir ses informations lorsqu'une tâche lui est attribuée au point correspondant du workflow.

Le puissant Process Workflow Editor vous offre la flexibilité nécessaire pour créer des processus avec des workflows aussi simples ou aussi complexes que nécessaire, en accord avec les exigences de votre entreprise.Le puissant Process Workflow Editor vous offre la flexibilité nécessaire pour créer des processus avec des workflows aussi simples ou aussi complexes que nécessaire, en accord avec les exigences de votre entreprise.

Une fois qu'un processus a été défini comme requis, cliquez sur le bouton pour l'ajouter à la liste des processus disponibles pour ce thème de processus. La nouvelle définition de processus sera activée et prête à être utilisée.

L'éditeur signalera tout problème dans votre diagramme de workflow empêchant son enregistrement et son déploiement – par exemple, un diagramme doit comporter un événement Start et au moins un événement End défini. Et une tâche utilisateur doit comporter au moins un champ de formulaire et un responsable.

Modification d'une définition de processus existante

Tout administrateur peut modifier toute définition de processus définie par l'utilisateur, indépendamment de la personne qui l'a créée à l'origine, puis l'enregistrer et la déployer comme version suivante. Pour ce faire, cliquez sur la  contrôle dans la colonne Actions pour la définition de processus que vous souhaitez modifier, puis sélectionnez Edit dans le menu qui apparaît. Le diagramme du workflow pour cette version de la définition de processus sera présenté dans le Process Workflow Editor, comme point de départ pour votre travail.

Pour les définitions de processus fournies par Altium, vous pouvez créer une nouvelle définition de processus en modifiant l’une d’elles (autrement dit en la forkant), mais vous ne pouvez pas modifier directement une définition par défaut.

Exemple de modification d’une définition de processus existante – accès au Process Workflow Editor, à partir duquel effectuer les changements requis.Exemple de modification d’une définition de processus existante – accès au Process Workflow Editor, à partir duquel effectuer les changements requis.

Apportez les modifications nécessaires au workflow schématique du processus, y compris aux formulaires associés aux tâches utilisateur, puis cliquez sur le bouton pour enregistrer effectivement la définition comme version suivante. Dans l’exemple présenté ici, la définition de processus d’origine Company Pre-release Review : 1 (version 1) est modifiée et enregistrée pour devenir Company Pre-release Review : 2 (version 2).

Une fois les modifications effectuées, enregistrez et déployez comme version suivante de cette définition de processus.Une fois les modifications effectuées, enregistrez et déployez comme version suivante de cette définition de processus.

En utilisant la liste déroulante en haut à gauche et en définissant l’entrée sur All, vous pouvez voir toutes les versions des définitions de processus existantes. Dans l’image ci-dessous, vous pouvez voir les deux versions de la définition de processus Company Pre-release Review.

Affichage de toutes les versions de l’exemple de définition de processus Company Pre-release Review. Notez que seule la version la plus récente (version 2) peut être activée et utilisée.Affichage de toutes les versions de l’exemple de définition de processus Company Pre-release Review. Notez que seule la version la plus récente (version 2) peut être activée et utilisée.

Seule la version la plus récente d’une définition de processus peut être utilisée (rendue active et démarrée). Les versions précédentes peuvent toutefois servir de point de départ pour construire une version ultérieure. Si vous supprimiez la dernière version d’une définition de processus, la version précédente deviendrait alors effectivement la plus récente, et pourrait de nouveau être activée et utilisée (instances démarrées).

Importation/exportation d’une définition de processus

Les définitions de processus peuvent être exportées et importées, ce qui vous permet de les réutiliser rapidement entre différentes instances d’Enterprise Server — un véritable gain de temps lorsque le workflow sous-jacent d’un processus est particulièrement complexe et qu’il faudrait autrement, pour ainsi dire, « réinventer la roue ».

Pour importer :

  1. Accédez à l’onglet de thème (Part Requests, Project Activities, Project Creations) correspondant à la définition de processus que vous souhaitez importer.

    Si vous tentez d’importer une définition de processus dans le mauvais thème, le logiciel vous en avertira et l’importation sera empêchée.
  2. Cliquez sur le bouton pour créer une nouvelle définition de processus et accéder au Process Workflow Editor.
  3. Cliquez sur le bouton . Dans la boîte de dialogue Open qui apparaît, recherchez puis ouvrez le fichier Workflow requis (*.aaw). Le contenu du fichier remplacera complètement tout ce qui est actuellement défini pour la définition de processus (nom, diagramme, etc.).
Vous pouvez également importer depuis un fichier une définition de processus précédemment exportée, directement depuis l’onglet Browser de l’interface. Pour ce faire, cliquez sur le bouton . Dans la boîte de dialogue Open qui apparaît, recherchez puis ouvrez le fichier Workflow requis (*.aaw). Le thème de processus correct sera détecté et le contenu du fichier sera chargé dans le Process Workflow Editor.

Pour exporter :

  1. Cliquez sur le contrôle  dans la colonne Actions pour la version requise de la définition de processus que vous souhaitez exporter, puis sélectionnez Edit dans le menu qui apparaît afin d’accéder au mode d’édition.
  2. Dans le Process Workflow Editor, cliquez sur le bouton . La définition de processus sera exportée sous forme de fichier Workflow (<ProcessDefinitionName>.aaw) dans le dossier de téléchargements par défaut défini pour votre navigateur.
  3. Cliquez sur l’entrée Processes dans l’arborescence de navigation de gauche de l’interface navigateur du Workspace pour quitter le Process Workflow Editor sans apporter de modification à la définition de processus.

Gestion de l’accès au workflow de processus

En tant qu’administrateur, vous pouvez définir quels utilisateurs et/ou groupes peuvent accéder à un workflow de processus. Pour ce faire, cliquez sur le contrôle  dans la colonne Actions pour la définition de processus dont vous souhaitez configurer l’accès au workflow sous-jacent, puis sélectionnez Assign dans le menu qui apparaît. La fenêtre Assign Access to This Workflow s’ouvrira.

Commencez à saisir le nom complet ou le nom d’utilisateur d’un utilisateur, ou le nom d’un groupe, dans le champ de texte pour faire apparaître une liste d’utilisateurs/groupes correspondants. Plusieurs utilisateurs/groupes peuvent être ajoutés. Pour supprimer l’accès au workflow à un utilisateur/groupe ajouté, cliquez sur la croix de suppression tout à droite de son nom.

Une fois les utilisateurs/groupes définis comme requis, cliquez sur pour appliquer l’affectation du workflow. Le workflow sera désormais disponible uniquement pour les utilisateurs/groupes ajoutés (et les membres du groupe Administrators) lorsqu’il est consulté comme décrit dans la section Designer Access to Process Workflows ci-dessous.

Comme indiqué dans la fenêtre Assign Access to This Workflow, si aucun utilisateur/groupe n’est ajouté, le workflow sera disponible pour tous les utilisateurs.

Accès du concepteur aux workflows de processus

Related pages: Effectuer des revues de conception, Publication vers un PLM, Demandes de composants basées sur un processus

Une fois l’ensemble requis de définitions de processus pour chaque thème de processus disponible élaboré selon les besoins de votre entreprise, les définitions activées seront disponibles pour les utilisateurs affectés dès qu’ils seront connectés au Workspace d’Enterprise Server. Les sections suivantes examinent où un concepteur peut accéder à ces processus actifs et les démarrer, à la fois via Altium Designer et via l’interface navigateur du Workspace.

Les administrateurs du Workspace peuvent, comme mentionné précédemment, démarrer une nouvelle instance de n’importe quelle définition de processus activée — directement depuis l’onglet de thème de processus correspondant dans la zone Processes de l’interface navigateur du Workspace — en cliquant sur le contrôle  dans la colonne Actions et en sélectionnant Start dans le menu qui apparaît.

Demandes de composants

Related page: Demandes de composants basées sur un processus

Depuis Altium Designer, les définitions de processus activées qui font partie du thème Part Requests sont accessibles aux emplacements suivants :

  • Depuis le panneau Components. Cliquez avec le bouton droit dans la zone principale du panneau — les définitions actives de processus de demande de composants sont disponibles dans le sous-menu Operations » Submit Request. Vous pouvez également cliquer sur le lien Submit request dans la section Need more components?.

Si aucune définition de processus active n’est disponible pour le thème de processus Part Requests, le sous-menu Submit Request ne sera pas affiché. Il se peut que vous deviez vous déconnecter du Workspace puis vous reconnecter, ou redémarrer Altium Designer, pour actualiser.
  • Depuis le panneau Manufacturer Part Search. Si l’élément de recherche actuellement sélectionné possède l’icône , le volet Information (accessible en cliquant sur ) affichera le bouton . Cliquez sur la partie déroulante du bouton pour accéder à un menu des définitions actives de processus de demande de composants. Un clic direct sur la partie principale du bouton lancera la première définition de processus de la liste.
Demander un composant via le panneau Manufacturer Part Search offre l’avantage supplémentaire de préremplir automatiquement les informations clés, y compris toutes les fiches techniques et les informations paramétriques.

Si aucune définition de processus active n’est disponible pour le thème de processus Part Requests, le bouton ne sera pas affiché. Il se peut que vous deviez vous déconnecter du Workspace puis vous reconnecter, ou redémarrer Altium Designer, pour actualiser.

Si l’élément de recherche actuellement sélectionné possède une icône , les définitions actives de processus de demande de composants seront disponibles depuis le menu associé au bouton (cliquez sur la partie déroulante du bouton).

Les définitions actives de processus de demande de composants sont également accessibles depuis le menu contextuel de la zone principale du panneau, via le sous-menu Submit Request.

Si aucune définition de processus active n’est disponible pour le thème de processus Part Requests, le sous-menu Submit Request ne sera pas affiché. Il se peut que vous deviez vous déconnecter du Workspace puis vous reconnecter, ou redémarrer Altium Designer, pour actualiser.
  • Depuis le panneau Explorer, dans le dossier Part requests ou après avoir effectué une recherche. Le bouton sera disponible et, lorsqu’on clique dessus, il affichera les définitions actives de processus de demande de composants disponibles au choix.

Notez que si la fonctionnalité Legacy Part Requests feature a été activée, le bouton apparaîtra comme . Une entrée supplémentaire relative aux nouvelles demandes de composants utilisant cette fonctionnalité héritée apparaîtra également dans le menu. Elle aura le suffixe (Legacy). Si aucune définition de processus active n’est disponible pour le thème de processus Part Requests et que la fonctionnalité Legacy Part Requests n’est pas activée, le bouton Submit Request ne sera pas affiché. Il se peut que vous deviez vous déconnecter du Workspace puis vous reconnecter, ou redémarrer Altium Designer, pour actualiser.

Depuis l’interface navigateur du Workspace, les définitions de processus activées qui font partie du thème Part Requests sont accessibles depuis la page Part Requests, en cliquant sur le bouton en haut à droite de la page.

Accès aux définitions activées de Part Requests depuis la page Part Requests de l’interface navigateur du Workspace.Accès aux définitions activées de Part Requests depuis la page Part Requests de l’interface navigateur du Workspace.

Si aucune définition de processus active n’est disponible pour le thème de processus Part Requests, le bouton sera indisponible. S’il n’existe qu’une seule définition de processus, le bouton n’apparaîtra pas avec une fonctionnalité déroulante et démarrera immédiatement ce processus lorsque vous cliquerez dessus.

Activités de projet

Related pages: Effectuer des revues de conception, Publication vers un PLM, Intégration PLM.

Les définitions de processus activées qui font partie du thème Project Activities sont accessibles à différents endroits.

Revue de conception et publication PLM standard

Depuis Altium Designer, les définitions de processus activées de revue de conception et de publication — qui font partie du thème Project Activities — sont accessibles depuis le sous-menu contextuel Project Activities, accessible par clic droit sur l’entrée du projet de conception dans le panneau Projects, ou depuis le menu principal Project » Project Activities.

Si aucune définition de processus active de revue de conception et de publication PLM standard n’est disponible pour le thème de processus Project Activities, les menus ne seront pas visibles.

Depuis l’interface navigateur du Workspace, les définitions de processus activées de revue de conception et de publication — qui font partie du thème Project Activities — sont accessibles depuis la page Projects de l’interface. Sélectionnez le projet requis, puis cliquez sur le bouton .

Accès aux définitions activées de Project Activities (revue de conception et publication PLM standard) pour un projet Workspace, dans la zone Projects de l’interface navigateur du Workspace.Accès aux définitions activées de Project Activities (revue de conception et publication PLM standard) pour un projet Workspace, dans la zone Projects de l’interface navigateur du Workspace.

Si aucune définition de processus active de revue de conception et de publication PLM standard n’est disponible pour le thème de processus Project Activities, le bouton ne sera pas affiché.

Publication PLM via Project Releaser

Depuis Altium Designer, le processus de publication vers une instance PLM dans le cadre du Project Releaser est accessible depuis le sous-menu Project » Project Releaser du projet actif, ou en cliquant avec le bouton droit sur l’entrée du projet de conception dans le panneau Projects et en choisissant le processus à partir de l’entrée de menu contextuel Project Releaser.

Créations de projet

Depuis Altium Designer, les définitions de processus activées qui font partie du thème Project Creations sont accessibles à trois endroits :

  • Depuis le sous-menu principal File » New » Project in <WorkspaceName>.

  • Depuis le sous-menu contextuel Convert to Managed Project, accessible par clic droit sur l’entrée d’un projet local dans le panneau Projects.

  • Depuis le sous-menu contextuel Clone, accessible par clic droit sur l’entrée d’un projet dans la boîte de dialogue Open Project dialog lorsque l’emplacement Workspace est sélectionné.

Notez que lorsqu’au moins une définition de processus pour le thème de processus Project Creations est active, la possibilité de créer un nouveau projet Workspace via la boîte de dialogue Create Project dialog (File » New » Project) est désactivée — le Workspace connecté n’est pas disponible comme emplacement cible. Regular Les projets de type (Local) et VCS peuvent être créés normalement via cette boîte de dialogue.

Si aucune définition de processus active n’est disponible pour le thème de processus Project Creations — ce qui est le cas par défaut pour une nouvelle installation d’Enterprise Server — les menus de processus ne seront pas visibles, et vous pourrez créer un projet Workspace via la boîte de dialogue Create Project comme d’habitude.

Notez également que, dans cette configuration par défaut, la commande Convert to Managed Project devient Make Project Available on Server.

Depuis l’interface navigateur du Workspace, les définitions de processus activées qui font partie du thème Project Creations sont accessibles aux emplacements suivants :

  • Depuis la page principale Projects de l’interface, en cliquant sur le bouton .

Accès aux définitions activées de Project Creations depuis la zone principale Projects de l’interface navigateur du Workspace.Accès aux définitions activées de Project Creations depuis la zone principale Projects de l’interface navigateur du Workspace.

  • Depuis la page Projects de l’interface, lorsque vous souhaitez cloner un projet particulier. Sélectionnez le projet requis, puis cliquez sur le bouton pour accéder aux processus du menu.

Accès aux définitions activées de Project Creations lorsque vous souhaitez cloner un projet Workspace, dans la zone Projects de l’interface navigateur du Workspace.Accès aux définitions activées de Project Creations lorsque vous souhaitez cloner un projet Workspace, dans la zone Projects de l’interface navigateur du Workspace.

  • Si aucune définition de processus active n’est disponible pour le thème de processus Project Creations — ce qui est le cas par défaut pour une nouvelle installation d’Enterprise Server — le menu proposera la fonctionnalité de clonage de projet de base (Clone). Cela n’est pas lié à la fonctionnalité de workflow de processus.
  • Pour utiliser le Constraint Manager afin de gérer les contraintes de conception de votre projet PCB Workspace basé sur un processus, veillez à attribuer un modèle de projet approprié lors de la création de ce projet. Il doit s’agir d’un modèle enregistré à partir d’un projet PCB qui a été créé avec son option Constraint Management activée dans la boîte de dialogue Create Project dialog.
AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Contenu