Réalisation de revues de conception
En un coup d'œil
- Comprenez les différences entre les trois processus de revue par défaut et la manière dont ils répondent à différents besoins de revue.
- Apprenez à lancer une revue, à partager les données de conception et les pièces jointes, et à recueillir les commentaires et les votes des réviseurs.
- Découvrez comment utiliser le panneau Tasklist pour suivre l’avancement des revues, effectuer les tâches qui vous sont attribuées et consulter les revues clôturées.
Une étape essentielle de tout processus de conception consiste à examiner son avancement et sa validité aux étapes clés du développement, que ce soit sous la forme de discussions collaboratives entre pairs ou de mécanismes d’approbation stricts. Quel que soit le niveau de formalité, ce processus implique de donner aux personnes chargées de la revue l’accès à l’ensemble des données du projet, fichiers, commentaires, représentations visuelles et outils de retour d’information nécessaires.
Altium Designer offre cette possibilité de manière très flexible grâce à l’utilisation de Process Workflows de revue, hébergés dans un espace de travail connecté et accessibles depuis Altium Designer.
Pour plus d’informations sur les processus et leurs flux de travail, consultez Creating & Managing Processes (espace de travail Altium 365, espace de travail Enterprise Server).
Les flux de travail des processus intègrent des formulaires interactifs présentés à l’utilisateur au fur et à mesure qu’il franchit les étapes du processus. Ils lui permettent d’ajouter des commentaires, de joindre des fichiers, de consulter les documents de conception et bien plus encore. Les processus de revue peuvent être lancés par tout utilisateur d’Altium Designer ayant accès au projet et sont attribués à d’autres utilisateurs (membres de l’équipe) ou à des groupes d’utilisateurs (rôles de l’équipe).
Du côté de l’espace de travail, l’administrateur gère les processus sous forme de flux représentés par des diagrammes, dont les formulaires utilisateur et les étapes sont entièrement personnalisables. Il est ainsi possible de créer, et d’imposer si nécessaire, des processus très spécifiques répondant, par exemple, aux exigences de revue établies par l’entreprise. Le nombre de processus pouvant être créés est illimité.
Pour plus d’informations, consultez Defining a Process Workflow (espace de travail Altium 365, espace de travail Enterprise Server).
Processus de revue
L’espace de travail propose trois processus de revue par défaut, qui peuvent être utilisés tels quels ou servir de base à des processus personnalisés plus avancés :
- Ad Hoc Review – Un processus de revue informel, sans enregistrement d’une conclusion.
- Handoff Review – Un processus de revue plus formel, dans lequel l’initiateur de la revue (le demandeur) enregistre une conclusion de validation ou de refus (Terminé/Rejeté) lors de la clôture de la revue. L’état Terminé indique que la conception est prête à passer à l’étape de développement suivante.
- Milestone Review – Un processus de revue en boucle fermée plus élaboré, dans lequel le demandeur s’appuie sur les retours de la revue pour décider si l’état doit être Terminé ou Rejeté, ou si la conception doit être corrigée (À retravailler). Dans ce dernier cas, la conception retravaillée est ensuite vérifiée et la décision Terminé/Rejeté/À retravailler est prise à nouveau. La revue est clôturée lorsque l’objectif ou le jalon du projet est atteint.
Dans tous les cas ci-dessus, le demandeur/approbateur de la revue (initiateur) et les personnes chargées de la revue (responsables désignés) sont guidés tout au long du processus par une succession de formulaires d’interface utilisateur. Les exigences et les options de chaque étape sont déterminées par l’entrée de processus correspondante dans l’espace de travail, elle-même gérée par l’administrateur du serveur, qui peut également lancer et annuler un processus de revue.
Effectuer une revue
Une revue se déroule généralement en trois étapes successives :
- L’utilisateur qui lance la revue (le demandeur) définit ce qui sera examiné et par qui, et ajoute toutes les données ou informations nécessaires.
- Les personnes chargées de la revue accèdent aux données du projet et fournissent des retours appropriés. Si nécessaire, elles ajoutent des données ou informations pertinentes.
- L’approbateur de la revue (généralement l’initiateur) évalue et synthétise les retours des personnes chargées de la revue, puis clôture le processus.
Chaque étape d’une revue est représentée par une tâche correspondante (espace de travail Altium 365, espace de travail Enterprise Server) dans le panneau Liste des tâches du logiciel, qui signale à chaque utilisateur qu’une action est requise et fournit des informations sur les tâches terminées. La sélection d’une tâche en attente active l’étape correspondante de la revue.
Lancer et définir une revue
Pour lancer un processus de revue pour un projet de l’espace de travail, cliquez avec le bouton droit sur son entrée dans le panneau Projects et choisissez une commande dans le sous-menu Project Activities du menu contextuel. Vous pouvez également utiliser le sous-menu Project Activities du menu principal Project pour lancer un processus de revue pour le projet actuellement actif.
En prenant le processus Ad Hoc Review comme exemple, dans sa configuration par défaut non modifiée, la boîte de dialogue initiale permet au demandeur (Barry dans l’exemple ci-dessous) de préciser le projet à examiner et les utilisateurs chargés de fournir les retours de revue.
Les champs de saisie et les menus de la boîte de dialogue Ad Hoc Review sont les suivants :
-
Request title – le mode
AUTOpar défaut utilise le nom du processus comme base pour le nom du processus actif (le titre de l’activité). Un nom personnalisé peut être saisi à la place. - Project – le nom du projet qui sera examiné. Il s’agit du projet actif au lancement du processus, mais tout projet disponible peut être sélectionné dans la liste déroulante, dont les options s’adaptent à la saisie.
- Description – texte fournissant des informations complémentaires aux personnes chargées de la revue.
- Reviewers – les membres de l’équipe ou les groupes de rôles auxquels sera attribuée la tâche de fournir les retours de revue. Commencez à saisir du texte pour afficher les entrées disponibles.
Cliquez sur le bouton
pour démarrer le flux de travail du processus et passer au formulaire de définition des données.
La boîte de dialogue Prepare review data qui suit vous permet de préciser les ressources de données de conception à utiliser et d’ajouter des pièces jointes. Notez que tout texte du formulaire affiché en bleu est un lien actif vers les données sources correspondantes. La boîte de dialogue comprend également, sous l’onglet Diagram, un diagramme descriptif du processus qui indique aussi l’étape à laquelle vous vous trouvez.
Les principales options du formulaire sont les suivantes :
-
Data – utilisez le menu déroulant pour sélectionner un jeu de données d’une version publiée du projet (par date), ou utilisez l’option
associée pour rechercher et sélectionner un jeu de données de publication précis. Par défaut, lorsqu’aucune donnée n’est sélectionnée, les personnes chargées de la revue ont uniquement accès aux données sources du projet.
- Attachments – recherchez ou glissez-déposez les fichiers que vous souhaitez ajouter comme données de revue ou sources d’information.
Une fois toutes les données de revue définies ou ajoutées au formulaire, cliquez sur le bouton
pour faire passer le processus à l’étape de revue.
À ce stade, la tâche Prepare review data active est clôturée dans le panneau Tasklist, puisque l’étape de soumission de la revue est terminée. Notez que l’utilisateur d’Altium Designer est ici le demandeur (initiateur) du processus de revue. Le processus de revue en cours figure dans la liste Activities du panneau avec un état actif. Cliquez sur le bouton
pour vous assurer que l’état des activités affiché est à jour.
Pour consulter l’état d’avancement du processus de revue actif, sélectionnez son entrée dans la liste Activities afin d’afficher les données actuelles et le diagramme de flux annoté (onglet Diagram).
Fournir des commentaires de revue
Une fois le processus de revue configuré et soumis par l’initiateur, l’activité génère automatiquement des tâches à effectuer par les personnes désignées comme réviseurs. Lorsqu’un réviseur (par exemple, Norm Smith dans cet exemple) se connecte ensuite à Altium Designer, la zone Tasks affiche une tâche Provide review feedback qui lui est attribuée.
La sélection de cette tâche active l’étape de revue du flux de processus pour le réviseur. La boîte de dialogue Provide review feedback qui s’affiche propose les données pertinentes du projet (telles que définies par la personne ayant soumis la revue), permet d’inclure des commentaires et des pièces jointes ou d’ouvrir le projet dans le visualiseur Web , et exige de soumettre un vote.
Les principales options de la boîte de dialogue Provide Review feedback sont les suivantes :
-
Open Project – sélectionnez cette option pour ouvrir la conception du projet dans le visualiseur Web de l’espace de travail. Celui-ci fournit de nombreuses données sur le projet ainsi que des vues interactives entièrement rendues des documents sources de conception, ce qui permet d’ajouter des commentaires avec mise en évidence et, si nécessaire, de les attribuer à un utilisateur spécifique (membre de l’espace de travail).
Pour plus d’informations, consultez la page Web Viewer (espace de travail Altium 365, espace de travail Enterprise Server).
-
Comment – les commentaires saisis ici seront attribués au nom du réviseur lors de la finalisation du processus de revue.
-
Vote – sélectionnez une synthèse appropriée de la conclusion de la revue.
-
Reviewers attachments – recherchez des fichiers ou faites-les glisser-déposer, par exemple des notes plus détaillées ou des documents de référence, afin de les inclure dans les commentaires de revue.
Notez que tout texte mis en évidence en bleu est un lien actif vers les données sources correspondantes. Sélectionnez le bouton
pour terminer le processus de revue ; cette action est indiquée dans le panneau Tasklist, qui ferme (supprime) cette tâche active.
Synthétiser et clôturer la revue
Lorsque tous les réviseurs désignés ont terminé les tâches de commentaires de revue qui leur ont été attribuées, le processus de revue actif passe à l’étape de synthèse/clôture. Une tâche Summarize review est générée pour l’utilisateur chargé d’évaluer l’activité de revue ; dans ce cas, Barry, l’utilisateur qui a soumis (lancé) la revue. Notez que, pour cet utilisateur, le processus de revue apparaît comme actif dans le panneau Tasklist, sous Activities. Pour les réviseurs, l’activité est désormais clôturée, car leurs tâches de contribution sont terminées.
La sélection de la tâche Summarize review dans le panneau Tasklist fait passer le flux de revue à son étape finale, présentée dans la boîte de dialogue Summarize review.
Les principaux éléments de ce formulaire sont les suivants :
-
Information provided by reviewers
-
Comment – une liste des commentaires fournis par les réviseurs à l’issue de leurs tâches de revue.
-
Vote – l’évaluation de la conclusion de la revue sélectionnée par chaque réviseur.
-
Review attachments – les fichiers associés ajoutés à la tâche par les réviseurs.
-
-
Summary
-
Summary note – les notes de conclusion ajoutées par la personne chargée d’évaluer le processus de revue (dans ce cas, la personne ayant soumis/lancé la revue), qui seront enregistrées lors de la clôture de la revue.
-
Un clic sur le bouton
de la boîte de dialogue clôture le processus de revue de conception actif. Notez que les processus de revue de conception plus avancés disponibles incluent, dans l’étape d’évaluation, des étapes supplémentaires telles que la définition d’une conclusion « terminé/rejeté » ou le lancement d’une tâche de reprise de la conception.
Pour examiner la revue de conception terminée, actualisez les entrées d’activités dans le panneau Tasklist , cochez l’option Show Closed dans le menu
, puis sélectionnez la tâche clôturée dans la liste. La boîte de dialogue qui s’affiche comprend une synthèse des informations de revue (sous l’onglet Data) et le diagramme de flux du processus (onglet Diagram), avec l’état d’avancement mis en évidence : Completed, comme prévu.
Processus de revue personnalisés
Les processus de revue de conception, tels qu’ils sont présentés à l’utilisateur dans Altium Designer, sont développés et modifiés dans l’espace de travail connecté par un administrateur désigné. La polyvalence des éléments d’étape du flux et des formulaires d’interface utilisateur qui constituent le flux de travail d’un processus de revue de conception permet de créer des revues répondant à un large éventail de besoins spécifiques.
Voici quelques options supplémentaires pouvant être appliquées aux étapes et aux formulaires :
-
attribuer n’importe quelle étape du flux à un utilisateur ou à un rôle spécifique, autre que ceux désignés comme réviseurs ou comme évaluateur.
-
refuser à un utilisateur ou à un rôle l’accès à une étape spécifique du flux de travail (un
Exception), afin que cette étape soit ignorée pour cet utilisateur ou ce rôle. -
rendre la saisie d’un champ de formulaire obligatoire avant de pouvoir soumettre la boîte de dialogue.
-
ajouter des étapes intermédiaires au flux de travail, imposant des tâches et des formulaires utilisateur supplémentaires.
-
créer une boucle de décision dans le flux de travail, que seule une action spécifique permet de fermer.
-
afficher ou masquer certaines données ou certains messages d’événement ou d’erreur dans le formulaire d’interface utilisateur d’une étape du flux de travail.
-
utiliser le visualiseur Web de l’espace de travail pour permettre aux réviseurs qui n’ont pas directement accès aux documents sources de conception de les examiner et de les commenter.
Comme indiqué précédemment, il est possible de créer autant de processus de revue que nécessaire et de les rendre accessibles dans Altium Designer. Ils peuvent être conçus pour différents niveaux de revue, allant des commentaires informels de collègues aux processus de revue formels validés par l’entreprise et alimentant d’autres systèmes de l’entreprise (tels que le PLM).
Pour obtenir des informations détaillées sur la création de processus personnalisés, consultez Defining a Process Workflow (espace de travail Altium 365, espace de travail Enterprise Server).








