ワークスペースのプロジェクト

Altium Designerは、Altium 365 Workspaceと連携することで、プロジェクトライフサイクルの開発段階に向けた高度なプロジェクト構造をサポートし、バージョン管理されたプロジェクトの作成と継続的なワークフローを簡素化します。また、Workspaceの管理下でストレージを一元化することで、この機能が他のコラボレーションサービスの基盤にもなります。

Workspaceベースのプロジェクトを使用する主な利点は次のとおりです。

  • ストレージの簡素化。保存場所を決める必要がなく、バックアップやその他の基本的なサービスも自動的に処理されます。

  • コラボレーション機能の基盤。

  • バージョン管理の徹底。

  • 専用のコメントシステムによる利便性。

  • 通知とステータス。ローカルでの変更を含むドキュメントのステータスを、設計チーム全体で確認できます。

  • 複雑な設定なしでPCBの同時設計が可能。

  • 複数のユーザーとプロジェクトを共有し、編集を許可したり、閲覧とコメントのみに制限したりできます。

  • プロジェクト履歴機能を使用する際に、VCS関連のコミットイベントを含むすべての機能を利用可能。

技術的には、プロジェクトはWorkspaceに保存されたメタ情報と、Workspaceに組み込まれたGITベースのバージョン管理との緊密な連携によって構成されます。一般的なワークフローは次のとおりです。

  1. ユーザーが新しいプロジェクトを作成します(Altium Designerのプロジェクトの作成ダイアログ、Workspaceのブラウザーインターフェース、またはAltium Designer内から既存のローカルプロジェクトをWorkspaceで利用可能にする方法を使用します)。作成時に、プロジェクトの名前と説明を指定します。

  2. Workspaceのブラウザーインターフェース、またはAltium Designer内で直接、プロジェクトへのアクセス権を設定・管理します。

  3. 各共同作業者がAltium Designer内で開くプロジェクトを選択すると、そのプロジェクトが自動的にチェックアウトされます。

Workspaceベースのプロジェクトの利点は、デフォルトでバージョン管理され、共有ドライブ、サーバー、取り決めなどを気にせずに共同作業できることです。バージョン管理は、Workspaceに組み込まれたGITバージョン管理サービスによって行われます。すべてのプロジェクトは、Workspace内のVersioned Storageという名前の単一の設計リポジトリ(Gitリポジトリ)に保存されます。プロジェクトが外部のバージョン管理下にある場合は、サーバー独自のGitリポジトリに設計ファイルを保存するWorkspace内のプロジェクトへ移行できます(実質的にWorkspaceのネイティブVCSに切り替わります)。詳しい手順については、外部VCSからWorkspaceのネイティブVCSへの移行を参照してください。

プロジェクトをローカルに保持したまま(通常のプロジェクトまたはVCSベースのプロジェクトとして)、Workspaceに送信して、同期されたコピーをオンラインで利用可能にすることもできます。これはSimple Syncと呼ばれ、Altium 365が提供するコラボレーションの利点を活用できます。

このドキュメントでは、Workspaceのブラウザーインターフェースでプロジェクトを操作する方法について説明します。設計ソフトウェアでのプロジェクトの操作については、Altiumの設計環境に慣れるを参照してください。

新しいプロジェクトの作成

プロジェクトは、WorkspaceのブラウザーインターフェースのProjects ページから直接作成できます。このページには、Workspaceで利用可能になっており、現在サインインしているユーザーと共有されているすべてのプロジェクトが一覧表示されます。新しいプロジェクトを作成するには、プロジェクト一覧の上にあるボタンをクリックし、メニューのCreateグループにあるProject項目を選択して、Create Project ウィンドウを開きます。

Workspaceのブラウザーインターフェースから新しいプロジェクトを作成。Workspaceのブラウザーインターフェースから新しいプロジェクトを作成。

Create Projectウィンドウは、最初は簡易表示で開き、次のフィールドが表示されます。

  • Project Name – プロジェクトに付ける名前を入力します。

プロジェクト名はA~Z、a~z、または0~9で始める必要があり、名前の中にもこれらの文字を使用できます。アンダースコア、ハイフン、スペースも使用できますが、スペースは名前の途中でのみ使用できます(先頭と末尾のスペースは無視されます)。次の単語は使用できません:AUX、COM1-COM9、LPT1-LPT9、CON、NUL、PRN。また、名前に次の文字を含めることはできません:\ . / ? % * : | " < >。
  • Template – 利用可能なプロジェクトテンプレートがある場合は選択します。対応するドロップダウンフィールドには、Workspace内にあるすべてのプロジェクトテンプレートが一覧表示されます(<Comment> (<ItemID>)の形式)。テンプレートを選択すると、プロジェクトの種類も自動的に決まります。既存のプロジェクトテンプレートを使用しない場合は、作成するプロジェクトの種類を指定するだけです(一覧にあるPCB ProjectまたはMultiboardの項目を使用します)。
  • Description – 必要に応じてプロジェクトの説明を入力します。

その他の設定を表示するには、ボタンをクリックします。次のフィールドが表示されます。

  • Parent Folder – このフィールドを使用して、Workspaceのフォルダー構造内でプロジェクトを作成する場所を指定します。現在開いているフォルダー、またはそれ以外の場合はデフォルトでProjectsが指定されます。新しいプロジェクトのデフォルトのフォルダーパスは、WorkspaceのブラウザーインターフェースのAdmin – Settings – Projectsページで指定されます。Create Projectウィンドウで、フィールドの右側にあるChange リンクをクリックすると、Workspaceのサーバーフォルダー構造にアクセスでき、プロジェクトの保存先として別のフォルダーを選択できます。

    処理の実行時にParent Folderフィールドで書き込み可能なフォルダーが選択されていない場合は、プロジェクトの保存用にPersonal Folder構造が自動的に作成されます。これは、ユーザーのメールアドレスを名前とする非公開の最上位フォルダーで、その下にMy Projectsサブフォルダーが含まれます。作成と使用の例は次のとおりです。

    • 新しいプロジェクトのデフォルトフォルダー(通常はProjects)を利用できないか、読み取り専用(書き込み不可)である場合。この場合、作成またはアップロードされたプロジェクトは、個人用のMy Projectsフォルダーに保存されます。

    • Parent Folderの保存先設定がデフォルト以外で、そのフォルダーへの閲覧権限しかない(書き込みできない)場合。この場合、プロジェクトの作成はブロックされ、My Projectsフォルダーへの追加は行われません。

詳しくは、フォルダーへの書き込み権限がない場合のプロジェクト作成を参照してください。

  • Projectsフォルダーを含むWorkspaceフォルダーへのユーザーのアクセス権は、ProjectsページのShareオプション、またはExplorerページ(Admin – Explorer)から設定するフォルダー共有権限によって決まります。詳しくは、プロジェクト作成権限の管理を参照してください。

  • 必要に応じて、プロジェクトをサブフォルダーの階層構造に整理できます。詳しくは、プロジェクトフォルダーの階層構造の作成のセクションを参照してください。

新しいプロジェクトを必要に応じて設定したら、をクリックします。プロジェクトの概要一覧に戻り、新しく作成したプロジェクトの項目が表示されます。

WorkspaceのブラウザーインターフェースのProjectsページに戻ると、新しく作成したプロジェクトが表示されます。WorkspaceのブラウザーインターフェースのProjectsページに戻ると、新しく作成したプロジェクトが表示されます。

プロジェクトは最初に、作成した設計者(作成者/所有者)およびワークスペース管理者に編集アクセス権付きで共有されます。追加のアクセス権限は、管理–設定–プロジェクトページのDefault permissions for new projects設定によって決まります。

  • このオプションが有効になっていない場合(デフォルト)、新しいプロジェクトは作成先の「親」フォルダーの共有権限を継承し、そのフォルダーの所有者にも書き込み(Edit)アクセス権が付与されます。

  • このオプションが有効になっている場合、プロジェクトは親フォルダーの権限を継承せず、このオプションで指定された共有権限を適用します。

詳細については、プロジェクト作成権限の管理を参照してください。

プロジェクトのアクセス権限の設定については、以下のプロジェクトの共有を参照してください。

既存のローカルプロジェクトのアップロード

既存の設計プロジェクトをワークスペースにアップロードすることもできます。手順は次のとおりです。

  1. プロジェクト一覧の上にあるボタンをクリックし、メニューのUploadグループからProject項目を選択します。プロジェクトのZIPアーカイブを探して選択し、Openをクリックしてアップロードを開始します。

  2. ポップアップウィンドウに、アップロード対象となるファイル(選択したフォルダーに含まれるファイル)の数が表示され、続行の確認を求められます。をクリックします。

  3. Upload Projectウィンドウが表示されます。デフォルトでは、Project Nameには既存のプロジェクトのものが使用されます。必要に応じて変更し、適切な説明を追加してください。Parent Folderには、アップロード処理を開始した時点でアクティブだったフォルダーが設定されます。フィールドの右側にあるChange リンクをクリックすると、ワークスペースのサーバーフォルダー構造にアクセスし、プロジェクトの保存先として別のフォルダーを選択できます。必要に応じて、サブフォルダーの階層を作成してプロジェクトを整理できます。詳細については、プロジェクトフォルダー階層の作成のセクションを参照してください。必要な設定を行ったら、ボタンをクリックします。

  4. アップロードが実行され、完了すると、概要レベルのプロジェクト一覧にプロジェクトの項目が追加されます。

ローカルプロジェクトに既存のバージョン管理へのリンクがあっても無視され、アップロードされたプロジェクトは、完全に管理され、バージョン管理が適用されたワークスペース上のプロジェクトになります。アップロード元のローカルプロジェクトは一切変更されません。

新規作成したプロジェクトと同様に、アップロードしたプロジェクトは、所有者(アップロードしたユーザー)と管理者に編集アクセス権付きで共有されます。追加の共有アクセス権は、親フォルダーの権限設定、または有効になっている場合は新規プロジェクトのデフォルト権限の設定によって決まります。

ガーバーまたはODB++ファイルセットのアップロード

ワークスペースには、生成されたガーバー/ODB++製造ファイル一式をアーカイブ形式でアップロードすることもできます。これには、ボタンのメニューにあるManufacturing Filesオプションを使用します。アップロード手順は、基本的に前述のプロジェクトのアップロード手順と同じです。

New – Manufacturing Files – Gerberオプションを選択し、Windowsのファイルブラウザーでアーカイブされたガーバーファイルセットを探して選択します。

Upload Gerberウィンドウで、必要に応じてプロジェクトのNameの候補(ガーバーアーカイブ名から取得されます)を編集し、Descriptionを追加します。Changeオプションを使用すると、デフォルトのプロジェクト保存フォルダーとは異なる保存先を指定できます。

アップロードしたファイルセットが処理され、ワークスペースのプロジェクトコレクションに追加されます。最初はガーバーアイコンが表示され、更新または表示すると、生成されたプレビュー画像に置き換わります。

New – Upload ODB++オプションを選択し、WindowsのファイルブラウザーでアーカイブされたODB++を探して選択します。

Upload ODB++ウィンドウで、必要に応じてプロジェクトのNameの候補(ODB++アーカイブ名から取得されます)を編集し、Descriptionを追加します。Changeオプションを使用すると、デフォルトのプロジェクト保存フォルダーとは異なる保存先を指定できます。

アップロードしたファイルセットが処理され、ワークスペースのプロジェクトコレクションに追加されます。最初はODB++アイコンが表示され、更新または表示すると、生成されたプレビュー画像に置き換わります。

 

ガーバー/ODB++プロジェクト名をクリックするか、対応するメニューのOpenオプションを使用すると、ワークスペース専用の製造ビューアーにファイルセットが読み込まれます。このビューアーでは、含まれるすべてのファイル/レイヤーを重ね合わせて表示でき、レイヤーの非表示や特定のレイヤーのみの表示、2点間の測定機能、コメントの配置が可能です。

これらのオプションの詳細については、Web Viewerドキュメントの製造セクションを参照してください。

OrCAD設計のアップロード

WorkspaceのOrCAD®アップロード機能により、Altium 365 Workspaceにアップロードして読み込める設計ファイルの種類がさらに広がります。適切な回路図(*.dsn)ファイルとPCB(*.brd)ファイルを含むアーカイブファイル(*.zip)を、以下に示すように、Projectsページのボタンから利用できるDesign Files » OrCADオプションでアップロードします。OrCAD設計は、Altium 365でバージョン管理下に保存されます。

  • 現時点では、アップロードするアーカイブに、回路図/PCBファイルの相対パスが登録された適切な *.opj プロジェクトファイルを含める必要があります。

  • バージョン17.2以降のOrCAD PCBファイルがサポートされています。

  • 詳細については、サポートされているECADファイルは何ですか?を参照してください。

New – Design Files – OrCADオプションを選択し、Windowsのファイルブラウザーで、アーカイブされたOrCAD設計ファイルセットの保存場所に移動して選択します。

Upload OrCADウィンドウで、必要に応じてプロジェクトのNameの初期値(OrCADアーカイブ名から取得されます)を編集し、Descriptionを追加します。Changeオプションを使用すると、デフォルトの保存フォルダーとは異なるプロジェクトの保存場所を指定できます。

アップロードされたファイルセットが処理され、初期アイコンとともにWorkspaceのプロジェクトコレクションに追加されます。その後、更新または表示すると、生成されたプレビュー画像が表示されます。

 

アップロードしたOrCAD設計は、他のWorkspaceプロジェクトと同様に、タイルをダブルクリックするか、タイルのメニューまたはページのメインのメニューからOpenオプションを選択して開きます。処理が完了すると、OrCAD設計ファイルが読み込まれ、回路図、PCB、3D PCB、BOM一覧のプロジェクトビューが生成されます。

ビューアーの設計ナビゲーションツリーは、フラットなFileビューとHierarchical構造ビューの間で切り替えられます。

 

Web Viewerを通じて提供されるWorkspaceの高度な機能により、統合された設計では、ドメインビュー間でのオブジェクトのすばやいクロスプローブ、オブジェクトの検索、ネットの追跡/ハイライト、コメントの追加、他のユーザーとの設計の共有、履歴の確認、タスクアクティビティの操作など、さまざまな作業が可能です。また、アップロードしたOrCADプロジェクトから高度なManaged BOMドキュメントを作成することもできます。これにより、Altiumの豊富なサプライチェーンデータリソースから情報が入力された、調達にすぐに使えるBOMファイルを確認、設定、共有できます。詳細については、BOM Portalのページを参照してください。

ビューアーの機能については、Web Viewerのページを参照してください。

設計の新しいバージョンのアップロード

OrCAD設計をWorkspaceにアップロードした後、たとえば外部委託先での追加作業によって、その設計の新しいバージョンが利用可能になった場合は、プロジェクトのUpload New Versionオプションを使用して既存のWorkspaceプロジェクトを更新できます。既存のプロジェクトはGitバージョン管理下に保存されているため、このオプションを使用すると、更新された設計をプロジェクトの新しいVCSリビジョンとしてコミットできます。このようなコミット(およびプロジェクトのリリース)イベントはすべて記録され、プロジェクトの履歴ビューで確認できます。

OrCADプロジェクトタイルのメニュー、またはメインのメニューから利用できるUpload New Versionオプションを使用して、既存のOrCADプロジェクト設計の新しいバージョンをアップロードします。

続いて表示されるUpload Projectウィンドウでは、Project NameフィールドとParent Folderフィールドが既存のプロジェクトの値に固定されています。わかりやすいDescriptionを追加してから、新しいバージョンのアップロードを確定します。

更新処理により、プロジェクトの新しいVCSリビジョンがコミットされます。プロジェクトを開くと、新しいバージョンのOrCAD設計とその変更内容を確認できます。

プロジェクトビュー内でHistoryビューを開くと、プロジェクトのコミットイベントを注釈付きのタイムラインで確認できます。ここでは、新しいOrCAD設計バージョンによって作成されたコミットに、手動でVersion 2というタグが付けられています。

コミットイベントのタイルのオプションを使用すると、設計の以前のバージョンにアクセスできます。各バージョンは個別に表示、コピー(クローン)、別のコミットとの比較が可能で、ソースファイルをZIPアーカイブとしてダウンロードすることもできます。

 

OrCADとAltium 365の統合

Altium 365では、OrCAD®設計をWorkspaceにアップロードできるだけでなく、専用プラグインを使用してOrCADとWorkspaceを直接統合することもできます。

Altium 365のECAD機能については、マルチCADファイルのサポートページを参照してください。

OrCADが動作するマシンにインストールするAltium 365 Plugin for OrCADは、両環境間で設計データを双方向に交換できる小規模なアプリケーションです。この統合により、既存のOrCAD環境でAltium 365のデータ管理のメリットを手軽に活用できます。Workspaceに移行したOrCAD設計は、履歴を追跡できるバージョン管理下に保存され、共同作業、表示、共有、コメントの追加など、さまざまな用途に利用できます。関係者のアクセスは権限で制御され、Webブラウザーから利用できます。

まだ共有されていない場合は、Altium 365 Plugin for OrCADのインストーラーをこちらからダウンロードできます:https://altium-install.s3.amazonaws.com/A365/A365OrCADPlug-in.exe

OrCADを実行しているマシンにAltium OrCADプラグインの実行ファイルをダウンロードして実行し、インストールウィザードの指示に従ってください。インストーラーはOrCADのインストール場所を自動的に検出します。

インストールが完了すると、OrCADのメインメニューのAltium 365項目からプラグインにアクセスできます。利用可能なメニューオプションを使用して、サインインし、現在のOrCADプロジェクトをAltium 365 Workspaceに保存したり、以前に保存したプロジェクトをWorkspaceから読み込んだりできます。

OrCADプラグインによって追加されたAltium 365メニューから、Altium 365 Workspaceにサインインします。

WorkspaceのURLとサインイン認証情報を入力してログインします。

接続すると、現在の設計をWorkspaceに保存(Save to Server)、以前に保存したOrCAD設計をWorkspaceからインポート(Open from Server)、または現在の保存済み設計をサーバーのブラウザーインターフェースで表示(View in Server)できます。

現在の設計をWorkspaceに保存する際は、Project Nameをそのまま使用するか編集し、必要に応じてDescriptionを追加します。

アップロード成功の通知には、保存した設計をWorkspaceのブラウザーインターフェースですぐに表示するためのオプションが含まれています。

インポートした設計のWorkspaceビューでは、共有、コメント、タスク管理、VCSによる履歴追跡などの追加機能を利用できます。

 
  • OrCAD設計をAltium 365 Workspaceに保存すると、実質的に2つのプロジェクトがリンクされ、プラグインがWorkspaceに接続されているときにデータを同期できるようになります。

  • その後OrCAD側で行った設計の編集は、いつでもWorkspaceに保存できます。Workspaceプロジェクトを更新するか開き直すと、更新された設計データが表示されます。詳細については、新しいデータでの更新を参照してください。

  • 接続先のWorkspaceでAltium 365 Design Reviews機能を利用できる場合、OrCADのAltium 365メニューの Request for Reviewオプションを選択すると、現在のプロジェクトのWorkspaceのDesign Reviewsページが直接開き、ピアレビューの作成、アクセス、管理を行えます。

注:OrCAD®は、Cadence Design Systems, Inc.が所有する米国連邦登録商標です。この商標への言及はすべて、識別のみを目的としています。この商標の使用は、Cadence Design Systems, Inc.との関係、同社による承認または推奨を意味するものではありません。

コメントとタスクのサポート

Altium 365 Plugin for OrCADは、Comments and Tasksパネルを通じて、Altium 365の高度なコラボレーション機能をOrCADに提供します。このパネルは、コメントとタスクのデータをリアルタイムで同期することで、Altium 365と直接通信します。OrCADユーザーは、コメントスレッドの作成と参加、自分自身や他のユーザーへの作業依頼(タスク)の割り当て、関連画像の貼り付けと表示、進行中のタスクに割り当てられた優先度と進捗状況の確認など、Altium 365のコラボレーション機能をすぐに活用できます。

Altium 365のコメントとタスクの操作については、Web Viewerのコメントを参照してください。

Altium 365メニューからComments and Tasksオプションを選択して、プラグインのComments and Tasksオーバーレイパネルを開きます。パネルには、接続先のAltium 365 Workspaceプロジェクトから取得した、既存のドキュメントのコメントとタスクの参照情報が表示されます。

Altium 365 WorkspaceとOrCAD間で双方向にデータを交換するには、Altium 365プラットフォームにサインインしている必要があります。

プラグインのComments and Tasksパネルは、基本的に、接続先のWorkspaceにあるComments and Tasksペインと同期したものです。そのため、このパネルではWorkspaceのペインのほとんどの機能を利用できます。ただし、OrCADはドキュメントへのコメント付加をネイティブにサポートしていないため、ドキュメント内に配置されたコメントにはアクセスできません。これらのWorkspace機能の詳細については、コメントペインの操作を参照してください。

プラグインのComments and Tasksパネルの上部から新しいコメントを追加できます。追加したコメントは、現在アクティブなOrCADドキュメントに関連付けられます。F5を押すと、いつでもパネルのデータを更新できます。

OrCAD内からコメントを追加するには、Comments and Tasksパネル上部のコメント入力欄に適切なテキストを入力します。

必要に応じて、@文字に続けてWorkspaceメンバー名を入力するか、ユーザーのドロップダウンリストから名前を選択することで、他のユーザーをメンションできます。

メンションしたユーザー、またはAssign a task toドロップダウンリストから選択した別のユーザーに、新しいWorkspaceタスクを割り当てることができます。

すべてのオプションを設定したら、ボタンをクリックして、コメントと、必要に応じてタスクを作成します。

新しいコメントは、現在のドキュメントに関連付けられたComments and Tasksパネルのエントリとして追加されます。このエントリには、Workspaceタスクへのリンクと、現在の優先度およびステータスを示すアイコンが含まれます。

Workspace側の他のユーザー、またはAltium 365 OrCAD Pluginにサインインした別のOrCADユーザーが、このスレッドにコメントを追加できます。

 

Altium 365 WorkspaceのComments and Tasksペインと同様に、OrCAD PluginのComments and Tasksパネルには、次のオプションと機能が用意されています。

  • Comments and Tasks Filtering – ペインに表示するユーザーのコメント(またはタスクのみ)を制御します。

  • Threads and Notifications – 表示するエントリを、現在のドキュメントに関連するものや未解決のもの(デフォルト設定)に絞り込みます。Workspaceのメール通知が有効な場合は、Notification Settingsオプションを使用して、メール通知を生成するコメントの範囲を指定します。

  • Comment entry options – コメントのメニューを使用して、そのエントリを管理したり、そのコメントに対応するタスクを作成したりします。

  • Comment image – Original Snapshotコントロールを使用すると、ドキュメントにコメントを配置した際に自動撮影されたスクリーンショット画像が開きます。Altium 365 Workspaceを使用してコメントを配置した場合にのみ利用できます。

  • Task assignment – Assign a task toメニューからユーザー名を選択して、コメントに関連付けられたタスクを作成します。タスクがまだ割り当てられていない場合に利用できます。

  • Link to associated Task – コメントのタスク識別エントリを選択すると、Workspaceプロジェクトのタスクビューでそのタスクが開きます。タスクの優先度とステータスの変更は、OrCADのComments and Tasksパネルに反映されます。

KiCad設計のアップロード

WorkspaceのKiCad®アップロード機能により、Altium 365 Workspaceにアップロードして解釈できるECAD設計データのソースがさらに広がります。適切なKiCad回路図ファイルとPCBファイルを含むアーカイブファイル(*.zip)は、以下に示すように、Projectsページのボタンから利用できるDesign Files » KiCadオプションを使用してアップロードします。処理されたKiCad設計は、Altium 365でバージョン管理下に保存されます。

Altium 365のECAD機能については、マルチCADファイルのサポートページを参照してください。

アップロードしたKiCad設計は、他のWorkspaceプロジェクトと同様に、タイルをダブルクリックするか、タイルのメニューまたはページのメインのメニューからOpenオプションを選択して開くことができます。処理が完了すると、KiCad設計ファイルが解釈され、回路図、PCB、3D PCB、BOMリストの各プロジェクトビューに表示されます。

New – Upload KiCad オプションを選択し、Windowsのファイルブラウザーで、アーカイブされたKiCad設計ファイルセットを探して選択します。

Upload KiCadウィンドウで、必要に応じてプロジェクトのNameの候補(KiCadアーカイブ名から取得されます)を編集し、Descriptionを追加します。Changeオプションを使用すると、デフォルトの保存フォルダーとは異なるプロジェクトの保存先を指定できます。

アップロードされたファイルセットは処理され、初期アイコンとともにWorkspaceのプロジェクト一覧に追加されます。更新または表示すると、生成されたプレビュー画像に置き換わります。

アップロードしたKiCad設計を開くには、タイルをダブルクリックするか、タイルのメニューまたはページのメインのメニューからOpenオプションを選択します。

上部のタブオプションを使用して、設計の回路図、PCB、BOMドキュメントを表示します。他のメニューやボタンのオプションを選択すると、Design Viewerの各種機能にアクセスできます。

 

設計とそのドキュメントでは、オブジェクトやレイヤーの表示制御、双方向クロスプロービング、管理された設計共有によるコラボレーション、ドキュメントへのコメント付加、履歴へのアクセスなど、Altium 365が提供する高度な機能を利用できます。BOM Portalアプリケーションにアクセスできる場合は、設計から調達向けのManaged BOMドキュメントを作成し、製造およびサプライヤーの部品データを管理できます。

設計ビューアーの機能については、Web Viewerページを参照してください。

たとえば外部委託先での追加作業などにより、そのKiCad設計の新しいバージョンが利用可能になった場合は、プロジェクトのUpload New Versionオプション()を使用して、既存のWorkspaceプロジェクトを更新できます。新しい設計の更新内容は、新しいVCSプロジェクトリビジョンとしてコミットされ、プロジェクトの履歴ビューにイベントとして記録されます。

EAGLE設計のアップロード

WorkspaceのAutodesk® EAGLE™アップロード機能は、Altium 365 Workspaceにアップロードして読み込めるECAD設計データのもう1つのソースを提供します。適切なEAGLE回路図(*.sch)とPCBファイル(*.brd)を含むアーカイブファイル(*.zip)は、以下に示すように、ProjectsページのボタンにあるDesign Files » EAGLEオプションからアップロードします。処理されたEAGLE設計は、Altium 365でバージョン管理されます。

Altium 365のECAD機能については、マルチCADファイルのサポートページを参照してください。

アップロードしたEAGLE設計は、他のWorkspaceプロジェクトと同様に、タイルをダブルクリックするか、タイルのメニューまたはページのメインメニューからOpenオプションを選択して開くことができます。処理が完了すると、EAGLE設計ファイルが読み込まれ、回路図、PCB、3D PCB、BOM一覧のプロジェクトビューが生成されます。

New – Upload EAGLE オプションを選択し、WindowsのファイルブラウザーでアーカイブされたEAGLE設計ファイルセットの場所に移動して選択します。

Upload EAGLEウィンドウで、必要に応じてプロジェクトのNameの初期値(EAGLEアーカイブ名から取得されます)を編集し、Descriptionを追加します。Changeオプションを使用すると、デフォルトの保存フォルダーとは異なるプロジェクトの保存場所を指定できます。

アップロードしたファイルセットが処理され、初期アイコンとともにWorkspaceのプロジェクトコレクションに追加されます。更新または表示すると、生成されたプレビュー画像が表示されます。

タイルをダブルクリックするか、タイルのメニューまたはページのメインメニューからOpenオプションを選択して、アップロードしたEAGLE設計を開きます。最初に回路図ドキュメントが表示されます。

上部のタブを使用して、2Dおよび3D PCBビューなど、他の設計ビューに切り替えます。その他のメニューやボタンのオプションを選択すると、Design Viewerのさまざまな機能にアクセスできます。

BOMビューのデータは、EAGLE設計ファイルから取得できる情報に限られますが、設計プロジェクトのCreate Managed BOMオプション()から、高度なManaged BOMドキュメントを作成できます。注:BOM Portalが有効になっている場合に利用できます。

 

設計とそのドキュメントでは、オブジェクトやレイヤーの表示制御、双方向クロスプロービング、管理された設計共有によるコラボレーション、ドキュメントへのコメント、履歴へのアクセスなど、Altium 365が提供する高度な機能を利用できます。BOM Portalアプリケーションにアクセスできる場合は、設計から調達向けのManaged BOMドキュメントを作成し、製造部品およびサプライヤー部品のデータを管理できます。

設計ビューアーの機能については、Web Viewerページを参照してください。

たとえば外部の委託先が追加作業を行い、そのEAGLE設計の新しいバージョンが利用可能になった場合は、プロジェクトのUpload New Versionオプション()を使用して既存のWorkspaceプロジェクトを更新できます。新しい設計更新は、新しいVCSプロジェクトリビジョンとしてコミットされ、プロジェクトの履歴ビューにイベントとして記録されます。

Managed BOMのアップロードまたは作成

WorkspaceでAltium 365 BOM Portalアプリケーションが有効になっている場合は、CSV/XLS形式のBOMファイルをアップロードしてManaged BOMプロジェクトアイテムを作成するか、既存の設計プロジェクトから直接作成できます。Managed BOMファイルはBOM Portalによって読み込まれ、処理されて、最終的に調達に使用できるBOMドキュメントになります。これらには、Altiumのデータリソースから取得した最新のメーカー/サプライヤー情報が入力され、会社のニーズに合わせて柔軟に設定できます。

複数の既存のManaged BOMで構成される統合BOMであるConsolidated BOMを作成することもできます。複数の基板やセクションからなるプロジェクトでは、これにより同等部品を集約し、発注数量を最適化した、プロジェクト全体の購買BOMを作成できます。詳細については、BOM Portalページの統合BOMのセクションを参照してください。

詳細については、BOM Portalページを参照してください。

BOMファイルをアップロードするには、ボタンのメニューにあるUploadグループからBOMオプションを選択し、適切なCSV/XMLBOMファイルを参照して選択します。Upload BOMウィンドウで詳細を入力し、アップロードを確定します。Managed BOMファイルは、デフォルトで現在開いているフォルダーまたはProjectsフォルダーに保存され、設計プロジェクトと同様の方法でアクセスおよび管理できます。

 

既存の設計プロジェクトからManaged BOMを作成するには、プロジェクトタイルのメニューからCreate Managed BOMオプションを選択し、プロジェクトバリアントを選択してCreate Managed BOMウィンドウにBOMの詳細を入力した後、BOMの作成を確定します。

 

Managed BOMを開くには、タイルをダブルクリックするか、名前をクリックするか、対応する省略記号メニューからOpenを選択します。BOM Portalアプリケーションは、BOMパラメーター(Description、Designator、Manufacturer Part Numberなど)の認識とマッピングを自動的に試みます。自動的に行えない場合は、ユーザーの選択に基づいて列のマッピング手順を案内します。

パラメーターデータが正常にマッピングされると、システムは最も適切な部品メーカーおよび部品サプライヤーのデータを自動的に取得し、互換性やリスクに関する問題を示すフラグを付け、BOMの「健全性」の概要をグラフィカルに表示します。

 

プロジェクトフォルダー階層の作成

Related information: コンテンツ構造とアクセスの管理

Workspaceには、サーバーの構造内でプロジェクトフォルダーを作成および管理する機能もあります。作成したフォルダー階層内の任意のフォルダーでプロジェクトを作成したり、そこに移動したりできます。

(デフォルトの)最上位のProjectフォルダーの下に新しいフォルダーを作成するには、プロジェクト一覧の上にあるボタンをクリックし、メニューのCreateグループからFolder項目を選択します。表示されたCreate Folderウィンドウで、新しいフォルダーの名前、親フォルダー、および任意の説明を指定します。新しいフォルダーは常に現在選択しているフォルダーの下に作成され、そのフォルダーが親フォルダーになります。新しいフォルダーの権限は親フォルダーから継承されます。親フォルダーの「所有者」が現在のユーザーと異なる場合は、その所有者の書き込みアクセス権も継承されます。

プロジェクトフォルダーの階層がすでに定義されている場合は、Parent Folderフィールドの右側にあるChange リンクをクリックして、Workspaceのサーバーフォルダー構造にアクセスし、新しいフォルダーを作成する別の親フォルダーを選択します。

必要に応じて属性を設定したら、をクリックします。新しいフォルダー(サブフォルダー)が作成され、そのフォルダーに移動します。

プロジェクトを保存する新しいフォルダー(サブフォルダー)の作成例。

プロジェクトを保存する新しいフォルダー(サブフォルダー)の作成例。

プロジェクトを保存する新しいフォルダー(サブフォルダー)の作成例。

 

必要に応じてフォルダーの作成を続け、設計プロジェクトを保存・分類するためのフォルダー階層を構築します。作成したフォルダーは、以降にフォルダーを作成する際に、次の画像のように親フォルダーとして選択できるようになります。

定義されたプロジェクトフォルダー階層の例。定義されたプロジェクトフォルダー階層の例。

フォルダー階層内の移動

Projectsページのデフォルトのグラフィカル表示では、Projectsフォルダーの下にすべての子フォルダーが表示されます。選択したフォルダーの詳細は、右側の情報ペインに表示されます。

フォルダー項目の名前をクリックすると、その内容が開きます。パンくずリストの項目を選択するとフォルダー階層の上位に移動でき、メインナビゲーションツリーのProjects項目を選択するとプロジェクトの最上位階層に戻ります。リスト表示()でも同じ方法で移動できます。

フォルダーの共有

既存のプロジェクトフォルダーの共有権限を変更するには、Projectsページで対象の項目を選択し、対応するコントロールからShare項目を選択するか、上部のボタンをクリックします。Share Itemウィンドウでは、指定したユーザーまたはグループ(Share Item With項目)にフォルダーへのアクセス権を追加し、フォルダーの既存の共有権限(Share Withの下)を確認・変更できます。ただし、所有者と管理者に固有の権限は変更できません。

フォルダーの共有権限にアクセスできるのは、管理者とフォルダーの所有者のみです。

ルートのProjectsフォルダーの共有権限は、管理者のみがExplorerページから変更できます。

Share Itemウィンドウでは、選択したフォルダーに適用される共有権限を追加・変更できます。Share Itemウィンドウでは、選択したフォルダーに適用される共有権限を追加・変更できます。

Shared With項目では、一部のユーザーアクセスレベル(表示、編集、アクセス権なし)を選択できない場合があります。これは、アクセスレベルを変更すると、親フォルダーから継承した権限(デフォルトではすべてのユーザーに対するEdit権限)と矛盾する(権限を引き下げる)ことになるためです。Share ItemウィンドウのAdvanced SettingsにあるInherit parent folder permissionsオプションを無効にすると、フォルダーの権限を親フォルダーの権限から切り離すことができます。これにより権限の継承が無効になり、すべてのアクセスレベルを選択できるようになります。

詳細については、コンテンツ構造とアクセスの管理ページを参照してください。

フォルダーの編集

既存のプロジェクトフォルダーのプロパティを編集するには、Projectsページで対象の項目を選択し、プロジェクト/フォルダーの一覧の上にあるコントロールをクリックして、表示されるメニューからEdit 項目を選択します。

編集コマンドは、Projectsページで対象のフォルダーのタイルを選択し、アイコンのコンテキストメニューからEditコマンドを選択することでも使用できます。Projectsページがリスト表示の場合は、対象のフォルダー項目の右端にあるコントロールをクリックし、表示されるメニューからEdit コマンドを選択します。

ルートのProjects フォルダーは変更できません。

続いて表示されるEdit Folderウィンドウで、フォルダーの名前と説明を変更できます。ボタンをクリックして変更を確定します。

プロジェクトフォルダーのNameとDescription は、いつでも編集できます。プロジェクトフォルダーのNameとDescription は、いつでも編集できます。

階層内でのフォルダーの移動

フォルダーを階層内の別の親フォルダーの下に移動するには、Projectsページで対象の項目を選択し、プロジェクト/フォルダーの一覧の上にあるコントロールをクリックして、表示されるメニューからMove 項目を選択します。

移動コマンドは、Projectsページで対象のフォルダーのタイルを選択し、アイコンのコンテキストメニューからMoveコマンドを選択することでも使用できます。Projectsページがリスト表示の場合は、対象のフォルダー項目の右端にあるコントロールをクリックし、表示されるメニューからMove コマンドを選択します。

ルートのProjects フォルダーは移動できません。

Move folder ウィンドウが表示されるので、新しい親フォルダーを選択します。ボタンをクリックすると移動が実行されます。フォルダーは、その中にあるプロジェクトとともに、選択した新しい親フォルダーのサブフォルダーとして移動されます。

フォルダー(またはプロジェクト/アイテム)を別の親フォルダーに移動する際は、ワークスペースの高度な権限継承方式が適用されることに注意してください。

詳細については、コンテンツ構造とアクセスの管理ページのフォルダーの移動セクションを参照してください。

フォルダーは、フォルダー階層内でいつでも移動できます。フォルダーは、フォルダー階層内でいつでも移動できます。

フォルダーの削除

既存のプロジェクトフォルダーをワークスペースから削除するには、Projectsページで対象の項目を選択し、プロジェクトフォルダーの一覧の上にあるコントロールをクリックして、表示されるメニューからRemove 項目を選択します。

削除コマンドは、Projectsページで対象のフォルダーのタイルを選択し、アイコンのコンテキストメニューからRemoveコマンドを選択することでも使用できます。Projectsページがリスト表示の場合は、対象のフォルダー項目の右端にあるコントロールをクリックし、表示されるメニューからRemove コマンドを選択します。

ルートのProjects フォルダーは削除できません。

削除を確認するためのRemove ウィンドウが表示されます。削除を実行するには、ボタンをクリックします。

フォルダーは、その中にあるプロジェクトとともにフォルダー階層から削除され、削除したフォルダーの親フォルダーに移動します。プロジェクトフォルダーは、ごみ箱ページから復元または完全に削除できます。フォルダーとともに削除されたプロジェクトは、Trash ページから復元または完全に削除できますが、この操作を行えるのは、そのプロジェクトの所有者またはワークスペース管理者のみです。

プロジェクトフォルダーの削除 — ワークスペースの隔離されたTrash 領域に移動します。プロジェクトフォルダーの削除 — ワークスペースの隔離されたTrash 領域に移動します。

プロジェクトの閲覧

ワークスペースのブラウザーインターフェースのProjectsページにあるプロジェクト一覧には、アクセス権を持つすべてのプロジェクトが表示され、包括的なプロジェクト管理機能とコントロールを利用できます。ボタンを使用するとページがリスト表示()に切り替わり、ボタンを使用するとグラフィカル表示(デフォルトの表示)に切り替わります。

ワークスペースのブラウザーインターフェースのProjectsページ — プロジェクトを操作するための中心となるページです。ここでは、ページのグラフィカル表示を示しています。 ワークスペースのブラウザーインターフェースのProjectsページ — プロジェクトを操作するための中心となるページです。ここでは、ページのグラフィカル表示を示しています。

プロジェクト一覧は最終更新日時で自動的に並べ替えられ、最後に変更されたプロジェクトが一覧の左上(グラフィカル表示の場合)または先頭(リスト表示の場合)に表示されます。グラフィカル表示()では、ボタンを使用して、プロジェクトドキュメントを名前、作成者、所有者、または最終更新日時ですばやく並べ替えることができます。

リスト表示()では、各列のヘッダーを使用して、プロジェクト一覧をName、Author、Owner、またはLast Modifiedで並べ替えることができます。1回クリックすると昇順で、もう一度クリックすると降順で並べ替えられます。列名の右側の矢印は、現在の並べ替え方向を示します。一方の表示で選択した並べ替え方法は、両方の表示に適用されます。

プロジェクトフィルター

フィルター()のドロップダウンメニューを使用して、一覧を特定の所有者やドキュメントの種類、またはその両方の組み合わせに絞り込むことができます。

Filtersウィンドウでは、プロジェクトドキュメントのTypeまたはプロジェクトのOwnerでフィルタリングできます。オプションをクリックすると、さらに多くの項目が表示されます。

プロジェクトの種類を1つ以上選択すると、プロジェクトのグリッド表示が即座に絞り込まれ、該当するドキュメントのみが表示されます。元に戻すには、セクションのClearまたはClear Allを使用します。

Workspaceユーザーを1人以上選択すると、そのユーザーが所有するプロジェクトに一覧を絞り込めます。所有者は通常、プロジェクトの作成者です。

WorkspaceでAltium Agileサブスクリプションが有効になっている場合は、追加のHas Accessフィルターを使用できます。ユーザーを選択すると、そのユーザーがアクセスできるプロジェクトドキュメントが表示されます。

Has Accessフィルターオプションを使用すると、1人またはすべての外部共有ゲストユーザーが利用できるプロジェクトドキュメントをすばやく表示することもできます。

 

 

情報、オプション、検索

デフォルトのグラフィカル表示()では、プロジェクトまたはManaged BOMのタイルに、プロジェクト名と最終更新日が表示されます。プロジェクトにPCBが含まれている場合、プロジェクトタイルにはPCBを真上から見た3Dビューが自動的に表示されます。一方、Managed BOMタイルには、BOM自体から抽出された主要な調達データが表示されます。

ページのグラフィカル表示で選択されたプロジェクトとManaged BOMのタイル。ページのグラフィカル表示で選択されたプロジェクトとManaged BOMのタイル。

リスト表示()では、各プロジェクトの項目に次の情報が表示されます。

  • Name – プロジェクトの名前。

  • Description – プロジェクトに対して入力または生成された説明。

  • Author – プロジェクトを作成したユーザー。

  • Owner – プロジェクトが新しい所有者に譲渡されていない限り、作成者と同じです。► 関連情報については、プロジェクト所有権の譲渡を参照してください。

  • Last Modified – プロジェクトの最終更新日時。

どちらのプロジェクト表示(グラフィカル表示およびリスト表示)でも、一覧の右上に次のコントロールが用意されています(詳細は、以降のリンク先のセクションで説明します)。これらは、一覧で現在選択されているプロジェクトに対して機能します。

(共有)– クリックすると、プロジェクトを他のユーザーと共有するために必要なすべてのコントロールを備えた共有ウィンドウが開きます。

(More)– クリックすると、次の追加オプションが表示されます。

  • Open – クリックすると、プロジェクトの詳細管理ページが開きます。このページはブラウザーの別のタブで開きます。

  • Share(プロジェクトタイルのメニューで使用可能)– クリックすると、プロジェクトを他のユーザーと共有するために必要なすべてのコントロールを備えた共有ウィンドウが開きます。

  • Move – クリックすると、プロジェクトの移動ウィンドウが開きます。ここでは、フォルダー階層内の利用可能なすべてのフォルダーから、プロジェクトの移動先となる別の親フォルダーを選択できます。

  • Edit – クリックすると、プロジェクトの編集ウィンドウが開きます。ここでは、プロジェクトのName、Description、およびサーバーのParametersを変更できます。Parent Folderフィールドは情報表示専用で、編集できません。親フォルダーを変更するには、移動コマンドを使用する必要があります。

  • Upload New Version – このコマンドを選択すると、プロジェクトの新しいバージョン/リビジョンを参照してアップロードできます。このオプションは通常、OrCAD、KiCad、Eagleなどで作成され、Workspaceにインポート(アップロード)された設計プロジェクトに使用します。

  • Clone – このコマンドを選択すると、プロジェクトの完全なコピーを作成するためのコントロールを備えたプロジェクトの複製ウィンドウが開きます。

  • Watch – このコマンドを選択すると、プロジェクトをフォローできます。プロジェクトに関する通知(更新、リリース、パラメーターや権限の変更など)が、Workspaceから送信されるメールで届きます(管理者によってWorkspaceのメール通知が有効にされている必要があります)。プロジェクトの作成者/所有者は、そのプロジェクトをウォッチするよう自動的に設定されます。

  • UnWatch – このコマンドを選択すると、プロジェクトのフォローを解除し、そのプロジェクトに関連するイベントの通知の受信を停止します。

  • Create Managed BOM – このコマンドを選択すると、現在のプロジェクトのソースデータからManaged BOMドキュメントを生成できます。Managed BOMには、BOM Portalからアクセスします。

  • Remove – このコマンドを選択すると、プロジェクトを削除できます。削除を確認するためのRemove ウィンドウが表示されます。この操作は「論理削除」であり、プロジェクト(リビジョンとリリースを含む)はWorkspaceのTrash 領域に移動されます。

グラフィカル表示では、プロジェクトタイルからすべてのコマンドに直接アクセスできます。コントロールをクリックすると、対応するメニューが表示されます。また、この表示でプロジェクトのタイルをダブルクリックする(または名前をクリックする)と、そのプロジェクトの詳細管理ページが開きます。リスト表示()では、プロジェクトの項目の右端にあるコントロールのメニューから、すべてのコマンドにアクセスできます。

プロジェクトの検索

また、すべてのプロジェクトフォルダーを対象にプロジェクトを検索できる、プロジェクトのSearch機能も用意されています。Workspaceのパラメーター名と値で検索できるため、検索しやすいようにカスタムのプロジェクトパラメーター(顧客名、プロジェクト番号など)を設定できます。ブラウザーインターフェース上部のフィールドに検索文字列の一部を入力すると、属性にその検索文字列を含むプロジェクトのみが一覧に表示されます。

プロジェクトパラメーターで検索する場合は、パラメーター名、または既存のパラメーターの特定の値で検索できます。パラメーター名にスペースが含まれていない場合は、検索フィールドに文字列<ParameterName> =を入力します。名前にスペースが含まれている場合は、リテラル文字列を"<ParameterName>" =の形式で入力します。通常は、顧客名などのパラメーター値(Customer、Customer Nameなどのパラメーター内の値)を使用します。以下の例では、部分的な文字列ではなく完全な検索文字列は"Customer Name"= CompanyXYZになります。また、パラメーターを単純な「タグ」として使用し、特定のプロジェクトの種類、用途、ステータスなどを定義するパラメーターでプロジェクト一覧を絞り込むこともできます。

検索機能の使用例。この例では、部分的な検索文字列を使用して、プロジェクトパラメーター(Customer Name)の値に基づいてプロジェクトを検索しています。検索機能の使用例。この例では、部分的な検索文字列を使用して、プロジェクトパラメーター(Customer Name)の値に基づいてプロジェクトを検索しています。

  • 検索では大文字と小文字は区別されません。ただし、引用符で囲まれたパラメーター名はリテラルとして扱われるため、大文字と小文字が区別されます。

  • すべてのプロジェクトフォルダーにあるプロジェクトの一覧をすばやく表示するには、検索フィールドに*を入力します。

  • 検索による絞り込みを解除するには、左側のナビゲーションペインでメインのProjectsページ項目をクリックするか、検索フィールドをクリアします(x)。

プロパティペイン

表示されていない場合は、右側のペイン上部にあるProperties をクリックして、Properties ペインを開きます。このペインには、現在選択されているプロジェクトの詳細なプロパティ情報が表示されます。

Properties ペインで、現在選択されているプロジェクトの詳細情報を確認できます。Properties ペインで、現在選択されているプロジェクトの詳細情報を確認できます。

Properties ペインに表示されるプロパティデータは、現在選択されているプロジェクトからWorkspaceによって抽出または生成されたものです。ペインの最上部には、基板の3Dビュー(プロジェクトにPCBがある場合)と、プロジェクトの名前、説明、所有者、作成日時、最終更新日時などの概要情報、およびプロジェクトの親フォルダーへのリンクが表示されます。

その他のプロパティは、次の展開可能な見出しの下にまとめられています(説明用の画像例を併記)。

  • Child Projects(マルチボードプロジェクトのみ)– マルチボードプロジェクトに含まれ、リンクされているサブプロジェクトPCBの一覧です。サブプロジェクトのリンクをクリックすると、通常どおり、そのPCBプロジェクトがWeb Viewerで開きます。

  • Child BOMs – プロジェクトから生成され、プロジェクトにリンクされているManaged BOMドキュメントの一覧です。

  • Who Has Access – プロジェクトへのアクセス権を持つWorkspaceのグループ、メンバー、および外部共有ゲストの概要です。アイコンにカーソルを合わせると、そのアイコンが示す共有アクセス権の詳細を確認できます。この情報は、下のテキストにも要約されています。なお、外部共有ユーザーのアクセスアイコンには黄色い点が付いています。
    Manage Accessコマンドを使用すると、プロジェクトのShareダイアログを直接開くことができます。以下のプロジェクトの共有を参照してください。

  • Issues(Managed BOMを選択した場合に表示)– Managed BOMによって報告されたすべてのBOMチェックの問題を分類した概要です。関連情報については、BOMエラーの検出と修正を参照してください。

  • Reports – 現在選択されているプロジェクトに対して生成された電気ルールチェック(ERC)およびデザインルールチェック(DRC)で、各レポートのエラー数や違反数も表示されます。ERCまたはDRCの項目を選択すると、プロジェクト内でレポートの詳細を開いて確認できます。Web ViewerのDRCおよびERCレポートを参照してください。

  • Parameters – プロジェクトの設計そのものから抽出または算出された詳細データを網羅したものです。Showコントロールをクリックすると一覧全体が展開され、Hideをクリックすると再び折りたたまれます。

  • Where Used – このプロジェクトを子要素として使用する、マルチボードプロジェクトなどの関連プロジェクトの一覧です。一覧内のWhere Usedプロジェクトリンクをクリックすると、その親プロジェクトが開きます。

  • Releases – プロジェクトのリリースの一覧です。リリースが複数ある場合は、最新のものを先頭に時系列順で表示されます。項目をクリックすると、そのリリースがManufacturing Portalを通じて別のタブに表示されます。このポータルでは、リリース済みのファイルデータの表示と移動、BOMの確認、およびリリースデータのソースとなる設計自体のスナップショットの表示やコメントの追加ができます。また、製造データをさまざまな単位(データセット全体から個々の生成済み出力ファイルまで)でダウンロードするためのコントロールも利用できます。選択したリリースは、Manufacturing Packageとして製造業者に直接送信することもできます。

アクティビティペイン

表示されていない場合は、右側のペイン上部にあるActivity をクリックして、Activity ペインを開きます。このペインには、現在選択されているプロジェクトのアクティビティ情報が表示されます。各メッセージには、プロジェクトに関連して発生したイベント(プロパティの変更、新しいコミット、リリースなど)が示されます。最新のイベントが一覧の先頭に表示されます。

Activityペインで、現在選択されているプロジェクトのイベント履歴を確認できます。Activityペインで、現在選択されているプロジェクトのイベント履歴を確認できます。

イベントメッセージ内のプロジェクトの項目をクリックすると、そのプロジェクトの詳細管理ページが開きます。

プロジェクトの共有

プロジェクトがWorkspaceで利用可能になったら、実際にそのプロジェクトにアクセスできるユーザーを決めます。これは、アクセス権限を個別に設定するのではなく、プロジェクトを共有することで行います。

デフォルトの共有設定

新規作成されたプロジェクト、またはWorkspaceで利用可能になったプロジェクトは、デフォルトで次の対象と共有されます。

  • プロジェクトの所有者。通常は、プロジェクトを作成した(またはWorkspaceで利用可能にした)設計者で、完全な編集アクセス権が付与されます。

  • Administratorsグループ。完全な編集アクセス権が付与されます。

  • プロジェクトの親フォルダーから継承される権限(通常はすべてのWorkspace Membersと共有)によって決まる他のユーザーまたはグループ、あるいはWorkspace管理者が指定した固定のデフォルト権限セット。

新規作成されるプロジェクトのデフォルトの保存先は、WorkspaceインターフェースのAdmin – Settings – Projectsページで定義・変更できます。別のデフォルトの保存先を指定するには、Default path for new projectsフィールドを選択して編集します。新しいプロジェクトは、この保存先、またはユーザーが現在開いている別のフォルダーに保存されます。ただし、そのフォルダーへのWriteアクセス権が必要です。

ユーザーがProjectsフォルダー(または別のデフォルトフォルダー)に書き込めない場合(Viewのみ)、この保存先で作成したプロジェクトは、ユーザーのメールアドレスに基づく最上位フォルダー内のMy Projectsフォルダー、つまりそのユーザーのPersonal Folder構造内に保存されます。デフォルトの保存先以外のフォルダーでは、Viewアクセス権のみを持つユーザーはプロジェクトを作成できません。

詳細については、フォルダーへの書き込み権限がない場合のプロジェクト作成を参照してください。

新しいプロジェクトのデフォルトの保存先は、Workspaceのブラウザーインターフェースの管理者エリアで管理します。新しいプロジェクトのデフォルトの保存先は、Workspaceのブラウザーインターフェースの管理者エリアで管理します。

新規作成されるプロジェクトのデフォルトのアクセス権限は、Admin –Settings – ProjectsページのDefault permissions for new projectsオプションを有効にすることで指定できます。これにより、新しいプロジェクトが親フォルダーの権限を継承するデフォルトの動作が上書きされます。このオプションを有効にすると、新規作成されるすべてのプロジェクトに適用するアクセス権限のセットを明示的に定義できます。すべての新しいプロジェクトをProjectsフォルダーなどの単一の保存先に作成する場合は、この方法が適していることがあります。詳細については、プロジェクト作成権限の管理を参照してください。

新しいプロジェクトのデフォルトのアクセス権限セットは、Workspaceのブラウザーインターフェースの管理者エリアで指定します。新しいプロジェクトのデフォルトのアクセス権限セットは、Workspaceのブラウザーインターフェースの管理者エリアで指定します。

プロジェクトフォルダーの共有は、Admin – Explorerページで、フォルダー項目の右クリックコンテキストメニューからShare Folderオプションを選択して設定できます。管理者またはフォルダー所有者の場合は、Projectsページのビューからも設定できます。上記のフォルダーの共有を参照してください。新しく有効化されたWorkspaceでは、すべてのWorkspaceメンバーがルートのProjectsフォルダーへの書き込み権限を持ちます。共有設定では、Workspace Membersに対するWrite権限に相当します(すべてのユーザーがフォルダーへの追加や編集を行えます)。

共有対象を特定のユーザーまたはグループに変更することもできますが、この最上位フォルダーの下にフォルダー階層を作成し、特定のフォルダーとその中のプロジェクトにカスタムの共有設定を適用して、共有(およびアクセス)を個別に制御する方法を推奨します。

  • Workspaceでは権限を継承する構造が採用されているため、フォルダー権限の追加や編集はフォルダー階層の下位に反映される点に注意してください。詳細については、フォルダーとアイテムの共有を参照してください。

  • 親フォルダーから継承したフォルダーの権限は、変更(特に権限の引き下げ)ができない場合があります。変更するには、ShareウィンドウのAdvanced Settings にあるInherit permissions from parent folderオプションを無効にして、その親子関係を「切り離す」必要があります。関連情報を参照してください。

ProjectsフォルダーはWorkspaceの最上位フォルダーで、管理者のみがアクセスできます。この階層の下に権限で制御されたフォルダー階層を作成して、Workspaceメンバーのアクセスを管理します。ProjectsフォルダーはWorkspaceの最上位フォルダーで、管理者のみがアクセスできます。この階層の下に権限で制御されたフォルダー階層を作成して、Workspaceメンバーのアクセスを管理します。

共有の概要

Workspaceのブラウザーインターフェースからプロジェクトのアクセス権限を設定するには、インターフェースのProjectsページでプロジェクトのタイルを選択し、そのコンテキストメニューからShareコマンドを選択するか、上部のボタンをクリックします。Projectsページがリスト表示の場合は、プロジェクト項目の右端にあるコントロールをクリックし、表示されるメニューからShareコマンドを選択します。

プロジェクト所有者、Workspace管理者、またはプロジェクトに対するEdit権限と再共有権限を持つユーザーは、プロジェクトを他のユーザーと共有できます。

次のShareウィンドウには、プロジェクトを他のユーザーと共有するために必要なすべてのコントロールが含まれています。

設計プロジェクトをWorkspaceで一元管理していれば、各プロジェクトの権限を管理するだけで他のユーザーと共有できます。設計プロジェクトをWorkspaceで一元管理していれば、各プロジェクトの権限を管理するだけで他のユーザーと共有できます。

共有相手には何が表示されますか?

設計は、Workspaceの他のメンバー、組織内のWorkspaceメンバーではないユーザー、または組織外のユーザーと共有できます。後者のように、たとえば請負業者やパートナーと共有する場合、共有相手は通常、自分のAltium 365 Personal Spaceにある自分と共有ページから設計にアクセスします。外部共有ゲストとして表示されるのは、そのプロジェクトのみです。メンバーリストやライブラリコンポーネントなど、Workspaceの他のデータが公開されることはありません。

関連情報については、こちらのWorkspaceへのアクセスに関するナレッジベースページを参照してください。

Note:共有プロセス中にInvite a User to your Workspaceを行い(下記参照)、その後、そのユーザーを新しいWorkspaceメンバーとして承認すると、そのユーザーはWorkspaceメンバーリストに加えて、すべてのWorkspaceメンバーおよび自身が割り当てられたグループと共有されているプロジェクトも閲覧できるようになります。

注意事項:

  • 権限に関しては、Can Editオプションが選択されている場合、ユーザーまたはグループはプロジェクトへの完全な編集権限を持ちます。それ以外の場合は、閲覧専用のアクセス権となります。

  • OwnerおよびAdministratorsグループは、常に完全な編集権限(Can Edit)を持ちます。

  • OwnerおよびAdministratorsグループを除き、含まれるすべてのユーザーまたはグループの権限は、個別にCan ViewまたはCan Editに設定でき、アクセス権を完全に削除することもできます。

  • Workspaceのバージョン管理(Git VCS)下に置くのではなく、ミラー形式(Simple Sync)でAltium DesignerからWorkspaceで利用できるようにしたプロジェクトは、編集権限(Can Edit)を付与して共有することはできません。編集できるのはプロジェクト所有者のみです。
    ► Altium Designerプロジェクトをオンラインで利用可能にするについての情報を参照してください。

  • プロジェクトは、特定のユーザーやグループと明示的に共有することも、Workspaceの任意のメンバー(またはすべてのメンバー)と共有することもできます。

  • プロジェクトに対する十分な共有権限があれば、Workspaceのメンバーではないユーザーとも共有できます。これらのユーザーはWorkspaceのExternal Share ユーザーとなり、指定した権限レベルで共有プロジェクトにアクセスできますが、Workspaceの他のデータにはアクセスできません。詳細については、外部ユーザーとの共有を参照してください。

特定のユーザーまたはグループとの共有

Workspace内のプロジェクトを指定したユーザーやグループと共有する手順は、次のとおりです。

  1. Share ウィンドウの Share Project With フィールドに、必要なユーザー名/グループ名を追加します。追加するには、目的の名前、メールアドレス、またはグループ名をフィールドに入力し始め、動的リストから該当するユーザー/グループを選択します。このリストには、Workspace のメンバーまたは組織内のユーザー、および Workspace に定義済みのグループのうち、入力内容に一致するものだけが表示されます。複数のユーザー/グループを選択できます。入力したユーザー/グループを削除するには、その項目に対応する コントロールをクリックします。

組織外のユーザーと共有するには、そのユーザーが Altium アカウントを持っているかどうかにかかわらず、完全なメールアドレスを入力して Enter を押す必要があります。

  1. 追加したユーザー/グループの共有アクセス権限を設定するには、対応するドロップダウンメニューから Can View または Can Edit を選択します。後者には閲覧権限も含まれます。この設定は、最初は Share Project With フィールドに含まれるすべての項目(ユーザー/グループ)に適用されます。

  1. このプロジェクトの共有に関する情報を記載する場合は、 コントロールをクリックしてテキスト入力欄を表示します。

  1. Shared With コントロールをクリックすると、現在このプロジェクトの共有先として明示的に指定されているユーザー/グループが表示されます。デフォルトでは、Owner と Administrators グループが含まれます。

Owner と Administrators グループを除き、一覧に含まれるすべてのユーザー/グループの権限は、個別に Can View、Can Edit、Owner に設定することも、アクセス権を完全に削除することもできます。現在の権限の状態をクリックすると、設定用のコントロールが表示されます。► Make Owner オプションの詳細については、プロジェクト所有権の移譲を参照してください。

  1. Workspace のすべてのメンバーにアクセスを許可するには、Workspace Members 項目のドロップダウンメニューから、適切な権限レベル(Can View(読み取り専用アクセス)または Can Edit(完全な読み取り/書き込みアクセス))を選択します。No access に設定すると、所有者、管理者、および共有先として個別に追加されたユーザーのみがアクセスできます。

    Workspace の権限継承の仕組みにより、一部の権限レベルのオプションが無効になる場合があります。これは、親フォルダーから継承された権限を引き下げ、既存の親子間の継承関係に反することを防ぐためです。親子間の継承を意図的に解除するには、Share ウィンドウの 詳細設定で Inherit parent folder permissions オプションを無効にします。

  1. 共有ウィンドウの Advanced Settings には、共有されたプロジェクトを誰が再共有またはダウンロードできるかを制御するオプションがあります。設定は Workspace の Member とゲストレベルのアクセス権に分かれており、編集権限(Can Edit)を付与されたユーザーがプロジェクトを共有できるかどうか、および読み取り専用権限(Can View)を持つユーザーがプロジェクトをダウンロードできるかどうかを指定できます。

    これにより、たとえば外部の委託先による再共有を制限できます。また、閲覧専用アクセス権を持つユーザーについては、ネイティブデータ(プロジェクト自体)および派生データ(生成されたガーバーデータや PDF など)をダウンロードできるかどうかを制御できます。これらのユーザーは、引き続き Web UI でデータを閲覧し、コメントを追加できます。いずれの場合も、Workspace 内のユーザー(メンバー)と Workspace 外のユーザー(外部共有)に対して、それぞれ個別の権限が用意されています。

  • 閲覧専用アクセス権を持つユーザーにダウンロードが許可されていない場合、そのユーザーは Web UI からのみプロジェクトを閲覧できます。Altium Designer で閲覧するには先にプロジェクトをダウンロードする必要があるため、Altium Designer からは閲覧できません。

  • 編集者は常にプロジェクトをダウンロードできますが、閲覧者はプロジェクトを共有できません。ただし、プロジェクトの閲覧者は、指定したユーザーへの共有をリクエストできます()。送信されたリクエストは、以下で詳しく説明するように、そのプロジェクトへの編集アクセス権を持つユーザーが処理します。

設計ソフトウェア内からプロジェクトを共有する際に詳細設定へアクセスするには、Altium Designer 21.3 以降が必要です。

  1. ボタンをクリックして、更新したプロジェクトの共有権限を確定します。その後の動作は、招待するユーザーの種類によって異なります。

  • すでに Workspace のメンバーであるユーザーは、プロジェクトのアクセスリストに直接追加されます。そのユーザーには、プロジェクトが共有されたことと、付与されたアクセス権を知らせるメールが届きます。ユーザーは、許可されていれば Altium Designer でプロジェクトを開くことができ、Altium 365 プラットフォームインターフェース(Projects ページ)からもアクセスできます。

  • 既存の Workspace グループを共有先に追加すると、そのグループはプロジェクトのアクセスリストに直接追加されます。グループの全メンバーに、プロジェクトが共有されたことと、付与されたアクセス権を知らせるメールが届きます。メンバーは、許可されていれば Altium Designer でプロジェクトを開くことができ、Altium 365 プラットフォームインターフェース(Projects ページ)からもアクセスできます。

  • Workspace 外のユーザーには、プロジェクトが共有され、通知メールが送信されます。以下の外部ユーザーとの共有を参照してください。Workspace の External Share ユーザー(下記参照)として、許可されていれば Altium Designer でプロジェクトを開くことができ、Shared with Me ページから自身の Altium 365 パーソナルスペースを通じてアクセスすることもできます。メールからは、Altium 365 を通じて設計に直接アクセスできます。メール内の ボタンをクリックすると、Altium 365 Sign In ページに移動します(すでにプラットフォームまたは Altium アカウントにサインインしている場合を除く)。サインインすると、共有された設計が読み込まれた Web Viewer に直接移動します。

Altium アカウントを持っていない場合は、まずアカウントを作成する必要があります。Altium 365 Sign In ページに登録用のリンクがあります。

Altium Designer 内では、File » Open Project コマンドと、それに対応する Open Project ダイアログを使用してプロジェクトにアクセスします。Workspace のメンバーであれば、接続中の Workspace から開くプロジェクトを選択できます。Workspace に接続すると、その Workspace はダイアログの Locations 領域に、Workspace に付けられた名前で表示され、 アイコンで識別できます。自分に共有されている(アクセス権のある)プロジェクトのみが一覧に表示されます。

外部ユーザーとの共有

Workspace のプロジェクトを「外部」ユーザー(Workspace のメンバーではないユーザー)と共有する手順は、目的と、現在のユーザー自身がそのプロジェクトに対して持つアクセス権によって異なります。ユーザーは、範囲を限定した 外部共有アクセス権を付与するか、共有リクエストを送信するか、または Workspace メンバーとして追加するよう依頼することで、外部ユーザーとプロジェクトを共有できます。最後の方法では、ユーザーの 招待リクエストが作成され、Workspace 管理者が承認または拒否します。

これらの共有方法は、自分の組織内の他のAltium Accountユーザー、別の組織のAltium Accountユーザー、およびAltium Accountを持たないユーザー(共有後にアカウント登録が必要)に適用できます。共有相手が利用できるプロジェクトへのアクセスレベルは、プロジェクトの編集および共有設定によって異なります。

外部共有の適用

プロジェクトの編集権限と共有権限を持つユーザー(管理者を含む)は、他のWorkspaceデータを公開しない、範囲を限定したExternal Shareアクセスを外部ユーザーに付与することで、プロジェクトを共有できます。

Shareウィンドウで、Share Project Withに入力されたメールアドレスで指定した外部ユーザーとプロジェクトを共有する場合、Shareウィンドウで確定すると、共有方法と共有相手を示す確認ウィンドウがさらに表示されます。Request to have these people invited to your Workspace as Membersオプションのチェックを外したまま、このウィンドウで確定()すると、外部ユーザーのExternal Shareアクセスが有効になります。上記のオプションにチェックを入れた場合(有効にした場合)については、招待リクエストの送信を参照してください。

プロジェクトの外部共有の状態は、PropertiesペインのWho Has Accessリストで確認できます。外部ユーザーのアイコンには黄色のドットが表示されます(詳細を確認するにはアイコンにカーソルを合わせます)。プロジェクトのShareウィンドウのShare Withリストでは、ユーザーのエントリに外部共有ラベル()が表示されます。また、管理者はTeamページの外部共有タブで、外部共有のエントリにアクセスして管理できます。

外部ユーザーは、自分のパーソナルスペース、またはアクセス権を持つ別のWorkspaceのShared With Meページから、共有されたプロジェクトにアクセスします。アクセスレベル(編集/表示および共有権限)は、共有時に選択されたオプションによって決まります。

Altium Designerでは、Open ProjectダイアログのShared WIth Meからユーザーのアクセスを利用できます。詳細については、Workspaceチーム外の招待された関係者を参照してください。共有元のWorkspaceでCan Edit共有権限が有効になっている場合、共有プロジェクトをAltium Designer(20.2以降)で編集できます。この場合、プロジェクトの共有は実質的に双方向となるため、外部ユーザーが行った変更はWorkspaceに反映されます。

Workspace外のユーザーに編集を許可する外部共有は、業務委託先向けの厳密に管理されたソリューションです。Workspaceのメンバーとして追加することなく、設計作業に積極的に参加してもらいたい場合に適しています。

詳細については、こちらのWorkspaceへのアクセスに関するナレッジベースページを参照してください。

共有招待リクエストの送信

プロジェクトの編集権限を持つユーザーは、招待リクエスト(外部ユーザーをWorkspaceメンバーとして追加するためのリクエスト)を送信して、外部ユーザーとプロジェクトを共有できます。管理者が承認すると、そのユーザーはプロジェクトとすべてのWorkspaceデータおよび機能にアクセスできるようになります。

この場合、共有確認ウィンドウのRequest to have these people invited to your Workspace as Membersオプションにチェックが入っており(有効)、続くRequest Invitationウィンドウで、リクエストにメモや追加のユーザーを登録できます。ボタンで確定すると、ユーザーが(この時点では)External Share として追加され、Workspace管理者にアクセスリクエストのメールが送信されます。また、Teamページの招待リクエストタブにリクエストのエントリが作成されます。

管理者はリクエストを承認または却下して、このエントリを処理します。承認されると、ユーザーは外部共有ユーザーから新しいWorkspaceメンバーに昇格します。他のメンバーと同様に、プロジェクトへのアクセスレベルは共有時に選択されたオプションによって決まります。管理者がリクエストを却下した場合、ユーザーは引き続きExternal Shareアクセスのみを利用できます。

上記のユーザーがWorkspaceメンバーとして承認された後に削除された場合、そのアクセスレベルはExternal Shareに引き下げられます。つまり、そのユーザーは引き続き共有プロジェクトにアクセスできますが、自分のパーソナルスペースなど、Shared with Meの場所からのみアクセスできます。

共有アクセスリクエストの送信

プロジェクトの共有権限を持たないユーザーは、そのプロジェクトの共有アクセスリクエストを送信することで、外部ユーザーとの共有を申請できます。このリクエストは、プロジェクトの完全な共有権限(Editおよび共有)を持つWorkspaceメンバーであれば誰でも処理できます。承認されると、指定されたユーザーに、そのプロジェクトへの外部共有アクセスが付与されます。

この場合、Shareウィンドウでは、指定したユーザーに対するプロジェクトの共有アクセスリクエストを送信できます()。このプロジェクトの編集権限を持つユーザーには、プロジェクトのShareウィンドウへのOpen sharing settingsリンクを含むアクセスリクエストのメールが送信されます。 

アクセスリクエストのメールを受信したWorkspaceユーザーは、プロジェクトのShareウィンドウにある対応するPending Approvalエントリで、対象ユーザーに適切なEdit/View権限を指定し、設定を確定()することで対応できます。続く確認ウィンドウには、対象ユーザーがWorkspace外のユーザー(メンバーではない)であることを示す警告が表示されます。承認する応答()を選択すると、そのユーザーにプロジェクトへの外部共有アクセスが付与されます。 

リクエストの対象となり、アクセスが承認されたユーザーが、外部ユーザーではなく既存のWorkspaceメンバーである場合、そのユーザーにはプロジェクトへのWorkspaceレベルのアクセスが付与されます。以下の アクセスリクエストへの対応 を参照してください。

新しいWorkspaceメンバーの追加による共有

Workspace管理者は、外部ユーザーを正式なWorkspaceメンバーとして追加することで、プロジェクトをすぐに共有できます。これにより、そのユーザーはプロジェクトとすべてのWorkspaceデータおよび機能にアクセスできるようになります。

共有確認ウィンドウのRequest to have these people invited to your Workspace as Membersオプションにチェックが入っており(有効)、続くInvite Team Membersウィンドウで、リクエストにメモや追加のユーザーを登録できます。ボタンで確定すると、外部ユーザーが新しいメンバーとして追加されることを通知する最終ウィンドウが開きます。

ウィンドウのボタンをクリックして、処理を完了します。それまで外部ユーザーだったユーザーが、新しいWorkspaceメンバーになります。他のメンバーと同様に、編集/共有のアクセスレベルは、共有時に選択されたオプションによって決まります。

組織内での共有

上記の特定のユーザーやグループとのプロジェクト共有とは別に、ShareウィンドウのAnyone in <company> can accessオプションを選択すると、組織の全メンバーに基本的な表示専用アクセスを付与できます。対象となる組織のメンバーは、組織のDashboardのUsersページで定義されているユーザーです。

このレベルの共有のみが適用されている場合、組織内のすべての登録ユーザーは、Altium Designerと各自のAltium 365 Personal Spaceの両方で、Shared with Meオプションからプロジェクトにアクセスできます。すべてのユーザーのアクセス権は表示専用ですが、プロジェクトの所有者とワークスペースの管理者は、引き続きワークスペース自体を通じて完全なアクセス権を保持します。

特定のワークスペースメンバーへのView/Edit権限など、プロジェクトに適用された個別の共有設定は、組織全体を対象とする基本的な共有に追加されるものです。たとえば、その後プロジェクトを特定のワークスペースユーザーと共有すると、そのユーザーは、Personal Spaceでの既存の組織向け表示専用アクセスに加え、ワークスペース内でも適用された権限でプロジェクトにアクセスできるようになります。

直接リンクによる共有

プロジェクトへの直接リンクを共有することもできます。リンクは、Sharing ウィンドウの下部にあるコントロールをクリックして取得します。このリンクでは、プロジェクトの現在の共有権限に基づいてアクセスが許可されます。

  • For members of the Workspace – アクセス権は、Workspace Membersエントリの権限設定(No access、Can View、Can Edit)、またはそのユーザー名(あるいは所属するグループ)に対して明示的に設定されたShare Withエントリの権限によって決まります。

  • For users outside of the Workspace – アクセス権は、そのユーザー名に対して明示的に設定されたShare Withエントリと、その名前に適用された権限によって決まります。アクセスするには、ユーザーがAltium Accountに登録し、サインインしている必要があります。このユーザーは 外部共有 ユーザーに分類されます。

プロジェクトへの直接リンクを取得します。このリンクの使用には、Sharing ウィンドウの既存の共有権限が適用されます。プロジェクトへの直接リンクを取得します。このリンクの使用には、Sharing ウィンドウの既存の共有権限が適用されます。

リンクはクリップボードにコピーされます。このリンクを使用すると、権限のあるユーザーはプロジェクトの詳細管理ページに直接アクセスできます。詳細については、以下のセクションを参照してください。

一方、リンクを開いたユーザーにプロジェクトへのアクセス権がない場合、つまりそのユーザーとプロジェクトが共有されていない場合は、アクセスリクエストを送信する方法が提示されます。

リンク先のプロジェクトにアクセスできない場合、ユーザーはアクセスリクエストを送信でき、適切なワークスペースユーザーがそのリクエストを処理できます。以下を参照してください。

リンク先のプロジェクトにアクセスできない場合、ユーザーはアクセスリクエストを送信でき、適切なワークスペースユーザーがそのリクエストを処理できます。以下を参照してください。

 

アクセスリクエストへの対応

ユーザーがアクセスリクエストを送信した際に、そのプロジェクトを共有できる(アクセス権を付与できる)ユーザーは、前述のとおり、ShareダイアログのプロジェクトのAdvanced Settingsによって決まります。ここで「編集者」とは、プロジェクトの編集権限(Can Edit)を持つユーザーを指します。なお、ワークスペースの管理者とプロジェクトの所有者は、常にプロジェクトを共有できます。

ワークスペースのAdmin-SettingsページでEmail Notificationsオプションが有効になっている場合は、該当するアクセスリクエストのメールもこれらのユーザーに送信されます。送信先は、プロジェクトのSh共有ウィンドウの詳細設定に基づいて、次のように決まります。

  • ワークスペースメンバーである編集者による共有が有効な場合、管理者、プロジェクトの所有者、およびそのプロジェクトの編集権限を持つメンバーに、アクセスリクエストのメールが送信されます。

  • 外部共有の編集者(ワークスペース外の編集者)による共有が有効な場合、管理者、およびそのプロジェクトの編集権限を持つゲストレベルのユーザーに、アクセスリクエストのメールが送信されます。

  • このプロジェクトで編集者に関する両方のオプションがオフになっている場合、管理者にのみアクセスリクエストのメールが送信されます。

Note: プロジェクトをすべてのワークスペースメンバーに編集権限を付与して共有するように設定し、Advanced Settingsで編集者による共有を許可している場合、allワークスペースメンバーに共有リクエストのメールが送信されます。

アクセスリクエストのメールを受信したユーザーは、メール内のOpen sharing settingsボタンからリクエストに対応できます。このボタンをクリックすると、そのプロジェクトのShareウィンドウが開き、保留中のリクエストを承認(ViewまたはEdit権限を付与)するか、拒否できます。 なお、共有ウィンドウのPending approvalエントリへのアクセスは、Access Requestメールの受信を条件としません。いつでもShareダイアログから直接リクエストを処理できます。 共有権限を指定すると、リクエストしたユーザーに対応するレベルのプロジェクトアクセス権が付与され、 共有承認処理の結果を通知するメールが送信されます。

リクエストを送信してアクセスを承認されたユーザーが、ワークスペースの既存メンバーではない場合、つまり外部ユーザーの場合は、プロジェクトへの外部共有アクセスが付与されます。上記の 共有アクセスリクエストの送信を参照してください。

プロジェクトの所有者に送信されるアクセスリクエストのメールには、そのプロジェクトの共有プロパティへの直接リンクが含まれています。プロジェクトの所有者に送信されるアクセスリクエストのメールには、そのプロジェクトの共有プロパティへの直接リンクが含まれています。

マルチボードプロジェクトの共有

マルチボードプロジェクトは、複数のPCB設計プロジェクトをまとめ、完全に機能するシステムを構成する特別なプロジェクト形式です。サブプロジェクトは親のマルチボードプロジェクトにリンクされており、それらのデータを取り込んでシステム全体の電気的および物理的な接続を確立できます。

マルチボードプロジェクトの操作については、マルチボード設計を参照してください。

マルチボードとそれに関連するサブプロジェクト間のリンクは、マルチボードプロジェクト自体に相対パスとして保存されます(*.PrjMbd)。そのため、設計クライアントからプロジェクトをWorkspace VCSに保存する際も、これらのパスが有効な状態を維持する必要があります(Project » Make available Online)。実際には、allプロジェクトがWorkspaceに保存され、正しいフォルダー構造に配置されていることを確認する必要があります。ただし、ほとんどの場合、マルチボードシステムに含まれるすべてのプロジェクトは同じフォルダー内に配置されます。

マルチボードプロジェクトを共有する際も、同様の点に注意する必要があります。親のマルチボードプロジェクトとその関連サブプロジェクトは、同じWorkspaceメンバーに対し、同じ表示/編集権限で共有する必要があります。その後、ユーザーが設計クライアントでマルチボードプロジェクトを初めて開く際には、関連するサブプロジェクトも開く必要があります。この場合も、ローカルの相対フォルダー構造が正しいことを確認してください。

マルチボードプロジェクトとそのサブプロジェクトは、いずれも個別のプロジェクトとしてオンラインに保存し、共有して開く必要があります。マルチボードプロジェクトとそのサブプロジェクトは、いずれも個別のプロジェクトとしてオンラインに保存し、共有して開く必要があります。

プロジェクト所有権の移譲

Workspace管理者に加え、プロジェクトの所有者(デフォルトではプロジェクトを作成または追加したユーザー)は、プロジェクトに対する完全な編集権限を持ちます。一方、プロジェクトへの共有アクセス権を持つ他のメンバーには、プロジェクトのShareウィンドウで指定されたEdit/View権限が付与されます。

Shareウィンドウには現在のプロジェクト所有者が表示され、所有権を別のWorkspaceメンバーに移譲するオプションが用意されています。Shareウィンドウには現在のプロジェクト所有者が表示され、所有権を別のWorkspaceメンバーに移譲するオプションが用意されています。

プロジェクトのOwnerステータスと、それに伴う編集権限は、プロジェクトのShareウィンドウから別のWorkspaceメンバーに移譲できます。これにより、新しい所有者はそのプロジェクトを完全に管理できるようになります。このオプションは、管理者と現在のプロジェクト所有者が利用できます。移譲先として指定できるのは他のWorkspaceメンバーのみで、EngineersやAdministratorsなどのメンバーグループは指定できません。

所有者のステータスと権限セットを受け取るには、Workspaceメンバーがそのプロジェクトへの共有アクセス権をすでに持っている必要があります。そのメンバーのプロジェクトに対する現在のView/Edit権限設定は、Shareウィンドウの権限ドロップダウンメニューからOwnerに変更できます(Make Owner)。ウィンドウのボタンをクリックし、続いて表示される警告ウィンドウで所有権の移譲を確定します()。

権限ドロップダウンメニューのMake Ownerオプションを使用して、プロジェクトの所有権を別のWorkspaceメンバーに移譲します。権限ドロップダウンメニューのMake Ownerオプションを使用して、プロジェクトの所有権を別のWorkspaceメンバーに移譲します。

  • 所有権を移譲すると、以前の所有者には、そのプロジェクトに対する Editing権限が付与されます。プロジェクトがバージョン管理されていない場合(SimpleSync)は、Viewのみの権限が付与されます。必要に応じて、新しい所有者または管理者が、以前の所有者のアクセス権限を変更できます。

  • 所有者がWorkspaceのメンバーから削除される場合、所有権の移譲が自動的に開始されます。管理者がWorkspaceメンバーページからメンバーを削除すると、削除処理中に、そのメンバーが所有するプロジェクトとアイテムの新しい所有者を指定するよう求められます。確定して移譲が完了すると、新しい所有者に所有権移譲の通知メールが送信されます(通知が有効な場合)。

    詳細については、ユーザーの削除を参照してください。

Workspaceのメール通知が有効になっている場合、新しいプロジェクト所有者に所有権移譲の通知メールが送信されます。

プロジェクトの詳細管理ページへのアクセス

Main page: 特定のプロジェクトの管理

Workspaceには、製造を重視した高度なCAD中心のプロジェクトビューが用意されています。このビューを開くには、対象のプロジェクトを選択し、プロジェクト一覧の上にあるコントロールをクリックして、表示されるメニューからOpen 項目を選択します。または、一覧内の対象プロジェクトの項目を直接ダブルクリックします。

Projectsページのグラフィカル表示でも、対象プロジェクトのタイルを選択し、コントロールをクリックして、コンテキストメニューからOpenコマンドを選択すると、このビューを開くことができます。または、タイル内のプロジェクト名をクリックします。Projects ページがリスト表示になっている場合は、対象プロジェクトの項目の右端にあるコントロールをクリックし、表示されるメニューからOpen コマンドを選択します。

そのプロジェクトの詳細管理ページが新しいブラウザータブで開きます。このページにはCAD中心のインターフェースが組み込まれており、設計、シミュレーション、リリース、履歴、アセンブリの各表示オプションを利用できます。

  • Design – ソースプロジェクトの設計ドキュメントの表示と閲覧、設計オブジェクトのプロパティの確認、レビューコメントの追加を行います。このビューでは、Web Viewerインターフェースを使用して、ソース回路図、2D基板、3D基板、部品表にそれぞれ対応する4つのデータサブビューで設計を表示します。このビューは、プロジェクトの特定のリリースではなく、ソースプロジェクトデータの最新バージョンを表示するため、作業中(WIP)のビューと見なすことができます。基本設計と、定義済みのバリアントの両方をレビューできます。
設計全体および該当する各サブビューで、部品やネットの検索、選択、クロスプローブ、詳細確認を行えます。また、基板の2D表示では、寸法の測定も可能です。

  • Simulation – 現在のプロジェクトまたはプロジェクトリリースに関連付ける回路シミュレーション結果ファイルを、アップロード(ドラッグ&ドロップ)できます。ファイルは実質的にプロジェクトに添付されるため、Workspaceのメンバーは、現在開いているプロジェクトに関連するシミュレーション結果のドキュメントを確認したり、ダウンロードしたりできます。詳細については、特定のプロジェクトの管理 – シミュレーションを参照してください。

  • Tasks – 現在開いている設計プロジェクトに適用される作業依頼(Tasks)にアクセスし、管理できます。タスクはカンバンボード形式で表示され、進行状況(ToDo、InProgress、Resolved)ごとにタスクの行が配置されます。1つの行はGeneral Tasks用に確保され、残りの各行には、特定のプロジェクトドキュメントのタスクが表示されます。これらの行には、開いているプロジェクトに関連付けられたタスクが表示されます。タスクは、プロジェクトのコメントが特定のユーザー(Workspaceのメンバー)に割り当てられたときに作成されます。この意味で、Workspaceのタスクシステムは、実質的にコメントシステムを拡張したものです。また、Newボタンから一般タスクを作成することもできます。これらのタスクは現在のプロジェクトに適用されますが、プロジェクトのコメントやドキュメントには関連付けられません。

なお、購入したソフトウェアのアクセスレベルによっては、Workspaceでプロセスワークフローに基づく高度なタスクシステムも利用できます。

  • Releases – プロジェクトのリリースを表示します。リリースデータ全体、または特定のアセンブリパッケージを開くことができ、Manufacturing Portalを通じて別のタブに表示されます。このポータルでは、リリースされたファイルデータの表示や閲覧、BOMの確認に加え、リリースデータのソースとなる設計自体のスナップショットの表示やコメントの追加ができます。Releases ビュー、または特定のリリースのManufacturing Portalから、さまざまな単位(データセット全体から、生成された個々の出力ファイルまで)で製造データをダウンロードするためのコントロールにアクセスできます。選択したリリースを、Manufacturing Packageとして製造業者に直接送信することもできます。また、ガーバー、回路図、またはBOMのデータを直接比較することもできます。詳細については、プロジェクトリリースを参照してください。

Altium 365プラットフォームには、Global Sharingサポートの一部として専用のManufacturing Package Viewerが用意されています。これにより、他のユーザーは世界中のどこからでも、任意のWebブラウザーを使用して、Workspaceの外部で製造パッケージを表示できます。そのため、設計自体やその他の貴重な知的財産へのアクセスは制限されたまま維持されます。詳細については、グローバル共有および製造パッケージビューアーを参照してください。

  • Activities – 現在のプロジェクトに適用される、進行中(現在アクティブ)または終了済み(完了または中止)のプロセスワークフローの状況を確認できます。これらには通常、Ad-hoc、Milestone、 Handoffなどのピアレビューワークフローに関連するアクティビティが含まれます。利用できるかどうかは、Altiumソフトウェアのアクセスレベルによって異なります。

    詳細については、アクティビティを参照してください。

  • Design Reviews – 他のユーザー(レビュアー)に評価を依頼できる、体系化されたプロジェクトレビューを作成・管理します。レビューはタスクベースで進められ、承認または却下が可能です。また、設計のスナップショット、定義可能なチェックリスト、コメント、ドキュメントの添付、設計ソースの比較などの追加機能も備えています。利用できるかどうかは、Altiumソフトウェアのアクセスレベルによって異なります。

    詳細については、設計レビューページを参照してください。

  • History – プロジェクトの作成、コミット、リリース、クローン、MCADとのデータ交換など、プロジェクトに関連する主要なイベントを時系列で閲覧できます。プロジェクトに関連してサポート対象のイベントが発生するたびに、そのイベントが専用のタイルとしてタイムラインに追加され、該当する場合は各種操作を実行できます。リリース/コミットイベントでは、ガーバー(リリースイベントのみ)、回路図、またはBOMのデータを直接比較することもできます。詳細については、プロジェクト履歴を参照してください。

  • Assembly Assistant – 対話型のAssembly Assistantツールを使用して、基板の組み立て工程を確認しながら進めます。このツールは、プロジェクトの詳細なBOMデータと2D/3Dアセンブリビューを統合し、組み立て工程を順に進めるために必要なグラフィック情報と部品情報を提供するインターフェースを表示します。詳細については、Assembly Assistantページを参照してください。

 

プロジェクトの詳細管理ページには、Altium Designer内からもアクセスできます。アクティブなプロジェクトについては、メインメニューのProject » Show in Web Browserコマンドを使用します。または、Projectsパネルでプロジェクトの項目を右クリックし、コンテキストメニューからShow in Web Browserコマンドを選択します。Altium DesignerのExplorerパネルでプロジェクトを閲覧している場合(Classic Viewではなく、デフォルトのProject Viewに設定されている場合)は、ボタンをクリックすると詳細管理ページにアクセスできます。

プロジェクトの移動

フォルダー階層内の別の親フォルダーにプロジェクトを移動するには、Projectsページでその項目を選択し、プロジェクト/フォルダーの一覧の上にあるコントロールをクリックして、表示されるメニューからMove の項目を選択します。

Projectsページのグラフィカルビューでも、対象のプロジェクトのタイルを選択し、コントロールをクリックして、コンテキストメニューからMoveコマンドを選択することで移動できます。Projectsページがリストビューで表示されている場合は、対象のプロジェクトの項目の右端にあるコントロールをクリックし、表示されるメニューからMove コマンドを選択します。

Move project ウィンドウが表示され、新しい親フォルダーを選択できます。ボタンをクリックして移動を実行します。プロジェクトは選択したフォルダーに移動され、そのフォルダーが表示されます。

プロジェクトを別の親フォルダーに移動する際は、Workspaceの高度な権限継承の仕組みが適用されることに注意してください。

詳細については、コンテンツ構造とアクセスの管理ページのフォルダーの移動セクションを参照してください。

プロジェクトは、どの段階でもプロジェクトのフォルダー階層内の任意のフォルダーに移動できます。

プロジェクトは、どの段階でもプロジェクトのフォルダー階層内の任意のフォルダーに移動できます。

 

プロジェクトの編集

Workspace内の既存のプロジェクトのプロパティを編集するには、Projectsページでその項目を選択し、プロジェクト一覧の上にあるコントロールをクリックして、表示されるメニューからEdit の項目を選択します。続いて簡易表示で開くEdit Projectウィンドウで、プロジェクトのNameとDescriptionを変更できます。

Projectsページのグラフィカル表示でも、対象プロジェクトのタイルを選択し、コントロールをクリックして、コンテキストメニューからEditコマンドを選択することで利用できます。Projects ページがリスト表示の場合は、対象プロジェクトのエントリの右端にあるコントロールをクリックし、表示されるメニューからEdit コマンドを選択します。

プロジェクトのNameとDescription は、いつでも編集できます。プロジェクトのNameとDescription は、いつでも編集できます。

ボタンをクリックすると、Edit Projectウィンドウの追加フィールドにアクセスできます。

追加フィールドには、Advanced ボタンをクリックしてアクセスします。追加フィールドには、Advanced ボタンをクリックしてアクセスします。

  • Requirements – 設計プロジェクトで利用できるこのフィールドでは、関連するRequirements Portalブロックを現在のプロジェクトにリンクできます。この接続により、設計プロジェクト内から要件にリアルタイムでアクセスできるようになります。ロックを解除しない限り、読み取り専用です。関連情報については、要件の操作を参照してください。

  • Jira – この詳細フィールドは、ワークスペースでJira連携が有効になっている場合に利用できます。設計プロジェクトからAtlassian Jira®プロジェクトへのリンクを設定するために使用し、Altium 365のコメントとタスク機能を通じて、両者の間でタスクを双方向に同期できるようになります。Jira入力フィールドをクリックすると、利用可能なJiraプロジェクトのリストから選択できます。このマッピングオプションは、Jiraアプリケーションの設定で全ユーザーに対して有効にしない限り、管理者のみが利用できます。詳細については、Jiraタスクの操作ページを参照してください。

  • Project – このフィールドは、管理対象BOMプロジェクトの編集時にのみ利用でき、BOMドキュメントとPCB設計プロジェクト間のリンクを指定します。このリンクにより、ソースプロジェクトの部品データを、リンクされたBOMに同期できます。プロジェクトから作成されたBOMドキュメントでは、自動的に設定されます。このリンクを再設定または削除すると、プロジェクトからBOMへの同期が解除されることに注意してください。プロジェクトへのリンクを参照して選択するには、フィールドのオプションを使用します。

  • Parameters – このコントロールをクリックすると、プロジェクトのサーバー側パラメーターを管理する領域が展開されます。パラメーターの名前と値のペアを追加()、編集(インライン編集)、削除()できます。

    プロジェクトのサーバー側パラメーターを編集します。プロジェクトのサーバー側パラメーターを編集します。

プロジェクトのサーバー側パラメーターを編集します。

サーバー側のプロジェクトパラメーターは、プロジェクトとともにワークスペースに保存され、ワークスペース内でのみ編集できます。一方、設計側のプロジェクトパラメーターはプロジェクトファイル(*.PrjPcb)に保存され、Altium Designerで編集できます。どちらのパラメーターも、Altium Designerで特殊文字列として使用できます。設計ワークスペースに配置したテキスト文字列を選択し、Propertiesパネルからアクセスします。プロジェクトに定義されているすべてのパラメーター(設計側およびサーバー側)は、Project Optionsダイアログ(Project » Project Options)のパラメータータブで確認できます。

ボタンをクリックして、変更内容を確定します。

プロジェクトのクローン作成

既存のプロジェクトのクローンを作成するには、Projectsページで対象のエントリを選択し、プロジェクト一覧の上にあるコントロールをクリックして、表示されるメニューからClone を選択します。Clone Projectウィンドウが表示されます。

Projectsページのグラフィカル表示でも、対象プロジェクトのタイルを選択し、コントロールをクリックして、コンテキストメニューからCloneコマンドを選択することで利用できます。Projects ページがリスト表示の場合は、対象プロジェクトのエントリの右端にあるコントロールをクリックし、表示されるメニューからClone コマンドを選択します。

プロジェクトのクローンを作成すると、作業ファイルも含めて同一のコピーを作成できます。プロジェクトのクローンを作成すると、作業ファイルも含めて同一のコピーを作成できます。

Clone Projectウィンドウで、プロジェクト名と任意の説明を指定します。デフォルトでは、元のプロジェクト名に接尾辞「 – Copy」が付加され、デフォルトの説明があらかじめ入力されます。

クローンプロジェクトの名前は、A~Z、a~z、または0~9で始める必要があり、これらの文字を使用できます。アンダースコア、ハイフン、スペースも使用できますが、スペースは名前の途中でのみ使用できます(先頭と末尾のスペースは無視されます)。次の語は使用できません:AUX、COM1-COM9、LPT1-LPT9、CON、NUL、PRN。また、名前に次の文字を含めることはできません:\ . / ? % * : | " < >。ソースプロジェクトと同じ名前は使用できません。

ボタンをクリックすると、Parent Folderフィールドにアクセスできます。デフォルトでは、ソースプロジェクトがあるフォルダーに設定されます。フィールドの右側にあるChange リンクをクリックすると、ワークスペースのサーバーフォルダー構造にアクセスし、クローンプロジェクトを保存する別のフォルダーを選択できます。必要に応じて、プロジェクトをサブフォルダーの階層に整理できます。詳細については、プロジェクトフォルダーの階層の作成セクションを参照してください。

各フィールドを必要に応じて設定したら、ボタンをクリックします。元のプロジェクトは、その構成ファイルおよびデータとともにクローン(複製)が作成され、Projectsページの一覧に新しいプロジェクトエントリとして追加されます(選択した親フォルダー内)。作成されたクローンは実質的に新しいプロジェクトであるため、その権限は新しいプロジェクトの作成(またはアップロード)時と同じ方法で設定されます。つまり、権限はデフォルトで親フォルダーから継承され、クローンを作成したユーザーが所有者になります。関連情報については、プロジェクト作成権限の管理も参照してください。

プロジェクトの削除

Related page: ゴミ箱

既存のプロジェクトをワークスペースから削除するには、Projectsページで対象のエントリを選択し、プロジェクト一覧の上にあるコントロール、またはプロジェクトのタイル内にあるコントロールをクリックして、表示されるメニューからRemove を選択します。Projectsページがリスト表示の場合は、対象プロジェクトのエントリの右端にあるコントロールをクリックし、表示されるメニューからRemoveコマンドを選択します。

削除できるのは、プロジェクトの所有者またはワークスペース管理者のみです。

続いて表示されるRemove <project>ウィンドウには、関連するリリースなど、プロジェクトとともに削除されるアイテムが一覧表示されます。Show detailsオプションを選択すると、プロジェクトのリリースビューが開き、関連するリリースや製造パッケージを確認できます。プロジェクトに関連するリリースがない場合は、簡易版のRemoveウィンドウが表示されます。

ワークスペースのプロジェクトの削除は、実際には「論理削除」であり、プロジェクトと関連するアイテムはワークスペースのTrash 領域に移動されます。Remove <project>ウィンドウのボタンで削除処理を確定します。

特定のプロジェクトに関連付けられた特定の製造パッケージのみを論理削除する場合は、そのプロジェクトのReleasesビューから直接実行できます。

削除が完了すると、プロジェクトはメインのプロジェクト一覧から削除されます。Altium Designerのローカル作業コピーはこの操作の影響を受けませんが、サーバーに変更をコミットできなくなります。ローカルプロジェクトが参照するVCSリポジトリが存在しなくなるため、ローカル作業コピーを閉じて再度開くと、推奨される各種操作を確認できます。

この方法で削除したすべてのプロジェクトは、インターフェースのTrash ページで確認できます。ただし、表示できるのは、自分自身が論理削除したプロジェクト(およびその他のアイテム)のみです。管理者は、Trash ページのすべてのコンテンツ、つまり論理削除されたすべてのアイテムを確認できます。

論理削除されたプロジェクトに関する注意事項:

  • 設計ソフトウェアやWebインターフェースから、そのプロジェクトを開いたり閲覧したりすることはできなくなります。

  • プロジェクトがWorkspace外のユーザーと共有されていた場合、共有先のすべての外部ユーザーについて、Altium 365プラットフォームインターフェースのShared with Meページから、そのプロジェクトのタイルが削除されます。

  • プロジェクトとともに削除された共有製造パッケージも、共有先のすべてのユーザーについて、Altium 365プラットフォームインターフェースのShared with Meページから削除されます。

  • プロジェクトで使用されていたアイテムを閲覧すると、そのプロジェクトの使用先エントリには、プロジェクトが削除されたことが表示されます。

  • Trash ページからプロジェクトを復元または完全に削除できるのは、そのプロジェクトの所有者またはWorkspace管理者のみです。

プロジェクトを論理削除してTrashに移動した場合、同じ名前で新しいプロジェクトを作成できます。その後、削除したプロジェクトを復元する際に元の名前がすでに使用されている場合は、Workspace内で名前が重複しないように、末尾に整数が付加されます。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

Contents