CoDesignerによるECAD-MCADの直接連携設計

このCoDesignerドキュメントを利用するには、次のものが必要です。

動画で学習したい場合は、MCAD CoDesignハウツー動画のページをご覧ください。

電子製品の設計と開発における注目すべき進化の一つが、製品の一部となるプラスチック成形品などの基材に、電子回路を直接印刷できるようになったことです。Altiumは、3D構造上で直接レイアウトと配線を行うことで、プリンテッドエレクトロニクスおよび立体回路部品(MID)の設計を支援する技術を開発しています。現段階では、必要な設計アプローチが異なるため、CoDesignerはECADとMCAD間でのプリンテッドエレクトロニクス設計の転送をサポートしていません。開発は進行中で、今後のアップデートでサポートが追加される予定です。

CoDesignとは?

電子設計と機械設計の領域をまたいで作業する際には、特有の課題が生じます。ECADツールとMCADツールは設計目的が異なり、それぞれ異なる道筋で進化してきました。データの保存方法や管理方法も異なります。

しかし、今日の設計では、この課題を解決することが求められます。不規則な形状の複数のプリント基板を収める、小型で複雑な製品筐体などをうまく設計するには、設計者がECADとMCADの領域間で設計変更をやり取りしながら連携できなければなりません。

異なる設計ソフトウェア間で複雑かつ詳細な設計変更をやり取りするには、単に別の形式でデータを保存できるだけでは不十分です。電子設計チームと機械設計チームは独立して作業するため、設計プロセスのどの段階でも変更を転送できる必要があります。両チームの日常の設計業務に影響を与えることなく、チーム間で双方向にやり取りされる変更をどのように管理すればよいのでしょうか。設計チームにとって最も避けたいのは、一方のチームが最新の変更を受け入れるまで、もう一方のチームが作業を中断しなければならず、両チームが先に進めなくなることです。

この共同設計の課題を解決するのが、ECADとMCADの設計領域間でプリント基板設計を転送するためのインターフェース、CoDesignerです。

仕組み

ECADおよびMCADソフトウェアにCoDesignerプラグインを追加すると、Altium Workspaceを介して設計変更を双方向にやり取りできるようになります。以下に示すように、WorkspaceはECADとMCADの領域をつなぐ橋渡し役として機能します。

PCB design data can be transferred in both directions between ECAD and MCAD through an Altium Managed Content Server

Workspaceを介して設計変更をやり取りする利点は、更新プロセスがstatelessになることです。つまり、各チームは相手の設計プロセスがどこまで進んでいるかを気にすることなく、独立して作業を続けられます。

たとえば、MCAD設計者は基板形状を定義したら、アセンブリをWorkspaceにPushできます。ECAD設計者には、未処理の変更があることが自動的に通知されます。Pullをクリックすると、その基板とWorkspace内のMCAD基板定義が比較され、基板をWorkspaceのバージョンと同期させるために必要な変更の一覧が生成されます。ECAD設計者は、必要な変更を有効にして、基板にApplyできます。その後、ECAD設計者はレイヤースタックで必要な各種銅箔層やその他の製造用レイヤーを設定し、基板の厚さを定義して、更新した基板をMCAD設計者にPushできます。これで、配置位置が重要なメカトロニクス部品を配置する準備が整います。

Workspaceとは?

Altium Workspaceは、すべての設計コンテンツをホストして管理するための専用サーバーで、設計ソフトウェアに直接接続されます。Altiumの設計ソフトウェアはWorkspaceとシームレスに連携し、設計データの整合性とセキュリティを確保しながら管理するための優れたソリューションを提供します。

  • Altium Workspaceは、購入したAltiumソリューションに応じて、Altium Develop Workspace またはAltium Agile Workspace という名称で提供されます。このドキュメントでは、どちらのWorkspaceについても、一般的な呼称であるAltium Workspaceなどを使用します。

  • Altium 365プラットフォームのセキュリティ、信頼性、プライバシー、コンプライアンスに関する最新情報については、Altium 365 Trust Centerをご覧ください。

  • ITARやEARなどの米国政府のセキュリティ規制への準拠が必要な組織向けに、Altiumは米国を拠点とするAltium 365 GovCloudを提供しています。これはAWS GovCloudリージョンで稼働し、追加のデータ保護対策を提供します。 詳細については、Altium 365 GovCloudおよび関連するFAQを参照してください。

Altiumの設計ソフトウェアは、次のWorkspaceに接続できます。

  • Altium 365 Workspace - Altium 365クラウドベースのインフラストラクチャプラットフォームでホストされるWorkspaceです。このWorkspaceは、設計、製造、サプライの各領域をシームレスにつなぎ、領域間でデータを移動する仕組みを提供します。クラウドベースのAltium 365プラットフォームでのみ利用できる、さまざまなグローバル共有機能や共同作業機能を活用できるため、クラウドベースのWorkspaceを推奨します。
  • Altium On-Prem Enterprise Server Workspace - 設計チームがクラウドでホストされるWorkspaceを使用できない場合に備え、Altiumは、自社内にインストールして社内のIT部門で管理するオンプレミスのEnterprise Serverもサポートしています。

接続されたWorkspaceを使用した設計について詳しく見る

Personal Spaceとは?

Altium Liveに登録したすべての設計者は、自分専用のAltium 365 Personal Spaceも利用できます。Personal Spaceは無料で、Workspaceで利用できる共同作業機能の一部を提供します。また、Personal Spaceは、Altium CircuitMakerとAutodesk Fusionを使用する設計者向けのECAD-MCAD間の転送インターフェースとしても使用されます。

Altium 365 Personal Spaceについて詳しく見る

Altium CircuitMakerとAutodesk Fusion間の共同作業について詳しく見る

お使いのMCADソフトウェアでCoDesignerが動作するかどうかを確認したい場合は、Altium MCAD CoDesignerのインストールと設定のページで、サポート対象のMCADソフトウェアの一覧をご確認ください。

設計データの転送

Workspaceの役割

MCAD CoDesignerは、Altium Workspaceを介して設計変更をプッシュおよびプルすることで、ECADとMCAD間で設計を転送します。ECADからプッシュを実行すると、PCBファイルではなく、専用のECAD-MCAD間データパッケージがAltium Workspaceに送信されます。このパッケージには、基板データ、レイヤージオメトリ、Parasolid形式の部品3Dモデル(MCADでの3Dモデルの命名方法について詳しく見る)、および有効になっている場合は銅箔ジオメトリが含まれます。

ECADまたはMCADでプッシュを実行すると、CoDesignerはまずローカルサブフォルダー<DesignName>-EDM内にデータパッケージを準備します。MCAD側では、EDMフォルダーはMCADデータの保存にも使用されます。その後、このデータパッケージはAltium Workspace内のMechatronic 3D Modelsという専用フォルダーに転送されます。このフォルダーは、MCAD CoDesignerがECAD-MCAD間データを保存するためだけに使用します。MCAD CoDesignerを使用している場合は、このフォルダーを削除または移動したり、電気設計者や機械設計者のアクセスを制限したりしないでください。

メカトロニクス3Dモデルの転送について詳しく見る

ECAD-MCAD間のオブジェクト変換

基板設計をECADとMCADの間で相互に転送する際には、一方の設計環境のオブジェクトを、もう一方の設計環境の対応するオブジェクトに変換する必要があります。 変換が単純なオブジェクトもあります。たとえば、ECADの取り付け穴はMCADの穴になり、MCADの基板パーツはECADの基板形状になります。

一方、それほど単純に変換できないオブジェクトもあります。たとえば、ECAD部品には、製造される基板の一部となるシルクスクリーンやパッドなどのフットプリント要素(パッドには、銅箔やソルダーマスクなどのレイヤー固有の詳細や穴が含まれます)に加え、PCB実装時にそのフットプリント上に搭載される部品の3Dモデルが含まれます。MCADでは、ECAD部品内の基板に関連するすべての要素がMCAD基板パーツの一部となり、3DモデルがMCAD部品になります。 

このオブジェクト変換は、最初は混乱を招くことがあります。たとえば、MCADで部品を移動しても、部品のパッドとその穴は元の位置に残ります。基板をECADにプッシュし、その後再びMCADにプルすると、それらのパッドの位置が更新され、部品の新しい位置に一致します。

理解を深めるため、以下の折りたたみセクションでは、それぞれの方向でオブジェクトがどのように変換されるかをまとめています。

サーバーへの保存時にCoDesignerで自動プッシュ

ECADでSaveを実行すると、設計ファイルはローカルのプロジェクト作業フォルダーに保存されます。Save to Serverを実行すると、ファイルはローカルに保存された後、プロジェクトのWorkspaceフォルダーにも保存されます。

これらの操作は、MCAD CoDesignerでのPushの実行とは独立しています。MCADへのプッシュとサーバーへの保存が別々の操作であるため、混乱が生じることがあります。たとえば、電気設計者が一日の終わりにサーバーへの保存を実行すると、その設計データへのアクセスが必要な他の全員も、最新のデータですぐに作業できる状態になったと思い込んでしまう可能性があります。

ファイルの同期を維持するプロセスを簡素化するため、プロジェクトをMCADに一度でもプルすると、その後はECADでそのプロジェクトに対してSave to Serverが実行されるたびに、Workspaceが自動でプッシュを実行します。

プロジェクトをサーバーに保存すると、MCADへのプッシュが自動的に実行されます。プロジェクトをサーバーに保存すると、MCADへのプッシュが自動的に実行されます。

  • 自動プッシュはWorkspaceが実行し、MCADへの初回プルが完了した後に開始されます。

  • 現在、自動プッシュはAltium 365 Workspaceでのみ有効です。オンプレミスのEnterprise Server Workspaceへの対応も近日中に追加される予定です。

  • 自動プッシュは、PCB、ハーネス、マルチボードのECADプロジェクトに対応しています。ハーネスプロジェクトへの対応は、MCAD CoDesigner 3.14で追加されました。

MCAD設計者がプルを実行すると、以下のスライドに示すように、前回のMCADへのプッシュが自動で行われたことが通知されます。

ECADでプロジェクトをWorkspaceに保存すると、MCADにも自動的にプッシュされます。

プッシュ中に警告やエラーが発生すると、フラグが表示されます。

クリックすると、警告やエラーの詳細が表示されます。

 

自動プッシュを実行できない場合、プルするデータのバージョンが最新ではないことがMCAD設計者に警告されます()。

次の場合、自動プッシュは実行されません。

  • The ECAD project has only been saved to the working folder – プロジェクトがまだサーバーに保存されていない場合。サーバーへの保存が実行されると、機械設計者がWorkspaceから初めてプルした後に、自動プッシュが開始されます。

  • The ECAD project has failed CoDesigner's validation checks – MCADへのプッシュを自動または手動で実行するには、事前にこれらを解決する必要があります。

  • There are multiple PCB files in the ECAD project, which have all been Saved to the Server – MCAD CoDesignerが自動プッシュの対象となるPCBを特定できない場合。ECAD設計者は、正しいPCBに対して手動でMCADへのプッシュを実行し、この問題を解決する必要があります。

MCAD CoDesignerの動作状況のログ保存先

MCAD CoDesignerは、ECADとMCADのあらゆる操作に関する詳細情報をログファイルに記録します。ログファイルは次の場所に保存されます。

C:\Users\<>\AppData\Local\Altium\Altium CoDesigner\

この場所では、次のように記録されます。

  • ECADイベントの記録先: AltiumDesignerExtension.log

  • MCADイベントの記録先: <McadName>Addin.log

共同設計インターフェース

AltiumソフトウェアとMCADソフトウェアは、それぞれのソフトウェア内のパネル(タブ)を通じて相互に連携します。AltiumソフトウェアではMCAD CoDesignerパネル、MCADソフトウェアではAltium CoDesigner パネルまたはタブと呼ばれます。

MCAD CoDesigner / Altium CoDesignerパネル

ECADでは、MCAD CoDesignerパネルから設計変更をプッシュおよびプルします。 

MCADでは、Altium CoDesignerパネルから設計変更をプッシュおよびプルします。

 
  • Altium設計ソフトウェアでは、MCAD CoDesignerパネルを使用して、設計変更を双方向にプッシュおよびプルし、メッセージを表示します。

  • MCADソフトウェアでは、Altium CoDesignerパネルを使用して次の操作を行います。

    • 新しい共同作業プロジェクトの作成

    • 既存の共同作業プロジェクトを開く

    • 共同作業オプションの設定

    • 設計変更の双方向のプッシュおよびプル

    • メッセージの表示

パネル(タブ)を有効にする方法はMCADツールごとに異なります。Altium CoDesignerパネルへのアクセス方法の詳細は、Altium MCAD CoDesignerのインストールと設定セクションの該当ページを参照してください。

CoDesignerパネルでの作業

全体的な概念は同じですが、Altium CircuitMakerとAutodesk Fusionでは操作方法にいくつか違いがあります。

CircuitMakerとAutodesk Fusion間の共同作業の詳細をご覧ください。

CoDesignerパネルで利用できる機能は、ECADとMCADで基本的に同じです。パネルには、ECADで行われた最新の変更とMCADで行われた最新の変更が常に表示されます。

すべての共同設計作業はCoDesignerパネルを通じて行います。すべての共同設計作業はCoDesignerパネルを通じて行います。

ECADからの最新情報 / MCADからの最新情報

  • これらの2つのセクションには、ECADで行われた最新の変更とMCADで行われた最新の変更が表示されます。

  • 三角形のアイコンをクリックするとパネルが展開され、最新の変更の詳細が表示されます 。

  • もう一方の設計環境から新しい変更がプッシュされると、以下に示すように バナーが自動的に表示されます。
    パネルには、次の詳細が表示されます。

    • プッシュを実行した設計者のサインイン名

    • プッシュ時に入力された任意のコメント

変更がプッシュされると、新しい変更を知らせる通知バナーが表示されます。変更がプッシュされると、新しい変更を知らせる通知バナーが表示されます。

  • Pullボタンをクリックすると、CoDesignerは現在開いている設計と、もう一方の設計ドメインから最後にWorkspaceへプッシュされたバージョンを比較します。検出された差分は、以下に示すように、パネルのChangesリストに表示されます。リストで変更を選択すると、可能な場合、その変更の影響が紫色でハイライト表示されます。

リスト内の変更をクリックすると、その変更の影響がハイライト表示されます。リスト内の変更をクリックすると、その変更の影響がハイライト表示されます。

  • 適用しない変更のチェックボックスをオフにします。
  • 適用できない変更がある場合は、その変更とチェックボックスがグレー表示されます。この差分は変更の適用後も残るため、プッシュしたエンジニアと協議する必要があります。
  • 準備ができたら、Applyボタンをクリックして、有効になっているすべての変更を現在開いている設計に適用します。

変更履歴と却下コメントのサポート

すべての変更の完全な履歴が保持されます。履歴を確認するには、以下に示すように、Latest from the ECAD/MCADドロップダウンの右側にある履歴リンクをクリックします。

変更履歴により、双方のエンジニアは、行われた変更に対する相手の対応を簡単に確認できます。変更履歴により、双方のエンジニアは、行われた変更に対する相手の対応を簡単に確認できます。

各変更セットには、次の情報が記録されます。

  1. このプッシュ()または プル()を実行したユーザーと、実行元の設計ドメイン( ECADまたは MCAD)

  2. これらのイベントが発生した日時。

  3. もう一方のドメインから変更をプッシュした際に、任意で入力された概要。

  4. 個々の変更の詳細リスト。承認された変更にはチェックマーク、却下された変更には×印が表示されます。

  5. 特定の変更を却下した理由を説明する任意のコメント。 

  6. パネルのHistoryモードにある ボタンをクリックすると、Latest Changesモードに戻ります。

  7. View Project in Browserボタンをクリックすると、Workspaceでプロジェクトを表示できます。 

  8. ブラウザーで左側のHistoryリンクをクリックすると、下の画像に示すようにプロジェクト履歴が表示されます。CoDesignerのプッシュに対応する各履歴イベントタイルにはMCAD Changes Suggestedというタイトルが付き、プッシュしたユーザーの名前、日時、および入力されている場合はメッセージが表示されます。この情報を使用して、CoDesignerパネルと履歴ビューの内容を照合できます。 

    プロジェクト履歴の詳細については、Altium 365 WorkspaceまたはEnterprise Server Workspaceを参照してください。

変更履歴はWorkspaceでも確認できます。変更履歴はWorkspaceでも確認できます。

CoDesignerの履歴イベントタイルが異なるのはなぜですか?

ECADでは、CoDesignerのプッシュによってデータがWorkspaceに保存されますが、このCoDesignerデータは元の回路図およびPCBプロジェクトドキュメントとは独立しています。CoDesignerのプッシュ時に、元の回路図およびPCBプロジェクトドキュメントが変更または保存されることはなく、プロジェクトもコミットされません。プロジェクトのコミットonlyは、ECADエンジニアがSave to Serverを実行したときに行われ、チャコール色のイベントタイルで表示されます。

MCAD CoDesignerの履歴が通常のプロジェクトのコミットイベントの履歴に影響しないことを示すため、MCADの変更は提案として紫色のタイルに記録されます。このタイルはタイムラインに直接つながっておらず、代わりに方向を示す矢印によって、プロジェクト履歴全体におけるイベントの位置が示されます。現在サポートされているのは、MCAD CoDesignerのプッシュイベントのみです。 

混乱を防ぎ、ワークフローを簡素化するため、Save to Serverを実行するとCoDesignerのプッシュも自動的に実行され、ECADとMCADのすべてのエンジニアが最新の設計データにアクセスできるようになります。詳細については、CoDesignerの自動プッシュを参照してください。

お使いのMCAD CoDesignerでプロジェクト履歴機能を利用できるかどうかについては、右側のペインのNoteを参照してください。

PCBの定義 - 基板領域

設計によっては、基板上に特別な配慮が必要な領域があり、MCADエンジニアがその領域を定義してECADエンジニアに伝える必要があります。たとえば、製品の組み立て時に筐体の導電性部分が基板表面に接触するため、基板表面の特定の領域に銅箔を配置できない場合があります。これに対応するため、MCADエンジニアはAltium CoDesignerリボンのボタンを使用して、Keep Out AreasとText Note Roomsを定義できます。

これらのオブジェクトのいずれかがMCADで基板上に配置されている場合、CoDesignerパネルのPCB DefinitionsセクションにあるBoard Areasリストに表示されます。

  • Keep Out Area - MCADで定義されたKeep Out Areaは、ECADではPCBキープアウトになります。PCBキープアウトは、特定のECADオブジェクトの配置を制限するように設定された基板上の領域です。キープアウトは基板のどちらの面にも定義でき、すべてのPCBレイヤーに適用することもできます。ECAD PCBのこの領域から除外するオブジェクトは、Altium CoDesigner MCADパネルのKeepout Restrictionプロパティで選択します。必要に応じて設定してください。詳細については、MCADでのKeep Out Areaの配置を参照してください。

  • Text Note Room - MCADで定義されたText Note Roomは、ECADではPCBルームになります。PCBルームは、特定のコンポーネントを配置する、または配置から除外する領域を定義するためのデザインルールです。このルールは一般的に、ルームが覆う基板領域でコンポーネントの高さを制限するために使用されます。通常、ルームルールは個々のコンポーネントまたはコンポーネントクラスに適用されます。Altium CoDesigner MCADパネルでText Note Roomの定義をクリックして選択し、ECADエンジニアへの指示や情報を入力します。このテキストは、ECAD PCBエディターでそのルームのCommentフィールドに設定されます。詳細については、MCADでのText Note Roomの配置を参照してください。

Board AreasとText Note Roomsは、MCADエンジニアが定義し、ECADエンジニアにプッシュする特別な領域です。 

  • ECADで作成または変更されたキープアウトとルームは、機械設計エンジニアにとって冗長な視覚情報を減らすため、デフォルトではMCADに表示されません。必要に応じてMCADで再表示できます。

  • MCADでは銅箔領域を定義できません。MCADエンジニアが銅箔領域を定義する必要がある場合は、MCADで適切なレイヤーにKeep Out Areaを配置し、ECADでTools » Convert » Convert Selected Keepouts to Primitives コマンドを使用して、キープアウト領域オブジェクトを銅箔領域オブジェクトに変換します。

PCBの定義 - 基板の筐体

CoDesignerは、MCADでのデバイスアセンブリレベルの作業と、MCADからECADへの基板と筐体の転送をサポートしています。

CoDesignerは、基板と筐体がデバイスアセンブリに追加されたことを認識します。CoDesignerは、基板と筐体がデバイスアセンブリに追加されたことを認識します。

デバイスアセンブリでの作業と、MCADからECADへの筐体のプッシュについて詳しくは、こちらを参照してください。

CoDesignerのMCAD設定メニュー

CoDesignerの設定メニューは、MCADソフトウェア内でCoDesignerを設定するために使用します。

Altium CoDesignerパネルの右上にある下矢印をクリックして、メニューを開きます。

メニューの各オプションで、次の操作を行えます。

  • 現在サインインしているサーバー/Workspaceを確認します。
  • 現在サインインしているサーバー/Workspaceからサインアウトします。
  • CoDesigner Settingsダイアログを開きます。このダイアログでは、モデルの保存先を一元管理する場所を設定し、実形状の銅箔のサポートを有効にできます。
  • カスタムサーバーにアクセスします。Use Custom Serverオプションをクリックすると、現在のWorkspaceからサインアウトし、Altium CoDesignerパネルのサインインモードに戻ります。

バージョン番号が表示されない旧バージョンのCoDesignerでバージョン番号を確認するには、Windowsのコントロールパネルで「プログラムと機能」を開きます。

CoDesignerのMCADリボン

MCADソフトウェアにCoDesignerアドインをインストールすると、インターフェースにAltium CoDesignerリボンが追加されます。Altium CoDesignerタブをクリックするとリボンが表示され、ECAD-MCAD共同設計プロセスで必要となる、PCB固有の一般的な設計オブジェクトに簡単にアクセスできます。これらのボタンを使用することで、互換性のあるECADオブジェクトの作成に適したMCADオブジェクトタイプを確実に使用できます。

CoDesignerリボンを使用して、ECADで利用できる形式でPCB上のオブジェクトを定義します。CoDesignerリボンを使用して、ECADで利用できる形式でPCB上のオブジェクトを定義します。

推奨される共同作業のワークフロー

ECAD-MCAD共同設計は柔軟なプロセスであり、必ず従わなければならない決まった方法はありません。基板形状はMCADで設計するのが一般的ですが、基板の厚さはECADで定義するmustがあります。各PCB層の材料を選択して設定するのがECADだからです。この要件に基づき、以下の設計フローを推奨します。

ECADで共同作業プロセスを開始する

In ECAD:

  1. プロジェクトを作成します。

  2. PCBを追加します。

  3. レイヤースタックを定義して、基板の厚さを設定します。

  4. MCAD CoDesignerパネルを開きます(設計スペースの右下にあるPanels ボタンをクリックしてパネル名を選択するか、View » Panelsサブメニューを使用します)。

  5. PushMCAD CoDesignerパネルのボタンを使用して基板をプッシュします。これにより、ECAD-MCAD間の交換データがWorkspaceにプッシュされるだけでなく、プロジェクトと基板ファイルもWorkspaceに保存されます。保存されたプロジェクトと基板は、ECAD設計者の作業用ファイルになります。


In MCAD:

  1. Altium CoDesignerパネルを開きます。パネルを開く手順は、使用するMCADソフトウェアによって異なります。詳細については、該当するMCADソフトウェアへのCoDesignerのインストールのリンクを参照してください。

  2. Pull Altium CoDesignerパネルで基板を操作します。これにより、Workspace内の基板定義に基づいてMCAD基板アセンブリが作成されます。

  1. 基板をデバイスアセンブリに挿入します。
  2. 筐体に合わせて基板形状を設定します。
  3. 取り付け穴を定義します。
  4. 位置が重要なメカトロニクス部品を配置します。
  5. 必要なキープアウトゾーンまたはテキストノートルームを定義します。
  6. MCADアセンブリを保存します。

    基板形状の定義、穴の追加、部品の配置について詳しくは、機械設計者向けの推奨事項セクションを参照してください。

Pushing from MCAD back to ECAD:

  1. MCAD CoDesignerパネルのボタンを使用して、基板をWorkspaceにPushします。これにより、基板定義、穴、および配置済み部品の詳細がMCAD-ECAD交換データとして保存されます。

Pulling into ECAD:

  1. 基板を開き、Pullを実行して、更新された基板定義と部品の詳細をWorkspaceから読み込みます。

In MCAD or ECAD:

  1. アセンブリまたはPCBファイルを再度開いて、設計作業を続けます。

MCADでのコラボレーションプロセスの開始

Starting the Board in MCAD:

  1. PCB設計プロセスをMCADで開始することは可能ですが、推奨されません。手順は、サポートされているすべてのMCAD環境で同じです。

プッシュと共有による機械設計者の招待(Altium 365でホストされるWorkspace)

ECADのMCAD CoDesignerパネルでPushをクリックすると、MCAD CoDesignerパネルで、プロジェクトを別の設計者とShareすることもできます。

CoDesignerは、専用のECAD-MCAD間データパッケージをAltium Workspace経由でやり取りすることによって、基板設計をプッシュおよびプルします。Shareチェックボックスをオンにすると、招待した設計者が専用のECAD-MCADデータパッケージを含むプロジェクトにアクセスできるように、Workspaceへのアクセスとプロジェクトの権限を設定するプロセスが開始されます。招待された設計者は、MCADソフトウェアのAltium CoDesignerパネルにあるプッシュ/プル機能からアクセスできます。また、Altiumアカウントをすでに持っている場合や、招待プロセス中にアカウントを作成する場合は、Webブラウザーからもアクセスできます。

Shareチェックボックスのオン/オフの状態は、Mechanical Engineersロールが割り当てられたWorkspaceメンバーがいるかどうかによって決まります。該当するメンバーがいない場合、このチェックボックスはデフォルトでOnになります。

プロジェクトは、相手がプロジェクトのWorkspaceのメンバーかどうか、あるいはAltiumアカウントを持っているかどうかに関係なく、誰とでも共有できます。以下の表は、共有実行時に招待先が持っていた権限の状態に応じて、プロジェクトへのアクセスがどのようになるかをまとめたものです。

Existing Altium Account Status Existing Workspace Status Permissions Assigned During Share Notes
有効なAltiumアカウントなし プロジェクトのWorkspaceのメンバーではない 編集権限付きでプロジェクトへのゲストアクセスが付与される

招待先に、Altiumアカウントを作成するためのリンクが記載されたメールが届きます。アカウントを作成すると、ゲストは自身のパーソナルスペースの自分と共有セクションから、ブラウザー経由でもプロジェクトにアクセスできるようになります。

この場合、招待先はMCADソフトウェアからプロジェクトにアクセスできません。アクセスを可能にするには、そのユーザーをWorkspaceのメンバーとして追加し、編集権限を割り当てます。

有効なAltiumアカウントあり プロジェクトのWorkspaceのメンバーではない プロジェクトのWorkspaceのメンバーとなり、Mechanical Engineerロールが割り当てられる。プロジェクトは閲覧権限で共有される

新しいWorkspaceメンバーには、Mechanical Engineerロールが割り当てられます。MEロールが割り当てられたWorkspaceメンバーが存在するようになるため、共有チェックボックスは自動的にオンにならなくなります。

機械設計者がMCADからプッシュできるようにするには、プロジェクトの権限を編集に引き上げる必要があります。

有効なAltiumアカウントあり すでにプロジェクトのWorkspaceのメンバーである プロジェクトは編集権限で共有される  

共有の手順

Shareチェックボックスがオンの場合、MCAD CoDesignerパネルのSendボタンをクリックすると、Share with a Mechanical Engineerダイアログが開きます。

プロジェクトを共有する相手のEmail Address(必要に応じてNoteも)を入力し、ダイアログのShareボタンをクリックします。招待先がまだWorkspaceのメンバーでない場合、Share with a Mechanical Engineer通知ダイアログが表示され、招待したユーザーが組織外のユーザーである可能性があることを警告します。

このダイアログでOKをクリックすると、通知メールが生成され、招待先に送信されます。招待先がすでにWorkspaceのメンバーである場合も、通知メールが送信されます。

メール通知機能を使用するには、WorkspaceでEnable Mail Notificationsオプションを有効にする必要があります()。

しばらくすると、成功を知らせるダイアログが表示されます。

これで、プロジェクトが機械設計者と共有されました。

プッシュと共有を実行する際の注意事項

  • ブラウザーでWorkspaceにサインインし、プロジェクトのShareダイアログ()で、招待した機械設計者にEdit permissionsが割り当てられていることを確認してください。機械設計者は閲覧権限だけでも基板をプルできますが、the projectが編集権限付きで共有されていないと、基板設計への変更をプッシュすることはできません。ECAD-MCAD CoDesignはツールに依存しない中間ファイルを介して行われ、機械設計者は実際のPCB設計ファイルに対して読み取り専用アクセスしか持たないため、共有に伴うリスクは低くなっています。

  • Workspaceのすべての管理者に、招待先(メールアドレスで識別)がプロジェクトに招待されたことを知らせる通知メールが届きます。

  • 招待先がAltiumアカウントを持っていない場合、Altiumアカウントのサインアップ/登録用の中間フォームに案内するメールが届きます。登録が完了すると、プロジェクトはEdit permissionsを持つGuestとして共有されます。Altiumアカウントを持たない招待先は、サインアップ時に独立した個人の組織として扱われる点に注意してください。Workspaceのメンバーとして追加されることはありません。

  • プッシュと共有を実行したAltium Designerの設計者がWorkspaceの管理者権限を持っていない場合は、追加の手順が必要になります。まず、共有リクエストがすべてのWorkspace管理者に通知されます。管理者が招待リクエスト()を承認すると、上記のとおりに招待が処理され、最初の招待を行ったユーザーにもメールで通知されます。詳しくは、Altium 365 Workspaceへの他のユーザーの招待をご覧ください。

MCADとECAD間での作業

CoDesignerが現在検出できる変更の精度は、直線寸法で0.5 mils (0.0127 mm)、角度寸法で0.5 degreesです。この精度は、今後のCoDesignerのアップデートで向上する予定です。

設計プロセスのどの段階でも、CoDesignerパネルを使用して、MCADツールとECADツールの間で変更を転送できます。

変更は、CoDesignerパネルを介してMCADツールとECADツールの間でプッシュおよびプルされます。 Changes to the board and component detail are Pulled from MCAD in the MCAD CoDesigner panel 変更は、CoDesignerパネルを介してMCADツールとECADツールの間でプッシュおよびプルされます。

  1. 設計変更を転送するには、該当するパネルのPushボタンをクリックします。
  2. Pushボタンをクリックすると、送信元エディターのパネル上部に編集ウィンドウが表示されます。設計変更に関するメッセージを入力し、Sendをクリックします。
  3. 送信をクリックすると、次の処理が行われます。
    • 変更されたPCBファイルの作業コピーが未保存の場合、自動的に保存されます。
    • 変更がWorkspaceに書き込まれます。
    • 投稿したメッセージが、送信元エディターのCoDesignerパネルのメッセージスレッドに表示されます。
    • 受信先で次に設計ファイルの作業コピーを開いたときに、受信先エディターのパネルに保留中の変更があることを知らせるメッセージが表示されます。
  4. 受信先エディターのパネルでPullをクリックすると、設計を再同期するために必要な各変更の詳細な一覧が表示されます。

変更リストの操作

Pullボタンをクリックすると、以下に示すように、Workspace上のスナップショットと同期するために作業ファイルに適用する必要がある変更が一覧表示されます。

Incoming changes are detailed in the CoDesigner panel, these can be selectively enabled as required

  • 現在の設計とWorkspaceに保存されているスナップショットの間で検出された各差分は、変更リストに変更項目として詳しく表示されます。
  • 変更は必ずしも受け入れる必要はありません。変更を無視すると、次回同じ方向で更新を実行したときに、その変更が再び変更リストに表示されます。ただし、取り付け穴の移動などの変更を無視した後で、設計変更をプッシュすると、無視した変更が上書きされる場合があることに注意してください。自分のバージョンでは、取り付け穴が元の位置にあるためです。MCAD設計者は、こちらからの取り付け穴の移動を受け入れなければ、自分の変更が失われるのを防ぐことができます。
  • コンポーネントの位置変更など、設計上の1つの変更が、変更リストでは複数の変更になることがあります。PCBコンポーネントを移動すると、MCADではコンポーネントの位置、コンポーネントオーバーレイ上の形状、および上面と下面の銅箔レイヤー上の形状が変更されます。関連する変更は、すべてまとめて適用する必要があります。
  • リストには、適用先の環境では適用できない変更が含まれる場合があります。この場合、変更は表示されますが、チェックボックスは使用できず、その差分を解消できないことを示します。
  • 変更リストで変更をクリックすると、可能な場合は、選択した変更が設計スペースでハイライト表示されます。
  • Applyをクリックすると、チェックを入れた変更が適用されます。

基板外形の定義、穴の追加、コンポーネントの配置について詳しくは、機械設計者向けの推奨事項セクションを参照してください。

次の種類のPCBは、ECADからMCADへの転送にnot:

  • Autodesk Inventor、Autodesk Fusion、Siemens NXではリジッドフレックス基板はサポートされておらず、基板は単一のリジッド構造としてMCADに読み込まれます。SOLIDWORKSとPTC Creoではリジッドフレックス基板がサポートされています。詳しくは、リジッドフレックス基板の同期を参照してください。

  • CoDesignerでマルチボードアセンブリのプルとプッシュがサポートされているMCADパッケージは、PTC CreoとSOLIDWORKSのみです。詳しくは、Altium MCAD CoDesignerによるマルチボードアセンブリの同期を参照してください。

MCAD座標グリッド

CoDesignerは、ECADからMCADに基板をプッシュする際、ECADの絶対原点を基準として使用します。CoDesigner 2.4では、MCADの原点がデフォルトのECAD原点(絶対原点)と異なる場合に、ECADへのプル時にMCAD Originエンティティを含む新しいMCAD Coordinatesグリッドを作成する機能が導入されました。これにより、電気設計者と機械設計者が、基板上の各種エンティティの位置について情報を共有しやすくなります。

MCAD Coordinatesグリッドの表示はECADでカスタマイズできます。Propertiesパネルの該当項目をダブルクリックすると、グリッドエディターダイアログが開きます。詳しくは、PCBグリッドシステムを参照してください。

MCADで定義した座標グリッドは、ECADでもカスタマイズできます。MCADで定義した座標グリッドは、ECADでもカスタマイズできます。

MCADで基板外形の位置を変更する場合は、コンポーネントやその他のオブジェクトを配置する前に行ってください。これにより、これらのオブジェクトの位置を手動で復元する必要がなくなります。

コンポーネント配置用のMCAD平面

CoDesigner 2.2.0以降では、MCADでのコンポーネント配置を容易にするため、基板をプルすると、上面および下面のコンポーネント配置用平面がMCADに作成されます。ECADからプッシュされたコンポーネントは、ソルダーマスクレイヤーの厚さを無視してMCADに配置されます。

CoDesignerによる銅箔、マスク、オーバーレイレイヤーの処理

CoDesignerは、基板外形とコンポーネントに加えて、上面と下面の銅箔、ソルダーマスク、およびコンポーネントオーバーレイの各レイヤーもECADからMCADに転送します。

デカールとしてのECADレイヤー

デフォルトでは、これらのレイヤーは個別のSVG画像としてECADからWorkspaceにプッシュされます。基板アセンブリをMCADにプルすると、CoDesignerはSVG画像をPNG画像に変換します。次に、上面のPNG画像群を1つの上面デカールに、下面のPNG画像群を1つの下面デカールにそれぞれ結合します。この2つのデカールは、MCADへのプル時に基板の上面と下面に適用されます。

MCADでは、上面と下面のデカールが基板の各面に適用されます。 MCADでは、上面と下面のデカールが基板の各面に適用されます。

Autodesk Fusion — スケッチプロファイルとしてのECADレイヤー

上面と下面の銅箔レイヤーおよびコンポーネントオーバーレイレイヤーをECADからAutodesk Fusionに転送する場合は、異なる方法が使用されます。Autodesk Fusionでは、これらのレイヤーは基板オブジェクト上に描画されたスケッチプロファイルとしてインポートされます。Autodesk Fusionでは、Altium CoDesignerリボンのAdvanced Geometry( )ボタンをクリックして、これらのレイヤーをまとめて表示または非表示にできます。また、Autodesk Fusionの表示アイコンを使用して、各レイヤーを個別に非表示または表示することもできます。

Autodesk Fusionでは、コンポーネントオーバーレイと表面の銅箔レイヤーがスケッチプロファイルとして作成されます。Autodesk Fusionでは、コンポーネントオーバーレイと表面の銅箔レイヤーがスケッチプロファイルとして作成されます。

上面と下面のソルダーマスクレイヤーは、Autodesk Fusionには転送されません。代わりに、ECADの上面ソルダーマスクレイヤーの色が基板オブジェクトに適用されます。

MCADでの詳細な銅箔ジオメトリ

CoDesignerでは、銅箔、マスク、オーバーレイレイヤーのデカール(画像)をMCADに表示する代わりに、実際の銅箔ジオメトリ(Advanced Copper Geometryと呼ばれます)と3DマスクレイヤーをMCADに転送することもできます。この機能は現在、PTC Creo、Autodesk Inventor、SOLIDWORKS、Siemens NXでサポートされています。CoDesigner 2.7以降では、コンポーネントオーバーレイ(シルクスクリーン)のデカールが、押し出されたソルダーマスクの面に適用されます。

必要に応じて、銅箔レイヤーをMCADに転送できます。上の画像では、上面の銅箔レイヤーを除き、コンポーネントと各レイヤーを非表示にしています。必要に応じて、銅箔レイヤーをMCADに転送できます。上の画像では、上面の銅箔レイヤーを除き、コンポーネントと各レイヤーを非表示にしています。

詳細な銅箔ジオメトリを含めるには、Altium CoDesigner SettingsダイアログでBuild 3D geometry for Copper and Solder Maskオプションを有効にします(必要に応じてBuild Viasオプションも有効にします)。設定ダイアログには、Altium CoDesignerパネルのCoDesignerメニュー()からアクセスできます。

「銅箔とソルダーマスクの3Dジオメトリを作成」オプションを有効にすると、これらのレイヤーがMCADアセンブリに含まれます(Autodesk Inventorのダイアログ)。「銅箔とソルダーマスクの3Dジオメトリを作成」オプションを有効にすると、これらのレイヤーがMCADアセンブリに含まれます(Autodesk Inventorのダイアログ)。

銅箔ジオメトリと3Dマスクレイヤーを扱う際の注意事項:

  • 銅箔レイヤーとマスクレイヤーは、MCADのサブアセンブリとして含まれます。
  • レイヤースタックに存在するすべてのPCB銅箔レイヤーが含まれます。ただし、銅箔レイヤーの厚さには、表面処理などのめっき層のデータは含まれません。これは今後のアップデートで追加される予定です。
  • Build 3D geometry for Copper and Solder Maskオプションを有効にすると、スルーホールパッドのバレルが含まれます。
  • Build 3D geometry for Copper and Solder Maskオプションを有効にすると、ビアの表面形状も含まれます。ビアの銅箔バレルを含めるには、Build Viasオプションを有効にします。
  • Build 3D geometry for Copper and Solder Maskオプションを有効にすると、コンポーネントオーバーレイ(シルクスクリーン)のデカールが、押し出されたソルダーマスクの面に適用されます。
  • 設計の複雑さによっては、銅箔ジオメトリとビアを含めることで、ファイルサイズとMCADへの設計のプルにかかる時間がsignificantly increase。
  • 銅箔とマスクのデータは、常にECADからプッシュされます。MCADでBuild 3D geometry for Copper and Solder MaskオプションとBuild Viasオプションを有効にした場合、ECADから再度プッシュする必要はありません。基板を閉じて、Workspaceからもう一度プルするだけです。

Notes:

  • お使いのMCAD CoDesignerでAdvanced Copper Geometry機能を利用できるかどうかについては、右側のペインのNoteを参照してください。利用できない場合は、 前述のとおり、画像ベースのデカールを使用できます。
  • 銅箔形状はECADでのみ編集できます。MCADで行った編集はECADにプッシュされません。

ソルダーマスクの正確な表現

Update 2.5で導入された機能により、CoDesignerはBuild 3D Copperオプションが有効な場合、パッドの開口部を含むソルダーマスクの正確なモデルを、MCAD内の独立したエンティティとして作成します。ソルダーマスクは銅箔間のエッチングされた領域を埋めるため、MCADでのマスク層の厚さは、ECADで定義された表面銅箔層の厚さとソルダーマスク層の厚さの合計になります。

ソルダーマスクは配線、パッド、ビア間のエッチングされた領域を埋めるため、MCADでの総厚は、ECADで定義された銅箔層の厚さとソルダーマスクの厚さの合計になります。ソルダーマスクは配線、パッド、ビア間のエッチングされた領域を埋めるため、MCADでの総厚は、ECADで定義された銅箔層の厚さとソルダーマスクの厚さの合計になります。

前述のとおり、MCADでは、部品は表面と裏面の部品配置平面上に配置されます(これらの平面は、基板をプルしたときにMCADで作成されます)。これらの平面は表面と裏面の銅箔層の外側表面に位置するため、ECADからプッシュされた部品は、ソルダーマスク層の厚さを無視してMCADに配置されます。その結果、部品とソルダーマスク層の間に干渉が発生します。この干渉が設計上の問題となる場合は、PCBの厚さを一時的に減らし、部品が実質的にソルダーマスク層の外側表面に載るようにしてください。この問題は、今後のアップデートでMCADのソルダーマスク層を非表示にするオプションを追加することで解消される予定です。

キープアウトとルームのサポート

Altium CoDesignerリボンからは、キープアウトやルームなど、PCB固有の一般的な設計オブジェクトにMCADで簡単にアクセスできます。これらのボタンを使用すると、互換性のあるECADオブジェクトの作成に適したMCADオブジェクトタイプが使用されます。

キープアウトのサポート

PCBのキープアウトとは、特定のECADオブジェクトの配置を制限するように設定された基板上の領域です。キープアウトは基板のどちらかの面に定義することも、PCBの全レイヤーに適用することもできます。この領域から除外するオブジェクトは、キープアウトの制限プロパティで選択します。

MCADでのキープアウトの定義:

  • Altium CoDesignerリボンのKeep Out Areaボタンをクリックします。
  • 面、サーフェス、または平面を選択するよう求められたら、キープアウトが必要な基板の面をクリックします。キープアウトを全レイヤーに適用する場合は、どちらの面に描画してもかまいません。
  • 長方形など、適切なMCADスケッチツールをクリックしてキープアウトを定義します。スケッチに含められる輪郭は1つだけです。 内部輪郭はサポートされていません。
  • キープアウトに必要な形状を描画します。
  • Sketchモードを終了します。
  • これでフィーチャーのプロパティを編集できます。キープアウトを、その領域を囲むフェンスと考え、Depthを1mmなどの小さい値に変更します。
  • このキープアウトは、MCADで描画したレイヤーに対応する、ECADのレイヤー固有のキープアウトになります。全レイヤーに適用するキープアウトを定義するには、MCADでキープアウトを両方向に押し出すように設定し、2つ目の方向のDepthを、基板を貫通するのに十分な値に設定します。
  • MCADの承認ボタン をクリックして、フィーチャーの定義を完了します。必要に応じて、フィーチャーツリーでフィーチャーの名前を変更できます。
  • Altium CoDesignerパネルでPCB Definitionタブを選択し、必要に応じてキープアウトの制限を設定します。これでキープアウトをECADにプッシュでき、キープアウト領域として追加されます。MCADでの設定に応じて、Top Layer、Bottom Layer、またはKeepout Layerのキープアウトになります。必要に応じて、ECADでキープアウト形状を調整し、MCADにプッシュし直すこともできます。

ルームのサポート

PCBのルームとは、特定の部品を配置する必要がある領域、または配置してはならない領域を定義するデザインルールです。このルールは一般に、ルームで覆われた基板領域内で部品の高さを制限するために使用されます。通常、ルームのルールは個々の部品または部品クラスに適用されます。

MCADでのルームの定義:

  • Altium CoDesignerリボンのText Note Roomボタンをクリックします。

  • 面、サーフェス、または平面を選択するよう求められたら、ルームが必要な基板の面をクリックします。

  • 長方形など、適切なMCADスケッチツールをクリックしてルームを定義します。スケッチに含められる輪郭は1つだけです。 内部輪郭はサポートされていません。

  • ルームに必要な形状を描画します。

  • Sketchモードを終了します。

  • MCADの承認ボタン をクリックして、フィーチャーの定義を完了します。必要に応じて、フィーチャーツリーでフィーチャーの名前を変更できます。

  • Altium CoDesignerパネルでPCB Definitionタブを選択し、ECADエンジニアにルームの目的を説明するコメントを入力します。これでルームをECADにプッシュでき、MCADで描画したレイヤー上にPlacement Roomデザインルールとして追加されます。MCADとECADの間で転送できるプロパティはCommentのみで、これはPlacement Roomデザインルールのコメントになります。

  • これで、ECADでPlacement Roomデザインルールを必要に応じて設定できます。

キープアウト領域とルームは、MCADで定義してECADにプッシュできます。キープアウト領域とルームは、MCADで定義してECADにプッシュできます。

基板領域の転送に関する注意事項:

  • ECADのキープアウト領域では、フィルとソリッド領域がサポートされています。
  • CoDesignerは、ECADのキープアウトとルームのロック状態を検出し、MCADでプルする際にそれらが移動されないようにします。
  • ECADのキープアウトオブジェクトには一意の識別子やオブジェクト名が含まれていないため、ECADからMCADへのキープアウトの変更は、既存のオブジェクトを削除し、新しいオブジェクトを新しいMCAD名で追加することで反映されます。
  • ECADのルームに加えられた変更も、ECADからMCADへの変更時には削除と追加として扱われますが、NameとCommentは保持されます。
  • ECADで作成または変更されたキープアウトとルームは、機械設計エンジニアに不要な視覚情報を表示しないよう、MCADではデフォルトで非表示になります。必要に応じて、MCADで再び表示できます。

Important Note about Versions: ECAD拡張機能が更新されていても、MCADプラグインが更新されていない可能性がある場合は、MCADからECADへの変更を適用する際に注意してください。ECADのPCB上にキープアウトとルームが定義されていると、CoDesignerはそれらの削除を提案します。対処方法は、ECADでそれらの変更を拒否するだけです。これにより、キープアウトとルームが保持されます。

MCADにプルする部品数の制御

多数の部品を含む基板で作業する際のパフォーマンスを向上させるため、CoDesignerでは、ECADからのプル時に、ユーザーが定義した高さ未満の部品を除外できます。高さのしきい値の判定には、ECADの部品プロパティで定義された高さが使用されます。これはPCB部品のHeightプロパティであり、部品フットプリントに追加された3Dモデル()の高さではない点に注意してください。

CoDesignerがチェックする高さのしきい値は、下図に示すように、Altium CoDesigner Settingsダイアログで定義します。このダイアログを開くには、MCADのAltium CoDesignerパネルのメニューでSettingsを選択します。下図はAutodesk Fusionの設定を示していますが、サポートされている各MCADでも同じ設定を使用できます。

[Ignore components smaller than]の高さのしきい値を設定すると、MCADへのプル時に小さな部品を除外できます。[Ignore components smaller than]の高さのしきい値を設定すると、MCADへのプル時に小さな部品を除外できます。

ECADでの部品の高さの設定

以下の動画では、Heightが定義されていない(デフォルト値がゼロの)PCB部品を見つけ、複数の部品の高さの値をすばやく更新する方法を紹介します。続いて、MCADでIgnore components setting smaller thanを設定する方法と、ECADからのプル時にMCAD CoDesignerがこの設定をどのように処理するかを説明します。 

部品の高さの値に誤りがある場合は、ECADですばやく検出して修正できます。

MCADでのスマートなスケッチ変更

ECADエンジニアが基板外形を変更する必要があり、その外形にMCADで寸法と拘束が適用されている場合を考えてみましょう。以前は、基板をMCADにプルし直すと、MCADのスケッチの寸法と拘束が失われていました。現在は、プル時にCoDesignerがスケッチのうちECADで変更された要素のみを再描画するため、変更されていない要素に関連する寸法と拘束はそのまま保持されます。

複雑な機械的拘束がある場合など、状況によっては、この動作によって形状に予期しない変更が生じることがあります。そのような場合は、この新しいスマートスケッチ対応機能を無効にして再度プルし、寸法と拘束を作成し直す方が効率的な場合があります(以前のバージョンのCoDesignerでは、この作業が必要でした)。この機能を無効にするには、MCADのAltium CoDesigner SettingsダイアログでSmart Sketch Changeオプションを無効にします。

設計変更の影響を受けないスマート寸法は、ECADからのプル時に保持されます。

MCADでのPCBルーターツールパスの管理

基板設計では、基板外形の外周に沿って切削パスを定義することがよくあります。このパスには、多くの場合、「マウスバイト」と呼ばれる小さな穴の列が複数含まれます。穴の周囲に残された材料によって、製造用パネル内に基板が保持されます。PCBの実装が完了したら、周囲の不要な材料から基板を折り取ることができます。

基板の外周に沿ったルーター加工パスと「マウスバイト」の穴に注目してください。

ルーターツールパスは、ECADでルーターツールパスレイヤーとして設定されたメカニカルレイヤー上に定義します。

 

ルーターツールパスは製造には不可欠ですが、メカニカルエンジニアが製品筐体への基板の組み込みに集中するMCAD設計時には、不要なことがよくあります。 MCAD CoDesigner 3.13のアップデートでは、 Altium CoDesigner Settingsダイアログに Build Route Tool Pathオプションが追加され、メカニカルエンジニアがルーターツールパスをMCADにプルするかどうかを制御できるようになりました(パスは常にECADからプッシュされます)。 

MCADへのプルにルーターツールパスを含めるかどうかを選択します。MCADへのプルにルーターツールパスを含めるかどうかを選択します。

バリアントを使用したPCBの共同設計

Altium Designerでは、電子回路設計者が設計中の製品のバリアントを作成できます。サポートされるバリエーションには、部品を未実装として指定すること、基板上にシルク印刷される部品の値を含む部品パラメーターを変更すること、部品を代替部品に置き換えること(異なるフットプリントを使用する場合もあります)が含まれます。

Altium Designerでは、基板設計は1つだけです。代替部品の詳細などのバリアント情報はプロジェクトファイルに保存され、Projectsパネルでバリアントを選択すると基板に適用されます。基板の[No Variations]バージョンがPcbDocとして保存されます。

Altium Designerでは基板設計のバリアントを作成できます。Projectsパネルでバリアントを選択し、CoDesignerパネルでMCADにプッシュします。Altium Designerでは基板設計のバリアントを作成できます。Projectsパネルでバリアントを選択し、CoDesignerパネルでMCADにプッシュします。

詳細については、ECADでのバリアントの操作

を参照してください。メカニカルエンジニア向けの推奨事項

このセクションでは、メカニカルエンジニアがCoDesignerを使用する際に把握しておくべき機能と動作について説明します。

MCADでのECADリファレンス指定子の表示

Altium MCAD CoDesignerでは、各MCADツールでリファレンス指定子を表示する方法が異なります。

  • Autodesk Fusion – ECAD Propertiesパネルを表示すると、現在選択されているパーツのプロパティが表示されます()。
  • Autodesk Inventor – リファレンス指定子は、デフォルトでモデルツリーに表示されます()。
  • PTC Creo – パネルのModel Treeモードで、Tree ColumnsボタンをクリックしてModel Tree Columnsダイアログを開きます。Not Displayed TypeをECAD Paramsに設定し、ECAD_REF_DESパラメーターを探して、Add Columnボタン()をクリックします。
  • SOLIDWORKS – モデルツリーには、デフォルトでリファレンスデジグネーターが表示されます()。
  • Siemens NX – アセンブリナビゲーターで、列名が表示されている場所をright-clickしてコンテキストメニューを開き、Columns » Component Nameを選択してComponent Name列を表示します()。

機械設計者間での変更の同期

  1. CoDesignerは、Altium 365 WorkspaceなどのAltium Workspaceを介して、機械系のPCBアセンブリをECADに転送します。Workspaceを介してプッシュ/プルされる変更には方向性があります。MCADからプッシュされ、ECADにプルされるPCBアセンブリは、ECADからプッシュされ、MCADにプルされるPCBアセンブリとは別にWorkspaceに保存されます。つまり、ある機械設計者が変更した基板をWorkspaceにプッシュしても、別の機械設計者がその基板をプルすることはできません。代わりに、最後にプッシュされたECADデータがプルされます。なお、MCADの拘束は、それを作成したMCADアセンブリ内にのみ存在します。基板をMCADからECADにプッシュすると、拘束によって決まる部品位置はプッシュされますが、拘束自体はプッシュされません。そのため、基板を新しいMCADアセンブリにプルしても、以前のMCAD設計者が作成した拘束は一切含まれません。

ECADとMCADの変更は、Workspace内に別々に保存されます。ECADとMCADの変更は、Workspace内に別々に保存されます。

他の機械設計者が変更内容を確認できるようにするには、他のアセンブリと同様に、双方がアクセスできる共有ストレージにPCBアセンブリを保存してください。この方法では、MCADの拘束も保持されます。別の方法として、ECAD設計者にデータをECADへプルして保存してもらい、更新した設計をMCADへプッシュしてもらうこともできます。ただし、前述のとおり、この方法ではMCADの拘束は含まれません。

  1. もう1つの重要な点は、複数の機械設計者が同じPCBアセンブリに加えた変更は、プッシュ時にマージされないということです。いずれかの機械設計者が最後にプッシュした変更によって、他の機械設計者がそれ以前にプッシュした変更が上書きされます。

Altium Workspaceは、複数のMCAD設計者間で変更を同期するための仕組みとして使用することを想定していません。このような同期には、適切なMCAD製品データ管理システムを使用してください。PDMが利用できず、Altium Workspaceを使用する場合は、まずECAD設計者がMCAD設計者1の変更をプルして承認し、更新された基板をWorkspaceにプッシュする必要があります。その後で初めて、MCAD設計者2がその変更をプルして確認できるようになります(後述)。

同期プロセスの図解

ECADとMCADは、それぞれの変更をWorkspace内の異なる保存先にプッシュします。そのため、各設計者がプルできるのは、相手の設計者がプッシュした変更のみです。その変更に自分自身の変更が含まれるのは、相手の設計者がプッシュする前に、その変更をすでに承認していた場合に限られます。

たとえば、ECADで基板を作成し、Workspaceにプッシュして、MCADにプルしたとします。

ECADで設計を変更します

MCADにプッシュすると(Workspaceに保存されます)

MCADにプルできるようになります

 

その後、ECAD設計者が部品を追加し、ANDMCAD設計者が穴を追加した場合、ANDそれぞれが自分の基板をプッシュしてから相手の基板をプルすると、CoDesignerはMCAD設計者の基板から穴を削除し、ECAD設計者の基板から部品を削除しようとします。

ECADとMCADの両方で変更を加えます

両方の設計者が相手の変更をプルする前に自分の変更をプッシュすると

相手の設計変更が失われます

 

各設計者は、提案された特定の変更を拒否することもできます。たとえば、ECAD設計者は穴の追加を承認しつつ、部品の削除を拒否できます。ただし、この方法では、基板や変更内容が複雑になると管理が難しくなる場合があります。また、デカールに対するすべての変更は、CoDesignerでは単一の変更として認識されるため、個別に承認または拒否することはできず、全体をまとめて承認または拒否する必要があります。

より適切な方法は、以下に示すように、一方の設計者が変更を加えて基板をプッシュし、もう一方の設計者がその基板をプルしてから自分の変更を加えることです。

 

 

 

 

 

 

 

 

 

ECADとMCADの間で設計変更を受け渡す際は、循環させる手順を使用してください。

MCADの基板形状にフィレットと面取りを含める

機械設計者は、基板の角の形状を整えるために、面取りやフィレットを適用することがよくあります。これらがMCADで3Dエンティティとして定義されている場合、ECADのPCBエディターでは基板形状を厚みのある2Dオブジェクトとして定義するため、CoDesignerでECADに転送することはできません。この問題を解決するため、CoDesignerはこのような3Dエンティティを検出すると、2Dエンティティに変換して基板スケッチに埋め込むことを提案します。 

Z軸方向のエッジに適用されたMCADの3Dフィレットと面取りは、CoDesignerで2Dに変換してECADにプッシュできます。Z軸方向のエッジに適用されたMCADの3Dフィレットと面取りは、CoDesignerで2Dに変換してECADにプッシュできます。

  • フィレットと面取りの変換は、一方向の処理であることに注意してください。一度変換すると、3Dエンティティとして編集することはできなくなります。 
  • 3Dから2Dへのエンティティ変換で最初にサポートされるのは、MCADの基板形状の垂直エッジ(Z軸方向のエッジ)に作成された3Dフィレットと面取りです。
  • CoDesigner 3.9より前のバージョンでは、このようなエンティティの存在について機械設計者に警告が表示されましたが、エンティティ自体は無視されていました。

フィレットと面取りのサポート:

  • 半径が一定の通常の(円弧状の)フィレットがサポートされています()。
  • エッジからの距離が等しい面取り(対称の距離–距離)がサポートされています()。
  • 角度–距離()、または非対称の距離–距離で定義された面取りはサポートされていません。
  • 直線ではない側面エッジ上に定義されたフィレットと面取り、および他のフィレットや面取りの上に定義されたフィレットと面取りはサポートされていません。
  • リジッドフレックス設計に定義されたフィレットと面取りはサポートされていません。

ECADで基板輪郭の問題を解決する

ECADから基板をプッシュすると、CoDesignerは基板輪郭をチェックし、微小セグメントの問題や自己交差する輪郭が見つかった場合にユーザーに警告します。基板をMCADにプルすると、CoDesignerはこれらの問題の解決を試みます。解決できない場合は、ECADで修正する必要があります。

微小セグメントの自動除去

CoDesigner 2.4では、基板外形の微小セグメントを検出して解消する自動機能が導入されました。微小セグメントが検出されると、以下に示すように、問題の解消を提案するダイアログが表示されます。Yesをクリックすると、検出された問題が自動的に解消されます。Noをクリックしてダイアログを閉じると、問題の位置を詳しく示すエラーダイアログが表示されます。その場合は、以下の説明に従って手動で修正する必要があります。

この機能は新しいAPIを使用するため、Altium Designer 21.3.x以降でのみ利用できます。

なお、この自動機能では、基板外形や基板カットアウトで検出された自己交差は解消されません。これらを解消するには、以下で説明する手動の方法を使用してください。

微小セグメントと自己交差の手動除去

自動的に解消されなかった微小セグメントや自己交差、または基板カットアウトで検出されたものは、手動で修正する必要があります。

ECADで問題を修正するには:

  1. 問題の座標を参照できるように、ダイアログのエラー情報をテキストエディターにコピーします。

  2. 頂点の位置を微調整できるように、スナップグリッド(ショートカット:Gtrl+G)を小さい値(例:0.001 mil)に設定します。

  3. View » Board Planning Modeに切り替えます。

  4. 問題の位置を拡大表示します。または、Jump Locationコマンド(Edit » Jump » New Location、またはショートカット:J、L)を使用し、Jump to Locationダイアログに座標を入力します。現在の基板の単位と異なる場合は、値に単位(mmまたはmil)を付けることができます。問題が円弧に起因する場合、問題の位置が円弧の中心点になっていることがあります。この場合は、基板外形に短くて曲がりの浅い円弧がないか目視で確認してください。

  5. Design » Edit Board Shapeコマンド(ショートカット:D、D)を実行します。基板外形の各エッジの両端と中央に頂点が表示されます。非常に近接した複数の頂点や、曲がりが非常に浅い円弧がないか確認します。問題の解消には、次のヒントを参考にしてください:

    1. エッジまたは頂点をクリックしてドラッグすると、形状を変更できます。編集中は、エッジの分割、エッジの移動(スライド)、エッジの湾曲(曲げ)の3つの形状変更モードを使用できます。編集中にShift+Spaceを押すと、モードが順番に切り替わります。現在のモードはステータスバーに表示されます。
    2. 短いエッジの端にある頂点を少し移動してから、マウスボタンを離します。多くの場合、これだけでソフトウェアが問題を解消し、短いエッジを除去できます。
    3. 短くて曲がりの浅い円弧は、湾曲モードで中央の頂点をドラッグして円弧を平らにすると、直線のエッジに変換できます(マウスボタンを離すと、直線のエッジに置き換えられます)。
    4. 移動中のエッジまたは円弧の弦が既存のエッジと整列すると、緑色の位置合わせガイドが表示されます。
    5. 頂点をクリックしたままDeleteを押すと、その頂点を削除できます。頂点を追加するには、Ctrlを押しながらエッジをクリックし、カーソルを目的の位置に移動してから離します。

     

  6. 基板を再度プッシュします。

基板をMCADにプッシュするには、基板輪郭の自己交差と微小セグメントを解消しておく必要があります。

上の動画では、Altium Designerで基板外形と基板カットアウトの問題を解消する方法を示しています。他のAltium設計ソフトウェアでも、手順は基本的に同じです。

頂点編集モードの詳細

基板形状の定義の詳細

1つの問題を修正すると、ECADは基板またはカットアウトの輪郭全体を再計算します。この再計算によって他の問題も自動的に解消される場合があるため、修正するたびにプッシュすることをお勧めします。

PCBの以前のリビジョンをMCADにプルする

ECADの基板を空のMCADアセンブリにプルするには、Altium CoDesignerパネルのPullボタンをクリックして、Select Project from Company Workspaceダイアログを開きます。デフォルトでは、最後にプッシュされた基板が選択されます。PCB設計の以前のリリースまたはリビジョンを開く必要がある場合は、ダイアログのECAD Push to Openセクションで 変更をクリックして、Select Pushダイアログiを開きます。

このダイアログには過去のすべてのプッシュが一覧表示されます。必要なものを選択して、OKをクリックします。 ECADのコミットにタグが付けられている場合は、Select PushダイアログでOnly show tagged commitsオプションを有効にすると、一覧をすばやく絞り込めます。

Select Pushダイアログを使用して、ECADでプッシュされたすべてのリビジョンから以前のリビジョンを選択します。Select Pushダイアログを使用して、ECADでプッシュされたすべてのリビジョンから以前のリビジョンを選択します。 

  • Workspaceは自動プッシュを実行します。この処理は、MCADへの最初のプルが実行された後に開始されます。自動プッシュの詳細をご覧ください。

ECAD側で行われた変更の表示

MCADソフトウェアでは、PCBアセンブリの組み込み先となる親デバイスや親アセンブリではなく、PCBアセンブリ自体を開くことが重要です。PCBアセンブリを開くと、ECAD側で行われてプッシュされた変更の詳細がAltium CoDesignerパネルに表示されます。親デバイスや親アセンブリを開いている場合、変更の詳細はパネルに表示されません。

ECADからPCBアセンブリへの変更を取得する

  1. MCADでPCBアセンブリを別ファイルとして(ルートアセンブリとして)開きます。
  2. Altium CoDesignerパネルを開きます。
  3. Pullをクリックします。
  4. 表内の変更を確認し、適用する変更を有効にして、Applyボタンをクリックします。

ECADからMCADに転送される前に、3D部品モデルはParasolid形式に変換されます(MCADでの3Dモデルの命名方法の詳細をご覧ください)。一部のモデルを変換できない場合があります。このようなモデルは、MCADではバウンディングボックスに置き換えられ、CoDesignerに警告メッセージが表示されます。

または、ECADでそのようなモデルを単一ボディのParasolidモデルに置き換えることもできます。これらは変換されずにECADとMCAD間で直接転送されます。問題のあるモデルの解決の詳細をご覧ください。

MCADで初めてPCBアセンブリを開いたときの操作

  1. PCBアセンブリをデバイスのアセンブリに追加します。
  2. 適切な合致や拘束を適用して固定します。

If a contour of the PCB does not correspond to the shape of your enclosure:

  1. 基板パーツの編集を開始します。
  2. 基板の押し出しスケッチを編集し、筐体に合わせて形状を調整します。

PCB形状を変更する方法の1つは、外形全体を削除し、筐体の対応する輪郭をオフセットして、最初から作成し直すことです。

MCADでのPCB設計の変更

MCADで使用する設計形状やオブジェクトが、基板をECADへプッシュした際にサポートされるようにするためのヒントを以下に示します。

基板外形の編集

  1. 基板パーツの編集を開始します。
  2. 基板の押し出しスケッチを編集します。

Notes:

  • CreoおよびInventorの基板外形スケッチ、またはSolidWorksのリジッドフレックス基板外形スケッチには、内部輪郭を含めないでください。切り抜きや穴には、それぞれ押し出しカットまたは穴フィーチャーを使用してください。

  • Inventorでは、基板外形スケッチに複数のプロファイルを作成しないでください。CoDesignerが予期しない方法で解釈する可能性があります。

  • Autodesk Fusionで、投影コマンドを使用して既存の筐体輪郭を投影し、MCADで基板形状を再作成する場合は、Autodesk FusionのPROJECTダイアログでProjection Linkオプションを無効にする必要があります。「投影リンク」オプションが有効になっていると、参照元の輪郭のサイズが変更されるたびに、投影された輪郭のサイズも自動的に変更されます。現時点では、CoDesignerはこの機能をサポートしていません。

MCADの基板原点の変更

  1. 必要に応じて、メカ設計者は基板定義の初期段階で、ベアボードのMCAD原点を変更できます。これを行うには、基板パーツ内で基板外形のsketch全体を移動するか、描き直すだけです。基板パーツは基板アセンブリ内で「固定」として拘束されており、その原点はアセンブリの原点と一致していることに注意してください(したがって、「MCAD原点」は基板パーツの原点と基板アセンブリの原点の両方を指します)。

予期しない変更が生じる可能性があるため、この拘束は変更も解除もしないことを強く推奨します。

Notes:

  • すでに部品が配置されている場合は、それに合わせて基板アセンブリ内で部品を移動する必要があります。
  • ECADの「電気的な」基板原点は別個に管理されるため、変更されません。

取り付け穴の作成と編集

  1. 基板パーツの編集を開始します。
  2. 基板パーツの上面または下面に、Holeフィーチャーを作成または編集します。

Notes:

  • フィーチャーパターンはサポートされていません。
  • 基板端を基準に穴の位置を定義している場合、その後ECADで基板外形を変更してMCADに戻すと、これらの関係は失われます。穴の操作について詳しくは、後述の拘束と寸法の操作セクションを参照してください。

切り抜きの作成と編集

  1. 基板パーツの編集を開始します。
  2. 基板パーツの上面または下面を基準に、Extruded Cutフィーチャーを作成または編集します。

Notes:

  • 複数の輪郭を含むスケッチは、PTC CreoおよびAutodesk Inventorではサポートされていないため、使用しないでください。*
  • フィーチャーパターンはサポートされていません。
  • 基板端を基準に押し出しカットのスケッチを定義している場合、その後ECADで基板外形を変更してMCADに戻すと、これらの関係は失われます。

部品配置の編集

  1. 基板アセンブリの編集を開始します。
  2. 部品を移動、回転、反転するか、合致または拘束を設定します。

Notes:

  • MCADでは、部品の穴とシルクスクリーンは部品の移動に追従しません。このような部品に依存する変更を反映するには、基板をECADへプッシュし、そこで変更を適用してから、ECADからMCADへ基板をプッシュし直して、部品の穴とシルクスクリーンを更新してください。
  • 基板端を参照するMCADの合致や拘束は、ECADで基板形状を変更すると失われる場合があります。

MCADの固定・拘束状態とECADのロック状態の同期

MCADで部品が固定または拘束されている場合、その部品はECADでロックされます(その拘束によってPCBアセンブリ内での移動が許可されているかどうかは関係ありません)。ECADで部品がロックされている場合、MCADですでに拘束されていなければ、その部品は固定されます。ロック・固定状態の変更は、MCADとECADの間で同期されます。

ECADの部品パラメーターのMCADへの転送

ECADのPCB部品パラメーターは、MCADで作成された対応するモデルに転送されます。ただし、最初にMCADで配置された部品は対象外です。

MCADでの拘束と寸法の操作

基板外形に適用される拘束

  1. メカ設計者は、基板外形の要素と、別の基板外形要素、データム/参照フィーチャー、上位アセンブリ内のパーツ、または部品との間に拘束を適用できます。CoDesignerはこれらの拘束を変更しません。ただし、ECAD側で基板外形を変更すると、MCADで基板パーツのスケッチが描き直され、すべてのエッジIDが変更されます。ECADで基板外形のどの部分を変更しても、MCADでは基板全体が描き直され、すべての基板エッジIDが変更されることに注意してください。それらのエッジや、そこから生成された面に拘束が適用されていた場合、その拘束は失われます。MCADで基板の位置が変わることはなく、必要に応じて拘束を手動で復元できます。

拘束の再定義にかかる時間を考慮し、only make changes to the board outline in MCADことを推奨します。

Note: CoDesignerは、メカ設計者間で変更を転送するためには使用できないことに注意してください(メカ設計者間での変更の同期を参照)。

部品に適用される拘束

  1. メカ設計者は、部品と、基板、筐体、または別の部品との間に拘束を適用できます。その部品のモデルがローカルで見つかる場合(PCBアセンブリを別のフォルダーで最初から構築しない場合、またはモデルを保存する共通フォルダーが設定されている場合)、これらの拘束は正常に維持されます。ただし、ECAD側で部品を移動した場合、MCAD側の配置変更がその移動に対応しない可能性があるため、手動で確認する必要があります(この場合、CoDesignerから通知されます)。ECADフットプリントを持つ部品の場合、部品のスタンドオフ(基板表面に対するZ方向の位置)は、常にフットプリント内のSTEPモデルの位置によって定義されます。CoDesignerは、MCADへのプル時に、競合するMCAD拘束を常に上書きしようとします。

Note: 合致や拘束を適用する箇所には注意してください。たとえば、デバイスアセンブリ内でPCBアセンブリを固定せずに、PCB部品と筐体の間に拘束や合致を適用すると、設計に予期しない変更が生じる可能性があります。

MCADからECADに転送されない変更

  • ベアボードの厚さ — ECADのレイヤースタックで定義されます。

    Note:MCADで行われた基板厚の変更は、ECADでは適用できない変更として表示されるため、ECAD設計者は提案されている変更を把握できます。

  • 一定の半径で定義された3Dフィレット と、エッジからの距離が等しくなるように定義された3D面取り (Z軸方向に定義) に加え、基板のZ軸方向の穴と押し出しカットがサポートされています。角度と距離で定義された面取りなど、基板パーツに適用されたその他の3D形状フィーチャーは無視されます。詳しくは、フィレットと面取りの操作をご覧ください。
  • 基板のZ軸方向の穴と押し出しカットを除く、基板パーツに適用されたその他の形状フィーチャー(3D面取りやフィレットなど)。
  • 基板アセンブリのコンテキストで作成されたその他の形状フィーチャー(アセンブリのコンテキストで作成された穴など)。ただし、これらのフィーチャーがパーツに反映されている場合を除きます。
  • コンポーネントとは別に移動された場合の、コンポーネントの穴の位置。
  • コンポーネントの穴のサイズ。
  • フィーチャーパターン。
  • 複数の輪郭を持つカットアウトのスケッチ(PTC CreoおよびAutodesk Inventor)。
  • 押し出された銅箔に加えられた変更。
  • シルクスクリーンに加えられた変更。
  • コンポーネントの削除。コンポーネントの位置変更はECADに転送されるため、MCADエンジニアはコンポーネントを基板領域の外側に移動することで 削除を示すことができます (コンポーネントの削除がサポートされていない理由をご覧ください)。 

デバイスアセンブリのコンテキストでの作業

CoDesigner 2.2.0では、MCADのデバイスアセンブリレベルで作業し、筐体を基板とともにECADに転送する機能が追加されました。以下の動画では、基板アセンブリをデバイスの筐体に組み込み、筐体をECADに転送する手順を紹介しています。

お使いのMCAD CoDesignerで筐体交換機能を利用できるかどうかについては、右側のペインのNoteを参照してください。利用できない場合は、こちらの動画で 筐体を転送する別の方法を紹介しています。

デバイスアセンブリのコンテキストでの作業の概要。

筐体を扱う際のヒント:

  • 基板アセンブリを筐体内に配置した後、Altium CoDesignerパネルのRecognizeボタンをクリックします。CoDesignerは基板と筐体の関係を検出し、デバイスの筐体に追加されたすべての基板アセンブリの名前をパネル上部に表示します。

  • 関係が検出されたら、最後に筐体を基板に追加します。手順は次のとおりです。

    • モデルツリーで筐体を選択します。
    • Altium CoDesignerリボンを表示します。
    • リボンのEnclosureボタンをクリックします。
    • Altium CoDesignerパネルを開くか表示し、Altium CoDesignerパネルのBoard Enclosureセクションで筐体が基板に関連付けられていることを確認します。
  • これで、筐体を基板とともにECADへプッシュできます。

変更を含むPCBアセンブリをECADに送信する

  • MCADでPCBアセンブリが個別のドキュメントとして(ルートアセンブリとして)開かれていることを確認します。
  • Altium CoDesignerパネルに移動します。
  • Pushをクリックします。

* この動作は、今後のアップデートで改善される予定です。

MCADデータ管理システムとの連携

お使いのMCAD CoDesignerでECAD-MCADコンポーネントリンク機能を利用できるかどうかについては、右側のペインのNoteを参照してください。

CoDesignerは、PCBをECADからプッシュしてMCADにプルする際に、ネイティブMCADコンポーネントを配置する機能をサポートしています。このために、CoDesignerはMCADソフトウェアに対し、MCADのデータ管理システムからコンポーネントのモデルをモデル名で取得するよう要求し、ECADから受け取ったモデルの代わりに、そのコンポーネントをMCADのPCBアセンブリに配置します。

ECADからMCADへのネイティブコンポーネントのリンクは、現在、次の環境でサポートされています。

  • CoDesigner Addinバージョン2.6.0以降を使用し、PTC Windchill®サーバーに接続されたPTC Creo Parametric。Windchillへの接続方法については、Creoのドキュメントを参照してください。詳しくは、PTC Creoの設定をご覧ください。
  • CoDesigner Addinバージョン2.6.0以降を使用し、SOLIDWORKS® PDM Professionalに接続されたSOLIDWORKS。SOLIDWORKS PDMへの接続方法については、SOLIDWORKSのドキュメントを参照してください。詳しくは、ネイティブMCADコンポーネントを使用するためのSOLIDWORKSの設定をご覧ください。
  • CoDesigner Addinバージョン3.4.0以降を使用し、Siemens Teamcenter PLMに接続されたSiemens® NX™。Teamcenter PLMへの接続方法については、Siemens NXのドキュメントを参照してください。詳しくは、ネイティブMCADコンポーネントを使用するためのSiemens NXの設定をご覧ください。
  • ECADコンポーネントとネイティブMCADコンポーネントのリンクは、Altium Workspaceで定義されます。詳しくは、ECADコンポーネントからMCADコンポーネントへのリンクをご覧ください。
  • Altium Workspaceは、複数のMCADエンジニア間で変更を同期するための仕組みとして使用することを意図したものではありません。これには、適切なMCAD製品データ管理システムを使用してください。PDMが利用できず、Altium Workspaceを使用する場合は、MCADエンジニア2が変更をプルして確認できるようにするために、ECADエンジニアがまずMCADエンジニア1の変更をプルして承認し、更新された基板をWorkspaceにプッシュし直す必要があることに注意してください。

SOLIDWORKS PDMとの連携

CoDesignerは、SOLIDWORKS® PDM Professionalを使用して開発およびテストされています。

SOLIDWORKS PDMからのネイティブMCADコンポーネントの配置

基板設計をECADからSOLIDWORKS MCADに転送する際、CoDesignerはECADコンポーネントを、SOLIDWORKS PDMシステム内の対応するネイティブMCADコンポーネントに置き換える機能をサポートしています。これを行うには、以下の設定が必要です。

  • MCAD - こちらの説明に従って、PDM設定とCoDesignerのモデル保存先を設定し、同期の要件を確認します。
  • ECAD - 正しい構文を使用して、ECADコンポーネント内でMCADモデルを参照します。MCADコンポーネントの参照は、ECADコンポーネント内でパラメーターとして定義する必要があり、そのパラメーター値は次の形式にします:
    <vault>:folder\folder\component.sldprt。ここで、<vault>はSOLIDWORKS PDMのボルト名です。
  • Workspace - ネイティブMCADコンポーネントを使用するようにWorkspaceのオプションを設定し、対応するMCADコンポーネントの参照に使用するECADコンポーネントのパラメーターを定義します。詳しくは、ECADコンポーネントからMCADコンポーネントへのリンクをご覧ください。

既存のPCBアセンブリに変更をプルする前に

  • モデル保存用の共通フォルダーで指定したコンポーネントフォルダーのローカルコピーをサーバーと同期します(SOLIDWORKS PDMのGet latest versionコマンドを使用)。
  • 以下のファイルをチェックアウトします。
    • 基板アセンブリ
    • 基板パーツ
    • リジッドフレックス2.0アセンブリの場合 - すべての基板パーツとサブアセンブリ
    • 3D銅箔が生成されている場合 - 3D銅箔およびソルダーマスクに関連するアセンブリとパーツ
    • PDMに保存されている場合は、デカールのPNGファイル

Note: 通常、部品モデルをPDMからチェックアウトする必要はありません。

ECADからMCADに変更をプルする際の注意点

  • CoDesignerが適用しようとする部品プロパティの変更に注意してください。該当する行は、SOLIDWORKSのAltium CoDesignerパネルにある変更一覧テーブルで黄色にハイライトされます。

変更が発生する一般的な理由として、CoDesignerはMCADで部品モデルを作成する際、ECADの部品ライブラリに保存されている部品プロパティをMCADモデルのプロパティに書き込みます。しかし、その後、一部のプロパティ(DescriptionやMaterialなど)がMCADまたはPDMによって自動的に変更されることがあります。そのため、プロパティの値に違いが検出されると、CoDesignerはその変更を提案します。

ただし、これらの変更を適用しようとすると、MCADは影響を受ける各モデルをPDMからチェックアウトするか、別の名前で保存するよう要求します。これを避けるには、Altium CoDesignerパネルで部品プロパティの変更に関連する項目のチェックを外してください。なお、部品プロパティが異なる理由を明らかにし、MCAD側とECAD側で同期させることを強くお勧めします。

変更の適用後

  • 新しく作成された部品、基板アセンブリ、サブアセンブリ、およびパーツをPDMにチェックインしてください。

MCAD PCBのクローン作成

既存のMCAD PCBアセンブリの機械的な寸法や参照を維持したまま、クローンを作成して新しいPCBプロジェクトで再利用したいとお考えですか?これは、MCADアセンブリの複製内で2つのプロパティを編集することで実現できます。

MCAD PCBアセンブリは、ManagedProjectGUIDとManagedProjectNameという2つのプロパティによってECADプロジェクトに関連付けられています。これらは、MCAD PCBアセンブリのPropertiesダイアログで表示および編集できます。下の画像は、SOLIDWORKSのPropertiesダイアログを示しています。

2つのプロパティがMCADアセンブリとECADプロジェクトを関連付けます。2つのプロパティがMCADアセンブリとECADプロジェクトを関連付けます。

  1. 既存のMCAD PCBアセンブリを新しいECADプロジェクトに関連付けるには、MCADアセンブリ内のこれらのプロパティを、新しいECADプロジェクトに合わせて更新する必要があります。
  • ManagedProjectName - ECAD PCBプロジェクトのファイル名:<ManagedProjectName>.PrjPcb

  • ManagedProjectGUID - GUIDを確認するには、次のいずれかからコピーします。

    1. Workspaceのブラウザーのアドレスバー – プロジェクトが保存されているAltium Workspaceを開き、プロジェクトをダブルクリックして別のブラウザータブで開きます。ブラウザーのアドレスバーのURLには、ManagedProjectGUID ()が含まれています。または、

    2. ECADプロジェクトファイル – プロジェクトファイル(拡張子は.PrjPcb)をテキストエディターで開きます。ManagedProjectGUIDは、ファイルの先頭にある[Design]セクション内にあります()。ManagedProjectGUIDをコピーしますが、テキストエディターではファイルをdo not modify or save.PrjPcb。

  1. MCADソフトウェアでMCAD PCBアセンブリを開き、これら2つのプロパティのValueを編集して、MCADアセンブリを保存し、閉じます。

  2. クローン化したMCADアセンブリを再度開き、Altium CoDesignerパネルの上部を確認します。手順1でクローンファイルに入力したManagedProjectNameプロパティが表示されているはずです。表示されていれば、クローンの作成は成功しており、MCADソフトウェアからWorkspaceへ基板定義をPushedできるようになります。

    ManagedProjectNameおよびManagedProjectGUIDプロパティを編集すると、CoDesignerパネルに更新後のプロジェクト名が反映されます。ManagedProjectNameおよびManagedProjectGUIDプロパティを編集すると、CoDesignerパネルに更新後のプロジェクト名が反映されます。

 

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

Contents