ドキュメント内の移動

Altium Training

Altium Essentials: Navigating Schematics

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

回路図シート、PCBドキュメント、Draftsmanドキュメントなどのグラフィカルドキュメントでは、ズームやパン操作を使って、ドキュメント内の特定の領域に注目できます。これらの操作に使用できる基本的なショートカットは次のとおりです。

  • Ctrl+Mouse Wheel:ズームイン/ズームアウト
  • Right-Click, Hold&Drag:ドキュメントをパン

Viewメインメニューには、現在のドキュメントの表示を制御するための各種コマンドがあります。

Viewメインメニューのコマンドを使用して、ドキュメントの表示を制御できます。上の画像は回路図エディターのViewメニュー、下の画像はPCBエディターのViewメニューを示しています。

Viewメインメニューのコマンドを使用して、ドキュメントの表示を制御できます。上の画像は回路図エディターのViewメニュー、下の画像はPCBエディターのViewメニューを示しています。

これらのコマンドには、次のものがあります。

  • Fit Document - 現在のドキュメントの全領域を表示します。

  • Fit All Objects - 現在のドキュメント内のすべての設計オブジェクトを表示します。

  • Area - 現在のドキュメント内でユーザーが指定した領域を拡大表示します。

  • Around Point - 現在のドキュメント内の指定した点を中心に、表示領域を再設定します。

  • Selected Objects - 選択したすべてのオブジェクトが見えるように、設計スペースの表示を変更します。

  • Zoom In - 現在のドキュメント内で、カーソル位置を基準に設計を拡大表示します。

  • Zoom Out - 現在のドキュメント内で、カーソル位置を基準に設計を縮小表示します。

  • Zoom Last - 現在のドキュメントの表示を、直前の画面表示に戻します。

Zショートカットを使用して、ズームコマンドを含むポップアップメニューを開くこともできます。

PCBエディターおよびPCBフットプリントエディターでは、このメニューからSelectコマンドを実行できます。このコマンドで開くZoom Value (0.001x..4x)ダイアログでは、指定した値で現在のドキュメントの表示倍率を変更できます。1より大きい値を入力すると、より大きくズームインします(表示倍率が上がります)。1より小さい値を入力すると、より大きくズームアウトします(表示倍率が下がります)。

Zoom Valueダイアログ
Zoom Valueダイアログ

PCBドキュメントまたはPCBフットプリントドキュメントを3D表示している場合は、追加のコマンド、ショートカット、コントロールを使用して、表示をスムーズに操作できます。詳しくは、3D表示の制御ページを参照してください。

ドキュメント内の特定の位置へのジャンプ

回路図エディター、回路図シンボルエディター、PCBエディター、PCBフットプリントエディターのメインメニューにあるEdit » Jumpサブメニューのコマンドを使用すると、アクティブなドキュメント内の特定の位置へジャンプできます。設計スペースでJキーを押して、Jumpポップアップメニューを開くこともできます。例えば、次の位置にジャンプできます。

  • ドキュメントの原点座標:
    • 回路図シートの原点(左下隅に相当) - Origin;

    • PCBドキュメントの絶対原点 - Absolute Origin;

    • 現在のPCBドキュメントの相対原点 - Current Origin;

    • PCBフットプリントドキュメント内のコンポーネントの基準点 - Reference;

  • ユーザーが指定したXY座標に基づく、現在のドキュメント内の任意の位置 - New Locationコマンドを選択し、表示されるJump To Locationダイアログで、カーソルのジャンプ先となる設計スペース内の位置のX座標とY座標を入力します。PCBエディターでは、Delta XフィールドとDelta Yフィールドを使用して、ジャンプ先の位置をXおよびYの差分座標で指定することもできます。

    Jump To Locationダイアログ - 回路図エディター(1枚目の画像)とPCBエディター(2枚目の画像)
    Jump To Locationダイアログ - 回路図エディター(1枚目の画像)とPCBエディター(2枚目の画像)

  • ドキュメント内のオブジェクト。目的のオブジェクトへジャンプするには、次のコマンドを使用します。
    • 回路図シート上のコンポーネント - Jump Component。コマンドを実行すると、Component Designatorダイアログが表示されます。ジャンプ先のコンポーネントのデジグネーターを入力してください。デジグネーターが有効で、アクティブなプロジェクト内のソース回路図ドキュメントにそのコンポーネントが存在する場合、該当する回路図ドキュメントがアクティブになり、対象のコンポーネントが拡大表示され、可能な場合は設計スペースの中央に配置されます。見つかったコンポーネント(マルチパートコンポーネントの場合はすべてのパート)は、Messages パネルにも一覧表示されます。メッセージ項目をダブルクリックすると、設計スペース内のそのコンポーネント(またはそのパート)へジャンプできます。

      Component Designatorダイアログ
      Component Designatorダイアログ

      マルチパートコンポーネントを対象とする場合は、ルートデジグネーターのみを入力し、パートのサフィックスは含めないでください。例えば、各パートがIC1_CPAとIC1_CPBで識別される2パートのICコンポーネントへジャンプするには、Component DesignatorダイアログにIC1_CPを入力します。マルチパートコンポーネントの場合、最初のパートがハイライト表示され、Find Text - Jumpダイアログが開きます。このダイアログを使用して、コンポーネントの各サブパート間を移動できます。
      Component DesignatorダイアログのPhysical オプションを有効にすると、ジャンプ機能の対象を物理コンポーネントのデジグネーター、つまりソース回路図ドキュメントのCompiled Documentタブ付きビューに表示されるデジグネーターのみに制限できます。このオプションを無効にすると、ジャンプ機能は論理デジグネーター、つまりソース回路図ドキュメントのEditor タブ付きビューに表示されるデジグネーターのみを対象とします。
    • PCBドキュメント内の特定のコンポーネント - Component。コマンドを実行すると、Component Designatorダイアログが表示されます。コンポーネントのデジグネーターを入力すると、そのコンポーネントへジャンプします。デジグネーターが不明な場合は、?を入力してOK をクリックすると、設計内のすべてのコンポーネントを一覧表示するComponents Placedダイアログが開きます。Maskフィールドにテキストを入力して、目的のコンポーネントを検索してください。入力するにつれてリストが絞り込まれ、マスク文字列に一致する文字列のみが表示されます。文字列には、ワイルドカードの?(任意の1文字)と*(任意の文字列)を使用できます。カーソルは、選択したコンポーネントの基準点へジャンプします。

      Component Designatorダイアログに?を入力すると、PCB内のすべてのコンポーネントを一覧表示するComponents Placedダイアログを開けます。
      Component Designatorダイアログに?を入力すると、PCB内のすべてのコンポーネントを一覧表示するComponents Placedダイアログを開けます。

    • PCBドキュメント内の特定のネット - Net。コマンドを実行すると、Net Nameダイアログが表示されます。ジャンプ先のネット名を入力するか、?を入力してOK を押すと、設計に読み込まれているすべてのネットを一覧表示するNets Loadedダイアログが開きます。Maskフィールドにテキストを入力して、目的のネットを検索してください。入力するにつれてリストが絞り込まれ、マスク文字列に一致する文字列のみが表示されます。マスク文字列には、ワイルドカードの?(任意の1文字)と*(任意の文字列)を使用できます。対象のネットがメイン設計ウィンドウにすでに表示されている場合、カーソルはそのネットに属する最も近い設計オブジェクトへジャンプします。ネットが表示範囲外にある場合、カーソルはそのネットに属する最も近い設計オブジェクトに移動し、可能な場合はそのオブジェクトが設計スペースの中央に表示されます。

      Net Nameダイアログに?を入力すると、PCB内のすべてのネットを一覧表示するNets Loadedダイアログを開けます。Net Nameダイアログに?を入力すると、PCB内のすべてのネットを一覧表示するNets Loadedダイアログを開けます。

    • PCBドキュメント内の特定のコンポーネントのパッド - Pad。コマンドを実行すると、Jump To Pad Numberダイアログが表示されます。目的のコンポーネントのパッドをComponentDesignator-PadDesignatorの形式(例:U1-6)で入力し、OKをクリックします。対象のパッドがすでに設計スペース内に表示されている場合、カーソルはそのパッドの中心に移動します。パッドが表示範囲外にある場合、カーソルはパッドの中心に配置され、その位置が設計スペースの中央に表示されます(可能な場合)。

      Jump To Pad Numberダイアログ
      Jump To Pad Numberダイアログ

    • PCBドキュメント内の特定の文字列 - String。コマンドを実行すると、Jump To Stringダイアログが表示されます。移動先の文字列を入力するか、?を入力してOK をクリックすると、Stringsダイアログが開きます。このダイアログには、アクティブな基板ドキュメント内のすべての文字列(独立した文字列と、他のグループオブジェクトに属する文字列)が一覧表示されます。このダイアログを使用すると、移動先の文字列をすばやく見つけることができます。対象の文字列がすでに設計スペース内に表示されている場合、カーソルは文字列のアンカーポイントに移動します。アンカーポイントとは、移動操作中に文字列を保持する基準点、または回転の中心となる点です。文字列が表示範囲外にある場合、カーソルは文字列のアンカーポイントに配置され、その位置が設計スペースの中央に表示されます(可能な場合)。

      Jump To Stringダイアログで?を入力すると、PCB内のすべてのネットを一覧表示するStringsダイアログにアクセスできます。
      Jump To Stringダイアログで?を入力すると、PCB内のすべてのネットを一覧表示するStringsダイアログにアクセスできます。

      システムは3段階の検索を実行します。まず、大文字と小文字、文字、および長さが指定した文字列と完全に一致する文字列を検索します。次に、同じ文字を含むものの、文字数が多い可能性がある文字列を検索します。最後に、大文字と小文字を区別せず、同じ文字を含む文字列を検索します。

    • 現在の設計ドキュメント内のすべてのエラーマーカーに順番に移動する - Error Marker。コマンドを実行すると、カーソルは最初のデザインルールチェック(DRC)エラーマーカーに移動し、その位置がメイン設計ウィンドウの中央に表示されます。コマンドを繰り返し実行すると、2番目のエラーマーカー、3番目のエラーマーカーというように順番に移動します。このコマンドは、違反が免除されているかどうかにかかわらず、エラーマーカーに移動します。

      カーソルの下にあるオブジェクトに関連する違反を調べるには、右クリックしてViolations サブメニューから該当するコマンドを選択します。

  • 現在のドキュメント内で選択されているすべての設計オブジェクトに順番に移動する - Selection。コマンドを実行すると、カーソルは最初の選択オブジェクトに移動し、そのオブジェクトがメイン設計ウィンドウの中央に拡大表示されます。コマンドを繰り返し実行すると、2番目の選択オブジェクト、3番目の選択オブジェクトというように、現在のドキュメント内で選択されているすべてのオブジェクトを順番に巡回します。巡回順序は、オブジェクトが最初に選択対象に追加された順序に従います。

  • 指定した位置マーカーに座標を保存しておいた、現在の回路図またはPCBドキュメント内の位置 - Location Marks » nコマンドを選択すると、Set Location Marks » nコマンドを使用して指定の位置マーカーに保存した位置に移動します。

    回路図ドキュメントの場合、保存した位置は、ドキュメントが開いている間のみ使用できます(アクティブかどうかは問いません)。ドキュメントを閉じて再度開くと、位置マーカーは空になります。PCBドキュメントの場合、位置マーカーは設計とともに保存されるため、設計セッションを終了しても、マーカーに保存されたユーザー定義の位置に引き続きアクセスできます。
AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。