Altium NEXUS Documentation

DocumentPreferences

Modified by Susan Riege on Nov 29, 2018

Parent page: PCB Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: VisibleGridKind=Toggle

Summary

This command is used to toggle the markers used for the fine-level display of the default Global Board Snap Grid between lines and dots.

Access

This command can be accessed from both PCB and PCB Library Editors:

  • PCB Editor - the following methods of access are available:
    • Choose the View » Grids » Toggle Visible Grid Kind command from the main menus.
    • Choose the Toggle Visible Grid Kind entry on the Grids drop-down () of the Utilities toolbar.
    • Use the V keyboard shortcut then choose the Grids » Toggle Visible Grid Kind entry on the subsequent pop-up menu.
  • PCB Library Editor - the following method of access is available:
    • Choose the View » Grids » Toggle Visible Grid Kind command from the main menus.
    • Choose the Toggle Visible Grid Kind entry on the Grids drop-down () of the PCB Lib Standard toolbar.
    • Use the V keyboard shortcut then choose the Grids » Toggle Visible Grid Kind entry on the subsequent pop-up menu.

Use

After launching the command, the marker type used for the Global Board Snap Grid's fine-level grid display will change to either dots or lines depending on the type that was previously in use.

Tips

  1. This command only toggles the marker type used for the fine-level display and not the coarse-level display.
  2. The marker type can also be changed through the Cartesian Grid Editor dialog when editing the default Global Board Snap Grid. Grid management is performed through the Grid Manager section of the Properties panel when no objects are currently selected in the design workspace.


Applied Parameters: ElectricalGridEnabled = Toggle

Summary

This command is used to cycle to the next mode of object Hotspot Snapping. Often referred to as an Electrical Grid, object hotspot snapping provides an aid to routing electrical objects, especially those that may not fall on the default Global Board Snap Grid or a defined custom grid. It gives you a distance, or tolerance, in which the cursor can be away from an object but still snap to the object's hot-spot (e.g., the center of a pad). Object hotspot snapping overrides a snap grid allowing you to easily connect to an off-grid object.

Access

This command can be accessed from both PCB and PCB Library Editors by:

  • Choosing the View » Grids » Toggle Object Hotspot Snapping command from the main menus.
  • Using the Shift+E keyboard shortcut.
  • Using the V keyboard shortcut then choose the Grids » Toggle Object Hotspot Snapping entry on the subsequent pop-up menu.
In addition, from the PCB Editor, you can choose the Toggle Object Hotspot Snapping entry on the Grids drop-down () of the Utilities toolbar.

Use

After launching the command, object hotspot snapping will cycle to the next mode within the following modes depending on its previous state:

  • ON (Current Layer) - hotspot snap is enabled for the current layer. That is, the cursor will snap to object hotspots on the current layer only.
  • ON (All Layers) - hotspot snap is enabled for all visible layers. That is, the cursor will snap to object hotspots on any layer, not just the current layer.
  • OFF - hotspot snap is disabled.
The current mode is reflected on the Status Bar - (Hotspot Snap) ----> (Hotspot Snap (All Layers)) ----> no display.

Tips

  1. Hotspot snapping can also be enabled/disabled and its range (Snap Distance) defined in the Snap Options section of the Properties panel (when no objects are currently selected in the design workspace).
  2. Hold the Ctrl shortcut key to temporarily disable object hotspot snapping during interactive routing.


Applied Parameters: MeasurementUnit=Toggle

Summary

This command is used to toggle the measurement units for the current document, between metric (mm) and imperial (mil).

Access

This command can be accessed from the PCB Editor, and PCB Library Editor, by:

  • Choosing the View » Toggle Units command from the main menus.
  • Using the Q keyboard shortcut.
  • Using the V keyboard shortcut then choosing the Toggle Units entry on the subsequent pop-up menu.

Use

After launching the command, the measurement units for the current document will become either metric or imperial depending on the measurement units previously in force.

Tips

  1. The current measurement units for the document can be checked/changed in the Other section of the Properties panel (when no objects are currently selected in the design workspace).


Applied Parameters: MaskLevel=Increase

Summary

This command is used to increase the masking level, and therefore, decrease the extent of dimming in the workspace for all objects not falling under the scope of a currently applied filter.

This command is only effective when the highlighting method for objects not passing the applied filter is set to Dim. Unlike the Mask highlighting method, such objects can still be selected and edited.

Access

This command can be accessed from the PCB Editor by:

  • Choosing the View » Increase Mask Level command from the main menus.
  • Using the ] keyboard shortcut.

Use

After launching the command, the level or intensity of masking applied in the workspace will be decreased. Design objects that do not fall under the scope of the currently applied filter will become less faded. Continue using this command to further increase the display intensity of objects not belonging to the filtered set.

Tips

  1. Use of this command corresponds to sliding the Dimmed Objects slider to the right (increasing its value). This slider can be found in the Mask and Dim Settings section on the View Options tab of the View Configuration panel.


Applied Parameters: MaskLevel=Decrease

Summary

This command is used to decrease the masking level, and therefore, increase the extent of dimming in the workspace for all objects not falling under the scope of a currently applied filter.

This command is only effective when the highlighting method for objects not passing the applied filter is set to Dim. Unlike the Mask highlighting method, such objects can still be selected and edited.

Access

This command can be accessed from the PCB Editor by:

  • Choosing the View » Decrease Mask Level command from the main menus.
  • Using the [ keyboard shortcut.

Use

After launching the command, the level or intensity of masking applied in the workspace will be increased. Design objects that do not fall under the scope of the currently applied filter will become more faded. Continue using this command to further decrease the display intensity of objects not belonging to the filtered set.

Tips

  1. Use of this command corresponds to sliding the Dimmed Objects slider to the left (decreasing its value). This slider can be found in the Mask and Dim Settings section on the View Options tab of the View Configuration panel.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。