Altium NEXUS Documentation

Add

Created: May 11, 2019 | Updated: May 11, 2019
現在、バージョン 2.1 をご覧頂いています。 最新情報については、バージョン 4 の をご覧ください。

Parent page: UnifiedComponent Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: ObjectKind=Component

Summary

This command is used to add a single, new component definition to the active Component Library document.

Access

This command can be accessed from the Component Library Editor when configured in Batch Editor mode by:

  • Choosing the Edit » Add Component command from the main menus.
  • Right-clicking anywhere within the lower grid region, and choosing the Add Component command from the context menu.
If the Component Library Editor is currently in Single Component Editor mode, switch to the Batch Editor mode using the Tools » Switch to Batch Editor command.

Use

After launching the command, a new component definition will be added to the component definitions grid, at the bottom of the current list of component definitions.

Tips

  1. A new component definition can also be added by clicking the Add Component control, located below the definitions region.
  2. The new component definition's FolderPath and Item ID will adhere to defined options for the Default Folder and Component Naming, specified for the Component Library document through the Document Options dialog. If the Component Library document references a Component Template, these settings will come from that template (if defined).
  3. The software will automatically assign the next available unique ID, based on the Component Naming scheme applied, having scanned the entire server and identifiers of existing Items.
  4. The component definition will contain any default values for parameters defined in any referenced component template.


Applied Parameters: ObjectKind=Components

Summary

This command is used to add multiple new component definitions to the active Component Library document. In concert with multi-cell editing support, and copy/paste features, you can quickly build an impressive array of component definitions in quick time.

Access

This command can be accessed from the Component Library Editor, when configured in Batch Editor mode, by:

  • Choosing the Edit » Operations » Add Components command from the main menus.
  • Right-clicking anywhere within the lower grid region, and choosing the Operations » Add Components command from the context menu.
If the Component Library Editor is currently in Single Component Editor mode, switch to the Batch Editor mode using the Tools » Switch to Batch Editor command.

Use

After launching the command, the Add Components dialog will appear. Enter the number of components you wish to add and click OK - new component definitions for the specified number of components will be added to the component definitions grid, at the bottom of the current list of component definitions.

Tips

  1. Be advised that entering too large a number in the Add Components dialog can have an impact on performance, and may 'tie' the software for a considerable time while the request is processed.
  2. The new component definitions' FolderPath and Item ID will adhere to defined options for the Default Folder and Component Naming, specified for the Component Library document through the Document Options dialog. If the Component Library document references a Component Template, these settings will come from that template (if defined).
  3. The software will automatically assign the next available unique ID, based on the Component Naming scheme applied, having scanned the entire server and identifiers of existing Items.
  4. The component definitions will contain any default values for parameters defined in any referenced component template.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: